Digging out the local machine's IP address

Does anyone know of someway to
determine the IP address of the local
computer through a locally running java app?
(in case you are wondering, it is data necessary
to do a DB lookup to retrieve a printer config. for a specific
client workstation)
thanks,
...Ben

I have tried this and get this exception:
C:\My Documents\Code\testProperties.java:13: unreported exception java.net.UnknownHostException; must be caught or declared to be thrown
          String ipAddr = InetAddress.getLocalHost().getHostAddress();
Am severely confused...
Any help would be appreciated
Regards
Paul

Similar Messages

  • Getting the IP address of the local machine.

    Hello All,
    We are deploying an application using 10g AS(LINUX).We have to capture the IP address of the
    user machine, in which the browser is running.(10g forms,9i db)
    WEB_UTIL is not configured and we are using java importer for the purpose.
    I am a 'very' newbie in java.I searched a lot in the net and got some solutions but all providing the Ip address of the AS machine.
    Can anyone give a java program to get the IP address of the local machine?Or a link...
    Thanks in advance
    Jeneesh

    Give a glance to these documents. may be coukd help you
    http://forum.java.sun.com/thread.jspa?threadID=245711
    Java 6.0 includes an API to get the MAC address of any attached network interface:
    http://java.sun.com/javase/6/docs/api/java/net/NetworkInterface.html#getHardwareAddress
    (idea for IP user: you can shell out, and use the 'who -m'?)
    Regards Jeneesh

  • CALL DOES NOT ROUTE OUT THE LOCAL GATEWAY

    Local calls will not route out the local Gateway of branch1 to the PSTN or from the PSTN back to branch1, however they will route out either CorpHQ or branch2 backup gateways. When I go into the route group configuration for branch1, and remove the backup gateways, I get a fast busy tone when I dial the local number. I know the MGCP Gateway at branch1 is functioning because when I dial 911 and run debug ISDN Q931, the call routes properly through branch1, so I have a call routing problem. I ran DNA and it came back as ROUTE THIS PATTERN and all of the number translations looked accurate, so I didn't have to check for any block patterns. I'm not getting any errors on the calling party phone display. When I deleted the route pattern for the branch1 site and forced it to use the global route pattern, I received a debug output on branch1. I do not know a debug command (such as debug voip dial-peer or debug ccsip messages) to use for an MGCP Gateway to see if the call is actually reaching the Gateway.
    I have checked the following:
    the route pattern configuration
    the translation pattern configuration
    the called party transformation pattern configuration
    the route list configuration to make sure the correct route group for branch1 was selected
    the route group configuration to make sure that the branch1 Gateway was first in the order of selected devices
    the route pattern configuration to make sure the correct route list for branch1 ist selected
    the Gateway configuration to make sure it's using the device pool for branch1 and to make sure the called party transformation CSS for the branch1 Gateway is applied
    the device pool configuration to make sure it's using the route group branch1
    Any assistance would be greatly appreciated
    Regards,
    Ron

    Hi Nishant:
    Please see the attachments for the Gateway pages
    The significant digits for inbound calls for all 3 gateways is '4'
    Please see the running-configs of the 3 gateways and the PSTN
    Please see the debugs for the INBOUND calls
    Many Thanks,
    Ron
    The following INBOUND call from the PSTN to 2065011001 is now working, however it is supposed to be routing through CorpHQ and is instead routing through Branch1. Please see 'DEBUG VOIP CCAPI INOUT' & 'DEBUG ISDN Q931'
    Branch1#
    ISDN Se0/0/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0x0096
            Cause i = 0x8290 - Normal call clearing
    //22/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
       (callID=0x16, digit_event=0x0, enable=FALSE, consume=FALSE)
    //22/5A001212800B/CCAPI/ccCallReportDigits:
       Enabled=TRUE, Call Id=22
    //22/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
       (vdbPtr=0x49E07FD4, callID=0x16, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)
    //22/5A001212800B/CCAPI/cc_api_call_report_digits_done:
       Enabled=TRUE, Disposition=0x0, Interface=0x49E07FD4, Call Id=22
    //22/5A001212800B/CCAPI/cc_api_call_report_digits_done:
       Call Entry(Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms))
    //22/5A001212800B/CCAPI/ccGenerateToneInfo:
       Stop Tone On Digit=FALSE, Tone=Null,
       Tone Direction=Network, Params=0x0, Call Id=22
    //23/5A001212800B/CCAPI/ccGetCallStatistics:
       Call Stats=0x4A5346FC, Call Id=23
    //22/5A001212800B/CCAPI/ccConferenceDestroy:
       Conference Id=0xC, Tag=0x0
    //22/xxxxxxxxxxxx/CCAPI/cc_api_bridge_drop_done:
       Conference Id=0xC, Source Interface=0x49E07FD4, Source Call Id=22,
       Destination Call Id=23, Disposition=0x0, Tag=0x0
    //23/xxxxxxxxxxxx/CCAPI/cc_api_bridge_drop_done:
       Conference Id=0xC, Source Interface=0x495BABA4, Source Call Id=23,
       Destination Call Id=22, Disposition=0x0, Tag=0x0
    //22/5A001212800B/CCAPI/cc_generic_bridge_done:
       Conference Id=0xC, Source Interface=0x495BABA4, Source Call Id=23,
       Destination Call Id=22, Disposition=0x0, Tag=0x0
    //22/5A001212800B/CCAPI/ccCallDisconnect:
       Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
    //22/5A001212800B/CCAPI/ccCallDisconnect:
       Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
    //22/5A001212800B/CCAPI/cc_api_get_transfer_info:
       Transfer Number Is Null
    //23/5A001212800B/CCAPI/ccCallDisconnect:
       Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
    //23/5A001212800B/CCAPI/ccCallDisconnect:
       Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
    //23/5A001212800B/CCAPI/cc_api_call_disconnect_done:
       Disposition=0, Interface=0x495BABA4, Tag=0x0, Call Id=23,
       Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
    //23/5A001212800B/CCAPI/cc_api_call_disconnect_done:
       Call Disconnect Event Sent
    //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
    :cc_free_feature_vsa freeing 4821DDE8
    //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
    vsacount in free is 1
    //22/5A001212800B/CCAPI/cc_api_call_disconnect_done:
       Disposition=0, Interface=0x49E07FD4, Tag=0x0, Call Id=22,
       Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
    //22/5A001212800B/CCAPI/cc_api_call_disconnect_done:
       Call Disconnect Event Sent
    //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
    :cc_free_feature_vsa freeing 4821DEC8
    //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
    vsacount in free is 0
    ISDN Se0/0/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x8096
    ISDN Se0/0/0:23 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x0096
    ISDN Se0/0/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0097
            Bearer Capability i = 0x8090A2
                    Standard = CCITT
                    Transfer Capability = Speech 
                    Transfer Mode = Circuit
                    Transfer Rate = 64 kbit/s
            Channel ID i = 0xA18381
                    Preferred, Channel 1
            Progress Ind i = 0x8183 - Origination address is non-ISDN 
            Display i = 'Seattle US Phone'
            Calling Party Number i = 0x4180, '2065015111'
                    Plan:ISDN, Type:Subscriber(local)
            Called Party Number i = 0xC1, '2065011001'
                    Plan:ISDN, Type:Subscriber(local)
    //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:
       Interface=0x49E07FD4, Interface Type=6, Destination=, Mode=0x9,
       Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
       Called Number=(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
       Subscriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=0, Call Count On=FALSE,
       Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=D000000002f5368f000000F580000097)
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    :cc_get_feature_vsa malloc success
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    cc_get_feature_vsa count is 1
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    :FEATURE_VSA attributes are: feature_name:0,feature_time:1210179280,feature_id:24
    //24/74820328800C/CCAPI/ccIFCallSetupRequestPrivate:
       SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
    //24/74820328800C/CCAPI/ccCallSetContext:
       Context=0x4A524790
    //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:
       Interface=0x495BABA4, Interface Type=9, Destination=0.0.0.0, Mode=0x9,
       Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
       Called Number=(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
       Subscriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=0, Call Count On=TRUE,
       Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=D000000002f5368f000000F580000097)
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    :cc_get_feature_vsa malloc success
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    cc_get_feature_vsa count is 2
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    :FEATURE_VSA attributes are: feature_name:0,feature_time:1210179056,feature_id:25
    //25/74820328800C/CCAPI/ccIFCallSetupRequestPrivate:
       SPI Call Setup Request Is Success; Interface Type=9, FlowMode=1
    //25/74820328800C/CCAPI/ccCallSetContext:
       Context=0x4A524580
    //25/74820328800C/CCAPI/cc_api_call_connected:
       Interface=0x495BABA4, Data Bitmask=0x0, Progress Indication=NULL(0),
       Connection Handle=0
    //25/74820328800C/CCAPI/cc_api_call_connected:
       Call Entry(Connected=TRUE, Responsed=TRUE, Retry Count=0)
    //24/74820328800C/CCAPI/cc_api_call_proceeding:
       Interface=0x49E07FD4, Progress Indication=NULL(0)
    //24/74820328800C/CCAPI/cc_api_call_connected:
       Interface=0x49E07FD4, Data Bitmask=0x1, Progress Indication=DESTINATION IS NON ISDN(2),
       Connection Handle=0
    //24/74820328800C/CCAPI/cc_api_call_connected:
       Call Entry(Connected=TRUE, Responsed=TRUE, Retry Count=0)
    //24/74820328800C/CCAPI/ccCallModify:
       Nominator=0x1000, Params=0x4A2E7368, Call Id=24
    //24/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
       (callID=0x18, digit_event=0x1, enable=TRUE, consume=FALSE)
    //24/74820328800C/CCAPI/ccCallReportDigits:
       Enabled=TRUE, Call Id=24
    //24/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
       (vdbPtr=0x49E07FD4, callID=0x18, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
    //24/74820328800C/CCAPI/cc_api_call_report_digits_done:
       Enabled=TRUE, Disposition=0x0, Interface=0x49E07FD4, Call Id=24
    //24/74820328800C/CCAPI/cc_api_call_report_digits_done:
       Call Entry(Initial Digit Timeout=15000(ms), Inter Digit Timeout=10000(ms))
    //24/xxxxxxxxxxxx/CCAPI/ccConferenceCreate:
       (confID=0x4A2E757C, callID1=0x18, callID2=0x19, tag=0x0)
    //24/xxxxxxxxxxxx/CCAPI/ccConferenceCreate:
       (confID=0x4A2E757C, callID1=0x18, gcid=0-0-0-0, tag=0x0)
    //25/xxxxxxxxxxxx/CCAPI/ccConferenceCreate:
       (confID=0x4A2E757C, callID2=0x19, gcid=0-0-0-0, tag=0x0)
    //24/74820328800C/CCAPI/ccConferenceCreate:
       Conference Id=0x4A2E757C, Call Id1=24, Call Id2=25, Tag=0x0
    //24/xxxxxxxxxxxx/CCAPI/cc_api_bridge_done:
       Conference Id=0xD, Source Interface=0x49E07FD4, Source Call Id=24,
       Destination Call Id=25, Disposition=0x0, Tag=0xFFFFFFFF
    //25/xxxxxxxxxxxx/CCAPI/cc_api_bridge_done:
       Conference Id=0xD, Source Interface=0x495BABA4, Source Call Id=25,
       Destination Call Id=24, Disposition=0x0, Tag=0x0
    //24/74820328800C/CCAPI/cc_generic_bridge_done:
       Conference Id=0xD, Source Interface=0x495BABA4, Source Call Id=25,
       Destination Call Id=24, Disposition=0x0, Tag=0x0
    //24/74820328800C/CCAPI/ccConferenceCreate:
       Call Entry(Conference Id=0xD, Destination Call Id=25)
    //25/74820328800C/CCAPI/ccConferenceCreate:
       Call Entry(Conference Id=0xD, Destination Call Id=24)
    //24/74820328800C/CCAPI/cc_api_caps_ind:
       Destination Interface=0x495BABA4, Destination Call Id=25, Source Call Id=24,
       Caps(Codec=0x1, Fax Rate=0x1, Vad=0x1,
       Modem=0x2, Codec Bytes=20, Signal Type=3)
    //24/74820328800C/CCAPI/cc_api_caps_ind:
       Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
       Playout Max=1000(ms), Fax Nom=300(ms))
    //25/74820328800C/CCAPI/cc_api_caps_ind:
       Destination Interface=0x49E07FD4, Destination Call Id=24, Source Call Id=25,
       Caps(Codec=0x4, Fax Rate=0x2, Vad=0x1,
       Modem=0x0, Codec Bytes=20, Signal Type=2)
    //25/74820328800C/CCAPI/cc_api_caps_ind:
       Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
       Playout Max=1000(ms), Fax Nom=300(ms))
    //25/74820328800C/CCAPI/cc_api_caps_ack:
       Destination Interface=0x49E07FD4, Destination Call Id=24, Source Call Id=25,
       Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Vad=OFF(0x1),
       Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=9314)
    //24/74820328800C/CCAPI/cc_api_caps_ack:
       Destination Interface=0x495BABA4, Destination Call Id=25, Source Call Id=24,
       Caps(Codec=g729r8(0x4), Fax Rate=FAX_RATE_VOICE(0x2), Vad=OFF(0x1),
       Modem=OFF(0x0), Codec Bytes=20, Signal Type=2, Seq Num Start=9314)
    //24/74820328800C/CCAPI/cc_api_call_modify_done:
       Result=0, Interface=0x49E07FD4, Call Id=24
    //24/74820328800C/CCAPI/cc_api_voice_mode_event:
       Call Id=24
    //24/74820328800C/CCAPI/cc_api_voice_mode_event:
       Call Entry(Context=0x4A524790)
    //24/74820328800C/CCAPI/cc_process_notify_bridge_done:
       Conference Id=0xD, Call Id1=24, Call Id2=25
    //24/74820328800C/CCAPI/ccSetDigitTimeouts:
       Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms)
    //24/74820328800C/CCAPI/ccSetDigitTimeouts:
       Call Entry(Inter Digit Timeout=4000(ms), Initial Digit Timeout=4000(ms))
    //24/74820328800C/CCAPI/ccRestartDigitTimeoutMsec:
       Digit Timeout=0, Call Id=24
    //24/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
       (callID=0x18, digit_event=0x1, enable=TRUE, consume=FALSE)
    //24/74820328800C/CCAPI/ccCallReportDigits:
       Enabled=TRUE, Call Id=24
    //24/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
       (vdbPtr=0x49E07FD4, callID=0x18, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
    //24/74820328800C/CCAPI/cc_api_call_report_digits_done:
       Enabled=TRUE, Disposition=0x0, Interface=0x49E07FD4, Call Id=24
    //24/74820328800C/CCAPI/cc_api_call_report_digits_done:
       Call Entry(Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms))
    ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8097
            Channel ID i = 0xA98381
                    Exclusive, Channel 1
    //24/74820328800C/CCAPI/ccCallModify:
       Nominator=0x1000, Params=0x4A2E6E68, Call Id=24
    //24/74820328800C/CCAPI/cc_api_call_modify_done:
       Result=0, Interface=0x49E07FD4, Call Id=24
    ISDN Se0/0/0:23 Q931: TX -> ALERTING pd = 8  callref = 0x8097
            Progress Ind i = 0x8088 - In-band info or appropriate now available
    //24/74820328800C/CCAPI/ccGenerateToneInfo:
       Stop Tone On Digit=FALSE, Tone=Ring Back,
       Tone Direction=Network, Params=0x0, Call Id=24
    //24/74820328800C/CCAPI/cc_handle_inter_digit_timer:
       Generate inter-digit timeout CC_EV_CALL_DIGIT_END event
    The following INBOUND call from the PSTN to 5126022001 fails and is supposed to be routing through Branch1 and is instead routing through CorpHQ. Please see 'DEBUG VOIP CCAPI INOUT'
    CorpHQ#
    //-1/A31ADF52800B/CCAPI/cc_api_display_ie_subfields:
       cc_api_call_setup_ind_common:
       cisco-username=
       ----- ccCallInfo IE subfields -----
       cisco-ani=5126026222
       cisco-anitype=4
       cisco-aniplan=1
       cisco-anipi=0
       cisco-anisi=0
       dest=5126022001
       cisco-desttype=4
       cisco-destplan=1
       cisco-rdie=FFFFFFFF
       cisco-rdn=
       cisco-lastrdn=
       cisco-rdntype=-1
       cisco-rdnplan=-1
       cisco-rdnpi=-1
       cisco-rdnsi=-1
       cisco-redirectreason=-1   fwd_final_type =0
       final_redirectNumber =
       hunt_group_timeout =0
    //-1/A31ADF52800B/CCAPI/cc_api_call_setup_ind_common:
       Interface=0x49F42894, Call Info(
       Calling Number=5126026222,(Calling Name=)(TON=Subscriber, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),
       Called Number=5126022001(TON=Subscriber, NPI=ISDN),
       Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,
       Incoming Dial-peer=1, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,
       Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
    //-1/A31ADF52800B/CCAPI/ccCheckClipClir:
       In: Calling Number=5126026222(TON=Subscriber, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)
    //-1/A31ADF52800B/CCAPI/ccCheckClipClir:
       Out: Calling Number=5126026222(TON=Subscriber, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    :cc_get_feature_vsa malloc success
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    cc_get_feature_vsa count is 1
    //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
    :FEATURE_VSA attributes are: feature_name:0,feature_time:1241383960,feature_id:13
    //13/A31ADF52800B/CCAPI/cc_api_call_setup_ind_common:
       Set Up Event Sent;
       Call Info(Calling Number=5126026222(TON=Subscriber, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),
       Called Number=5126022001(TON=Subscriber, NPI=ISDN))
    //13/A31ADF52800B/CCAPI/cc_process_call_setup_ind:
       Event=0x497D0010
    //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
       Try with the demoted called number 5126022001
    //13/A31ADF52800B/CCAPI/ccCallSetContext:
       Context=0x4A131A54
    //13/A31ADF52800B/CCAPI/cc_process_call_setup_ind:
       >>>>CCAPI handed cid 13 with tag 1 to app "_ManagedAppProcess_Default"
    //13/A31ADF52800B/CCAPI/ccCallProceeding:
       Progress Indication=NULL(0)
    //13/A31ADF52800B/CCAPI/ccCallDisconnect:
       Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
    //13/A31ADF52800B/CCAPI/ccCallDisconnect:
       Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)
    //13/A31ADF52800B/CCAPI/cc_api_get_transfer_info:
       Transfer Number Is Null
    //13/A31ADF52800B/CCAPI/cc_api_call_disconnect_done:
       Disposition=0, Interface=0x49F42894, Tag=0x0, Call Id=13,
       Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)
    //13/A31ADF52800B/CCAPI/cc_api_call_disconnect_done:
       Call Disconnect Event Sent
    //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
    :cc_free_feature_vsa freeing 49FE0410
    //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
    vsacount in free is 0
    PSTN#sh run
    Building configuration...
    Current configuration : 13975 bytes
    ! No configuration change since last restart
    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    hostname PSTN
    boot-start-marker
    boot-end-marker
    card type e1 0 0
    card type t1 0 1
    logging message-counter syslog
    no aaa new-model
    clock timezone EST -5
    clock summer-time EST recurring
    network-clock-participate wic 0
    network-clock-participate wic 1
    no network-clock-participate aim 0
    dot11 syslog
    ip source-route
    ip cef
    no ip domain lookup
    ip domain name att.com
    ip name-server 177.1.100.110
    ip multicast-routing
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-ni
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    redirect ip2ip
    fax protocol cisco
    sip
      bind control source-interface Loopback10
      bind media source-interface Loopback10
      header-passing
    voice translation-rule 101
    rule 1 /^\+.*/ //
    rule 2 /^501.*/ //
    rule 3 /^1206.*/ //
    rule 4 /^00.*/ //
    rule 5 /^0011.*/ //
    rule 6 /^206/ /1206/
    rule 7 /^1512.*/ /\0/
    rule 8 /^011\(.*\)/ /\1/
    voice translation-rule 102
    rule 1 /^1\(2065015111\)$/ /\1/ type any subscriber plan any isdn
    rule 2 /^1\(2065015555\)$/ /\1/ type any subscriber plan any isdn
    rule 3 /^1\(2065015151\)$/ /\1/ type any subscriber plan any isdn
    rule 4 /^1\(5126026222\)$/ /\1/ type any national plan any isdn
    rule 5 /^31670357575$/ /&/ type any international plan any isdn
    rule 6 /^31207037333$/ /&/ type any international plan any isdn
    rule 7 /^31107047444$/ /&/ type any international plan any isdn
    rule 8 /^911$/ /&/ type any unknown plan any unknown
    rule 9 /^15126022.../ /&/ type any unknown plan any unknown
    rule 10 /^31207033.../ /&/ type any unknown plan any unknown
    rule 11 /^....$/ /&/ type any unknown plan any unknown
    voice translation-rule 103
    rule 1 /^206.*/ /&/ type any subscriber plan any isdn
    rule 2 /^1/ // type any national plan any isdn
    rule 3 /^00/ // type any international plan any isdn
    voice translation-rule 201
    rule 1 /^\+.*/ //
    rule 2 /^602.*/ //
    rule 3 /^1512.*/ //
    rule 4 /^00.*/ //
    rule 5 /^0011.*/ //
    rule 6 /^512/ /1&/
    rule 7 /^1206.*/ /&/
    rule 8 /^011\(31.*\)/ /\1/
    voice translation-rule 202
    rule 1 /^1\(5126026222\)$/ /\1/ type any subscriber plan any isdn
    rule 2 /^1\(2065015555\)$/ /\1/ type any national plan any isdn
    rule 3 /^1\(2065015151\)$/ /\1/ type any national plan any isdn
    rule 4 /^1\(2065015111\)$/ /\1/ type any national plan any isdn
    rule 5 /^31670357575$/ /&/ type any international plan any isdn
    rule 6 /^31207037333$/ /&/ type any international plan any isdn
    rule 7 /^31107047444$/ /&/ type any international plan any isdn
    rule 8 /^911$/ /&/ type any unknown plan any unknown
    rule 9 /^12065011.../ /&/ type any unknown plan any unknown
    rule 10 /^31207033.../ /&/ type any unknown plan any unknown
    rule 11 /^....$/ /&/ type any unknown plan any unknown
    voice translation-rule 203
    rule 1 /^512.*/ /&/ type any subscriber plan any isdn
    rule 2 /^1/ // type any national plan any isdn
    rule 3 /^00/ // type any international plan any isdn
    voice translation-rule 301
    rule 1 /^\+.*/ //
    rule 2 /^20.*/ //
    rule 3 /^0\([1-8].*\)/ /31\1/
    rule 4 /^011/ //
    rule 5 /^0031/ //
    rule 6 /^703..../ /3120&/
    rule 7 /^00\(1.*\)/ /\1/
    voice translation-rule 302
    rule 1 /^31207037333$/ /7037333/ type any subscriber plan any isdn
    rule 2 /^7033\(...\)$/ /0207033\1/
    rule 3 /^911$/ /112/ type any unknown plan any unknown
    rule 4 /^31\(670357575\)$/ /0\1/ type any national plan any isdn
    rule 5 /^31\(107047444\)$/ /0\1/ type any national plan any isdn
    rule 6 /^12065015555$/ /&/ type any international plan any isdn
    rule 7 /^12065015151$/ /&/ type any international plan any isdn
    rule 8 /^12065015111$/ /&/ type any international plan any isdn
    rule 9 /^15126026222$/ /&/ type any international plan any isdn
    rule 10 /^12065011...$/ /&/ type any unknown plan any unknown
    rule 11 /^15126022...$/ /&/ type any unknown plan any unknown
    rule 12 /^....$/ /&/ type any unknown plan any unknown
    voice translation-rule 303
    rule 1 /^703.*/ /&/ type any subscriber plan any isdn
    rule 2 /^010/ // type any national plan any isdn
    rule 3 /^1/ // type any international plan any isdn
    voice translation-rule 1000
    rule 1 /.*\(1...$\)/ /206501\1/
    rule 2 /.*\(2...$\)/ /512602\1/
    rule 3 /.*\(45..$\)/ /020757\1/
    voice translation-rule 1001
    rule 1 /^1206...5...$/ /+&/
    rule 2 /^1512...6...$/ /+&/
    rule 3 /^31.0...7...$/ /+&/
    voice translation-profile 1-HQ-Change_DNIS-Check_ANI
    translate called 101
    voice translation-profile 1-HQ-Proper_Types
    translate calling 102
    translate called 103
    voice translation-profile 2-BR1-Change_DNIS-Check_ANI
    translate called 201
    voice translation-profile 2-BR1-Proper_Types
    translate calling 202
    translate called 203
    voice translation-profile 3-BR2-Change_DNIS-Check_ANI
    translate called 301
    voice translation-profile 3-BR2-Proper_Types
    translate calling 302
    translate called 303
    voice translation-profile SIP-NORMALIZE-DNIS-ANI
    translate calling 1001
    translate called 1000
    voice-card 0
    dspfarm
    archive
    log config
      hidekeys
    controller E1 0/0/0
    clock source internal
    pri-group timeslots 1-3,16
    description == Voice Circuit to Branch2
    controller T1 0/1/0
    clock source internal
    cablelength long 0db
    pri-group timeslots 1-3,24
    description == Voice Circuit to CorpHQ
    controller T1 0/1/1
    clock source internal
    cablelength long 0db
    pri-group timeslots 1-3,24
    description == Voice Circuit to Branch1
    interface Loopback0
    ip address 177.1.254.254 255.255.255.255
    interface Loopback10
    ip address 177.1.254.250 255.255.255.255
    interface Loopback11
    ip address 177.1.254.251 255.255.255.255
    interface FastEthernet0/0
    description ==TO INTERNET==
    ip address 192.168.1.150 255.255.255.0
    duplex auto
    speed auto
    interface FastEthernet0/1
    description === To HQ
    ip address 177.1.19.1 255.255.255.0
    duplex auto
    speed auto
    interface Serial0/0/0:15
    description == PRI Circuit to R3-BR2
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn negotiate-bchan resend-setup
    no isdn outgoing ie network-facility
    isdn outgoing display-ie
    no cdp enable
    interface Serial0/1/0:23
    description == PRI Circuit to R1-HQ
    no ip address
    encapsulation hdlc
    isdn switch-type primary-5ess
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn negotiate-bchan
    isdn outgoing display-ie
    no cdp enable
    interface Serial0/1/1:23
    description == PRI Circuit to R2-BR1
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn supp-service name calling
    isdn negotiate-bchan resend-setup
    isdn outgoing ie network-facility
    no cdp enable
    router ospf 1
    log-adjacency-changes
    network 0.0.0.0 255.255.255.255 area 0
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:
    control-plane
    voice-port 0/0/0:15
    translation-profile incoming 3-BR2-Change_DNIS-Check_ANI
    description == Voice PRI to Branch2
    voice-port 0/1/0:23
    translation-profile incoming 1-HQ-Change_DNIS-Check_ANI
    description == Voice PRI to CorpHQ
    voice-port 0/1/1:23
    translation-profile incoming 2-BR1-Change_DNIS-Check_ANI
    description == Voice PRI to Branch1
    dial-peer voice 1 pots
    description == All inbound calls from HQ BR1 BR2 into PSTN
    incoming called-number .
    direct-inward-dial
    dial-peer voice 101 pots
    description == Subscriber Calls from PSTN into CorpHQ
    translation-profile outgoing 1-HQ-Proper_Types
    preference 1
    destination-pattern ^2065011...$
    direct-inward-dial
    port 0/1/0:23
    forward-digits 10
    dial-peer voice 102 pots
    description == National Calls from PSTN into CorpHQ
    translation-profile outgoing 1-HQ-Proper_Types
    preference 1
    destination-pattern ^12065011...$
    direct-inward-dial
    port 0/1/0:23
    forward-digits 10
    dial-peer voice 103 pots
    description == International Calls into CorpHQ from PSTN Coming from NL Ph
    translation-profile outgoing 1-HQ-Proper_Types
    preference 1
    destination-pattern ^0012065011...$
    direct-inward-dial
    port 0/1/0:23
    forward-digits 10
    dial-peer voice 104 pots
    description == + Calls into CorpHQ from PSTN Coming from Mobiles
    translation-profile outgoing 1-HQ-Proper_Types
    preference 1
    destination-pattern +12065011...$
    direct-inward-dial
    port 0/1/0:23
    forward-digits 10
    dial-peer voice 201 pots
    description == Subscriber Calls from PSTN into Branch1
    translation-profile outgoing 2-BR1-Proper_Types
    preference 1
    destination-pattern ^5126022...$
    direct-inward-dial
    port 0/1/1:23
    forward-digits 10
    dial-peer voice 202 pots
    description == National Calls from PSTN into Branch1
    translation-profile outgoing 2-BR1-Proper_Types
    preference 1
    destination-pattern ^15126022...$
    direct-inward-dial
    port 0/1/1:23
    forward-digits 10
    dial-peer voice 203 pots
    description == International Calls into Branch1 from PSTN Coming from NL Ph
    translation-profile outgoing 2-BR1-Proper_Types
    preference 1
    destination-pattern ^0015126022...$
    direct-inward-dial
    port 0/1/1:23
    forward-digits 10
    dial-peer voice 204 pots
    description == + Calls into Branch1 from PSTN Coming from Mobiles
    translation-profile outgoing 2-BR1-Proper_Types
    preference 1
    destination-pattern +15126022...$
    direct-inward-dial
    port 0/1/1:23
    forward-digits 10
    dial-peer voice 301 pots
    description == Subscriber Calls from PSTN into Branch2
    translation-profile outgoing 3-BR2-Proper_Types
    destination-pattern ^7033...$
    direct-inward-dial
    port 0/0/0:15
    forward-digits 7
    dial-peer voice 302 pots
    description == National Calls from PSTN into Branch2
    translation-profile outgoing 3-BR2-Proper_Types
    destination-pattern ^0207033...$
    direct-inward-dial
    port 0/0/0:15
    forward-digits 10
    dial-peer voice 303 pots
    description == International Calls into Branch2 from PSTN Coming from US Ph
    translation-profile outgoing 3-BR2-Proper_Types
    destination-pattern ^01131207033...$
    direct-inward-dial
    port 0/0/0:15
    forward-digits 9
    prefix 0
    dial-peer voice 304 pots
    description == International Calls into Branch2 from PSTN Coming from US Ph
    translation-profile outgoing 3-BR2-Proper_Types
    destination-pattern ^31207033...$
    direct-inward-dial
    port 0/0/0:15
    forward-digits 9
    prefix 0
    dial-peer voice 305 pots
    description == + Calls into Branch2 from PSTN Coming from Mobiles
    translation-profile outgoing 3-BR2-Proper_Types
    destination-pattern +31207033...$
    direct-inward-dial
    port 0/0/0:15
    forward-digits 9
    prefix 0
    dial-peer voice 1000 voip
    description == Calls into AT&T SIP ITSP for VC Week1 Lab1
    rtp payload-type nse 99
    rtp payload-type nte 100
    voice-class sip localhost dns:sip1.att.com
    session protocol sipv2
    incoming called-number .
    dtmf-relay rtp-nte
    codec g711ulaw
    dial-peer voice 5000 voip
    service aa
    destination-pattern A5000
    session target ipv4:177.1.254.254
    incoming called-number A5000
    dtmf-relay h245-alphanumeric
    codec g711ulaw
    no vad
    num-exp 1888....... 911
    num-exp 1900....... 911
    num-exp 1976....... 911
    num-exp 1777....... 911
    num-exp 1444....... 911
    num-exp 0800....... 911
    num-exp 0900....... 911
    sip-ua
    telephony-service
    no auto-reg-ephone
    max-ephones 1
    max-dn 10
    ip source-address 177.1.254.254 port 2000
    caller-id block code *67
    system message You WILL PASS this Exam!
    voicemail A5000
    max-conferences 8 gain -6
    call-forward pattern .T
    dn-webedit
    transfer-system full-consult
    transfer-pattern .T
    create cnf-files version-stamp 7960 Sep 01 2012 15:29:37
    ephone-dn  1  dual-line
    number 12065015111 secondary +12065015111
    label Seattle, US +1 206 501 5111
    description INE PSTN Phone
    name Seattle US Phone
    ephone-dn  2  dual-line
    number 15126026222 secondary +15126026222
    label Austin, US +1 512 602 6222
    name Austin TX Phone
    ephone-dn  3  dual-line
    number 31207037333 secondary +31207037333
    label Amsterdam, NL +31 20 703 73 33
    name Amsterdam NL Phone
    ephone-dn  4  dual-line
    number 12065015555 secondary +12065015555
    label Hurley Mobile +1 206 501 5555
    name Hurley's Mobile
    call-forward busy A5000
    call-forward noan A5000 timeout 16
    ephone-dn  5  dual-line
    number 12065015151 secondary +12065015151
    label Hurley's Home +1 206 501 5151
    name Hurley's Home
    call-forward busy A5000
    call-forward noan A5000 timeout 12
    ephone-dn  6  dual-line
    number 31670357575 secondary +31670357575
    label Sawyer's Mobile +31 6 70357575
    name Sawyer's Mobile
    call-forward busy A5000
    call-forward noan A5000 timeout 16
    ephone-dn  7  dual-line
    number 911 secondary 112
    label US/EU Emer/FreePhone/Prem
    name Emergency Services
    ephone-dn  8  dual-line
    number 15126026262 secondary +15126026262
    label BLinus Mobile +1 512 602 6262
    name Benjamin Linus Mobile
    call-forward busy A5000
    call-forward noan A5000 timeout 16
    ephone-dn  9  dual-line
    number 31207037373 secondary +31207037373
    label DHume Home +31 20 703 73 73
    name Desmond Hume Home
    call-forward busy A5000
    call-forward noan A5000 timeout 16
    ephone-dn  10  dual-line
    number 31107047444 secondary +31107047444
    label Rotterdam, NL +31 10 704 74 44
    name Rotterdam NL Phone
    ephone  1
    device-security-mode none
    mac-address A456.3040.0DAA
    type 7975
    button  1:1 2:2 3:3 4:10
    button  5:6 6o7,8,5,4
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    no login
    line vty 5 15
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    no login
    scheduler allocate 20000 1000
    ntp source Loopback0
    ntp master 10
    ntp server 64.90.182.55
    end
    CorpHQ#sh run
    Building configuration...
    Current configuration : 6353 bytes
    ! No configuration change since last restart
    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    hostname CorpHQ
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    no aaa new-model
    clock timezone PST -8
    clock summer-time PDT recurring
    network-clock-participate wic 0
    network-clock-select 1 T1 0/0/0
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp excluded-address 177.1.11.1 177.1.11.14
    ip dhcp excluded-address 177.1.11.21 177.1.11.254
    ip dhcp excluded-address 177.2.11.1 177.2.11.14
    ip dhcp excluded-address 177.2.11.21 177.2.11.254
    ip dhcp pool CorpHQ-Phones
       network 177.1.11.0 255.255.255.0
       option 150 ip 177.1.10.10 177.1.10.20
       default-router 177.1.11.1
       dns-server 177.1.100.110
    ip dhcp pool Branch1-Phones
       network 177.2.11.0 255.255.255.0
       option 150 ip 177.1.10.10 177.1.10.20
       default-router 177.2.11.1
       dns-server 177.1.100.110
    no ip domain lookup
    ip multicast-routing
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-ni
    voice service voip
    allow-connections h323 to h323
    fax protocol cisco
    sip
      bind control source-interface Loopback0
      bind media source-interface Loopback0
      no update-callerid
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    voice translation-rule 1
    rule 1 // // type any subscriber plan any isdn
    voice translation-rule 2
    rule 1 // // type any national plan any isdn
    voice translation-rule 3
    rule 1 // // type any international plan any isdn
    voice translation-rule 10
    rule 1 /^[2-9].........$/ /9&/
    rule 2 /^1[2-9].........$/ /9&/
    rule 3 /^011/ /9&/
    voice translation-profile MakeInternational
    translate called 3
    voice translation-profile MakeNational
    translate called 2
    voice translation-profile MakeSubscriber
    translate called 1
    voice translation-profile Prefix9_InFrom_CUCM
    translate called 10
    voice-card 0
    dsp services dspfarm
    archive
    log config
      hidekeys
    controller T1 0/0/0
    pri-group timeslots 1-3,24
    description == Voice Circuit to PSTN
    interface Loopback0
    ip address 177.1.254.1 255.255.255.255
    ip pim dense-mode
    interface FastEthernet0/0
    description == To CorpHQ-Switch
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/0.10
    description == Server VLAN
    encapsulation dot1Q 10
    ip address 177.1.10.1 255.255.255.0
    ip pim dense-mode
    interface FastEthernet0/0.11
    description == Voice VLAN
    encapsulation dot1Q 11
    ip address 177.1.11.1 255.255.255.0
    ip helper-address 177.1.10.10
    ip nbar protocol-discovery
    ip pim dense-mode
    interface FastEthernet0/0.12
    description == Data VLAN
    encapsulation dot1Q 12
    ip address 177.1.12.1 255.255.255.0
    interface FastEthernet0/0.13
    description == PSTN PHONE VLAN
    encapsulation dot1Q 13
    ip address 177.1.13.1 255.255.255.0
    interface FastEthernet0/1
    description === To PSTN
    ip address 177.1.19.254 255.255.255.0
    duplex auto
    speed auto
    interface Serial0/0/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/1/0
    description == Frame-Relay Circuit to WAN
    no ip address
    encapsulation frame-relay
    fair-queue 64 256 36
    cdp enable
    frame-relay lmi-type ansi
    ip rsvp bandwidth
    interface Serial0/1/0.1 point-to-point
    description == FR To BR1
    bandwidth 384
    ip address 177.0.101.1 255.255.255.0
    ip pim dense-mode
    snmp trap link-status
    frame-relay interface-dlci 101  
    ip rsvp bandwidth 136
    interface Serial0/1/0.2 point-to-point
    description == FR To BR2
    ip address 177.0.201.1 255.255.255.0
    snmp trap link-status
    frame-relay interface-dlci 102  
    ip rsvp bandwidth 136
    router ospf 1
    log-adjacency-changes
    network 0.0.0.0 255.255.255.255 area 0
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 177.1.19.1
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.10
    no ip http server
    no ip http secure-server
    control-plane
    voice-port 0/0/0:23
    voice-port 0/3/0
    voice-port 0/3/1
    ccm-manager music-on-hold
    sccp local Loopback0
    sccp ccm 177.1.10.10 identifier 1 priority 1 version 5.0.1
    sccp ccm 177.1.10.20 identifier 2 priority 2 version 5.0.1
    sccp ccm 177.1.254.3 identifier 3 priority 3 version 5.0.1
    sccp
    sccp ccm group 1
    bind interface Loopback0
    associate ccm 2 priority 1
    associate ccm 1 priority 2
    associate ccm 3 priority 3
    associate profile 1 register CorpHQ-729-MTP
    associate profile 2 register CorpHQ-711-MTP
    associate profile 3 register CorpHQ-HW-Xcode
    dspfarm profile 3 transcode 
    codec g711ulaw
    codec g711alaw
    codec g729ar8
    codec g729abr8
    codec g729r8
    codec g729br8
    codec ilbc
    maximum sessions 2
    associate application SCCP
    dspfarm profile 1 mtp 
    codec g729ar8
    codec g729r8
    rsvp
    maximum sessions software 10
    associate application SCCP
    dspfarm profile 2 mtp 
    codec g711ulaw
    rsvp
    maximum sessions software 10
    associate application SCCP
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    dial-peer voice 10 pots
    translation-profile outgoing MakeSubscriber
    destination-pattern 911
    no digit-strip
    port 0/0/0:23
    dial-peer voice 11 pots
    translation-profile outgoing MakeSubscriber
    destination-pattern 9[2-9]..[2-9]......$
    port 0/0/0:23
    dial-peer voice 12 pots
    translation-profile outgoing MakeNational
    destination-pattern 91[2-9]..[2-9]......$
    port 0/0/0:23
    forward-digits 11
    dial-peer voice 13 pots
    translation-profile outgoing MakeInternational
    destination-pattern 9011T
    port 0/0/0:23
    prefix 011
    dial-peer voice 100 voip
    description == Inbound/Outbound SIP PSTN GW From/To CUCM Pub
    translation-profile incoming Prefix9_InFrom_CUCM
    destination-pattern ^2065011...$
    voice-class codec 1
    session protocol sipv2
    session target ipv4:177.1.10.10
    incoming called-number .
    ip qos dscp cs3 signaling
    dial-peer hunt 1
    sip-ua
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    no login
    line vty 5 15
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    no login
    scheduler allocate 20000 1000
    ntp source Loopback0
    ntp master 2
    ntp server 177.1.254.254
    end
    Branch1#sh run
    Building configuration...
    Current configuration : 3838 bytes
    ! Last configuration change at 01:19:02 CDT Thu Oct 10 2013
    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    hostname Branch1
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    no aaa new-model
    clock timezone CST -6
    clock summer-time CDT recurring
    network-clock-participate wic 0
    network-clock-select 1 T1 0/0/0
    dot11 syslog
    ip source-route
    ip cef
    ip multicast-routing
    no ipv6 cef
    ntp update-calendar
    ntp server 177.1.254.1
    multilink bundle-name authenticated
    isdn switch-type primary-ni
    voice-card 0
    dsp services dspfarm
    archive
    log config
      hidekeys
    controller T1 0/0/0
    pri-group timeslots 1-3,24 service mgcp
    interface Loopback0
    ip address 177.1.254.2 255.255.255.255
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/0.11
    description == Voice VLAN
    encapsulation dot1Q 11
    ip address 177.2.11.1 255.255.255.0
    ip helper-address 177.1.254.1
    ip pim dense-mode
    interface FastEthernet0/0.12
    description == Data VLAN
    encapsulation dot1Q 12
    ip address 177.2.12.1 255.255.255.0
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    interface Serial0/0/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn incoming-voice voice
    isdn supp-service name calling
    isdn bind-l3 ccm-manager
    isdn outgoing ie facility
    isdn outgoing display-ie
    isdn outgoing ie redirecting-number
    no cdp enable
    interface Serial0/1/0
    description == Frame-Relay Circuit to WAN
    no ip address
    encapsulation frame-relay
    fair-queue 64 256 37
    cdp enable
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    ip rsvp bandwidth
    interface Serial0/1/0.1 point-to-point
    description == FR To HQ
    ip address 177.0.101.2 255.255.255.0
    ip pim dense-mode
    snmp trap link-status
    frame-relay interface-dlci 101  
    ip rsvp bandwidth 136
    interface Serial0/1/1
    no ip address
    shutdown
    clock rate 2000000
    router ospf 1
    log-adjacency-changes
    network 0.0.0.0 255.255.255.255 area 0
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    control-plane
    voice-port 0/0/0:23
    ccm-manager fallback-mgcp
    ccm-manager redundant-host 177.1.10.10
    ccm-manager mgcp
    no ccm-manager fax protocol cisco
    ccm-manager music-on-hold
    mgcp
    mgcp call-agent 177.1.10.20 service-type mgcp version 0.1
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp fax t38 ecm
    mgcp bind control source-interface Loopback0
    mgcp bind media source-interface Loopback0
    mgcp profile default
    sccp local Loopback0
    sccp ccm 177.1.254.3 identifier 3 priority 3 version 5.0.1
    sccp ccm 177.1.10.10 identifier 1 priority 1 version 5.0.1
    sccp ccm 177.1.10.20 identifier 2 priority 2 version 5.0.1
    sccp
    sccp ccm group 1
    bind interface Loopback0
    associate ccm 2 priority 1
    associate ccm 1 priority 2
    associate ccm 3 priority 3
    associate profile 3 register Br1-HW-Xcode
    associate profile 1 register Br1-729-MTP
    associate profile 2 register Br1-711-MTP
    dspfarm profile 3 transcode 
    codec g711ulaw
    codec g711alaw
    codec g729ar8
    codec g729abr8
    codec g729r8
    codec g729br8
    maximum sessions 2
    associate application SCCP
    dspfarm profile 1 mtp 
    codec g729ar8
    codec g729r8
    rsvp
    maximum sessions software 10
    associate application SCCP
    dspfarm profile 2 mtp 
    codec g711ulaw
    rsvp
    maximum sessions software 10
    associate application SCCP
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous level 0 limit 20
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    no login
    line vty 5 15
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    no login
    scheduler allocate 20000 1000
    end
    Branch2#sh run
    Building configuration...
    Current configuration : 5789 bytes
    ! No configuration change since last restart
    version 12.4
    no service pad
    no service timestamps debug uptime
    no service timestamps log uptime
    no service password-encryption
    hostname Branch2
    boot-start-marker
    boot system flash:c2800nm-advipservicesk9-mz.124-24.T7.bin
    boot system flash:
    boot-end-marker
    card type e1 0 0
    logging message-counter syslog
    no aaa new-model
    clock timezone CEST 1
    clock summer-time CEDT recurring
    network-clock-participate wic 0
    no network-clock-participate aim 0
    dot11 syslog
    ip source-route
    ip cef
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    no supplementary-service h225-notify cid-update
    fax protocol cisco
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    voice class custom-cptone JOIN-TONE
    dualtone conference
      frequency 300 3600
      cadence 150 100 500
    voice class custom-cptone LEAVE-TONE
    dualtone conference
      frequency 300 3600
      cadence 500 100 150
    voice translation-rule 1
    rule 1 /^7033...$/ /020&/
    voice translation-rule 10
    rule 1 /^0/ /0&/
    voice translation-rule 200
    rule 1 /^206501...$/ /1&/
    voice translation-profile 7DigitDNIS-to-10Digit
    translate called 1
    voice translation-profile Prefix0_InFrom_CUCM
    translate called 10
    voice translation-profile Prefix1-toCorpHQ-ANI
    translate calling 200
    voice-card 0
    dsp services dspfarm
    archive
    log config
      hidekeys
    controller E1 0/0/0
    pri-group timeslots 1-3,16
    description == Voice Circuit to PSTN
    controller E1 0/0/1
    interface Loopback0
    ip address 177.1.254.3 255.255.255.255
    h323-gateway voip bind srcaddr 177.1.254.3
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/0.11
    encapsulation dot1Q 11
    ip address 177.3.11.1 255.255.255.0
    ip helper-address 177.1.10.10
    interface FastEthernet0/0.12
    encapsulation dot1Q 12
    ip address 177.3.12.1 255.255.255.0
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    interface Serial0/0/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    isdn bchan-number-order ascending
    no cdp enable
    interface Serial0/1/0
    description == Frame-Relay Circuit to WAN
    no ip address
    encapsulation frame-relay
    fair-queue 64 256 37
    cdp enable
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    ip rsvp bandwidth
    interface Serial0/1/0.1 point-to-point
    description == FR To HQ
    ip address 177.0.201.2 255.255.255.0
    snmp trap link-status
    frame-relay interface-dlci 102  
    ip rsvp bandwidth 136
    interface Serial0/1/1
    no ip address
    shutdown
    clock rate 2000000
    interface Service-Engine1/0
    no ip address
    shutdown
    router ospf 1
    log-adjacency-changes
    network 0.0.0.0 255.255.255.255 area 0
    ip forward-protocol nd
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:
    control-plane
    voice-port 0/0/0:15
    translation-profile incoming 7DigitDNIS-to-10Digit
    ccm-manager music-on-hold
    sccp local Loopback0
    sccp ccm 177.1.10.20 identifier 2 priority 2 version 5.0.1
    sccp ccm 177.1.10.10 identifier 1 priority 1 version 5.0.1
    sccp ccm 177.1.254.3 identifier 3 priority 3 version 5.0.1
    sccp
    sccp ccm group 1
    bind interface Loopback0
    associate ccm 2 priority 1
    associate ccm 1 priority 2
    associate ccm 3 priority 3
    associate profile 4 register Br2-HW-Conf
    associate profile 3 register Br2-HW-Xcode
    associate profile 2 register Br2-711-MTP
    associate profile 1 register Br2-729-MTP
    dspfarm profile 3 transcode 
    codec g711ulaw
    codec g711alaw
    codec g729ar8
    codec g729abr8
    codec g729r8
    codec g729br8
    maximum sessions 2
    associate application SCCP
    dspfarm profile 4 conference 
    codec g711ulaw
    codec g711alaw
    codec g729ar8
    codec g729abr8
    codec g729r8
    codec g729br8
    maximum sessions 1
    conference-join custom-cptone JOIN-TONE
    conference-leave custom-cptone LEAVE-TONE
    associate application SCCP
    dspfarm profile 1 mtp 
    codec g729ar8
    codec g729r8
    rsvp
    maximum sessions software 10
    associate application SCCP
    dspfarm profile 2 mtp 
    codec g711ulaw
    rsvp
    maximum sessions software 10
    associate application SCCP
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    dial-peer voice 10 pots
    destination-pattern 112
    no digit-strip
    port 0/0/0:15
    dial-peer voice 11 pots
    destination-pattern 00[1-9]T
    port 0/0/0:15
    prefix 0
    dial-peer voice 12 pots
    translation-profile outgoing Prefix1-toCorpHQ-ANI
    destination-pattern 000T
    port 0/0/0:15
    prefix 00
    dial-peer voice 100 voip
    description == Inbound/Outbound H323 PSTN GW From/To GK and CUCM Pub
    translation-profile incoming Prefix0_InFrom_CUCM
    destination-pattern 0207033...$
    voice-class codec 1
    session target ipv4:177.1.10.10
    incoming called-number .
    ip qos dscp cs3 signaling
    dial-peer voice 101 voip
    description == Outbound H323 PSTN GW To CUCM Sub
    destination-pattern 0207033...$
    voice-class codec 1
    session target ipv4:177.1.10.20
    ip qos dscp cs3 signaling
    dial-peer hunt 1
    telephony-service
    max-ephones 1
    max-dn 1
    ip source-address 177.1.254.3 port 2000
    max-conferences 8 gain -6
    moh test.au
    multicast moh 239.2.1.1 port 16384 route 177.1.254.3 177.3.11.1
    transfer-system full-consult
    create cnf-files version-stamp 7960 Sep 13 2013 18:55:27
    line con 0
    exec-timeout 0 0
    line aux 0
    line 66
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    login
    scheduler allocate 20000 1000
    ntp source Loopback0
    ntp update-calendar
    ntp server 177.1.254.1
    end

  • Get local machine Internet IP address

    Hi all,
    I want to get the internet IP address (from ISP) of my computer. But my computer already has a internal IP address. How can I get the Internet IP instead of Internal IP?
    I tried :
    InetAddress mNet = InetAddress.getLocalHost();
    String t = mNet.getHostAddress();
    But the IP is Internal once.
    Here is the infomration when I run ipconfig :
    0 Ethernet adapter :
    IP Address. . . . . . . . . : xxx.xxx.xxx.xxx
    Subnet Mask . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . : xxx.xxx.xxx.xxx
    1 Ethernet adapter :
    IP Address. . . . . . . . . : 0.0.0.0
    Subnet Mask . . . . . . . . : 0.0.0.0
    Default Gateway . . . . . . :
    2 Ethernet adapter :
    IP Address. . . . . . . . . : xxx.xxx.xxx.xxx
    Subnet Mask . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . :
    Remark : 0 Ethernet adapter is Internet IP, 2 Ethernet adapter is Internal IP
    Thanks!

    Hi,
    This code should print all the IP addresses from the local machine:
    import java.net.*;
    public class TestIP {
         public static void main(String args[]) {
              try {
                   InetAddress[] addresses;
                   addresses = InetAddress.getAllByName(InetAddress.getLocalHost().getHostName());
                   for (int i=0; i<addresses.length; i++) {
                        System.out.println(addresses.getHostAddress());
              catch(UnknownHostException e) {
                   System.out.println (e.getMessage());
    Hope this helps,
    Kurt.

  • Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine. at System.Data.OleDb.OleDbServicesWrapper

    HI
    when i copy asp.net 3.5  application  from IIS7 to IIS 8 in windows server 2012 and browse the application and try to save data in oracle , i  get following error in Event viewer
    Log Name:      Application
    Source:        ASP.NET 4.0.30319.0
    Date:          4/6/2015 2:53:21 PM
    Event ID:      1309
    Task Category: Web Event
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      TSharepint2013.test.com
    Description:
    Event code: 3005 
    Event message: An unhandled exception has occurred. 
    Event time: 17/06/36 02:53:21 ? 
    Event time (UTC): 17/06/36 11:53:21 ? 
    Event ID: 34f214e1dcdf45f5ad8450739c954494 
    Event sequence: 24 
    Event occurrence: 1 
    Event detail code: 0 
    Application information: 
    Process information: 
        Process ID: 18724 
        Process name: w3wp.exe 
        Account name: TEST\splaw 
    Exception information: 
        Exception type: InvalidOperationException 
        Exception message: The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine.
       at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
       at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
       at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
       at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionInternal.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.OleDb.OleDbConnection.Open()
       at printLawsuit.RetJudgement(Int32 x) in C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\printLawsuit.aspx.vb:line 2374
       at printLawsuit.Page_Load(Object sender, EventArgs e) in C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\printLawsuit.aspx.vb:line 44
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    Request information: 
     Request URL: http://-----:50/executionreq/printLawsuit.aspx 
        Request path: /executionreq/printLawsuit.aspx 
        User host address: ---3.184 
        User:  
        Is authenticated: False 
        Authentication Type:  
        Thread account name: TEST\Spfarm 
    Thread information: 
        Thread ID: 16 
        Thread account name: TEST\Spfarm 
        Is impersonating: False 
        Stack trace:    at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper)
       at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
       at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
       at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionInternal.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.OleDb.OleDbConnection.Open()
       at printLawsuit.RetJudgement(Int32 x) in C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\printLawsuit.aspx.vb:line 2374
       at printLawsuit.Page_Load(Object sender, EventArgs e) in C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\printLawsuit.aspx.vb:line 44
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    Custom event details: 
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ASP.NET 4.0.30319.0" />
        <EventID Qualifiers="32768">1309</EventID>
        <Level>3</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2015-04-06T11:53:21.000000000Z" />
        <EventRecordID>174735</EventRecordID>
        <Channel>Application</Channel>
        <Computer>TSharepint2013.test.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>3005</Data>
        <Data>An unhandled exception has occurred.</Data>
        <Data>17/06/36 02:53:21 ?</Data>
        <Data>17/06/36 11:53:21 ?</Data>
        <Data>34f214e1dcdf45f5ad8450739c954494</Data>
        <Data>24</Data>
        <Data>1</Data>
        <Data>0</Data>
        <Data>/LM/W3SVC/3/ROOT/ExecutionReq-1-130727947211114471</Data>
        <Data>Full</Data>
        <Data>/ExecutionReq</Data>
        <Data>C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\</Data>
        <Data>TSHAREPINT2013</Data>
        <Data>
        </Data>
        <Data>18724</Data>
        <Data>w3wp.exe</Data>
        <Data>TEST\splaw</Data>
        <Data>InvalidOperationException</Data>
        <Data>The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine.
       at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper&amp; datasrcWrapper)
       at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
       at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal&amp; connection)
       at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
       at System.Data.ProviderBase.DbConnectionInternal.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.OleDb.OleDbConnection.Open()
       at printLawsuit.RetJudgement(Int32 x) in C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\printLawsuit.aspx.vb:line 2374
       at printLawsuit.Page_Load(Object sender, EventArgs e) in C:\inetpub\wwwroot\wss\VirtualDirectories\Law\ExecutionReq\printLawsuit.aspx.vb:line 44
       at System.Web.UI.Control.LoadRecursive()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    </Data>
        <Data>http://----:50/executionreq/printLawsuit.aspx</Data>
        <Data>/executionreq/printLawsuit.aspx</Data>
        <Data>10.169.3.184</Data>
        <Data>
        </Data>
        <Data>False</Data>
        <Data>
        </Data>
        <Data>TEST\Spfarm</Data>
        <Data>16</Data>
        <Data>TEST\Spfarm</Data>
        <Data>False</Data>
        <Data>   at System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper&amp; datasrcWrapper)
       at System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection)
       at System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, 
    </Data>
      </EventData>
    </Event>
    adil

    Hi,
    As this question is more relate to iis, I suggest you post it to IIS Forum, you will get more help and confirmed answers from there.
    http://forums.iis.net/
    Best regards
    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact
    [email protected]

  • Reading the output from a object running in the local machine.

    Reading the output from a object running in the local machine.
    By using a signed applet i am lunching a small application that returns an image object, how to read that without storing it in the hard disk.
    Which means i need to read the image object return by the local application using applet or jsp .
    i am using tomacat and an html page with an applet with it to lunch the application.

    You can write that image in a binary format using OutputStream for System.out and then read it in your applet.

  • HT4901 Why does OS X have this poison pill?  What if iCloud isn't working one day; isn't it a security feature to keep a copy on the local machine?

    Why does OS X have this poison pill?  What if iCloud isn't working one day; isn't it a security feature to keep a copy on the local machine?

    Thank you Julian and Csound1.  Please help me understand these two messages that I get when I try to sign out from iCloud:

  • How can I find out the mail server from email address?

    Hi:
    How can I find out the mail server from email address?
    for example: If I know the email address is [email protected],
    how to find the pop3 and smtp mail server?
    THANK YOU

    You can't tell by the email address since you can pretty much put whatever you want in there (especially if the SMTP server is not filtering anything).
    The header may be able to tell you something. There is a Received header value which looks like it has the routing information although I am not sure if this is a complete trace or just the last hop the message took.
    Sean

  • The OraOledb.Oracle is not registered on the local machine.

    Hi Everyone,
    I am having Windows XP operating system with Service pack 2 on my computer. I also using Microsoft.Net 2003 & Oracle 9.x for creating a client-server Application. I installed the Oracle provider from OraWin9204.exe which i was downloaded from the Oracle's site. But I am getting the above mentioned problem "The OraOledb.Oracle is not registered on the local machine", while i m executing the open method of the Connection object of ADO.NET. I also checked the permission on ora92 (ORACLE HOME DIRECTORY) folder and gave full control to my username. But the problem remains same.
    Can anybody have any idea? Please help me on [email protected]
    Thanx
    Rahul Ratnaker

    make manual registration of following file.
    [oracle_Home]\ora92\bin\OraOLEDB.dll
    Enjoy
    Rahul Ratnaker

  • The 'IBMDADB2' provider is not registered on the local machine.

    Hi Experts,
    Need you help on this
    I am trying to migrate an application from Windows Server 2003 (32 Bit), IIS 6 to  Windows Server 2008 R2 (64 Bit), IIS 7.
    But i am getting The 'IBMDADB2' provider is not registered on the local machine error  when i am trying to connect to DB2 via application. However i am able to connect to DB2 directly via DB2CMD.
    "Provider=IBMDADB2; User ID=xxx; Password=yyyy; Data Source=zzzz; hostname=aaaa;"
    Request your help on the same.
    Thanks in Advance.

    Hi Hari,
    This forum is for Team foundation server, which it's not related to your question. Please open a new thread in corresponding forums that you used for the application.
    Best regards,
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • The 'ORAOLEDB.ORACLE' provider is not registered on the local machine.

    Sir,
    I am having my oracle 11g 64 bit database in RHEL linux 64 bit server. My Visual Studio .Net 2008 64 bit application is running in server having Windows server 2008 64 bit OS and oracle 11.2.0.2.0 client 64 bit.
    When I try to connect the database through the oracle client its working fine and I am able to connect through the development mode of visual studio 2008. But when I try to run in the IIS the following error is coming:
    The 'ORAOLEDB.ORACLE' provider is not registered on the local machine.
    Kindly help me
    Thanks in advance
    n v r

    This is not an Oracle database problem, never mind a database server language (PL/SQL or SQL) problem.
    The problem you've described is with a Microsoft product, Visual Studio 2008. The server you refer to is Microsoft IIS. The error you list is an error with a Microsoft proprietary technology called OLEDB (part of Microsoft's <i>Component Object Model</i>).
    Just where does Oracle PL/SQL and SQL languages, the subject matter of this forum, feature in your problem with Microsoft proprietary technology?

  • Check if the file exists in the local machine...

    Hi,
    I am getting a problem while checking if the local file exists or not. In the first case the server is same as my local machine. When I try to test if the file exists or not using FILE.exists() it works because I am looking for the file in my machine.
    But when I move the code in Unix the file.exists( ) tries to look in the unix box and not the local machine. My question is how to read it from the local machine?
    We are using jdk v1.2.2 and Iplanet App server v6.0.
    Thanks
    Amol

    What do you mean by "when I move the code in UNIX..."?

  • Getting Datapump Export Dump file to the local machine

    I apologize to everyone as this is a duplicate post.
    Re: Getting Datapump Export Dump file to the local machine
    My initial thread(started yesterday)was in 'Database General' and didn't get much response today. Where do i post questions on EXPORT/IMPORT utilities?
    Anyway, here is my problem:
    I want to take the export dump of itemrep schema in orcl database (in a remote machine). I have an Oracle server (10G Rel2) running in my local Windows machine. I have created a user john with necessary EXPORT/IMPORT privileges in my local db. Then i created a Directory object,ie a folder named datapump in my local hard drive and granted READ WRITE privileges to john.
    So john, who is a user in my local machine's oracle db is going to run the expdp utility.
    expdp john/jhendrix@my_local_db_alias SCHEMAS=itemrep directory=datapump logfile=itemrepexp.log
    The above command will fail because it will look for itemrep schema inside my local db, not the remote db where the itemprep is actually located. And you can't qualify the schemaname with its db in the SCHEMAS parameter (like SCHEMAS=itemrep@orcl).
    Can anyone provide me a solution for this?

    I think you can initiate the datapump exp utility from your client machine to export a schema in a remote database.But, Upon execution,oracle looks for the directory in the remote database and not on your local machine.
    You're inovoking expdp from a client (local DB) to export data from a remote DB.
    So, With this method, you can create the dumpfiles only on the Remote server and not on the local Machine.
    You can perform a direct import instead of export using the NETWORK_LINK option.
    Create a DBlink from your local and Remote DB and verify the connection.
    Then,Initiate the Impdp from Your local machine DB using the parameter network_link=<db_link of the Remote DB> to import the schema.
    The advantage of this option eliminates the Dumpfile creation at the Server side.
    There are no dumpfiles during the import process. the Data is imported directly to the target schema.

  • "The 'VFPOLEDB.1' provider is not registered on the local machine" in SSRS 2008

    Hi,
    I installed Visual Foxpro OLE DB driver for accessing dbf file and tried to get the data from the dbs file through BIDS.
    I made one report using BIDS its working fine.
    But once i deployed this report to SSRS its giving an error that “The 'VFPOLEDB.1' provider is not registered on the local machine."
    My SQL Report services is 64 bit i realaized that Visual Foxpro OLE DB will not work in 64 bit application.
    Its there any work arround for these kind of issue. I need to keep 64 bit ssrs because this is production server other reports are there.
    Please let me know is there any solution.

    Hi iqbalkmk,
    As you know the report designer is 32 bit, if you have installed the 32 bit data provider it will works fine in the designer but not work on the 64 bit report server.
    When you deploy a report to a 64-bit report server (x86), the report server must have natively compiled 64-bit data providers installed. Wrapping a 32-bit data provider in 64-bit interfaces is not supported.
    In your scenario, please try to do below setting to have a try:
    Click the IIS manager in the start.
    Edit the Advanced Properties of the application pool in which the application is running and set "Enable 32-Bit Applications" to "True".  If you don't do this you see the error message that kicked off this whole thread.
    More details information:
    Data Sources Supported by Reporting Services (SSRS)
    Similar thread for your reference:
    The 'VFPOLEDB.1' provider is not registered on the local machine
    The 'VFPOLEDB.1' provider is not registered on the local machine
    If you still have any problem, please feel free to ask.
    Regards
    Vicky Liu
    Vicky Liu
    TechNet Community Support

  • Save a .wid file to the local machine.

    hello,
    I've just started developing a java jsp client using BO report engine sdk.
    I'm looking for a way to retrieve a .wid from the CMS and save it on the local machine.
    I have been looking around in the forum and I have seen that it could be done using [IIObject.getFiles()|Re: Save Webi Document Locally] collection.
    I'm still new to BO programming so I need a hint on how to implement this.
    Thank you.
    Regards.
    Bob

    Hey Leo,
    Actually, I found a KnowledgeBase article on our website which describes this exact process, and it's not necessary to modify the UUT container. I tried this method and was successful in saving the ASCII report to the table. This KB mentions a ModelNumber parameter as its example. Instead, for our situation, I made a new Local variable in my process model called "ASCIIReport" and stored the value of Locals.Report in there as soon as the report is generated. Then I log this Locals.ASCIIReport variable to the database using the method described in the KB. It appeared to work properly.
    Also, please note that this method is only valid for the TestStand 2010 and older process models. In newer versions of TestStand, we've changed the way reporting and database logging works to use a plugin architecture, and this is partially what Scott was referring to when he mentioned that these two features don't "know" about each other. If you're currently using the TestStand 2012 or newer process model, or if you plan to migrate to those models in the future, further work will be required to log the text report to the database. The method in the linked KB should work for the legacy models, however.
    Daniel E.
    TestStand Product Support Engineer
    National Instruments

Maybe you are looking for

  • T7900 in the US... really?

    So, I go to www.creative.com. Nothing special, just want to see some 7.1 speakers to buy, and really want the T7900 set. I click on "Speaker Systems"... again, nothing special. I click on "7.1", you know, to see the 7.1 systems available. There are t

  • Open Documents with Office Web App - SharePoint 2013

    We have configured Office Web App for our SharePoint 2013 Farm and in Site settings, Site Collection Features,  have disabled "Open Documents in Client Applications by Default" . Out of 15 sites, all documents in 13 sites open in Office Web App. One

  • Since updating to OS5, my text messages are being sent as e-mails.  Also, my contacts do not show the people's phone

    Since updating my iPhone 4 to iOS5, it seems my texts are being sent as e-mails or in e-mail form. The person I am texting gets a phone number and not my name.  Also, when I click on contacts to text to, where it used to show the phone number and I w

  • Support package requierement for unicode conversion

    We are currently planning a unicode conversion for a SAP 4.7enterprise 1.1 extension version, running under Aix and Oracle, Basis/ABAP SP 35, HR SP20. According to the conversion guide, we must implement at least Support Pachage 60 for Abap and Basis

  • DPM Agent Installation Failed with Error code =0x80070643

    Hi, We had an Virtual Machine TFS server 2010 which had SQL server 2008 R2 installed on it. On this Server we were running an DPM 2010 agent and it was fine.  Then I had uninstalled DPM 2010 agent and  try to Install DPM 2012 R2 Agent on this Virtual