Duplicate check on one column in only one datablock

hi all,
i have a database block with three columns.
X Y Z
X is a display item and not navigable. Y has to be a unique number therefore no duplicate number can be added before commit is done and Z is check box.
i have written a code for this in the pre-update trigger but the issue is when i update the checkbox it looks as if the Y clumn has been changed. could some please tell me a better method to check for duplicate check.
any advice would be really helpful. thanks in advance.

I saw your other thread asking how to prevent duplicate keys on a database.
I am not sure what code you wrote in the pre-update trigger, but it sounds like you are checking for a duplicate record in the database, but NOT excluding the present record. You can add: AND ROWID <> :this_block.ROWID
to your where clause, and it should bypass the present record when checking for a duplicate. (Change "this_block" to the name of your forms block.) Also, did you write a similar pre-insert trigger? It would be better to write the code for both insert and updates in a when-validate-record trigger (see below).
However, after saying all that, you can do all sorts of checks in your form, but none of them will trap the situation where a second user inserts or updates a record with the same key at the first user. The only thing you can do to prevent duplicates and be 100% sure is to create a unique constraint on the database table. Then you will need to write code in the form to check when the error is raised. Here is a thread where that method is discussed:
Re: Question about Unique Table Columns - How to Handle Alerts
Also, in your other thread, you asked about using a record group to prevent duplicates. You can read this thread:
Re: Hi all, Very interesting problem to tackle,..help me
Here is code for a when-validate-record trigger to check for duplicates:
Declare
  dummy varchar2(1);
Begin
  -- check if inserting OR changing key:
  If :System.record_status = 'INSERT'
  or :System.record_status = 'CHANGED'
    and :this_block.key_item
    <> get_item_property('THIS_BLOCK.KEY_ITEM',database_value) then
    begin
      Select 'X' into dummy from table where key_item = :this_block.key_item;
    exception when no_data_found then null;
    end;
    If dummy='X' then
      Message('  Record already exists on the database');
      Raise form_trigger_failure;
  End if;
End;For small tables (those with maybe less than a thousand rows) you can use the famous Kevin Clarke duplicate summary function to trap for duplicates within the block. But this method depends on your always fetching all rows into the block every time you query.
You can see a description of the method in the following threads:
Duplicate key prevention
Re: checking for same rows in a tabular
Re: duplicate records in  a multi record block

Similar Messages

  • Returning two rows with one column containing only one place

    Dear all;
    I have a query that returns two rows similar to this below
    ID      PLACE            PROGRAM
    A       NEWYORK      PROGRAM A
    A       NEWYORK      PROGRAM B
    I would like this instead
    ID      PLACE             PROGRAM
    A       NEWYORK       PROGRAM A
                                   PROGRAM  B
    All help is appreciated. Thank you.Edited by: user13328581 on Mar 22, 2011 11:52 AM

    user13328581 wrote:
    WOW...THanks a lot Solomon, I have never used partitions and row_number in such a manner...can you please explain your logic.Sure:
    row_number() over(partition by id order by place,program)This will take all rows returned by the query andsplit them into buckets (partitions) by id. Inside each bucket it will order rows by place and program and assign them row numbers. So for each ID row number 1 will be row with first (alphabetically) place first programt. And this is the row where we want ID to show up. That is why we wrap the above analytic function in CASE statement which will do exactly that. Now:
    row_number() over(partition by id,place order by program)does pretty much the same just bucket is ID and PLACE combination. So for each such combination we want to show only for the first (alphabetically) programt.
    Now notice in ORDER BY clause I prefix ID and PLACE with table alias. You must do it since otherwise query alias ID and PLACE will take precedence resulting in wrong sort order (remember we nulled all ID and PLACE except for row number 1).
    SY.

  • I need to edit out parts of a song to cut it down to two minutes for my daughter's talent show. I went to info and it will cut down one part but only one part. I need to put three parts together. I tried adding duplicates of the song to the list but if I

    I need to edit out parts of a song to cut it down to two minutes for my daughter's talent show. I went to info/start time and it will cut down one part but only one part. I need to put three parts together. I tried adding duplicates of the song to the list but if If I change the start time on one it will change it on all of them.

    In your library, right-click the song you want to edit.
    select "get info".
    go to "options" and select the start and stop times for your first section of the song.
    click "OK".
    Find the shortened version of the song in your library. It may take a minute for it to show up. right click it again and select "create (????) version". (the ???? is different for different formats).
    The library will spit out a new, second version of the song which you can rename. I suggest you use the original title and add a 1 to the end.
    Now you can go back to the other version and repeat the process with a different  start/stop time.
    Once you are done editing, you can burn all of your versions to a disk, just make sure your interval time is zero so there are no gaps between edits.
    To keep the orginal song on your library, just go back to the original and put the start/stop times back to the original settings.

  • Different Effective Date in One BOM with only ONE Change Number

    Hi gurus
    here is my complete question?
    Is it possible to realize this function that Different Effective Date in One BOM for different BOM items with only ONE Change Number?
    Thanks for your information/help in advance.

    Dear Zhao,
    Using One change number it's not possible to define a different valid from date for the BOM changes of a single material BOM.
    In case if the same change number is used for making different material's BOM component,then a different valid from date for
    each BOM can be defined,but at any given point not for each component/item level of the same BOM.
    Check and revert back.
    Regards
    Mangalraj.S

  • Getting "IPSEC(epa_des_crypt): decrypted packet failed SA identity check" messages on packets from only one of two far-end sources sharing the same tunnel, the other source works fine. What exactly does this error mean?

    One computer at COMPANY-A is attempting to communicate with two
    computers located at COMPANY-B, via an IPsec tunnel between the
    two companies.
    All communications are via TCP protocol.
    All devices present public IP addresses to one another, although they
    may have RFC 1918 addresses on other interfaces, and NAT may be in use
    on the COMPANY-B side.  (NAT is not being used on the COMPANY-A side.)
    The players:(Note: first three octets have been changed for security reasons)
    COMPANY-A computer      1.2.3.161
    COMPANY-A router        1.2.3.8 (also IPsec peer)
    COMPANY-A has 1.2.3.0/24 with no subnetting.
    COMPANY-B router        4.5.6.228 (also IPsec peer)
    COMPANY-B computer #1   4.5.7.94 (this one has no issues)
    COMPANY-B computer #2   4.5.7.29 (this one fails)
    COMPANY-B has 4.5.6.0/23 subnetted in various ways.
    COMPANY-B also has 9.10.11.0/24, but it is not involved in the issue.
    What works:
    The COMPANY-A computer 1.2.3.161 can communicate via the single IPsec
    tunnel to COMPANY-B computer #1 4.5.7.94 without problems.
    The "show crypto session detail" command shows Inbound/Outbound packets
    flowing in the dec'ed and enc'ed positions.
    What doesn't:
    When the COMPANY-A computer 1.2.3.161 attempts to communicate
    via the single IPsec tunnel with the COMPANY-B computer #2 4.5.7.29,
    the COMPANY-A router eventually reports five of these messages:
    Oct  9 15:24:54.327: IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    Oct  9 15:24:57.327: IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    Oct  9 15:25:03.327: IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    Oct  9 15:25:15.328: IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    Oct  9 15:25:39.329: IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    Oct  9 15:26:27.328: IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    and the "show crypto session detail" shows inbound packets being dropped.
    The COMPANY-A computer that opens the TCP connection never gets past the
    SYN_SENT phase of the TCP connection whan trying to communicate with the
    COMPANY-B computer #2, and the repeated error messages are the retries of
    the SYN packet.
    On the COMPANY-A side, this IPsec configuration has been set up on a 3745,
    a 3725, and some 76xx routers were tried, all with similar behavior,
    with packets from one far-end computer passing fine, and packets from
    another far-end computer in the same netblock passing through the same
    IPsec tunnel failing with the "failed SA identity" error.
    The COMPANY-A computer directs all packets headed to COMPANY-B via the
    COMPANY-A router at 1.2.3.8 with this set of route settings:
    netstat -r -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    4.5.7.0         1.2.3.8         255.255.255.0   UG        0 0          0 eth3
    1.2.3.8.0       0.0.0.0         255.255.255.0   U         0 0          0 eth3
    10.1.0.0        0.0.0.0         255.255.240.0   U         0 0          0 eth0
    169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth3
    10.0.0.0        10.1.1.1        255.0.0.0       UG        0 0          0 eth0
    0.0.0.0         1.2.3.1         0.0.0.0         UG        0 0          0 eth3
    The first route line shown is selected for access to both COMPANY-B computers.
    The COMPANY-A router (IPsec tunnel endpoint, 1.2.3.8) has this
    configuration:
    crypto isakmp policy 10
    encr 3des
    authentication pre-share
    group 2
    lifetime 28800
    crypto isakmp key XXXXXXXXXXXXXXXXXXXXXXX address 4.5.6.228
    crypto ipsec security-association lifetime seconds 86400
    crypto ipsec transform-set COMPANY-B01 esp-3des esp-sha-hmac
    crypto map COMPANY-BMAP1 10 ipsec-isakmp
    description COMPANY-B VPN
    set peer 4.5.6.228
    set transform-set COMPANY-B01
    set pfs group2
    match address 190
    interface FastEthernet0/0
    ip address 1.2.3.8 255.255.255.0
    no ip redirects
    ip virtual-reassembly
    duplex auto
    speed auto
    no cdp enable
    crypto map COMPANY-BMAP1
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 1.2.3.1
    ip route 10.0.0.0 255.0.0.0 10.1.1.1
    ip route 1.2.3.8.0 255.255.255.0 FastEthernet0/0
    access-list 190 permit ip host 1.2.3.161 4.5.7.0 0.0.0.255
    access-list 190 permit ip host 1.2.3.161 9.10.11.0 0.0.0.255
    bridge 1 protocol ieee
    One of the routers tried had this IOS/hardware configuration:
    Cisco IOS Software, 3700 Software (C3725-ADVIPSERVICESK9-M), Version 12.4(25c),
    RELEASE SOFTWARE (fc2)
    isco 3725 (R7000) processor (revision 0.1) with 115712K/15360K bytes of memory.
    Processor board ID XXXXXXXXXXXXXXX
    R7000 CPU at 240MHz, Implementation 39, Rev 3.3, 256KB L2 Cache
    2 FastEthernet interfaces
    4 ATM interfaces
    DRAM configuration is 64 bits wide with parity disabled.
    55K bytes of NVRAM.
    31296K bytes of ATA System CompactFlash (Read/Write)
    250368K bytes of ATA Slot0 CompactFlash (Read/Write)
    Configuration register is 0x2102
    #show crypto sess
    Crypto session current status
    Interface: FastEthernet0/0
    Session status: UP-ACTIVE
    Peer: 4.5.6.228 port 500
      IKE SA: local 1.2.3.8/500 remote 4.5.6.228/500 Active
      IPSEC FLOW: permit ip host 1.2.3.161 4.5.7.0/255.255.255.0
            Active SAs: 2, origin: crypto map
      IPSEC FLOW: permit ip host 1.2.3.161 9.10.11.0/255.255.255.0
            Active SAs: 0, origin: crypto map
    #show crypto sess det
    Crypto session current status
    Code: C - IKE Configuration mode, D - Dead Peer Detection
    K - Keepalives, N - NAT-traversal, X - IKE Extended Authentication
    Interface: FastEthernet0/0
    Session status: UP-ACTIVE
    Peer: 4.5.6.228 port 500 fvrf: (none) ivrf: (none)
          Phase1_id: 4.5.6.228
          Desc: (none)
      IKE SA: local 1.2.3.8/500 remote 4.5.6.228/500 Active
              Capabilities:(none) connid:1 lifetime:06:26:27
      IPSEC FLOW: permit ip host 1.2.3.161 4.5.7.0/255.255.255.0
            Active SAs: 2, origin: crypto map
            Inbound:  #pkts dec'ed 651 drop 16 life (KB/Sec) 4496182/23178
            Outbound: #pkts enc'ed 574 drop 2 life (KB/Sec) 4496279/23178
      IPSEC FLOW: permit ip host 1.2.3.161 9.10.11.0/255.255.255.0
            Active SAs: 0, origin: crypto map
            Inbound:  #pkts dec'ed 0 drop 0 life (KB/Sec) 0/0
            Outbound: #pkts enc'ed 0 drop 0 life (KB/Sec) 0/0
    The COMPANY-B device on their end of the IPsec VPN is a Juniper SSG1000
    Version 6.1 (ScreenOS)
    We only have a limited view into the Juniper device configuration.
    What we were allowed to see was:
    COMPANY-B-ROUTER(M)-> sh config | incl COMPANY-A
    set address "Untrust" "oss-COMPANY-A-1.2.3.161" 1.2.3.161 255.255.255.255
    set ike gateway "COMPANY-A-1-GW" address 1.2.3.8 Main outgoing-interface "ethernet2/1" preshare xxxxxxxxxxxxxxxxxxxxxx  proposal "pre-g2-3des-sha"
    set vpn "COMPANY-A-1-IKE" gateway "COMPANY-A-1-GW" no-replay tunnel idletime 0 proposal "g2-esp-3des-sha-28800"
    set policy id 2539 from "Untrust" to "Trust"  "oss-COMPANY-A-1.2.3.161" "9.10.11.0-24" "ANY" tunnel vpn "COMPANY-A-1-IKE" id 0x309a pair-policy 2500
    set policy id 2500 from "Trust" to "Untrust"  "9.10.11.0-24" "oss-COMPANY-A-1.2.3.161" "ANY" tunnel vpn "COMPANY-A-1-IKE" id 0x309a pair-policy 2539
    set policy id 2541 from "Trust" to "Untrust"  "4.5.7.0-24" "oss-COMPANY-A-1.2.3.161" "ANY" tunnel vpn "COMPANY-A-1-IKE" id 0x309b pair-policy 2540
    set policy id 2540 from "Untrust" to "Trust"  "oss-COMPANY-A-1.2.3.161" "4.5.7.0-24" "ANY" tunnel vpn "COMPANY-A-1-IKE" id 0x309b pair-policy 2541
    COMPANY-B-ROUTER(M)->
    I suspect that this curious issue is due to a configuration setting on the
    Juniper device, but neither party has seen this error before.  COMPANY-B
    operates thousands of IPsec VPNs and they report that this is a new error
    for them too.  The behavior that allows traffic from one IP address to
    work and traffic from another to end up getting this error is also unique.
    As only the Cisco side emits any error message at all, this is the only
    clue we have as to what is going on, even if this isn't actually an IOS
    problem.
    What we are looking for is a description of exactly what the Cisco
    IOS error message:
    IPSEC(epa_des_crypt): decrypted packet failed SA identity check
    is complaining about, and if there are any known causes of the behavior
    described that occur when running IPsec between Cisco IOS and a Juniper
    SSG device.  Google reports many other incidents of the same error
    message (but not the "I like that IP address but hate this one" behavior),
    and not just with a Juniper device on the COMPANY-B end, but for those cases,
    not one was found where the solution was described.
    It is hoped that with a better explanation of the error message
    and any known issues with Juniper configuration settings causing
    this error, we can have COMPANY-B make adjustments to their device.
    Or, if there is a setting change needed on the COMPANY-A router,
    that can also be implemented.
    Thanks in advance for your time in reading this, and any ideas.

    Hello Harish,
    It is believed that:
    COMPANY-B computer #1   4.5.7.94 (this one has no issues)
    COMPANY-B computer #2   4.5.7.29 (this one fails)
    both have at least two network interfaces, one with a public IP address
    (which we are supposedly conversing with) and one with a RFC 1918 type
    address.   COMPANY-B is reluctant to disclose details of their network or
    servers setup, so this is not 100% certain.
    Because of that uncertainty, it occurred to me that perhaps COMPANY-B
    computer #2 might be incorrectly routing via the RFC 1918 interface.
    In theory, such packets should have been blocked by the access-list on both
    COMPANY-A router, and should not have even made it into the IPsec VPN
    if the Juniper access settings work as it appears they should.  So I turned up
    debugging on COMPANY-A router so that I could see the encrypted and
    decrypted packet hex dumps.
    I then hand-disassembled the decoded ACK packet IP header received just
    prior to the "decrypted packet failed SA check" error being emitted and
    found the expected source and destination IP addresses (4.5.7.29 and 1.2.3.161),
    in the unecapsulated packet.  I also found the expected port numbers of the TCP
    conversation that was trying to be established in the TCP header.  So, it
    looks like COMPANY-B computer #2 is emitting the packets out the right
    interface.
    The IP packet header of the encrypted packet showed the IP addresses of the
    two routers at each terminus of the IPsec VPN, but since I don't know what triggers
    the "SA check" error message or what it is complaining about, I don't know what
    other clues to look for in the packet dumps.
    As to your second question, "can you check whether both encapsulation and
    decapsulation happening in 'show crypto ipsec sa'",   the enc'ed/dec'ed
    counters were both going up by the correct quantities.  When communicating
    with the uncooperative COMPANY-B computer #2, you would also see the
    received Drop increment for each packet decrypted.  When communicating
    with the working COMPANY-B computer #1, the Drop counters would not
    increment, and the enc'ed/dec'ed would both increment.
    #show crypto sess det
    Crypto session current status
    Code: C - IKE Configuration mode, D - Dead Peer Detection
    K - Keepalives, N - NAT-traversal, X - IKE Extended Authentication
    Interface: FastEthernet0/0
    Session status: UP-ACTIVE
    Peer: 4.5.6.228 port 500 fvrf: (none) ivrf: (none)
          Phase1_id: 4.5.6.228
          Desc: (none)
      IKE SA: local 1.2.3.8/500 remote 4.5.6.228/500 Active
              Capabilities:(none) connid:1 lifetime:07:59:54
      IPSEC FLOW: permit ip host 1.2.3.161 4.5.7.0/255.255.255.0
            Active SAs: 2, origin: crypto map
            Inbound:  #pkts dec'ed 376 drop 5 life (KB/Sec) 4458308/28784
            Outbound: #pkts enc'ed 401 drop 3 life (KB/Sec) 4458308/28784
    Attempt a TCP communication to COMPANY-B computer #2...
    show crypto sess det
    Crypto session current status
    Code: C - IKE Configuration mode, D - Dead Peer Detection
    K - Keepalives, N - NAT-traversal, X - IKE Extended Authentication
    Interface: FastEthernet0/0
    Session status: UP-ACTIVE
    Peer: 4.5.6.228 port 500 fvrf: (none) ivrf: (none)
          Phase1_id: 4.5.6.228
          Desc: (none)
      IKE SA: local 1.2.3.8/500 remote 4.5.6.228/500 Active
              Capabilities:(none) connid:1 lifetime:07:59:23
      IPSEC FLOW: permit ip host 1.2.3.161 4.5.7.0/255.255.255.0
            Active SAs: 2, origin: crypto map
            Inbound:  #pkts dec'ed 376 drop 6 life (KB/Sec) 4458307/28753
            Outbound: #pkts enc'ed 402 drop 3 life (KB/Sec) 4458307/28753
    Note Inbound "drop" changed from 5 to 6.  (I didn't let it sit for all
    the retries.)
    #show crypto ipsec sa
    interface: FastEthernet0/0
        Crypto map tag: COMPANY-BMAP1, local addr 1.2.3.8
       protected vrf: (none)
       local  ident (addr/mask/prot/port): (1.2.3.161/255.255.255.255/0/0)
       remote ident (addr/mask/prot/port): (4.5.7.0/255.255.255.0/0/0)
       current_peer 4.5.6.228 port 500
         PERMIT, flags={origin_is_acl,}
        #pkts encaps: 402, #pkts encrypt: 402, #pkts digest: 402
        #pkts decaps: 376, #pkts decrypt: 376, #pkts verify: 376
        #pkts compressed: 0, #pkts decompressed: 0
        #pkts not compressed: 0, #pkts compr. failed: 0
        #pkts not decompressed: 0, #pkts decompress failed: 0
        #send errors 3, #recv errors 6
         local crypto endpt.: 1.2.3.8, remote crypto endpt.: 4.5.6.228
         path mtu 1500, ip mtu 1500, ip mtu idb FastEthernet0/0
         current outbound spi: 0xDF2CC59C(3744253340)
      inbound esp sas:
          spi: 0xD9D2EBBB(3654478779)
            transform: esp-3des esp-sha-hmac ,
            in use settings ={Tunnel, }
            conn id: 2004, flow_id: SW:4, crypto map: COMPANY-BMAP1
            sa timing: remaining key lifetime (k/sec): (4458307/28600)
            IV size: 8 bytes
            replay detection support: Y
            Status: ACTIVE
         inbound ah sas:
         inbound pcp sas:
         outbound esp sas:
          spi: 0xDF2CC59C(3744253340)
            transform: esp-3des esp-sha-hmac ,
            in use settings ={Tunnel, }
            conn id: 2003, flow_id: SW:3, crypto map: COMPANY-BMAP1
            sa timing: remaining key lifetime (k/sec): (4458307/28600)
            IV size: 8 bytes
            replay detection support: Y
            Status: ACTIVE
         outbound ah sas:
         outbound pcp sas:
    The "send" errors appear to be related to the tunnel reverting to a
    DOWN state after periods of inactivity, and you appear to get one
    each time the tunnel has to be re-negotiated and returned to
    an ACTIVE state.  There is no relationship between Send errors
    incrementing and working/non-working TCP conversations to the
    two COMPANY-B servers.
    Thanks for pondering this very odd behavior.

  • I have three user accounts on one computer. On only one account when I when I check Help - About fire fox only one user account says apply update and won't apply. The other two work fine.

    One of three user accounts on the same computer appears to not be updating to 8.0.1 correctly. One admin and one none admin user account says it is up-to-date. The other non-admin user account, under Help About Firefox says apply update, but won't.

    As long as you installed MS Office into its default location (the top level /Applications folder) it will be available to all user accounts on the Mac.
    As far as licensing is concerned you only have to enter the license code once, which you should do right after installing MS Office, in the same admin account you installed it from, by opening any one of the MS Office applications.  There is no additional licensing required for additional user accounts on the same Mac.
    Each user account is able to run the Office apps.  The only thing you will have to do is go through an initial setup screen in each user account (but this setup does NOT involve entering any additional license codes).
    You may have problems if you installed MS Office in a particular user account (i.e. NOT in the top level /Applications folder).

  • Duplicate Songs!!!  But only one plays... HELP!

    Please help... in my entire library i have 2 songs listed. One plays and the other has an exclamation point next to it. How can i delete all the copies of songs w/ exclamation point at the same time without going thru all 7,000 songs one at a time and hitting the delete button?

    There is a difference between duplicate music files and duplicate library entries.
    Have you re-organised your music files? Have you run the evil "Consolidate Music Library" command? Or added directories to the library after reorganisation?
    I've had similar problems and I've deleted the library and had iTunes rebuild the library. Sure, you lose some library specific data. It also depends on all your music being contained in a single directory (plus sub directories). Long ago, I learnt the lesson of letting iTunes organising my music and copying any music it played via double-clicking to the iTunes music directory.

  • HT2513 I keep getting duplicate Birthday entries in Ical with only one date/entry in the Contacts App.  Please help?

    I need help deleting one of the duplicate birthdays in Ical on my Macbook Pro?
    Sam

    What I found was that you have to go all or nothing. I don't have any personal iDevices (just an iPad through work) so the simple solution was to turn off Contact syncing for iCloud. I'm guessing you'll need to remove all your local contacts or, the more tedious solution, remove the birthdays from all the local contacts. As you surmised, iCal seems to use the whole address book, and can't be just a subset of contacts.

  • Duplicate Copies of Music Files (but only one in Library)  HELP!

    Hopefully, someone can help me out here!
    I have a "missing" 13 gigs or so on my hard drive, and I was trying to figure out what the problem was.
    I thought it might have something to do with my music b/c that is about what I have on my iPod......soooo, I went a did a search to see if I had the files in two places.
    My search results (just did a search for all music on the computer) show that I have two of the exact same files for all my iTunes music...each in the exact same location.
    In my iTunes, it just says I have one of each, though.
    I tried deleting one of the duplicate files to see what would happen, but then the song wouldn't play (got the little !mark).
    Has anyone else gone through this? (I've done searches, but I can't seem to find the answer)
    I'd really like to get rid of any superfluous files!
    Thanks in advance!
    Mandalyn
    Dell XPS m170   Windows XP  

    Hi, Mandalyn.
    Welcome to the Apple Discussions!
    I tried deleting one of the duplicate files to see what would happen, but then the song wouldn't play (got the little !mark).
    I really hate answering a question with another question but ...
    What happens when you restore that file and then delete the other file for the same song?

  • More than one sender with only one comunication channel

    Hi experts.
    I need to know that it is possible to make a one File FTP sender comunication channel with more than one host.
    If that is not possible, how could get that functionality?
    Thanks!
    Regards.

    Hi Alvaro,
    It is not a bad idea to do a report to search in the two locations, make a job for polling and later the report call  via http or SOAP to PI itself (if you need to do any map or you need file content conversion) or not to use in PI scenario (neither http or SOAP call) if you only need to move files. I only see the next disadventages:
    1. It is not a standard solution. This could be problematic in a SP uppgrade or PI version change.
    2. If one day your client thinks to migrate to the PI java-only version, you would need to do again this scenario.
    3. If you haven't any scenario in PI or a good documentation system, this interface can be forgotten for you or by future PI technician.
    4. You lose the powerful of the monitoring tools.
    Hope this helps.
    Regards.

  • Auto loading of username and password are taking place on one site and only one site and I do not want this to happen but can"t get it to stop.

    As my question states I don't want auto loading on any site and it only happens on this one site. I have went thru tools and options and there are no sites listed for auto loading. There are no saved passwords. If I go to the site using Internet explorer the problem does not occur.

    Ok, no problem i found this help articles:
    https://support.mozilla.org/en-US/kb/how-clear-firefox-cache
    http://www.youtube.com/watch?v=OukBlXfOP8Y

  • One friend , and only one, is unable to send, or I cannot receive his emails

    Since installing Firefox, Mozilla, one friend seems unable to contact me by email - there was no problem before. He sends me email, which does not bounce, but there is no sign of it in my webmail, or OE inbox. I use a dongle to receive my Broadband and emails. There are no problems with any other senders

    Perform the suggestions mentioned in the following articles:
    * [https://support.mozilla.com/en-US/kb/Template:clearCookiesCache/ Clear Cookies & Cache]
    * [[How to clear the cache#w_clear-the-cache|Clear the Network Cache]]
    Check and tell if its working.
    -> Update Firefox to the latest version (9.0.1)
    * [[Updating Firefox]]
    -> Update All your Firefox Plugins
    * https://www.mozilla.org/en-US/plugincheck/
    * '''When Downloading Plugins Update setup files, Remove Checkmark from Downloading other Optional Softwares with your Plugins (e.g. Toolbars, McAfee, Google Chrome, etc.)'''
    * Restart Firefox

  • Two accounts on one computer but only one itunes works

    I used the directions for creating two user accounts on one computer when my son got a new itouch.  I have an itunes account for my iphone.  I then created a new user account and downloaded itunes to second account for son's itouch.  I can't access itunes store from the new user account.  My account for an iphone will access itunes store.  When I click itunes store, the loading signal comes up at the top of the page as if loading but it never loads. 
    I have tried reinstalling?  Updating quicktime.
    Any idea what may be stopping the access?  I use firefox as the default for my account but have not loaded it onto the new account.... could that be a problem?
    What's wrong?

    Possibly it registered incorrectly once (who knows why), and now it thinks that is the right way. From what I understand all of the correct songs are still on your iPod though. In iTunes, single click on the incorrectly named iPod, then click again (kinda a delayed double click), then rename the iPod. From what I picked out of your post, they are both the same kind of iPod with the same amount of memory. If that's not the case, post back.
    As for the songs skipping...
    Songs That Skip On iPod
    iPod Does Not Play Content from iTunes Music Store
    I hope this helps!

  • Radiobuttons: More than one block and only one RB group. Is it possible?

    Hi experts!
    Mi requirement needs to have 5 different radiobuttons in 3 different SELECTION-SCREEN block. But the point is that they need that RB needs to belong to the same radiobutton's group. Is this possible to do when I define parameters or I have to manage them by program?
    Thanks and regards.

    Dear,
    It is possible.
    Please go through the example of live program.
    SELECTION-SCREEN : BEGIN OF BLOCK B1 WITH FRAME TITLE TEXT-001.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P1 RADIOBUTTON GROUP G1 DEFAULT 'X' .
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P2 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P3 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P4 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P5 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P6 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P7 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : SKIP.
    PARAMETERS :  P8 RADIOBUTTON GROUP G1.
    SELECTION-SCREEN : END OF BLOCK B1.
    IF P1 = 'X'.
      SUBMIT ZSD_INVOICE_DETAIL VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P2 = 'X'.
      SUBMIT ZSD_SERVICE_COMM_BDC VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P3 = 'X'.
      SUBMIT ZSD_INSPIRA_UPLOAD VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P4 = 'X'.
      SUBMIT ZSD_SERVICE_COMM_PAYOUT VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P5 = 'X'.
      SUBMIT ZSD_SERVICE_COMM_PAYOUT_BDC VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P6 = 'X'.
      SUBMIT ZSD_SERVICE_COMM_CANC_BDC VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P7 = 'X'.
      SUBMIT ZSD_SERVICE_COMM_REVR_BDC VIA SELECTION-SCREEN AND RETURN.
    ELSEIF P8 = 'X'.
      SUBMIT ZBDC_F02_PAYOUT_50 VIA SELECTION-SCREEN AND RETURN.
    ENDIF.
    Regds,
    Anil

  • EzVPN sometimes ping only in one direction or only one interface

    Guys, I have lots of 857's routers in the field with mostly the latest OS - 12.4(15)T17 making ezVPN connections to a 2951 with 15.1(4)M5.
    All the 857's have lookback and vlan interfaces similar to :
    interface Loopback0
    ip address 50.43.8.1 255.255.255.255
    ip tcp adjust-mss 1452
    end
    interface Vlan1
    ip address 40.43.8.1 255.255.255.128
    ip tcp adjust-mss 1452
    crypto ipsec client ezvpn SMS_VPN inside
    end
    This is my Dialer interface :
    interface Dialer0
    ip ddns update hostname my_custom_host_name
    ip ddns update SMS_DynDNS
    ip address negotiated
    ip access-group 102 in
    ip access-group 101 out
    ip mtu 1492
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent
    ppp authentication chap pap callin
    ppp chap hostname my_hostname
    ppp chap password 0 my_password
    ppp pap sent-username my_hostname password 0 my_password
    ppp ipcp dns request accept
    crypto ipsec client ezvpn SMS_VPN
    And their crypto's are defined as :
    crypto ipsec client ezvpn SMS_VPN
    connect auto
    group HW_Client key my_client_key
    mode network-extension
    peer my_peer_ip
    acl 100
    username my_username password my_password
    xauth userid mode local
    Now lately for some or other reason we have instances where I can ping either the VLAN or the LOOPBACK interface, but not both. Or I have instances where the 2951 can ping all the interfaces on the 857, but the 857 can not ping the 2951. Or I have instances where the 2951 can not ping the 857, but the 857 can ping the 2951.
    The way I have been fixing this is either to add crypto ipsec client ezvpn SMS_VPN inside to the loopback interface, or if it is there already to remove it. This usually works for a few days, but then suddenly I have to reverse this again. If that does not work then I usually do lots of clear crypt sess and/or clear crypt ipsec client ezvpn on the 857, or clear crypt sess remote 857_ip_address from the 2951 and then suddenly it starts working again.
    Surely there must be something wrong, but I just can not figure out what. Any ideas ?!

    Bump ... Anyone please ...

Maybe you are looking for

  • How to connect to excel document at network machine through oracle ?

    Hello ! I am able to read excel doc at my local drive through sqlplus(oracle). Please help me to modify steps to access excel docs at network machine. steps:-> 1) start\settings\control\panel\administartive tolls\data source odbc\system dns\driver fo

  • Photos copies photos when importing even when told not to copy photos when importing?

    The new Photos app is pretty cool. The one thing I didn't like about iPhotos is still present here:  Rather than handling my photos in the Finder it creates a weird database full of all the photos -- and the only way to get to them is via this one ap

  • Page length problem in PDFs generated from HTML pages in Acrobat

    I just spent an exhausting 2-1/2 hours on the phone with Adobe tech support (offshore) in order to get a 5 minute fix. I figured that I'd document it here in case another user has the same problem. (I'd checked the forums and a few e-mail lists and h

  • Weird install problem with OS X, please help!

    I've been upgrading a friend powerbook firewire 400Mhz G3, we installed 1GB of memory and put in an 80GB HD. I partioned so that OSX can be on the first 8GB, put 9.1 on the second parition of 7GB, upgraded the firmware, and i think i have tried just

  • Salesforce integration with SAP using XI

    Hi Experts, We are evaluating to integrate salesforce with SAP. We can understand more about salesforce through salesforce.com. Can we use XI/PI to integrate SAP with salesforce. Appreciate your help!! Regards, Suraj Kumar