Dynamic Cell variant assignment

Hi
I wish to dynamically assign a table variant with a cell editor of type checkbox and then check/uncheck/make readonly the field accordign various situations. I only wish this to happen on certain rows.
So far I can achieve this my using context attributes and binding to these. My only concern is that there are a lot of extra attributes required as thses cell variants appear on 7 columns and then 8 tabs.
I would prefer to achive this solution by using the view->get_element approach, but so far I have only managed to assign the cell variant to the entire column and not an individual cell.
Any ideas?
Cheers
Ian
Edited by: Ian Stubbings on Mar 10, 2008 8:52 AM

Hi,
In case of a checkbox, based on the value of the attribute bound to the checkbox column, the checkbox will be checked/unchecked. Anyways, you have to have a context node of cardinality 0...n, with an attribute which can be bound to the checkbox. As far as readonly property is concerned, you can have an additional attribute in the same context node, and bind that to the read-only property of the checkbox. Alternatively, I think you can use the SET_ATTRIBUTE_PROPERTY of the IF_WD_CONTEXT_ELEMENT class.
Hope this helps.
Regards
Wenonah

Similar Messages

  • How to add cell editor to cell variant dynamically?

    Hi everyone,
      I'm developing a web dynrpo component. In one of the views , I need to modify the view dynamically
    because the data structure only can be determined at runtime. And the table column should have two
    cell variants. I don't know the exact cell variant class which should be used. I only find an abstract class about cell variant CL_WD_ABSTR_TABLE_CELL_VAR , but I can't find any method in this class which
    can add cell editor under this cell variant.
    Thanks in advance.

    Hi Sireesha,
    Thanks for link you provided.
    I am able to add Column with CommandImageLink.And onclick of that link i am able to display another popup.
    Now another problem which i am facing is when i select one row from popup and click "Ok" i have to modify some columns from Dyanamic table which is displayed on main page.
    For this.
    1)First i took the selected row from dyanamic table to update that perticular row depending upon the row which i select from popup.
    if you see the code above i am refaring the list as collection for data.So i am updating that collection but again it is refreshing to it's original value.
    because number of times getList() method of bean get's called equal to number of columns. which brings the values from database.
    Here On click of popup's Ok button I don't want to save the data for table i just want to show there in some column's .and After click on SAVE button from table i have to save it.
    Let me help how can i modify the Dynamic table's data.
    Thanks for all help.
    Jaydeep

  • Table UI element - dynamic cell editor change on runtime

    Hello,
    I have standard table UI element defined on one of the views as part of it's layout, two columns only - KEY and VALUE. Both defined as text cell editor by default. Content of the table is dynamic and different combination of keys and values are presented depending on the app context.
    Recently the need arised to (depending on the key value) change the cell editor type for single rows only, dynamically from text to link to action - and to register a triggable event for that with some logic behind (to open new window when link is clicked).
    Is it possible at all to have a column in Table UI element with different editor types set dynamically on runtime for different rows? Some cells then wolud still be presented as text, some would have a link to action in them.
    If possible can I ask for any hints on how to achieve that?
    I imagine that first I have to get somehow a reference to the UI element created when the view is triggered first time, then after I recieve values from backend but prior (or after?) binding it to the table context I would like to evaulate the keys and change cell editors accordingly. Then for changed editors (link to action) I would like to register triggable events (on action) which would call some custom methods for further processing. Please advice.
    Best regards,
    Marcin

    Hi,
       You can use the cell variants to display different cell editors in different rows.
       First in your table column where you want to display different cell editors insert two cell variants
       and fill the VARIANT KEY for each cell variant and insert textview under one cell variant and input field
       under another cell variant, and bind the text to be displayed to these cell editors, now take an extra
       attribute of type string in your node and bind it to the table column property SELECTED CELL VARIANT.
       Now depending on your requirement change this attribute to any of the VARIANT KEY defined for cell variants. 
    loop at itab into wa.
          if 'YOUR CONDITION'.
            wa-cellvar = 'VAR1'.                 "cellvar is the attribute which is bound to SELECTED CELL VARIANT
            else.                                          " of table column
              wa-cellvar = 'VAR2'.                 " VAR1 and VAr2 are the variant keys of cellvariants
              endif.
              modify itab from wa.
          endloop.
    Hope this solves your problem.

  • Setting new cell variant for an alv table column

    Hi,
    I want to set a new cell variant for a column. Therefore I did the following steps:
    1. Create an object of CL_SALV_WD_CV_STANDARD
    2. SET_KEY( 'CELLVAR1 )
    3. set_cell_design([..]-goodvalue_medium )
    4. SET_EDITOR( lr_alv_input_field )
    After that I added the cell variant to the column by using the method "add_cell_variant".
    The last step is to call method SET_SELECTED_CELL_VARIANT.
    I checked my program by using get_selected_cell_variant( ) and the return string was okay.
    But when the table is displayed, the new cell variant isn't working. I defined an input field as the cell editor for my new cell variant but when the table is shown, it is just text - no input possible. In addition to that the selected cell design (goodvalue_medium , step 3) isn't working. So I think the cell variant is not used.
    Can you help me?
    Thanks & Regards,
    Hendrik

    Hi
    I wonder if you can help me please, I too am having issues implementing ALV cell changes in WDA?
    I am basically trying to dynamically change the individual color of a cell (not the entire column or row) dependant on certain criteria. I apologies but find that you are the closest resource for any potential information. Please see screen shot below.
    Currently my code is as follows:
    see: www.picasaweb.google.co.uk/dave.alexander69/Pictures#5244416971466907938
    data: lr_cv TYPE REF TO cl_salv_wd_cv_standard.
    loop at table 1 row data
            loop at table columns
              for the date columns only...
              IF <fs_column>-id(4) = 'CELL'.
               get and set column header dates from select option user input - done
                loop at table 2 row data (table 2 contains date ranges for row concerned)
                  MOVE: ls_zdata-variance TO lv_variance.
                  method 1 - as in sap press WD4A -:
                  lr_cv = cl_wd_table_standard_cell=>new_table_standard_cell(
                                                     view        = view
                                                    variant_key = lv_variance ).
                 as mentioned...
                  CREATE OBJECT lr_cv.
                  lr_cv->set_key( 'VARIANCE' ).
                  lr_cv->set_cell_design( '09' ).
                  lr_cv->set_editor( lr_input_field ).
                  lr_column->add_cell_variant( lr_cv ).
                  lr_column->set_cell_editor( lr_input_field ).
                  lr_column->set_sel_cell_variant_fieldname( 'VARIANCE' ).
                  lr_column->set_cell_design_fieldname( value = 'COLOR_CELL' ).
                  lr_field = lr_table->if_salv_wd_field_settings~get_field( <fs_column>-id ).
                  lr_field->if_salv_wd_sort~set_sort_allowed( abap_false ).
                  the only way I get cell coloring to work - but this is for entire column?
                  ls_zdata-color_cell = cl_wd_table_standard_cell=>e_cell_design-one.
                  MODIFY lt_zdata FROM ls_zdata..
                ENDLOOP.
              ENDIF.
              IF <fs_column>-id = 'COLOR_CELL'.
                CALL METHOD lr_column->set_visible( EXPORTING value = '00' ).
              ENDIF.
            ENDLOOP
          ENDLOOP.
    As you see I am in the dark a bit regarding cell variants and wonder if you can point me in a better direction.
    Many thanks for any help,
    Dave Alexander

  • CELL VARIANT

    Hi Experts,
    Could you provide me detailed information on how to use the cell variants in a normal table in Webdynpro ABAP (using the cell variants to make a read-only field as input field/dropdown field on the click of a button).
    Thanks in Advance,
    Mirza.

    Hi Mirza,
    Please go through this excellent [blog|https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/f0e7461d-5e6c-2b10-dda9-9e99df4d136d] by Suman Kumar in which he explains usage of cell variants to make the cells of a column as checkboxes or textviews dynamically.
    Regards,
    Uday

  • Enhancing a standard component - Table Cell Variant

    Hi Forum,
    I am trying to enhance the standard WD component /SAPSRM/WDC_UI_SC_DOTC_BD view V_SC_DOTC_BASIC in SRM 7.0 .
    The requierment that for certain condition the Quantity cell in a row should be read only.
    Carried out the following steps:
    1. Created an enhancement
    2. In the standard table column ITEMS_TABLE_QUANTITY  [Columns] , removed the standard inputfield.
    3. Added two cell variants ZITEMS_TABLE_QUANTITY_CV1  [CellVariants]  and ZITEMS_TABLE_QUANTITY_CV2  [CellVariants]  first one contans a text view and second contains inputfield. Variant key for first one is DISPLAY and for second one is EDITABLE.
    4. Enhanced the method WDDOMODIFYVIEW with below code:
    **Read the ITEMS table
      DATA lo_nd_items TYPE REF TO if_wd_context_node.
      DATA lt_items TYPE wd_this->elements_items.
      DATA ls_item LIKE LINE OF lt_items.
      DATA lo_el_context TYPE REF TO if_wd_context_element.
      DATA ls_context TYPE wd_this->element_context.
      DATA lv_disable_quantity TYPE wd_this->element_context-enable_quantity.
      DATA lr_table_column TYPE REF TO cl_wd_table_column.
    ** navigate from <CONTEXT> to <ITEMS> via lead selection
      lo_nd_items = wd_context->path_get_node( path = `COMP_CONTEXT.ITEMS` ).
      lo_nd_items->get_static_attributes_table( IMPORTING table = lt_items ).
      lr_table_column ?= view->get_element( 'ITEMS_TABLE_QUANTITY' ).
      LOOP AT lt_items INTO ls_item .
        IF  ls_item-catalogid EQ 'VEP_Staples_D0'.
          lr_table_column->set_selected_cell_variant( value = 'DISPLAY' ).
        ELSE.
          lr_table_column->set_selected_cell_variant( value = 'EDITABLE' ).
        ENDIF.
      ENDLOOP.
    But even after the condition is true ALL cell i.e. the complete column is DISABLED or when the condition is false the COMPLETE column is enabled instead of enabling disabling ONLY THE SPECIFIC CELL.
    Is there a problem with the code in WDDOMODIFYVIEW or something else?
    Thanks,
    Anubhav

    Hi  Saravanan
    Under ITEMS node I added one more Node(cv_quantity) and one attribute(cell_variant_quantity) with in this node.
    And code in WDDOMODIFYVIEW :
    DATA lo_nd_items TYPE REF TO if_wd_context_node.
      DATA lt_items TYPE wd_this->elements_items.
      DATA ls_item LIKE LINE OF lt_items.
      DATA lo_el_context TYPE REF TO if_wd_context_element.
      DATA ls_context TYPE wd_this->element_context.
      DATA lr_table_column TYPE REF TO cl_wd_table_column.
    ** navigate from <CONTEXT> to <ITEMS> via lead selection
      lo_nd_items = wd_context->path_get_node( path = `COMP_CONTEXT.ITEMS` ).
      lo_nd_items->get_static_attributes_table( IMPORTING table = lt_items ).
      lr_table_column ?= view->get_element( 'ITEMS_TABLE_QUANTITY' ).
      DATA lo_nd_cv_quantity TYPE REF TO if_wd_context_node.
      DATA lo_el_cv_quantity TYPE REF TO if_wd_context_element.
      DATA ls_cv_quantity TYPE wd_this->element_cv_quantity.
    IF first_time EQ abap_true.
      lr_table_column->set_selected_cell_variant( value = 'EDITABLE' ).<--Initially ALL cells shoud be editable
    ELSE.
      lr_table_column->bind_selected_cell_variant( path = 'COMP_CONTEXT.ITEMS.CV_QUANTITY.CELL_VARIANT_QUANTITY' )  .
    * navigate from <CONTEXT> to <CV_QUANTITY> via lead selection
      lo_nd_cv_quantity = wd_context->path_get_node( path = `COMP_CONTEXT.ITEMS.CV_QUANTITY` ).
      IF lo_nd_cv_quantity is BOUND.
      lo_el_cv_quantity = lo_nd_cv_quantity->get_element( ).
          LOOP AT lt_items INTO ls_item .
            IF  ls_item-catalogid EQ 'VEP_Staples_D0' AND ls_item-number_int IS NOT INITIAL AND ls_item-description IS NOT INITIAL.
              lo_el_cv_quantity->set_attribute(
                                                name =  `CELL_VARIANT_QUANTITY`
                                                value = 'DISPLAY' ).
            ELSEIF ls_item-catalogid NE 'VEP_Staples_D0' OR ( ls_item-number_int  IS INITIAL AND ls_item-description IS INITIAL ) ."If the condition is not satisfied OR no item is added to that line
              lo_el_cv_quantity->set_attribute(
                                                name =  `CELL_VARIANT_QUANTITY`
                                                value = 'EDITABLE' ).
            ENDIF.
          ENDLOOP.
    ENDIF.
    ENDIF.
    Now If I add an item that DO NOT satisfy the comdition to be read only, for that row the quantity is enabled but for all the rows below it quantity cells are DISABLED.
    Hope my issue is clear?
    Thanks a lot,
    Anubhav

  • Example ---Defining Cell Variants: TableSingleMarkableCell-Getting error

    Hi All,
          We are trying an example of cell variant concept of table as given in NetWeaver help. But after deploying we are getting folllowing error. Please guide me.
    <b>Create a value attribute attributePointer, switch to the Properties, click … for the property type, and select the Java Simple Type. Enter com.sap.tc.webdynpro.progmodel.api.IWDAttributePointer and confirm with Ok</b>---
    I am not able to get this type..I have chosen ---com.sap.ide.webdynpro.uielementdefinitions.AttributePointer
    Thanks in Advance,
    Gangadhar.
    <b>Error we are getting is</b>  
    java.lang.NoClassDefFoundError: com/sap/tc/webdynpro/clientserver/uielib/standard/api/IWDAbstractTableColumn
         at java.lang.Class.getDeclaredConstructors0(Native Method)
         at java.lang.Class.privateGetDeclaredConstructors(Class.java:1618)
         at java.lang.Class.getConstructors(Class.java:865)
         at com.sap.tc.webdynpro.progmodel.generation.ControllerHelper.createDelegate(ControllerHelper.java:68)
         at com.sap.tc.webdynpro.progmodel.generation.DelegatingView.<init>(DelegatingView.java:41)
         at com.sap.tc.webdynpro.progmodel.view.ViewManager.createUninitializedView(ViewManager.java:486)
         at com.sap.tc.webdynpro.progmodel.view.ViewManager.getView(ViewManager.java:523)
         at com.sap.tc.webdynpro.progmodel.view.ViewManager.bindRoot(ViewManager.java:421)
         at com.sap.tc.webdynpro.progmodel.view.ViewManager.init(ViewManager.java:130)
         at com.sap.tc.webdynpro.progmodel.view.InterfaceView.initController(InterfaceView.java:41)
         at com.sap.tc.webdynpro.progmodel.controller.Controller.init(Controller.java:200)
         at com.sap.tc.webdynpro.clientserver.cal.ClientComponent.displayToplevelComponent(ClientComponent.java:135)
         at com.sap.tc.webdynpro.clientserver.cal.ClientApplication.init(ClientApplication.java:404)
         at com.sap.tc.webdynpro.clientserver.task.WebDynproMainTask.execute(WebDynproMainTask.java:618)
         at com.sap.tc.webdynpro.clientserver.cal.AbstractClient.executeTasks(AbstractClient.java:59)
         at com.sap.tc.webdynpro.clientserver.cal.ClientManager.doProcessing(ClientManager.java:251)
         at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doWebDynproProcessing(DispatcherServlet.java:154)
         at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doContent(DispatcherServlet.java:116)
         at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doGet(DispatcherServlet.java:48)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
         at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:401)
         at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:266)
         at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:387)
         at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:365)
         at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:944)
         at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:266)
         at com.sap.engine.services.httpserver.server.Client.handle(Client.java:95)
         at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:160)
         at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33)
         at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)
         at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)
         at java.security.AccessController.doPrivileged(Native Method)
         at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:100)
         at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:170)
    <b>Example we are trying is</b>
    You need the option to select a single cell to provide a value help for individual cells, for example.
    The interface TableSingleMarkableCell allows you to group cell variants in any way as you like and to make a single cell selectable in this group. The following example shows how to proceed if you want to implement a selection of a single cell from an entire table.
    Prerequisites
    You have created an applicaton with a component and view in your Web Dynpro project.
    Procedure
    Creating the Context
           1.      Create a value node TableNode for the data of the table and insert three value attributes of the type String for the table columns.
           2.      Create a value attribute selectedCellVariant of the type String in the TableNode.
           3.      Create a value attribute attributePointer, switch to the Properties, click … for the property type, and select the Java Simple Type. Enter com.sap.tc.webdynpro.progmodel.api.IWDAttributePointer and confirm with Ok.
    Creating the View
           1.      Open the context menu in the Outline, select Apply Template and then Table. In the subsequent dialog box from the context, select three attributes for the columns (col1, col2, col3). Confirm by choosing Finish
           2.      Set the property selectionMode of the table to none.
    Repeat the steps for each column.
           3.      Highlight the column and open the context menu. Select Insert Cell Variant, TableSingleMarkableCell and confirm with Finish.
           4.      Enter the same value for each TableSingleMarkableCell for the property variantKey - for example, variant1
           5.      Insert a cell editor of the type TextView in each TableSingleMarkableCell.
    Binding the UI Elements
           1.      Bind the text property of each TextView to the column in which the property is contained.
           2.      Bind the attributeToMarkproperty of the corresponding TableSingleMarkableCell to the column in which the element is contained.
           3.      Bind the selectedCellVariantproperty of each TableColumn to the context attribute selectedCellVariant.
           4.      Add the following source code to the wdDoInit method.
    wdDoInit()
    1
    2
    3
    IPrivateUseSingleMarkableCellsView.ItableNodeElement elem;
          int count = 10;
    // Fill dummy data
         for(int i=0; i<count; i++) {
             elem = wdContext.nodeTableNode().createTableNodeElement();
             wdContext.nodeTableNode().addElement(elem);
             elem.setCol1(“1.” + i);
             elem.setCol2(“2.” + i);
             elem.setCol3(“3.” + i);
    // set TableSingleMarkableCell as a variant for the table
             elem.setSelectedCellVariant(“variant1”);
                For each element that is created in the for loop and is then added, the
                TableSingle MarkableCell is set as a cell variant in row 3.
           5.      Add the following source code to the wdDoModifyView method.
    wdDoModifyView()
    IWDAttributeInfo markedDataInfo = wdContext.currentContextElement().getAttributePointer(“attributePointer”).getAttributeInfo();
                            ((IWDTableSingleMarkableCell) view.getElement(“TableSingleMarkableCell1”)).bindMarkedData(markedDataInfo);
                            ((IWDTableSingleMarkableCell) view.getElement(“TableSingleMarkableCell2”)).bindMarkedData(markedDataInfo);
         1.                          ((IWDTableSingleMarkableCell) view.getElement(“TableSingleMarkableCell3”)).bindMarkedData(markedDataInfo);
    The current AttributeInfo is now retrieved at every change of the view and is bound to the context using the markedDataproperty.
    Result
    Each single cell can be selected separately. You can define an action and in its method, you can determine the coordinates of the currently selected cell using the following code:
    IWDAttributePointer attPointer = wdContext.currentContextElement().getAttributePointer();
    Message was edited by:
            Gangadharayya Hiremath

    Hi Gangadhar,
    at first: you are right: you have to choose
    com.sap.ide.webdynpro.uielementdefinitions.AttributePointer
    and not the other one. I already updated the documentation for this.
    In which SP are you working?
    Kind Regards
    Stefanie

  • Screen variant assignment for a Z Program

    Hi all ,
    I had created a screen  variant .
    I want to assign the screen variant assignment for a Z Program.
    how do i do that.
    Thanks
    ksr

    follow the link, first click hyperlink screen variants, next click hyperlink maintenance
    http://help.sap.com/erp2005_ehp_04/helpdata/EN/67/232037ebf1cc09e10000009b38f889/frameset.htm

  • Use of Cell Variant for a normal table

    Hi Experts,
    I have a requirement in a normal table where a row is first in read-only mode, then on click of edit button (given on that row),
    the row should become editable and also edit button should become invisible and two more buttons update/cancel have to be visible. How to achieve this using a cell variant for this normal table.
    A detailed reply would be appreciated.
    Thanks in Advance,
    Mirza Hyder.

    Hi Mirza,
    Cell variant property is used to chenge the cell property not for other.That means in one cell you want checkbox and in other cell you want textview like this you can change the property of cell as you want.
    Test this standard program WDR_TEST_TABLE in that test view cell varint for your understanding.
    Coming to your requirement.You can do in this way.
    Check in the below thread in that i gave code to make the entire row is editable when you click on the lead selection of row.I gave code for ALV.I hope that code is use ful for you.
    How to make all columns of alv editable
    To make tool bar buttons disable and enable:Write your logic in method handler of lead selection event like change the visible property of button to none.
    Note: In the event handler method you dont get reference of view.You only get reference of view in WDDOMODIFYVIEW only so take a global variable of type ref to if_wd_view and populate that global variable in method WDODIFYVIEW.So that you can access any view element in any method.
    For cell variant in ALV check this Article written by me.
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/f0e7461d-5e6c-2b10-dda9-9e99df4d136d

  • Dynamic cell associated value as query string parameter in custom hyperlink property of KPI of scorecard in PPS SP2013

    Can we pass dynamic cell associated value [of scorecard] as query string parameter in custom hyperlink property of KPI of scorecard in PPS SP2013 , so that we can pass those values to another page 
    How to get those cell associated values and set these dynamic value as query string parameter in custom hyperlink property of KPI of scorecard in performance point services in sharepoint 2013

     I could somehow link to the table name, but that can be changed...  Any ideas?
    Not sure if this will help or not but maybe a little from several areas might point you in the right direction.
    If you are concerned about users changing the table name then you can define a name to reference the table and then if the user changes the table name then the Refers to automatically changes to the new table reference but your defined name remains the same.
    However, if users want to break a system even when you think you have it bullet proof the users come along with armour piercing bullets.
    Example:
    Insert a table (say Table1)
    Go to Define a name and insert a name of choice (eg.  ForMyTab1)
    Then click the icon at the right of the Refers to field and select the entire table including the column headers and it will automatically insert something like the following in the Refers to field.
    =Table1[#All]
    Now if a user changes the table name then Table1 will also automatically change.
    Example code to to reference the table in VBA.
    Sub Test()
        Dim wsSht1 As Worksheet
        Dim lstObj1 As ListObject
        Set wsSht1 = Worksheets("Sheet1")
        Set lstObj1 = wsSht1.ListObjects(Range("ForMyTab1").ListObject.Name)
        MsgBox lstObj1.Name
    End Sub
    Regards, OssieMac

  • Dynamic VLAN/SSID assignment using 4402/MS IAS

    Greetings,
    In short we have a WLC4402 (50 AP license) and approx 30 1252s LAPs in place. Right now we have three VLANs/SSIDs in place - one for admin, one for teachers and one for students. The WLC uses a MS Windows 2003 server running IAS for PEAP authentication. The clients are Windows XP, the SSID is entered manually based on "pre-designation" of the laptop's "type" (either admin, teacher or student).
    This is working fine. However more and more frequently our users have been "sharing" laptops so a student may need to use a teacher's laptop and vice-versa. In short we would like to use dynamic VLAN/SSID assignment so that if a student does have a teacher's laptop the "student" VLAN/SSID would be assigned to them when log in (and the proper ACLs, QoS policies, etc would be applied)
    We have found documentation on how to perform this with an ACS but is there anything available for this configuration with a MS IAS server.
    Any input/information would be greatly appreciated.
    Joe

    Shaun,
    My LAG - etherchannel interface
    interface Port-channel8
    description WLC-portchannel
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,3,24-26
    switchport mode trunk
    end
    My 2 WLC Fiber ports:
    Current configuration : 382 bytes
    interface GigabitEthernet7/47
    description CiscoWLC-LAG-Ports
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,3,24-26
    switchport mode trunk
    service-policy output autoqos-voip-policy
    qos trust cos
    auto qos voip trust
    tx-queue 3
    bandwidth percent 33
    priority high
    shape percent 33
    spanning-tree bpdufilter enable
    channel-group 8 mode on
    end
    2200-3A#sh run int g7/48
    Building configuration...
    Current configuration : 382 bytes
    interface GigabitEthernet7/48
    description CiscoWLC-LAG-Ports
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,3,24-26
    switchport mode trunk
    service-policy output autoqos-voip-policy
    qos trust cos
    auto qos voip trust
    tx-queue 3
    bandwidth percent 33
    priority high
    shape percent 33
    spanning-tree bpdufilter enable
    channel-group 8 mode on
    end
    I use vl1 for ap mgmt, vl3 for hotspot, and vl24-26 for WPA2 clients and wireless voip devices.
    One of my AP switchports on the same switch. I let the trunk port to the AP carry a range of vlan's, and then a manage the vlans assigned to clients with IAS and the WLC.
    interface FastEthernet4/48
    description AP-PoE
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1-1004
    switchport mode trunk
    service-policy output autoqos-voip-policy
    qos trust cos
    auto qos voip trust
    tx-queue 3
    bandwidth percent 33
    priority high
    shape percent 33
    end
    Jim

  • Dynamic date variant

    Hi Gurus,
    I've a dynamic system date variant for my program, which runs in background. I have no issue with variant, it works fine. But when I went to job log to check the old jobs that has dynamic date variant, it always refer to current system date. Anybody can suggest me how to fix it to show the actual variant at the time of job run?
    Regards, Raju.

    The dynamic date overwrites the value that it was saved with at the time of processing.  What you see when you display it is the value at the time it was saved (the non-dynamic value).  There is no way to see the value at the time it was run.  At least not that I know.
    You can however compute it if you know that the variant hasn't been changed since it was run.
    Neal

  • Dynamic Date Variant in SAP ver 3.1

    How to create a dynamic date variant in SAP ver 3.1 ?

    Hi,
    I guess that you know how manage dynamic dates in a variant. (Please, tell me if you need help about it)
    You can try with two DATUM type fields in the ABAP program. Fix the first one with a fixed date u201901.01.2009u2019 and the second one will be fixed with the dynamic date u2018Current Dateu2019
    Regards,
    OLA

  • Dynamic transaction variant

    Hi gurus,
       Can we create dynamic transaction variant based upon screen value if yes wht is the procedure, my scenario is like i have to show sale order header condition data based upon sale order type in VA02, that is if sale order is of type A then is should not display pricing condition tab at header level and if of order type B then show the pricing data to same user.
    Mandy

    NOT POSSIBLE.

  • No Hierarchy Variant assigned to FM Area Test

    Hi...
    I am facing problem at the time of creating Budget using T.Code: FMBB
    System gives Error: "No Hierarchy Variant assigned to FM Area Test"
    After that I have gone through configuration & trying to assign Hierarchy variant to FM Area,
    Fiscal Year: 2010
    Hierarchy Variant: THV,
    then  it will show message that -  Here You are only allowed to enter Fiscal Year "0000".
    After that I changed fiscal year 0000 & trying to assign hierarchy variant,
    then it shows message that 'Hierarchy variant THV is incomplete with regard to fiscal year 0000".
    Now I am unable to post budget initial Entry.
    Kindly suggest the possible solutions for this.
    Regards
    Moonoo

    Hi,
    Please refer below mentioned link for Hierarchy Variants in the Fiscal Year :
    http://help.sap.com/saphelp_erp2004/helpdata/en/dd/a0193ca1f5e713e10000000a114084/content.htm
    Regards,
    Pramitha.

Maybe you are looking for