Eigrp variance question

hi all
I am trying some variance commands. I have 2 routers connected to each other using 2 serial links
R1=====R2
I change the delay  on my s1/1 interface to 500.
here is the output of show ipv6 eigrp topology all-links
P ::/0, 1 successors, FD is 2560128256, serno 71
        via FE80::C801:8FF:FECC:0 (2560128256/2560000256), Serial1/1
        via FE80::C801:8FF:FECC:0 (2560512256/2560000256), Serial1/0
when I look at show ipv6 route I get this output:
EX  ::/0 [170/2560128256]
     via FE80::C801:8FF:FECC:0, Serial1/1
As expected It would only use the link to s1/1, I wanted to try unequal cost load-balancing so i configured a variance of 2.
when i do  a show ipv6 route it  was not load balancing, when i configured a variance of 3, it did load balancing. Could someone please explain why didnt variance 2 worked.
EX  ::/0 [170/2560128256]
     via FE80::C801:8FF:FECC:0, Serial1/1
     via FE80::C801:8FF:FECC:0, Serial1/0
thanks and regards,
jonathan

Jonathan,
I believe you are experiencing a simple integer overflow bug.
With variance set to 2, the router looks at all pahs through feasible successors whose metric is in the interval [Best Metric, 2 x Best Metric].
The problem is that your current best metric is already quite high - it is 2,560,128,256. When you take this number and multiply it by two, a normal calculator will produce the result of 5,120,256,512. However, in IOS, it appears that the result of this multiplication is being stored in an unsigned integer variable which is only 4B long and is unable to hold such a large number. So the result simply wraps over - the integer variable overflows, and in the end, it holds a value of (2,560,128,256 * 2) MOD 0x100000000 = 825,289,216. Notice that this resulting value is even lower than your current best metric, and naturally, the second route with its slightly elevated metric has no chance of fitting into the variance interval. That is why the variance of 2 did not work for you.
With variance set to 3, the multiplication result overflows again but now, the resulting value will be (2,560,128,256 * 3) MOD 0x100000000 = 3,385,417,472. In this case, it turns out that the resulting value - while not being a true triple of the current best metric - is still higher than the current best metric and also higher than the metric of your second route, so in this case, it passes the variance test and is installed into the routing table. Note that this is just a coincidence that the overflowed value was still larger than your current feasible successor route's metric.
If you test various different variance values, you will see that variance 4 will not work, variance 5 will work, variance 6 will not work, variance 7 will not work, variance 8 will work, etc. This all is caused by the fact that the IOS does not check for integer overflow when calculating the upper bound of the interval of admissible path metrics, and the resulting value may not fit into the variable, causing it to overflow.
Best regards,
Peter

Similar Messages

  • Router EIGRP updates question

    Router A
    interface eth 0
    ip address 172.30.0.1 255.255.255.128
    router eigrp 4444
    network 172.30.1.0
    Router B
    interface eth0
    ip address 172.30.2.1 255.255.255.128
    router eigrp 4444
    network 172.30.1.0
    MAIN ROUTER
    interface eth0
    ip address 172.30.1.1 255.255.255.0
    router eigrp 4444
    network 172.30.0.0
    Router A users should reach ONLY Main Router users.
    Router B users should reach ONLY Main Router users.
    based on the EIGRP network in Router A & B, they can reach ONLY Main Router users, where as Main Router can reach both.
    am i right? if not please correct me.

    Hello,
    in addition to Abd's post, keep in mind that with EIGRP, you are not actually advertising networks, you are advertising interfaces. So, when you say:
    network 172.30.0.0
    you tell the EIGRP process to let all interfaces that have an IP address within the 172.30.0.0/16 range participate in EIGRP. In order to avoid confusion, you could advertise just the exact interface addresses as following:
    Router A
    interface eth 0
    ip address 172.30.0.1 255.255.255.128
    router eigrp 4444
    network 172.30.0.1 0.0.0.0
    Router B
    interface eth0
    ip address 172.30.2.1 255.255.255.128
    router eigrp 4444
    network 172.30.2.1 0.0.0.0
    MAIN ROUTER
    interface eth0
    ip address 172.30.1.1 255.255.255.0
    router eigrp 4444
    network 172.30.1.1 0.0.0.0
    If you want both Router A and Router B to reach only the main router and not each other, you could configure a distribute list for the interfaces on Router A and Router B as following:
    Router A
    interface Serial0
    description connection to Main
    router eigrp 444
    distribute-list 1 out Serial0
    access-list 1 deny 172.30.2.1 0.0.0.0
    access-list 1 permit any
    Router B
    interface Serial0
    description connection to Main
    router eigrp 444
    distribute-list 1 out Serial0
    access-list 1 deny 172.30.0.1 0.0.0.0
    access-list 1 permit any
    Does that make sense ?
    Regards,
    GNT

  • EIGRP Metric and UCLB Doc

    Team,
    http://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13677-19.html
    I somehow find the doc for EIGRP unequal cost load balancing a little bit misleading because it shows that the cost to reach network X is additive to demonstrate EIGRP variance. The only time that the cost will be additive is if only delay is used along the path to network X. However, there is no mention about delay solely being used as the metric in the doc which might lead one to think that the metric for a certain route is FD = cost to neighbor + neighbor's RD.
    Thoughts please. Thanks.

    Team,
    http://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/13677-19.html
    I somehow find the doc for EIGRP unequal cost load balancing a little bit misleading because it shows that the cost to reach network X is additive to demonstrate EIGRP variance. The only time that the cost will be additive is if only delay is used along the path to network X. However, there is no mention about delay solely being used as the metric in the doc which might lead one to think that the metric for a certain route is FD = cost to neighbor + neighbor's RD.
    Thoughts please. Thanks.

  • Is there some simple PfR documentation out there?

    We are not a large organization by any means:  we have an MPLS network with the HQ and 8 branch offices.  We have a backup MPLS via another supplier.
    In the past we had a 6513 at the core of our network and we used a combination of EIGRP with the variance command plus PBR to accomplish the following:    we prefered one provider for certain mission critical traffic, unless that provider was down then all traffic went over the other link.  As long as both links were up, non-mission critical traffc was shipped proportionately over the backup link and the remaining bandwidth of the prefered link.  Ugly to look at, but simple to implement and worked like a charm.
    Now, we bought expensive Nexus equipment to replace the 6513 and, well, EIGRP variance command is no longer part of the set. 
    I'm left with PfR on the two routers which is infinately more complex than what we need.
    Every document  I read about configuring OER/PfR is more essoteric than the one before it.  It's not that there isn't good stuff out there, but getting to the heart of the matter "how do I configure a simple set up" is not to be had.  The info I need to get to is burried under features, design, and marketing hype.
    Is there anything out there that shows a very simple set up?  I should have thought a simple access-list type definition for my prefered networks pointing them to provider A plus some way to ration out the remaining packets would not take so long to ferret out but here I am weeks later still reading and not making much progress.
    To date I have GNS3 set up and PfR is "enabled and active" on the simulated links.  I just need to translate my once-upon-a-time working ACL/PBR configuration into the PfR syntax.  It's harder than it sounds.
    Thanks for any links or examples.

    Both these post links contain very helpful info and I've seen some other posts besides that do help but, still running into problem with this. Steve you touched on this in a conversation with our SE and myself on a conference call.
    Here's the situation. I need...am MANDATED in fact, to prefer one provider for certain types of traffic, then load balance based on available bandwidth the remaining traffic.
    Item one is easy: preferred link groups. But everything I read says that function  is mutually exclusive with load balancing based on bandwidth. So what am I to do? Tell my employer the million dollar investment in Nexus was a mistake?
    I hate to sound so frustrated but this PfR solution, while useful to large shops and ISP's, is convoluted to say the least, and overkill for a shop that has a fairly static amount of traffic over an two MPLS networks that simply aren't impacted by many (if any) external factors. Life was fine with EIGRP, variance, and a small number of PBR statements. While that wasn't exactly 'load balanced' perfectly, it was close enough to satisfy the requirements.  It worked well for 5 years and because of how EIGRP worked, failure of any link was undetected by end users.  Simple, clean, effective.
    And here's an unrelated question that has plagued me throughout my studies of PfR:  if I have a link that is suffering performance degredation do I really need both passive and active probes adding traffic to that link trying to determine if/when it's time to fall back to it?  Sounds kind of like when I'm trying to fix a problem and my boss is constantly over my shoulder saying, "is it fixed yet, is it fixed yet?"!  How exactly is this helping?
    I really need variance back.  without it, I'm not seeing anyway to meet my mandate. 

  • Interview question: EIGRP and Grandmother

    Hi all.
    A question was asked to me a couple of months ago during an interview. I'm quite curious as to how others would respond to it. Here it is.
    "If I was your grandmother, how would you make me understand EIGRP?"
    I know that when the interviewer says "make me understand", it doesn't mean you should go deep into the details of the IGP. Maybe just a bird's eyeview. But still, makes you think.

    I guess I'd have to relate it to something my grandmother would understand.  I know she would be lost as soon as I said IP.
    I would probably relate to driving in her car to get to the grocery store.  Imagine if it every corner there was a traffic guard directing traffic, and every traffic guard had a map with the fastest way to get to her destination in his hand.  When she gets to that intersection the traffic guard tells her which way to go.  As long as all the roads are working the path she takes to the store pretty much remains the same.  Now imagine that all of these guards have walkie-talkies in their hands, and if there is an accident on a road, and that road is closed that guard announces to all the other traffic guards that that road is closed and and the traffic guards are quickly able to give you an alternate route before you get stuck in traffic.  The good thing about EIGRP is that these updates to traffic patterns are only sent periodically instead of all the time, this greatly reduces the amount of communication over the walkie-talkies, making it much easier for other communication to pass over them as well, while keeping everyone updated on what the best path to take to the store is.
    I like trying to use analogies in my explanations to my end users.  It puts the context of your discussion into terms that they can relate to and understand the general concept of.  An interviewer might be asking you to do this to show, that you not only can regurgitate the answer that they're looking for, but understand it well enough to break it down into simpler terms that can be communicated to someone without technical knowledge that can still be understood.
    I report to the VP of Finance/CFO here at my organization.  I find myself constantly having break down complicated terms into something that he can understand in order to get budget approval for projects.  I'm guessing your interviewer wanted to be sure you had the skills to be able to communicate complex IT concepts with someone who may not understand the "dictionary" explanation?

  • Basic question on settlment of production order variance to FI

    Hi Experts,
    I know im asking a dumb question. I really understood the concept of variance generated in production order, to say it in simple words the difference between debits and credits. But when it comes back to FI im confused and lost, when we settle the production order variance, the following entry is posted.
    Production variance a/c                                      100
    COGM var a/c or Mfg ouput var a/c                                    100
    Now my question here is, there is a debit and credit of variance for 100, which is equal to zero, so there is no net impact of variance in my P&L, the variance is not accounted in FI at all. How is the production order variance accounted in FI?
    Could somebody please answer my question or provide me with some clarification. I know either i would have misunderstood the concept or something is wrong or may be i need to look over the entire postings.
    appreciate for your time spent.
    Thanks in advance,
    Best Regards,
    sk

    Hi SK,
    The net impact of settlement of production order on P & L is zero. The reason is actual consumption to that particular production order is  booked to P & L at the moment the activities are confirmed over that order.
    Variance is difference between Std cost of Goods recepit and actual consumption. Suppose actual material consumption is 100 Rs and your std cost of goods with which production order is credited is Rs 90. The diff is Rs 10. Now if you again book this 10 Rs to P & L as negative being excess and giving second effect NOT to P & L, you will not come to know what is actual consumption and the picture will be wrong. There will be mismatch between Actual physical consumption and what is booked to P & L.Hence the debit and credit is given to P & L to nullify the effect of variance.
    Truely speaking, the variance account is to be observed to  verify the actual consumption against standards and to correct BOM and Routing and/or to take necessary action for excess or less consumption.
    Hope the matter is clear.
    Makrand

  • Question about EIGRP's feasible successor

    Hi,
    I read article "Who's Afraid of DUAL-3-SIA?" on http://www.cisco.com/en/US/partner/about/ac123/ac114/ac173/Q2-05/tech_routing.html
    there is a sample to explain a new IOS feature.
    But I have a question about that sample,
    why Router C can't be Router A's feasible successor?
    IF C is A's feasible successor, A can declare C as the alternate route as soon as receive B's query.
    Am I misunderstanding the concept of feasible successor? can anybody give me some hint?
    thank you all!
    Regards,
    sha

    HI Sha,
    There is no mention of any values for bandwidth and load in the topology in that link.
    What I see that the link between router A to Router B is gigabit which means the bandwidth will be gbps. Now the link between Router A to Router C is only T1 which will be 1.54 MBPS. Much difference.
    Now when Eigrp will calculate the metric the best metric will be from router C and that will become the best path. Now it will also check the reported distance from router C. If the reported distance from Router C will be more then the best metric which is been calculated from Router B it will never become feasible succ.
    In short to become the feasilbe succ its reported dist should be less then the Feasible distance.
    This link will give a better pic.
    http://www.cisco.com/warp/customer/103/eigrp-toc.html#eigrpmetrics
    HTH
    Ankur

  • EIGRP auto summary question

                       Hi all,
    I have question about EIGRP auto summary.
    Lets say R1 is connected to R2 and R2 is connected to R3.
    R2 and R3 have auto summ on by default.
    R1 has no auto summary configured.
    If R1 advertise about its Lan network 10.10.10.0/24
    Router EIGRP 100
    network 10.0.0.0
    no auto summary
    When router 10.10.10.0 reaches R3 will it be shown as or 10.0.0.0/8 classfull address  in R3s routing table?
    Thanks
    MAhesh

    Hello, it's been a few monts since you posted your question, but i fund it while preparing to ROUTE exam and i feel need to respond.
    Well I must say Mohamed i wrong. In your case R2 will NOT advertise summary route to R3.
    The official certification guide says:
    When a router has multiple working interfaces, and those interfaces use IP addresses in different classful networks, the router advertises a summary route for each classful network on interfaces attached to a different classful network.
    So learned routes are not subject of auto-summarization. They can still be summarized manually ofcourse.
    Firs of all - create a lab. Ok. I did it for you:
    10.10.10.0 - R1 - 192.168.12.x - R2 - 193.168.23.x - R3
    R1 does not summarize, R2 does.
    Lets see at R3:
    R3#sh ip route
    D    192.168.12.0/24 [90/307200] via 193.168.23.2, 00:42:30, FastEthernet0/0
         10.0.0.0/24 is subnetted, 1 subnets
    D       10.10.10.0 [90/332800] via 193.168.23.2, 00:42:30, FastEthernet0/0
    C    193.168.23.0/24 is directly connected, FastEthernet0/0
    See? No summary route. Let's do an experiment - let's add loopback interface on R2 with IP of 10.1.1.1 and check R3 again:
    R3#sh ip route
    D    192.168.12.0/24 [90/307200] via 193.168.23.2, 00:50:45, FastEthernet0/0
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    D       10.10.10.0/24 [90/332800] via 193.168.23.2, 00:50:45, FastEthernet0/0
    D       10.0.0.0/8 [90/409600] via 193.168.23.2, 00:00:35, FastEthernet0/0
    C    193.168.23.0/24 is directly connected, FastEthernet0/0
    Now we have a 10/8 network as R2 summarised 10.1.1.0/24 to a classfull boudary, but we can still see /24 network as well. Thats the freaky way the auto-summariazation works.
    You have to remember: auto-summary feature indeed works when a router advertises prefixes between major networks, but ONLY directly connected ones. It does not affect learned networks.

  • Native Multi-VRF-Lite Design with EIGRP Question

    Hello,
    we think about to implement a VRF-Lite design (no MPLS and MBGP) in our campus network (10,000 ports, 20x 6500Sup720, 400x L2-Switches). MPLS is from our point of view oversized for our requirements. We need only a segmentation from different departments. Our IGP is eigrp.
    In the latest IOS-Release for the cat6500 (12.2.18SXD) is finally a VRF-Lite support for EIGRP inside.
    We could test successful a design with different VRFs in our lab, the division workes fine. But we didn't found a way to implement shared service. These are in our case DHCP, DNS, InternerAccess and some others. We thought about a redistribution between our global EIGRP routing table and the EIGRP-vrf tables, but we didn't found a way to do this.
    How can we do this?
    Thanks

    Use a crossover cable to connect a port belonging to the global routing table to a port belonging to a VRF. This way you can leak EIGRP routes from the global routing table into the VRF (through that physical connection). The drawback is that you use 2 ports (that could instead be used for other things...).
    Another way to this, would be to use static routing; use ip route vrf VRF x.x.x.x m.m.m.m n.n.n.n global to allow traffic to go from the VRF into the global routing table.
    Hope that helps...

  • DMVPN Question on NHRP and EIGRP neighbor relations

    First of all thank you for your answer, in a DMVPN network, running EIGRP over GRE, will a spoke consider another spoke an EIGRP neighbor? or will it just consider the hub to be an EIGRP neighbor when it comes to sending/receiving eigrp queries/updates? given that in dmvpn setup one spoke can establish a direct tunnel with another spoke.

    If you are running EIGRP, under EIGRP type in
    no split-horizon eigrp ; where x is the as #.
    Also, if your dmvpn routers have default routes ie 0.0.0.0/0 pointing to the ISP on all routers that is ok. IF you have specific static routes for DMVPN hub public on DMVPN spoke router, you would also need to add a static route for the other dmvpn spoke public address on your first dmvpn spoke and vice versa. Hope this helps.

  • Question on passive serial sub interface EIGRP

                       Hi Everyone,
    I know how passive interface default works in EIGRP.
    I need to confirm below say we have
    se0/0/0
    no ip address
    se0/0/0.10
    ip address 192.168.50.1 x.x.x.x
    Router eigrp 100
    passive interface default
    no passive interface se0/0/0
    I do not have device to test this so need to confirm if i also need command
    no passive interface se0/0/0.10 or not?
    Regards
    Mahesh

    Mahesh
    I do not have any device that would allow me to test this either. But I believe that you need to specify the subinterface and not just the physical interface.
    HTH
    Rick

  • DMVPN Design Question - EIGRP or OSPF

    Hi,
    We are in the process of designing a DMVPN network, which will be used as a backup (over the Internet) to our MPLS WAN Network. Currently we are using EIGRP at central and remote site.
    If I select EIGRP as also the routing protocol for the DMVPN, then EIGRP will consider the MPLS WAN Routes as External (Since they are being redistributed through BGP from MPLS Core into our internal Core) and then DMVPN Routes will be preferred over MPLS WAN Routes. Is this understanding correct ?
    How can i correct this problem ? Using the 'distance eigrp ...' command ?
    Is there any advantage using OSPF as the routing protocol in DMVPN ? This won't solve the above problem but are there any inherent advantages of OSPF over EIGRP in DMVPN Design ?
    We have around 18 Sites that will be connected with no Spoke-Spoke functionality required.
    Thanks,
    Naman

    You really cannot use EIGRP effectively over the WAN. I was managing a 500 node DMVPN with a a redundant 6509 core. The results were unbelievable. The 1811's hanging off of the cores through the DMVPN's were crazy. Every time a change occurred, if one router lost its VPN connection, the EIGRP protocol would broadcast the changes to all of the cloud, meaning to all 499 EIGRP participants would have to be notified of the change. This was HUGE. OSPF has better NBMBA environments that you would use. Personally, you wouldn't have a choice. Using EIGRP with DMVPN's that are over 50 nodes are practically impossible. I did work around the issue and stabilized the network but knowing what I know now, definately OSPF.

  • Question a bout Ospf & eigrp

    Guys,
    I would like to have more over view to the following:-
    1- what is the exact functionality of (DR/BDR) on ospf tobology.
    2- what is the point of using (auto-summary) command on eigrp, and when we should use it?
    3- also I am alittle bit confused about using Ospf ABR type 3 LSA filtering with different areas, when should be applied?Is any difference between configuring normal OSPF comparing To ABR, what should I consider when configuring Type 3 ABR?
    Thanks

    Hi,
    1. One of the major reasons for the DR/BDR concept is to reduce unnecessary flooding. If there wasn't such a concept, each router on a LAN would have to have an adjacency with every other router on a LAN. For example, on a LAN with 10 routers, that would mean 45 adjacencies !! Using a DR/BDR, that same LAN now has only 17 adjacencies. Now, OSPF floods LSAs over adjacencies so the more of those you have, the greater the flooding traffic. And most of this would have been unnecessary since the routers would have already seen the LSAs from some other neighbor.
    2. This feature was more of a using in the days of classful routing, where you would not have wanted more specific routes of a classful network from leaking out of that network. These days, it is disabled by default and it should be kept that way !
    3. One application of this is when using stub (not totally) areas with multiple ABRs. In such a case, you could filter out some type-3 LSAs from being generated by one of the ABRs. The other ABR would still advertise them and so all traffic for these networks would exit out of this ABR. The ABR on which you did the filtering would still advertise the type-3 default so if the other ABR dies, all traffic will now exit out of this ABR.
    Pls do remember to rate the post..
    Paresh

  • Bgp-Eigrp-Bgp redistribution question

    Hi Experts,
    Just wish to ask if there is an option to retain the as-path information in eigrp when i redistribute from bgp to eigrp then to bgp?
    I recall coming across something similar to this before but I can't seem to remember it.
    Thanks in advance.

    Hello friend.
    No, you can't retain the AS-PATH when redistributing prefixes from BGP to EIGRP.
    What you CAN do though, is to add the AS-PATH you want when redistributing it BACK to BGP.
    You can do something like this:
    1 - Add a TAG when redistributing the BGP prefixes into EIGRP
    route-map SET_TAG permit 10
     set tag 100
    router eigrp 1
    redistribute bgp 100 metric 1 1 1 1 1 route-map SET_TAG
    2 - transform the TAG into an AS_PATH, when redistributing it BACK to BGP.
    route-map set-as-path-from-tag
    set as-path tag
    router bgp 100
    redistribute eigrp 1 route-map set-as-path-from-tag
    Got it ?
    I hope this helps you !
    cheers

  • Question on alerts and variances?

    Hi Friends
    1.Alerts in SUS. Is it possible in std or any badi is used in SRM 7.0
    2.Price variances in SUS.Is it possible in std or any badi is used in SRM 7.0
    Thanks
    Timothy

    1.Alerts in SUS - SUS provides standard functionality for generating the alert. The followings are link to the documentation. Additional documentation is available through IMG. You can also use BADI BBP_ALERTING for additional requirement.
    http://help.sap.com/saphelp_srm50/helpdata/en/42/c8aaddd9cc6bb3e10000000a1553f6/frameset.htm
    2.Price variances in SUS.Is it possible in std or any badi is used in SRM 7.0. - Price tolerance check is not available. May want to consider using BADI BBP_DOC_CHANGE_BADI to provide the validation.
    Revi

Maybe you are looking for

  • How to post multiple message using file adapter in XI2.0

    We have to post multiple IDOCS.We have scenario as below. We will have file structure like as shown below. VKORG,VTWEG,SPART,BSART,PARVW,PARTNER,BSTDK,MATNR,MENGE,VSART,BSTZD,POLINE,BSARK BE10;10;10;OR;SP;1000033;;M184-ISS01;2;G;131;0002; BE10;10;10;

  • Can't get Mic to Work

    New Arch on a 5 year old PC. I tested the mic input before I zapped the Windows that was on this machine and it was good. Now it has oss and output is perfect, but no matter what I do, I can't get the input to work. I tried two mics, both of which wo

  • Edited PDF Does Not Retain Fill Data on iPhone

    When I input data in the fill boxes on a form I created with Acrobat which has been sent to my iPhone, the text that was added in the fill forms does not stay on the document after emailing it to myself and opening it in my email preview. The data, h

  • Package does not exists

    Hai I want to use the package com.jscape.inet.ftp in my Java program. But when I imported it in my program and compiled , I got the error:- package com.jscape.inet.ftp does not exist Why? How can I use that package in my program? Any idea?

  • How to set display luminance to 80 cd ?

    Is there a way to set the brightness of the 27 Cinema Display to the recommended 80 candelas ?