External Calling

Hi I'm trying to enable external calls currently I can call internally and receive external however I want to be able to phone out on one if not all phones connected to the network.
Below is my current config:
Building configuration...
Current configuration : 5655 bytes
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname Router
boot-start-marker
boot-end-marker
no aaa new-model
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-participate wic 3
ip dhcp excluded-address 192.168.0.1 192.168.0.50
ip dhcp excluded-address 192.168.0.241 192.168.0.255
ip dhcp pool PHONES
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 192.168.0.5 192.168.0.6
 option 150 ip 192.168.0.17
ip cef
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type basic-net3
cts logging verbose
voice-card 0
 dspfarm
 dsp services dspfarm
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
voice service voip
 ip address trusted list
  ipv4 192.168.0.0 255.255.255.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
 h323
  h245 tunnel disable
 sip
  bind control source-interface GigabitEthernet0/0
  registrar server expires max 3600 min 3600
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g729br8
 codec preference 3 g729r8
voice class h323 1
  h225 timeout tcp establish 4
  call start fast
voice hunt-group 1 longest-idle
 timeout 0
license udi pid CISCO2901/K9 sn FGL173220Y3
license accept end user agreement
hw-module ism 0
hw-module pvdm 0/0
hw-module pvdm 0/1
redundancy
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
interface GigabitEthernet0/0
 ip address 192.168.0.17 255.255.255.0
 duplex auto
 speed auto
interface ISM0/0
 description Unity-Express-Module
 ip unnumbered GigabitEthernet0/0
 ip virtual-reassembly in
 service-module ip address 192.168.0.10 255.255.255.0
 !Application: CUE Running on ISM
 service-module ip default-gateway 192.168.0.17
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
interface ISM0/1
 no ip address
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/1/0
 description Test_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn layer1-emulate network
 isdn incoming-voice voice
 isdn static-tei 0
interface BRI0/1/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/2/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/2/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/3/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/3/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface Vlan1
 no ip address
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 192.168.0.10 255.255.255.255 ISM0/0
control-plane
voice-port 0/0/0
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 description TEST_ISDN
voice-port 0/0/1
 input gain -6
 output attenuation -6
 echo-cancel coverage 64
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 timeouts interdigit 6
 description ***2BRI-NT/TE Port***
 bearer-cap Speech
voice-port 0/1/0
voice-port 0/1/1
voice-port 0/2/0
voice-port 0/2/1
voice-port 0/3/0
voice-port 0/3/1
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
mgcp profile default
dial-peer voice 2 voip
 destination-pattern 1[0-9][0-9][0-9]
 session target ipv4:162.168.0.17
dial-peer voice 1 pots
 destination-pattern 9.
 port 0/0/0
 forward-digits all
dial-peer voice 3 pots
 destination-pattern 9T
 port 0/0/1
gatekeeper
 shutdown
telephony-service
 max-ephones 20
 max-dn 200
 ip source-address 192.168.0.17 port 2000
 network-locale GB
 load 7906 term11.default
 load 7960-7940 P0030801SR02
 load 6921 SCCP69xx.9-2-1-0
 load 6941 SCCP69xx.9-2-1-0
 max-conferences 8 gain -6
 web admin system name alex secret 5 $1$eSOq$7L1LD5IBwR3F5v0.3gc3i1
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
ephone-dn  1
 number 1001
 name ***Black 6941 ***
ephone-dn  2
 number 1002
 name ***6921 v1***
ephone-dn  3
 number 1003
 name ***6921 v2***
ephone-dn  4
 number 1004
 name ***Big Bertha***
ephone  1
 mac-address E8B7.484E.8483
 type 6941
 button  1:1
ephone  2
 mac-address 8478.ACC7.13C0
 type 6941
 button  1:2
ephone  3
 mac-address 8478.ACC7.13A4
 type 6921
 button  1:3
ephone  4
 mac-address 0023.5E18.A3AA
 type 7940
 button  1:4
ephone-hunt 1 longest-idle
 pilot 619879
 list 1001, 1002, 1003
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input none
scheduler allocate 20000 1000
end

Have tried adding however still getting an engaged tone. Below is my latest config can anyone help?
Building configuration...
Current configuration : 5860 bytes
! Last configuration change at 10:37:45 UTC Wed Jan 21 2015
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname Router
boot-start-marker
boot-end-marker
no aaa new-model
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-participate wic 3
ip dhcp excluded-address 192.168.0.1 192.168.0.50
ip dhcp excluded-address 192.168.0.241 192.168.0.255
ip dhcp pool PHONES
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 192.168.0.5 192.168.0.6
 option 150 ip 192.168.0.17
ip cef
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type basic-net3
cts logging verbose
voice-card 0
 dspfarm
 dsp services dspfarm
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
voice service voip
 ip address trusted list
  ipv4 192.168.0.0 255.255.255.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
 h323
  h245 tunnel disable
 sip
  bind control source-interface GigabitEthernet0/0
  registrar server expires max 3600 min 3600
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g729br8
 codec preference 3 g729r8
voice class h323 1
  h225 timeout tcp establish 4
  call start fast
voice hunt-group 1 longest-idle
 timeout 0
license udi pid CISCO2901/K9 sn FGL173220Y3
license accept end user agreement
hw-module ism 0
hw-module pvdm 0/0
hw-module pvdm 0/1
redundancy
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
interface GigabitEthernet0/0
 ip address 192.168.0.17 255.255.255.0
 duplex auto
 speed auto
interface ISM0/0
 description Unity-Express-Module
 ip unnumbered GigabitEthernet0/0
 ip virtual-reassembly in
 service-module ip address 192.168.0.10 255.255.255.0
 !Application: CUE Running on ISM
 service-module ip default-gateway 192.168.0.17
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
interface ISM0/1
 no ip address
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/1/0
 description Test_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn layer1-emulate network
 isdn incoming-voice voice
 isdn static-tei 0
interface BRI0/1/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/2/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/2/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/3/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface BRI0/3/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
interface Vlan1
 no ip address
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 192.168.0.10 255.255.255.255 ISM0/0
control-plane
voice-port 0/0/0
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 description TEST_ISDN
voice-port 0/0/1
 input gain -6
 output attenuation -6
 echo-cancel coverage 64
 no vad
 compand-type a-law
 no comfort-noise
 cptone GB
 timeouts interdigit 6
 description ***2BRI-NT/TE Port***
 bearer-cap Speech
voice-port 0/1/0
voice-port 0/1/1
voice-port 0/2/0
voice-port 0/2/1
voice-port 0/3/0
voice-port 0/3/1
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
mgcp profile default
dial-peer voice 2 voip
 destination-pattern 1[0-9][0-9][0-9]
 session target ipv4:162.168.0.17
dial-peer voice 1 pots
 destination-pattern 9.
 port 0/0/0
 forward-digits all
dial-peer voice 3 pots
 destination-pattern 9T
 port 0/0/1
dial-peer voice 100 pots
 description outbound dialpeer 1
 preference 7
 destination-pattern 1[2-9].........
 port 0/0/0
 forward-digits all
gatekeeper
 shutdown
telephony-service
 max-ephones 20
 max-dn 200
 ip source-address 192.168.0.17 port 2000
 network-locale GB
 load 7906 term11.default
 load 7960-7940 P0030801SR02
 load 6921 SCCP69xx.9-2-1-0
 load 6941 SCCP69xx.9-2-1-0
 max-conferences 8 gain -6
 web admin system name alex secret 5 $1$eSOq$7L1LD5IBwR3F5v0.3gc3i1
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
ephone-dn  1
 number 1001
 name ***Black 6941 ***
ephone-dn  2
 number 1002
 name ***6921 v1***
ephone-dn  3
 number 1003
 name ***6921 v2***
ephone-dn  4
 number 1004
 name ***Big Bertha***
ephone  1
 mac-address E8B7.484E.8483
 type 6941
 button  1:1
ephone  2
 mac-address 8478.ACC7.13C0
 type 6941
 button  1:2
ephone  3
 mac-address 8478.ACC7.13A4
 type 6921
 button  1:3
ephone  4
 mac-address 0023.5E18.A3AA
 type 7940
 button  1:4
ephone-hunt 1 longest-idle
 pilot 619879
 list 1001, 1002, 1003
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input none
scheduler allocate 20000 1000
end

Similar Messages

  • CUCM 8.6(2) migration problem with external calls

    Hello all.
    Yesterday we have migrated our telephone infrastructure from CM4.x to CUCM8.6(2), after some weeks of tests.
    Yesterday night all seems to work properly, all phone updated and registered, external calls going out and in.
    But from this morning, with all users at work, it appears a strange problem, that until now I couldn't solve: randomly all external calls go down.
    I can't address this problem, since gateways (all cisco 2811 routers) are the same and with same configuration as yesterday.
    All thing that I can think is that router that seems to cause the problem is configured not with mgcp by cucm, but with h323 route inside the router.
    Any suggestions will be greatly appreciated.
    Daniele

    GW says normal call clearing.
    But, maybe I've addressed the problem.
    I've found a bug fixed into latest cucm release (8.6(2a)SU1) that say "h.323 calls improperly disconnected".
    So I'm trying to upgrade from 8.6(2a) to 8.6(2a)SU1, but process fails :-(
    I've tried from a dvd and also loading iso image from sftp, but after few minutes appears an error
    08/04/2012 09:43:55 upgrade_install.sh|Started auditd...|
    08/04/2012 09:43:56 upgrade_install.sh|Started setroubleshoot...|
    08/04/2012 09:43:56 upgrade_install.sh|Changed selinux mode to enforcing|
    08/04/2012 09:43:56 upgrade_install.sh|Cleaning up rpm_archive...|
    08/04/2012 09:43:56 upgrade_install.sh|Removing /common/rpm-archive/8.6.2.21900-5|
    08/04/2012 09:43:56 upgrade_install.sh|File:/usr/local/bin/base_scripts/upgrade_install.sh:599, Function: main(), Upgrade Failed -- (1)|
    08/04/2012 09:43:56 upgrade_install.sh|set_upgrade_result: set to 1|
    08/04/2012 09:43:56 upgrade_install.sh|is_upgrade_lock_available: Upgrade lock is not available.|
    08/04/2012 09:43:56 upgrade_install.sh|is_upgrade_in_progress: Already locked by this process (pid: 1286).|
    08/04/2012 09:43:56 upgrade_install.sh|release_upgrade_lock: Releasing lock (pid: 1286)|
    I've rebooted server yet and problem remains.
    Thanks for any other suggestions.
    Daniele

  • AIM/CUE not Picking-up in-bound external calls

    I have a 2811 router with an AIM/CUE (12-VM) card. All of the telephony-service stuff works fine:
    -All calls in house work fine
    -All outbound calls work fine, to PSTN
    -All inbound calls work fine, from PSTN
    -Each phone can access it's VM internally
    -the CME gui and the Unity-Express gui's are accessible on the LAN.
    But, when I call from outside into the PRI with a DID number, I get four rings, then a pause, and then it never goes to voicemail. Sometimes; depending if I call with my celr or a land line, I get the message "Sorry your call cannot be completed as dialed, 000-000." Any clue why the vm does work for internal or external calls.
    Here's a sample of the config.
    interface FastEthernet0/0
    no ip address
    no ip mroute-cache
    duplex full
    speed 100
    interface FastEthernet0/0.100
    description SUB-IF for VOICE VLAN
    encapsulation dot1Q 100
    ip address 10.1.100.1 255.255.255.0
    interface FastEthernet0/0.101
    description GW FOR VOICEMAIL MODULE AIM/CUE
    encapsulation dot1Q 101
    ip address 10.1.101.1 255.255.255.0
    interface Service-Engine0/1
    discription AIM/CUE VOICEMAIL MODULE
    ip unnumbered FastEthernet0/0.101
    service-module ip address 10.1.101.2 255.255.255.0
    service-module ip default-gateway 10.1.101.1
    ip route 10.1.101.2 255.255.255.255 Service-Engin0/1
    dial-peer voice 40 voip
    description ** cue voicemail pilot **
    destination-pattern 6000
    session protocol sipv2
    session target ipv4:10.1.101.2
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 41 voip
    description ** cue auto attendant **
    destination-pattern 6001
    session protocol sipv2
    session target ipv4:10.1.101.2
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 1 pots
    description ** T1 PRI Emergency 911 **
    destination-pattern 9911
    port 0/0/0:23
    forward-digits 3
    dial-peer voice 2 pots
    description ** T1 PRI OutBnd Calls **
    destination-pattern 9T
    port 0/0/0:23
    dial-peer voice 3 pots
    description ** T1 PRI InBnd Calls**
    incoming called-number .
    direct-inward-dial
    port 0/0/0:23

    Problem has to do with how many Digits are getting sent to voice mail on the router when it tries to make the call. You should be seeing 10 digits in the debug.
    Next question when one ephone calls another ephone locally does voice mail work?
    Try the following commands. This will create a translation-rule that will strip incoming 10 digits to the 4 digits you need. I assume you do not need all 10 digits.
    voice translation-rule 1
    rule 1 /^650\(....\)/ /\1/
    voice translation-profile digitstrip
    translate called 1
    voice-port 0/0/0:23
    translation-profile incoming digitstrip
    *************Voice port were you Telco Line comes in Port 0/0/0:23 based on your config*************
    telephony-service
    no dialplan-pattern 1 6503926... extension-length 4
    Ronnie

  • TestSuite: External Calls

    Hi,
    is there any further documentation on external calls in bpels testsuite?
    I only found
    http://download-uk.oracle.com/docs/cd/B31017_01/integrate.1013/b28981/testsuite.htm#sthref3734
    Is there any sample/demo?

    Hi,
    nice tutorial, but if found noting about external calls....
    Can you provide me a pointer to the relevant chapter?
    Thanks...

  • Block External calls h.323 gateway CM4.1(3)

    Is there a way to block external calls from getting through the gateway. The gateway is H.323, Callmanager 4.1(3)

    You can use Class of Restriction on the gateway.
    http://www.cisco.com/en/US/tech/tk652/tk90/technologies_configuration_example09186a008019d649.shtml

  • Initiating External Calls in Adobe Edge

    Can I do external calls with edge? For example: can I access external music and build a list which could be played back by a user? Additionally could i use some library that would allow me to record in Edge and save the recording? I am thinking like some browser api or some external call that would allow me to create a stand alone Adobe Edge html file that someone could launch on their desktop. I know this is asking a lot but I would greatly appreciate any info.

    Hell0,
    I did this example a long time ago. Maybe this could help you.
    https://www.box.com/s/ygym12tza9s9x2gfrgja

  • How to add external call from Report Painter

    Hi experts,
    I'm working on a report painter, and I need to do an external call, from the generated code.
    add something like this    PERFORM Z_CALCULO_IMPORTE_COMPENSADO(ZCASS_FFMRBCS)
                                                                                    USING CUR-TAB
    Is there any way to do it without an SSCR key?
    Thanks in advance

    HI  Pradeep,
    Goto the transaction code (Change Report) GR32.
    Give you library name and report name
    And click on the column (application tool bar or F7) button then place the curser on the screen where you want column (please note you have to keep curser on the header section u2013Red column text) right click and insert element. Then you select formula as selection element  and enter. You will get the enter formula box. Then you can type your formula and continue. This will add new column to the report.
    How to enter formula: you can see the formula components in that id and description.
    Id is columns that are present and description indicates explanation of that column.
    Enter formula according your requirement.
    Examples:
    Enter formula screen:
    ID :    des
    X001  amount
    X002  pt000
    X003  test
    1. Enter formula as: ( X001 u2013 X002)
    The above formula is for fist column u2013 second column.
    2. ( ( X001 u2013 X002) / X003) * 100
    First column u2013 second column and devide by third column after that multiple with 100.
    Hope this will help you
    Regards
    Manohar

  • Different MOH for Internal and External Calls

    Is it possible to have a different MOH source for internal vs external calls.
    I know that Network MOH is for transfering but can this be used for external MOH source from the PSTN?

    There's really no way to do this easily. The issue is that the call to a PSTN phone would flow through a gateway and if an IP phone put this call on hold, then the Audio Source configured on the IP phone would determine the MoH file/source and the MRGL of the gateway would determine which MoH server it actually came from. As a result, there's really no way that the IP phone placing the call on hold could specify a different audio source for an internal call (to another IP phone) because even if the other phone has a different MRGL (and therefore a different MoH server), the MoH audio source will be the same

  • Netweaver 7.01 ABAP Trial Version - External Call Into Possible?

    I am trying to do any kind of external call into the Netweaver 7.01 ABAP Trial Version.
    Is it possible with either VS 2003 using the .NET Connector or even via a web service call to a BAPI?
    Here are my results in both technologies:
    1 - Deplaying a BAPI as a Web Service - Receive Error Message Object Director R3TR WEBI does not exist.
    (Note: Also when trying to acces SOAMANAGER, I receive a 500 Connection Time-Out Error Web page).
    2- VS2003 using the .net Connector - When I try to list the BAPIs, I receive the error message "Open file c:\windows\sapmsg.ini failed".
    Note: All services have been enabled in SICF.

    And which problem was? And how you solved it?
    Because im trying to acces SOAMANAGER and it starts loading but it never finishies. IE says waiting for reply...

  • Caller display says external call

    My caller display only works sometimes. The rest of the time it says external call. I phoned BT who said it was an exchange fault. It then worked for a short time but back to only working sometimes again.

    Hi annegray01,
    Thanks for you post.
    I'm sorry for the problems you're having using Caller Display.  I can help get you sorted from here.
    To get in touch, click on my username and under the "about me" section you'll see the link to "contact the mods".
    Cheers
    Robbie
    BTCare Community Mod
    If we have asked you to email us with your details, please make sure you are logged in to the forum, otherwise you will not be able to see our ‘Contact Us’ link within our profiles.
    We are sorry that we are unable to deal with service/account queries via the private message(PM) function so please don't PM your account info, we need to deal with this via our email account :-)
    If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.

  • Change the ringtone on external calls

    Hi all,
    Working with a SPA 525G. Looking to change the ringtone when any external call comes through the VOIP Phone. Can the SPA 525G do that?
    For example: I call our office from my cell, it identifies it as an external number to the site, and a different ringtone plays. I know you can program the personal address book to play different ring tones, but it's impossible to account for every number that might call a moderately sized business centre. 
    Really appreciate any help,
    -Glen.

    I was looking to change the ringtone of any interal call coming to the voip phone.
    Here is what I did to solve the issue.
    Login to the phone via browser on your pc.  http://192.168.xxx.xxx
    Click on personal directory. Add all of your phone extentions.
    Example:
    1.  n=John Doe;p=100conXXX;r=12
    2.  n=Jane Doe;p=101conXXX;r=12
    100 is the ext# XXX you replace with your numbers. You can find this number in your call logs.
    Now when I receive a call from an extention inside the office, it has a different ring then a customer calling.

  • CME:how to block external call to external call

    cme have the four fxo and AA,when the external calls come in,and dial 9+ pstn num,it can call from external call to another external call,how can blocking?

    Hi,
    try to use this command
    #call application voice aa max-extension-length 5
    This option declares the maximum length of the extension that the user can dial when dial-by-extension-option is chosen. The default value is 5. The value can be 0 with no restriction up to x digits.
    or try
    3.
    Configure Class of Restriction (COR) to block call transfers from B-ACD to PSTN numbers. The sample configuration below prevents the B-ACD from transferring calls out to local and long distance PSTN numbers. The B-ACD can still transfer calls to internal extensions.
    Below is an example of such a configuration:
    dial-peer cor custom
    name longdistance
    name local
    dial-peer cor list call-longdistance
    member longdistance
    dial-peer cor list call-local
    member local
    dial-peer cor list block-pstn
    dial-peer voice 1 voip
    corlist incoming block-pstn
    application aa
    destination-pattern 1000
    session target ipv4:192.168.1.1
    incoming called-number 1000
    dtmf-relay h245-alphanumeric
    codec g711ulaw
    no vad
    dial-peer voice 2 pots
    corlist outgoing call-longdistance
    destination-pattern 91..........
    port 0/2/0
    dial-peer voice 3 pots
    corlist outgoing call-local
    destination-pattern 9[2-9]......
    port 0/2/0
    Thanks
    Najeeb

  • JTAPI, CallManager 3.3 and external calls problem

    Hi everyone,
    I'm putting together an application that uses JTAPI to track call times.
    When I'm tracking an internal call, the call time is pretty much exact and my application gets notified about all call events.
    But when tracking external calls (calls that go to the public telephone network) I've noticed that as soon as the call is directed to the router (a Cisco 3800), CallManager sends a connected event when in fact the phone on the other side is still ringing.
    Even if the external call never gets answered I get a connected (active call) event.
    I have a trace dump of my application that shows the events when they happen and I can provide that if needed but for now I was wondering what, if anything, should be configured either in CallManager 3.3 or the Cisco 3800 so that events are triggered correctly, i.e. get one connected event when the call is actually answered and not when CallManager passes the call to the router.

    Hey all
    Just got a 17" i7 MBP a few weeks ago, anxious of all the spinning beachball freezes people have reported in the Apple forums. Thankfully, I have none of these problems, however, I have a problem that's just as annoying.
    I have my laptop connected to an Eizo 24" Widescreen via a display port to DVI adapter, using the extended desktop functionality. I started fine, and I have pretty much the external monitor connected 90% of the time. But then after a few days (and this happens now 2-5 times ever day), the screens will go black, once entering sleep mode for the screens only, and I can't wake them up, only do a hard reboot via the power button. it's really annoying, as I can't leave the monitor plugged in, while I go do other stuff. When the MBP is on it's own, there's no problem.
    Also, sometimes when starting up, a few seconds into the desktop showing, I get severe graphics corruption, all kind of colours on both monitors, and I can only o a hard reboot to recover it. No problem as well when only using the MBP without the external monitor.
    The only good thing about these problems are that wen I push the machine hard (I am a graphic designer, so it get's pushed to max maybe 5 hours a day), there's no problems what so ever, it's like it's more tend to crash when cold. No problems during intense gaming as well.
    I run solely on the geforce card, as I have read a lot of problems are due to the switching of cards.
    Anyway, just wanted to chime in, hopefully Apple will deliver a solution for this soon. My old 2007 MBP was rock-solid, and so far this has been the least stable Mac I have owned. Love it still though.
    Lars

  • Choppy voice on IP Phone with external calls

    Hi,
    Having a issue where the IP Phone side of the call hears choppy voice (jitter) on some external calls coming in/out a MGCP PRI Gateway across WAN from the users. The PSTN (outside party) is fine and doesn't hear a problem.
    The users can call other IP Phones at the main location fine and don't have this problem, problem is only with calls going out the PRI on the gateway now and then.
    QoS is in place and no drops on the policies.
    The WAN connection is a Multilink frame relay connection with 2 T1s. FRTS is configured and set to shape to 10ms with a fragment size of 1600 bytes.
    The 'mgcp playout adaptive' command was added and set to 250 which improved things a little and it happens less often then before but still there.
    The gateway is IOS 12.4(3b) and CCM is 4.1(3)Sr1 with 7.2(2) phone load on the 7940/7960 phones. Using G729 codec across WAN.

    Fragment size 1600 ? It should be quite smaller to be effective.
    Also, how big the the queues ? If too large, you can experience delay without drops.
    Finally, check your FRTS values and perhaps bumping up a little. More often than not WAN networks are a little more tolerant of what the contract guarantees.

  • VOICE_IEC-3-GW error - no external calling available

    Anyone have any thoughts on this? I've been getting this error on the logs of my router,
    "%VOICE_IEC-3-GW: C SCRIPTS: Internal Error (Interface busy): IEC=1.1.182.11.26.0 on callID" 
    It was happening last Thursday about the same time it was reported that the location could not make or receive external calls. Users could still dial 5 digits inside company.
    It's a 2851 router, running c2800nm-adventerprisek9-mz.151-4.M6.bin and has analog lines connected to FXO card. We had a problem with one of these analog lines previously. I'm wondering if it's not a telco issue again. Suddenly the problem cleared up and calls were successful again without me doing anything.
    Thanks

    Hi,
    From the error decoder tool
    %VOICE_IEC-3-GW: [chars]: Internal Error ([chars]): IEC=[dec].[dec].[dec].[dec].[dec].[dec] on callID [dec] [chars]
    An internally-detected error has caused a voice call to be released or terminated. An Internal Error Code (IEC) has been generated to report the error. This IEC will be logged in the accounting record for this call. In addition it is being reported through syslog because of the voice iec syslog configuration.
    Recommended Action: To display more information on the details of this error, enter the show voice iec description IECvalue command, with IECvalue being the value of the IEC that was received. Debugging actions might also indicate the cause of the error.
    Regards,
    Alex.
    Please rate useful posts.

  • Changing external Caller ID over a SIP Trunk to SIP Provider

    I am working with a client and when they place calls out to any external user they have the wrong name showing on the external caller ID. 
    I have spoken with the SIP provider and apparently they want us to pass the CNAM, or rather they have it setup for us to do this.
    I opened a case with Cisco and the TAC engineer said the provider has to do this because it cannot be done from CUCM or the gateway.
    For example, it says right now "location A" for external calls and I want to change this to say "location B" . 
    Is this even possible?

    what is the call flow? did you check the caller name in SIP trunk configuration?

Maybe you are looking for