Front end to facilitate sparql and/or RDF network browsing

Hello
I have been looking at public tools to use as a front to our data in Spatial that will assist our users in creating queries (esp. across tables) and also browse the network or the ontology.
I have looked at:
Protege: locks up when I attempt to load the data via the Oracle plugin (our data is not significant size, 8kb in triples) then looses the links between classes when it is loaded. I like this tool but can anyone offer tips on how to leverage the query ability?
Simile Longwell - cannot get jetty to correctly launch the browser on windows, added bug to Simile Jira. Does not connect to Oracle anyway...
Others (Rhodonite, Brownsause, ) want to work from a flat file, not Oracle. Are there plugins I do not know about?
Does anyone have ideas for others or guidance for using Protege?
Thanks
Maurice

Hello,
you probably would need a config like this on the Head end router:
ip vrf Cust1
rd 65000:1
interface Vlan10
description Customer1
ip vrf forwarding Cust1
ip address 10.1.1.1 255.255.255.252
router bgp 65000
address-family ipv4 vrf Cust1
neighbor 10.1.1.2 remote-as 60000
neighbor 10.1.1.2 description ISP PE for Customer1
Adjust the interface names, IP addresses, RD, RT, etc. for your environment.
This would insert the routes learned from the mpls Provider into your VRFs. The scenario, by the way, is described in RFC2547bis section 10a.
You could off course also place filters and other stuff into BGP for security reasons depending on your requirements.
Hope this helps! Please rate all posts.
Regards, Martin

Similar Messages

  • Is there an output switch at the analog front end of PXI-6723 and PXI-6713?

    I was reading the analaog output user manual and i could not find this. Is there any output switch just before the analog output of each channel for PXI-6723 and PXI-6713? I am would like to have total isolation between when these output are not needed. If yes, is there any specification to refer to?
    Thanks.

    Hello Chris,
         I would recommend having a look at the examples in the LabVIEW
    example finder to start with. In particular i would look at 'Cont Gen
    Wfm-Ext Clk.vi' This is a basic example that allows you to output a
    waveform through the card and source an external clock source to do
    this. I would recommend exporting the sample clock that you wish to use
    from the 4462 on one of the RTSI lines and then setting this as the
    sample clock source for the Analog output card.
    Another good example to look at is the 'Cont Gen Voltage Wfm-Int Clk
    non regeneration.vi' This does not regenerate the same waveform in the
    buffer but instead creates a new waveform to output after the previous
    one has been written to the buffer.
    It should be noted that there may be some gliltching if you are
    updating the waveform. This is because the buffer will already have a
    waveform in there to output before you input the new one so a new
    frequency may not have an exact number periods that fit into the
    pre-defined buffer. If you are looking to generate dynamic waveforms
    then the best option for the best results would be one of our arbitrary
    waveform generators here.
    Good Luck,
    LeeM
    NIUK

  • Head End Build between MPLS and standard IP network

    Hi,
    I'm a bit new to MPLS to please excuse my ignorance if I'm completely wrong here, but here goes.
    We provide standard IP services to our customers. We have recently gone into an agreement with an MPLS wholesale provider, where they supply our customers with MPLS connections. We then supply IP services to these customers such as SMTP POP and Web browsing etc.
    We have a pipe into the MPLS providers MPLS cloud that provides such connectivity. This circuit is terminated on a 7206VXR on our network.
    Each customer has their own DLCI on this circuit with a /30 subnet. There is then a BGP session for each customer using the /30 from our Head End Router to the MPLS Provider's P router.
    The MPLS provider announces the customers subnets that are connected to the MPLS cloud to our Head End Router using BGP.
    My issue is that I want routes announced from each BGP session to be injected into their own, per customer VRF table so that the routes are kept seperate from other customers routes.
    I've setup a lab to simulate the above, but cannot seem to get it to work.
    I suppose my question is does the MPLS provider's P router that our Head End connects to have to announce the BGP routes to us using VRF also or can it just use standard BGP and I can use a route map to place routes announced from a specific BGP peer IP into a per Customer VRF table?
    Is this actually possible?
    Any advice would be greatly appreciated

    Hello,
    you probably would need a config like this on the Head end router:
    ip vrf Cust1
    rd 65000:1
    interface Vlan10
    description Customer1
    ip vrf forwarding Cust1
    ip address 10.1.1.1 255.255.255.252
    router bgp 65000
    address-family ipv4 vrf Cust1
    neighbor 10.1.1.2 remote-as 60000
    neighbor 10.1.1.2 description ISP PE for Customer1
    Adjust the interface names, IP addresses, RD, RT, etc. for your environment.
    This would insert the routes learned from the mpls Provider into your VRFs. The scenario, by the way, is described in RFC2547bis section 10a.
    You could off course also place filters and other stuff into BGP for security reasons depending on your requirements.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • Coldfusion back-end, AngularJS front-end, and Security

    The company I work for is building an application in which security is of the utmost importance.  We're really hoping to use Angular as the client-side application, and we're exploring how best to create our back-end in ColdFusion (which we've used for a few years now).
    I understand that only so much security can exist in the front-end of the app, and that the bulk of the work needs to happen on the server.  But I'm really unsure about how to move forward in that regard.  From what I've read, it sounds like we'll need some kind of Authentication Token to be created on login and stored on the backend.  This token should come along with every http request, and the server can then decide on the validity of the request.
    Does this sound about right?  And if so, are there best practices for implementing it?
    Any resources that might shed more light on the topic would be HUGELY appreciated.
    Thanks,
    Jonathan

    maheshguruswamy wrote:
    mycoffee wrote:
    maheshguruswamy wrote:
    847102 wrote:
    More and more teams in my company are now mixing technologies. For example they use java for the back end and C# for all the client side code i.e GUI.
    How can you mix these technologies. Ie how can c# code "talk" to java code?
    Not sure if this is the best place to ask, as its a java forum but I though I would give it a try!
    ThanksSimplest way would be to use web services.It is new thing for me to learn...
    How efficient to do it compared to all in one either C# or java? I guess it would be slower.
    Either C# or java can handle the job. Why both? I don't get it.It all depends on how big the teams are and how much "separation of concerns" you are looking for. In enterprise architecture what i aim to do is try to give the development groups freedom to use whatever technology they feel best suits their need...BUT...if they want to talk to other systems and vice versa, they have to follow certain standards (SOAP, REST etc). Architect the lines, not the boxes. If you are not looking for separation of concerns, sure build out everything in one technology..but keep it mind future changes.Thank,
    It is good thing to learn. I used to work with java front end calling Cobol back end (using transactions)
    I know C# and java can talk by SOAP or web services but only wondered about the reason.
    If I am going to design everything new, one technology is the answer.

  • RFC to read the attachment from PR05 and pass the doc to the PHP front end

    Hi Team,
    Our requirement : We are designing a new front end using PHP portal and pull the data from SAP-backend for travel expense/request.
    We are able to upload the document to PR05 using frontend portal.
    If employee/manger wants to read the attachment in the portal,how to get the documents attached in PR05 to the front end..
    I would like to know the RFC which help me in reading the attachemnts.Regards,
    Madhu

    I dont want use all the values in my second program I need to pass empno and job only.Since your cursor gets all the columns (using the * is not a good way to code the cursor), that is what your other program will get when it calls pr_test procedure. You will have to FETCH all the columns in that other procedure and discard the ones you do not need.
    Alternatively, change the code of cursor to select only the columns you would actually need.

  • Sharepoint recovery 1 front-end one back-end

    I have a simple SharePoint environment with a SharePoint 2010 front end and a dedicated SQL back-end. Both virtualized on Hyper-V 2008 R2 host. There are no complicated apps - it is just a file serving SharePoint implementation.
    The VHD for the front end server (it only had one drive) got corrupted. I have an export of the complete server from the 29th December, including the VHD.
    The back end (SQL and all the databases) if unaffected.
    I tried creating a new VM with the three day old VHD from the export, but it does not seem to correctly connect to the back end.
    I also have DPM 2012 backups of the whole thing systems, though they are made via the SharePoint front end.
    With a whole panoply of solutions I can:
    1. import the exported front end and see if that works better than just re-creating the machine (GUIDs and all that)
    2. Forget the export of the front end on the 29th and do a fully fledged DR from DPM
    Any other ideas?
    CarolChi

    One thing to note is that SharePoint does not support VM backups (that is, snapshots or full backups of the VHD itself). Since your VHD is older than the data within the Configuration database, it is best to start with a new front end.
    You should be able to install SharePoint up to the same patch level on the new front end, "join" the existing farm, and then forcibly remove the defunct SharePoint server from Central Administration.
    Trevor Seward
    Follow or contact me at...
    &nbsp&nbsp
    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

  • Lync 2013 On Prem - Front End Pool - Second server in pool becomes unavailable when first server is offline

    We have one front end pool, that contains 2 front end servers running Lync Server 2013.
    When the first server, LFE01 goes offline (to be restarted for instance), the second front end server LFE02 in the same pool's Lync services will suddenly stop and will refuse to start until LFE01's Lync services have started again.
    During this time, the Lync client will go from full functioning mode whilst LFE01 is up and running, to reduced functionality (when LFE01 is restarting), to the user being signed out of Lync and not able to log back in. As soon as LFE01 comes back up, users
    can log back in to Lync.
    We'd ideally like LFE02 to take over the front end server role whilst LFE01 is restarting, and vice-versa.
    Checking the event logs on LFE02, I can see the following errors when LFE01 is offline:
    This process was not able to update its health status
    The Audio-Video Conferencing Server failed to send health notifications to the MCU factory at https://frontendpool.contoso.com:444/liveserver/mcufactory/. 
    Failure occurrences: 30, since 7/11/2013 3:40:38 PM.
    Cause: Either the Front End service is not running, or poor network connectivity.
    Resolution:
    Verify that the Front End Service is available, and its machine is visible over the network.
    This process was not able to update its health status
    The IM Conferencing Server failed to send health notifications to the MCU factory at https://frontendpool.contoso.com:444/liveserver/mcufactory/. 
    Failure occurrences: 30, since 7/11/2013 3:40:42 PM.
    Cause: Either the Front End service is not running, or poor network connectivity.
    Resolution:
    Verify that the Front End Service is available, and its machine is visible over the network.
    Server startup is being delayed because fabric pool manager is initializing.
    Cause: This is normal when Pool is bootstrapped and indicates that the Front-End is waiting for a quorum of other Front-Ends to be started.
    Resolution:
    If this event recurs persistently, ensure that 85% of the Front-Ends configured for this Pool are up and running. For 2 or 3 machine Pools, initial cold-start of the Pool requires all machines to be started. If multiple Front-Ends have been recently
    decommissioned, run Reset-CsPoolRegistrarState -ResetType QuorumLossRecovery to enable the Pool to recover from Quorum Loss and make progress.
    Does the first server in the pool need to be up at all times for the second server to be running? If so, I may need to re-plan my redundancy.

    I can't believe how inaccurate these statements are. 
    Yes as per Microsoft it is best practice to have 3 FE in a pool but that absolutely does not mean that if you have 2 FE server in a pool that your pool will stop working!!
    In case when you do have 2 FE servers in a pool your Back End primary database server will act as a vote to keep the quorum for single server still left in a pool and all your clients will keep operating in a pool with one FE still running. 
    The problem with having 2 FE in a pool as per Microsoft documentation is as follows:
    If one of the two Front End Servers goes down, you should try to bring the failed server back up as soon as you can. Similarly, if you need to upgrade one of the two servers, bring it back
    online as soon as the upgrade is finished.
    If for some reason you need to bring both servers down at the same time, do the following when the downtime for the pool is finished:
    The best practice is to restart both Front End Servers at the same time.
    If the two servers cannot be restarted at the same time, you should bring them back up in the reverse order of the order they went down.
    If you cannot bring them back up in that order, then use the following cmdlet before bringing the pool back up:.
    http://technet.microsoft.com/en-us/library/gg412996.aspx
    I tested this in my environment which I currently am running with 2 FE servers and I can categorically confirm that pool will continue operating. 
    However, with all this said I did notice that clients with connection to FE server that is shut down take anywhere from 2-9 min to reconnect. I was trying to figure out why such a long delay until clients reconnect. Possibly it might be because there are
    2 FE servers in a pool and Back End server is taking a while to vote in turn delaying auto reconnect process for clients. Second possibility that I'm looking into is that we deployed HLB for sip traffic internally as well and I'm curious if using DNS LB would
    fix this delay.
    I'm just so disappointed how inaccurate some of these accepted answers above are.

  • Front-End Loopback Test on Catalyst 2955 causes connected hardware to "die"

    I have recently purchased a Cisco Catalyst model WS-2955C-12 switch. During POST (boot), the console reports that the switch undergoes what is known as a "FRONT-END LOOPBACK TEST". During this test the 14 port lights on the device light up amber for a moment, connectivity is lost, and after a second or two the lights go off and connectivity returns. We've found that the moment the lights go off at the end of this test, if we have a specific device (with a specific ethernet chip) directly connected to the switch the ethernet chip is adversely affected by this test - the device "goes dark" and is not capable of communicating with anything (including other switches, routers, etc...) until it is power-cycled. What exactly does this FRONT-END LOOPBACK TEST do, and what does it send across the wire that could be causing my ethernet chip onboard the device to go bonkers?
    Thanks!
    -Danny

    Cisco IOS Release 12.1(22)EA1 runs on Catalyst 2955, Catalyst 2950, and Catalyst 2940 switches.
    Review the new software features, open caveats, and resolved caveats sections for information specific to your switch. The information in this document refers to all the switches, unless otherwise noted.
    These release notes include important information about this release and any limitations, restrictions, and caveats that apply to it. To verify that these are the correct release notes for your switch:
    If you are installing a new switch, refer to the Cisco IOS release label on the rear panel of your switch.
    If your switch is running, you can use the show version user EXEC command. See the "Finding the Software Version and Feature Set" section.
    If you are upgrading to a new release, refer to the software upgrade filename for the Cisco IOS version.
    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2950/12122ea1/ol554602.htm

  • Issue with IE8, during login to Oracle Apps 11.5.9 front end

    Hi,
    One of the user is getting below error message window in IE8, when he tries to login to Oracle Apps 11.5.9 front end, with his username and password:
    "Errors on this webpage might cause it to work incorrectly.
    Element not found
    Common2_2_24_2.js Line 2722
    Code:0 Char:1
    URI:http://myserver.x.com:8020/OA_HTML/cabo/jsLibs/Common2_2_24_2.js"
    User tried deleting cookies and temporary internet files aslo, restore default as well nothing seemed to be worked.
    Please suggest.
    Regards,
    Purnima

    I assume you mean in the security settings screen of IE. There are several differences:
    Description     User's Computer     Other Computer
    Allow previously unused ActiveX controls to run without prompt     Enable     Disable
    Allow Scriptlets     Enable     Disable
    Automatic prompting for ActiveX controls     Enable     Disable
    Only allow approved domains to use ActiveX without prompt     Disable     Enable
    Automatic prompting for file downloads     Enable     Disable
    Access data sources across domains     Prompt     Disable
    Allow scripting of Microsoft web browser control     Enable     Disable
    Allow script-initiated windows without size or position constraints     Enable     Disable
    Allow websites to open windows without address or status bars Enable Disable
    Don’t prompt for client certificate selection when no certificates or only
    one certificate exists     Enable     Disable
    Include local directory path when uploading files to a server     Enable     Disable
    Launching applications and unsafe files     Enable     Prompt
    Software channel permissions     Medium safety     Does not have this option listed
    Use Pop-up Blocker     Disable     Enable
    Use SmartScreen Filter     Disable     Enable
    Allow status bar updated via script     Enable     Disable
    Allow websites to prompt for information using scripted windows     Enable     Disable
    Enable XSS filter     Disable     Enable
    User even changed above IE setting according to the other IE but he still gets the same error.
    Regards,
    Purnima

  • To develop front end jsp page

    Hi.....
    How to develop jsp for front-end entry of creating and updating as well as tracking values from the table....
    Can u suggest me how to do this?

    Hi,
    You can develop JSP's in Jdeveloper.
    But you won't require the Jdeveloper with OA extension for this requirement. You can download latest Jdeveloper (without OA extension) from Oracle.com.
    Regards,
    Mukesh Uchaniya

  • Using DAC0/DAC1 as I/Q baseband channel to work with zero-IF architectu​re RF front end

        Hi,
         I am using the 5640R FPGA card together with RF front-end to transmit and receive OFDM modulated signal. (something similar to 802.11). I was working with a low-IF architecure RF front-end (NI PXI 1042) and now I need to modify my design to work with a zero-IF(direct downconversion) architecture RF front-end.
       Therefore, I need to generate both I and Q baseband analog signal which I will use as the input to the RF front-end.  Thus, I need to gurantee the I and Q channel (ADC0/ADC1, or DAC0./DAC1) are both synchornized.
       I read Mauricio's post about synchronizing the two DAC and two ADC, in his response to the filtering with IF-RIO. It helps a lot. Yet I still have some questions. Advices would be greatly appreciated.
        If I want to synchornize ADC0 and ADC1, should I put a "ADC reset" vi in the host after I finish the DAC configuration VI? Besides, I could not find anything similar to the "Profile" used in the DAC configuration. Since DAC reset will reset the profile 0 which is undesired as discussed in the previous post, I am wondring if there is anything similar to the ADC.
       Besides, to get the received I/Q based band data, should I just read the ADC_0_Port_I and ADC_0_Port_Q? I will later set the Transmit Frequency and Receive Frequency to both 0M. Is there anything that I should do in addition to what Mauricio kindly listed in his post?
       I attached the picture of what I did to the Host VI and FPGA VI.
       Thanks a lot.
    David
    Attachments:
    zeroiffp.JPG ‏99 KB
    zeroifho.JPG ‏116 KB

    Hi,
       I was not able to run my vi after I clocked the configuration loop with RTSI_Ref_Clk and also did the other step as illustrated in "filtering with..." post.  A error -61046 occured with the following message.
      Error -61046 occurred at ni5640R Template (HOST).vi
       Possible reason(s):
        LabVIEW FPGA:  An error was detected in the communication between the host computer and the FPGA target.
        If you are using any external clocks, make sure they are connected and within the supported specifications. Also, verify that the rate of any external clocks match the specified clock rates. If you are generating your clocks internally, please contact National Instruments Technical Support.
       The attached .zip file is my coded project.
       Advice is greatly appreciated...Thanks.
    David
    Attachments:
    Joing Configuration of WLAN Transmitter and Receiver up to Carrier step_zeroIF.zip ‏4980 KB

  • How to pack a front end app to the application that is going to publish

    Hi,
    I want to pack the front end application along with the application that I am going to post on the mobile server. Can anyone help me out in executing this phase.
    I have made an application with some base tables and posted them to mobile server and able to sync with clinet machine and mobile server. Now I am able to access client database with MSQL and there is a front end application with us and now we want that front end application to be packed with that application that we are going to publish on the mobile server.

    You have two options,
    1) Create an application on mobile server and attach your front-end files to that application. Upon synchronization the client machine will download the front-end files. Section 6.1.3 Listing Application Files in Developer's guide For OLite version 10.3.0.2.0
    2) Use the Oracle Lite framework used for keeping the olite client software up-to-date on the mobile device. Follow inistructions in Metalink Note ID: 350993.1

  • Allowing a website to expand and shrink with a browser

    I am working on a website and wanted to know how to let a
    logo with butts right up to the left side of the screen but can
    also shrink and strectch with the browser so it will always start
    and end at the bottom and top of the browser.

    Ask your boss, "How high is up?"
    The notion that all the space on a page has to be filled is a
    hallmark of a
    rookie designer, whether on paper or screen. Your boss needs
    to hire someone
    with professional web design skills and then follow what he
    or she suggests.
    A boss who dictates things he or she has no knowledge of or
    experience in is
    going to end up with a disaster. The page you have created so
    far is doomed
    to failure. 20 layers?
    (Please show this message to your boss & suggest he or
    she log on here and
    learn the realities of web design.)
    Walt
    "margin_walker" <[email protected]> wrote in
    message
    news:f8or9s$4hn$[email protected]..
    > this is the site so far
    http://www.trinity3marketing.com/
    >
    > i would like the left icon to stretch to the bottom but
    also adapt to the
    > window size i guess is what i wanted to say. my boss is
    very adamant about
    > that,
    >

  • SharePoint Foundation 2013 - Search Configuration Issue - 2 App Servers and 2 Front-End Servers

    Hi, 
    We have a SharePoint Foundation 2013 with SP1 Environment. 
    In that, we have 2 Front-End Servers and 2 App Servers. In the Front-End Servers, the Search Service is stopped and is in Disabled state and in the 2 App Servers in One App Server, Search is Online and in another Search is Starting but goes to Stopped sooon
    after.
    Originally, we had only 1 App Server and we were running our Search Service and Search Service Application in that. Now since the index location became full and we were unable to increase the drive there, we added one more App Server and now the issue is
    Search is not properly getting configured in either of these App servers. What we want to do is run Search only in the new App Server, because we have a lot of storage space for Index locations here, but in the older App Server, not run Search at all.  We
    tried keeping the Search Service disabled and ran the below PowerShell Scripts, but none of the ones are working. These scripts are creating the Search Service Application, but the error of "Admin Component is not Online", "Could not connect
    to the machine hosting SharePoint 2013 admin component" is coming up. 
    http://www.funwithsharepoint.com/provision-search-for-sharepoint-foundation-2013-using-powershell-with-clean-db-names/
    http://blog.falchionconsulting.com/index.php/2013/02/provisioning-search-on-sharepoint-2013-foundation-using-powershell/
    http://blog.ciaops.com/2012/12/search-service-on-foundation-2013.html
    Can I get some help please?
    Karthick S

    Hi Karthick,
    For your issue, could you provide the
    detail error message of ULS log  to determine the exact cause of the error?
    For SharePoint 2013, by default, ULS log is at      
    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS
    For troubleshooting your issue,  you can try to run the SharePoint Products Configuration Wizard on your WFE servers and run the script for configuring the search service on SharePoint
    Foundation:
    [string]$farmAcct = "DOMAIN\service_Account"
    [string]$serviceAppName = "Search Service Application"
    Function WriteLine
    Write-Host -ForegroundColor White "--------------------------------------------------------------"
    Function ActivateAndConfigureSearchService
    Try
    # Based on this script : http://blog.falchionconsulting.com/index.php/2013/02/provisioning-search-on-sharepoint-2013-foundation-using-powershell/
    Write-Host -ForegroundColor White " --> Configure the SharePoint Foundation Search Service -", $env:computername
    Start-SPEnterpriseSearchServiceInstance $env:computername
    Start-SPEnterpriseSearchQueryAndSiteSettingsServiceInstance $env:computername
    $appPool = Get-SPManagedAccount -Identity $farmAcct
    New-SPServiceApplicationPool -Name SeachApplication_AppPool -Account $appPool -Verbose
    $saAppPool = Get-SPServiceApplicationPool -Identity SeachApplication_AppPool
    $svcPool = $saAppPool
    $adminPool = $saAppPool
    $searchServiceInstance = Get-SPEnterpriseSearchServiceInstance $env:computername
    $searchService = $searchServiceInstance.Service
    $bindings = @("InvokeMethod", "NonPublic", "Instance")
    $types = @([string],
    [Type],
    [Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool],
    [Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool])
    $values = @($serviceAppName,
    [Microsoft.Office.Server.Search.Administration.SearchServiceApplication],
    [Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool]$svcPool,
    [Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool]$adminPool)
    $methodInfo = $searchService.GetType().GetMethod("CreateApplicationWithDefaultTopology", $bindings, $null, $types, $null)
    $searchServiceApp = $methodInfo.Invoke($searchService, $values)
    $searchProxy = New-SPEnterpriseSearchServiceApplicationProxy -Name "$serviceAppName - Proxy" -SearchApplication $searchServiceApp
    $searchServiceApp.Provision()
    catch [system.exception]
    Write-Host -ForegroundColor Yellow " ->> Activate And Configure Search Service caught a system exception"
    Write-Host -ForegroundColor Red "Exception Message:", $_.Exception.ToString()
    finally
    WriteLine
    ActivateAndConfigureSearchService
    Reference:
    https://sharepointpsscripts.codeplex.com/releases/view/112556
    Thanks,
    Eric
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact
    [email protected].
    Eric Tao
    TechNet Community Support

  • Front end and back end questions

    Hi,
    If I want to develop a web base SOA application by using Jcaps, I have several question want to ask.
    1.) In the front end, if i create the page by using eVision to create the page
    flow and the page layout, how can I match the fields of the page (such
    as the username, email, tel no... with the back end web services?
    2.) Does the flow of the front end web pages are control by the page flow in
    eVision? When will the eVision supported AJAX or JSF?
    3.) What is the use of the eInsight Business process manager, does it
    control all the back end flow, such as the flow of each web services?
    Does Jcaps has the Bpel engine to control the flow of web services?
    4.) I know that in JBoss, there is a jBPM server to control the flow of the front
    end pages, does JCAPS has this kind of server?
    5.) If i want to connect to the Database? I know that there is a eTL to extract
    the data from the database, it is true? Or do u recommend to connect the
    database directly through the web services by using JDBC or other
    framework as well?
    6.) If I have an existing application that is developed by .Net (With no web
    services). How can i integrate with other systems? What can I do in order
    to reuse the system? Or what Jcaps can do in this manner?
    Thanks for you reply! ^ ^

    Generally, back-end would consist of the taks associated with configuration of data targets (ODS, Cubes), working with extractors, mapping data to the data targets, writing transfer/start rtn/update rules, and creating Infopkgs/ Process Chains.
    Front-end deals with the use of the BW - writing queries, workbooks, web (although I think some of the infrastructure aspects of web reporting. e.g. javascript/templates might really could be considered backend).  Think of Front-end as all of the client/customer/user facing components.

Maybe you are looking for