Get IP address ... behind xDSL ...of the ISP

Hi i m looking for a cool way to get not my localhost address.... i need to get my IP ... i have the next code:
import java.net.*;
public class TestIP {     
public static void main(String args[]) {          try {               
InetAddress[] addresses;
addresses = InetAddress.getAllByName(InetAddress.getLocalHost().getHostName());     for (int i=0; i<addresses.length; i++) {                    System.out.println(addresses<i>.getHostAddress());               }          }          catch(UnknownHostException e) {          System.out.println (e.getMessage());          }     
this code if is coorect (but is not)...give all the ip of your PC ...but....
thanks for the help ....... :)

look, i am behind a Router and the router use NAT ..
the point is if i can get the outside Address , i can
do some hacking tricks to bypass the router and make a
server behind ... in a different port of course like
the.ip.address:8989 / index.htmlWrite a small server application that prints out the remote client host name / IP address when a connection is received. Host it somewhere outside your network and connect to it from your machine. This will display your external IP.
Alternatively, you could browse to one of those online credit card forms, the type where they display a warning about fraud, and display your IP and the time (Your IP has been recorded...)

Similar Messages

  • My iPhone is stolen. How can I get my address book back from the iCloud? I should have synchronized my iPad address book. However, I loss some recent contacts from iPhone.

    My iPhone is stolen. How can I get my address book back from the iCloud? I should have synchronized my iPad address book. However, I loss some recent contacts from iPhone.

    I use my iPad to get the address book backed up by iCloud from my iPhone. However, I cannot see the recent new contacts from my iPad. Is there anyway to check the iCloud server to see if my address book backup from my iPhone is still there?

  • I need to get into my old account and get my addresses and then cancel the old account but can not get into it. Had to change my user name when I moved and now I can't get into Firefox. Can't remember the old password. What to do??

    I moved during the summer. I changed to highspeedand & when I set my computer up it told me that my email address was already in use so I had to change it(????) I changed from jkady to [email protected] I tried to change it on firefox but it would not except the new name and I could not get into my old account.I need all my addresses and would like to cancel the old account but I can not get into it. This is very frustrating!!!!! I need my addresses!!!!!!!!

    I logged in changed the primary E-Mail address to a different one, vertified it then tried to log in it said either to send an E-Mail to veritify again or to do my security questions, so I choose to do the security questions and put in my Birthday like it asked and it said that it was wrong and I had to authenticate it to get in, why is it so hard to just set up a Apple ID really though!
    So I tried the E-Mail to and it has not sent me an E-Mail then I tried to log in again and it has locked me out of my account so I try to recover my password and it gave me the same options to get my password back and both options are doing the same as before, it says I don't know my on birth date or it is wrong or needs authenticate it, then the E-Mail doesn't come through!
    This is just stupid now.

  • Get MAC Address Of Device On The Other End Of Crossover Cable

    If you have a SonicWall UTM available to you, connect to it.  Monitor the logs, if the device is on a different subnet, you'll get a spoofing notification with the IP in question (if the device has an IP already assigned to it).  I believe the MAC address will also show in the logs.  Now I'm guessing that other firewalls/UTMs will also have similar alerting. 

    Hey guys
    So I got a proprietary device which I need the MAC address for in order to set the IP and reset credentials via a weird web UI, and the MAC is not written anywhere. 
    So I connected this device to my laptop via a crossover cable and tried to nmap various common subnets (including the entire private space) to see if it maybe had a static IP. No dice. So how can I get the MAC address of this device using only my laptop, since I can't get into it?
    This topic first appeared in the Spiceworks Community

  • How to get delivery address in STO for the storage location

    Hi All,
    We have to create STO from the reservation using MRP run. While system is creating the STO we need to populate the storage location address as delivery address (not the plant address ). How we can do that? what are teh settings required for this setup? please hlep in that.
    Regrads,
    Khan

    Hello...
    You can select the storage location in the line item itself which is adjecent to Plant for the line item.
    Regards
    Suresh

  • I need the IP values and Subnet Mask which is given by the ISP for my jetpack so i can configure my smart tv

    i need the IP values and Subnet Mask which is given by the ISP for my jetpack so i can configure my smart tv

    Your public IP Address is provided by the ISP.  Your smart TV does not need to know this information unless you plan to host some kind of an application or service for folks on the internet through your TV.  It wouldn't work anyways since all Jetpacks sit behind a VZW NAT firewall and blocks hosting capabilities by default.
    What you more than likely are referring to is the Default Gateway and Subnet mask of the Local Area Network being hosted by your Jetpack.  By default these values should be something like 192.168.1.1 and 255.255.255.0.  You can confirm the DG and SM by connecting a computer to the Jetpack.  Every computer has a way to look up the networking information.  On a Windows OS you would open up a CMD window and type in "IPCONFIG".
    If you shoot us the model number of your Smart TV we may be able to look up a User Guide to confirm what kind of info is needed to connect to a wireless network.  Most of the time exchanging the IP information is done automatically during the connection process.  It would also be nice to know which Jetpack model you have so we can compare the User Guide for that device with your TV.

  • AEX fails to get DHCP address, but works on DLink

    Sorry for the long post -- I'm hoping the details will help you diagnose the problem faster in the long run.
    My DLink router gets a DHCP IP address from the (Comcast) cable modem, but when I switch to the AirPort Extreme (5th gen, refurbished), it doesn't. It shows an autoconfiguration IP address of the 169.254 variety, suggesting that DHCP isn't working for the AEX. (Just fyi, my girlfriend's macbook can connect to the AEX and get 10.0.1.x IP addresses; I can ping the AEX over wifi.)
    Airport Utiltiy shows a red number 2 with a single error indicating Internet failure to get IP address or something. The suggested solution is power-cycling the modem; failing that, contact the ISP. Contacting Comcast was amusing but useless...they gave me instructions for setting up AEX with a DSL modem -- twice -- without understanding my objection!
    The AEX is configured for DHCP (not Static or PPPoE), and uses all stock settings (I did both a soft reset and used the Airport Utility to restore default settings...not sure if those two are the same).
    I've tried power-cycling the router and cable modem numerous times, including leaving them off for 15+ minutes and leaving the AEX connected for 6+ hours. I tried using the DLink to release the DHCP reservation and then quickly switching the cable over to the AEX.
    I read somewhere that resetting the "CMTS (cable modem termination system)" might help. I mentioned it to the Comcast tech support, but they didn't respond.
    At this point, I'm not sure what else to try. It could be the refurbished unit is broken, but 95% of the time these sorts of things are configuration issues. (I know a fair amount about networking, but I'm new to Apple products so I could be doing something stupid.) I may try connecting the AEX to the LAN side of the DLink to see if it can get a DHCP address from that...but I'm clearly grasping at straws.
    <whimpers>...Help?

    Update: The AEX does get a DHCP address when connected to the LAN side of the DLink gateway. (But the AEX doesn't get one when connected directly to the cable modem. Yet the DLink gets a DHCP address when connected to the cable modem.) So...??!?!!!

  • Wireless Router 877W users cannot get ip address from DHCP

    Users can connect to wireless but they cant get ip address what can be the problem ?
    Thanks
    no aaa new-model
    resource policy
    ip subnet-zero
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.239.1 192.168.239.50
    ip dhcp pool users
       network 192.168.239.0 255.255.255.0
       default-router 192.168.239.1
       dns-server 4.2.2.2
    bridge irb
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface Dot11Radio0
    no ip address
    encryption vlan 1 key 1 size 40bit 0 1234567890 transmit-key
    encryption vlan 1 mode wep mandatory
    ssid wirele
        vlan 1
        authentication open
        guest-mode
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    channel 2437
    station-role root
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no snmp trap link-status
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 192.168.239.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxxx password xxx
    crypto map MerkezVPN
    interface Dialer0
    no ip address
    interface BVI1
    no ip address
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1

    go into config t and add "bridge 1 route ip" and see what you get....

  • HT201248 My email address associated with my Apple ID on my iPad has been turned off from the ISp (U.S. army).   I have a new gmail account with a new Apple ID. How do I get my iPad to use my gmail account?

    Help. My old @us.army.mil email address was terminated by the army. I used that address to register my first apple id account on my iPad. I can't remember my original Apple ID number and if I ask to reset my password, Apple sends the reset link to my old non-working email address. I have a new gmail address and a new Apple ID number associated with that address. How do I get my iPad to use my new gmail address and new apple ID number?  Remember, I can't log out of my old account because I can't remember the password. Amd Apple will only reset the password by sending a link to my old, non functioning army email account. ( I hate army webmail for canceling all retired military email accounts). John Marc
    <Personal Information Edited By Host>

    Hi John,
    You can change the email address associated with an Apple ID using the steps in this article -
    Change your Apple ID - Apple Support
    Thanks for using Apple Support Communities.
    Best,
    Brett L 

  • When I bought my iPhone 5s I set up the email account for iCloud with a Shaw Cable address. Shaw was my ISP. I changed ISP's which rendered my iCloud email account as useless. I did reset my AppleID but it didn't change for iCloud. How can I change?

    Ok so now I right the novel. Haha.
    I bought my iPhone 5s and set up the AppleID for iCloud to be the same as the Apple ID I already used for iTunes and the App store. I was using @shaw.ca as part  of the emaill address. I changed my ISP to save money so had to change the Apple ID. I had no issues changing it for iTunes and the App store, but it wouldn't change for iCloud. I don't recall the password and can't have it sent to me as that address does not work any longer.
    What do I do to get my AppleID for iCloud working again?

    Yes, you understood correctly.  From your explanation, you created your hotmail.ca ID by revising the shaw.ca ID.  Given that, you should perform the steps listed in my original post:
    Make sure you are signed into iMessage and FaceTime with your current ID.  If they are signed into the old ID, go to Settings>Messages>Send & Receive and Settings>FaceTime, tap the ID, sign out, then sign back in with your current ID.
    Then temporarily recreate the old ID by going to https://appleid.apple.com, click Manage my Apple ID and sign in with your current iCloud ID.  Click edit next to the primary email account, change it back to your old email address and save the change.  (You should not have to verify the old email account so it doesn’t matter if you no longer have access to it.)  Now go to Settings>iCloud, turn off Find My iDevice and enter your current password when prompted (even though it prompts you for the password for your old ID).  Then save any photo stream photos that you wish to keep to your camera roll (unless using iCloud Photo Library).  When finished goThen go to Settings>iCloud, tap Sign Out (or Delete Account if you are not running iOS 8) and choose Delete from My iDevice when prompted (your iCloud data will still be in iCloud).  Next, go back to https://appleid.apple.com and change your primary email address back to the way it was.  Now you can go to Settings>iCloud and sign back in with your current iCloud ID and password (your data will download back to your device).

  • When I try to send e-mail I get an error message stating that the e-mail address was rejected by the server.  When I send to e-mail from another address, I get back an error saying the e-mail address is unknown.  My e-mail has worked fine for years until

    When I try to send e-mail I get an error message stating that the e-mail address was rejected by the server.  When I send to e-mail from another address, I get back an error saying the e-mail address is unknown.  My e-mail has worked fine for years until yesterday.  HELP!

    The specific text of the error message is very important here — I'm not sure exactly you're encountering here.
    If you're able to connect to your email server and are able send email to other email addresses and if the failures are specific to one email recipient address, then please contact the intended recipient of the failing email, and confirm their address is valid.  (This is the way I'm reading your question.)
    If you are unable to send any email to any other email addresses and this is specific to your email address, then try the web mail client interface (if one is available) to verify your login user and password, and check with your email ISP for assistance.  If your email password works via web mail, follow this Apple troubleshooting guide, then — if everything else fails — I'd probably then entirely remove the email account from Mail.app and re-add it per your email ISP's particular setup requirements.  (Some issue with the setup or maybe a corrupt setting in OS X or a problem at the mail ISP servers is a common problem, but this effects attempts to send to all email addresses via that account.)
    An email account setup is specific to an email provider, unfortunately.   If you're using one of the more common email ISPs, then there are usually setup guides and frequently-asked questions posted online.

  • Getting the ISP name

    I'm surprised I couldn't find this information myself, but here I am...
    When I go to a statistics program like SmarterStats, it's able to show me what ISPs (Time Warner, Cox, Roadrunner, etc) visited the website.
    3-part question:
    1. Does anyone know of a way (reliable or otherwise) in Coldfusion to capture that same info - not the IP address, but the ISP name?
    2. If a college professor visits a website, will it show the ISP as their college, or something generic?

    Really?  You think that functionality is built into JavaScript and it's not the third-party service http://www.ip2phrase.com/ that is being called that's doing it?
    You could call the service just as easily with CF using CFHTTP, but since that particular service returns an executable JS statement you would need to parse out the pieces that you want.
    <cfhttp url="http://www.ip2phrase.com/ip2phrase.asp?template=Looks%20like%20you%20live%20in%20<CITY>." result="response" method="get" />
    <cfdump var="#response.filecontent#" />

  • How do I get messages to go back to an AIM account? It's only seeing the iPad's Facetime email address and not seeing the old AIM account name that is on my desktop. I am using my iMac using iChat to talk to a newer iMac that doesn't have iChat.

    How do I get messages to go back to an AIM account? It's only seeing the iPad's Facetime email address and not seeing the old AIM account name that is on my desktop. I am using my iMac using iChat to talk to a newer iMac that doesn't have iChat. We had this working using Messages and Facetime (on the new machine) talking to my existing iChat account. One day last week, when Facetime rang, my kids answered on the iPad. Dang! Now it's all fouled up! The new iMac won't see my AIM account name and shows that I'm offline, because the iPad is off. We were able to call using "most recent call" in Facetime, but now I can't go and control that new iMac remotely to help with some email concerns the user is having. I'm trying to not personalize this too much, but it's grandkids talking to Grandma and Mom and Dad trying to solve new machine hiccups. Normally, I could just go in via iChat and control the other machine and troubleshoot, but I can't do it with Facetime only. My buddy list doesn't see  the other computer even though we are connected on Facetime right now. My name is not highlighted for the other computer. What could have gone so wrong?
    Any help would be appreciated.

    How do I get messages to go back to an AIM account? It's only seeing the iPad's Facetime email address and not seeing the old AIM account name that is on my desktop. I am using my iMac using iChat to talk to a newer iMac that doesn't have iChat. We had this working using Messages and Facetime (on the new machine) talking to my existing iChat account. One day last week, when Facetime rang, my kids answered on the iPad. Dang! Now it's all fouled up! The new iMac won't see my AIM account name and shows that I'm offline, because the iPad is off. We were able to call using "most recent call" in Facetime, but now I can't go and control that new iMac remotely to help with some email concerns the user is having. I'm trying to not personalize this too much, but it's grandkids talking to Grandma and Mom and Dad trying to solve new machine hiccups. Normally, I could just go in via iChat and control the other machine and troubleshoot, but I can't do it with Facetime only. My buddy list doesn't see  the other computer even though we are connected on Facetime right now. My name is not highlighted for the other computer. What could have gone so wrong?
    Any help would be appreciated.

  • Apple maps has received a poor performance rating just after introduction of the iPhone 5. I am running google maps app on the phone. Siri cannot seem to get me to a specific address. Where does the problem lie? Thanks.

    Apple maps has received a poor performance rating just after introduction of the iPhone 5. I am running Google Maps app on the phone. SIRI cannot seem to get me to a specific address. Where does the problem lie? Also can anyone tell me the hierarchy of use between the Apple Maps, SIRI, and Google maps when the app is on the phone? How do you choose one over the other as the default map usage? Or better still how do you suppress SIRI from using the Apple maps app when requesting a "go to"?
    I have placed an address location into the CONTACTS list and when I ask SIRI to "take me there" it found a TOTALLY different location in the metro area with the same street name. I have included the address, the quadrant, (NE) and the ZIP code into the CONTACTS list. As it turns out, no amount of canceling the trip or relocating the address in the CONTACTS list line would prevent SIRI from taking me to this bogus location. FINALLY I typed in Northeast for NE in the CONTACTS list (NE being the accepted method of defining the USPS location quadrant) , canceled the current map route and it finally found the correct address. This problem would normally not demand such a response from me to have it fixed but the address is one of a hospital in the center of town and this hospital HAS a branch location in a similar part of town (NOT the original address SIRI was trying to take me to). This screw up could be dangerous if not catastrophic to someone who was looking for a hospital location fast and did not know of these two similar locations. After all the whole POINT of directions is not just whimsical pasttime or convenience. In a pinch people need to rely on this function. OR, are my expectations set too high? 
    How does the iPhone select between one app or the other (Apple Maps or Gppgle Maps) as it relates to SIRI finding and showing a map route?  
    Why does SIRI return an address that is NOT the correct address nor is the returned location in the requested ZIP code?
    Is there a known bug in the CONTACTS list that demands the USPS quadrant ID be spelled out, as opposed to abreviated, to permit SIRI to do its routing?
    Thanks for any clarification on these matters.

    siri will only use apple maps, this cannot be changed. you could try google voice in the google app.

  • I am trying to download xfinity tv go app. I can not find it in my App Store and can not download it from the comcast website. All I get is a blank screen in the App Store. My Apple ID is associated with a Canadian address. How can I find the app?

    I am trying to download xfinity tv go app. I can not find it in my App Store and can not download it from the comcast website. All I get is a blank screen in the App Store. My Apple ID is associated with a Canadian address. How can I find the app?

    Its possible the App is not available in the Canadian store if the link doesn't work for you.
    https://itunes.apple.com/us/app/xfinity-connect/id320788270?mt=8

  • I have a bigpond email account and can receive emails on both ipad and iPhone. I can receive on th iPhone when on 3G. When I connect either to a wi if network I cannot send emails. Get a message that says my email address is rejected by the server.

    I have both iPhone and iPad that will not send emails when I am connected via wi if. Have tried three wi if networks. I get a messag that says the sender address (my address) was rejected by the server. Any ideas on what I need to do?
    Rusty

    Hi and thanks again for trying to help.
    Definitely works ok from pc.
    Have deleted and re-established account a few times now but still the same.
    I have actually given up and added gmail account which is working fine.
    Sends and receives no problem.
    Bloody bigpond....
    We are not remote at all. Sitting in the fantastic Pavilion Hotel in Phnom Penh. Another couple here having trouble but not bigpond. Hotel staff have tried to help but to no avail.
    Giving up and stick with gmail until we get home then start trying to get resolution.
    Problem actually existed on a personal wi fi network in Melbourne before we left so I should have tried to resolve it then.
    Thanks again for suggestions.
    R

Maybe you are looking for

  • I want an answer urgent for this Error

    Hi all I am using MS Access as a database In my JSP code when i used one query or many updates, that works fine. However, when i use two queries, it shows the following error. By the way, i tried to use different connections and the same connection a

  • Need to turn Appleworks into Word

    Hi, I know, I know. I should have used Word in the first place if I was doing it for publishing. But, like so many others, I didn't know until after the fact. Can anyone turn me on to a tutorial of some kind re this? Maybe Apple has one? Video or pri

  • One to another

    I have recently been given a budget from work to get a new macbook, after only getting out of my own pocket in sept. I'm going to give this one to my girlfriend. My question is can i clone this HD to the new MB without the use of an external HD, befo

  • 10.4.3 Upgrade will not load

    hi - I am currently running 10.4.2 on a computer that came with Tiger. I am trying to upgrade to 10.4.3 and have repeatedly gotten the following message: "The digital signature for this package is incorrect. The package may have been tampered with or

  • Training & events management integration with controlling

    Dear TEM Gurus I am doing the SAP TEM integration with Controlling module. I have run the Cost transfer wizard with all the settings. But while running the programme RHXCCOS0 HR Document is not created. it doesnt even show any error message. Pls sugg