Help needed in connecting to oracle9i

Hi
I am using oracle9i,tomcat5.0&jdk1.4.2. when i tried to connect my application with oracle it is showing
" Failed to get connection object from the datasource: org.apache.commons.dbcp.SQL NestedException: Cannot create PoolableConnectionFactory, cause: Io exception:
Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153092352)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))"
i have made the needed changes in the server.xml
<Context path="/ilms" docBase="D:/iLMS/iLMS2.0/contexts" debug="0" reloadable="true" crossContext="false">
<Resource name="jdbc/myoracle" auth="Container"
type="javax.sql.DataSource"/>
<ResourceParams name="jdbc/myoracle">
<parameter>
<name>factory</name>
<value>org.apache.commons.dbcp.BasicDataSourceFactory</value>
</parameter>
<parameter>
<name>removeAbandoned</name>
<value>true</value>
</parameter>
<parameter>
<name>maxActive</name>
<value>100</value>
</parameter>
<parameter>
<name>maxIdle</name>
<value>30</value>
</parameter>
<parameter>
<name>maxWait</name>
<value>10000</value>
</parameter>
<parameter>
<name>username</name>
<value>scott</value>
</parameter>
<parameter>
<name>password</name>
<value>tiger</value>
</parameter>
<!-- Class name for mm.mysql JDBC driver -->
<parameter>
<name>driverClassName</name>
<value>oracle.jdbc.driver.OracleDriver</value>
</parameter>
<parameter>
<name>url</name>
<value>jdbc:oracle:thin:@10.10.21.29:1521:abb</value>
</parameter>
</ResourceParams>
</Context>
I am trying to connect from the client machine using scott, tiger & abb as username, password & hoststring .using sql plus i was able to connect to the oracle server giving the above entries. The server ip is "10.10.21.29" . also i downloaded ojdbc14.jar . Is this the driver needed?. can any one help me in solving this problem?
Thanking you in advance
Dinny

1008737 wrote:
Hi,
I have been trying to connect to Oracle database in my codes. I have tried using OdbcConnection and OleDbconnection. But both did not allowed me to connect to the database. The database, testDb, can be accessed using SQL plus as well as the SQL developer. I even tested the connection successful using ODBC data source administrator.
the following is my code for the connection string:
OdbcConnection connectionString = "Driver={Oracle ODBC Driver};Server=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP )(HOST=127.0.0.1)(PORT=1521))(CONNECT_DATA=(SID=Te stDb)));Uid=scott;Pwd=password;";
whenever localhost (127.0.0.1) is used, this means that no remote client can ever connect to this system
The problem involves ODBC configuration & has nothing to do with Oracle.

Similar Messages

  • Help needed in Connecting to SAP From Eclipse

    Hi All,
    Currently, we have a requirement where we need to retrieve data from SAP System and need to upload the same in a Third Party Application (Java based system).
    We are able to create an account in Java Application using Eclipse IDE by hard coding the Account details. We are stuck up in establishing the SAP connection and retrieving the details and then creating the extracted account details in Java application from Eclipse.
    Any pointers on this will be of great help.
    Regards,
    Eureka

    Hi Eureka,
    Please refrain from creating cross-posts in parallel forums, moreover this question is JCo-related and is not directly connected with Java EE 5. The Help needed in Connecting to SAP From Eclipse in the Java Programming forum would be enough. Please continue the discussion there.
    Regards,
    Vladimir

  • Help needed in connecting a Mac Mini to AT&T DSL

    Any suggestions on how to troubleshoot this problem will be appreciated. I'm helping a friend connect a Mac to the Internet using AT&T DSL. The computer is a Mac Mini, 1.42 GHz PPC G4, running OS X 10.5. It is connected by Ethernet to an AT&T DSL modem. The Mini's Network preference is configured to connect using DHCP.
    Strange symptoms include:
    1. Safari will not connect to the Internet.
    2. However, Firefox WILL connect and loads all websites I tried.
    3. Apple Mail will connect and download messages from my friend's previous email address (not AT&T), but will not connect to allow me to configure his new AT&T account.
    4. Other programs that need a network connection won't run; for example, the Software Update preference, when checking for new updates, claims that there is no network connection.
    Do these symptoms indicate that the Mini's network preferences are not configured correctly, or that the DSL modem is not configured correctly?
    More information: with the modem is an "Installation Wizard Disc" CD with a setup program. It's supposed to work for any PPC G3 or greater Mac, which certainly fits this Mini. BUT, when run on the Mini, the setup program displays a message that the computer's processor is "unrecognized". Then the setup program quits. I ran the setup program on my MacBook Pro laptop connected to the DSL modem. It went through a lengthy process with messages about "configuring the modem". After this, I was able to connect to the Internet with Safari using the laptop. This seems to indicated that there's nothing basically wrong with the modem or DSL connection. However, I can't run the setup program on the Mini. (The above symptoms were after getting the laptop to work, then switching the Ethernet connection back to the Mini.)

    This is a strange problem, especially since Firefox is working OK.
    You might try using OpenDNS. They have a good set of instructions about how to do this here:
    https://www.opendns.com/start
    It's possible that AT&T's DNS servers aren't responding fast enough, and Safari is timing out quicker than Firefox.
    The other option is to call AT&T and ask for support in accessing their DSL modem.
    A third option would be to download a system maintenance utility like Yasu
    http://jimmitchell.org/projects/yasu/
    and use it to clear all the caches in the system -- in case the Mini somehow is using stale information about the net.

  • Help needed to connect to remote PPTP VPN via PIX 515e

    Hello,
    A user in our office needs to connect to a client's remote PPTP VPN but can't connect.  The user is running Windows 7.  We have a Cisco PIX 515e firewall that is running PIX Version 6.3(3) - this is what our user is having to go through to try and make the connection to the client's remote VPN.
    The client's network guys have come back and said the issue is at our side.  They say that they can see some of our traffic but not all of it. The standard error is shown below, and they say it's symptomatic of the client-side firewall not allowing PPTP traffic:
    "A connection between the VPN server and the VPN client XXX.XXX.XXX.XXX has been established, but the VPN connection cannot be completed. The most common cause for this is that a firewall or router between the VPN server and the VPN client is not configured to allow Generic Routing Encapsulation (GRE) packets (protocol 47). Verify that the firewalls and routers between your VPN server and the Internet allow GRE packets. Make sure the firewalls and routers on the user's network are also configured to allow GRE packets. If the problem persists, have the user contact the Internet service provider (ISP) to determine whether the ISP might be blocking GRE packets."
    I have very little firewall experience and absolutely no Cisco experience I'm afraid.  From looking at the PIX config I can see the following line:
    fixup protocol pptp 1723.
    Does this mean that the PPTP protcol is enabled on our firewall?  Is this for both incoming and outgoing traffic?
    I can see no reference to GRE 47 in the PIX config.  Can anyone advise me what I should look for to see if this has been enabled or not?
    I apologise again for my lack of knowledge.  Any help or advice would be very gratefully received.
    Ros

    Hi Eugene,
    Thank you for taking the time to reply to me.  Please see our full PIX config below.  I've XX'd out names and IP addresses as I'm never comfortable posting those type of details in a public forum.  I hope that the information below is still sufficient for you.
    Thanks again for your help,
    Ros
    PIX(config)# en
    Not enough arguments.
    Usage:  enable password [] [level ] [encrypted]
            no enable password level
            show enable
    PIX(config)# show config
    : Saved
    : Written by enable_15 at 10:30:31.976 GMT/BDT Mon Apr 4 2011
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 DMZ security10
    enable password XXX encrypted
    passwd XXX encrypted
    hostname PIX
    domain-name XXX.com
    clock timezone GMT/BST 0
    clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol pptp 1723
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name XX.XX.XX.XX Secondary
    access-list outside_access_in permit tcp XX.XX.XX.XX 255.255.255.240 host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp host XX.XX.XX.XX host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp host XX.XX.XX.XX host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 8082
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq www
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.0.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl deny udp any any eq 135
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_40 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_60 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER1 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_10 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_20 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_30 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_50 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_70 permit ip any XX.XX.XX.XX 255.255.0.0
    access-list USER2 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER3 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER4 permit ip any XX.XX.XX.XX 255.255.0.0
    pager lines 24
    logging on
    logging host inside XX.XX.XX.XX
    icmp permit any outside
    icmp permit any inside
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    ip address outside XX.XX.XX.XX 255.255.255.248
    ip address inside XX.XX.XX.XX 255.255.255.0
    no ip address DMZ
    ip audit info action alarm
    ip audit attack action alarm
    pdm location XX.XX.XX.XX 255.255.255.255 inside
    pdm location XX.XX.XX.XX 255.255.0.0 outside
    pdm location XX.XX.XX.XX 255.255.255.0 outside
    pdm logging debugging 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) XX.XX.XX.XX XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX. XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX. XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX XX.XX.XX.XX netmask 255.255.255.255 0 0
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 XX.XX.XX.XX 1
    route inside XX.XX.XX.XX 255.255.0.0 XX.XX.XX.XX 1
    timeout xlate 3:00:00
    timeout conn 2:00:00 half-closed 0:30:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    ntp authenticate
    ntp server XX.XX.XX.XX source outside prefer
    http server enable
    http XX.XX.XX.XX 255.255.0.0 outside
    http XX.XX.XX.XX 255.255.255.0 outside
    http XX.XX.XX.XX 255.255.255.255 inside
    snmp-server host inside XX.XX.XX.XX
    no snmp-server location
    no snmp-server contact
    snmp-server community XXX
    snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map cola 20 set transform-set ESP-3DES-MD5
    crypto dynamic-map dod 10 set transform-set ESP-3DES-MD5
    crypto map outside_map 10 ipsec-isakmp dynamic cola
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer XX.XX.XX.XX
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 25 ipsec-isakmp
    crypto map outside_map 25 match address USER1
    crypto map outside_map 25 set peer XX.XX.XX.XX
    crypto map outside_map 25 set transform-set ESP-3DES-MD5
    crypto map outside_map 30 ipsec-isakmp
    crypto map outside_map 30 match address outside_cryptomap_30
    crypto map outside_map 30 set peer XX.XX.XX.XX
    crypto map outside_map 30 set transform-set ESP-3DES-MD5
    crypto map outside_map 40 ipsec-isakmp
    crypto map outside_map 40 match address outside_cryptomap_40
    crypto map outside_map 40 set peer XX.XX.XX.XX
    crypto map outside_map 40 set transform-set ESP-3DES-MD5
    crypto map outside_map 50 ipsec-isakmp
    crypto map outside_map 50 match address outside_cryptomap_50
    crypto map outside_map 50 set peer XX.XX.XX.XX
    crypto map outside_map 50 set transform-set ESP-3DES-MD5
    crypto map outside_map 60 ipsec-isakmp
    crypto map outside_map 60 match address outside_cryptomap_60
    crypto map outside_map 60 set peer XX.XX.XX.XX
    crypto map outside_map 60 set transform-set ESP-3DES-MD5
    crypto map outside_map 70 ipsec-isakmp
    crypto map outside_map 70 match address outside_cryptomap_70
    crypto map outside_map 70 set peer XX.XX.XX.XX
    crypto map outside_map 70 set transform-set ESP-3DES-MD5
    crypto map outside_map 75 ipsec-isakmp
    crypto map outside_map 75 match address USER4
    crypto map outside_map 75 set peer XX.XX.XX.XX
    crypto map outside_map 75 set transform-set ESP-3DES-MD5
    crypto map outside_map 80 ipsec-isakmp
    crypto map outside_map 80 match address USER2
    crypto map outside_map 80 set peer XX.XX.XX.XX
    crypto map outside_map 80 set transform-set ESP-3DES-MD5
    crypto map outside_map 90 ipsec-isakmp
    crypto map outside_map 90 match address USER3
    crypto map outside_map 90 set peer XX.XX.XX.XX
    crypto map outside_map 90 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet XX.XX.XX.XX 255.255.0.0 outside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet timeout 30
    ssh XX.XX.XX.XX 255.255.255.248 outside
    ssh XX.XX.XX.XX 255.255.255.248 outside
    ssh timeout 30
    management-access inside
    console timeout 0
    terminal width 80
    Cryptochecksum:XXX
    PIX(config)#

  • Help needed to connect Archos G90 to BT HHv2

    Aa a newbie here I hope this is the right place to post.  I've recently got an Archos G90 tablet.  It tells me it's connected to my home hub but fails to connect with the internet.  Same with BTFON.  In fact I'm still stuck with limited/access problem when I try to connect to FON on my laptop.  After trying to connect with the Archos I have turn the device off and then restart the hub to restore its settings .  I've also reset the hub but there was no change. As far as I can tell my hub settings are okay and it has the latest firmware.  
    So mainly I need to get the tablet connected reliably and without upsetting the hub settings.  
    Secondly if there is a link to a cure for the limited/local access problem with my home BTFON I'd be delighted to know.
    Internet access via the hub is generally reliable on both my laptop and PC, both connected wirelessly.  I have BT Infinity and Vista OS.

    Hi Johnjazz,
    Thanks for posting. I've had a look around and found this which might help. Let me know if it does.
    Cheers
    David
    BTCare Community Mod
    If we have asked you to email us with your details, please make sure you are logged in to the forum, otherwise you will not be able to see our ‘Contact Us’ link within our profiles.
    We are sorry but we are unable to deal with service/account queries via the private message(PM) function so please don't PM your account info, we need to deal with this via our email account :-)

  • Expert help needed to connect iPhone / iPad using BlueTooth and Wi-Fi

    We need expert help to connect iPhone / iPad using BlueTooth and Wi-Fi. If you have worked with Apple MFi Program [http://developer.apple.com/programs/mfi], or have expertise/experience in this, please contact me. Thanks! Kevin.

    Hi there.
    I connected to my livebox after about three attempts. You have to pair the livebox by pressing either the number one or two that is on the box. When it is in pair mode it stays that way for ten minutes so it gives you chance to try your wep code that is on the bottom of the box a few times. I can't remember which one was successful but i did try the letters in uppercase and lower and one of them seemed to connect.
    Welcome to discussions by the way.
    Hope this helps JB

  • Help needed in connecting two midi keyboards to Logic Pro.

    Hey there, I would like to connect two midi keyboards to Logic Pro and enable each keyboard to trigger separate software instruments each. For example, one keyboard has guitar and the other has strings.
    I realise this must have something to do with midi channels or ports, however my knowledge is limited.
    At current, I just have the two keyboards connected via usb straight to the computer. Is it possible I need a multi input or output interface, so that Logic can recognise different ports, or channels? Perhaps there is simply something I need to do in Logic itself? the keyboards are basic M-Audio midi controllers, just a usb port - thats it, no other connections. Any help would be great, Brad.

    Hey Brad,
    yes you need also to change the out midi of the keyboards.
    in my case I have the Keysation 61 es, it's done this way:
    "Channel
    MIDI data from the keyboard can be sent on any of 16 MIDI Channels. However, certain MIDI devices and MIDI software applications require
    the keyboard to send data on a specified channel. If this is the case, you can change the channel the data is sent using the following
    method:
    < Press the Advanced Functions button to engage Edit Mode.
    < Press one of the 16 Channel keys from D1 to E3, according to the Channel that you need.
    For example, if a device specifies that you need to send data on Channel 10, press the Advanced Functions button, and then key F2 to select
    Channel 10.
    The Channel can also be assigned to the Octave “+” and “-” buttons. Once assigned, pressing “+” or “-” will increase or decrease the channel
    incrementally. When Channel 16 is reached and “+” is pressed, Channel 1 will be selected. If the Octave “+” and “-” keys are selected to vary
    the Channel, the lights above the buttons will not change, since it is not possible to have a Channel with a negative value. Pressing both the
    “+” and “-” buttons together will recall Channel 1."
    Can you please tell me what keyboards do you have?
    this is for two players having a go on completely 2 different parts.
    In case you want to record 2 tracks with the same content say a piano and a pad,
    all you need to do is open the tracks and rec enable both and you have piano pad.
    Anyway I believe you need to have two separate sounds for two players?
    Give us some more input of what you want, there must have one or more solutions to what you need.
    Cheers mate,
    Jorge

  • Help needed with CONNECT BY PRIOR

    I need to display salesrep-manager hierarchy. I'm using the following SQL and am sure I'm doing something wrong somewhere, but just can't pinpoint. Any help is greatly appreciated.
    <pre>
    SELECT sf.source_name salesrep
    ,mgr.full_name manager
    ,level
    FROM as_salesforce_v sf
    ,per_all_assignments_f pass
    ,per_all_people_f mgr
    WHERE sf.role_name = 'Sales Representative'
    AND SYSDATE BETWEEN nvl(sf.start_date_active, SYSDATE) AND
    nvl(sf.end_date_active, SYSDATE)
    AND SYSDATE BETWEEN nvl(pass.effective_start_date, SYSDATE) AND
    nvl(pass.effective_end_date, SYSDATE)
    AND SYSDATE BETWEEN nvl(mgr.effective_start_date, SYSDATE) AND
    nvl(mgr.effective_end_date, SYSDATE)
    CONNECT BY PRIOR mgr.person_id = pass.supervisor_id
    START WITH pass.person_id = sf.employee_person_id;
    </pre>
    TIA
    Alka.
    Forgot to mention, the SQL takes forever to run.
    Message was edited by:
    user498444

    as_salesforce_v view stores the salesrep name (as specified by the condition sf.role_name = 'Sales Representative'). This view also has rows for managers of salesreps as that's how Oracle Sales app allows the users to access the app. This table stores employee id in column employee_person_id.
    per_all_assignments_f table stores the assignments for all the employees (including salesreps and that's why condition START WITH pass.person_id = sf.employee_person_id). It also stores the employee id for the manager (column supervisor_id).
    per_all_people_f has all the employee records (including manager records) and the column person_id is the employee id (condition pass.supervisor_id = mgr.person_id).
    Hope this explanation is helpful.

  • Display Options Help Needed to connect to TV

    Hi
    I am a New Mac User and have My macbook pro running Bootcamp with Windows Vista, However I have got the Computer Plugged into my Tv using the Mini DVI to s-video adapter and works fine when running leopard ( plug and auto works ) however when on the windows I cannot make it work on the TV , I have tried changing display setting , extending to 2nd monitor ,etc .. but nothing I do seems to work ..
    So if anyone has any idea , or do I need a Windows Vista for Mac driver for the DVI port or Something ??? where can I get , and what do I need ..
    Anyway all and any Help s Appriciated
    Thanks For help All

    Sorry, I thought it was myTV device you were asking about. My situation differs: cable company service which includes TV & Broadband split by ~$10 cable splitter with co-ax into cable modem & ~$100 myTV.PVR which is USB to MacPro.
    More here on your problem:
    http://discussions.apple.com/thread.jspa?messageID=7179753
    (Just tried this with my new Penryn 2.4 Macbook purchased last week. Hooked up the mini-DVI to VGA adapter to my LCD monitor, booted up in Windows (via Bootcamp), and set both monitors to 1024 x 768. It works flawlessly. The quality on my 18" Sun LCD monitor is wonderful!)
    Richard

  • Help needed with connection problem before I chew off my foot.

    I am on 24/7 with Virgin.
    From last Friday, my connection telephone number has been constantly engaged.
    BT tell me it is not a valid number (?).
    I can access the internet just by changing the number in remote access to the one I'm using now - a pay by the minute number.
    This leads me to believe thay my settings are correct - as they have been for a considerable time.
    Virgin have responded once with a standard reply confirming the telephone number (useless) to four e-mails. There is an unconnected (no pun intended) 'server' problem with their 'online help'.
    I am on Netscape or IE, external Zoom modem and I haven't done anything which might alter my settings.
    Any help would be much appreciated - even sympathy might make me feel better!
    Please bear in mind that I am a techno-idiot with any advice offered.
    Thanks in advance.

    I get a perpetual 'engaged' tone with a mechanical woman telling me that the number is busy, please try later.
    The 'helpline' is a premium number. Cleverly, I have had premium numbers blocked on my 'phone line to defeat the fraudsters re-directing calls.
    This means that I have to use someone else's 'phone to call a premium number!
    Since last Friday, I have sent a total of six e-mails to Virgin and received one 'standard' reply which was of no help.
    I agree that it seems like an ISP problem.
    However, perhaps someone could kindly talk me through the things I ought to be checking on my computer (in words of one syllable where possible!).
    Thankyou in anticipation.

  • Help needed in connecting to oracle database in unity

    Hi,
    I have been trying to connect to Oracle database in my codes. I have tried using OdbcConnection and OleDbconnection. But both did not allowed me to connect to the database. The database, testDb, can be accessed using SQL plus as well as the SQL developer. I even tested the connection successful using ODBC data source administrator.
    the following is my code for the connection string:
    OdbcConnection connectionString = "Driver={Oracle ODBC Driver};Server=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP )(HOST=127.0.0.1)(PORT=1521))(CONNECT_DATA=(SID=Te stDb)));Uid=scott;Pwd=password;";
    the error i got is [ODBC Driver Manager] Data Source name not found and no default driver specified.
    for the driver parameter, i have tried using "Microsoft ODBC for Oracle". It gives me another error stating that the oracle and network components are not installed.
    I even tried "Oracle in OraDb11g_home1" which was specified in the ODBC Data Source Administrator. The same error came out.
    Below are some of my specifications:
    Platform: Windows 7 64bit
    Oracle: Oracle Database 11g Release 2 (64bit)
    Unity: 4.1.2
    Can someone please help me with this? What is it that i have done wrong?
    Thanks.

    1008737 wrote:
    Hi,
    I have been trying to connect to Oracle database in my codes. I have tried using OdbcConnection and OleDbconnection. But both did not allowed me to connect to the database. The database, testDb, can be accessed using SQL plus as well as the SQL developer. I even tested the connection successful using ODBC data source administrator.
    the following is my code for the connection string:
    OdbcConnection connectionString = "Driver={Oracle ODBC Driver};Server=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP )(HOST=127.0.0.1)(PORT=1521))(CONNECT_DATA=(SID=Te stDb)));Uid=scott;Pwd=password;";
    whenever localhost (127.0.0.1) is used, this means that no remote client can ever connect to this system
    The problem involves ODBC configuration & has nothing to do with Oracle.

  • Help needed to connect dual monitors.

    Hi everyone. Here's my problem, I bought two Samsung SyncMaster 913v LCD TFT Displays.
    Both of these displays (since they aren't the digital LCD) connect the same way my old Sony Trinitron MultiscanG400 display connected, which I believe is the VGA connection or SVGA or whatever... I'm not smart enough to look into the difference.
    Anyway, I have the right Graphics/Video card to run dual monitors. I'm using the GeForce 2 TwinView and it has the required 64mb VRam.
    My problem is that there is only one port on the back for monitors. I believe the connection type next to it is an old pre-usb printer/scanner type of connector, LPT1 or whatever those are called.
    So do I need an adapter/connector to hook up both of my monitors to use it as a dual display? If not, what do I need to do?
    Thanks.

    Hi,
    To clarify the last post by PB PM. Your present card meets those requirements.
    The GF2 Twinview card is sufficient. It has two outlets, one is VGA the other is ADC (Apple Display Connector). You will need a ADC to VGA Adapter, they cost @ $25-30. Hook one monitor to the existing VGA outlet, the other to the adapter on the ADC outlet.
    One example is here: http://eshop.macsales.com/item/AddLogix/MCAADCVGA/
    You can google for other prices.
    After the monitors are connected you may need to go to Displays Pref's and set it for dual monitors in Mirror or Span modes.
    Regards,
    Dave

  • Help needed to connect to wifi on touch please!

    The ipod touch has recognised my home wifi connection and I have entered the password. The wifi symbol is showing in the top left hand corner. On the settings page the IP address and subnet mask has automaticaly come up but I can't connect to any web pages.
    The message I get is that it can't connect to the server.
    Should there be something in the Router, DNS, Search Domains and Client ID boxes?
    Please help if you can.

    The ipod touch has recognised my home wifi connection and I have entered the password. The wifi symbol is showing in the top left hand corner. On the settings page the IP address and subnet mask has automaticaly come up but I can't connect to any web pages.
    The message I get is that it can't connect to the server.
    Should there be something in the Router, DNS, Search Domains and Client ID boxes?
    Please help if you can.

  • Help needed! connecting 2 ipods to one pc

    does anyone have experience with hooking up 2 ipods to one pc? i have both a shuffle and a nano (which is new and needs to be installed) but i am worried that the pc will get confused if i hook up 2 different models with different stuff on them! can anybody tell me what might happen before i actually try it out myself??? appreciate any feedback on this!! thanks michael

    theres 2-3 main methods for doing this on Windows atleast.
    Method 1 is if you want both to have the same songs just connect them one at a time to the PC
    Methods 2 and 3 are based on if you want to use 2 user accounts in windows or not and are covered in more detail here on the apple site http://docs.info.apple.com/article.html?artnum=300432
    PS if you do decide to use 2 user accounts in windows, make sure you turn off "Fast user switching" iTunes does not play well with this feature turned on in windows

  • Help needed on connecting to sqlserver2000

    HI,
    I am using Netbeans 1.4 and sql server2000 .I had downloaded MS sql server SP3 and it's driver and then I added jar files to Classpath.
    When I try to connect to the database I'll get this error message:
    java.lang.ClassNotFoundException: com.microsoft.jdbc.sqlserver.SQLServerDriver
    at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    Error Trace in getConnection() : com.microsoft.jdbc.sqlserver.SQLServerDriver
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    Error: No active Connection
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:164)
    at ss.Connect.getConnection(Connect.java:39)
    at ss.Connect.displayDbProperties(Connect.java:57)
    at ss.Connect.main(Connect.java:93)
    BUILD SUCCESSFUL (total time: 3 seconds)
    Can anyone tell me what the problem is?
    plz help me.......
    thanks

    The jar is not in the Netbeans project's classpath. Both Netbeans and Eclipse (and other IDEs) ignore the external classpath when executing a project's code.

Maybe you are looking for

  • How to compile a single file in a project

    I have placed my java connector file called "xxxTargetconnector .class" in the below mentioned path D:\FSCM9DMO\webserv\FSCMDMO9\applications\peoplesoft\PSIGW\WEB-INF\classes\com\peoplesoft\pt\integrationgateway\targetconnector I have converted the a

  • GeForce2 with Solaris question

    Hello. I asked if Solaris 8 works with an Geforce2 video adapter. Someone gave me this answer (and I am very grateful for it): "You might want to use the XFree86 X Server, with the nv driver. Binaries and source are available from: http://soldc.sun.c

  • My Biometric Scan is not working

    mine is HP ProBook 4445s Notebook PC  with windows 8 and my biometric scan is not working every time i open it, it says device not found and on my laptop finger scaner is provided

  • GetAttribute() method of a view object is returning NULL

    Hi , I am trying to implement PPR in one of my OAF page and I have taken the following approach. I have declared the follwing transient boolean attribute in the VO() apart from the existing attribute "Meaning" . 1.MfgEnttity 2.MfgAcct 3.MfgSubAcct 4.

  • Importing Quicktime Files to Edit in Final Cut Express

    I just bought final cut express to edit quicktime files I receive from work. FCE will not let me import certain files and I get a message saying "Error: File Type Unknown", but what's weird is I CAN import some files that are the EXACT same file type