Help with using xmonad configuration

http://haskell.org/haskellwiki/Xmonad/C … _xmonad.hs
ok when I did ghci <filename> after I downloaded the configuration, I got an error saying parse error on input `<!' Failed modules loaded: none.
how would I go about solving this problem?
PS I'm a noob when it comes to this stuff but I'm learning
Last edited by unregistered (2009-06-08 10:15:41)

Here is Assorato's config:
{-# OPTIONS_GHC -fglasgow-exts -fno-warn-missing-signatures #-}
-- |
-- Module : XMonad.Config.Arossato
-- Copyright : (c) Andrea Rossato 2007
-- License : BSD3-style (see LICENSE)
-- Maintainer : [email protected]
-- Stability : stable
-- Portability : portable
-- This module specifies my xmonad defaults.
module XMonad.Config.Arossato
( -- * Usage
-- $usage
arossatoConfig
) where
import qualified Data.Map as M
import XMonad hiding ( (|||) )
import qualified XMonad.StackSet as W
import XMonad.Actions.CycleWS
import XMonad.Hooks.DynamicLog hiding (xmobar)
import XMonad.Hooks.ManageDocks
import XMonad.Hooks.ServerMode
import XMonad.Layout.Accordion
import XMonad.Layout.LayoutCombinators
import XMonad.Layout.Magnifier
import XMonad.Layout.NoBorders
import XMonad.Layout.SimpleFloat
import XMonad.Layout.Tabbed
import XMonad.Layout.WindowArranger
import XMonad.Prompt
import XMonad.Prompt.Shell
import XMonad.Prompt.Ssh
import XMonad.Prompt.Theme
import XMonad.Prompt.Window
import XMonad.Prompt.XMonad
import XMonad.Util.Run
import XMonad.Util.Themes
-- $usage
-- The simplest way to use this configuration module is to use an
-- @~\/.xmonad\/xmonad.hs@ like this:
-- > module Main (main) where
-- >
-- > import XMonad
-- > import XMonad.Config.Arossato (arossatoConfig)
-- >
-- > main :: IO ()
-- > main = xmonad =<< arossatoConfig
-- NOTE: that I'm using xmobar and, if you don't have xmobar in your
-- PATH, this configuration will produce an error and xmonad will not
-- start. If you don't want to install xmobar get rid of this line at
-- the beginning of 'arossatoConfig'.
-- You can use this module also as a starting point for writing your
-- own configuration module from scratch. Save it as your
-- @~\/.xmonad\/xmonad.hs@ and:
-- 1. Change the module name from
-- > module XMonad.Config.Arossato
-- > ( -- * Usage
-- > -- $usage
-- > arossatoConfig
-- > ) where
-- to
-- > module Main where
-- 2. Add a line like:
-- > main = xmonad =<< arossatoConfig
-- 3. Start playing with the configuration options...;)
arossatoConfig = do
xmobar <- spawnPipe "xmobar" -- REMOVE this line if you do not have xmobar installed!
return $ defaultConfig
{ workspaces = ["home","var","dev","mail","web","doc"] ++
map show [7 .. 9 :: Int]
, logHook = myDynLog xmobar -- REMOVE this line if you do not have xmobar installed!
, manageHook = newManageHook
, layoutHook = avoidStruts $
decorated |||
noBorders mytabs |||
otherLays
, terminal = "urxvt +sb"
, normalBorderColor = "white"
, focusedBorderColor = "black"
, keys = newKeys
, handleEventHook = serverModeEventHook
, focusFollowsMouse = False
where
-- layouts
mytabs = tabbed shrinkText (theme smallClean)
decorated = simpleFloat' shrinkText (theme smallClean)
tiled = Tall 1 (3/100) (1/2)
otherLays = windowArrange $
magnifier tiled |||
noBorders Full |||
Mirror tiled |||
Accordion
-- manageHook
myManageHook = composeAll [ resource =? "win" --> doF (W.shift "doc") -- xpdf
, resource =? "firefox-bin" --> doF (W.shift "web")
newManageHook = myManageHook
-- xmobar
myDynLog h = dynamicLogWithPP defaultPP
{ ppCurrent = xmobarColor "yellow" "" . wrap "[" "]"
, ppTitle = xmobarColor "green" "" . shorten 40
, ppVisible = wrap "(" ")"
, ppOutput = hPutStrLn h
-- key bindings stuff
defKeys = keys defaultConfig
delKeys x = foldr M.delete (defKeys x) (toRemove x)
newKeys x = foldr (uncurry M.insert) (delKeys x) (toAdd x)
-- remove some of the default key bindings
toRemove x =
[ (modMask x , xK_j)
, (modMask x , xK_k)
, (modMask x , xK_p)
, (modMask x .|. shiftMask, xK_p)
, (modMask x .|. shiftMask, xK_q)
, (modMask x , xK_q)
] ++
-- I want modMask .|. shiftMask 1-9 to be free!
[(shiftMask .|. modMask x, k) | k <- [xK_1 .. xK_9]]
-- These are my personal key bindings
toAdd x =
[ ((modMask x , xK_F12 ), xmonadPrompt defaultXPConfig )
, ((modMask x , xK_F3 ), shellPrompt defaultXPConfig )
, ((modMask x , xK_F4 ), sshPrompt defaultXPConfig )
, ((modMask x , xK_F5 ), themePrompt defaultXPConfig )
, ((modMask x , xK_F6 ), windowPromptGoto defaultXPConfig )
, ((modMask x , xK_F7 ), windowPromptBring defaultXPConfig )
, ((modMask x , xK_comma ), prevWS )
, ((modMask x , xK_period), nextWS )
, ((modMask x , xK_Right ), windows W.focusDown )
, ((modMask x , xK_Left ), windows W.focusUp )
-- other stuff: launch some useful utilities
, ((modMask x , xK_F2 ), spawn "urxvt -fg white -bg black +sb" )
, ((modMask x .|. shiftMask, xK_F4 ), spawn "~/bin/dict.sh" )
, ((modMask x .|. shiftMask, xK_F5 ), spawn "~/bin/urlOpen.sh" )
, ((modMask x .|. shiftMask, xK_t ), spawn "~/bin/teaTime.sh" )
, ((modMask x , xK_c ), kill )
, ((modMask x .|. shiftMask, xK_comma ), sendMessage (IncMasterN 1 ) )
, ((modMask x .|. shiftMask, xK_period), sendMessage (IncMasterN (-1)) )
-- commands fo the Magnifier layout
, ((modMask x .|. controlMask , xK_plus ), sendMessage MagnifyMore)
, ((modMask x .|. controlMask , xK_minus), sendMessage MagnifyLess)
, ((modMask x .|. controlMask , xK_o ), sendMessage ToggleOff )
, ((modMask x .|. controlMask .|. shiftMask, xK_o ), sendMessage ToggleOn )
-- windowArranger
, ((modMask x .|. controlMask , xK_a ), sendMessage Arrange )
, ((modMask x .|. controlMask .|. shiftMask, xK_a ), sendMessage DeArrange )
, ((modMask x .|. controlMask , xK_Left ), sendMessage (DecreaseLeft 10))
, ((modMask x .|. controlMask , xK_Up ), sendMessage (DecreaseUp 10))
, ((modMask x .|. controlMask , xK_Right), sendMessage (IncreaseRight 10))
, ((modMask x .|. controlMask , xK_Down ), sendMessage (IncreaseDown 10))
, ((modMask x .|. shiftMask , xK_Left ), sendMessage (MoveLeft 10))
, ((modMask x .|. shiftMask , xK_Right), sendMessage (MoveRight 10))
, ((modMask x .|. shiftMask , xK_Down ), sendMessage (MoveDown 10))
, ((modMask x .|. shiftMask , xK_Up ), sendMessage (MoveUp 10))
-- gaps
, ((modMask x , xK_b ), sendMessage ToggleStruts )
] ++
-- Use modMask .|. shiftMask .|. controlMask 1-9 instead
[( (m .|. modMask x, k), windows $ f i)
| (i, k) <- zip (workspaces x) [xK_1 .. xK_9]
, (f, m) <- [(W.greedyView, 0), (W.shift, shiftMask .|. controlMask)]
As you can see Assorato uses other keybindings than the default ones.

Similar Messages

  • Looking for help with respect to configuring MS Exchange server to handle attachments over 10 MB for forwarding to Salesforce (Email-to-case).

    Looking for help with respect to configuring MS Exchange server to handle attachments over 10 MB for forwarding to Salesforce (Email-to-case).
    Problem - SFDC does not create cases from emails that have more than 10 MB of attachments. Our clients will not go-live if their clients cannot send in emails with attachments over 10 MBs
    Potential resolution - Configure MS exchange to strip off the attachments(if over 10 MB) and store it in a public folder, forward the email to Salesforce (so the case gets created or the email
    is associated to an existing case), the client should have some way to know if the attachments were stripped off and should be able to dlownload the attachments and continue with case resolution.
    Any help is appreicated!
    Thanks

    Hi,
    From your description, you want to achieve the following goal:
    Configure Exchange to filter the attachments if the size is over 10 MB and store it in a public folder, and then forward the email to Salesforce.
    Based on my knowledge, I'm afraid that it can't be achieved. Exchange can filter messages with attachments, but it couldn't store these attachments on public folder automatically. Also, I don't see any transport rule can do it.
    Hope my clarification is helpful.
    Best regards,
    Amy Wang
    TechNet Community Support

  • Help with using multiple hard drives

    Is there a way to install the OS on an "external" (expresscard SSD) drive, but have all of the library and data files on the primary hard disk? I LOVE the speed on my SSD, but it's a pain finding stuff now. Is this something a RAID configuration could help with?

    mwmmartin wrote:
    I have a 1 TB hard drive; but I have a 500GB and 250GB usb external hard drives.
    Wouldn't it be cool if I could make the two external hard drives a RAID drive and use Time Machine to use all the 750GB of external memory to do my backups???
    You can, but I would +*strongly recommend against+* it. See +Concatenated RAID+ in the Help for Disk Utility.
    There are several potential problems:
    Depending on how much data is on your 1 TB drive, 750 GB may not be enough to back it up. See #1 in Time Machine - Frequently Asked Questions (or use the link in *User Tips* at the top of this forum).
    To set up a +Concatenated RAID+ set, both drives will be erased.
    When (not if) either drive fails, you'll lose all the data on both.
    Both drives must be connected any time you do a backup or want to browse your backups.
    Especially with USB, if one drive wakes from sleep, or spins up, quickly enough, but the other one doesn't, the backup may fail and/or your backups may be corrupted.
    For now, it looks like my only solution is to go buy a bigger external hard drive and spend more money,,,
    That's your best solution +*by far.+* Anything else is taking a large risk with your backups.

  • How to make system update with "use automatic configuration script" and an URL

    Hello,
    all our laptop using "use automatic configuration script" with an "accelerated_pac_base.pac" prxy setting.
    How can we make system update work with that ?
    And no way for us to by pass this proxy settings with
    Thanks

    I mean there is no general method which is capable of correcting all possible errors found by schema validation.
    For example if the validation says it expected to find an <organization> element or a <company> element but it found a <banana> element, there is no way to determine what repair is necessary.
    Anyway the requirement is fighting against the way things work in the real world. The purpose of validation is just to find out whether a document matches a schema. If it doesn't, then too bad. Send it back to be fixed or replaced. If you are having a problem because you repeatedly get documents which don't quite match your schema, then you need to train the users to produce valid documents or to give them tools which help them do that.

  • Need help with using Solaris FLAR across disparate platforms

    All,
    I need help with what needs to be done to use solaris Flash for disaster recovery between the disparate Server platforms listed below.
    I am concerned about the platform specific files that would be missing?
    Note: All our servers are installed with the SUNWCprog cluster through Custom jumpstart and We use disksuite for mirroring the operating system drives.
    Primary Server     Recovery Server
    Sun Fire 6800     Sun Fire E2900
    Sun Fire E2900     Sun Fire 6800
    Sun Fire-880     Sun Fire-V440
    Sun Fire-V440     Sun Fire-880
    Sun Fire 4800     Sun Fire-880
    Sun Fire-V890     Sun Fire 4800          
    Me

    jds2n,
    Is it possible to get around installing the Entire Distribution + OEM and include only the platform specific files?
    Just a thought
    Example:
    I would like to create a Flash Archive of a E2900 server which i plan to use to recover a 6900.
    The 2900 was installed with a developer cluster.
    When creating the Flash archive of the 2900 is it possible to add the 6900 platform specific files and drivers
    from the Solaris CD?
    Thanks

  • Need help with using Email Activation Agent

    Hi,
    please, help me with using E-mail Activation Agent.
    I used email activation agent to start business processes by email, but after that letter disappear from email-server.
    Where letter was located?
    Can I get and read letter for processing?

    Mail/Preferences/General - do you have Unibox set as your default e-mail application?

  • Help with using a web page from disk after saved from web

    Hi, I almost forgot the little I learned about web page development, so, I'm a total noob when it comes to this and I need your help.
    I saved as a complete web page on my hard disk this web page but when I open it in Firefox or IE, it doesn't display as much as I need it. I'm mostly interested  in displaying the logo images as they appear on the original web page. The browsers just show them briefly when refreshing but hide them right away. I can see the image files downloaded to my hard drive and if I open the page in Dreamweaver it displays these images  in the preview pane but I can't make them show in the browsers. From Dreamweaver I saved the page as in the folder where the images are and this also updated the code with the relative image links but the browsers still don't show them.
    I will greatly appreciate your help with this.

    I'm sorry, but your post is very confusing
    I saved as a complete web page on my hard disk this web page
    Does this include site definitions?
    when I open it in Firefox or IE, it doesn't display as much as I need it.
    I dont know what this means...are there images that are not being displayed?  Is there styling that is not being rendered?
    . I'm mostly interested  in displaying the logo images as they appear on the original web page. The browsers just show them briefly when refreshing but hide them right away.
    Again, I dont know what this means?
    I can see the image files downloaded to my hard drive and if I open the page in Dreamweaver it displays these images  in the preview pane but I can't make them show in the browsers. From Dreamweaver I saved the page as in the folder where the images are and this also updated the code with the relative image links but the browsers still don't show them.I will greatly appreciate your help with this.
    Do you have a link to the page, and perhaps some explanation that is more clear as to what your issue is.
    Gary

  • Videoconfrence : Help with MCU to configure in CCM

    Hi,
    I have a confusion with the configuration of the MCU in CallManager when i want to have a multipoint videoconference where 3 SCCP viedo endpoints(7985) and 1 Polycom video endpoint (H.323) participate all in the same confenrence!
    Here is attached the architecture of my videoconference deseign.
    I have activated SCCP and H.323 on the MCU.
    I have added the MCU as a conference bridge in CCM, and configured MRGL to use this Conference Bridge.i associated the MRGL with the 3 video SCCP endpoint(7985) and now i can do Multipoint videoconference between the three video endpoints (7985)!!
    The problem that i want to the Polycom participate and to initiate a videoconference with the other SCCP endpoints.
    I have added a gatekeeper, i registered the MCU (H.323 activated) with the gatekeeper!! In CCM i added the gatekeeper and added a trunk Gatekeeper controlled!!
    Now here is my problem: what else to do in CCM??
    Should i create a route pattern that points to the trunk ??
    or should i add the MCU as a H.323 gateway and a route pattern that points to the this H.323 gateway???
    PLz help me, i really have a serious problem.
    Thx

    Hi,
    i think that the most difficult part is done now.
    plz can u tell me first of all if the bridge is registered with the callmanager?in the administration page of the CCM, click SERVICE >> MEDIA RESOURCE >> CONFERENCE BRIDGE.
    Then u have to find your bridge configured (u should see it's IP address).
    If this is done, so u need to configure a service (SCCP activated)in the MCU.
    U need to login to ur mcu with a browser, then click SERVICES >> ADD , and u need to activate the SCCP field, then choose ur video and audio parameters.
    If this is done so to start a videoconference(between 3 persons for example) all u have to do is :
    If u have 3 persons : A,B and C (and u'r the person A)
    so A calls B normally, here a point to point videocall should be established (done by the CCM), then to make multipoint videoconference, u shoud click on the button MORE of ur phone, u'll see the word CONF, click CONF, u enter the number of the third person and when he hangs on the phone u click an other once on CONF. then a Multipoint videoconference should be established using the bridge this once.
    unfortunately i can't have picture of my configuration because i did it in a production in another entreprise but u the online course (ICRMC) an e-learning course, had helped me a lot an there is flash videos that can give u an idea:
    http://www.cisco.com/web/learning/le36/learning_partner_e-learning_connection_tool_launch.html
    i hope this helps,
    If there is an other problem plz contact me.

  • Help with Class-map configuration - ZBFW

    Hello,
    I need some clarification regarding the class-map configuration in a ZBFW. I need to allow https,http,ftp & rdp traffic from Internet to few of the servers inside our LAN. So I put the below configuration to accomplish the task (example shows class-map for only https protocol) :
    a.)
    class-map type inspect match-all HTTPS-ACCESS
    match protocol https
    match access-group name HTTPS-SERVER-ACCESS
    ip access-list extended HTTPS-SERVER-ACCESS
    permit tcp any host 172.17.0.55 eq 443
    permit tcp any host 172.17.0.56 eq 443
    permit tcp any host 172.17.0.36 eq 443
    permit tcp any host 172.17.0.45 eq 443
    permit tcp any host 172.17.0.60 eq 443
    Where 55,56,36,45,60 are the servers inside the LAN (12 more servers are there) that need to be accessed via https,http,ftp & rdp from Internet.
    Is it a correct approach? or do I need to change my configuation so that I have to match ACL with my class-map like below:
    b.)
    ip access-list extended OUTSIDE-TO-INSIDE-ACL
    permit tcp any host 172.17.0.55 eq 443
    permit tcp any host 172.17.0.55 eq www
    permit tcp any host 172.17.0.55 eq 21
    permit tcp any host 172.17.0.55 eq 3389
    permit tcp any host 172.17.0.56 eq 443
    permit tcp any host 172.17.0.56 eq www
    permit tcp any host 172.17.0.56 eq 21
    permit tcp any host 172.17.0.56 eq 3389
    permit tcp any host 172.17.0.36 eq 443
    permit tcp any host 172.17.0.36 eq www
    permit tcp any host 172.17.0.36 eq 21
    permit tcp any host 172.17.0.36 eq 3389
    permit tcp any host 172.17.0.45 eq 443
    permit tcp any host 172.17.0.45 eq www
    permit tcp any host 172.17.0.45 eq 21
    permit tcp any host 172.17.0.45 eq 3389
    class-map type inspect match-all OUT-IN-CLASS
    match access-group name OUTSIDE-TO-INSIDE-ACL
    Which one is the correct approach when we consider the performance of the firewall ? Please help me.
    Regards,
    Yadhu

    Hey
    I do not agree with Varun, I think the first approach is the best one.
    Why? Because when you issue the "match protocol ..." you are usig NBAR wich is an application inspection software, which means that https or whatever protocol is inspected at layer 7, not layer 3 and 4 which the seconds approach does (IP and port-number).
    Lets say you use the second approach and an attacker uses some malicious protocol that runs over port 443 or whatever (a port that you opened).  That attack would be successfull because all you say, you are going to IP-address 172.17.0.56 over port 443 so go ahead.
    But if you are using NBAR, this would not work because NBAR will look at layer 7, inside the protocol itself and look if this really is HTTPS (or whatever protocol).
    That's my two cents. Hope it helped!

  • A little help for my xmonad configuration???

    i'm totally new with xmonad, and i'm all confused with this problem...
    it says that the last statement in a 'do' block must be an expression or something...
    i'm just following http://thinkingeek.com/2011/11/21/simpl … en2-conky/,
    everything goes right except the "log hook" part...
    i don't really know Haskell code,
    thanks for the help and sorry for my bad English,
    here's the code...
    -- import stuffs {
    import XMonad
    import XMonad.Actions.CycleWS
    import XMonad.Hooks.ManageDocks
    import XMonad.Hooks.ManageHelpers
    import XMonad.Hooks.SetWMName
    import XMonad.Hooks.DynamicLog
    import XMonad.Hooks.UrgencyHook
    import XMonad.Hooks.FadeInactive
    import XMonad.Hooks.EwmhDesktops
    import XMonad.Layout.SimpleFloat
    import XMonad.Layout.NoBorders (smartBorders, noBorders)
    import XMonad.Layout.PerWorkspace (onWorkspace, onWorkspaces)
    import XMonad.Layout.Reflect (reflectHoriz)
    import XMonad.Layout.IM
    import XMonad.Layout.SimpleFloat
    import XMonad.Layout.Spacing
    import XMonad.Layout.ResizableTile
    import XMonad.Layout.LayoutHints
    import XMonad.Layout.LayoutModifier
    import XMonad.Layout.Grid
    import XMonad.Operations
    import XMonad.Prompt
    import XMonad.Prompt.RunOrRaise (runOrRaisePrompt)
    import XMonad.Prompt.AppendFile (appendFilePrompt)
    import XMonad.Util.Run
    import Control.Monad
    import Data.Ratio ((%))
    import System.IO
    import System.Exit
    import qualified XMonad.StackSet as W
    import qualified Data.Map as M
    -- end of import stuffs }
    -- default terminal {
    myTerm = "urxvt"
    -- end of default terminal }
    -- workspaces {
    myWork = ["home", "surf", "devs", "ofce", "play", "misc"]
    -- end of workspaces }
    -- mod key {
    myModm = mod4Mask
    -- end of modkey }
    -- window border {
    myBord = 1
    myNorm = "#272727"
    myFocu = "#5387BF"
    -- end of window border }
    -- keybinding {
    -- key to add
    addKeys x = [
    -- closing window
    ((modMask x, xK_c), kill)
    -- key to remove
    removeKeys x = [
    -- gmrun
    (modMask x .|. shiftMask, xK_p),
    -- closing window
    (modMask x .|. shiftMask, xK_c)
    -- strip the key to remove
    strippedKeys x = foldr M.delete (keys defaultConfig x) (removeKeys x)
    -- merging keys
    myKeys x = M.union (strippedKeys x) (M.fromList (addKeys x))
    -- end of keybinding }
    -- layout hooks {
    defaultLayouts = tiled ||| Mirror tiled ||| simpleFloat ||| Full
    where
    -- tiling algorithm
    tiled = Tall nmaster delta ratio
    -- master window count
    nmaster = 1
    -- master pane portion
    ratio = 2/3
    -- increment/decrement resize
    delta = 3/100
    -- specific workspaces
    miscLayout = noBorders $ Full
    -- merging layout
    myLayo = onWorkspace "misc" miscLayout $ defaultLayouts
    -- end of layout hooks }
    -- log hooks
    myLogh :: Handle -> X ()
    myLogh h = dynamicLogWithPP $ defaultPP {
    ppCurrent = dzenColor "#ebac54" "#1B1D1E" . pad,
    ppVisible = dzenColor "white" "#1B1D1E" . pad,
    ppHidden = dzenColor "white" "#1B1D1E" . pad,
    ppHiddenNoWindows = dzenColor "#7b7b7b" "#1B1D1E" . pad,
    ppUrgent = dzenColor "#ff0000" "#1B1D1E" . pad,
    ppWsSep = " ",
    ppSep = " | ",
    ppLayout = dzenColor "#ebac54" "#1B1D1E" . (
    \x -> case x of
    "ResizableTall" -> "^i(" ++ myBitmapsDir ++ "/tall.xbm)"
    "Mirror ResizableTall" -> "^i(" ++ myBitmapsDir ++ "/mtall.xbm)"
    "Full" -> "^i(" ++ myBitmapsDir ++ "/full.xbm)"
    "Simple Float" -> "~"
    _ -> x
    ppTitle = (" " ++) . dzenColor "white" "#1B1D1E" . dzenEscape,
    ppOutput = hPutStrLn h
    -- end of log hooks
    -- manage hooks {
    myMana = composeAll . concat $ [
    -- apps to surf
    [ className =? t --> shiftWin "surf" | t <- mySurfClass ],
    -- apps to devs
    [ className =? t --> shiftWin "devs" | t <- myDevsClass ],
    -- apps to float
    [ className =? f --> doFloat | f <- myFloatClass ]
    where
    shiftWin = doF . liftM2 (.) W.greedyView W.shift
    mySurfClass = ["Luakit", "luakit", "Chromium"]
    myDevsClass = ["Geany", "Gedit", "Netbeans"]
    myFloatClass = ["Gimp"]
    -- end of manage hooks }
    -- dzen bar
    myDzen = "dzen2 -x '1440' -y '0' -h '24' -w '640' -ta 'l' -fg '#FFFFFF' -bg '#1B1D1E'"
    myBitmapsDir = "/home/perud/.xmonad/dzen2"
    -- end of dzen bar
    -- status bar
    myStat = "conky -c /home/perud/.xmonad/.conky_dzen | dzen2 -x '2080' -w '1040' -h '24' -ta 'r' -bg '#1B1D1E' -fg '#FFFFFF' -y '0'"
    -- end of status bar
    -- MAIN METHOD
    main = do
    dzenLeftBar <- spawnPipe myDzen
    dzenRightBar <- spawnPipe myStat
    xmonad $ defaultConfig {
    terminal = myTerm,
    workspaces = myWork,
    modMask = myModm,
    borderWidth = myBord,
    normalBorderColor = myNorm,
    focusedBorderColor = myFocu,
    keys = myKeys,
    layoutHook = myLayo,
    logHook = myLogh dzenLeft >> fadeInactiveLogHook 0xdddddddd,
    manageHook = myMana
    -- END OF MAIN METHOD
    Last edited by perud (2013-02-14 02:28:03)

    Please use code tags when pasting to the boards:
    https://wiki.archlinux.org/index.php/Fo … s_and_Code

  • Newbie help with Fixed IP configuration / Machine Record

    I have a Mac Mini running Snow Leopard Server. It has a fixed IP, and runs a variety of web services, iCal Server and Address Book Server. I've been having problems getting VPN to work (can connect from client OK, but not able to get any traffic through the VPN subsequently).
    In the process of trying to work out what is wrong with VPN, I noticed an oddity with the 'machine record' in DNS. The server was configured initially while connected to a LAN, but now runs with a fixed IP / FQDN outside the LAN.
    DNS is set up with the original machine name (sls.2gc.org) assigned to the original 192.x.x.x address it had when first configured. The reverse entry is also based on this 192. number.
    This name and 192.x.x.x number also appears in the 'Workgroup Manager' in the machine record.
    The new configuration has the machine assigned to a FQDN that is not the same as the original machine name (2gc.org, rather than sls.2gc.org), and a different IP address (77.44.50.51).
    Question is do I need to do anything (does the mapping to 192.x.x.x matter). If so, do I simply run changeip to correct the number / name, or do I have to also manually change the Workgroup Manager and DNS entries too?
    Thanks in advance for any help.

    You need a second IP for the server which you can use to get at services in the server itself.
    If you try to use the main IP, even when the VPN is up, the traffic will not go through the VPN but direct and will then be stopped by the firewall.
    From what IP-range does the VPN client get it's IP?
    If you need to go through the VPN and then to Internet (via the server) you need to have NAT running.
    NAT requires the firewall running and you'd also need ipforwarding (automatically on when firewall/NAT is on).
    The server can have a second (private) IP added to an alias en0 ethernet interface.
    I'd prefer using a NAT router/firewall between server and Internet or a second (LAN) interface in the server. Some use Apple USB -> ethernet adapter but you also have the AirPort one (but it won't make a good AP and you only get WEP encryption).

  • Help with using the WRT54G as an Access Point

    Ever since I've been using the WRT54G as an access point behind another router I have been experiencing intermittent disconnects and reconnects from the internet anywhere from once every 5 to 60 minutes.  I get the message notifcation that the Local Area Network is disconnected for a split second before everything reconnects and works fine.  This has been happening on my desktop which is wired directly to the WRT54G which itself is wired directly to the other router, but I have also experienced these disconnects with my iPhone and laptops which have been using the wireless signal. 
    When I was connected directly to the original router I hadn't experienced any of these problems.  I've also tried changing settings and even disabling the wireless broadcast of the WRT54G but to no avail.  I can't figure out what the issue is, but it seems to also be affecting the wireless broadcast of the original router. 
    I've updated firmware for the Linksys, and I've done a reset for the Linksys as well.
    Any help would be much appreciated to get rid of these disconnects.

    OK, so I've tried a different setting to see if it'll work. 
    Previously I had not configured the WAN of the Linksys router at all and left it on Auto (DHCP) even though I disabled the DHCP for the LAN.  I've now set the WAN up to a random Static IP and hopefully this will solve the problem, but I'm not sure as of yet, if anyone could look over the settings to see if they're correct please let me know.
    Router 1- (Router)
    WAN - Configured to ISP
    LAN - DHCP
    IP: 192.168.1.1
    Subnet: 255.255.255.0
    IP Range: 192.168.1.100 - 192.168.1.150
    Router 2 - Linksys (AP)
    WAN - Static IP
    IP: 64.XXX.XXX.1 (made up value)
    Subnet: 255.255.255.0
    Gateway: 64.XXX.XXX.254 (made up value)
    DNS: XX.XXX.XXX.X (made up value)
    LAN - DHCP disabled
    IP: 192.168.1.2
    Subnet: 255.255.255.252
    The WRT54G was a bit of a pain in terms of what Static IP and Gateway values they would accept, so I had to randomly put in values until I found something that worked.  So far no disconnects, but it's only been half an hour.  I can't seem to access the admin page for my Linksys router at 192.168.1.2 anymore though.

  • Need help with cisco 881 configuration.

    Hi, I have cisco 881 wireless router, and I need to configure this as a switch, I have dhcp server in network 192.168.12.254, and I need that cisco wifi and lan clients get IP addresses from existing dhcp server.
    I connect wire from network (with dhcp server) to FastEthernet0, create vlan interface (192.168.12.10 255.255.255.0), described vlan on other FastEthernet interfaces, so LAN clients get IP addresses from my dhcp server without problems, but how to do the same with wifi clients?

    Follow this support doc because you need to trunk the AP to the router and specify the vlan the wireelss clients will be on.
    https://supportforums.cisco.com/docs/DOC-16145
    Here is a doc that guides you through multiple vlans/subnets on access points:
    https://supportforums.cisco.com/docs/DOC-14496
    Thanks,
    Scott
    Help out other by using the rating system and marking answered questions as "Answered"

  • Help with QoS basic configuration.

    Hi all, i want to configure qos in a cisco lan with non cisco phone. I read a lot of documentation and some basic videos. I don't want to configure it very granular, so, the most basic commands that i found:
    conf t
    int fa0/5
    switchport voice vlan 111
    mls qos trust cos
    auto qos voip trust
    How i'm be realy sure that QoS is working on mi lan?
    And how about the interface trunk configuration?
    Any suggestion?
    Here are the verification:
    In the show running-configuration :
    mls qos map cos-dscp 0 8 16 24 32 46 48 56
    mls qos srr-queue input bandwidth 70 30
    mls qos srr-queue input threshold 1 80 90
    mls qos srr-queue input priority-queue 2 bandwidth 30
    mls qos srr-queue input cos-map queue 1 threshold 2 3
    mls qos srr-queue input cos-map queue 1 threshold 3 6 7
    mls qos srr-queue input cos-map queue 2 threshold 1 4
    mls qos srr-queue input dscp-map queue 1 threshold 2 24
    mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55
    mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63
    mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45
    mls qos srr-queue input dscp-map queue 2 threshold 3 46 47
    mls qos srr-queue output cos-map queue 1 threshold 3 4 5
    mls qos srr-queue output cos-map queue 2 threshold 1 2
    mls qos srr-queue output cos-map queue 2 threshold 2 3
    mls qos srr-queue output cos-map queue 2 threshold 3 6 7
    mls qos srr-queue output cos-map queue 3 threshold 3 0
    mls qos srr-queue output cos-map queue 4 threshold 3 1
    mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
    mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
    mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
    mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
    mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
    mls qos srr-queue output dscp-map queue 2 threshold 2 24
    mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
    mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
    mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
    mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
    mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
    mls qos queue-set output 1 threshold 1 100 100 50 200
    mls qos queue-set output 1 threshold 2 125 125 100 400
    mls qos queue-set output 1 threshold 3 100 100 100 400
    mls qos queue-set output 1 threshold 4 60 150 50 200
    mls qos queue-set output 1 buffers 15 25 40 20
    mls qos
    In the interface configuration:
    interface FastEthernet0/5
    switchport access vlan 111
    switchport mode access
    switchport voice vlan 111
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust cos
    auto qos trust
    spanning-tree portfast
    In trunk port:
    interface GigabitEthernet0/1
    switchport mode trunk
    sh mls qos int f0/5
    FastEthernet0/5
    trust state: trust cos
    trust mode: trust cos
    trust enabled flag: ena
    COS override: dis
    default COS: 0
    DSCP Mutation Map: Default DSCP Mutation Map
    Trust device: none
    qos mode: port-based
    Thanks a lot !
    Martín.

    Hi, thanks for reply. I investigate a little more.
    When i want verify that QoS really work in the lan, first of all:
    - The marking (in my case verify traffic VoIP at 64)
    - Queue, that put first in the queue voice traffic, dscp 64
    To try, i make a call connecting an IP phone (in fa0/6) and call to analog phone. Wait for 2 minutes and see what changes in this command:
    Switch#sh mls qos int f0/6 stFastEthernet0/6 (All statistics are in packets)  dscp: incoming-------------------------------  0 -  4 :       4465744658 0            0            0            0  5 -  9 :           0            0            0            0            0 10 - 14 :           0            0            0            0            0 15 - 19 :           0            0            0            0            0 20 - 24 :           0            0            0            0            0 25 - 29 :           0         1196            0            0            0 30 - 34 :           0            0            0            0            0 35 - 39 :           0            0            0            0            0 40 - 44 :           0            0            0            0            0 45 - 49 :           0        41769 62163 0           91 98            0 50 - 54 :           0            0            0            0            0 55 - 59 :           0            0            0            0            0 60 - 64 :           0            0            0            0  dscp: outgoing-------------------------------  0 -  4 :      251670 272323 0            0            0            0  5 -  9 :           0            0            0            0            0 10 - 14 :           0            0            0            0            0 15 - 19 :           0            0            0            0            0 20 - 24 :           0            0            0            0            0 25 - 29 :           0            0            0            0            0 30 - 34 :           0            0            0            0            0 35 - 39 :           0            0            0            0            0 40 - 44 :           0            0            0            0            0 45 - 49 :           0         3393            0            0            0 50 - 54 :           0            0            0            0            0 55 - 59 :           0            0            0            0            0 60 - 64 :           0            0            0            0  cos: incoming-------------------------------  0 -  4 :       89094 109541 0            0            0            0  5 -  7 :           0            0            0  cos: outgoing-------------------------------  0 -  4 :      295699 316387 0            0            0            0  5 -  7 :        3393            0            0  output queues enqueued: queue:    threshold1   threshold2   threshold3----------------------------------------------- queue 0:           2           0           0 queue 1:      209108        1534      194272 queue 2:           0           0       56565 queue 3:           0           0       33762  output queues dropped: queue:    threshold1   threshold2   threshold3----------------------------------------------- queue 0:           0           0           0 queue 1:          57           0           0 queue 2:           0           0           0 queue 3:           0           0           0Policer: Inprofile:            0 OutofProfile:            0
    The underlined numbers is the variations in aprox. 2 minutes in the call. That mean that the traffic was marked as VoIP traffic, but i´m not sure that the traffic is queued right.
    I´m wrong?
    Thanks for the help
    PS:Later monitoring: with iperf or Cacti using IP SLA.

  • Help with using Scanner Class

    Hi there - I'm a newbie to Java and may have posted this in the wrong forum previously.
    I am trying to modify a program so instead of using a BufferReader, a scanner class will be used. It is basically a program to read in a name and then display the variable in a line of text.
    Being new to Java and a weak programmer, I am getting in a mess with this and missing something somewhere. I don't think I'm using scanner in the correct way.
    Any help or pointers would be good. There are 2 programs of code being used. 'Sample' and 'Run Sample'
    Thanks in advance.
    Firstly, this program will run named 'Sample'
    <code>
    * Sample.java
    * Class description and usage here.
    * Created on 15 October 2006
    package internetics;
    * @author John
    * @version 1.2
    import javax.swing.*;
    import java.awt.*;
    import java.awt.event.*;
    import java.io.*;
    // import com.ralph.*;
    public class Sample extends JFrame
    implements java.awt.event.ActionListener{
    private JButton jButton1; // this button is for pressing
    private JLabel jLabel1;
    private String name;
    /** Creates new object ChooseFile */
    public Sample() {
    initComponents();
    name = "";
    selectInput();
    public Sample(String name) {
    this();
    this.name = name;
    private void initComponents() {
    Color bright = Color.red;
    jButton1 = new JButton();
    jLabel1= new JLabel();
    addWindowListener(new WindowAdapter() {
    public void windowClosing(WindowEvent evt) {
    exitForm(evt);
    getContentPane().setLayout(new java.awt.GridLayout(2, 1));
    jButton1.setBackground(Color.white);
    jButton1.setFont(new Font("Verdana", 1, 12));
    jButton1.setForeground(bright);
    jButton1.setText("Click Me!");
    jButton1.addActionListener(this);
    jLabel1.setFont(new Font("Verdana", 1, 18));
    jLabel1.setText("05975575");
    jLabel1.setOpaque(true);
    getContentPane().add(jButton1);
    getContentPane().add(jLabel1);
    pack();
    public void actionPerformed(ActionEvent evt) {
    System.out.print("Talk to me " name " : ");
    try {
    jLabel1.setText(input.readLine());
    } catch (IOException ioe) {
    jLabel1.setText("Ow! You pushed my button");
    System.err.println("IO Error: " + ioe);
    /** Exit this Application */
    private void exitForm(WindowEvent evt) {
    System.exit(0);
    /** Initialise and Scan input Stream */
    private void selectInput() {
    input = new Scanner(new InputStreamReader(System.in));
    /**int i = sc.nextInt(); */
    /** Getter for name prompt */
    public String getName() {
    return name;
    /** Setter for name prompt */
    public void setName(String name) {
    this.name = name;
    * @param args the command line arguments
    public static void main(String args[]) {
    new Sample("John").show();
    </code>
    and this is the second program called 'RunSample will run.
    <code>
    class RunSample {
    public static void main(String args[]) {
    new internetics.Sample("John").show();
    </code>

    The compiler I'm using is showing errors in these areas of the code. I've read the tutorials and still can't get it. They syntax for the scanner must be in the wrong format??
    the input.readLine appears incorrect below.
      public void actionPerformed(ActionEvent evt) {
        System.out.print("Talk to me " +name+ " : ");
        try {
            jLabel1.setText(input.readLine());
        } catch (IOException ioe) {
          jLabel1.setText("Ow! You pushed my button");
          System.err.println("IO Error: " + ioe);
        }and also here...
    the input is showing errors
      /** Initialise and Scan input Stream */
      private void selectInput() {
        input = new Scanner(new InputStreamReader(System.in));
       /**int i = sc.nextInt(); */
      }Thanks

Maybe you are looking for

  • RH9 Webhelp Search function is not working properly

    Hi, My organization is using RH9 for a Webhelp project.  My company and our client are restricted to using IE9 for the online help I have created for this project, and our OS environment is Windows 7.  When I generate using the Webhelp layout, with t

  • MouseMove problem in JPanel

    Hello I am writing an applet and I am calling a class which extends JPanel. In the JPanel I am trying to create a rectangle (fillRect) which than I will be able to move using the method mouseMove(). I have been able to draw the rectangle on the panel

  • TCODE to find users Looged in the system

    Hi Friends, I want to see all the USERS logged into any of the SAP system. Thanks, Ster

  • Price diffrence calculate

    Hi Gurus, just I want to know how the price diffrence calculate and hit the material. For example A purchase Order is raised and the amount of Rsa.10000/-. GRN is made and when the invoice verification is done the user give 9000/- instead of 10000/-.

  • Failed app store update. Safari 8.0.4

    Hi all Mid 2012 Macbook Pro, running OS X Yosemite 10.10.2. I received the red number bubble last night indicating available updates within the App Store, I clicked on update all and run through the normal rigamarole of restarts etc. The iPhoto app u