How to implement MVC model?

Hi, I have a question on how to implement MVC model, that is, how will the GUI be informed that the data from the Model has been changed?
Suppose that I have two simple classes, Model and GUI. Model creates 10 integers each time, and then GUI draws some bars whose height is the integers. then after each time the integers has been created, how could GUI know?
Thanks!!!!

There is an Observer pattern specific to Google?I so implement the Google Observer pattern. ;o)Isn't that the (G)oogling Observer pattern? ;)

Similar Messages

  • How to implement mvc model in designing game architecture

    I have a problem in implementing the mvc architecture in my game designing. I want you to suggest me how should I do it ?
    I have created 3 packages viz : model , view , and controller
    I am confused in which package should include canvas ? which should implement Runnable ? and what actually the model package must include ?
    Also i would like to know that whatever dynamic active background is generated in my game play must it be treated as model or not ?

    Hi
    Here is a good article about this: http://www-128.ibm.com/developerworks/library/wi-arch6/?ca=drs-wi3704
    Mihai

  • How to implement custom Model Class in Oracle ADF?

    I am using Oracle ADF for one of my project and i am using Query component of ADF. For given tables the query component creates view objects and maps the relations. ADF uses its own custom model class for this component and it should understand the DB tables. But for my project i have no access to database. All i can do is pass a string or object/query to the existing (custom) Java class/object, and this model class formulates query and queries the database and returns the value to my Java class. I have to display these results using ADF to the front end. Is There a way to achieve this? Can i replace/override the existing Model class of ADF. If so how?
    Thanks in advance for your help.

    Hi, there:
    Best thing to do is to start with the default login.html page, and then modify it. The login screen is fairly complex and it's easy to just miss a JS function you need to call. To get to default page, you would need to do one deploy (to simulator or whatever), and then look for login.html page in the temporary Xcode or Android project generated from the deployment. It should be under the "deploy" directory in your JDev workspace.
    You can also see all the framework JS files and CSS files that way as well.
    We have had customers implementing custom login screen so we know it can work, but they all had to start with the default login screen and then modify it.
    Thanks,
    Joe Huang

  • Is there a way to specify MVC model in a Wizard?

    I am fairly new to JDeveloper so forgive me if I ask a stupid question....
    In a past web project I used IBM Websphere and Visual Age developing environments. For an upcoming project I am going to be using JDeveloper but with the same basic MVC architecture with the Servlets being the Controllers and JSP as the View. In Websphere there was a wizard that we could use to create a Java Bean based on our SQL statement. Within this wizard we could also select what 'model' we wanted to use and if we chose 'Servlet model' it would not only create the Java Bean but it would also crate the corresponding Servlet, XML file and JSP. All we had to do after that was bring up the JSP in the test environment and everything was hooked together already. If it was a simple select statement then the JSP displayed the results in a table. The JSP could then be facncied up or whatever. What I want to know is if there is something similar to that in JDeveloper. I know there are wizards to create Servlets and JSPs but is there any way to specifiy a 'model' and have everything to connected up without manually going into the code and doing it? I know this is kinda cheating and being lazy but I just wanted to ask if this type of feature existed before going ahead and doing unneccessary work. So if anyone can follow what I am saying and has an answer or perhaps can direct me to some documentation, that would be much appreciated. Thanks in advance for your help!
    Janis

    Janis,
    JDeveloper ships with a handy, built-in J2EE application framework called Business Components for Java that provides a full-functionality J2EE MVC model layer for you.
    You can get a nice overview of the framework's functionality from this whitepaper:
    Simplify J2EE Applications with the Oracle BC4J Framework
    For a quick overview of how the BC4J framework components implement the familiar collections of value objects design pattern for you, see:
    Implement Collections of Value Objects for MVC Apps with BC4J
    To answer your question about the wizards, you can (in no time flat)
    [list]
    [*]Create a new connection in the System Navigator
    [*]Create a new package of BC4J framework components ("New Business Components Package...")
    [*]On the last panel of the BC4J package wizard, you can select existing tables to reverse-engineer into framework data-access and business logic components (view objects and entity objects, respectively)
    [*]Then, you can use one of our other wizards to produce, for example, a BC4J+Struts application, a BC4J+JSP application, or a BC4J+JClient/Swing (rich client) application
    [list]
    Hope this helps.

  • MVC model in Web systems and applications

    MVC model in Web systems and applications
    Object-oriented design model is experience, MVC idea is a user interface for the original. This article discusses how the major application areas in the new Web design patterns and the use of MVC framework. The article first introduced the concept of design patterns and characteristics, and MVC architecture design concepts and analysis of the MVC framework contains several key models. Based on the characteristics of Web applications on how to use patterns and MVC framework made some design ideas.??
    1. Introduction
    1.1 design model
    Object-oriented technology and the emergence of software applications has greatly enhanced the trusted and software quality. Object-oriented programming than previous models to various programming simple and efficient, but the object-oriented design methodology than the previous design methods to complex and much more skill, a good design should be both on the issue of gender, but also to take full account of the problems and needs sufficient interoperability. In the past 10 years, people in the object-oriented technology and the practical application of research to explore certain issues in relation to the creation of a number of good solutions, the so-called object-oriented design patterns. Object-oriented technology is one of the purposes of enhancing the software trusted, and to design model, design programmes in important positions from a deeper sense of meaning and essence embodies trusted. There are many people in the design model definition, which cited Christopher Alexander is the largest design model definition : Each design model is a tripartite rule, which expresses a contextual environment (Context), a problem and a solution. Design models generally following basic elements : model name, the purpose solution effect 1995-1998 code and related design models. There are several classifications design patterns can be divided into a model based on the purpose (Creational), structural type (Structural) and the type of behaviour (Behavioral) three. It is mainly used in the creation of a model-based object model-based structure to deal primarily with the category or combination of objects, used to describe behavior-based model is the main target for the category or how stress and how to allocate responsibilities. Design patterns can be divided into categories based on the scope and target mode model type model dealing with the relationship between the categories and sub-categories, these relations through the establishment of succession in Translation moment to be finalized, are static. Model is targeted at addressing the relationship between the moment of change these relations in the operation, more dynamic. Model features : through the experience acquired in a structured format to write down, avoid encountering the same problems on the first design, exist in different abstract level, in continuous improvement, can be trusted artificial product for the design and best practice in the world to be combined to address larger issues.
    1.2 MVC framework
    MVC was first used in a user interface Smalltalk-80 China. M representative models Model, representatives maps View V, C representatives controller Controller. MVC trusted code with the aim of increasing the rate of data reduction expressed, the data describing the operation and application coupled degrees. Also makes software Keweihuxing, restorative, expansionary, flexibility and packaging of greatly enhanced. Single-user applications are usually incident-driven user interface to the organizational structure. Staff development tool with an interface painting of a user interface interface code based on user input and then prepare to implement the corresponding moves, many interactive development environment encouraged to do so, because it emphasizes first and then a functional interface. Some software design model is the strategy that will be fixed before the code into the regular system of the final. Result is that the procedures and organizations around the user interface elements in the user interface elements of those moves, data storage, applications and functions of the code is used to indicate the way intertwined. In single-user system code structure can be so, because the system will not demand frequent changes. But for a large system such as large Web systems, or e-commerce systems to be applied. Model by incorporating data from a variety of access and control data can be separated to improve distributed system design. MVC design pattern is composed of three parts. Model is the application object, no user interface. Type in the screen showing that it represents the flow of data users. Controller user interface definition response to user input, the users responsible for the action against the Model into operation. Model View data updated to reflect the adoption of data changes.
    2. MVC design pattern,
    An MVC framework for the design of the system includes many models, but with MVC is most closely related to the following three models : Observer, Cambridge and Strategy.
    2.1 Observer models
    MVC through the use of purchase / notification form and the separation of the Model View. View to ensure that their content accurately reflected Model and state. Once Model content changes, there must be a mechanism to allow notification to the relevant Model View, View can be made relevant at the appropriate time updating of data. This design is also more general problems can be solved, the target separation, making a change to the target audience affect others, which targets those who do not know the details of the object being affected. This is described as Observer in the design model. Model type : Observer model is the object-oriented model, it is behaviour-based model. Model purposes : definition of hierarchical dependence relations between objects, or when a target value of the state change, all its dependent relationship with the object are notified and automatically updated. There are a variety of data may show a way, in different ways and may also show. When a way through a changed data, then the other should be able to show immediately that the data change and do accordingly.
    Effect :
    1. Abstract coupling. I only know that it has a target audience of some observers, the observers met each abstract Observer category simple interface, does not know their specific affiliation categories. This makes the coupling between goals and observers smallest and abstract.
    2. Support radio communications. Needless to notify designated observers goals, how to deal with the observer informed decisions.
    3. Possible accidents updated. We update logic, avoiding mistakes updated.
    2.2 Faculty model
    MVC is an important feature of View can nest. Nest can be used for any type of combination of local maps available, but also management of type nest. This thinking reflects the type and mix of components will be equal treatment design. This object-oriented design ideas in the area of Cambridge has been described as a design model. Model types : Cambridge model is the object-oriented model, it is also the structure type model. Model purpose : to target portfolio into tree structures to express "part-whole" level structure. Prepared for the use and combination of individual target audiences with the use of consistency.
    Effect :
    1. Definition of a target portfolio includes simple objects and the structure of the category level. Simple objects may be complex combinations of objects, and can be targeted portfolio mix. This customer-code used in the target areas can use simple combinations target.
    2. Simplify customer-code. Needless to know their customers - a mix of target audiences is a simple target or can use these items in a consistent manner.
    3. Easier to add new types of components. New components can easily be changed to a combination of customer-targeted codes.
    2.3 Strategy model
    Another important characteristic is the MVC can not change the View of changes View response to user input. This often requires a change in response to the logic of the system is very important. MVC to respond to the logic involved in the Controller. Controller of a category level structure could easily change to the original Controller appropriate, a new Controller. View Controller son used to achieve a specific example of such a response strategy. To achieve different response strategy, as long as examples of the use of different types of replacement will Controller. Also in the running time by changing the View Controller for users to change View of response strategies. This View-Controller relationship was described as an example of Strategy design pattern. Model types : Strategy model is the object-oriented model, it is behaviour-based model. Model purposes : definition of a series of algorithms, and their packaging, and ensure that they can replace each other, making algorithms can independently use its customer-change.
    Effect :
    1. Strategy category levels for Context definition of the relevant algorithms can be trusted or behaviour.
    2. Alternative methods of succession. If the direct successor Context, with different acts will be added Context act, the realization of which would algorithm mixed up with Context, Context hard to preserve and expand, but can not dynamically changing algorithms. Will be enclosed in a separate Strategy category algorithms to enable algorithm independent Context change easily cut over expansion.
    3. Can provide the same acts different date.
    4. Strategy-must understand what customers between different.
    5. Context and Strategy communications between costs.
    6. An increase in the number of targets.
    3. MVC in Web application system
    Now some of the distributed systems such as Web-based B2B e-commerce system, suitable for use MVC framework. Through analysis from the perspective of high-level applications can be a target divided into three categories. Category is shown for the target audience consists of a group of commercial rules and data, there is a category that is receiving requests to control commercial target to complete the request. These applications often need to change is shown, such as web style, color, but also need to demonstrate the contents of the display. And the business rules and data to be relatively stable. Therefore, said that the frequent need to change the View objects that the business rules and data model to be relatively stable target, and that the control of the Controller is the most stable. When the system is usually issued after the View objects by artists, designers or HTML/JSP system managers to manage. Controller target applications development personnel from the development and implementation of rules for commercial and business development personnel from the target data, database managers and experts in the field of common completed. Show in Web?? or customers - control logic can be Servlet or JSP, dynamically generated Html. Generally used Servlet better than using JSP. JSP will be better with the Html code of separate codes for page designers and developers of separation efficiency. Servlet and JSP can complete all complete functions, actually JSP eventually converted into a Servlet. And control of the target system exists in every level, the coordination of cross-layer moves. Contain business rules and data objects exist in the EJB layer (EJB-centred model) or Web?? (Web-centred model).
    3.1 View in the Web application system
    View of the system shows that it fully exist in Web??. General by JSP, Java Bean and Custom Tag. JSP can generate dynamic web content using Java Custom Tag easier Bean, but it can show the logic of packaging, and more conducive to modular trusted. Some well-designed in a number of JSP Custom Tag can even be used in different system duplication. Model for control of JSP and Java Bean objects. JSP through Java Bean objects to retrieve the data model, the Model and Controller object is responsible for updating the data on Java Bean. In general, can we devise all possible screen that users can see all the elements of the system. Based on these elements, to identify the public part of passive components and dynamics. Can consider the use of templates means to separate the content generated JSP public, also need to change their generation Html or JSP from a JSP templates to dynamically introduce these different parts (include methods). Another issue to consider is screen option, when dealing with End users request template automatically available to show that the concern that users must know what is the screen components. So can consider all screens on the definition of a centralized document, such as a document or text document java. Taking into account the possibility of changes in future document definition screens, the best use of text documents such as a XML document, so future changes to the recompilation. According to the URL and user input parameters to shine upon the results of a screen, of course, likely to be made on the basis of the outcome of the implementation of actions to choose different results screen. Therefore, the need for a request for matching resources with document (XML), if a URL request several different results, it must specify in the document need to control the flow (a controller object), as well as the corresponding screen different flows.
    3.2 Model in the Web application system
    Model objects represent business rules and business data exist in EJB layer and Web??. In J2EE norms, the system needs some data stored in the database, such as user account information (account model), the company's data (company model), some not recorded in the database. If a user browsing the current catalogue (catalog model), the contents of his shopping (shopping cart model). Which one of these models exist in the data according to their life cycle and scope to decide. In Web?? a HttpSession and ServletContext and Java Bean objects to store data in the EJB layer is a data storage and logic EJB to. Web?? the Java Bean objects stored in the model layer model of the EJB object data copy. Because there are many different EJB tier model targets, so Web?? through a ModelManager to control the EJB layer object model in ModelManger background model can be used for packaging methods. In the EJB layer and the rules have all the data into EJB model is inappropriate. If the database can visit the Dao object model into objects. Dao can be encapsulated and the specific details of the database in the world, if we can write a different table, a number of databases, or even multiple databases. If the orders can be a model for OrderDAO, it may have to deal with Order table, table and OrderItemLines OrderStatus table. Value can also consider the use of targets. Value can be a target of securing long-range targets, because every time the remote object attributes could be a long-range redeployment process will consume network resources. EJB objects in the distance can be used instead target. In the distance, one-time items to be targeted instead of the value of all attributes.
    3.3 Controller in Web application system
    Coordination with the Model View Controller object to the request of users into the system to identify incidents. In Web?? generally a MainServlet (or Main.jsp), and receiving all requests, it can use screen flow management devices (ScreenFlowManger) decided next screen. There is a general request processors RequestProcessor contains all requests are needed to be done to deal with logic, such as the request translated into system events (RequestToEvent). Acting processors usually also includes a request for ClientControlWebImpl, it is logical to deal with the EJB layer in Web?? Acting. In EJB layer, a layer for EJB tier Web ClientController provide the CD visit. Another StateMachine used to create and delete ejb handle Web?? sent to the incident. Controller Another important function is synchronous View and Model data. ModelManger contained in a ModelUpdateManger, it puts events into a Model System assembly that all the needs of synchronous Model, and then notify Listeners do synchronous operation.
    4. Concluding remarks
    In recent years, with the Internet technology development and the emergence of new business models, the Web is based on a large number of applications. On how to design these systems architecture, and gradually there has been some convergence of opinion, the most important point is that its structure should be rational in the open. Demand than ever faster development of technology and design concepts, systems for the future, the cost of upgrading the smallest, research software systems architecture still very useful and necessary.

    Bravo. And your point is?

  • How to Implement BW in IT Service Desk/IT Help Desk /IT Complain Surveillance Dept/IT Customer Support Dept?

    Hi
    If a organization have 200 to 300 daily complains of there IT equipment/Software/Network e.t.c.
    How to Implement BW in IT Service Desk/IT Help Desk /IT Complain Surveillance Dept/IT Customer Support Dept?
    Is there any standard DataSources/InfoObjects/DSOs/InfoCubes etc. available in SAP BI Content?

    Imran,
    The point I think was to ensure that you knew exactly what was required. A customer service desk can have many interpretations from a BI perspective.
    You could have :
    1. Operational reports - calls attended per shift , Average number of calls per person , Seasonality in the calls coming in etc
    2. Analytic views - Utilization of resources , Average call time and trending , customer satisfaction , average wait time
    3. Strategic - Call volumes corresponding to campaigns etc , Employee churn and related call times
    Based on these you would then have to construct your models which would be populated by data from the MySQL instance for you to report.
    Else if you have BWA you could have data discovery instead or if you have HANA - you could do even more and if you have a HANA sidecar - you technically dont need BW. The possibilities are virtually endless - it depends on how you want to drive it and how the end user ( client ) sees value in the same.

  • How to Implement custom share functionality in SharePoint 2013 document Lib programmatically?

    Hi,
    I have created custom action for Share functionality in document library.
    On Share action i'm showing Model pop up with Share form with addition functionality.
    I am developing custom share functionality because there is some addition functionality related to this.
    How to Implement custom share functionality in SharePoint 2013  document Lib pro-grammatically?
    Regards,
    - Siddhehswar

    Hi Siddhehswar:
    I would suggest that you use the
    Ribbon. Because this is a flexible way for SharePoint. In my project experience, I always suggest my customers to use it. In the feature, if my customers have customization about permission then i can accomplish this as soon
    as possible. Simple put, I utilize this perfect mechanism to resolve our complex project requirement. Maybe we customize Upload/ Edit/ Modify/ Barcode/ Send mail etc... For example:
    We customize <Edit> Ribbon. As shown below.
    When user click <Edit Item>, the system will
    render customized pop up window.
    Will

  • How to implement this requirement

    Greetings!!!
    The following are my tables
    CREATE TABLE SHIPMENT_CARTON(
    SSSD_ID               NUMBER(10) NOT NULL,
    CTN_MEAS_ID          NUMBER(10),
    SSSD_NO_CTN          NUMBER(10),
    SSSD_GW               NUMBER(10,2),
    SSSD_NW               NUMBER(10,2),
    CONSTRAINTS PK_SHIPMENT_CARTON PRIMARY KEY(SSSD_ID))
    TABLESPACE  order_data01
         STORAGE(
         INITIAL 10K
         NEXT 10K
         MINEXTENTS 5
         MAXEXTENTS 10);   
    ALTER TABLE SHIPMENT_CARTON ADD CONSTRAINTS FK_SHIPMENT_CARTON1 FOREIGN KEY(CTN_MEAS_ID)
    REFERENCES CARTON_MEAS(CTN_MEAS_ID);
    CREATE TABLE ITEMS_IN_CARTON(
    IIC_ID               NUMBER(10) NOT NULL,
    IIC_QTY               NUMBER(10),
    SSSD_ID               NUMBER(10),
    OI_ITEM_ID          NUMBER(10),
    CONSTRAINTS PK_ITEMS_IN_CARTON PRIMARY KEY(IIC_ID))
    TABLESPACE  order_data01
         STORAGE(
         INITIAL 10K
         NEXT 10K
         MINEXTENTS 5
         MAXEXTENTS 10);
    ALTER TABLE ITEMS_IN_CARTON ADD CONSTRAINTS FK_ITEMS_IN_CARTON1 FOREIGN KEY(SSSD_ID)
    REFERENCES SHIPMENT_CARTON(SSS_ID);
    ALTER TABLE ITEMS_IN_CARTON ADD CONSTRAINTS FK_ITEMS_IN_CARTON2 FOREIGN KEY(OI_ITEM_ID)
    REFERENCES ORDER_ITEM(OI_ITEM_ID);
    REQUIREMENT:
    More than 1 itemcode(s) will be put in 1 carton.
    Solution:
    I did it's  master detail entry wherein the user will initially select the carton size(CTN_MEAS_ID), enter no of carton(SSSD_NO_CTN),
    gross weight(SSSD_GW), net weight(SSSD_NW) and primary key (SSSD_ID sequence generated) in table SHIPMENT_CARTON(Master Block Entry).
    Afterwhich, user will select itemcodes(OI_ITEM_ID), enter the quantity(IIC_QTY) and primary key (IIC_ID sequence generated) in
    ITEMS_IN_CARTON (Detail Block Entry).
    MY NEW REQUIREMENT:
    More than 1 itemcode(s) will be put in 1 carton.
    User will initially select the itemcode(s)and quantity , then select the carton size,enter the no of carton, gross & net weight.
    How to implement it in reverse manner.
    I hope somebody out there can suggest how to do it in Forms10g.
    Thank you in Advance...

    It depends on what the front end should look like and whether the carton details are known immediately after the items have been entered or not. I'll assume the carton details will not be known for some time.
    Presumably you have other tables in the model, for example there would probably be a table above shipment_carton. "Shipment" perhaps? If not then create it and foreign key both tables here to the Shipment table. When you add items you add them to a shipment and when you add cartons you add them to a shipment. Then you just have to assign items to cartons within that shipment. The foreign key from items to cartons must now include the Carton AND Shipment primary key columns so you know that the items are not being put into another shipment's carton.

  • How to use MVC using MDM as backend... in Webdynpro for java

    Hi,
       How to use MVC using MDM as backend.. when we r using R/3 we used to create RFC model. I dont know how to use it here..
    Regards,
    laxmi.

    Haii
    Create a data a source using ur ODBC tool. This can be found in Administrative tools of windows.
    In ur connectino class u can write the following code
    Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
    Connection con=DriverManager.getConnection("jdbc.odbc.dsnname u have given when u created data source","user namet","pwd");( I think there is no need to give username when u connect to ur access)
    The connection "con" is ready to use.. Put these statements inside a try catch...
    I think i have explained enough..
    regards
    SHanu

  • MVC model confusion...

    I don't know if this is an mvc model:
    I have an HTML pages for viewing and input of data....
    a JSP file to get the request from the HTML page....
    and Java beans that has functions that is called by the JSP file...
    The beans also gets the data to the database......
    Im really confused on how I would make this an MVC model or is this already an MVC model?

    You are right...
    MVC(Model-View-Controller) is used to separate the presentation from the business logic.
    Your jsp page has nothing to do with business logic.
    Model includes Beans & EJBsThis is something you have to correct...
    view is your databaseview .. its nothing to do with database instead its the jsp's html's
    and controllers can be your servlets..

  • How to implement parent entity for core data

    Hi there.
    I am starting a document-based Core Data application (Cocoa) and developed the following data model;
    The 'invoice' entity is a parent entity of 'items', because ideally I would want there to be many items for each invoice. I guess my first point here is - is what I am trying to do going to be achieved using this method?
    If so, I have been trying several ways in Interface Builder to sort out how to implement this structure with cocoa bindings. I have made a Core Data app before, just with one entity. So this time, I have two separate instances of NSArrayController's connected to tables with relevant columns. I can add new 'invoice' entities fine, but I can't get corresponding 'items' to add.
    I tried setting the Managed Object Context of the 'item' NSArrayController to this;
    I thought this would resolve the issue, but I still have found no resolution to the problem.
    If anyone done something similar to this, I'd appreciate any help
    Thanks in advance,
    Ricky.

    Second, when you create a Core Data Document Based application, XCode generates the MyDocument class, derivating from NSPersistentDocument. This class is dedicated to maintain the Managed Object Model and the Managed Object Context of each document of your application.
    There is only one Context and generally one Model for each Document.
    In Interface Builder, the Managed Object Context must be bound to the managedObjectContext of the MyDocument instance: it's the File's owner of the myDocument.xib Nib file.
    It's not the case in your Nib File where the Managed Object Context is bound to the invoiceID of the Invoice Controller.
    It's difficult to help you without an overall knowledge of your application, perhaps could you create an InvoiceItem Controller and bind its Content Set to the relationship of your invoice.

  • How to download org model from R/3 to CRM.

    Dear Friends,
                     How to download Org model  from R/3 to CRM. Any one tell me step by step detaily.
    Regards,
    Raj kumar,
    08123667379

    You can download organization from R3 to CRM in the following way.
    go to SPRO -> Customer Relationship Management -> Master Data -> Organization Management -> Data Transfer -> Copy SAP ECC Sales Structure. This is the place from where you can replicate the sales structure from ECC. You can have a look at the IMG Implementation Guide for a more detailed information.
    As for the BP not coming as an Organization, you need to activate the switch to integrate the BP and Organization functionality. The link for the same is given below:
    SPRO -> Customer Relationship Management -> Master Data -> Business Partner -> Integration Business Partner-Organization Management --> Set up Intergration with Organization Management . Here you need to activate the following Switch - HRALX OBPON ON Integration O-BP Activated.

  • How to implement redundant with 1 CE router to 2 MPLS service providers

    Dear all,
    Our head-office are currently have 1 Cisco CPE 3825 router with 2 WAN connections to our branches. We are now using static routing protocol in our network infrastructure, we consider how to implement the redundancy for networks by the redundant circuits connection to 2 MPLS providers, only when the primary connection to the primary MPLS L3 provider fail, the backup link to the second MPLS Layer 2 provider automatically active. Anybody knows where can I find information, tips or examples, how we'd handle the routing for that?
    We are now have:
    1 G0/1 interface connect to primary MPLS L3 Provider (the 2nd G0/2 interface is a leased-line connection to our partner, and we not consider here)
    1 HWIC (layer 2) card, with 4 ports, which has interface F0/2/3 connected to the backup MPLS Layer 2 provider.
    Thanks in advance.
    PS: Current configuration : 3727 bytes
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Router
    boot-start-marker
    boot system flash c3825-entservicesk9-mz.123-11.T7.bin
    boot-end-marker
    logging buffered 4096 debugging
    logging monitor xml
    no aaa new-model
    ip subnet-zero
    ip cef
    no ftp-server write-enable
    no spanning-tree vlan 4
    no spanning-tree vlan 5
    interface GigabitEthernet0/1
    description connect to VDC MPLS$ETH-WAN$
    mtu 1480
    ip address 222.x.x.66 255.255.255.252
    ip flow ingress
    ip flow egress
    service-policy output SDM-QoS-Policy-1
    ip route-cache flow
    duplex auto
    speed auto
    media-type rj45
    fair-queue 64 256 256
    no cdp enable
    interface FastEthernet0/2/0
    switchport access vlan 2
    no cdp enable
    interface FastEthernet0/2/3
    description ToTBToverFPT
    switchport access vlan 5
    no cdp enable
    interface Vlan2
    description CONNECT TO MPLS_VDC
    ip address 192.168.201.9 255.255.248.0
    interface Vlan5
    description Connect to HoChiMinhCity
    ip address 172.16.1.5 255.255.255.252
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.16.244.0 255.255.255.0 222.255.33.65
    ip route 192.168.0.0 255.255.248.0 222.255.33.65
    ip route 192.168.24.0 255.255.254.0 222.255.33.65
    ip route 192.168.30.0 255.255.254.0 222.255.33.65
    ip route 192.168.32.0 255.255.254.0 222.255.33.65
    ip route 222.x.x.68 255.255.255.252 222.255.33.65
    ip route 222.255.33.72 255.255.255.252 222.255.33.65
    ip route 222.x.x.196 255.255.255.252 222.255.33.65
    ip route 222.x.x.200 255.255.255.252 222.255.33.65
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 3
    control-plane
    line con 0
    logging synchronous
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    password
    login
    transport input telnet
    line vty 5 14
    privilege level 15
    password
    login
    transport input telnet
    line vty 15
    privilege level 15
    password
    login
    transport input telnet
    parser view SDM_Monitor
    scheduler allocate 20000 1000
    end

    Hi Mr jianqu,
    Because of our customer now has 2 main central offices, and all other sub branches are now connected to each of these main central office via one primary full-meshed MPLS VPN of 1st Service Provider, so If I use the float static routes, and when there is a failure at one link at a CENTRAL CE Router to primary link to primary MPLS VPN Service Provider, but still there is no failure at the other site from a router CE sub branch with the the PE of the primary full-meshed MPLS VPN Layer 3 Service Provider,so It cannot cause a failover to a second redundant link of the 2nd Service Provider?
    So with our system, do we only have one solution like this:
    -Configure BGP as the routing protocol between the CE and the PE routers.
    -Use local preference and Multi Exit Discriminator (MED) when running BGP inside a our customer VPN to select the primary and backup links.
    -Use AS-override feature to support overlapping AS numbers between customer sites

  • BI Beans, Struts and MVC Model 2

    Hi,
    Is there documentation or samples about how to use BI Beans with Struts, in a MVC Model 2 design? I.e. Struts Actions acting as controller, instantiating and initializing the BI Beans presentations (Model), passing them on to JSP's to build the view layer (by rendering the presentations).
    I saw such a sample in the BI Beans 9.0.4 samples, but it seems to have been removed in the BI Beans 10.1.2 samples. There are only samples showing either exclusive use of servlets, or exclusive use of JSP's. Is there a reason why the struts sample is no longer offered with BIB 10.1.2? Is this approach actually supported by BI Beans 10.1.2?
    Can I still make use of most of the "orabi" JSP tags, if I build up my presentations in an action, prior to forwarding it to the JSP?
    Kind regards,
    Johan

    Suppose you've created biTest.uix which contains bi beans
    Now just add struts-config.xml to your bi beans project (right click on Project in Navigator -> New -> Struts -> Struts Controller Page Flow)
    add example action
    <action path="/biTest" className="oracle.adf.controller.struts.actions.DataActionMapping" type="oracle.adf.controller.struts.actions.DataForwardAction" name="DataForm" parameter="biTest.uix">
    <set-property property="modelReference" value="biTestUIModel"/>
    <forward name="biTest" path="/biTest.do"/>
    </action>
    to your struts-config.xml
    where
    biTest.uix - your bi beans page
    biTestUIModel - empty model (you can create it by clicking on your bi beans page (here it's biTest.uix)
    and selecting UI Model tab Structure tool-window, where you have to right click on
    "<No Bindings>" node and select Create UI Model in appeared popup menu)
    Now you can run biTest.do action and you bi beans page will be displayed.

  • Implementing MVC with menus

    Hi, I'm trying to implement a menu bar with menus and submenus, all of which contain only basic JMenuItems (i.e., no checkboxes, radiobuttons, etc.). The twist here is I'd like to use MVC (Model-View-Controller), where there is a "menu model" to handle updates, similar to JTree with an underlying TreeModel.
    May I know if someone has already implemented this before, or know of a framework for this? I've googled using the keywords menu, jmenubar and model, but without any luck...
    Thanks in advance.

    Thanks, I'll have a good read over that later.
    I notice that Java has a lot of pre-defined interfaces and abstract classes for things I'd usually go ahead and write myself in other languages. To avoid wasting time re-inventing the wheel which of the commonly used patterns below already provide the necessary interfaces? :)
    * Singleton (yuck -- I avoid this where I can)
    * Registry
    * Observer (I know this does)
    * MVC
    * Prototype
    * Strategy
    * Data Mapper
    * DI
    A bit out of scope for this thread I guess.

Maybe you are looking for