HTTP POST method does not pass parameters to the server

Hi ,
I am using SSO using VSJ product and implemented using a filter.
I have problems as below
1. Every request to the web server will be intercepted by this vsj filter and if sso does not succeed it will send 403
2. my system will detect 403 in web.xml and redirect to login page
3. user key in username and password and log in
4. after successful login set the HttpSession and redirect to homepage
Problem is subsquent form submit / ajax call using "POST" method cannot pass any parameters to the servers ( parameters sent using POST will be null in the servers )  ? GET is okay
If i comment out the vsj filter altogether , everything works as per normal.
My Question is
1. Is there anyway to overcome come ?
2. Is there any method to clear off whatever this sso vsj has set ( clear cookies / start new browser instance / etc ) in order to forget the state
Any idea?
Thanks

Yes.
here to illustrate
public MyFilter extends VSJAuthFilter
*public void doFilter(){*
*if(session.getAttribute("loginSucces") != true){*
super.doFilter(); //call VSJ Auth filter to perform SSO in order to get User Principal populated.
*}else{*
chain.doFilter(); // normal filter
My Filter only intercepts *.jsp and *.do
Basically here is the pattern that i observe
1. If i hit default url (homepage.do) for the first time it will trigger the super.doFilter() , it will then throw 403 and redirect to login.html , after success and go to homepage , subsequent POST parameter is missing
2. if i hit the external login page directly just to simulate ( eg : login.html ) it wont trigger this filter , after success and go to homepage , subsequenet POST parameter is okay
3. GET is always ok
I am using weblogic server 10.x btw
Thanks

Similar Messages

  • I am now able to receive emails in MAIL, but Yosemite's Mail program does not recognize any of the server's connections that have worked for years!  What do I do next?

    Yesterday, I was unable to receive emails from Google but was able to receive them from another server - but then receiving them began to work again - but now I am unable to send any mail - Yosemite's Mail program does not recognize any of the server's connections that have worked for years, !  What do I do next?

    Mail troubleshooting - Yosemite
    What does Mail/Window/Connection Doctor Show? If the server is red, select it and look at the Show Details box.
    Troubleshooting sending and receiving email messages
    Troubleshooting sending email messages

  • SetActionListener method does not print anything in the html file...

    Hi
    I want to add the actionlistener from my Javacode, but the setActionListener method does not have any effect on the Html. I can not figure out why. Can someone tell me what I'm doing wrong?
    tnx
    Andras
    public class Links {
    private HtmlPanelGrid topLinks;
    public HtmlPanelGrid getTopLinks() {
    TopLinks links = new TopLinks();
    Class args[] = {ActionEvent.class};
    if (topLinks == null) {
    topLinks = new HtmlPanelGrid();
    }else {
    topLinks.getChildren().clear();
    MethodBinding mb =
    FacesContext.getCurrentInstance().
    getApplication().
    createMethodBinding("#{event.actionevent}", args);
    HtmlCommandLink command = new HtmlCommandLink();
    command.setValue("Link 1");
    command.setActionListener(mb);
    topLinks.getChildren().add(command);
    return topLinks;
    public void setTopLinks(HtmlPanelGrid topLinks) {
    this.topLinks = topLinks;
    generates this html:
    <body>
    <form id="_id0" method="post" action="/Test/event.faces" enctype="application/x-www-form-urlencoded">
    <table>
    <tbody>
    <tr>
    <td><a href="# onclick="document.forms['_id0'['_id0:_idcl'].value='_id0:_id2'; document.forms['_id0'].submit(); return false;">Link 1</a></td>
    </tr>
    </tbody>
    </table>
    <input type="hidden" name="_id0" value="_id0" />
    <input type="hidden" name="_id0:_idcl" /></form>
    </body>
    As you can see there is no sign of the actionListener... :(

    You may completely misunderstand something.
    Don't worry even if you can't see the actionListener in the html.
    There is one in the server side.

  • Cisco 881 ISR IPSec VPN Tunnel does not pass traffic from the vlan.

    I have a cisco 881 ISR Router with a site-to-site IPsec vpn tunnel to a mikrotik device on the other end (I inherited this from my client). The tunnel is constructed properly and is up, however traffic does not pass or get routed to the FA4 interface. I see in my packet captures that it hits the vlan1 interface (vlans are required on the L2 ports) and does not pass to the tunnel.
    This is my configuration:
    141Kerioth#sh config
    Using 3763 out of 262136 bytes
    ! Last configuration change at 01:02:41 UTC Mon May 26 2014 by admin
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname 141Kerioth
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    aaa new-model
    141Kerioth#do wr mem
                  ^
    % Invalid input detected at '^' marker.
    141Kerioth#wr mem
    Building configuration...
    [OK]
    141Kerioth#sh run
    Building configuration...
    Current configuration : 5053 bytes
    ! Last configuration change at 01:38:06 UTC Mon May 26 2014 by admin
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname 141Kerioth
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    aaa new-model
    aaa authentication login default local
    aaa authentication ppp default local
    aaa session-id common
    memory-size iomem 10
    crypto pki trustpoint TP-self-signed-580381394
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-580381394
     revocation-check none
     rsakeypair TP-self-signed-580381394
    crypto pki certificate chain TP-self-signed-580381394
     certificate self-signed 01
      30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 35383033 38313339 34301E17 0D313430 35323231 38323333
      365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
      532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3538 30333831
      33393430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
      B001A012 2CA6970C 0648798B 2A786704 84F2D989 83974B19 9B4287F2 4503D2C9
      173F23C4 FF34D160 202A7565 4A1CE08B 60B3ADAE 6E19EE6E 9CD39E72 71F9650E
      930F22FE C4441F9C 2D7DD420 71F75DFC 3CCAC94E BA304685 E0E62658 A3E8D01C
      D01D7D6A 5AF0B0E6 3CF6AF3A B7E51F83 9BF6D38E 65254E1F 71369718 ADADD691
      02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
      23041830 168014D6 24878F12 1FFADF2F 537A438E 6DD7FB6B D79E4130 1D060355
      1D0E0416 0414D624 878F121F FADF2F53 7A438E6D D7FB6BD7 9E41300D 06092A86
      4886F70D 01010505 00038181 00771667 FCA66002 8AB9E5FB F210012F C50B586F
      9A9640BB 45B4CEFD 030A38C0 E610AAC8 B41EF3C4 E55810F9 B2C727CF C1DEFCF1
      0846E7BC 1D95420E 5DADB5F8 EFE7EB37 B5433B80 4FF787D4 B1F2A527 06F065A4
      00522E97 A9D2335C E83C4AE1 E68D7A41 9D0046A7 ADCC282B 7527F84D E71CC567
      14EF37EA 15E57AD0 3C5D01F3 EF
            quit
    ip dhcp excluded-address 10.0.16.1
    ip dhcp pool ccp-pool
     import all
     network 10.0.16.0 255.255.255.0
     default-router 10.0.16.1
     dns-server 8.8.8.8
     lease 0 2
    ip domain name kerioth.com
    ip host hostname.domain z.z.z.z
    ip name-server 8.8.8.8
    ip name-server 4.2.2.2
    ip cef
    no ipv6 cef
    license udi pid CISCO881-K9 sn FTX180483DD
    username admin privilege 15 secret 4 CmmfIy.RPySmo4Q2gEIZ2jlr3J.bTBAszoe5Bry0z4c
    username meadowbrook privilege 0 password 0 $8UBr#Ux
    username meadowbrook autocommand exit
    policy-map type inspect outbound-policy
    crypto isakmp policy 1
     encr 3des
     authentication pre-share
     group 5
    crypto isakmp key 141Township address z.z.z.z
    crypto isakmp keepalive 10
    crypto ipsec transform-set TS esp-3des esp-sha-hmac
     mode tunnel
    crypto map mymap 10 ipsec-isakmp
     set peer z.z.z.z
     set transform-set TS
     match address 115
    interface Loopback0
     no ip address
    interface Tunnel1
     no ip address
    interface FastEthernet0
     no ip address
    interface FastEthernet1
     no ip address
    interface FastEthernet2
     no ip address
    interface FastEthernet3
     no ip address
    interface FastEthernet4
     description $FW_OUTSIDE_WAN$
     ip address 50.y.y.y 255.255.255.240
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
     crypto map mymap
    interface Vlan1
     description $ETH_LAN$
     ip address 10.0.16.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1452
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 115 interface Vlan1 overload
    ip nat inside source list 199 interface FastEthernet4 overload
    ip nat inside source route-map nonat interface FastEthernet4 overload
    ip route 0.0.0.0 0.0.0.0 50.x.x.x
    access-list 110 deny   ip 10.0.16.0 0.0.0.255 10.0.1.0 0.0.0.255
    access-list 110 permit ip 10.0.16.0 0.0.0.255 any
    access-list 115 permit ip 10.0.16.0 0.0.0.255 10.0.1.0 0.0.0.255
    access-list 144 permit icmp host c.c.c.c host 10.0.1.50
    access-list 144 permit icmp host p.p.p.p host 10.0.16.105
    access-list 199 permit ip a.a.a.a 0.0.0.255 any
    no cdp run
    route-map nonat permit 10
     match ip address 100
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     access-class 1 in
     exec-timeout 30 0
     privilege level 15
     transport preferred ssh
     transport input ssh
    line vty 5 15
     access-class 23 in
     privilege level 15
     transport input telnet ssh
    cns trusted-server all-agents x.x.x.x
    cns trusted-server all-agents hostname
    cns trusted-server all-agents hostname.domain
    cns id hardware-serial
    cns id hardware-serial event
    cns id hardware-serial image
    cns event hostname.domain 11011
    cns config initial hostname.domain 80
    cns config partial hostname.domain 80
    cns exec 80
    end

    Why do you have following command on the PIX?
    crypto map outside_map 40 set transform-set 165.228.x.x
    Also you have this transform set on the PIX:
    crypto ipsec transform-set 10.112.60.0 esp-aes-256 esp-sha-hmac
    This does not match the transfor set on the router:
    crypto ipsec transform-set tritest esp-3des esp-md5-hmac
    Where are you using the access-list/route-map
    101 ?

  • 1424 does not pass diagnostic​s after running program

    Hello, we are using the PCI-1424 card with a Dalsa linescan camera, and are having trouble trying to do ring acquisitions with different buffer sizes. The camera either times out or always returns the number of lines that it is first set to, ie; if the original number of lines is 100, and the number of lines is then set to 1000 (and confirmed using imgGetAttribute(DisplaySid, IMG_ATTR_ACQWINDOW_HEIGHT, &nBufSize).
    I've noticed that the 1424 board does not pass 2 of the diagnostic tests in MAX. The details it returns are:
    Advanced Control Circuitry failed
    Configuration could not be written to when Confwren bit was set. [F1.5]
    Timing Circuitry failed
    Counter configuration could not be loaded. [T1.0
    Is this a programming error on my part? I am closing the session and the interface, which in my opinion should be all that is needed to reset the board to the default settings. This does not work, even the snap acquisition in MAX fails.

    I'm not surprised at the behavior that you are seeing. When the acquisition is started the board is programmed with the acquisition size and when you change that it has to reprogram the board while it is acquiring, so either it will timeout or it just won't do it and you will only see the first size. I'm not sure why the diagnostics are failing but it sounds like you can reboot and that resolves the issue. I would recommend looking into a couple of alternatives. Variable Height Acquistion uses a hardware signal to indicate how many lines should be in an image. If you didn't have a signal you could generate one with a DAQ card or you could programmatically assert
    and deassert one of the trigger lines on the 1424 but that would not be the most accurate depending on your line rate. The other alternative would be to set the image size to the largest size and then just crop the images.
    Regards,
    JR A.
    Application Engineer
    National Instruments

  • Poster image does not appear in IE

    I am having another problem with the poster image feature.  In IE7 & 8, the poster image does not appear at all when the player is first loaded. If the page is cached and loaded, the poster image appears fine.
     I think this is a bug, but can anyone confirm seeing this or fixing it? 
    Thanks!

    According to the javadoc:
    getImage
    public Image getImage(URL url,
    String name)Returns an Image object that can then be painted on the screen. The url argument must specify an absolute URL. The name argument is a specifier that is relative to the url argument.
    This method always returns immediately, whether or not the image exists. When this applet attempts to draw the image on the screen, the data will be loaded. The graphics primitives that draw the image will incrementally paint on the screen.
    Parameters:
    url - an absolute URL giving the base location of the image.
    name - the location of the image, relative to the url argument.
    Returns:
    the image at the specified URL.
    I am confused as to how to use the name after the url.
    Should it read something like:
    bugimg = getImage("http://g.jtrusty.com/JavaApplet/", "LadyBug.gif");
    EDIT: I still get the same error, cannot find symbol at getImage.
    Message was edited by:
    gnikollaj

  • Apple account none payment methode does not appear

    when i creat my apple id the none option in payment methode does not appear . please tell me what I do ?????

    Unless the instructions on this page are followed when creating an account : Create an iTunes Store, App Store, or iBooks Store account without a credit card or other payment method - Apple Support…
    then credit card details will need to be entered before the account can be used to download any item from the store.
    If you are being prompted to review the account then you could see if this post by mountaingoatgirl lets you do so without needing to enter credit card details : https://discussions.apple.com/message/24303054#24303054
    If not then you will either need to enter your credit card details (you should be able to remove it after entering it), or create a new account (and use the instructions on the above link when creating it).

  • Itunes does not pass windows logo testing to verify CD/DVDrom drives, Why?

    Hello All,
    When I try to install Itunes 9.2 on my XP 32bit machine, I get the error message "Itunes does not pass windows logo testing to verify CD/DVD rom drives this software will not be installed. Contact your administrator" I am the owner & my account has administrator rights. When I start itunes i get the message "Itunes was not properly installed if you wish to burn Cds you will need to reinstall itunes" Any ideas what i should do anyone?
    Thanks
    Lacanox

    When I start itunes i get the message "Itunes was not properly installed if you wish to burn Cds you will need to reinstall itunes" Any ideas what i should do anyone?
    That sounds like the GEAR drivers that iTunes uses for burning and importing aren't going in properly. (or there's damaged GEAR drivers for an old install stuck on the PC.
    Perhaps manually uninstalling and reinstalling the GEAR drivers can get you past this. There's instructions for that on the GEAR wiki:
    [DRIVERS: Windows - Updating, removing, 64 bit versions, etc|http://www.gearsoftware.com/wiki/index.php?title=DRIVERS:Windows_-_Updating%2C_removing%2C_64_bit_versions%2Cetc]

  • Hashmap containsKey() method does not appear to work

    Hashmap containsKey() method does not appear to work
    I have an amazingly simple custom class called CalculationKey, with my own amazingly simple custom equals() method. For some reason when I call my containsKey() method on my HashMap it does not use my defined equals method in my defined key class. Do hashmaps have their own tricky way for establishing whether two keys are equal or not?
    THIS IS MY AMAZINGLY SIMPLE CUSTOM KEY CLASS
    private class CalculationKey
    private LongIdentifier repID;
    private LongIdentifier calcID;
    public CalculationKey(LongIdentifier repID, LongIdentifier calcID)
    this.repID = repID;
    this.calcID = calcID;
    public boolean equals(Object o)
    CalculationKey key = (CalculationKey)o;
    if (key.getCalcID().equals(calcID) &&
    key.getRepID().equals(repID))
    return true;
    else
    return false;
    public LongIdentifier getCalcID()
    return calcID;
    public LongIdentifier getRepID()
    return repID;
    THIS IS MY AMAZINGLY SIMPLE CALLS TO MY HASHMAP WHICH ADDS, CHECKS, AND GETS FROM THE HASHMAP.
    private Hashmap calculationResults = new Hashmap();
    public boolean containsCalculationResult(LongIdentifier repID, LongIdentifier calcID)
    if (calculationResults.containsKey(new CalculationKey(repID, calcID)))
    return true;
    else
    return false;
    public Double getCalculationResult(LongIdentifier repID, LongIdentifier calcID)
    return (Double)calculationResults.get(new CalculationKey(repID, calcID));
    public void addCalculationResult(LongIdentifier repID, LongIdentifier calcID, Double value)
    calculationResults.put(new CalculationKey(repID, calcID), value);
    }....cheers

    You can make a trivial implementation to return a
    constant (not recommended)What do you mean by that? Hmm.. I guess you mean that
    you shouldn't use the same constant for all objects?
    But don't see the int value of an (immutable) Integer
    as constant?
    /Kaj
    You can write hashCode to just always return, say, 42. It will be correct because all objects that are equal will have equal hashcodes. Objects that are not equal will also have equal hashcodes, but that's legal--it just causes a performance hit.
    The value is that it's really really simple to implement: public int hashCode() {
        return 42;
    } So you can use it temporarily while you're concentrating on learning other stuff, or during debugging as a way to confirm that the hashCode is not the problem. (Returning a constant from hashcode(), rather than computing a value, is always legal and correct, so if something's behaving wrong, and you replace your hashCode method with the one above, and it still breaks, you know hashCode isn't the problem.)
    The downside is that you're defeating the purpose of hashing, and any non-trival sized map or set is going to have lousy performance.
    For a decent hashCode recipe, look here:
    http://developer.java.sun.com/developer/Books/effectivejava/Chapter3.pdf

  • IOS 6 showFeedbackCaptionAndDoAction() javascript method does not draw consistently

    Hi!
    The issue describe below seem to only appear in iOS 6
    CPlayerLib.js judge() -> showFeedbackCaptionAndDoAction() javascript method does not draw the Feedback Caption consistently
    sometime the feedback does not appear, I see it in the dom tree but the canvas is not drawn, the Div capturing the click is always present. Strangely when I scroll the page a bit it shows up.
    Thanks

    Ok I found a way to fix it.
    In CPlayerLib.js cp.show method in the for loop within the if (htmlItem) I added a setTimeout(function() { htmlItem.style.webkitTransform = "scale3d(1,1,1)"},100) and it now force the canvas to repaint.
    Related issue:
    http://stackoverflow.com/questions/11002195/chrome-does-not-redraw-div-after-it-is-hidden

  • JAX-WS -- Force a wsimport generated ws client to use http POST method

    I've used wsimport to generate a JAX-WS client for a wsdl and xsd bindings that were provided to me.
    The basic implementation goes something like this.
    URL serviceUrl = ...url to the live web service's wsdl (this will change often and needs to be data driven)
    QName qname = new QName("thenamespace", "MyService")
    MyService myService = new MyService(serviceUrl, qname);
    At this point a http GET request is sent to the server which promptly spits back a "405: method not allowed" because it is only configured to accept the http POST method.
    Unfortunately i cannot change this behavior and need a way to get the web service client to generate http POST requests.
    Setting the following seemed to have no effect.
    System.setProperty("javax.xml.ws.http.request.method", "POST");
    Thanks!

    so, keep the wsdl as a local resource and use a url for the local resource. then the service will not request the remote wsdl.

  • Cannot optimize volume - Receive error "The specified extrinsic Method does not exist"

    When I try to optimize a volume on a server running Windows Server 2012 (R1). I receive the below error. This volume is an ISCSI target to our Compellent SAN. Other Servers don't have an issue with volumes created on the same SAN and I have already ran ChkDsk
    and it returned no errors. Oddly enough I can run a "Defrag T: /D" but a "Defrag T: /O" returns
    "Incorrect Function. (0x80070001)" (Incidentally an "Optimze-Volume T -Defrag" also works) 
    Any Ideas? I'm stumped!
    Command:
    Optimize-Volume -DriveLetter T -Verbose
    Error:
    VERBOSE: Invoking slab consolidation on iSCSI_SAN01_ExchLogFiles (T:)...
    VERBOSE: Slab Analysis:  100% complete.
    optimize-volume : The specified extrinsic Method does not exist.
    At line:1 char:1
    + optimize-volume -DriveLetter T -Verbose
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : MetadataError: (MSFT_Volume (Ob...2-a802-ba7e...):ROOT/Microsoft/...age/MSFT_Volume) [Optimize-Volume], CimException
        + FullyQualifiedErrorId : MI RESULT 17,Optimize-Volume

    I did stumble upon that article as well and working through it didn't help. This is an Exchange 2013 server but I wouldn't think that that would exclusively cause a problem like this (unless there is something under the hood that Exchange 2013 is secretly
    doing). The C drive is for the OS, the M drive is for the Exchange DB, and the
    T drive is for the Logs.  The C drive is "directly" connected and the M and T drives are on the same SAN (different LUNs) via iSCSI. This is running as a virtual guest on VMWare ESXi v5.5.  I have other servers setup the
    same way (not Exchange servers though) with drives on the iSCSI SAN and there are no issues when I run those Optimize-Volume commands. Here is some more output from the console:
    PS C:\Users\administrator> Optimize-Volume -DriveLetter T -Analyze -Verbose
    VERBOSE: Invoking slab consolidation on iSCSI_SAN01_ExchLogFiles (T:)...
    VERBOSE: Slab Analysis: 0% complete...
    Optimize-Volume : The specified extrinsic Method does not exist.
    At line:1 char:1
    + Optimize-Volume -DriveLetter T -Analyze -Verbose
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : MetadataError: (MSFT_Volume (Ob...2-a802-ba7e...):ROOT/Microsoft/...age/MSFT_Volume) [Optimize-Volume], CimException
    + FullyQualifiedErrorId : MI RESULT 17,Optimize-Volume
    PS C:\Users\administrator> Optimize-Volume -DriveLetter M -Analyze -Verbose
    VERBOSE: Invoking slab consolidation on iSCSI_SAN01_ExchMailStoreDB (M:)...
    VERBOSE: Slab Analysis: 0% complete...
    Optimize-Volume : The specified extrinsic Method does not exist.
    At line:1 char:1
    + Optimize-Volume -DriveLetter M -Analyze -Verbose
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : MetadataError: (MSFT_Volume (Ob...2-93f1-0050...):ROOT/Microsoft/...age/MSFT_Volume) [Optimize-Volume], CimException
    + FullyQualifiedErrorId : MI RESULT 17,Optimize-Volume
    PS C:\Users\administrator> Optimize-Volume -DriveLetter C -Analyze -Verbose
    VERBOSE: Invoking analysis on (C:)...
    VERBOSE: Analysis: 0% complete...
    VERBOSE: Analysis: 22% complete...
    # ... Repeated ...
    VERBOSE: Analysis: 94% complete...
    VERBOSE: Analysis: 99% complete...
    VERBOSE: Analysis: 100% complete...
    VERBOSE: Analysis: 100% complete.
    VERBOSE:
    Post Defragmentation Report:
    VERBOSE:
    Volume Information:
    VERBOSE: Volume size = 84.48 GB
    VERBOSE: Cluster size = 4 KB
    VERBOSE: Used space = 63.18 GB
    VERBOSE: Free space = 21.29 GB
    VERBOSE:
    Fragmentation:
    VERBOSE: Total fragmented space = 4%
    VERBOSE: Average fragments per file = 1.23
    VERBOSE: Movable files and folders = 153593
    VERBOSE: Unmovable files and folders = 6
    VERBOSE:
    Files:
    VERBOSE: Fragmented files = 2745
    VERBOSE: Total file fragments = 35394
    VERBOSE:
    Folders:
    VERBOSE: Total folders = 4819
    VERBOSE: Fragmented folders = 2
    VERBOSE: Total folder fragments = 2
    VERBOSE:
    Free space:
    VERBOSE: Free space count = 74005
    VERBOSE: Average free space size = 296.00 KB
    VERBOSE: Largest free space size = 409.42 MB
    VERBOSE:
    Master File Table (MFT):
    VERBOSE: MFT size = 308.00 MB
    VERBOSE: MFT record count = 315391
    VERBOSE: MFT usage = 100%
    VERBOSE: Total MFT fragments = 4
    VERBOSE: Note: File fragments larger than 64MB are not included in the fragmentation statistics.
    VERBOSE:
    You do not need to defragment this volume.

  • Pay Method does not exist.

    Hi,
    I 'm trying to load bank details like Bank name, Account No and etc., through HR_PERSONAL_PAY_METHOD_API. Before that i loaded data thru Assignment
    API.
    But i'm getting error 'Pay method does not exits'
    Any one help this issue.
    Thanks in advance.
    DK

    Please provide us exact error, so that we can take a look into and provide you the solution.
    Below is sample api parameters we need to provide...
    hr_personal_pay_method_api.create_us_personal_pay_method
    (p_validate => false
    ,p_effective_date => effective_date
    ,p_assignment_id => assignment_id
    ,p_org_payment_method_id => 123
    ,p_account_type => acct_type
    ,p_account_name => 'XYZ'
    ,p_account_number => acct_num
    ,p_transit_code => routing_num
    ,p_bank_name => 'PQR'
    ,p_bank_branch => 'ABC'
    ,p_percentage => ln_percentage
    ,p_amount => ln_amount
    ,p_priority => priority
    ,p_personal_payment_method_id => l_personal_payment_method_id
    ,p_object_version_number => l_object_version_number
    ,p_external_account_id => l_external_account_id
    ,p_effective_start_date => l_effective_start_date
    ,p_effective_end_date => l_effective_end_date
    ,p_comment_id => l_comment_id
    Please take a look and try once again. Let us know exact error.

  • Method 'publishCatalog' does not match any of the valid signatures for mess

    When I run my client, I get "Method 'publishCatalog' does not match any of the valid signatures for message-style service methods" I know that it means that my web service method should conform to one of those 4 methods (http://ws.apache.org/axis/java/user-guide.html#ServiceStylesRPCDocumentWrappedAndMessage), and I made it conform, yet I still get that error.
    Here's my Service and Client code:
    import org.w3c.dom.Element;
    import org.apache.axis.client.Service;
    import org.apache.axis.client.Call;
    import org.apache.axis.message.SOAPBodyElement;
    import org.apache.axis.utils.XMLUtils;
    import java.io.File;
    import java.io.FileInputStream;
    import java.net.URL;
    import java.util.Vector;
    public class CatalogPublisherServiceClient {
         public static void main(String[] args) throws Exception{
              String endpointURL="http://localhost:8080/axis/services/CatalogPublisherService";
              org.apache.axis.client.Service service = new Service();
              Call call = (Call)service.createCall();
              call.setTargetEndpointAddress(new URL(endpointURL));
              SOAPBodyElement[] reqSOAPBodyElements = new SOAPBodyElement[1];
              File catalogFile = new File("catalog.xml");
              FileInputStream fis = new FileInputStream(catalogFile);
              reqSOAPBodyElements[0] = new SOAPBodyElement(XMLUtils.newDocument(fis).getDocumentElement());
              SOAPBodyElement[] resSOAPBodyElements = (SOAPBodyElement[]) call.invoke(reqSOAPBodyElements);
              SOAPBodyElement resSOAPBodyElement = null;
              for(int i=0; i<resSOAPBodyElements.length; i++){
                   resSOAPBodyElement = (SOAPBodyElement)resSOAPBodyElements;
                   System.out.println(XMLUtils.ElementToString(resSOAPBodyElement.getAsDOM()));
    import javax.xml.parsers.DocumentBuilderFactory;
    import javax.xml.parsers.DocumentBuilder;
    import javax.xml.soap.MessageFactory;
    import javax.xml.soap.SOAPMessage;
    import org.w3c.dom.Document;
    import org.w3c.dom.Element;
    import org.w3c.dom.NodeList;
    import org.w3c.dom.Node;
    import org.w3c.dom.Text;
    import java.util.Vector;
    import java.util.Date;
    import java.text.SimpleDateFormat;
    import org.apache.axis.MessageContext;
    import org.apache.axis.utils.XMLUtils;
    import org.apache.axis.message.SOAPBodyElement;
    public class CatalogPublisherService {
         public SOAPBodyElement[] publishCatalog (SOAPBodyElement[] soapBodyElements) throws Exception {
              Element soapBody = (Element)soapBodyElements[0];
              NodeList productList = soapBody.getElementsByTagName ("PRODUCT");
         int productCount = productList.getLength();
         DocumentBuilderFactory factory = DocumentBuilderFactory.newInstance();
         factory.setNamespaceAware(true);
         DocumentBuilder builder = factory.newDocumentBuilder();
         Document responseDoc = builder.newDocument();
         Element resRoot = responseDoc.createElementNS("http://www.axis03.ws", "CATALOGUPDATE");
         resRoot.setPrefix("CU");
         Element itemCount = responseDoc.createElement("ITEMCOUNT");
         Text itemCountText = responseDoc.createTextNode (String.valueOf(productCount));
         Element dateReceived = responseDoc.createElement("DATERECEIVED");
         SimpleDateFormat sdf = new SimpleDateFormat("MM/dd/yyyy");
         String date = sdf.format(new Date());
         Text dateReceivedText = responseDoc.createTextNode(date);
         //Append the child elements appropriately
         resRoot.appendChild(itemCount);
         itemCount.appendChild(itemCountText);
         resRoot.appendChild(dateReceived);
         dateReceived.appendChild(dateReceivedText);
         SOAPMessage message=null;
         MessageFactory msgFactory = MessageFactory.newInstance();
         message = msgFactory.createMessage();
         SOAPBodyElement[] result = new SOAPBodyElement[1];
         result[0] = new SOAPBodyElement(resRoot);
         return(result);

    That's a really helpful answer and not smug at all, thanks Carey.
    I just downloaded a DVD image from my university's MSDN Academic Alliance program, named "Microsoft
    Windows 7 with Service Pack 1 Debug/Checked Build 64-bit (English)", which I wanted to use to install over an existing 32-bit version. I thought the install screen was giving this weird unskippable error described in the OP before I even entered
    a key because the 32-bit key I had used on the HDD was somehow interpreted to be used in an upgrade, but no. Even after I wiped the hard drive, this error persisted.
    Guess I'll go Google some more on how to install my legit copy of Windows, because this self-serving shit sure isn't helping.
    edit: IF YOU GOOGLED THIS AND ARE STILL LOOKING FOR YOUR ANSWER, CHECK HERE:
    http://answers.microsoft.com/en-us/windows/forum/windows_8-windows_install/the-product-key-entered-does-not-match-any-of-the/47e6f575-5792-404b-9b7f-2065bdb91011

  • The MoveTo method does not accurately preserve version history

    I know this is a tired story ;-) but
    this link says that one cannot update metadata (e.g. ModifiedBy) of previous versions of an SPListItem.
    Using the MoveTo() method of the API does move both the current list item and all previous versions of course, that much is clear.
    But, that method does not 100% preserve the Version History in that if, after it has moved a file, you were to look at the History via the UI, previous versions will have Modified set to the account under which the (in my case) console application has run
    to kick of the MoveTo process etc.
    This differs from moving using the Content & Structure approach where everything is maintained 100%.
    So I deduce that there must be some underlying code using the Content & Structure approach that differs from that using the MoveTo() method.? Is that the case?
    And is the link at the start of this question correct? We cannot then programmatically change the metadata on old versions?
    Thanks,
    Maz

    1. There must be, but not sure if its publicly accessible. You probably have to disassemle (i.e. using ILSpy) and find out.
    2. That's correct, you can't change the metadata of old versions
    Kind regards,
    Margriet Bruggeman
    Lois & Clark IT Services
    web site: http://www.loisandclark.eu
    blog: http://www.sharepointdragons.com

Maybe you are looking for

  • Get all content from iTouch to a new computer.

    My problem is very simple to explain, but I find no solution. My old computer is damaged and I cant use it anymore. So I bought a new one and I want to get all my stuff from the iTouch to iTunes on me new computer. After installing iTunes I actived i

  • I Need oracle Application r12.0.6 install and prerequstics document

    Hi, In my prod instance is R12.0.6 and database version 10.2.0.4.0 runing on rhel 5update1 32bit os Now We are plan to move another server the server is rhel 5 update6 64bit os if it possible to move the database as well as applications if it possbil

  • CS2 Camera Raw Problem - how to see my images?

    A few weeks ago I had a complete PC failure and as a result I now have a new PC running Vista. I have reloaded PS CS2, which is fine for all my needs but now I can't open my Camera Raw 2 files from my Canon 5D. I realised that I had made an error whe

  • Xserve as file server

    Hey guys, We're considering putting an xserve in charge of our all windows network as DC. Should be no probs, my question is in regards to storage. The HD modules for the xserve are expensive so I'm looking at a cheaper storage solution. Maybe a linu

  • 27" iMac doesn't have correct resolution for LG monitor

    Hi guys, Hoping to find some answers here - I called Apple Care but they weren't very helpful and told me to call LG..but I really doubt the issue has anything to do with LG. I have a 22" LG monitor that I used as a second monitor for my 24" imac. It