Implementing QOS

I want to implement QOS for VOIP traffic between Branch Office IP phones and Headoffice PABX.
Basic network diagram is as follows
Nortel IP PHONES (Branch Office)
|
L2 ordinary Switch
|
Cisco 1841
|
|
-----MPLS WAN-----
|
|
Cisco 1841
|
Cisco ASA
|
Cisco 3560 (with multiple VLANs)
|
NORTEL PABX (Headoffice)
Regards,
Muhammad

hello muhammad,
you will need to configure a low-latency queueing strategy giving priority & bandwidth allocation to voice traffic. you can use this sample config and build upon this:
router(config)# class-map voice
router(config-cmap)# match access-group 102
router(config)# policy-map policy1
router(config-pmap)# class voice
router(config-pmap-c)# priority 50
router(config-pmap)# class bar
router(config-pmap-c)# bandwidth 20
router(config-pmap)# class class-default
router(config-pmap-c)# fair-queue
router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range
16384 20000
router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range
53000 56000
interface serial0/1
service-policy output policy1
if you have other traffics, u can configure the classmaps accordingly... you can read about LLQ for more info:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t2/ftllqpct.htm
hope this helps..all the best.. rate replies if found useful..
Raj

Similar Messages

  • Implementing QoS on 768 line

    I am implementing QoS FRTS and LLQ on two 2600 routers one with 12.2(6) the other running 12.3(3a).
    Everything seems to work fine except the ICA traffic, When I turn the QoS on the users are able to connect to the server but, the screen doesn't come up like its dropping the packets for it.
    I am wondering if anyone has run into this. Or if anyone can help...
    here are my policy maps and map class stuff.
    router A
    class-map match-all voip
    match dscp ef
    policy-map VoIP
    class voip
    priority 256
    class class-default
    fair-queue
    interface Serial0/0
    bandwidth 512
    no ip address
    encapsulation frame-relay
    no ip route-cache
    no ip mroute-cache
    service-module t1 timeslots 1-12
    cdp enable
    frame-relay traffic-shaping
    frame-relay lmi-type cisco
    interface Serial0/0.100 point-to-point
    description Frame-Relay to router B
    ip address x.x.x.x 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    frame-relay class voip
    frame-relay interface-dlci xxx
    map-class frame-relay voip
    frame-relay cir 512000
    frame-relay bc 7680
    frame-relay be 0
    frame-relay mincir 512000
    service-policy output VoIP
    router B
    class-map match-all voip
    match ip dscp 46
    policy-map VoIP
    class voip
    priority 256
    class class-default
    fair-queue
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    service-module t1 timeslots 1-12
    frame-relay traffic-shaping
    frame-relay lmi-type cisco
    interface Serial0/0.1 point-to-point
    description frame-relay to router A
    ip address x.x.x.x 255.255.255.0
    frame-relay class voip
    frame-relay interface-dlci xxx
    map-class frame-relay voip
    no frame-relay adaptive-shaping
    frame-relay cir 512000
    frame-relay bc 7680
    frame-relay be 0
    frame-relay mincir 512000
    service-policy output VoIP
    Thanks,
    Stephen Flanagan

    Oh one more thing the packets are marked dscp 46 comming into the router via a pbx

  • How to implement QoS over UDP ?

    Hi
    Excuse me fo my poor english.
    Is-it possible to implement QoS with java and socket UDP ?
    Thanks

    The term QoS means a number of different things. Which one do you mean? See here: http://en.wikipedia.org/wiki/Quality_of_service
    Are you sure you want to use UDP? It is an unreliable protocol, and often takes quite a bit of work to use properly.
    Also google for udp qos etc.

  • Help implementing QoS for Video Streaming

    Hello friends!
    I am trying to implement a quality of service logic for a videoplayer based on the Brightcove API. As I have learned it's a better idea to use methods in NetStreamInfo class (eg. currentBytesPerSecond) rather than using a native bandwith check.
    E.g. (where nc is a NetConnection object)
    var ns:NetStream = new NetStream(nc);
    var nsi:NetStreamInfo = ns.info;
    var cbytes:Number = nsi.currentBytesPerSecond;
    use cbytes to evaluate which quality to chose...
    The problem is that streams are initiated (by videoplayer) using the Brightcove API and not directly using NetConnection.connect(). The BC API doesnt seem to give me any access to the classes listed above either, altough I'm certain it's utilizing them.
    Are there any Brightcove or video streaming experts out there that have a clue as to how I can access the NetConnection object used by Brightcove? Or if i can access the NetStream object or even tge NetStreamInfo object directly.
    best regards,
    Fredrik

    You don't have your egress queuing setup. You need to map your COS values to a queue, then you can allocate bandwidth to those queue's. This makes lower priority traffic wait while higher priority traffic gets transmitted.
    I have a few configuration examples on my site that may help you. Remember that the config that I have may not be the best for your network so you will have to figure that out yourself.
    http://goatnetworking.com/CiscoCSwitchQOSConfig.php
    Make sure that your QOS profile on the WLC is set correctly. I found one of my controllers didn't even have a value set in the profile, but the profile was applied and doing nothing.
    You need to apply the policy map to mark packets on the port where the video source is on your network.
    You need to Trust DSCP on all of your trunk ports or the switch will ignore the dscp markings.
    QOS may only be one of many issues that may be causing your problem. Your AP's could be overloaded with clients, your data rates may not be optimized, etc..
    I hope this helps
    Scape

  • Implemention QOS for Voice

    Hi,
    We have a 2Mbps LL 1:4
    we are using CSICO ATA for Voice.
    we are using cisco 2620 router .
    Here are my questions.
    1.Kindly check My config and say whether this QOS config will work for prioritising the Voice.
    class-map match-all VOIP-RTP
    match ip dscp ef
    policy-map VOICE-QOS
    class VOIP-RTP
    priority 1024
    interface Serial0/0
    description ### STPI-GATEWAY-VASHI ###
    bandwidth 2048
    ip address 213.11.12.115 255.255.255.252
    ip access-group 103 in
    ip access-group 103 out
    service-policy output VOICE-QOS
    shutdown
    2.How can i filter the HTTP,TELNET,SSH,RDP,FTP traffic.
    Kindly help me.
    Thanks
    Ranga

    A more scalable config (that you dont have to redo too much) might include bandwidth guarantees for other classes of traffic as well...
    Also, I like to go with the qos design guide recommendation and set aside a queue for voice signalling... like the following...
    i also dont "match ip dscp ef" but rather just look for rtp audio... dont always have a marking switch/phone system behind your router... sometimes its a whitebox phone system sending rtp packets, and a dumb switch... I also go with a nested policy, which shapes all to the speed of the link, then decides which traffic will follow the rules of the child policy to leave the single queue ;)
    class-map match-any manage
    match protocol dhcp
    match protocol dns
    match protocol kerberos
    match protocol ldap
    match protocol snmp
    match protocol syslog
    class-map match-any bulk
    match protocol exchange
    match protocol ftp
    match protocol pop3
    match protocol smtp
    class-map match-any voicesignal
    match protocol h323
    match protocol rtcp
    class-map match-any transactional
    match protocol citrix
    match protocol pcanywhere
    match protocol secure-telnet
    match protocol sqlnet
    match protocol sqlserver
    match protocol ssh
    match protocol telnet
    match protocol tsrvrdp
    class-map match-any video
    match protocol rtp video
    match protocol cuseeme
    match protocol netshow
    match protocol rtsp
    match protocol streamwork
    match protocol vdolive
    class-map match-any voicebearer
    match protocol rtp audio
    policy-map Pol-S0/0/0.1-child
    class voicebearer
    set dscp ef
    priority percent 25
    class transactional
    bandwidth percent 25
    class voicesignal
    bandwidth percent 5
    class manage
    bandwidth percent 5
    policy-map Pol-S0/0/0.1-parent
    class class-default
    shape average 1444000
    service-policy Pol-0/0/0.1-child
    int s0/0/0.1
    service-policy output Pol-S0/0/0.1-parent
    (yes not all my classes are used in my policy; they are for future use... nice to have them in there now though, as they can always be allocated some bandwidth later on, at the expense of what is carved out now...)
    Tschuss,
    Joe

  • Where to implement QoS ???

    Hi All,
    I have the following scenario that i attached a jpg for !!
    My router (RouterB) is connected to my ISPs router (RouterA) All my incoming traffic is through routerA.
    After my RouterB i have a PIX515 with inside network and DMZ on the DMZ i have aproxy for internet access.
    My connection between routers is only 256kbps, and the internet usage is hogging the line most of the time.
    im not interested in other methods of controlling traffic on the proxy etc but rather perform QoS to allocate PRIORITY traffic to the PC1 and to a specific port for an aplication its using, as it becomes dead slow because the FR (256kbps) is hogged by internet traffic.
    I do not have access to routerA. i have access to RouterB and PIX515.
    My question is:
    Router B is not aware of my QoS problems. if i configure QoS to prioritize traffic for PC1 where should i configure it..on routerB or on PIX515 !!! and which interface is the most effective.
    I cannot help of thinking that routerA will send traffic to routerB as it is requested by the internet users and the appicaton of PC1. the internet users being more demanging than the PC1 application wont they stil hog up the bandwidth...or when i configure QoS on either of my machines will 'somehow tell' router A to limit its traffic to the proxy ???
    with the above i mean that...if i have internet traffic of 200kbps and my application traffic is needing 200 kbps as well..Router A will send the internet traffic and application traffic as it comes on its interfaces (without QoS) and spitting it out the FR link with the same rates...so if it is already sending streams of 200kbps internet traffic. i will still only get 56 kbps for my application, untill the internet traffic dies down ??? (im confused)
    please let me know if i am not clear with my request !!!
    Thank you,
    George

    Hi jon,
    so...in a few words theres nothing that can be done !!!! :( (on the QoS side) ...
    so..in order for the QoS to work efficiently it should be configured at the source, where a HIGH BANDWIDTH Input is present (like 100Mbps ) and a smaller bandwidth output interface (2Mbps lets say ) in order for a QUEUE to be created !!! RIGHT !!! ???? so if in the node i want to apply QoS, a QUEUE is not created for traffic towards my machines i can only pray !!! So i would have to talk to the guys on RouterA ??? to apply QoS and prioritize traffic on their router (where a queue is being created !!!)
    Did i get this right then ???
    Thanks for the help,
    George

  • Can QoS be implemented when VPN tunnel bandwidth is unknown?

    Is it possible to have some sort of QoS on both sides of a VPN tunnel when the speed at the endpoint is unknown. In other words is it possible to have QoS bandwidth parameters to be automatically detected/adapted to the actual bandwidth?

    Hey Martin,
    Thanks for your reply. I Think IntServ won't be a solution straight away, I'll try to explain what I would like to do.
    What my issue is that I have a few locations who are kind of mobile, and each location connects to the internet via various links, depending on which is available. This link can be a normal ISP which blocks all traffic except port 80 and 443. The connection could be a simple ISDN dialin or a dedicated T1 link.
    Because there is a Cisco VoIP router on the mobile location and some users' data should have precedence over others' I would like to implement QoS.
    My idea was when I were able to set up a site-to-site SSL VPN tunnel to a router in a datacenter (using Array Network stuff if the Cisco can't do site-to-site SSL) I would have more control over the internetlink. I Would not be limited to using only port 80 and 443: all traffic would just go encrypted and look like normal HTTPS traffic.
    It's likely that this VPN link would always consume the maximum available bandwidth. When it is be possible for some QoS mechanism to "detect" the speed of the VPN I could let's say dedicate bandwidth for 4 VoIP calls and the remaining bandwidth can be made available for normal traffic. Note that this normal traffic should have some priority levels too.
    Assigning dedicated bandwidth to VoIP isn't a big problem I think, however how can I make x percentage of the remaining bandwidth available to user x and y percentage available to user y?
    I Hope I wrote it understandable ;).
    Regards

  • QoS for App-V

    Hello,
    I'm currently configuring new 3750X switches.
    I must implement QoS on the stack. The QoS must be the following:
    VOIP Class (50%)
    App-V Class (40%)
    Movie Class (10%)
    How I can do this (in particular for AppV)? I do the following for the moment:
    class-map match-any VOIP
    match protocol voice
    match dscp ef
    match protocol sip
    match protocol skype
    match protocol rtp audio
    match protocol rtp video
    exit
    class-map AppV
    exit
    class-map Movie
    match protocol rtp video
    exit
    policy-map BandwidthTraffic
    class VOIP
    priority percent 50
    set dscp ef
    class AppV
    bandwidth remaining percent 40
    class Movie
    bandwidth remaining percent 10
    interface Gig1/0/3
    ip nbar protocol-discovery
    service-policy input BandwidthTraffic
    Anyone can says me if it's correct or not? And why?
    Thank you for your help.
    Florent

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    It appears you've some router QoS.  3750X QoS is quite different for egress as you're limited to working with four egress queues.  I don't recall 3750X supporting NBAR.
    Suggest you read the configuration guide's chapter on QoS, for you 3750X IOS version, and then post questions as necessary.  (My concern is, 3750X QoS is so different, it wouldn't be helpful to suggest a QoS configuration until you had a basic understanding of the 3750 QoS architecture and features.)

  • QOs detoriation with increase in bandwidth utilisation

    we are the MPLS service provider providing MPLS services in India.we notice that Voice quality detoriates as soon as the bandwdith utilisation of the customer links increase more than 60% of link bandwdith particularly with FTP. we have implemented QOS properly. i am told that qos is ineffective if bandwdith utilisation increases more than 60% of link bandwdith. customer should be adviced to increase the bandwdith. Is it true? please help

    Hi
    AFAIK if u configure strict priority to your voice traffic (i.e.,LLQ for your voice)it shuldnt affect your voice traffic at all regardless to your bandwidth utilsation since it reserves a particular amount of B/W for your voip traffic which again can be configured manually.
    The same you can do under your policy map configurations,hope you are having LLQ in place for your voice otherwise would suggest to look onto that and try out the same.
    And when theres no congestion thts your h/w queue is ample enough to serve your traffic the software queues will be bypassed (which are manually configured) and if theres some congestion then your S/W queues kicksin.
    so in a ideal customer network with voip and other traffic i would go with llq for voip and cbwfq for other traffic based on the traffic patterns using the DSCP,IP Prec values..
    to be more precise you can go for LFI also to slice your packets so that your voip packets dont get backlogged..
    regds

  • Sg200 vlan and qos

    Hello,
         Looking for best practice setup for this network I have three buildings networked together at layer2 have three swiches 2x sg200-24
    and one sg200-18. The middle building is the one with voip phones. On the other two buildings on each end I have pbx's that mark tos bit with '5'
    and voip cards in pbx's do not have vlan capabilites nor mark dscp. However in the middle building the phones have vlan marking and dscp. So have successfully made communication with setting voip cards on port 2 in the end buildings untagged on vlan 10. and middle building  tagged on vlan10 with vlan1 for downstream pc's hooked to phones (using trunks to phones) 10t 1U.
         My question is how to implement qos. The equipment does not have lldp advertising? Ideas would be apprecitated. I should mention that my idea is to use the oui's. The voip cards are marking tos bit with value '5' but the again voip cards do not support dscp. Not clear on best method for this.
    Mike

    Hi Mike, the SG 200 supports LLDP med. Here's a document I wrote for the SX300
    https://supportforums.cisco.com/docs/DOC-27005
    It's pretty much identical to the SX200.
    If you will keep the phones connected to a port and not move them, you can probably use the QoS  function of the switch, manually set the QoS configuration on the port then over ride ingress DSCP (much more aggressive, but cool) which can be found on the Quality of Service tab.
    -Tom
    Please mark answered for helpful posts

  • QoS for FRATM Internetworking

    Here is the scenario.
    We have a customer who has tow routers connected to an ATM cloud via an OC3 interface, and around 200 remote offices connected to the central office via Frame Relay data links (all of then). Recently, our customer implemented VoIP on his network and right now we are having problems with voice quality. In the case there is a network diagram with the actual network topology.
    If you look at the diagram (attached in the post), our customer has tow routers 7507 in the core. Both routers are redundant with each other and all the remote sites are connected to both routers with two different PVCs.
    In some sites the customer has routers 1751-V connected with a PABX using FXS ports. All remote routers consult a Gatekeeper which is located in the central office and the gatekeeper decides if the call gets routed or not.
    Now, when we try making a call from the Central Office to one remote site, the call gets through but the end party sometimes cannot hear the person in the CO, but the person in the CO can hear the end party perfectly without problems. The issue is only with the remote offices, the CO can hear end party without problems.
    We’ve been implementing QoS techniques like RSVP in the remote sites, WFQ and others without success. Our last attempt was with policy maps and class maps and didn’t get a success result.
    What would be the best QoS practice in this case?
    We would like to implement a QoS technique which ensures the voice traffic has priority over all other traffic and ensure the quality of the voice.
    Attached to this post are the configurations of the 2 core routers and one remote office.

    For troubleshooting one way voice issues, please check the below link
    http://www.cisco.com/warp/public/788/AVVID/fix_1way_voice.html#addlinfo

  • Qos standard vs priority vs hierarchical

    Hi all,
    I am really getting confused and have read lots of article and still don't fully get the queues on asa.
    I know asa can support standard priority and hierarchical but here is what i don't understand
    why can I not police priority queue? for instance police standard at 1mbps and police priority at 2mbps . this is so the priority will not take whatevery is available
    also what is hierarchical queue as I don't seem to get this one at all.
    I appreciate examples for this one
    I guess WRED, RED etc are all in the same class of standard,priority queuing etc which are used to manage queues and asa only offers what is mentioned on the title and the priority queue uses low latency queue?
    Thanks

    Hello ,
    I will try to explain this as simple as possible:
    Standard Priority queue:
    It basically splits the interface into 2 different queues (one for low latency traffic and the other one for best effor traffic)
    You cannot use shaping in here, altough you can use Policing just for the best-effort traffic
    Hierarchical Priority configuration, when it's need it?
    It needs to be used when you enable traffic shapping on an interface and you want to use a LLQ. that's all... so that some traffic that is being shapped can be prioritized.
    why can I not police priority queue? for instance police standard at 1mbps and police priority at 2mbps . this is so the priority will not take whatevery is available
    Well, that's just the desing of the firewall, I mean this is not a device that I would recommend to purchase to implement QoS in the network but at least it allow us to provide some basic mechanisms need it to have QoS end-to-end up and running.
    I know that with the MQC on a router you will be able not just to determine which traffic will get to the priority queue but also provide it certain limit of bandwith so it does not overwhelm the other queue (best effort) but on the ASA you have to think of it like if it were using Custom Priority Queueing where you just select which traffic goes first and that's it.. No option for limiting the traffic on the LLQ.
    Cheers,
    Julio Carvajal Segura

  • QOS voip

    Good day.
    I want to implement qos to priorise voice on other traffic.I have a router 1710 and behind (lan side) it computer and ipphone all set on private address 192.168.1.x.
    The ip phone use sip signalisation.
    On wan side the ip address of router is 196.202.234.162.
    how can configure it please ?
    Any suggest will be appreciate

    HI
    I think at You can use the QoS ACLs in this issue.
    Simple example:
    access-list 103 permit any any udp eq 5060 (SIP Signaling)
    access-list 103 permit any any tcp eq 5060 (SIP Signaling)
    access-list 103 permit any any udp range 11000 39000 (MEDIA)
    class-map voip1
    match access-group 103
    policy-map voipsip
    class voip1
    set ip dscp 56
    Interface Fast ethernet x/x
    service-policy input voipsip
    service-policy output voipsip
    rgds,
    Ismo

  • IEEE 802.1X auto-QoS

    Hello,
    Do Cisco switches implement QoS polices using 802.1X?
    I found at Cisco 3560-X and 3750-X software configuration guide informations about 802.1x authentication with per-user ACL and authentication with VLAN assignment, but nothing related of QoS.
    Could you help me please?
    Thank you!
    Allyson

    Hi Claudia,
    do you mean that the EAP-TLS authentication fails only on some 2960 switches and it works on other 2960s?
    What is the IOS version you're using there?
    What is the RADIUS server in use?
    What is the exact error message you see on the RADIUS side?
    Usually, the reason for the EAP-TLS handshake failure is to be troubleshoot on the supplicant and AAA server, however, there may be something on the switch depending on the certificate size and MTU settings on the switch(es).
    What is the server cert size and the MTU configured on the switches?
    With the info you provided it's difficult to say what's the reason of this failure.
    I would suggest to start looking into the above mentioned topics, else you would need to proceed with deeper debugging and sniffer traces, which may be better/easier to handle through a TAC case.
    I hope this helps.
    Regards,
    Federico
    If this answers your question please mark the question as "answered" and rate it, so other users can easily find it.

  • How to test QoS?

    Is there any solution to test that an implemented QoS (priority,..) works fine after configuration?
    For example: my boss want to see if the QoS implemented in my border router works fine. But he don't know how to read packet sniffer like wireshark, Ethereal.
    Best regards

    iantra123 wrote:Is there any solution to test that an implemented QoS (priority,..) works fine after configuration?For example: my boss want to see if the QoS implemented in my border router works fine. But he don't know how to read packet sniffer like wireshark, Ethereal.Best regards
    In addition to Marwan's excellent link, it depends what you mean by testing.
    If you want to show your boss that packets are being marked etc. then the doc has commands to show you that. But the real test of QOS is whether or not you are getting the service you expected for the different types of traffic you are marking. Is there some issue with the speed/throughput of your traffic ?
    Jon

Maybe you are looking for