Intercepting keystrokes not working

I have a need to validate/format keyed data, so I came up with a class which I thought would solve the problem. The problem is that the characters display on the device before I can intercept them. Is there a better way to achieve this? I'm using a Symbol MC7094 running IBM J9 v2.3. Here's the class:
public class FormattedTextField extends TextField implements KeyListener
    private int maxLength;
    public FormattedTextField( String initialStr, int col, int maxLength )
        super( initialStr, col );
        this.maxLength = maxLength;
        addKeyListener( this );
    public FormattedTextField( int col, int maxLength )
        this( "", col, maxLength );
    public void keyPressed( KeyEvent e ) {}
    public void keyReleased( KeyEvent e ) {}
    public void keyTyped( KeyEvent e )
        char c = e.getKeyChar();
        int len = getText().length();
        if (( c == KeyEvent.VK_BACK_SPACE ) || ( c == KeyEvent.VK_DELETE ) ||
            ( c == KeyEvent.VK_ENTER ) || ( c == KeyEvent.VK_TAB ) ||
            e.isActionKey() )
            return ;
        if ( len < maxLength )
            return;
        else
            e.consume();
}I did try this with the keyPressed() method as well, with the same result.
TIA,
Jeff

I was wondering the same. All of a sudden the f7, f8, and f9 controls arent working for Itunes when they worked perfectly fine before. I've tried searching different forums for the solution and have tried all of them but to no avail. I've never changed the keyboard settings, and haven't done anything to tweak the computer, just used the programs as usual and upgraded my Itunes.
I just downloaded ITunes 10 so I'm wondering if this has something to do with it.

Similar Messages

  • File export keystroke not working

    According to the menu, this keystroke is shift command E (Mac). Does not work at all. Puzzled.
    btw, on this forum, why is that that you enter a title to ask question, then you have to enter that title again.

    Hi,
    What is the version of LR ?
    Version of MAC ?
    You have to select the images you want to export and then press Shift+Command+E, it shoud open the Export box.
    Thanks,
    Baljeet

  • Some keystrokes not working

    I am learning more about my iMac and have found a nifty shortcut to quick hide/unhide dock. Command - Option. But id doesn't work for me. Why? Do I have to set something somewhere? This happens with other keystrokes as well.
    Any help is appreciated,
    Sarah

    The default +keyboard shortcut+ for hide/show Dock is Command-Option-D, not Command-Option.
    The pre-assigned keyboard shortcuts are turned ON and OFF in System Preferences +Keyboard & Mouse+ pane +Keyboard Shortcuts+ tab. Here, you can also create new keyboard shortcuts.

  • FCP7 keystroke not working correctly in PP CS6?

    Command 'R' to render out a clip?  Each time I do it Premiere Pro whips me back to the start of the timeline.  I've started up a new project, still the same issue.
    I'm wondering if Premiere Pro will have a plist file, mmm, maybe I will go look ..
    But any suggestions or warnings about using the FCP7 keystrokes in PP CS6 would be most appreciated.
    Thank you,
    Ben

    You can customize your keyboard shortcuts any way you prefer:
    Customize or load keyboard shortcuts
    http://helpx.adobe.com/premiere-pro/using/default-keyboard-shortcuts-cc.html#id_38940
    note:
    Premiere keyboard shortcut preset files have the extension '.kys'.

  • Keystrokes not working

    Hi....
    I have a MacBook White with snow leopard installed...
    A few days ago, I found that some keystrokes don't work any more...like command-1 and command-2 (in ALL applications, and I checked each button individually and they work just fine "i.e. it isn't a hardware issue"). The play button (F8) doesn't start itunes also. Actually, the F7, F8 & F9 doesn't work in itunes nor in Quick player....
    Is there any fix for that?... Of course, i don't want to re-install snow leopard...
    Thanks....

    I was wondering the same. All of a sudden the f7, f8, and f9 controls arent working for Itunes when they worked perfectly fine before. I've tried searching different forums for the solution and have tried all of them but to no avail. I've never changed the keyboard settings, and haven't done anything to tweak the computer, just used the programs as usual and upgraded my Itunes.
    I just downloaded ITunes 10 so I'm wondering if this has something to do with it.

  • Certain keystrokes not working

    On my dual G5 2.5 with the white pro keyboard there are some key combinations that won't work.
    This is the left "shift" in combination with the "o" key and the left "alt" key in combination with the "l" key to receive a "@" (this is on a german keyboard).
    Left shift and alt work with any other key and "o" and "l" work with the right shift and alt.
    So does this look as a malfunction of the keyboard? Or could this be system related?
    Any insights would be very much appreciated.
    Ralf

    Hi Ralf, and a Warm Welcome to the Power Mac G5 Forum!
    Have the keys been working ok, and just stopped working? If so, it may be hardware fault.
    If you haven't tried this already... you can go to System Preferences > International > Input Menu and there you can check the language selection, enable 'Keyboard Viewer' and enable 'Show input menu in menu bar'.
    Then you should get a little flag at top right of the Finder menu bar; select it, and then select 'Show Keyboard Viewer' and you should then be able to see what pressing the various keys and combinations of keys on the keyboard will produce.

  • Keystroke return and ASCII character 13 and 10 not working in

    I have the following script to opens a web page of my internal telephone switch (all in the local network) and fill in the two fields that come up and needs filled out in order to log in.
    tell application "Safari"
    activate
    open location "http://192.168.1.90/"
    end tell
    tell application "System Events"
    delay 1
    keystroke tab
    delay 1
    keystroke "" -- Note: Username goes here if one is wanted/needed
    delay 1
    keystroke "XYZ" -- Note: Password goes here if one is wanted/needed
    delay 1
    keystroke (ASCII character 13)
    end tell
    All works fine, it skips the first field (the login name is blank). Puts the password in the next field. However it refuses to activate the “log-in” button of the login window (the one that is blue and normally can be done with the enter key).
    I tried:
    keystroke (ASCII character 13)
    keystroke (ASCII character 10)
    keystroke return
    keystroke enter
    Non of them do the job.
    Any suggestions please? Thanks.

    Consider replacing ...
    keystroke (ASCII character 13)
    ... with ...
    tell document 1 to do JavaScript "document.myform.submit()"
    ... where 'myform' will have to be replaced with the forms' name.
    To obtain the forms' name ...
    01. Perform a right ('control' if single button mouse) button click on the form based web page. A contextual menu will appear.
    02. Select the 'View Source' menu item. A new 'Safari' will appear with the title beginning with 'Source of ...'.
    03. Look for a line similar to ...
    <form name="myform" action="submit-form.php">
    ... Note, the name="myform". This is the forms' name. Whatever is between the name="" is what you need to substitute 'myform' with, in 'tell document 1 to do JavaScript "document.myform.submit()"'.
    I entered ...
    tell application "Safari" to tell document 1 to do JavaScript "document.myform.submit()"
    ... in 'Script Editor', and visited 'JavaScript Form Submit example'. When the AppleScript code was executed, the web page responded accordingly.
    New test of code. With 'JavaScript Form Submit example' again displayed, the following code ...
    set tValue to "ChangeAgent"
    tell application "Safari"
    tell document 1
    do JavaScript ("myform.query.value=\"" & tValue & "\"")
    do JavaScript "document.myform.submit()"
    end tell
    end tell
    ... was entered into 'Script Editor', and executed.
    The results were as expected - the resultant web page reported ...
    Great! The Form is Submitted Successfully!
    Query:'ChangeAgent'
    Back
    ... And, the code was condensed even further ...
    set tValue to "ChangeAgent"
    tell application "Safari" to tell document 1 to do JavaScript ("myform.query.value=\"" & tValue & "\"; document.myform.submit()")
    ... producing the desired results.

  • Captivate 4 AS2 Text Entry Box not working with Flash Player 11

    I am having issues with text entry boxes not working at all in flash 11. I am using Captivate 4 and exporting an AS2 swf. When you get to the slide you can type but you cannot see anything nor does the button or keystroke to move on. Also there is no cursor. Any ideas?

    You said it is not working with Flash 11, so does that mean you tested with previous version and that worked?
    While publishing choose Flash player as 9 and publish that, verify if that plays in a compatible web browser.
    AS 2 is a legacy scripting, it has been said not too be supported with even Flash Player 10 --
    http://help.adobe.com/en_US/AS2LCR/Flash_10.0/help.html?content=Part2_AS2_LangRef_1.html
    I believe if you switch back to version 9 while publish your project, it should work.
    Thanks,
    Anjaneai

  • ASA-5505 Site-to-Site Not Working

    I am somewhat new to Cisco but to do have some experience. I am trying to connect two ASA 5505's together via site-to-site VPN. They are configured with public IPs and all other services are working. I have used the VPN wizard on both boxes successfully but the tunnels are not working. The two devices are on the Comcast network. Any help would be appreacited.
    Site A: ASA 5505 w/50 User license
    Site B: ASA 5505 w/10 User license
    Site A Config:
    ASA Version 8.2(5)
    hostname *********************
    enable password 6.De4e7UzES9wBPg encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.100.10 Web_Server
    name 10.0.6.0 Ghost_Flower_Inside
    name 10.0.5.0 San_Mateo_Inside
    name 10.0.5.100 Any_Connect_100
    name 10.0.5.101 Any_Connect_101
    name 10.0.5.102 Any_Connect_102
    name 10.0.5.103 Any_Connect_103
    name 10.0.5.104 Any_Connect_104
    name 10.0.5.105 Any_Connect_105
    name 10.0.5.106 Any_Connect_106
    name 10.0.5.107 Any_Connect_107
    name 10.0.5.108 Any_Connect_108
    name 10.0.5.109 Any_Connect_109
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    switchport access vlan 12
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.5.201 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 173.10.XXX.XXX 255.255.255.252
    interface Vlan12
    no forward interface Vlan1
    nameif dmz
    security-level 50
    ip address 192.168.100.1 255.255.255.0
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 75.75.75.75
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group network Any_Connect_DHCP
    network-object host Any_Connect_100
    network-object host Any_Connect_101
    network-object host Any_Connect_102
    network-object host Any_Connect_103
    network-object host Any_Connect_104
    network-object host Any_Connect_105
    network-object host Any_Connect_106
    network-object host Any_Connect_107
    network-object host Any_Connect_108
    network-object host Any_Connect_109
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list outside_access_in extended permit tcp any interface outside eq ssh
    access-list outside_1_cryptomap extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip object-group Any_Connect_DHCP any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    ip local pool AnyConnectDHCPPool Any_Connect_100-10.0.5.110 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (dmz) 1 192.168.100.2 netmask 255.255.255.255
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (dmz,outside) tcp interface www Web_Server www netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 173.10.XXX.XXX 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 10.0.1.0 255.255.255.0 inside
    http 10.1.10.0 255.255.255.0 outside
    http San_Mateo_Inside 255.255.255.255 inside
    http San_Mateo_Inside 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 173.12.XXX.XXX
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    vpn-sessiondb max-webvpn-session-limit 10
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh 10.0.1.0 255.255.255.0 inside
    ssh San_Mateo_Inside 255.255.255.0 inside
    ssh 10.1.10.0 255.255.255.0 outside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 10.0.5.10-10.0.5.30 inside
    dhcpd dns 75.75.75.75 75.75.76.76 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    anyconnect-essentials
    svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 1 regex "Intel Mac OS X"
    svc profiles CATS disk0:/cats.xml
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    dns-server value 75.75.75.75
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    webvpn
      svc profiles value CATS
    username user1 password tTq7bIZ.C4x0j.qv encrypted privilege 15
    username ********* password sPxon1E6hTszm7Ko encrypted privilege 15
    tunnel-group 173.12.XXX.XXX type ipsec-l2l
    tunnel-group 173.12.XXX.XXX ipsec-attributes
    pre-shared-key *****
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:1751532c3624a6c2eec3c1ae0c31fe03
    : end
    Site B:
    ASA Version 8.2(5)
    hostname ***************
    enable password 6.De4e7UzES9wBPg encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.100.10 Web_Server
    name 10.0.6.0 Ghost_Flower_Inside
    name 10.0.5.0 San_Mateo_Inside
    name 10.0.5.100 Any_Connect_100
    name 10.0.5.101 Any_Connect_101
    name 10.0.5.102 Any_Connect_102
    name 10.0.5.103 Any_Connect_103
    name 10.0.5.104 Any_Connect_104
    name 10.0.5.105 Any_Connect_105
    name 10.0.5.106 Any_Connect_106
    name 10.0.5.107 Any_Connect_107
    name 10.0.5.108 Any_Connect_108
    name 10.0.5.109 Any_Connect_109
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    switchport access vlan 12
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.5.201 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 173.10.XXX.XXX 255.255.255.252
    interface Vlan12
    no forward interface Vlan1
    nameif dmz
    security-level 50
    ip address 192.168.100.1 255.255.255.0
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 75.75.75.75
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group network Any_Connect_DHCP
    network-object host Any_Connect_100
    network-object host Any_Connect_101
    network-object host Any_Connect_102
    network-object host Any_Connect_103
    network-object host Any_Connect_104
    network-object host Any_Connect_105
    network-object host Any_Connect_106
    network-object host Any_Connect_107
    network-object host Any_Connect_108
    network-object host Any_Connect_109
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list outside_access_in extended permit tcp any interface outside eq ssh
    access-list outside_1_cryptomap extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip object-group Any_Connect_DHCP any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    ip local pool AnyConnectDHCPPool Any_Connect_100-10.0.5.110 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (dmz) 1 192.168.100.2 netmask 255.255.255.255
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (dmz,outside) tcp interface www Web_Server www netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 173.10.242.182 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 10.0.1.0 255.255.255.0 inside
    http 10.1.10.0 255.255.255.0 outside
    http San_Mateo_Inside 255.255.255.255 inside
    http San_Mateo_Inside 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 173.12.XXX.XXX
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    vpn-sessiondb max-webvpn-session-limit 10
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh 10.0.1.0 255.255.255.0 inside
    ssh San_Mateo_Inside 255.255.255.0 inside
    ssh 10.1.10.0 255.255.255.0 outside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 10.0.5.10-10.0.5.30 inside
    dhcpd dns 75.75.75.75 75.75.76.76 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    anyconnect-essentials
    svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 1 regex "Intel Mac OS X"
    svc profiles CATS disk0:/cats.xml
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    dns-server value 75.75.75.75
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    webvpn
      svc profiles value CATS
    username ************** password sPxon1E6hTszm7Ko encrypted privilege 15
    tunnel-group 173.12.XXX.XXX type ipsec-l2l
    tunnel-group 173.12.XXX.XXX ipsec-attributes
    pre-shared-key *****
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:1751532c3624a6c2eec3c1ae0c31fe03
    : end

    Hi Kevin,
    Both the sides have IP address of 173.10.XXX.XXX  on the respective Outside interfaces and you have configured the peers for 173.12.X.X.
    Please ensure the correct IP addresses for VPN peers are configured , via the following command:
    crypto map outside_map 1 set peer X.X.X.X
    e.g. If you have 173.10.X.X on Site X and 173.12.X.X on Site Y , then
    On Site X, peer would be
    crypto map outside_map 1 set peer 173.12.X.X
    and the tunnel-group will be
    tunnel-group 173.12.XXX.XXX type ipsec-l2l
    tunnel-group 173.12.XXX.XXX ipsec-attributes
    pre-shared-key *****
    On Site Y, peer would be
    crypto map outside_map 1 set peer 173.10.X.X
    and the tunnel-group will be
    tunnel-group 173.10.XXX.XXX type ipsec-l2l
    tunnel-group 173.10.XXX.XXX ipsec-attributes
    pre-shared-key *****
    Also , the nat exempt would be complimentary on each other i.e.
    On Site X,
    access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    On Site Y,
    access-list inside_nat0_outbound extended permit ip Ghost_Flower_Inside 255.255.255.0 San_Mateo_Inside 255.255.255.0
    Hope that helps.
    Regards,
    Dinesh Moudgil

  • IBM cognos TM1 Executive viewer is not working on direct Access

    Hi,
    We are implementing DirectAccess in our environment and testing applications in test lab. It has been observed that executive viewer is not working on Direct Access but working fine over VPN mobile checkpoint. When DA client click on open view button it
    gives error
    " Additional information:
    Unable to connect to server XYZ.com using TCP-IP port 7112. Please make sure that IBM cognos TM1 executive viewer server is started and the port is not blocked by any proxy server or firewall"
    but from client telnet is working on port 7112. All ports between DA server and application server are open 3389,7112 and 80.
    Also select database option is grayed out and user is unable to select the database. When switching to VPN its working fine.
    We are using Executive viewer 9.4. 
    Any help would be appreciated.

    It sounds like this program may not be capable of talking over IPv6, which DirectAccess uses. First make sure that when you connect it is trying to talk to a hostname and not an IPv4 address. If your program is calling for "192.168.1.100" - this is never
    going to work over DirectAccess. It must call for a name that DirectAccess can resolve to an IPv6 address for communication over DA.
    If you confirm it is talking to a name, and then if you confirm that you can do other things to that same name (can you RDP into the server for example?), then that confirms that DirectAccess traffic flow is working to that name/server.
    If RDP works but the application still doesn't work, then the application is probably incapable of IPv6. You can either ask IBM if they have a newer version that does talk IPv6, otherwise I have a utility available that can intercept packets from these kinds
    of problematic applications and flip the packets into IPv6 on the DA client. Let me know if you need any further information on that: http://www.ivonetworks.com/news/2013/05/ivo-networks-announces-app46-for-directaccess/

  • Mouselistner is not working with jtable in the browser

    Hi
    I am having a problem with jTable.
    I added a mouselistener to table header to sort table but when i run that applet from my netbean ide it works fine but when i run that applet in my browser it doesn't work, i have tested, its not even generate mouseclick event .Please help me guys.
    I call this function after calling initComponents() method of JApplet.
    public void setTableAction()
    //set mouselistener to sort table on click of table header
    final JTableHeader head= jTable1.getTableHeader();
    head.addMouseListener(new java.awt.event.MouseAdapter()
    public void mouseClicked(java.awt.event.MouseEvent evt)
    Vector data= ((DefaultTableModel)jTable1.getModel ()).getDataVector();
    sortTable(data, head.columnAtPoint(evt.getPoint()));
    //set action map to change the default action performed for enter key pressed
    InputMap imap = jTable1.getInputMap(JTable.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT);
    KeyStroke enterKey = KeyStroke.getKeyStroke(KeyEvent.VK_ENTER, 0);
    KeyStroke tabKey = KeyStroke.getKeyStroke(KeyEvent.VK_TAB, 0);
    final Action oldAction= jTable1.getActionMap().get(imap.get(tabKey)); // get map to set enter key.
    imap.put(enterKey, "enter"); // set enter key
    Action newAction = new AbstractAction(){
    public void actionPerformed(ActionEvent e) {
    oldAction.actionPerformed(e);
    JTable table= (JTable)e.getSource();
    table.changeSelection(0,0,false,false);
    if(table.isCellEditable(0,0))
    String sTemp= (String)table.getValueAt(0,0);
    if(sTemp.length()>0) {
    if(bRenewItem)
    retrieveRcodeDetails("",sTemp);
    else
    processRCodeDetails(sTemp, e);
    }else
    table.editCellAt(0,0);
    jTable1.getActionMap().put("enter", newAction);
    jTable1.setPreferredScrollableViewportSize(jTable1.getPreferredSize());
    }

    Hi,
    I also am using the Bépo layout with an encrypted drive and encountered the same problem: the Return key does not work.
    It seems to work fine if you use the fr-bepo-latin9 keymap.
    # /etc/vconsole.conf
    KEYMAP=fr-bepo-latin9
    But I also looked at the files /usr/share/kbd/keymaps/i386/bepo/fr-bepo.map.gz and /usr/share/kbd/keymaps/i386/bepo/fr-bepo-latin9.map.gz (you can open gzipped files in vim directly). fr-bepo-latin9.map.gz defines keycode 28 (Return) but fr-bepo.map.gz does not.
    I modified fr-bepo.map.gz:
    # vim /usr/share/kbd/keymaps/i386/bepo/fr-bepo.map.gz # Append that line : "keycode 28 = Return".
    # mkinitcpio -p linux # Rebuild the initramfs.
    The Return key now works, but the Backspace (14, "Delete") and Shift (54) keys don’t work. I found that both the cf.map.gz (french canadian layout) and fr-bepo-latin9.map.gz files define those keycodes as well as other non-printing keys so I copied the following lines from fr-bepo-latin9.map.gz to fr-bepo.map.gz:
    keycode 1 = Escape Escape
    keycode 14 = Delete Delete
    keycode 15 = Tab Tab
    keycode 28 = Return
    keycode 29 = Control
    keycode 42 = Shift
    keycode 54 = Shift
    keycode 56 = Alt
    keycode 58 = Caps_Lock
    keycode 97 = Control
    It works! Don’t forget to rebuild the initramfs after you change the keymap file.
    # mkinitcpio -p linux
    I will send a message to the kbd and bépo projects mailing lists and report back.

  • Generic GRE not working (ver 4.1.3.55)

    Hi everybody.
    I'm testing in Lab a configuration for one customer.
    It's a basic environment with :
    DATA CENTER (wccp)
    1 WAEs 7341 and 1 Cat6506 routers
    BRANCH (inline)
    1 WAE 574.
    Optimization works with l2-redirect and gre return in DATA CENTER !!
    It does not work with egress-method generic-gre inteception-method wccp.
    This is the problem that i can see with " show wccp gre" on the 7341..
    " Packets received on a disabled service: 667790".
    I read some manuals but...
    I don't understand .. The service 61 and 62 works !!
    So any idea ?
    Thanks a lot to everybody
    Vittorio

    Hy and thanks to be interested.
    That's the output you ask :
    WAE-DC-01#sh egress-methods
    Intercept method : WCCP
    TCP Promiscuous 61 :
    WCCP negotiated return method : WCCP GRE
    Egress Method Egress Method
    Destination Configured Used
    any Generic GRE Generic GRE
    TCP Promiscuous 62 :
    WCCP negotiated return method : WCCP GRE
    Egress Method Egress Method
    Destination Configured Used
    any Generic GRE Generic GRE
    Intercept method : Generic L2
    Egress Method Egress Method
    Destination Configured Used
    any not configurable IP Forwarding
    And here there is another useful :
    WAE-DC-01#sh wccp gre
    Transparent GRE packets received: 52082
    Transparent non-GRE packets received: 0
    Transparent non-GRE non-WCCP packets received: 0
    Total packets accepted: 0
    Invalid packets received: 0
    Packets received with invalid service: 0
    Packets received on a disabled service: 50118
    Packets received too small: 1964
    Packets dropped due to zero TTL: 0
    Packets dropped due to bad buckets: 0
    Packets dropped due to no redirect address: 0
    Packets dropped due to loopback redirect: 0
    Pass-through pkts dropped on assignment update:0
    Connections bypassed due to load: 0
    Packets sent back to router: 50118
    GRE packets sent to router (not bypass): 0
    Packets sent to another WAE: 0
    GRE fragments redirected: 28770
    GRE encapsulated fragments received: 0
    Packets failed encapsulated reassembly: 0
    Packets failed GRE encapsulation: 0
    Packets dropped due to invalid fwd method: 0
    Packets dropped due to insufficient memory: 0
    Packets bypassed, no pending connection: 0
    Packets due to clean wccp shutdown: 0
    Packets bypassed due to bypass-list lookup: 0
    Conditionally Accepted connections: 0
    Conditionally Bypassed connections: 0
    L2 Bypass packets destined for loopback: 0
    Packets w/WCCP GRE received too small: 0
    Packets dropped due to received on loopback: 0
    Packets dropped due to IP access-list deny: 0
    Packets fragmented for bypass: 28770
    Packets fragmented for egress: 0
    Packet pullups needed: 57543
    Packets dropped due to no route found: 0
    Any new idea ?
    Thanks
    Vittorio

  • Keyboard shortcuts not working

    Here is the thread I had going online. Lost patience. Very disappointed. I would love an answer if you have one.
    Drake DeLucca
    in Adobe Story Plus my keyboard shortcuts do not work. I'm on a Macbook. I'm really tired of using an outdated Mac and Final Draft AV, but I cannot get this Adobe Story to work at all. I cannot work efficiently if I have to go to a drop down menu every time I need a new element. I need to keystroke the element & type. I'm running the latest OS on my Macbook Pro.
    Vartul, thank you for the link , but I didn't make myself clear. I had been to the linked page previously. When I use these keyboard shortcuts on my Macbook they simply do not have the specified outcome. They don't work at all. Is there a setting in preferences that I need to correct? I am generally working with multiple desktops and swipe from one to another using my multitouch trackpad. When I use the specified shortcuts I get bounced out of Adobe Story into another desktop. This leads me to believe there is a Mac Preference that needs to be changed but I haven't figured it out yet. Can you enlighten me as to what the conflict might be?

    Hi Drake,
    Sorry for a late reply.
    I am guessing that you are using Story through Safari browser. The shortcuts to change element types are in Safari are:
    Apply Scene Heading : Control + 1
    Apply Action : Control + 2
    Apply Character : Control + 3
    Apply parenthetical : Control + 4
    Apply dialogue : Control + 5
    Apply transition : Control + 6
    Apply shot : Control + 7
    Apply General : Control + 8
    There are another set of keyboard shortcuts that affect the behaviour of 'Tab' and 'Enter' keys while you are typing some element.
    e.g. when you are typing a 'Scene Heading', pressing 'Enter' will move you to an 'Action' element. Similarly while typing an Action element, pressing 'tab' key will add a new 'Character' element.
    You can customize these set of shortcuts from Temple option of Edit Menu.
    I hope this helps

  • VPN not working after adding subinterface - ASA 5510

    Hello,
    Currently I want to add a second lan (vlan) in a customers network. The new network will be for a wireless infrastructure.
    There is also VPN Configured on the ASA - One with L2TP for Windows Clients and an IPsec for Cisco Clients.
    Former we only had one outside (Eth0/0) and one inside interface (Eth0/1) on the ASA.
    Now I want to use the Eth0/2 with subinterfaces, so that we will be flexible for future, when deploying more vlans.
    But now, when i turn the first subinterface Eth0/2.2 to no-shut the VPN Connections does not work any more.
    Bulding up the VPN connection works, but it seems that the traffic is not tunneled. (I checked this, because tracert to an internal adress goes to the internet)
    Below there is my config, i don't know whats wrong. I think split-tunnel is configured correctly (because it works when i delete eth0/2.2)
    TREV is the network of this location.
    Company1,2,3 are remote locations.
    : Saved
    ASA Version 8.2(5)
    hostname XXXXXXX
    domain-name domain.lan
    enable password XXXXXXXXXXX encrypted
    passwd XXXXXXXXXX encrypted
    names
    name 192.168.100.0 TREV
    name 192.168.200.0 COMPANY3
    name XXXXXXXX Company1
    name 192.168.1.0 Company2
    name XXXXXXXXX GCT
    name XXXXXXXX BMD
    name 192.168.110.0 Wireless
    name 192.168.201.0 COMPANY3-VPN
    name 192.168.11.0 COMPANY2-VPN
    name 192.168.101.0 TREV-VPN
    interface Ethernet0/0
    description Outside
    nameif outside
    security-level 0
    ip address XXXXX 255.255.255.248
    interface Ethernet0/1
    description Inside
    nameif inside
    security-level 100
    ip address 192.168.100.1 255.255.255.0
    interface Ethernet0/2
    description Trunk Interface
    no nameif
    no security-level
    no ip address
    interface Ethernet0/2.2
    description Wireless
    vlan 110
    nameif wlan
    security-level 100
    ip address 192.168.110.1 255.255.255.0
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    ftp mode passive
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 192.168.100.10
    domain-name domain.lan
    dns server-group COMPANY2
    name-server 192.168.1.16
    domain-name domain.local
    dns server-group COMPANY3
    name-server 192.168.200.1
    domain-name domain.local
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group network VPN_Networks
    network-object COMPANY3 255.255.255.0
    network-object COMPANY3-VPN 255.255.255.0
    network-object COMPANY2 255.255.255.0
    network-object COMPANY2-VPN 255.255.255.0
    network-object TREV 255.255.255.0
    network-object TREV-VPN 255.255.255.0
    object-group network DM_INLINE_NETWORK_1
    network-object COMPANY2 255.255.255.0
    network-object COMPANY3 255.255.255.0
    network-object COMPANY3-VPN 255.255.255.0
    network-object COMPANY2-VPN 255.255.255.0
    network-object Wireless 255.255.255.0
    access-list INCOMING remark *** ICMP Erlauben ***
    access-list INCOMING extended permit icmp any any echo-reply
    access-list INCOMING extended permit icmp any any time-exceeded
    access-list INCOMING extended permit icmp any any unreachable
    access-list INCOMING extended permit icmp any any parameter-problem
    access-list INCOMING extended permit icmp any any source-quench
    access-list INCOMING extended permit icmp any any echo
    access-list INCOMING remark *** Wartung Company1 ***
    access-list INCOMING remark *** Wartung BMD ***
    access-list INCOMING remark *** Mail ***
    access-list ......
    access-list Trev-nat0 remark *** NoNat ***
    access-list Trev-nat0 extended permit ip TREV 255.255.255.0 object-group VPN_Networks
    access-list Trev-nat0 extended permit ip object-group VPN_Networks TREV 255.255.255.0
    access-list Trev-nat0 extended permit ip TREV 255.255.255.0 object-group DM_INLINE_NETWORK_1
    access-list DefaultRAGroup_splitTunnelAcl standard permit TREV 255.255.255.0
    access-list outside_1_cryptomap extended permit ip TREV 255.255.255.0 object-group DM_INLINE_NETWORK_1
    access-list inside_debug extended permit tcp any host 192.168.100.5
    access-list inside_debug extended permit tcp any TREV 255.255.255.0
    access-list Wireless-nat0 extended permit ip Wireless 255.255.255.0 TREV 255.255.255.0
    pager lines 24
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    mtu wlan 1500
    ip local pool VPN-Pool 192.168.101.1-192.168.101.31 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (outside) 2 XXXXXXXXXXX
    nat (inside) 0 access-list Trev-nat0
    nat (inside) 2 192.168.100.25 255.255.255.255
    nat (inside) 2 192.168.100.250 255.255.255.255
    nat (inside) 1 TREV 255.255.255.0
    nat (wlan) 0 access-list Wireless-nat0
    static (inside,outside) tcp interface 444 192.168.100.10 444 netmask 255.255.255.255
    static (inside,outside) tcp interface https 192.168.100.10 https netmask 255.255.255.255
    .... a lot of statics..............
    static (inside,outside) tcp XXXXXXXXXX pop3 192.168.100.25 pop3 netmask 255.255.255.255
    static (inside,outside) tcp XXXXXXXXXX  995 192.168.100.25 995 netmask 255.255.255.255
    access-group INCOMING in interface outside
    route outside 0.0.0.0 0.0.0.0 XXXXXXXXXX  1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server RADIUS protocol radius
    aaa-server RADIUS (inside) host 192.168.100.10
    timeout 5
    key *****
    radius-common-pw *****
    aaa-server RADIUS2 protocol radius
    aaa-server RADIUS2 (inside) host 192.168.100.10
    key *****
    radius-common-pw *****
    aaa authentication ssh console LOCAL
    http server enable 4430
    http COMPANY2 255.255.255.0 management
    http TREV 255.255.255.0 inside
    http Company1 255.255.255.224 outside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
    crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set TRANS_ESP_AES_128_SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set TRANS_ESP_AES_128_SHA mode transport
    crypto ipsec transform-set TRANS_ESP_AES_256_SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set TRANS_ESP_AES_256_SHA mode transport
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 TRANS_ESP_AES_128_SHA TRANS_ESP_AES_256_SHA TRANS_ESP_3DES_MD5 TRANS_ESP_3DES_SHA
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs group1
    crypto map outside_map 1 set peer 178.188.202.78
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    crypto isakmp policy 20
    authentication pre-share
    encryption des
    hash sha
    group 5
    lifetime 28800
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash sha
    group 5
    lifetime 86400
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh bit-Studio 255.255.255.224 outside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh TREV 255.255.255.0 inside
    ssh timeout 60
    console timeout 0
    management-access inside
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcprelay server 192.168.100.10 inside
    dhcprelay enable wlan
    dhcprelay setroute wlan
    dhcprelay timeout 90
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    wins-server value 192.168.100.10
    dns-server value 192.168.100.10
    vpn-tunnel-protocol IPSec l2tp-ipsec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
    default-domain value domain.lan
    intercept-dhcp enable
    group-policy IPsecVPN internal
    group-policy IPsecVPN attributes
    wins-server value 192.168.100.10
    dns-server value 192.168.100.10
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
    default-domain value domain.lan
    username admin password XXXXXXXXXX encrypted privilege 15
    username vpntest password XXXXXXXXX nt-encrypted
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool
    authentication-server-group RADIUS
    default-group-policy DefaultRAGroup
    tunnel-group DefaultRAGroup ipsec-attributes
    pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    no authentication chap
    authentication ms-chap-v2
    tunnel-group XXXXXXXXX type ipsec-l2l
    tunnel-group XXXXXXXXXXXX ipsec-attributes
    pre-shared-key *****
    tunnel-group IPsecVPN type remote-access
    tunnel-group IPsecVPN general-attributes
    address-pool VPN-Pool
    authentication-server-group RADIUS
    default-group-policy IPsecVPN
    tunnel-group IPsecVPN ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:f2041a5902e945a130fe25fbb8e5d368
    : end

    Hi,
    First I would go through all the NAT0/NAT Exempt rules you have for VPNs. They seem to contain useless lines where either destination or source network isnt correct.
    Lets look at the NAT0 ACL you have line by line
    access-list Trev-nat0 extended permit ip TREV 255.255.255.0 object-group VPN_Networks
    The above access-list has the correct source network configured Yet it has its destination addresses configured with an "object-group" which contains your LAN network
    You should probably remove the LAN network from the object-group VPN_Networks
    access-list Trev-nat0 extended permit ip object-group VPN_Networks TREV 255.255.255.0
    To my understanding the above ACL line doesnt serve any purpose as the networks configured under VPN_Networks arent located behind your "inside" interface (Other than the one I'm asking to remove from the object-group)
    access-list Trev-nat0 extended permit ip TREV 255.255.255.0 object-group DM_INLINE_NETWORK_1
    The above ACL overlap with the very first ACL lines configurations and needlesly makes the configuration harder to read. It also contains the Wireless network which it shouldnt
    I would suggest simplifying your NAT0 configurations for example in the following way (change the names if you want if youre going to try it out)
    object-group network TREV-LAN
      description Local networks
      network-object 192.168.100.0 255.255.255.0
    object-group network VPN-NETWORKS
    description Remote networks
    network-object 192.168.200.0 255.255.255.0
    network-object 192.168.201.0 255.255.255.0
    network-object 192.168.1.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 192.168.101.0 255.255.255.0
    access-list TREV-LAN-NAT0 remark NAT0 / NAT Exempt for VPN Connections
    access-list TREV-LAN-NAT0 permit ip object-group TREV-LAN object-group VPN-NETWORKS
    With the above configurations
    You have all NAT0 with a single line of access-list configuration (not counting the remark line as it doesnt affect anything)
    If there is changes in the VPN pools, VPN remote networks or LAN networks you can simply change them under the configured object-groups instead of touching the actual ACL. There might be situations where you should change the ACL from the above if there is some bigger changes to network
    So as I said, I would start with changing the above NAT configurations and then test the VPN again. If it doesnt work we will have to check some other things out.
    - Jouni

  • System Events not working correctly with Acrobat Professional

    Hey Guys, I have a script that I have written that automatically enables security settings on a PDF through Acrobat Professional. Because of Acrobats poor scriptability I am forced into doing much though System Events.
    This is not a major problem... however when activating some settings in the security settings, often warning Alert dialog boxes appear when you tell System Events to enable particular settings. These Alerts do not have a title... The only way I have been able to get the script to deal with them is with the following code:
    if title of front window is "" then
        tell front window
            click button "OK"
        end tell
    end if
    I guess this is an ok solution... bit hard to identify windows when they don't have titles...
    BUT this is not my main problem. The main problem is that the script gets to one of these alert dialog boxes and just sits there... It sits there for like 10 seconds and then it performs the "click button "OK"" command.
    This is a problem as there are like 3 of these instances and it really adds up. Can anybody help me... I am using Acrobat Professional 8.2.0 and the entire code is:
    tell application "System Events"
        try
            tell process "Acrobat"
                -- Enable security settings
                click menu item "Properties..." of menu "File" of menu bar item "File" of menu bar 1
                tell window "Document Properties"
                    tell tab group 1
                        click radio button "Security"
                        tell group "Document Security"
                            click pop up button 1
                            click menu item 2 of menu 1 of pop up button 1
                        end tell
                    end tell
                end tell
                tell window "Password Security - Settings"
                    click pop up button 1
                    click menu item 4 of menu 1 of pop up button 1
                    tell group "Permissions"
                        click checkbox "Restrict editing and printing of the document. A password will be required in order to change these permission settings."
                        click text field 1
                        keystroke pdfPassword
                        click pop up button 1
                        click menu item 2 of menu 1 of pop up button 1
                        click pop up button 2
                        click menu item 4 of menu 1 of pop up button 2
                    end tell
                    click button "OK"
                end tell
                if title of front window is "" then
                    tell front window
                        click checkbox 1
                        click button "OK"
                    end tell
                end if
                tell window "Adobe Acrobat - Confirm Permissions Password"
                    click text field 1
                    keystroke pdfPassword
                    click button "OK"
                end tell
                if title of front window is "" then
                    tell front window
                        click checkbox 1
                        click button "OK"
                    end tell
                end if
                tell window "Document Properties"
                    click button "OK"
                end tell
    end tell
        on error
            display alert "System Events was unable to Enable Commenting. This may be because Acrobat has modified its menu system. Please contact your system administrator."
        end try
    end tell
    A delay does not work... its like as soon as I click the "OK" button it stalls for 10 seconds or does not know that is meant to continue... because I did this:
    tell window "Password Security - Settings"
        click button "OK"
    end tell
    beep
    In this situation it still takes like 10 seconds for the beep to occur after the click button "OK" command.

    Hey Guys, I have a script that I have written that automatically enables security settings on a PDF through Acrobat Professional. Because of Acrobats poor scriptability I am forced into doing much though System Events.
    This is not a major problem... however when activating some settings in the security settings, often warning Alert dialog boxes appear when you tell System Events to enable particular settings. These Alerts do not have a title... The only way I have been able to get the script to deal with them is with the following code:
    if title of front window is "" then
        tell front window
            click button "OK"
        end tell
    end if
    I guess this is an ok solution... bit hard to identify windows when they don't have titles...
    BUT this is not my main problem. The main problem is that the script gets to one of these alert dialog boxes and just sits there... It sits there for like 10 seconds and then it performs the "click button "OK"" command.
    This is a problem as there are like 3 of these instances and it really adds up. Can anybody help me... I am using Acrobat Professional 8.2.0 and the entire code is:
    tell application "System Events"
        try
            tell process "Acrobat"
                -- Enable security settings
                click menu item "Properties..." of menu "File" of menu bar item "File" of menu bar 1
                tell window "Document Properties"
                    tell tab group 1
                        click radio button "Security"
                        tell group "Document Security"
                            click pop up button 1
                            click menu item 2 of menu 1 of pop up button 1
                        end tell
                    end tell
                end tell
                tell window "Password Security - Settings"
                    click pop up button 1
                    click menu item 4 of menu 1 of pop up button 1
                    tell group "Permissions"
                        click checkbox "Restrict editing and printing of the document. A password will be required in order to change these permission settings."
                        click text field 1
                        keystroke pdfPassword
                        click pop up button 1
                        click menu item 2 of menu 1 of pop up button 1
                        click pop up button 2
                        click menu item 4 of menu 1 of pop up button 2
                    end tell
                    click button "OK"
                end tell
                if title of front window is "" then
                    tell front window
                        click checkbox 1
                        click button "OK"
                    end tell
                end if
                tell window "Adobe Acrobat - Confirm Permissions Password"
                    click text field 1
                    keystroke pdfPassword
                    click button "OK"
                end tell
                if title of front window is "" then
                    tell front window
                        click checkbox 1
                        click button "OK"
                    end tell
                end if
                tell window "Document Properties"
                    click button "OK"
                end tell
    end tell
        on error
            display alert "System Events was unable to Enable Commenting. This may be because Acrobat has modified its menu system. Please contact your system administrator."
        end try
    end tell
    A delay does not work... its like as soon as I click the "OK" button it stalls for 10 seconds or does not know that is meant to continue... because I did this:
    tell window "Password Security - Settings"
        click button "OK"
    end tell
    beep
    In this situation it still takes like 10 seconds for the beep to occur after the click button "OK" command.

Maybe you are looking for

  • How can I share music between users on one computer without duplicating it all?

    I have myself and my partner set up as separate users on my laptop. I have shared the music on iTunes so we can both access it, but this has meant that all my music is on the laptop twice and is consequently taking up all the memory. Please can someo

  • DVD Studio is Freezing on me...

    Hey everyone I've been having lots of trouble when I import my m2v file onto DVD Studio and it either freezes or it just doesn't show any image. I compressed it on compressor and that's another issue when I want to compress I get an exclamation point

  • Help with FDM / vb script

    Hi, We are using Hyperion 11.1.1.3 suite. We want to load data to data warehouse from FDM (using pull adapter). We wrote trial vb script for SQL server as below and its working : /* need help in converting the below script for Oracle server from SQL

  • Unable to Log out in Apple discussions

    When I try to log out in Apple Discussions, I get an error message saying cannot find page. I have to shut down Safari to logout. I haven't had any problems before. I did have to change my Apple ID to be able to use my new iPod Touch recently so woul

  • Recommendations for DDR400

    Now that I have my machine booting with PC2100, I want to find some memory modules that will run at the max memory speed of the board.  I looked over the MSI recommended modules.  I need to run 1GB of RAM.  What type do you guys recommend? I have onl