Interface confusion

Hi. I posted this topic yesterday, but somehow it didn't appear on the forum. So, here it is again...
I'm confused about some interface issues. If I understood correctlty, interfaces are classes whose methods have no implementation, so it's up on a user to implement them. So far I'm oK.
But, what confuses me is that Java API is filled with interfaces which seem to work on their own?!! I mean, I can make an object of some interface type, call it's methods, and it all works without me having to write any implemenation? How can this be? Hope somebody can axplain this.
Thanks in advance.

Or, slightly more directly (in case there's any confusion about the mysterious factory method)...
java.util.List is an interface.
java.util.ArrayList is a concrete class that implements the interface List.
List list = new ArrayList(); The key is that list is declared to be of type List, but you don't actually create a "raw" List object, since there is no such thing, because that's part of the definition of what an interface is.
Since list is a List, whatever is on the right hand side of that equals must also be a List. But wait, it's an ArrayList, not a List--how can that work? Well, actually, it's an ArrayList and a List.
ArrayList "is-a" List, AbsractList, Serializable, Object, and a few other classes and interfaces.
An instance of a given class "is-a" all of the following...
* its parent class
* every class between its parent class and Object
* Object
* every interface that class itself directly impelments
* every interface that those interfaces extend, recursively up to the root interface(s)
* every interface that all its ancestor classes implement, by this rule recursively, and by the above 2 rules.
If an A "is-a" B, then anyplace where a B is required (e.g. the RHS of an equals, or to pass as a param to a method), you can put an A in. The consequences of this form large part of the foundation of OO. You can declare List, and not need to know any details of how that List is implemented, as long is it does everything a List promises to do (add, remove, contains, iterator...). Any concrete class that meets the contract laid out by the List interface will work. You can try one implementation, and if, say, it doesn't perform well, switch to a different one. The only bit of code you need to change is the one that actually creates that List object. You can call the same method from different parts of the code, passing in a LinkedList in one call and and ArrayList in another. Same exact code interacting with those various List implementations.
For more info...
http://java.sun.com/docs/books/tutorial/
http://java.sun.com/learning/new2java/index.html
http://javaalmanac.com
http://www.jguru.com
http://www.javaranch.com
http://www.javadude.com
Bruce Eckel's Thinking in Java
Joshua Bloch's Effective Java

Similar Messages

  • Publishing iWeb by Mobile Me

    Hi Dear's ,
    I have trouble to publishing my iWeb by MobileMe, i got free domain from Dot Tk then i configuration CNAME between my host name and web.me.com by. after finally, i open new browser link to my hostname (www.zems.tk) then do you know what? the result page is forwarding to apple.com/mobileme interface.
    confused
    SO, HOW TO CONFIGURATION iWeb to publishing by mobileme exactly?

    All you need to do to publish to your MMe account is:
    1 - log into MobileMe via the System/MobileMe Preference pane.
    2 - set iWeb to use MobileMe as the publishing destination by clicking on the site's icon in the left hand pane of iWeb and select MMe from the drop down menu (upper right hand image in screenshot):
    Click to view full size
    After publishing you can check to see it went as expected by entering the following URL in your browser: http://web.me.com/MobileMeAccount_Name/SiteName
    OT

  • Longtime bug: Table cell strokes disappearing

    I was hoping this would be fixed in CS5, but apparently not.
    I want a very simple table with just horizontal rules above each line. I want to set this as a cell style, so I can apply and unapply for maximum flexibility.
    So this is what I want:
    row 1, col 1     row 1, col 2   row 1, col 3
    row 2, col 1     row 2, col 2   row 2, col 3
    row 3, col 1     row 3, col 2   row 3, col 3
    Here's what I do:
    - I create a new table.
    - I remove the ugly borders that are applied by default, and I save that as a new table style (because, apparently, I'm unable to overwrite the default style).
    - I select the cells from the top row (or all rows or just one) and apply a top border of, say, 1 point. I save that as a cell style called "ruled."
    - Problem is, when I try to apply this to a specific cell or row, the cell underneath loses its stroke. So if I apply the "ruled" style to row 2, col 2, the table looks like this:
    row 1, col 1     row 1, col 2   row 1, col 3
    row 2, col 1     row 2, col 2   row 2, col 3
    row 3, col 1     row 3, col 2   row 3, col 3
    When I check the cell style of row 3/col 2, the Cell Styles palette claims that it's the "ruled" style with no custom formatting. But the border says 0. When I double-check the cell style options, sure enough, it's supposed to be 1 point. So if I apply the style, it gets applied -- but, then, the cell beneath *that* one (if there is one) loses its stroke!
    So every time I have to make a change, I have to apply the strokes all the way down the table.
    Of course, this completely negates the advantage of having a style. If I have to manually apply and re-apply formatting for every cell, there is no point to having a style.
    If I am doing this wrong, I'd love to know a solution. I've grappled with this for years, and I've always ended up abandoning styles, which should be one of the most powerful features.
    As a corollary, I've occasionally tried alternating row strokes (using every line) for the table style, from which I've had mixed results. This would work in some cases, but I also sometimes want tables with only some columns ruled, like so:
    row 1, col 1     row 1, col 2   row 1, col 3
    row 2, col 1     row 2, col 2   row 2, col 3
    row 3, col 1     row 3, col 2   row 3, col 3
    I suppose I could override the cells in the non-ruled column with cell styles without rules, given that the cell styles function seems awfully good at making strokes disappear ...
    Thanks for any help!

    Yes, yes, yes! Thank you!
    So I need to select top AND middle when applying the stroke, then redefine style if necessary. I guess, due to interface confusion, I was ignoring the middle stroke, thinking it was only for full table-level styling.
    In the style options dialog for the Cell Styles, you don't even see a middle stroke. You only get middle strokes if you select the cell and use the stroke palette for local formatting.

  • ICloud will not accept my mobileMe address

    Having moved from MobileMe, I have sorted out Contacts and Addresses (with some heartache)
    I now try to set up iCloud mail. So I go to Preferences>iCloud and check the Mail button.
    I am asked for an e-mail name. So - of course - I put in my MobileMe address.
    But it says that is already in use....
    So I go back to MobileMe to try to delete my address from there.
    But it says that the address has been moved to iCloud.....
    Totally mystified
    If I choose a new (unchangeable) iCloud address - which I DO NOT WANT TO DO - what happens to all the mail sent to my old @me address if I want to see it one the iCloud web interface
    Confused.....

    Winstone
    Thanks
    Yes - I had my old email address in Mac Mail
    So I have moved ALL my mail into On-my-Mac for safekeeping
    Then I deleted that account from Mac Mail
    I then tried - once more - with Preferences>iCloud to get my MobileMe address onto iCloud
    and got the following....
    So that does not help
    Back to Mac Mail and re-install my old account and it looks like this
    So its an iCloud account .... ? and [email protected] is my old mobile.me address
    So why can I not access it from my iPad, which now wants me to "Create a free @me.com email address to turn on iCloud Mail". If I do that, how do I get my old @me address working on the iPad.
    Really Apple has not excelled itself with this migration...
    Completely confused.....

  • Find my ipad not showing up on iCloud

    Find My iPad is not showing up on iCloud, nor is Find My Mac.  Find my iPhone is working beautifully.  I have checked all the settings on each device, and that all are with the same AppleID.  I did originally have the iPhone and the iPad with different IDs.
    I'd appreciate any advice how to get this fixed.  Not the only problem I have with iCloud, but this would be a start.
    Cheers

    I, too was confused about this. I signed into my iCloud account, and I see the icon for "Find my iPhone", but no icon for "Find my iPad".  Apparently, when I go into "Find my iPhone", there is a sub-area where it lists my devices - it defaults to "All Devices" at the top is designated, but then, I can click on the "Devices" Radio button located at the top left corner, and it will list my iPhone and my iPad separately.  I can then click on my iPad there. See if this doesn't resolve your problem. Apple made this interface confusing by allowing one icon in iCloud to represent all your devices, whether an iPad, iPod, or iPhone. Hope this helps!

  • Confused regarding  interface mapping in BPM scenarion

    hi
    my scenario goes like this:
    have 2 sources sendign files to target.
    Am using BPM to merge the input files into a single target file.
    am confused as to which interfaces to use in interface mapping.
    (have 3 abstract ,and 2 outbound and 1 inbound interfaces).
    am already using 2 abstract interfaces as input and 1 abstract target interface in o/p for nterface mapping.
    However ,while running the configuratin wizard,no interface mapping appears.
    please help me ASAP.

    Hi...
      Whenever you use transformation in BPM process where you will mention interface mapping there itself, so you cant see the it in interface determination. Your scenario is configured correctly.
    Regards
    Leela

  • What is the point of interfaces??? Confused!!!!

    I have obviously missed something big out because I know that interfaces are very important but I don't get the point of them.
    I underdstand an interface as a class which declared methods but does not implement them i.e.: public void hello(int num);.
    Then you implement it in a class and you implement the hello method. Why don't you just implement the hello method in the class, why would you want to create an interface and then implement it.
    I have obviously missed something here so could someone give me an example and quickly show me how to use an interface and explain why I would want to use one.
    Manny thanks,

    I'm brand new to Java myself, and haven't yet written anything worthwhile, so take what I say with a grain of salt. BUT... my understanding of interfaces is as follows:
    An interface allows you define a "way" in which something should be done without specifying "how" that thing should be done. Say you have a computer, and you want to write some software that controls how the cursor is moved around on the screen. So, you could write your software so that it watches for activity coming from the mouse, and then moves the cursor according to how the mouse was moved. Great, right? Not quite.
    What happens when someone comes along and wants to install your software on a laptop, which uses a touchpad instead of a mouse? Well, unfortunately, you wrote your software so that it watched for mouse activity, and not touchpad activity, so the cursor doesn't respond correctly. (Yes this is a theoretical example, I understand that this sort of thing is really abstracted away by the operating system, but let's just pretend that we're writing operating system-level software.)
    Now you can dig deep into your code and change it so that it works for both mice and touchpads, but this requires you to carefully check all the surrounding layers of code to make sure that you didn't screw anything else up. And then what happens if you find that someone has invented a light-pen that lets a stylus be used on the screen to move the mouse? You have to go through it all again!
    If instead you had defined an interface to define how input devices should move the cursor, you might have an easier time of it. You can write a new class that handles touchpad or light-pen input and moves the cursor appropriately, and as long as it implements the interface that you wrote, your code can still take advantage of polymorphism -- because the way in which the input devices are manipulated was "officially" defined by the interface ahead of time. You still have to write the code to handle the touchpad or light-pen, but it plugs into your code more easily.
    Now the question of when to use an interface and when to use an abstract class... I'm not totally clear on that yet. It seems that an interface is more general, whereas an abstract class is when you know that you're going to be writing a class that descends ("is a") from another class....
    HTH
    Erik

  • Interface/Impl confusion

    I was just restructuring some of my code and I decided to extract interfaces out of some concrete
    classes. I'm not really expecting to have multiple impls for them, but I did it to reinforce thinking in interfaces and to have a good view over the class without having to look at implemntation details.
    Here's a Channel-interface I extracted (an abstraction to IRC-channel):
    public interface Channel {
         public void addChannelListener(ChannelListener listener);
         public void removeChannelListener(ChannelListener listener);
         public void send(String message);
         public void rejoin();
         public void leave();
         public void say(String text);
         public void ban(String nickOrAddress);
         public void unban(String nickOrAddress);
         public void kick(String nick);
         public void kick(String nick, String reason);
         public void invite(String nick);
         public void setInviteOnly(boolean enabled);
         public void setTopic(String topic);
         public Server getServer();
         public String getName();
         public String getKey();
         public String getTopic();
         public int getUserCount();
         public User[] getUsers();
         public boolean isConnected();
         public boolean containsNick(String nick);
    }Note that this is still an incomplete implementation and there'll be some more of these methods.
    Now, earlier I had a concrete Channel-class and it also had methods like this:
    public final void topicChanged(Message msg) {...}
    public final void messageReceived(Message msg) {...}
    public final void modeChanged(Message msg) {...}
    public final void nickChanged(Message msg) {...}
    public final void userJoined(Message msg) {...}I decided to leave them out of the public interface as they don't really belong there,
    since they are called only by the Server-class. The Server-class contains a list of Channel-objects.
    It is also the only class that creates new Channel-objects.
    So, only the Server-class calls the above methods of it's Channel-objects, when the server receives new messages (and determines they're channel-messages).
    I also extracted an interface for the Server, and the ServerImpl now casts the Channel-interfaces to ChannelImpls in some places, to be able to call the above leftover methods.
    Is this a bad idea? Does this break the 'Liskov substitution principle'? Do you have any better ideas? Maybe the Channel-class should do 'more work' itself?
    I personally don't feel it's that bad but i still get kind of dirty feeling of doing it this way.

    So th eChannel interface is the public interface for all others present
    in the system but your server needs a bit more functionality. Why not
    define another interface:interface ServerChannel extends Channel {
       // server specific methods here
    }and your ChannelImpl class:public class ChannelImpl implements ServerChannel { ... }Now the server treats these ChannelImpl objects as ServerChannels,
    while the rest of the world simply treats these objects as Channels.
    btw, you can build a Factory that builds the appropriate objects for the
    appropriate callers, e.g. a package scoped method for the server
    (which needs to be in the same package) and a public method for the
    rest of the world. The first object would return ServerChannels while
    the second method (the public one) would return Channels:[code
    public class ChannelFactory {
    ServerChannel makeServerChannel() { ... }
    public Channel makeChannel() { return makeServerChannel(); }
    kind regards,
    Jos

  • Confusion with interfaces

    Hi ,
    What is the advantage over using interface. I mean , suppose
    public interface Calculator
    int add();
    int sub();
    int div();
    int mul();
    Now
    public class Calculation implements Calculator
    // will implement all method of Calculator interface
    The same thing i can achieve with abstract class.

    Prem wrote:
    What is the advantage over using interface. I mean , suppose Well a Google of "advantages of using interfaces" threw up [url http://artofsoftwarereuse.com/2010/04/24/5-advantages-of-using-interfaces-for-reusable-assets/]this page, which gives 5 pretty good ones.
    ...The same thing i can achieve with abstract class.Yes, but an abstract class imposes a hierarchy that may not be desirable (hopefully, you've already been warned about overusing inheritance); it also (usually) imposes an implementation which may not be suitable for everyone.
    PS: Didn't you already ask this question?
    I believe I suggested you look at AbstractList as an example of a good pattern for an abstract class (ie, as a skeleton implementation of an interface).
    Winston

  • Interfaces...slightly confused =S

    Hey all
    Basically Iv got a board game that mostly uses just ordinary classes but now im trying to introduce interfaces so that testing can be done easily...However I'm not sure how to go about naming these or even how to set them up properly. For example:
    Currently I have a CardStack class and this is used for objects whenever there is a need for a representation of a bunch of card....if I was to introduce an interface one options would be like so:
    - Have a CardStack interface
    - Have a AvailableCards implement CardStack
    - Have a DiscardedCards implement CardStack
    - Have a PlayerCards implement CardStack
    But now those three implementation use a lot of duplicated code since they have almost the same methods (pop, push, add, remove, get, etc.) so it seems pointless to have this CardStack interface =S might have as well used inheritance instead of an interface no? Or even just stick to how I had it before...I guess another way would be to have a Stack interface and a CardStack implement this Stack interface? But now what will I have as the return types/parameter types that the interface's methods use? They can use
    Card for example but then if I want to implement a PigStack rather than a CardStack I'm doomed.
    So yeh im not too sure on how to go about incorporating interfaces like this...any help?
    Also sorry for the long post!

    kman91 wrote:
    hmm...but I don't see how having getters will make it any better? I mean now your just passing the reference to the private field, essentially giving it full access (just cant overwrite it) now.First of all, you need not provide a setter. For example, it's easily possible that only the Board itself needs to set the variable. In that case you can provide a getter but no setter.
    Also, you can do stuff other than just returning the variable in the getter: you can log access, count access, deny access (by throwing an exception) or returning a wrapper object.
    The thing is there will be alot of methods (and apparently thats a design smell)"Design smell" does not necessarily mean that it's a bad thing, it just means that it's something to investigate (as you're doing it right now!)
    since each card has an action that can be activated that can do a whole variety of things.Really? If each card has an action, then i'd expect a single invokeAction() method on the Card class with multiple different implementatons. How do you have multiple methods on a single class because of this?

  • Confusing Interface Icon

    Greetings:
    I hope someone can help with this question. I just noticed that almost every song in my ITunes library (5300+) has the small grey circle with the white arrow in the Name, Artist, and Album columns. I've never really noticed this icon before so I don't know how long it's been there or even if it should be there.
    When I click on it, the computer attempts to connect to the Apple Music Store. Before I go any further I need to point out that I have never bought anything from the Music Store. I don't even have an account with them.
    But after hacking around the preferences for awhile, I noticed that if I click "Disable Music Store" in the Parental Preferences, the circles go away. As I said, none of these songs were purchased through Apple. They are all from my own personal CD collection. The only songs that don't display the circle are some of the songs recorded by my band. But even this isn't consistent. Some of band's songs have the circle, others don't. Some only have the icon in the artist column
    So I'm confused. Why does this circle appear with the majority of songs? Why does it try to connect to the Music Store. Why does it go away when I turn off access to the Music Store?
    I also noticed that in the Advanced Preferences, Deauthorize this Computer is lit up. I was going to click on it, but then started thinking there might be some bizarre reason the library thinks everything is from Apple, and if I deauthorized the computer I might not have access to my own songs.
    Is this a bug? Or is it something I should just ignore? Or is this just a way Apple encourages you to visist the store? Hopefully this is just something simple I've overlooked. Maybe this should be posted in the Music Store Boards, but since I don't have an account with them, I thought I would start here.
    Thanks in advance for any help or suggestions...

    There is another use for those arrows. If you option-click on the arrow beside and artist or album name, you will end up with a listing of just that artist or album. There is a script or program around to reverse the order of the actions, so that you would click on the arrows to get the arist or album list.
    You do not need a iTunes account to browse the music store and the arrows that take you to the store acts like a sales brochure - "Here's what we got".
    Do you have a playlist named "Purchased" or any tracks listed as "Protected AAC" in the Kind column? If so, then you have some music from the music store and you shouldn't de-authorize your computer.

  • I am confused with Interface

    my example is
    public interface IName
    public interface IAdress
    public interface IPhoneBook
    public class PhoneBook implement IPhoneBook
    my question is
    IPhoneBook associate with IName interface at the one time. (public interface IPhoneBook extends IName) ex.
    But IPhoneBook must be have one more with IAdrress (like. BillingAddress, ContactAddres).
    How code IPhoneBook
    and How PhoneBook create java code...

    if you have a good solution my PhoneBook class can
    you send to me class and Interface codes.You don't have to start using interfaces from day
    one. Why don't you just define a plain PhoneBook
    class holding information about name, address and
    phone number?because hibernate need Interface for caching..What's hibernate? And why does it need exactly a interfaces? And why especially for cashing? What cashing?
    Are these interfaces predefined? In that case you only have to implement them. Is your question actually how one implements an interface?

  • What is the diff b/w Abstract class and an interface ?

    Hey
    I am always confused as with this issue : diff b/w Abstract class and an interface ?
    Which is more powerful in what situation.
    Regards
    Vinay

    Hi, Don't worry I am teach you
    Abstract class and Interface
    An abstract class can have instance methods that implement a default behavior. An Interface can only declare constants and instance methods, but cannot implement default behavior and all methods are implicitly abstract. An interface has all public members and no implementation. An abstract class is a class which may have the usual flavors of class members (private, protected, etc.), but has some abstract methods.
    Edited by SASIKUMARA
    SIT INNOVATIONS- Chennai
    Message was edited by:
    sasikumara
    Message was edited by:
    sasikumara

  • OSPF with ipsec VTI interface goes down before dead timer.

    I have a strange issue that OSPF will initially start working, hellos are exchanged both ways but then after about 3 – 6 hellos one of the sides stops getting them and the ipsec VTI tunnel drops on router A even before the dead timer reaches 0. Is this default behavior, when OSPF is over a VTI interface if it doesn’t receive hellos is drops the tunnel?
    I’m at a loss as to what is going on since it looks like only one neighbor stops receiving hellos, router A, for a brief period of time. This VTI tunnel is going over another provider’s FW and they have assured me the tunnel destination/source ips are wide open they also sent me the ACL and I can verify this. The weird thing is if I enable EIGRP it works great with no issues. On router B I am using the same source/ip unnumbered  interface on multiple VTI tunnels to to other destinations but this shouldn’t cause any issues I don’t think. I have never had an issue like this and from what I can tell the router A just stops briefly getting hellos after 3 – 6 initial hellos and drops the protocol on the VTI interface. If I set the dead timer on router A long enough it will stop receiving hellos but stay up and then after a while you get “LOADING to FULL” as the hellos start coming in again.  Again the tunnel goes over a cisco 800 which I have no control over it and a potential FW before that but I saw the ACL and ip is being allowed. I was thinking this could be a trolling issue on the FW but it doesn’t explain why EIGRP works.  FYI I was having a recursive routing issue before but I have since fixed that and the issue still continues.
    ********  it turns out that i was using the same source ip on multiple tunnels. IPsec would get confused with packets coming in and would deliver packets to the wrong tunnel interface. This was solved but using the key command with a different key number on each set of tunnels with the shared profile command
    "If more than one mGRE tunnel is configured on a router that use the same tunnel source address, the shared keyword must be added to the tunnel protection command on all such tunnel interfaces. Each mGRE tunnel interface still requires a unique tunnel key, NHRP network-ID, and IP subnet address. This is common on a branch router when a dual DMVPN cloud topology is deployed. "
    Router A:
    router ospf 1
    router-id 10.213.22.2
    passive-interface default
    network x.x.97.26 0.0.0.0 area 0
    interface Tunnel1
    ip unnumbered GigabitEthernet0/1
    ip virtual-reassembly in
    ip tcp adjust-mss 1398
    ip ospf network point-to-point
    load-interval 30
    tunnel source GigabitEthernet0/1
    tunnel mode ipsec ipv4
    tunnel destination x.x.173.109
    tunnel path-mtu-discovery
    tunnel protection ipsec profile VTI-to-NB
    router B:
    router ospf 1
    router-id 172.17.2.6
    priority 1
    redistribute static subnets route-map Lan-static-RM
    passive-interface default
    no passive-interface Tunnel1
    no passive-interface Tunnel4
    no passive-interface Tunnel5
    network x.x.173.109 0.0.0.0 area 0
    network 172.17.2.6 0.0.0.0 area 0
    network 192.168.1.47 0.0.0.0 area 0
    interface Tunnel4
    ip unnumbered GigabitEthernet0/2
    ip virtual-reassembly in
    ip tcp adjust-mss 1398
    ip ospf network point-to-point
    load-interval 30
    tunnel source GigabitEthernet0/2
    tunnel mode ipsec ipv4
    tunnel destination x.x.97.26
    tunnel path-mtu-discovery
    tunnel protection ipsec profile VTI_NB_to_dorrance_prv
    end
    thanks P

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    I haven't studied your config, but I can tell you I have production environment using OSPF across VTI  (and GRE, and GRE/IPSec and DMVPN) tunnels without issue.  I.e. so OSPF can be okay with VTI tunnels.

  • Problem with FWSM and L3 interface in same switch

    I have two 6513s with an 802.1q trunk connecting them. Each switch has redundant Sup720s running in Native mode, IOS ver 12.2(18)SXF (they were initially running SXD3). A FWSM (ver 2.3(3), routed mode, single context) is in each switch, setup in failover mode.
    I can not get a PC, in a vlan that has the layer 3 interface defined on the switch with the active FWSM in it, to communicate with devices "behind" the FWSM. If I move the layer 3 configuration for that vlan to the other 6513, everything works fine.
    The MSFCs are on the inside of the firewall, they have a layer 3 interface configured in the same vlan as the FWSM "inside" interface. Several "same security level" interfaces are defined on the FWSM and used to protect server farms. I am using OSPF on the MSFCs and FWSM and the routing table is correct.
    The FWSM builds connections for attempts made by the PC with the layer 3 interface defined on the same switch as the active FWSM just fine, so this is not a FWSM ACL problem.
    A ping of the FWSM "inside" interface from a PC with the layer 3 interface defined on the same switch as the active FWSM fails, even though debug icmp trace on the FWSM shows the request and the response. A packet capture, using the NAM-2, shows only the request packets. I have captured on the common vlan and the FWSM backplane port channel interface.
    Just to add to the confusion, if I capture in the same places, but do the ping from a PC that is in a vlan with the layer 3 interface defined in the 6513 that does not contain the active FWSM, which works fine, I see the request and reply on the common vlan capture, but only the request on the port channel capture.
    This problem has been there from the beginning of this implementation and has not changed with IOS and FWSM software upgrades. I have experienced this with any and all vlans that I tried to define the layer 3 interface for on the switch with the active FWSM. I have MLS turned on.
    If anyone else has experienced this and solved it, or knows what is going on, I would appreciate any insight.
    Thanks.
    Keith

    I will have to get setup to record more data, but I do know the FWSM showed a ping request and a ping reply at the "inside" interface.
    I believe my problem is related to the IOS command "firewall multiple-vlan-interfaces" which I put in place to allow IPX traffic to be brought around the FWSM. The little documentation that there is for this command, states that policy routing may need to be implemented to prevent ip packets from going around the firewall. I do not have any policy routing in place.
    I also do not have any active layer three interfaces defined for any of the vlans assigned to the firewall except the "inside" interface. So my resoning was that I did not need to be concerned about ip packets having a way around the FWSM. My suspicion is that this command and the fact that I have mls on is causing some type of a problem which results in the packet being "lost" when it needs to be going through the MSFC in the switch with the active FWSM to get to the PC. Hopefully that makes some sense.
    Do you have any idea where better documention on using the "firewall multiple-vlan-interfaces" may be, or a better explanation of all that is happening inside the switch when that command is used?
    Thanks.

Maybe you are looking for

  • Fresh Windows 7 install on Satellite C75D-B7200

    Hey Toshiba Forums,  My laptop, the C75D-B7200 recently had some HDD hardware problems so I got a new one and decided to put windows 7 64 bit on it.  After the installation process was finished and I logged in, I couldn't connect to the internet.  Th

  • Fields in iView Item Details -create mode- are disabled

    Hello, we are using SAP MDM Standard iViews (Item Details) to create new data records. In some iViews on specific tables - I coudn't find any logic - the fields are grey and disabled instead of white and ready for data entry after pressing button "cr

  • About the Zen Touch power adapte

    I bought a Zen Touch off Ebay and realized after I bought it, that it didn't come with a power adapter! It does come with a USB cable and they said you can charge it via computer. My question is: Is there any power adapter that can fit the zen touch?

  • Maintain an Adobe Muse site for a client once Muse subscription expires?

    Hi there, I'd really appreciate some advice here. I have created a site in adobe muse for a client that is shortly to be pushed live. I also have a subscription to Adobe Muse (monthly), which  will need to terminate shortly. How can I ensure that the

  • Iphoto does not read cd's photo

    I have many cd and dvd with photos and i can't open to see my photos