Interface FTP - XI - FTP

Hi,
I need to make a interface that take a file via FTP , with this data call a BAPI to update a SAP table and send the same file to other FTP.
The problem is that in when an error appears in the ftp receiver (ex. connection error or login error) this file must be sent to other FTP. It's possible do it, any idea?
thanks in advance
Jose

Hi Kulwant,
Yes the this is the scenario.
I get a file to send to other system, if the adapter fails I have to send the file to other system using FTP.
FTP sender -
> XI -
> FTP receiver (if sent ok the interface finish)
Error case:
FTP Sender -
> XI -
> FTP receiver (Error login in FTP)
> FTP receiver (Sent to other system)
Regards,
Jose

Similar Messages

  • Can not connect to Cerberus FTP Server with PASV

    I setup a FTP Server and i can connect from the inside fine but from the outside i can not connect in passive mode. I can in regular ftp or ssh.
    Here is the log from filezilla
    Status:          Resolving address of domain.com
    Status:          Connecting to ExternalIP:990...
    Status:          Connection established, initializing TLS...
    Status:          Verifying certificate...
    Status:          TLS/SSL connection established, waiting for welcome message...
    Response:          220-220-Welcome to Cerberus FTP Server
    Response:          220 220 Created by Cerberus, LLC
    Command:          USER test
    Response:          331 User test, password please
    Command:          PASS ***********
    Response:          230 Password Ok, User logged in
    Command:          CLNT FileZilla
    Response:          200 Command okay
    Command:          OPTS UTF8 ON
    Response:          220 UTF8 support on
    Command:          PBSZ 0
    Response:          200 PBSZ=0
    Command:          PROT P
    Response:          200 PROT P OK, data channel will be secured
    Status:          Connected
    Status:          Retrieving directory listing...
    Command:          PWD
    Response:          257 "/" is the current directory
    Command:          TYPE I
    Response:          200 Type Binary
    Command:          PASV
    Response:          227 Entering Passive Mode (external IP,195,83)
    Command:          MLSD
    Error:          Connection timed out
    Error:          Failed to retrieve directory listing
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.0(4)
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.10.10 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group att
    ip address pppoe setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service FTP_PASV_Ports tcp
    description Passive Ports
    port-object range 35000 35999
    object-group service FTPS tcp
    description FTPS
    port-object eq 990
    access-list outside_access_in extended permit tcp any any object-group RDP
    access-list outside_access_in extended permit icmp any any
    access-list outside_access_in extended permit tcp any any eq ftp
    access-list outside_access_in extended permit tcp any any eq telnet
    access-list outside_access_in extended permit tcp any any eq smtp
    access-list outside_access_in extended permit tcp any any eq www
    access-list outside_access_in extended permit tcp any any eq pop3
    access-list outside_access_in extended permit tcp any any eq https
    access-list outside_access_in remark passive FTP port range
    access-list outside_access_in extended permit tcp any host server object-group FTP_PASV_Ports
    access-list outside_access_in extended permit tcp any any eq ssh
    access-list outside_access_in extended permit tcp any any object-group FTPS
    access-list outside_access_in extended permit tcp any any eq ftp-data
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1492
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www server www netmask 255.255.255.255
    static (inside,outside) tcp interface https server https netmask 255.255.255.255
    static (inside,outside) tcp interface smtp server smtp netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 server 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface pop3 server pop3 netmask 255.255.255.255
    static (inside,outside) tcp interface ftp server ftp netmask 255.255.255.255
    static (inside,outside) tcp interface ssh server ssh netmask 255.255.255.255
    static (inside,outside) tcp interface 990 server 990 netmask 255.255.255.255
    static (inside,outside) tcp interface ftp-data server ftp-data netmask 255.255.255.255
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.10.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 5
    ssh 192.168.10.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    vpdn group att request dialout pppoe
    vpdn group att localname @static.sbcglobal.net
    vpdn group att ppp authentication pap
    vpdn username @static.sbcglobal.net password *********
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username admin password rcuFiQnIXLd encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:ecb5356a2f5e680b
    : end
    I am programing the router with ASDM so if you could tell me what i need to do from the GUI to fix this.

    Dan,
    Looking at the output,
    Status:          Resolving address of domain.com
    Status:          Connecting to ExternalIP:990...
    Status:          Connection established, initializing TLS...
    Status:          Verifying certificate...
    Status:          TLS/SSL connection established, waiting for welcome message...
    This looks like FTPS which is not supported on the ASA. You can workaround it by trying to connect using Active mode from the outside instead of PSV.
    You can find more info here:
    https://supportforums.cisco.com/docs/DOC-23206
    Mike

  • Production Issue with Receiver FTP Adapter

    Hi all,
    We have so many interfaces with ECC To FTP via XI, working fine.
    We had problem with one particular Interface, FTP Owner is saying that we did not received any files since last night for this interface. But that receiver channel's log is saying clearly that file has been written to folder with given name.
    Nearly 140 files needs to be received at FTP site. Suddenly they told that received all 140 files at a time with time all with stamp 11:40am
    What might be the cause for this?? has any one faced this kind of issues??
    Please share your thoughts
    Regards
    Suman

    Hi rajesh,
    Thnx for replying, there is no receiver channel on scheduled
    Receiver communication channel time stamp is showing as same as time ecc generated with idoc.
    But received at FTP is different time( more time difference)
    Checked with FTP Admin, and there is no issues or downtime with FTP at that time.
    >>use messaging system and search with message id for knowing this step time stamp.
    How to check this, please let me know the link.
    Regards

  • FTP Port ERROR Forwarding in Cisco ASA 8.2(5), Very Intersting.

    Hi,
    I  have the following configuration on a Cisco ASA 8.2(5), all the traffic  to the port 5000 go to an IP Camera and www 80 it's forward throught static NAT to a Web Server without problem,  I have the same Configuration for a FTP SERVER Windows and FTP Server Linux and doesn't make the foward to an internal IP address.  Attach is  the configuration I would like to know what is causing the problems.
    The  FTP Server Are running locally without any problems, when I try to  reach it for the Outside interface then i  can't, this is in the only  port i can't forward.
    I really appreciate your help.
    Thanks
    ASA Version 8.2(5)
    hostname ciscoasa
    enable password dAWCvYvyr2FRISo5 encrypted
    passwd dAWCvYvyr2FRISo5 encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.2 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 8.8.4.4
    name-server 8.8.8.8
    name-server 196.3.81.132
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group service TEST2 tcp
    port-object eq www
    port-object eq https
    access-list 101 extended permit ip 192.168.1.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list 101 extended permit icmp any interface outside echo-reply
    access-list 101 extended permit udp any any eq 5000
    access-list 101 extended permit udp any any eq ntp
    access-list 101 extended permit udp any 192.168.1.0 255.255.255.0 eq tftp
    access-list 102 extended permit icmp any interface outside echo-reply
    access-list 102 extended permit icmp any interface outside
    access-list 102 extended permit ip any host 192.168.1.5
    access-list 102 extended permit tcp any host 192.168.1.5 eq 5000
    access-list 102 extended permit tcp any interface outside eq 5000
    access-list 102 extended permit tcp any host 192.168.1.5 eq https
    access-list 102 extended permit tcp any any eq 5000
    access-list 102 extended permit ip any host 192.168.1.8
    access-list 102 extended permit tcp any any eq telnet
    access-list 102 extended permit tcp any interface outside object-group TEST2
    access-list 102 extended permit ip any 192.168.1.0 255.255.255.0
    access-list 102 extended permit tcp any interface outside eq www
    access-list 102 extended permit tcp any interface outside eq ftp
    access-list 102 extended permit tcp any interface outside eq ftp-data
    access-list 102 extended permit tcp any any eq ftp
    access-list 103 extended permit udp any 192.168.1.0 255.255.255.0 eq tftp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 192.168.1.0 255.255.255.0
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface 5000 192.168.1.5 5000 netmask 255.255.255.255
    static (inside,outside) tcp interface www 192.168.1.15 www netmask 255.255.255.255
    static (inside,outside) tcp interface ftp 192.168.1.15 ftp netmask 255.255.255.255
    static (inside,outside) tcp interface ftp-data 192.168.1.15 ftp-data netmask 255.255.255.255
    access-group 102 in interface outside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 192.168.1.0 225.255.255.0 inside
    telnet timeout 30
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 30
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.1.10-192.168.1.41 inside
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    username cabelen password tJPt4MkXkeex6ITZ encrypted
    class-map ftp-class
    match access-list 102
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect ftp
      inspect dns preset_dns_map
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect pptp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:3465bc9d04198e9df80787c0c039db27
    : end
    ciscoasa#

    This is the results of the log it didn't not find the public ip address which im making FTP connection.
    ciscoasa#  sh logg | i 147.197.115.171
    ciscoasa#  sh logg
    Syslog logging: enabled
        Facility: 20
        Timestamp logging: disabled
        Standby logging: disabled
        Debug-trace logging: disabled
        Console logging: disabled
        Monitor logging: disabled
        Buffer logging: level debugging, 88 messages logged
        Trap logging: disabled
        History logging: disabled
        Device ID: disabled
        Mail logging: disabled
        ASDM logging: level informational, 68 messages logged
    connection 125407 for outside:111.221.74.28/443 to inside:192.168.1.24/24483 duration 0:02:01 bytes
    44
    %ASA-7-609002: Teardown local-host outside:111.221.74.28 duration 0:02:01
    %ASA-7-710005: UDP request discarded from 192.168.1.24/138 to inside:192.168.1.255/138
    %ASA-6-302016: Teardown UDP connection 125402 for outside:177.0.186.239/57036 to inside:192.168.1.24
    /24483 duration 0:02:02 bytes 220
    %ASA-7-609002: Teardown local-host outside:177.0.186.239 duration 0:02:02
    %ASA-6-302016: Teardown UDP connection 125408 for outside:89.240.135.18/47096 to inside:192.168.1.24
    /24483 duration 0:02:01 bytes 44
    %ASA-7-609002: Teardown local-host outside:89.240.135.18 duration 0:02:01
    %ASA-6-302016: Teardown UDP connection 125409 for outside:111.221.77.145/40037 to inside:192.168.1.2
    4/24483 duration 0:02:01 bytes 486
    %ASA-7-609002: Teardown local-host outside:111.221.77.145 duration 0:02:01
    %ASA-6-302016: Teardown UDP connection 125410 for outside:64.4.23.148/40014 to inside:192.168.1.24/2
    4483 duration 0:02:01 bytes 178
    %ASA-7-609002: Teardown local-host outside:64.4.23.148 duration 0:02:01
    %ASA-6-305012: Teardown dynamic UDP translation from inside:192.168.1.24/24483 to outside:69.86.151.
    109/54119 duration 0:03:00
    %ide:216.146.39.70/80 to inside:192.168.1.5/3628 duration 0:00:00 bytes 303 TCP FINs
    %ASA-7-609002: Teardown local-host outside:216.146.39.70 duration 0:00:00
    nable_15' executed the 'configure terminal' command.
    %ASA-6-302015: Built inbound UDP connection 125412 for inside:192.168.1.20/68 (192.168.1.20/68) to i
    dentity:192.168.1.2/67 (192.168.1.2/67)
    %ASA-6-604103: DHCP daemon interface inside:  address granted 0128.987b.d28e.e7 (192.168.1.20)
    %ASA-6-302016: Teardown UDP connection 125411 for inside:192.168.1.27/68 to identity:192.168.1.2/67
    duration 0:02:01 bytes 623
    %ASA-5-111008: User 'enable_15' executed the 'no access-list 102 extended permit ip any 192.168.1.0
    255.255.255.0' command.
    %ASA-6-302010: 20 in use, 234 most used
    %ASA-5-111008: User 'enable_15' executed the 'no access-list 102 extended permit ip any host 192.168
    .1.8' command.
    %ASA-5-111005: 192.168.1.24 end configuration: OK
    %ASA-6-302016: Teardown UDP connection 125412 for inside:192.168.1.20/68 to identity:192.168.1.2/67
    duration 0:02:01 bytes 641
    %ASA-7-609001: Built local-host outside:209.128.96.248
    %ASA-6-305011: Built dynamic TCP translation from inside:192.168.1.20/57764 to outside:69.86.151.109
    /50424
    %ASA-6-302013: Built outbound TCP connection 125413 for outside:209.128.96.248/80 (209.128.96.248/80
    ) to inside:192.168.1.20/57764 (69.86.151.109/50424)
    %ASA-7-111009: User 'enable_15' executed cmd: show running-config
    %ASA-7-111009: User 'enable_15' executed cmd: show logging
    %ASA-7-609001: Built local-host outside:174.35.22.69
    %ASA-6-305011: Built dynamic TCP translation from inside:192.168.1.24/51106 to outside:69.86.151.109
    /53818
    %ASA-6-302013: Built outbound TCP connection 125414 for outside:174.35.22.69/80 (174.35.22.69/80) to
    inside:192.168.1.24/51106 (69.86.151.109/53818)
    %ASA-6-305011: Built dynamic TCP translation from inside:192.168.1.24/51107 to outside:69.86.151.109
    /12433
    %ASA-6-302013: Built outbound TCP connection 125415 for outside:174.35.22.69/80 (174.35.22.69/80) to
    inside:192.168.1.24/51107 (69.86.151.109/12433)
    %ASA-7-609001: Built local-host outside:8.8.8.8
    %ASA-6-305011: Built dynamic UDP translation from inside:192.168.1.24/51214 to outside:69.86.151.109
    /42103
    %ASA-6-302015: Built outbound UDP connection 125416 for outside:8.8.8.8/53 (8.8.8.8/53) to inside:19
    2.168.1.24/51214 (69.86.151.109/42103)
    %ASA-6-302016: Teardown UDP connection 125416 for outside:8.8.8.8/53 to inside:192.168.1.24/51214 du
    ration 0:00:00 bytes 176
    %ASA-7-609002: Teardown local-host outside:8.8.8.8 duration 0:00:00
    %ASA-6-302014: Teardown TCP connection 125414 for outside:174.35.22.69/80 to inside:192.168.1.24/511
    06 duration 0:00:06 bytes 2075 TCP FINs
    %ASA-6-302014: Teardown TCP connection 125415 for outside:174.35.22.69/80 to inside:192.168.1.24/511
    07 duration 0:00:06 bytes 3016 TCP FINs
    %ASA-7-609002: Teardown local-host outside:174.35.22.69 duration 0:00:06
    ciscoasa#

  • Having issues with Simple FTP configuration

                       I am attempting to set up FTP behind this new CISCO ASA 5510 we just bought. I haven't configured a cisco device in 5 years, so I am having issues., i think i am close, but need a little help to get me over the hump. If I FTP from outside (fixed) IP it connects and takes the password but hangs on PASV and gives no data connection below is my configuration.  Can anyone help? I am hoping it is simple since I seem to have the connection inside correct. and yes you can connect to the FTP server from inside without issue.
    ASA Version 8.2(5)
    hostnameASA1
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    nameif External
    security-level 0
    ip address y.y.y.y 255.255.255.0
    interface Ethernet0/1
    nameif Internal
    security-level 100
    ip address x.x.x.x. 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    ftp mode passive
    dns domain-lookup External
    dns server-group DefaultDNS
    name-serverg.g.g.g.g.
    name-server h.h.h.h.
    access-list 100 extended permit tcp any host y.y.y.y eq ftp
    access-list 100 extended permit tcp any host y.y.y.y eq ftp-data
    pager lines 24
    logging enable
    logging asdm informational
    mtu External 1500
    mtu Internal 1500
    mtu management 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (External) 101 interface
    nat (Internal) 101 0.0.0.0 0.0.0.0
    static (Internal,External) tcp interface ftp-data 192.168.0.69 ftp-data netmask 255.255.255.255
    static (Internal,External) tcp interface ftp 192.168.0.69 ftp netmask 255.255.255.255
    access-group 100 in interface External
    route External 0.0.0.0 0.0.0.0 L.L.L.L 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 192.168.0.0 255.255.255.0 Internal
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca
      quit
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcpd enable management
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map INSPECTION_DEFAULT
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    call-home reporting anonymous
    Cryptochecksum:9c15122a54bf6b87ce5ab8be0f23e9d5
    : end

    First of all Thanks! So I pulled those commands off. 
    I am hitting the FTP server behind the firewall as you can see from my first log... It dies on PASV which is why I thought I needed that FTP-Data.
    000018)1/25/2013 11:48:21 AM - (not logged in) (72.90.68.10)> 220-FileZilla Server version 0.9.41 beta
    (000018)1/25/2013 11:48:21 AM - (not logged in) (72.90.68.10)> 220-written by Tim Kosse ([email protected])
    (000018)1/25/2013 11:48:21 AM - (not logged in) (72.90.68.10)> 220 Please visit http://sourceforge.net/projects/filezilla/(000018)1/25/2013 11:48:21 AM - (not logged in) (72.90.68.10)> USER administrator(000018)1/25/2013 11:48:21 AM - (not logged in) (72.90.68.10)> 331 Password required for administrator(000018)1/25/2013 11:48:21 AM - (not logged in) (72.90.68.10)> PASS *****(000018)1/25/2013 11:48:21 AM - administrator (72.90.68.10)> 230 Logged on(000018)1/25/2013 11:48:21 AM - administrator (72.90.68.10)> CWD /(000018)1/25/2013 11:48:21 AM - administrator (72.90.68.10)> 250 CWD successful. "/" is current directory.(000018)1/25/2013 11:48:21 AM - administrator (72.90.68.10)> TYPE A(000018)1/25/2013 11:48:21 AM - administrator (72.90.68.10)> 200 Type set to A(000018)1/25/2013 11:48:21 AM - administrator (72.90.68.10)> PASV(000018)1/25/2013 11:48:21 AM - administrator (ip.ip.ip.ip.ip)> 227 Entering Passive Mode (72,90,69,2,10,125)
    Here's what the Log shows when I hit the FTP server from the outside...
    6
    Jan 25 2013
    08:48:52
    72.90.68.10
    39185
    72.90.69.2
    21
    Deny TCP (no connection) from ip.ip.ip.ip/39185 to outsideinterfaceip/21 flags PSH ACK on interface External
    Does that help?
    Thanks again? Cyclist eh? Nice, that's my latest passion and it will probably send me to the poor house with the amount of times I crash.

  • SSL FTP Transfer to non SAP system

    Hi all. My company is sending an eForex interface to a bank that does not use SAP but requires our message to be sent using the FTP protocol we have but with SSL protection. There was an external tool doing the SSL encryption on our side but we want to do it directly from PI though i doubt the bank has any PCK etc on their side.
    I see the option use this in the message interface (FTP with SSL for data etc.) but i would like to know if theres more technical configuration to be done to do the connection with the bank.
    Any help would be appreciated.
    Regards,
    Darren.

    Hi Stefan thanks for noting that. This is not with Citi btw, a bank in SA. But let me get this correct. You're saying if we do the FTP/S in our interface and the bank does not use SAP or a PCK at least, it is possible to to do the transaction if we technically enable SSL on our PI system here and request that the bank allow for reverse DNS lookups to find us as well?
    Just those steps on our side and them enabling the lookup means we dont need them to implement any PCK (but perhaps continue with their existing method of dealing with SSL on their side) and request that 1 technical change of allowing reverse lookups for us.
    Thank you again for your response.
    Regards,
    Darren.

  • Windows 8 FTP Folder in File Explorer - Interface Not Supported

    I access my FTP site Via Windows Explorer in Windows 7 and Have tried doing the same via File Explorer in Windows 8
    When I double click a File in the FTP folder, whereas in W7 It would download a copy and open the file, In W8 I receive the error Interface Not Supported.
    Does anyone know of a fix for this?
    Thanks in advance.
    Tim

    I remember seeing something similar happen in Windows Explorer on W7 after I installed Google Chrome, however this was happening right from first install on W8.
    I seem to remember the solution in W7 was a registry fix but I'm not sure whether this would work in W8
    Ravenstar68
    Edit 
    Just remembered it wouldn't let you create the ftp site in W7 so was a different problem
    I was waiting to see if you brought that up.
    When I first made the standard ftp shortcut (the kind that opens IE), it had no association.  That green bird-foot arrow icon comes from OpenWith.exe.
    Double-clicking the shortcut brought up a very reduced-choice metro dialog.  Those were the only choices.  No OpenWith browse options there.
    There wasn't even a Open With... choice in the right-click dialog.
    I was curious to see what might happen if I made the wrong choice.  It was very unforgiving.
    No obvious way to fix it.  No OpenWith right-click context menu.
    I had to reassociate ftp elsewhere.
    Even now that I have everything straightened out, the right-click menus don't offer OpenWith.
    The left pic above shows the ordinary IE ftp shortcut.  I can drag-n-drop it into Firefox and it works.  But there's no OpenWith option for that.
    The right pic above shows the File Explorer ftp shortcut.  What in the world is that "Open folder location" option?  It launches IE to my (blank) home page.  Hmm?
    Just thought I'd share all this with you, since you brought up initializing ftp access.
    Deluxe in some ways, but pretty ragged in others.

  • 10g ftp interface seems to mess up embedded namespaces

    We have XML documents that are being inserted and retrieved using the resource_view without incident. However, whenever we retrieve these same documents through either the FTP or WebDAV interfaces, the documents come back with embedded namespaces messed up.
    For example: this is a document selected through a SQLPlus session (I've removed some of the contents to make it clearer):
    ---8<---
    SQL> conn cosmos/cosmos
    Connected.
    SQL> set pagesize 100
    SQL> set linesize 100
    SQL> set long 100000
    SQL> select extract(res, '/Resource/Contents/*') doc
    2 from resource_view
    3 where any_path = '/home/cosmos/SampleData/SampleData-100bd32900000005.xml';
    DOC
    <SampleData xmlns="http://digitalsteps.com/schema/cosmos" xmlns:xsi="http://www.
    w3.org/2001/XMLSchem
    a-instance" id="/SampleData/SampleData-100bd32900000005" xsi:schemaLocation="htt
    p://digitalsteps.com
    /schema/cosmos http://cosmos.com/schema/cosmos/SampleData.xsd">
    <gam:Metadata xmlns:gam="http://digitalsteps.com/schema/gamma">
    <gam:Approved>true</gam:Approved>
    <gam:LastUpdatedBy>UNAUTHENTICATED</gam:LastUpdatedBy>
    <gam:LastUpdatedTime>2004-12-10T14:08:25.000000</gam:LastUpdatedTime>
    <gam:Validated>false</gam:Validated>
    <gam:Version>1</gam:Version>
    </gam:Metadata>
    <Period>
    <g:From xmlns:g="http://digitalsteps.com/schema/gamma">2005-01-01</g:From>
    <g:To xmlns:g="http://digitalsteps.com/schema/gamma">2005-01-31</g:To>
    </Period>
    <SampleRef>12545/121/A</SampleRef>
    </SampleData>
    SQL>
    ---8<---
    That same document retrieved through ftp looks like this:
    ---8<---
    <?xml version="1.0" encoding="UTF-8"?>
    <SampleData xmlns="http://digitalsteps.com/schema/cosmos" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" id="/SampleData/SampleData-100bd32900000005" xsi:schemaLocation="http://digitalsteps.com/schema/cosmos http://cosmos.com/schema/cosmos/SampleData.xsd">
    <gam:Metadata xmlns:gam="http://digitalsteps.com/schema/gamma">
    <gam:Approved>true</gam:Approved>
    <gam:LastUpdatedBy>UNAUTHENTICATED</gam:LastUpdatedBy>
    <gam:LastUpdatedTime>2004-12-10T14:08:25.000000</gam:LastUpdatedTime>
    <gam:Validated>false</gam:Validated>
    <gam:Version>1</gam:Version>
    </gam:Metadata>
    <Period>
    <g:From>2005-01-01</g:From>
    <g:To>2005-01-31</g:To>
    </Period>
    <SampleRef>12545/121/A</SampleRef>
    </SampleData>
    ---8<---
    As you can see, the namespace declaration on the Period element has been dropped leaving a namespace prefix that is now not bound to anything. The document is, needless to say, now invalid.
    I suspect that this is a problem caused by having embedded namespaces that are equal but that are using different namespace prefixes, i.e.
    xmlns:gam="http://digitalsteps.com/schema/gamma"; and
    xmlns:g="http://digitalsteps.com/schema/gamma".
    Is this a bug in Oracle 10g's ftp and WebDAV interfaces?

    Hi, i've been discussing the problems with the recent driver update here in another thread:
    http://discussions.apple.com/message.jspa?messageID=12854782#12854782
    10.6.5 did come with new kexts (the dates just didn't change because they are using the same directories, but the version numbers for the kexts are all new).
    Unfortunately there are no fixes yet - we are hoping that 10.6.6 update will bring new stable drivers, otherwise the fix will be to revert back to 10.6.4

  • SAP ECC Interface w/ IDOC-XML using TCP/IP, HTTP, or FTP to 3rd-Party Syst.

    I am trying to understand if the following interface options can occur (without the use of SAP PI or any other middleware):
    Option 1A: Can I process an SAP ECC outbound IDoc in XML using TCP/IP to a non-SAP 3rd party system?  Can you please explain the reason for why I can or can NOT do this.  If possible, please provide supporting documentation on how-to do this?
    Option 1B: Can I process an SAP ECC inbound XML-IDOC from a non-SAP calling system that used TCP/IP?  Can you please explain the reason for why I can or can NOT do this. If possible, please provide supporting documentation on how-to do this?
    Option 2A: Can I process an SAP ECC outbound IDOC in XML using HTTP to a non-SAP 3rd-party system?  Can you please explain the reason for why I can or can NOT do this. If possible, please provide supporting documentation on how-to do this?
    Option 2B: Can I process an SAP ECC inbound XML-IDOC from a non-SAP calling system that used HTTP?  Can you please explain the reason for why I can or can NOT do this. If possible, please provide supporting documentation on how-to do this?
    Option 3A: Can I process an SAP ECC outbound IDOC in XML using FTP to a non-SAP 3rd-party system?  Can you please explain the reason for why I can or can NOT do this. If possible, please provide supporting documentation on how-to do this?
    Option 3B: Can I process an SAP ECC inbound XML-IDOC from a non-SAP calling system that used FTP?  Can you please explain the reason for why I can or can NOT do this. If possible, please provide supporting documentation on how-to do this?

    Hello Kirk  ,
    The answers for your question are:
    Option 1A: Yes you can .you can use TCP/IP but you must have a middleware component for that such as BC/JCO .
    Please see the link : [http://help.sap.com/saphelp_nw04/helpdata/EN/09/c88442a07b0e53e10000000a155106/frameset.htm]
    Option 1B: See the link above.
    Option 2A: You can use ABAP code :
    [http://help.sap.com/saphelp_nw04/helpdata/EN/e5/4d3514c11411d4ad310000e83539c3/frameset.htm]
    Option 2B: [http://help.sap.com/saphelp_nw04/helpdata/EN/90/4f3c2ec3c511d6b2b400508b6b8a93/frameset.htm]
    Option 3A: Only with ABAP code :[Reg: FTP Connection;
    Option 3B: See the link of Option 3A.
    Good Luck,
    Boaz
    Edited by: Boaz Ornan on Feb 21, 2010 4:33 PM

  • Stetting up FTP and SFTP adapters for the same interface

    Experts-
    I have a situation in which client has a requirement to setup both FTP and SFTP adapters (from adapetive adapters) for the same interface. They want to have a copy of file locally and also want a file to be sent out securly using SFTP. In my interface which was previously developed they have used one business system and added FTP and SFTP to the same. If try to add new Receiver Agreement it will say that the object already exists as the Interface Mapping is same.
    Please send me any suggestions which would resolve my problem

    Hi Hari,
    As you cannot create two Receiver agreement using only one receiver interface , please create a new receiver Interface, add that in interface determination step and then assing a different channel to new receiver agreement.
    If your requirement is to store the file ,i would suggest write the file in your unix directory using NFS( /usr/sap...). then run a AFT job (if already set up in your landscape) to transfer file securly to target destination.Not sure if its feasible in your case otherwise you can use  SFTP for the secure transfer.
    Best Regards
    Srinivas

  • Interface using ftp

    please give me an idea about the code of ftp interface.
    can u give some code for customer data or any others?

    Hi Abhijit Paul,
    For Example :
    data : v_handle TYPE i.
    CONSTANTS: cs_key_500098 TYPE i VALUE '500098'.
    DATA: it_itab(255) OCCURS 0 WITH HEADER LINE.
    DATA: v_password(20) TYPE c,
    i_key TYPE i VALUE 500098,
    v_pwd_len TYPE i,
    DATA: v_key TYPE i.
    v_password = 'youreoneh'.
    v_pwd_len = STRLEN( v_password ). and a constant key has to be passed.
    CALL FUNCTION 'HTTP_SCRAMBLE'
    EXPORTING
    SOURCE = v_password
    sourcelen = v_pwd_len
    key = cs_key_500098
    IMPORTING
    destination = v_password.
    Then :
    CALL FUNCTION 'FTP_CONNECT'
    EXPORTING
    user = 'user_name'
    password = v_password
    host = '192.168.10.10' " for example
    rfc_destination = 'SUNRFC' " for example
    IMPORTING
    handle = v_handle
    EXCEPTIONS
    not_connected = 1
    OTHERS = 2.
    Then : CONCATENATE sy-datum SY-TZONE '.txt' INTO v_filename.
    CONCATENATE '//192.168.10.10/sap file/' v_filename INTO v_filename .
    then use the
    CALL FUNCTION 'GUI_DOWNLOAD'
    EXPORTING
    filename = v_filename
    write_field_separator = 'X'
    TABLES
    data_tab = ta_download
    EXCEPTIONS
    file_write_error = 1
    no_batch = 2
    gui_refuse_filetransfer = 3
    invalid_type = 4
    no_authority = 5
    unknown_error = 6
    header_not_allowed = 7
    separator_not_allowed = 8
    filesize_not_allowed = 9
    header_too_long = 10
    dp_error_create = 11
    dp_error_send = 12
    dp_error_write = 13
    unknown_dp_error = 14
    access_denied = 15
    dp_out_of_memory = 16
    disk_full = 17
    dp_timeout = 18
    file_not_found = 19
    dataprovider_exception = 20
    control_flush_error = 21
    OTHERS = 22.
    "Then finally Disconnect the connection:
    CALL FUNCTION 'FTP_DISCONNECT'
    EXPORTING
    handle = v_handle
    EXCEPTIONS
    OTHERS = 1.
    Regards,
    Suneel G

  • How do I tie an Code Interface Node to the dos command prompt or Windows FTP stuff

    I have tried to use the System Exec.vi to do some ftp-ing with a box that If developing an automated ATP for. The sys exe vi dose most of what I need but not all. I can not modify the sys exe vi, nor can I copy the code interface node to another vi,I think that is because it has been compiled. So I need to generate my own vi that call the Windows ftp stuff or command prompt. I have spent several hours searching the NI site and the web in general and have not been able to find what to link the CIN to.
    Can somebody please explain this to me?
    I'm using:
    LabVIEW 8.6.0
    Windows XP Professional with service pack 3
    Thanks
    TeBlues

    Yes this is related to the post of yesterday. I tried your suggestions yesterday and was unable to get any of them to work.
    I down loaded the ftp library form OPENG and was unable to get it to connect to my box under test, and was unable to find any helping documentation on the OPENG site.
    I down loaded the vi from the earlier post you referred to and do to my lack of knowledge of windows was unable to figure out how the incorporate it in to my vi. For example what is the "lpsz Window?
    To complete this project I'm having to go deeper in to the stuff that goes on behind the seen than I have ever need before. So to me it looked like the next steep is to create a vi that used an CIN similar the the sys exe vi but add a few things around it..
    If this is wrong, What do you suggest? Keeping in mind I do not have the internet tool kit and the project dose not want to purchase it if we can avoided it.
    Thanks for your interest and time
    TeBlues

  • IFS-FTP Interface: How to ? Ref:OracleFilesOnLine

    The white paper on oracleFilesOnLine claims support to various
    FTP protocols. Will it be possible to get more information as to
    how this interface was accomplished.
    1. Is the FTP client integrated with the web ui for filesonline?
    2. How is the authentication on FTP server handled. Is the
    oraclefilesonline login/password used for ftp server also ?
    3. Was there any Joint dev. effor with FTP vendors resulting in
    some API provided to filesonline
    Thanks
    Vinod

    Hi,
    not quite.
    I want to achieve the following:
    Let's assume, the workitem is in the inbox of user DILBERT.
    Now DILBERT is in his Business workplace, selects the workitem and clicks "forward". He gets the popup to enter the user he wants to send the workitem to. Let's say, he picks user WALLY.
    Now I want to upate my custom status table with the user WALLY as the actual agent. Unfortunately, when I call the mehtod IM_WORKITEM_CONTEXT->get_header, the field WI_AAGENT still contains the value DILBERT instead fo WALLY.
    And I can find the value WALLY in no other accessible field either.
    Thanks,
    Martin
    Edited by: Martin Krausch on Apr 19, 2009 4:47 PM --> corrected typo only

  • Secured FTP interface with ABAP

    Hi Friends,
    We are trying to extract a file which is in remote system from FTP folder, for which we were successful in extraction using 'HTTP_SCRAMBLE, FTP_CONNECT, FTP_R3_TO_SERVER, FTP_SERVER_TO_R3 function modules.
    Similar to that we would like to extract data from SFTP folder as FTP is not secured. Are there any Function Modules which let us to extract data from SFTP folder through ABAP program. Or same function modules like above can be used here as well ?
    Waiting for your reply eagerly.
    Thanks & Regards,

    Hi Robin
    I know the answer comes late but you might find my wiki posting helpful:
    https://wiki.sdn.sap.com/wiki/display/Snippets/ABAP+Report-Report-Interface
    Regards,
    Marc
    SAP NetWeaver RIG

  • FTP Uploading from a Flash Interface

    Hi there!
    I wish to allow users of my all Flash website to upload their
    identity photograph when they register.
    How can I proceed to make a navigation window to open in
    order to select in their directory the photo they want to upload ?
    I also want to have the ftp address being hidden (this for
    obvious security reasons...)
    Many thanks in advance for your help !
    Best regards,
    Gerry

    I used a trial of Flash 9 (CS3) to publish and test a
    FlashPlayer 9 version of my file.
    Forget it! I got always the same result.
    Promise not to laugh. OK?
    "onHTTPError 404" means "File not found". Right?
    Which is the script sending this message?
    Is it the AS inside the .swf or is it the .php Script?
    And why is the file not found as I clearly see the LEDs
    flashing on my modem which is the proof that the upload is
    physically occurring?
    More : I can't believe that the problem is related to the
    .swf because it works for you. If the .swf was buggy it shouldn't
    work at all.
    Same for the .php Script.
    And it is not a CHMOD related problem because if it was you
    shouldn't be able to successfully upload.
    And it is not a browser related problem because on my Mac
    upload fails with any browser (Safari, Firefox, Opera, Explorer)
    This leaves only one possibility : it's a Mac related
    problem.
    And I say No because I was able to successfully use the very
    same .swf as a tryout on flash-db Website
    here
    I really am lost!

Maybe you are looking for