IP timeout when connecting to tomcat

I have tomcat 5.5 running and the sample servlet is running on it just fine when i connect to localhost. However, when I try to run it by connecting to my ip I get a timeout while trying to connect. Am I missing some setup or can Tomcat not be run to the outside?

In the server.xml you need to configure the Host element to listen on your IP address. The easiest way of doing this is opening up server.xml and replacing all instances of "localhost" with your IP address.
Of course Tomcat can be opened up for the outside world, what would be the use otherwise?

Similar Messages

  • Certificate problem when connection to tomcat

    I setup tomcat to use ssl by creating my own certificate.
    This works fine using the browser.
    But when I try this code from a test program:
    URL u = new URL("https://localhost:8443/");
    BufferedReader in = new BufferedReader(
    new InputStreamReader(
    u.openStream()));
    I get the error:
    javax.net.ssl.SSLHandshakeException:
    java.security.cert.CertificateException:
    Couldn't find trusted certificate
    I exported the cert from my keystore and
    imported it into my Trusted Root Certificate Autority
    using IE, but I still get same error.
    Any advice please?

    Solved this by adding the tomcat cert
    to <JAVA_HOME>\jre\lib\security\cacerts
    1. Export cert from keystore
    2. Import cert into cacerts keystore
    Then I got an io error about localhost
    Solved this by creating the tomcat cert
    with the company name as localhost

  • ITunes timeouts when connecting to remote speakers?

    When trying to connect to a remote set of speakers (Airport Express/Airtunes), iTunes times out. The set of speakers shows in the menu, iTunes attempts to connect for some time, and then "gives up" - there is no error message. Any suggestions?
    iTunes 7.0.2, Airport Express firmware 6.3.
    Thanks.

    At times, instead of the time out, I get the following error message:
    The remote speaker "Test" is not compatible with this version of iTunes
    This happens even though iTunes and the Airport Express are up to the latest versions, respectively.
    Thanks.

  • My Macbook pro 10.6.7 always says connection timeout when connecting to my wifi. hours ago it was still working.

    whats the prob? it says connection timeout. well, it worked once but the signal was 1 bar only then in 2 minutes the signal was out. guys it was working just 1 hour ago. and now it says timeout, my ipad can connect and the other macs. but this laptop wont.

    You may want to repost in the MacBook Pro forum, this is a forum for iMacs?

  • When connecting to wifi, I get a "Connection timeout" error message.

    I'm trying to connect to a WEP password wifi signal. I have the password, but when connecting, I'm getting a connection timeout error message. Please help?

    I'm having the exact same problem. Yesterday it was fine, but today, I get connection timeout error message. Help?

  • Initermittent Connection Timeout at Post-Login when connect to AlwaysOn Availability Group listener

    Hi,
    I'm using SQL 2014 AlwaysOn Availability Group and my ASP .Net application is connected to the database thru the availability group listener (tcp:[myHAGroup],14330).
    Things work most of the time, but recently I started to see the following Connection Timeout exception in Event Log. It looks like under heavy traffic the application can't connect to the availability group listener.
    Timestamp: 8/17/2014 10:07:28 AM
    Message: System.Data.EntityException: The underlying provider failed on Open. ---> System.Data.SqlClient.SqlException: Connection Timeout Expired. The timeout period elapsed during the post-login phase. The connection could have timed out while waiting for server to complete the login process and respond; Or it could have timed out while attempting to create multiple active connections. The duration spent while attempting to connect to this server was - [Pre-Login] initialization=2; handshake=0; [Login] initialization=0; authentication=0; [Post-Login] complete=15008; ---> System.ComponentModel.Win32Exception: The wait operation timed out
    --- End of inner exception stack trace ---
    I've checked SQL Profiler and don't see any memory or CPU peak at that time. Looks like somethings happened during the Post-Login stage, but I couldn't figure out what or why....
    I'm using 2 SQL servers (1 primary, 1 secondary): SQL 2014 ENT, 8GB RAM, 8 core 2.67 Xeon X5650.
    Application: ASP .Net, framework 4.0.
    All servers are VMWare virtualization servers, running on 1 virtual switch, so internal traffic should not be a problem.
    Comments/ideas are appreciated.
    Eric.

    Hi Eric Nguyen,
    According to your description and error message, we need to verify if there are some queries/transaction lock your database via SQL trace. If yes,
     you have to find out which queries are blocking and rewrite them/run them at other time to avoid blocking other processes.
    In addition, you can use performance monitor to track connection pool connections. If you set default connection limit and timeout limit with a small number, the error of “wait operation timed out” will occur. Meanwhile, you also need to monitor disk usage
    on SQL Server , and set the auto increment size of your transaction log and database with a fixed size instead of a percentage of the current files due to avoid transaction timeout. For more information, see:
    http://stackoverflow.com/questions/7743725/how-to-troubleshoot-intermittent-sql-timeout-errors
    There is an similar issue about connection failed from webservers to SQL Server AlwaysOn Listener, you can review it.
    http://stackoverflow.com/questions/23416492/connection-timeouts-when-using-multisubnetfailover-true
    Regards,
    Sofiya Li
    Sofiya Li
    TechNet Community Support

  • WRT54GC setup timeout when trying to connection to internet

    hi there,
    I've just bought the WRT54GC v2.0 and I haven't yet been able to connect to the internet with it.
    I used the Setup CD (well, there's not much choice actually) and after I have finished making all the connections asked there is a progress window that says "Checking Internet Connection" that eventually times-out and I get a popup message saying "Unable to detect internet connection". (During the process the lights on the modem flicker quite a bit, but alas...)
    My internet connection works fine when I connect directly to the modem so I don't know why the WRT54GC can't connect.
    Some Info:
    OS: Windows XP
    Modem: Netopia (Cayman 3300 Series)
    Modem IP: 192.168.1.1
    My Dynamically Assigned IP: 192.168.1.41 (when connected directly to the modem)
    I have tried all sorts of things: (not necessarily in that order)
    - Changing the WRT54GC's IP to 192.168.1.2
    - Playing in the "Advanced" page
    - Reseting the factory settings
    - Turning off everything and turning each device on in order (modem, WRT54GC, computer) with 3 minutes between each turn-on (no pun intended)
    Can anyone help? please?
    newbie

    Change the local IP of your WRT54GC router to 192.168.3.1 or 10.10.10.1 to avoid IP address conflicts from Netopia modem. It will not work if you had only changed the last octet of the router because it will still be within the range of the Netopia modem.

  • Finder crashes when connecting to server (10.9.4)

    I have been having an issue with my Mac Mini the last few days when it tries to connect to my local server.
    The first few times I can access the server normally through Finder, but after a few goes Finder freezes (spinning beach ball on finder - other apps work ok) up completely and needs to be restarted. Once it has restarted and I re-open Finder, it freezes up again completely until I restart my computer. The same applies when I try to access the server from other apps (eg. when adding a photo from the server to something in Chrome).
    I have reset PRAM, verified/repaired disk, run CCleaner.
    Any solutions to this issue?
    Mac Mini mid-2011
    Processor  2.5 GHz Intel Core i5
    Memory  4 GB 1333 MHz DDR3
    Running 10.9.4

    Sorry...
    tcp:
        61269 packets sent
            14501 data packets (5423429 bytes)
            457 data packets (298568 bytes) retransmitted
            0 resends initiated by MTU discovery
            34229 ack-only packets (284 delayed)
            0 URG only packets
            0 window probe packets
            8915 window update packets
            3181 control packets
            0 data packets sent after flow control
            0 checksummed in software
                0 segments (0 bytes) over IPv4
                0 segments (0 bytes) over IPv6
        66665 packets received
            15538 acks (for 5408457 bytes)
            1286 duplicate acks
            0 acks for unsent data
            46049 packets (49418889 bytes) received in-sequence
            233 completely duplicate packets (175429 bytes)
            0 old duplicate packets
            1 packet with some dup. data (996 bytes duped)
            6329 out-of-order packets (8815198 bytes)
            0 packets (0 bytes) of data after window
            0 window probes
            70 window update packets
            166 packets received after close
            0 bad resets
            0 discarded for bad checksums
            0 checksummed in software
                0 segments (0 bytes) over IPv4
                0 segments (0 bytes) over IPv6
            0 discarded for bad header offset fields
            0 discarded because packet too short
        1604 connection requests
        50 connection accepts
        0 bad connection attempts
        0 listen queue overflows
        1622 connections established (including accepts)
        1613 connections closed (including 48 drops)
            37 connections updated cached RTT on close
            37 connections updated cached RTT variance on close
            15 connections updated cached ssthresh on close
        0 embryonic connections dropped
        15554 segments updated rtt (of 13699 attempts)
        544 retransmit timeouts
            20 connections dropped by rexmit timeout
            0 connections dropped after retransmitting FIN
        2 persist timeouts
            0 connections dropped by persist timeout
        0 keepalive timeouts
            0 keepalive probes sent
            0 connections dropped by keepalive
        2887 correct ACK header predictions
        40214 correct data packet header predictions
        79 SACK recovery episodes
        43 segment rexmits in SACK recovery episodes
        39243 byte rexmits in SACK recovery episodes
        256 SACK options (SACK blocks) received
        6226 SACK options (SACK blocks) sent
        0 SACK scoreboard overflow
        0 LRO coalesced packets
            0 times LRO flow table was full
            0 collisions in LRO flow table
            0 times LRO coalesced 2 packets
            0 times LRO coalesced 3 or 4 packets
            0 times LRO coalesced 5 or more packets
        3 limited transmits done
        106 early retransmits done
        20 times cumulative ack advanced along with SACK
    udp:
        6116 datagrams received
            0 with incomplete header
            0 with bad data length field
            0 with bad checksum
            0 with no checksum
            0 checksummed in software
                0 datagrams (0 bytes) over IPv4
                0 datagrams (0 bytes) over IPv6
            41 dropped due to no socket
            2230 broadcast/multicast datagrams undelivered
            0 times multicast source filter matched
            0 dropped due to full socket buffers
            0 not for hashed pcb
            3845 delivered
        994 datagrams output
            69 checksummed in software
                0 datagrams (0 bytes) over IPv4
                69 datagrams (11318 bytes) over IPv6
    ip:
        72011 total packets received
            0 bad header checksums
            0 headers (0 bytes) checksummed in software
            0 with size smaller than minimum
            0 with data size < data length
            3522 with data size > data length
                0 packets forced to software checksum
            0 with ip length > max ip packet size
            0 with header length < data size
            0 with data length < header length
            0 with bad options
            0 with incorrect version number
            0 fragments received
                0 dropped (dup or out of space)
                0 dropped after timeout
                0 reassembled ok
            71997 packets for this host
            14 packets for unknown/unsupported protocol
            0 packets forwarded (0 packets fast forwarded)
            0 packets not forwardable
            0 packets received for unknown multicast group
            0 redirects sent
        62678 packets sent from this host
            0 packets sent with fabricated ip header
            0 output packets dropped due to no bufs, etc.
            0 output packets discarded due to no route
            0 output datagrams fragmented
            0 fragments created
            0 datagrams that can't be fragmented
            0 tunneling packets that can't find gif
            0 datagrams with bad address in header
            0 packets dropped due to no bufs for control data
            71 headers (1428 bytes) checksummed in software
    icmp:
        41 calls to icmp_error
        0 errors not generated 'cuz old message was icmp
        Output histogram:
            destination unreachable: 41
        0 messages with bad code fields
        0 messages < minimum length
        0 bad checksums
        0 messages with bad length
        0 multicast echo requests ignored
        0 multicast timestamp requests ignored
        Input histogram:
            destination unreachable: 14
        0 message responses generated
        ICMP address mask responses are disabled
    igmp:
        0 messages received
        0 messages received with too few bytes
        0 messages received with wrong TTL
        0 messages received with bad checksum
        0 V1/V2 membership queries received
        0 V3 membership queries received
        0 membership queries received with invalid field(s)
        0 general queries received
        0 group queries received
        0 group-source queries received
        0 group-source queries dropped
        0 membership reports received
        0 membership reports received with invalid field(s)
        0 membership reports received for groups to which we belong
        0 V3 reports received without Router Alert
        2 membership reports sent
    ipsec:
        0 inbound packets processed successfully
        0 inbound packets violated process security policy
        0 inbound packets with no SA available
        0 invalid inbound packets
        0 inbound packets failed due to insufficient memory
        0 inbound packets failed getting SPI
        0 inbound packets failed on AH replay check
        0 inbound packets failed on ESP replay check
        0 inbound packets considered authentic
        0 inbound packets failed on authentication
        0 outbound packets processed successfully
        0 outbound packets violated process security policy
        0 outbound packets with no SA available
        0 invalid outbound packets
        0 outbound packets failed due to insufficient memory
        0 outbound packets with no route
    arp:
        5 ARP requests sent
        9 ARP replies sent
        0 ARP announcements sent
        98 ARP requests received
        6 ARP replies received
        104 total ARP packets received
        0 ARP conflict probes sent
        0 invalid ARP resolve requests
        0 total packets dropped due to lack of memory
        3 total packets dropped due to no ARP entry
        0 total packets dropped during ARP entry removal
        12 ARP entries timed out
        0 Duplicate IPs seen
    ip6:
        793 total packets received
            0 with size smaller than minimum
            0 with data size < data length
            0 with data size > data length
                0 packets forced to software checksum
            0 with bad options
            0 with incorrect version number
            0 fragments received
                0 dropped (dup or out of space)
                0 dropped after timeout
                0 exceeded limit
                0 reassembled ok
            784 packets for this host
            0 packets forwarded
            0 packets not forwardable
            0 redirects sent
            0 multicast packets which we don't join
            0 packets whose headers are not continuous
            0 tunneling packets that can't find gif
            0 packets discarded due to too may headers
            0 forward cache hit
            0 forward cache miss
            0 packets dropped due to no bufs for control data
        126 packets sent from this host
            0 packets sent with fabricated ip header
            0 output packets dropped due to no bufs, etc.
            4145 output packets discarded due to no route
            0 output datagrams fragmented
            0 fragments created
            0 datagrams that can't be fragmented
            0 packets that violated scope rules
        Input histogram:
            TCP: 22
            UDP: 762
            ICMP6: 9
        Mbuf statistics:
            507 one mbuf
            two or more mbuf:
                lo0= 69
            217 one ext mbuf
            0 two or more ext mbuf
            0 failures of source address selection
    icmp6:
        0 calls to icmp_error
        0 errors not generated because old message was icmp error or so
        0 errors not generated because rate limitation
        Output histogram:
            router solicitation: 4
            neighbor solicitation: 4
            neighbor advertisement: 4
            MLDv2 listener report: 7
        0 messages with bad code fields
        0 messages < minimum length
        0 bad checksums
        0 messages with bad length
        Input histogram:
            neighbor solicitation: 3
            neighbor advertisement: 6
        Histogram of error messages to be generated:
            0 no route
            0 administratively prohibited
            0 beyond scope
            0 address unreachable
            0 port unreachable
            0 packet too big
            0 time exceed transit
            0 time exceed reassembly
            0 erroneous header field
            0 unrecognized next header
            0 unrecognized option
            0 redirect
            0 unknown
        0 message responses generated
        0 messages with too many ND options
        0 messages with bad ND options
        0 bad neighbor solicitation messages
        3 bad neighbor advertisement messages
        0 bad router solicitation messages
        0 bad router advertisement messages
        0 bad redirect messages
        0 path MTU changes
    ipsec6:
        0 inbound packets processed successfully
        0 inbound packets violated process security policy
        0 inbound packets with no SA available
        0 invalid inbound packets
        0 inbound packets failed due to insufficient memory
        0 inbound packets failed getting SPI
        0 inbound packets failed on AH replay check
        0 inbound packets failed on ESP replay check
        0 inbound packets considered authentic
        0 inbound packets failed on authentication
        0 outbound packets processed successfully
        0 outbound packets violated process security policy
        0 outbound packets with no SA available
        0 invalid outbound packets
        0 outbound packets failed due to insufficient memory
        0 outbound packets with no route
    rip6:
        0 messages received
        0 checksum calcurations on inbound
        0 messages with bad checksum
        0 messages dropped due to no socket
        0 multicast messages dropped due to no socket
        0 messages dropped due to full socket buffers
        0 delivered
        0 datagrams output
    pfkey:
        0 requests sent to userland
        0 bytes sent to userland
        0 messages with invalid length field
        0 messages with invalid version field
        0 messages with invalid message type field
        0 messages too short
        0 messages with memory allocation failure
        0 messages with duplicate extension
        0 messages with invalid extension type
        0 messages with invalid sa type
        0 messages with invalid address extension
        0 requests sent from userland
        0 bytes sent from userland
        0 messages toward single socket
        0 messages toward all sockets
        0 messages toward registered sockets
        0 messages with memory allocation failure

  • Error when connecting to portal from some machines

    Hi all,
    Can anyone help me with this.
    I get this jserver error when connecting to portal from some
    client machines.
    I works fine from the others. Any ideas?
    This is the error I get:
    [08/01/2002 17:41:57:618 GMT+00:00] page/Timeout occurred,
    label=73 url=http://odeceixe:81/pls/portal30/!
    PORTAL30.wwpro_app_provider.execute_portlet time=15828ms
    [08/01/2002 17:41:57:618 GMT+00:00] page/ContentFetcher
    Unexpected Exception, name=content-fetcher5
    java.io.EOFException: Premature EOF encountered
         at HTTPClient.StreamDemultiplexor.read
    (StreamDemultiplexor.java, Compiled Code)
         at HTTPClient.RespInputStream.read(RespInputStream.java,
    Compiled Code)
         at java.io.InputStream.read(InputStream.java:95)
         at java.io.InputStreamReader.fill
    (InputStreamReader.java:163)
         at java.io.InputStreamReader.read
    (InputStreamReader.java:239)
         at oracle.webdb.page.ContentFetcher.run
    (ContentFetcher.java, Compiled Code)

    Did you ever find the cause of this, I am receiving the same message, but as you said, only when connecting to the portal via a certain pc.

  • No WIFI when connected to External Display

    When I connect MBA to a Dell 2405FPW monitor, wifi gets a "connection timeout".
    When I disconnect external display, wifi works - all this with the same wifi point.
    I took MBA to the apple store, they connected the MBA to their displays and it works. This is very stressful since I cannot take the dell monitor to the apple store - Its where I work.
    I also tested the MBA on a newer 24" dell monitor(At work) with same output. My only result was turninng to a less dimension monitor - works fine(again, all with the same wifi point). Is there a limitation when connecting MBA to external monitors - MBA? Again, very frustrating dealing with this issue. My previous MBP had no issues with this dell monitor. Any recommendations will be appreciated.

    Alexander - I have a MBA 1.6 HDD and have been experiencing the same problem as you have. I connect via micro DVI to a 23" Apple Cinema Display and have been losing transmission speed or connection altogether with my Airport Extreme.
    I have been reading the posts regarding this issue and found a link to this article on maximizing wireless connectivity with an external display and MBA: http://docs.info.apple.com/article.html?artnum=307295.
    After reading the article and trying different settings, I found that my Airport was set to channel 11 and if I set it to 6 I stopped having connectivity issues and was able to work without incident. Give it a try - I hope it works for you.

  • Consistently getting "The wait operation timed out" when connecting to Azure SQL Database from a virtual instance...

    I have a web app that is backed by a an Azure SQL Database. The problem is that I had multiple issues when connecting to the database mainly when trying to establish a connection, or timeouts. This is the log I just encountered when trying to use the web
    app.
    [Win32Exception (0x80004005): The wait operation timed out]
    [SqlException (0x80131904): Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement. This could be because the pre-login handshake failed or the server was unable to respond back in time. The duration spent while attempting to connect to this server was - [Pre-Login] initialization=21970; handshake=1; ]
    System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection) +671
    System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection) +116
    System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection) +1012
    System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions) +6712291
    System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry) +152
    System.Data.SqlClient.SqlConnection.Open() +229
    System.Data.EntityClient.EntityConnection.OpenStoreConnectionIf(Boolean openCondition, DbConnection storeConnectionToOpen, DbConnection originalConnection, String exceptionCode, String attemptedOperation, Boolean& closeStoreConnectionOnFailure) +102

    Hi Affar2k,
    According to your description, we need to verify if there is no network issue and the Sqlclient version is older than .NET 4.5.  You can try to connect to the Windows Azure SQL database via SSMS and check if it can run well. When you
    connect to the SQL Azure database via ADO.NET, you need to verify that the server name and passwords are right in the connection string.
    For more information, you can review the following article about how to connect to Windows Azure SQL Database using ADO.NET.
    http://msdn.microsoft.com/en-us/library/windowsazure/ee336243.aspx
    Thanks,
    Sofiya Li
    Sofiya Li
    TechNet Community Support

  • Default Gateway when connected to VPN

    Thanks for reading!
    This is probably a dump question so bear with me...
    I have set up a VPN connection with a Cisco ASA 5505 fronting internet, with the customers environment behind it (on the same subnet), When connected ot the VPN I can reach the inside Router fronting me and one switch behind the Router (every switch is connected to the router), but nothing else.
    My beet is that the Router is messing with my connection, but,, nevermind that!, the setup ain't complete anyway... my question is more related to the Gateway I'm missing when I'm, from the outside, is connected to the VPN on the ASA, could this mess it up? Shouldn't I have a Standard-Gateway in the ipconfig settings in windows?
    This is who it looks like now:
            Anslutningsspecifika DNS-suffix . : VPNOFFICE
            IP-adress . . . . . . . . . . . . : 10.10.10.1
            Nätmask . . . . . . . . . . . . . : 255.255.255.0
            Standard-gateway  . . . . . . . . :
    The internal network is :
    172.16.12.0 255.255.255.0
    Below is my config for the ASA, thanks a lot!!!!!!!
    !FlASH PÅ ROUTERN FRÅN BÖRJAN
    !asa841-k8.bin
    hostname DRAKENSBERG
    domain-name default.domain.invalid
    enable password XXXXXXX
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 172.16.12.4 255.255.255.0
    interface Vlan10
    nameif outside
    security-level 0
    ip address 97.XX.XX.20 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 10
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone CEST 1
    clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list nonat extended permit ip 172.16.12.0 255.255.255.0 10.10.10.0 255.255.255.0
    access-list MSS_EXCEEDED_ACL extended permit tcp any any
    access-list VPN-SPLIT-TUNNEL remark VPN SPLIT TUNNEL
    access-list VPN-SPLIT-TUNNEL standard permit 172.16.12.0 255.255.255.0
    tcp-map MSS-MAP
      exceed-mss allow
    pager lines 24
    logging enable
    logging timestamp
    logging buffer-size 8192
    logging console notifications
    logging buffered notifications
    logging asdm notifications
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN 10.10.10.1-10.10.10.40 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any outside
    asdm image disk0:/asdm-625-53.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nonat
    nat (inside) 1 172.16.12.0 255.255.255.0
    route outside 0.0.0.0 0.0.0.0 97.XX.XX.17 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    http server enable
    http 172.16.12.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 172.16.12.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    group-policy VPNOFFICE internal
    group-policy VPNOFFICE attributes
    dns-server value 215.122.145.18
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value VPN-SPLIT-TUNNEL
    default-domain value VPNOFFICE
    split-dns value 215.122.145.18
    msie-proxy method no-proxy
    username admin password XXXXXX privilege 15
    username Daniel password XXXXX privilege 0
    username Daniel attributes
    vpn-group-policy VPNOFFICE
    tunnel-group VPNOFFICE type remote-access
    tunnel-group VPNOFFICE general-attributes
    address-pool VPN
    default-group-policy VPNOFFICE
    tunnel-group VPNOFFICE ipsec-attributes
    pre-shared-key XXXXXXXXXX
    class-map MSS_EXCEEDED_MAP
    match access-list MSS_EXCEEDED_ACL
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
      inspect icmp error
      inspect pptp
      inspect ipsec-pass-thru
      inspect icmp
    class MSS_EXCEEDED_MAP
      set connection advanced-options MSS-MAP
    service-policy global_policy global
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command vpnclient
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    Cryptochecksum:aaa1f198bf3fbf223719e7920273dc2e
    : end

    I didn't realise I had that crypto settings on, thanks my bad!!!
    But... the 172.16.12.0 network is directly connected, the Router (that to be honest is a firewall) / switches is all on the same subnet (172.16.12.X/24), so sorry I didn't explain thoroughly, was more wondering about the GW and didn't want to overcomplicate things..
    The Firewall/Router dosen't do any routing, so it should work right (I you count out the firewalling in the firewall and so forth, there shouldn't be any problems accomplishing this with the ASA)? The Firewall is more a DHCP for the clients/Firwall for the clients.. this will change in the future.. it will be removed,
    the vpn network is staticly routed back to my ASA in that firewall...
    I don't like this solution.. but this is who it looks.. for now..
    (VPN network is 10.10.10.X/24)
    But... shouldn't I see a default gateway under ipconfig when I'm connected to the VPN from internet, on the vpn client that's vpned in, is this correct?
    THANKS for all the help!

  • Problem when connect to SAP

    Hi All!
    When i create an Addon Application I Register String to connect to SAp by: Right click in my app/properties/Debug/ and input command line Agruments.
    And in myclasses I call:
    Private Sub SetApplication()
            '// Use an SboGuiApi object to establish the connection
            '// with the application and rturn an initialized appliction object
            Dim SboGuiApi As SAPbouiCOM.SboGuiApi
            Dim sConnectionString As String
            SboGuiApi = New SAPbouiCOM.SboGuiApi
            '// by following the steps specified above, the following
            '// statment should be suficient for either development or run mode
            sConnectionString = Environment.GetCommandLineArgs.GetValue(1)
            '// connect to a running SBO Application
            Try ' If there's no active application the connection will fail
                SboGuiApi.Connect(sConnectionString)
            Catch ' Connection failed
                System.Windows.Forms.MessageBox.Show("No SAP Business One Application was found")
                End
            End Try
            '// get an initialized application object
            SBO_Application = SboGuiApi.GetApplication()
        End Sub
    to connect to SAP.
    But When i create many classes I call many this function so my application will timeout when I setup this Application for SAp. How to connect one time and using all.
    please help me solve this problem.
    Thanks

    Hi,
    1) Define a main class, which calls SetApplication and initializes SBO_Application.
    Public class clsSBO
      Public WithEvents SBO_Appln As SAPbouiCOM.Application
      Public sub New()
        SetApplication()
        CreateObjects()
      end sub
    your functions
    end class
    2) Create objects of all of your classes in the clsSBO.
    3) Whenever ItemEvent or MenuEvent happens, pass the event to the appropriate objects.
    Hope this helps.
    Please give points if you find this useful.
    Regards
    Geetha

  • Timeout when calling long running Oracle Apps Adapter API calls

    When making a Oracle Apps Based adapter from ESB, Transactions are getting timedout for running calls (~ > 5 mins)
    1) Created a Oracle Apps Adapter to execute a API call that returns, in our case, customer data.
    2) Created a BPEL Which invokes this API based Adapter via. a partner link.
    3) Following errors for calls which take ~ >5, transaction is timeout, when invoked from BPEL/ESB/SOAP UI Client.
    From domain.log
    ==========
    <2009-04-21 18:54:25,718> <DEBUG> <yeruvp.collaxa.cube.ws> <WSIFInvocationHandler::invoke> invoke failed
    org.collaxa.thirdparty.apache.wsif.WSIFException: exception during SOAP invoke: Timed out; nested exception is:
         javax.xml.rpc.soap.SOAPFaultException: Timed out
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.populateFaultMessage(WSIFOperation_JaxRpc.java:3086)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.invokeOperation(WSIFOperation_JaxRpc.java:1728)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.invokeRequestResponseOperation(WSIFOperation_JaxRpc.java:1473)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.executeRequestResponseOperation(WSIFOperation_JaxRpc.java:1196)
         at com.collaxa.cube.ws.WSIFInvocationHandler.invoke(WSIFInvocationHandler.java:476)
         at com.collaxa.cube.ws.WSInvocationManager.invoke2(WSInvocationManager.java:436)
         at com.collaxa.cube.ws.WSInvocationManager.invoke(WSInvocationManager.java:251)
         at com.collaxa.cube.engine.ext.wmp.BPELInvokeWMP.__invoke(BPELInvokeWMP.java:790)
         at com.collaxa.cube.engine.ext.wmp.BPELInvokeWMP.__executeStatements(BPELInvokeWMP.java:395)
         at com.collaxa.cube.engine.ext.wmp.BPELActivityWMP.perform(BPELActivityWMP.java:195)
         at com.collaxa.cube.engine.CubeEngine.performActivity(CubeEngine.java:3715)
         at com.collaxa.cube.engine.CubeEngine.handleWorkItem(CubeEngine.java:1655)
         at com.collaxa.cube.engine.dispatch.message.instance.PerformMessageHandler.handleLocal(PerformMessageHandler.java:75)
         at com.collaxa.cube.engine.dispatch.DispatchHelper.handleLocalMessage(DispatchHelper.java:220)
         at com.collaxa.cube.engine.dispatch.DispatchHelper.sendMemory(DispatchHelper.java:317)
         at com.collaxa.cube.engine.CubeEngine.endRequest(CubeEngine.java:5710)
         at com.collaxa.cube.engine.CubeEngine.createAndInvoke(CubeEngine.java:1085)
         at com.collaxa.cube.engine.ejb.impl.CubeEngineBean.createAndInvoke(CubeEngineBean.java:132)
         at com.collaxa.cube.engine.ejb.impl.CubeEngineBean.syncCreateAndInvoke(CubeEngineBean.java:161)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at com.evermind.server.ejb.interceptor.joinpoint.EJBJoinPointImpl.invoke(EJBJoinPointImpl.java:35)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor$1.run(JAASInterceptor.java:31)
         at com.evermind.server.ThreadState.runAs(ThreadState.java:646)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor.invoke(JAASInterceptor.java:34)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.TxRequiresNewInterceptor.invoke(TxRequiresNewInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.InvocationContextPool.invoke(InvocationContextPool.java:55)
         at com.evermind.server.ejb.StatelessSessionEJBObject.OC4J_invokeMethod(StatelessSessionEJBObject.java:87)
         at CubeEngineBean_LocalProxy_4bin6i8.syncCreateAndInvoke(Unknown Source)
         at com.collaxa.cube.engine.delivery.DeliveryHandler.initialRequestAnyType(DeliveryHandler.java:515)
         at com.collaxa.cube.engine.delivery.DeliveryHandler.initialRequest(DeliveryHandler.java:457)
         at com.collaxa.cube.engine.delivery.DeliveryHandler.request(DeliveryHandler.java:131)
         at com.collaxa.cube.ejb.impl.DeliveryBean.request(DeliveryBean.java:95)
         at sun.reflect.GeneratedMethodAccessor129.invoke(Unknown Source)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at com.evermind.server.ejb.interceptor.joinpoint.EJBJoinPointImpl.invoke(EJBJoinPointImpl.java:35)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor$1.run(JAASInterceptor.java:31)
         at com.evermind.server.ThreadState.runAs(ThreadState.java:646)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor.invoke(JAASInterceptor.java:34)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.TxRequiredInterceptor.invoke(TxRequiredInterceptor.java:50)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.InvocationContextPool.invoke(InvocationContextPool.java:55)
         at com.evermind.server.ejb.StatelessSessionEJBObject.OC4J_invokeMethod(StatelessSessionEJBObject.java:87)
         at DeliveryBean_RemoteProxy_4bin6i8.request(Unknown Source)
         at com.collaxa.cube.ws.soap.oc4j.SOAPRequestProvider.processNormalOperation(SOAPRequestProvider.java:451)
         at com.collaxa.cube.ws.soap.oc4j.SOAPRequestProvider.processBPELMessage(SOAPRequestProvider.java:274)
         at com.collaxa.cube.ws.soap.oc4j.SOAPRequestProvider.processMessage(SOAPRequestProvider.java:120)
         at oracle.j2ee.ws.server.provider.ProviderProcessor.doEndpointProcessing(ProviderProcessor.java:956)
         at oracle.j2ee.ws.server.WebServiceProcessor.invokeEndpointImplementation(WebServiceProcessor.java:349)
         at oracle.j2ee.ws.server.provider.ProviderProcessor.doRequestProcessing(ProviderProcessor.java:466)
         at oracle.j2ee.ws.server.WebServiceProcessor.processRequest(WebServiceProcessor.java:114)
         at oracle.j2ee.ws.server.WebServiceProcessor.doService(WebServiceProcessor.java:96)
         at oracle.j2ee.ws.server.WebServiceServlet.doPost(WebServiceServlet.java:177)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)
         at oracle.security.jazn.oc4j.JAZNFilter$1.run(JAZNFilter.java:396)
         at java.security.AccessController.doPrivileged(Native Method)
         at javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
         at oracle.security.jazn.oc4j.JAZNFilter.doFilter(JAZNFilter.java:410)
         at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:623)
         at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:370)
         at com.evermind.server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:871)
         at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
         at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:302)
         at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:190)
         at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
         at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
         at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.xml.rpc.soap.SOAPFaultException: Timed out
         at oracle.j2ee.ws.client.StreamingSender._raiseFault(StreamingSender.java:568)
         at oracle.j2ee.ws.client.StreamingSender._sendImpl(StreamingSender.java:396)
         at oracle.j2ee.ws.client.StreamingSender._send(StreamingSender.java:112)
         at oracle.j2ee.ws.client.dii.CallInvokerImpl.directInvoke(CallInvokerImpl.java:726)
         at oracle.j2ee.ws.client.dii.BasicCall.directInvoke(BasicCall.java:743)
         at oracle.j2ee.ws.client.dii.BasicCall.invoke(BasicCall.java:649)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.invokeOperation(WSIFOperation_JaxRpc.java:1714)
         ... 83 more
    <2009-04-21 18:54:25,721> <ERROR> <yeruvp.collaxa.cube.ws> <WSIFInvocationHandler::invoke> Fault happened: exception during SOAP invoke: Timed out; nested exception is:
         javax.xml.rpc.soap.SOAPFaultException: Timed out
    <2009-04-21 18:54:25,752> <DEBUG> <yeruvp.collaxa.cube.engine> AJPRequestHandler-RMICallHandler-61, a4 <invoke> partner OrgCustAdapter_pl, wikey:7990001-BpInv0-BpSeq0.3-3, bpel code line:84, Connection info:oracle_jdbc_driver_T4CConnection_Proxy@17f3851, connection hashCode:25114705, autocommit:false, Transaction info:[Transaction : orabpel : Xid( Global Id 1b.16.00.7d.00.00.00.00.2f.d3.6d.ca.20.01.00.00.17.41.03.00.00.00.00.00, Format Id 1330790740)], jtaTxState:1, CubeInstance:7990001, Process name:testCustomer_BPEL
    Now looking to troubleshoot this Timed out issue.
    i, Does this need to increase any configuration file timeout parameter on EBS Adapter or other component ?
    Any suggessions to fix/towards resolution is appricated.
    Thanks,
    sgaraga

    After increasing sync-time-out and global transaction time out to 1800. Issue is still reported.
    We are not using the jdbc pool.
    Still not sure what we are missing here and running into this:
    WSIFInvocationHandler::invoke> invoke failed
    org.collaxa.thirdparty.apache.wsif.WSIFException: exception during SOAP invoke: Timed out; nested
    exception is:
    javax.xml.rpc.soap.SOAPFaultException: Timed out
    In addition:
    ========
    Tested calling this PL/SQL API (exactly the same API CALLED in BPEL) in TOAD and this ran for 20 mts in DB.
    With the changes(sync-time-out,global transaction time,hpptd.conf, and transaction-manager.xml ) in SOA configuration then we are getting the exception ..
    So, we need help with SOA configuration to get the BPEL service working when the API called within BPEL service is taking approximately 20 mts.
    Edited by: sgaraga on Apr 22, 2009 4:29 PM

  • Timeout when calling Oracle Apps Adapter API calls.

    1) Create a Oracle Apps Adapter to execute a API call that returns, in our case, customer data.
    2) Create a BPEL Which invokes this API based Adapter via. a partner link.
    Observations:
    A) Posts the following errors for calls which take ~ >5, transaction is timeout, when invoked from BPEL/ESB/SOAP UI Client.
    <2009-04-21 18:54:25,718> <DEBUG> <yeruvp.collaxa.cube.ws> <WSIFInvocationHandler::invoke> invoke failed
    org.collaxa.thirdparty.apache.wsif.WSIFException: exception during SOAP invoke: Timed out; nested exception is:
         javax.xml.rpc.soap.SOAPFaultException: Timed out
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.populateFaultMessage(WSIFOperation_JaxRpc.java:3086)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.invokeOperation(WSIFOperation_JaxRpc.java:1728)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.invokeRequestResponseOperation(WSIFOperation_JaxRpc.java:1473)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.executeRequestResponseOperation(WSIFOperation_JaxRpc.java:1196)
         at com.collaxa.cube.ws.WSIFInvocationHandler.invoke(WSIFInvocationHandler.java:476)
         at com.collaxa.cube.ws.WSInvocationManager.invoke2(WSInvocationManager.java:436)
         at com.collaxa.cube.ws.WSInvocationManager.invoke(WSInvocationManager.java:251)
         at com.collaxa.cube.engine.ext.wmp.BPELInvokeWMP.__invoke(BPELInvokeWMP.java:790)
         at com.collaxa.cube.engine.ext.wmp.BPELInvokeWMP.__executeStatements(BPELInvokeWMP.java:395)
         at com.collaxa.cube.engine.ext.wmp.BPELActivityWMP.perform(BPELActivityWMP.java:195)
         at com.collaxa.cube.engine.CubeEngine.performActivity(CubeEngine.java:3715)
         at com.collaxa.cube.engine.CubeEngine.handleWorkItem(CubeEngine.java:1655)
         at com.collaxa.cube.engine.dispatch.message.instance.PerformMessageHandler.handleLocal(PerformMessageHandler.java:75)
         at com.collaxa.cube.engine.dispatch.DispatchHelper.handleLocalMessage(DispatchHelper.java:220)
         at com.collaxa.cube.engine.dispatch.DispatchHelper.sendMemory(DispatchHelper.java:317)
         at com.collaxa.cube.engine.CubeEngine.endRequest(CubeEngine.java:5710)
         at com.collaxa.cube.engine.CubeEngine.createAndInvoke(CubeEngine.java:1085)
         at com.collaxa.cube.engine.ejb.impl.CubeEngineBean.createAndInvoke(CubeEngineBean.java:132)
         at com.collaxa.cube.engine.ejb.impl.CubeEngineBean.syncCreateAndInvoke(CubeEngineBean.java:161)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at com.evermind.server.ejb.interceptor.joinpoint.EJBJoinPointImpl.invoke(EJBJoinPointImpl.java:35)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor$1.run(JAASInterceptor.java:31)
         at com.evermind.server.ThreadState.runAs(ThreadState.java:646)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor.invoke(JAASInterceptor.java:34)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.TxRequiresNewInterceptor.invoke(TxRequiresNewInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.InvocationContextPool.invoke(InvocationContextPool.java:55)
         at com.evermind.server.ejb.StatelessSessionEJBObject.OC4J_invokeMethod(StatelessSessionEJBObject.java:87)
         at CubeEngineBean_LocalProxy_4bin6i8.syncCreateAndInvoke(Unknown Source)
         at com.collaxa.cube.engine.delivery.DeliveryHandler.initialRequestAnyType(DeliveryHandler.java:515)
         at com.collaxa.cube.engine.delivery.DeliveryHandler.initialRequest(DeliveryHandler.java:457)
         at com.collaxa.cube.engine.delivery.DeliveryHandler.request(DeliveryHandler.java:131)
         at com.collaxa.cube.ejb.impl.DeliveryBean.request(DeliveryBean.java:95)
         at sun.reflect.GeneratedMethodAccessor129.invoke(Unknown Source)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at com.evermind.server.ejb.interceptor.joinpoint.EJBJoinPointImpl.invoke(EJBJoinPointImpl.java:35)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor$1.run(JAASInterceptor.java:31)
         at com.evermind.server.ThreadState.runAs(ThreadState.java:646)
         at com.evermind.server.ejb.interceptor.system.JAASInterceptor.invoke(JAASInterceptor.java:34)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.TxRequiredInterceptor.invoke(TxRequiredInterceptor.java:50)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.interceptor.system.DMSInterceptor.invoke(DMSInterceptor.java:52)
         at com.evermind.server.ejb.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:119)
         at com.evermind.server.ejb.InvocationContextPool.invoke(InvocationContextPool.java:55)
         at com.evermind.server.ejb.StatelessSessionEJBObject.OC4J_invokeMethod(StatelessSessionEJBObject.java:87)
         at DeliveryBean_RemoteProxy_4bin6i8.request(Unknown Source)
         at com.collaxa.cube.ws.soap.oc4j.SOAPRequestProvider.processNormalOperation(SOAPRequestProvider.java:451)
         at com.collaxa.cube.ws.soap.oc4j.SOAPRequestProvider.processBPELMessage(SOAPRequestProvider.java:274)
         at com.collaxa.cube.ws.soap.oc4j.SOAPRequestProvider.processMessage(SOAPRequestProvider.java:120)
         at oracle.j2ee.ws.server.provider.ProviderProcessor.doEndpointProcessing(ProviderProcessor.java:956)
         at oracle.j2ee.ws.server.WebServiceProcessor.invokeEndpointImplementation(WebServiceProcessor.java:349)
         at oracle.j2ee.ws.server.provider.ProviderProcessor.doRequestProcessing(ProviderProcessor.java:466)
         at oracle.j2ee.ws.server.WebServiceProcessor.processRequest(WebServiceProcessor.java:114)
         at oracle.j2ee.ws.server.WebServiceProcessor.doService(WebServiceProcessor.java:96)
         at oracle.j2ee.ws.server.WebServiceServlet.doPost(WebServiceServlet.java:177)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)
         at oracle.security.jazn.oc4j.JAZNFilter$1.run(JAZNFilter.java:396)
         at java.security.AccessController.doPrivileged(Native Method)
         at javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
         at oracle.security.jazn.oc4j.JAZNFilter.doFilter(JAZNFilter.java:410)
         at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:623)
         at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:370)
         at com.evermind.server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:871)
         at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
         at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:302)
         at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java:190)
         at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
         at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
         at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.xml.rpc.soap.SOAPFaultException: Timed out
         at oracle.j2ee.ws.client.StreamingSender._raiseFault(StreamingSender.java:568)
         at oracle.j2ee.ws.client.StreamingSender._sendImpl(StreamingSender.java:396)
         at oracle.j2ee.ws.client.StreamingSender._send(StreamingSender.java:112)
         at oracle.j2ee.ws.client.dii.CallInvokerImpl.directInvoke(CallInvokerImpl.java:726)
         at oracle.j2ee.ws.client.dii.BasicCall.directInvoke(BasicCall.java:743)
         at oracle.j2ee.ws.client.dii.BasicCall.invoke(BasicCall.java:649)
         at com.collaxa.cube.ws.wsif.providers.oc4j.jaxrpc.WSIFOperation_JaxRpc.invokeOperation(WSIFOperation_JaxRpc.java:1714)
         ... 83 more
    <2009-04-21 18:54:25,721> <ERROR> <yeruvp.collaxa.cube.ws> <WSIFInvocationHandler::invoke> Fault happened: exception during SOAP invoke: Timed out; nested exception is:
         javax.xml.rpc.soap.SOAPFaultException: Timed out
    <2009-04-21 18:54:25,752> <DEBUG> <yeruvp.collaxa.cube.engine> AJPRequestHandler-RMICallHandler-61, a4 <invoke> partner OrgCustAdapter_pl, wikey:7990001-BpInv0-BpSeq0.3-3, bpel code line:84, Connection info:oracle_jdbc_driver_T4CConnection_Proxy@17f3851, connection hashCode:25114705, autocommit:false, Transaction info:[Transaction : orabpel : Xid( Global Id 1b.16.00.7d.00.00.00.00.2f.d3.6d.ca.20.01.00.00.17.41.03.00.00.00.00.00, Format Id 1330790740)], jtaTxState:1, CubeInstance:7990001, Process name:testCustomer_BPEL
    Now i am looking to troubleshoot this Timed out issue.
    i, Does this need to increase any configuration file timeout parameter on EBS Adapter or other component ?
    Any suggestions to fix/towards resolution is appreciated.
    Thanks,
    sgaraga

    After increasing sync-time-out and global transaction time out to 1800. Issue is still reported.
    We are not using the jdbc pool.
    Still not sure what we are missing here and running into this:
    WSIFInvocationHandler::invoke> invoke failed
    org.collaxa.thirdparty.apache.wsif.WSIFException: exception during SOAP invoke: Timed out; nested
    exception is:
    javax.xml.rpc.soap.SOAPFaultException: Timed out
    In addition:
    ========
    Tested calling this PL/SQL API (exactly the same API CALLED in BPEL) in TOAD and this ran for 20 mts in DB.
    With the changes(sync-time-out,global transaction time,hpptd.conf, and transaction-manager.xml ) in SOA configuration then we are getting the exception ..
    So, we need help with SOA configuration to get the BPEL service working when the API called within BPEL service is taking approximately 20 mts.
    Edited by: sgaraga on Apr 22, 2009 4:29 PM

Maybe you are looking for

  • While connecting the MSSQL (2000, 2005) to BI 7 in rsa1 source system getti

    While connecting the MSSQL (2000, 2005) to BI 7 in rsa1 source system getting below error. (When calling a function within the database interface, a return value which cannot be processed by the calling function was provided.) Please help me to solve

  • Run Oracle form non-interactively

    I am using Oracle 8i. I want to be able to run a form non-interactively, that is, in batch mode. The reason for that is that the application is a "turn-key" package and I don't have access to the source. I want to be able to run the form from a UNIX

  • Unable to Install upgrade version of Adobe Presenter 9.

    When I tried to install the upgrade, it stopped and said that I needed to restart. I did that ...and then when I tried reinstalling it asks me to remove the trial version of Adobe Presenter 9 !!! I never installed any trial version. So I had a chat a

  • Lightroom CC shuts down before opening.

    I just updated to Lightroom CC through the cloud app and now Lightroom will not start. The opening screen shows for about one second and it shuts down.

  • Worried my mac may be hacked. Help!

    Hi I've come home from work to find that my login screen on my mac has created a guest user for itself even though I've disabled it. When I go to change any settings I also get weird symbols coming up instead of english text (The accept button is als