Is open_cursors per session or user?

I'm getting a lot of ORA-01000 in error logs on my app servers. 8i documentation states that:
"OPEN_CURSORS determines the maximum number of cursors per user."
but I suspect this is a typo and should be per session, an extremely relavant difference when multiple app servers are connecting to DB w/common username.
does Oracle actually track open cursors across all active sessions for a given username or is it per session like most parameters?

It must be per session,
You can resolve the problem by increasing the parameter to 2500 as it cotrolls maximum allowed.

Similar Messages

  • Increasing max-streaming-connections-per-session has slow acknowledge response?

    Our application is a Flex GUI with a WebLogic Server (BlaseDS) on a private network.  We were originally using IE 6, but have upgraded to IE 8.
    I am trying to use publish/subscribe messaging to monitor lengthy processes on the server and received incremental data.  With 1 such process everything works fine.  But we want to allow the user to subscribe to more than 1 message destination.  So I increased the "max-streaming-connections-per-session" (default is 1) in the services-config.xml file
         <channel-definition id="process-notification-streaming-amf"
              class="mx.messaging.channels.StreamingAMFChannel">
              <endpoint url=https://{server.name}:{server.port}/{context.root}/messagebroker/streamingnotificationamf"
              class="flex.messaging.endpoints.StreamingAMFEndpoint"/>
              <properties>
                   <user-agent-settings>
                        <user-agent match-on="MSIE" kickstart-bytes="2048"
                             max-streaming-connections-per-session="3" />
                   </user-agent-settings>
              </properties>
         </channel-definition>
    If we leave max-streaming-connections-per-session as the default value of 1 and try to subscribe to another message destination we get an error indicating limit has been reached:
         [BlaseDS]Endpoint with id 'process-notification-streaming-amf' cannot grant streaming connection to FlexClient with id '7FFC82DE-etc ' because max-streaming-connections-per-session limit of '1' has been reached.
         We upgraded to IE8 as documentation indicates IE8 allows for an increase of max-streaming-connections-per-session, where IE 6 is limited to 1.  But increasing max-streaming-connections-per-session does not quite solve the problem.  We have 3 consumers; consumer1, consumer2, consumer3.  For each of these consumers, we add event listeners for MessageAckEvent.ACKNOWLEDGE and MessageEvent.MESSAGE.
         We call consumer1.subscribe().  When we receive the acknowledge message, we call consumer2.subscribe() (likewise with consumer3)
         The problem is it takes over 2 minutes to receive the acknowledge message from the call to consumer1.subscribe().  (With max-streaming-connections-per-session set to 1, the acknowledge message is received in a few seconds.)
         So, increasing max-streaming-connections-per-session removes the error about reaching a limit, but it appears to come with a cost of a big delay in a long delay on the call to subscribe?  Or is there something we are missing?

    I guess I will answer my own question.  Hopefully this will be useful to someone else in the future...
    The problem was coming from IE being limited to 1 connection by the registry.  The solution can be found at:
    http://support.microsoft.com/kb/282402
    I manually performed the steps to update the registry, though microsoft provides a "Fix It"; MicrosoftFixit50098.msi
    One other key element was to make sure to have kickstart-bytes="2048".

  • Start systemd --user once after first login, not per session?

    Hey guys,
    So I've been toying around with using systemd to manage user daemons and some oneshot processes, it seems like it could be really nice
    Here's what I'm thinking I would like to do:
    I would have two user targets, `console.target` and `graphical.target`.
    The console target will start things like pulseaudio, ssh-agent (envoy), transmission, stuff like that.
    The graphical target will start xorg and then other things like the WM, set the wallpaper.. you get the idea. Obviously the graphical target will want the console target.
    Now, the part I wanted to get some feedback on is this: I would like a systemd --user instance to only be started once after my first login, not once per session.
    So for example, I login from vt1 and it brings systemd --user up to the graphical.target. Then if I later SSH in from somewhere, it won't start a new systemd --user session (Ie, won't start pulse-audio, transmission-daemon, etc).
    However, if I haven't logged into my machine yet and I SSH in, it will start up systemd --user and will start the console.target. If I then later login via vt1 it will see that there's already a systemd --user session started and start the graphical.target
    Does this make sense? Is it a bad idea?

    You could make a column in the database, and when the
    information is set (emailed) make the value to be 0, then when they
    first register use a IF recodset("column_name") = 0 Then
    reponse.redirect("filloutpage.asp") end if, then when they fill out
    the info have a hidden form field thats updates the value to 1. on
    the login page after the first if make another IF
    recordset("column_name") = 1 Then response.redirect("index.asp")
    end if.
    i have forms that have three different redirect based on user
    input, and you could do the same thing you could add the one for
    the first time to dw made code, here is an example, you could
    change the request.form to a recordset value and it will work.
    If Request.Form("select") = "Self" Then
    MM_editRedirectUrl = "FridaySchedule.asp"
    Response.Redirect(MM_editRedirectUrl)
    End IF
    If Session("MM_AdminEdit") = "True" Then
    MM_editRedirectUrl = "FridayScheduleAdmin.asp"
    Response.Redirect(MM_editRedirectUrl)
    End IF
    MM_editRedirectUrl = "FridayScheduleDept.asp"
    If (Request.QueryString <> "") Then
    If (InStr(1, MM_editRedirectUrl, "?", vbTextCompare) = 0)
    Then
    MM_editRedirectUrl = MM_editRedirectUrl & "?" &
    Request.QueryString
    Else
    MM_editRedirectUrl = MM_editRedirectUrl & "&" &
    Request.QueryString
    End If
    End If
    Response.Redirect(MM_editRedirectUrl)

  • Avg number of open cursors per session

    We've been noticing a large number of open cursors open per session in our database, these users being Oracle Forms users. There are quite a few 'bells & whistles' in this vendor-supplied application with many round trips to the database. The warning we were receiving was induced by an alert that we had set up within OEM.
    It got me wondering then, what a large number of cursors per process really was. We're seeing between 10-80 open cursors. The init parm OPEN_CURSORS has a default value of 50 upon installation (which is per session), so the max of 80 doesn't seem too much higher.
    Are we really experiencing a large # of open cursors per session? Does someone have a means of estimating the max # of cursors that one would expect based upon CPU & memory resources? I can't find anything in the documentation.
    Thanks,
    Chuck

    There is an OPEN_CURSORS parameter in the init.ora file,
    I want to know the impact of number of open cursors on performance
    (ie., how many open cursors would be appropriate for an instance)There shouldn't be a performance issue here. The value needs to be set based on how many open cursors you want to allow simultaneously. If you set the value too low, applications will get the "too many cursors open" error when they try to open a new cursor. If you're not having problems, or if you don't know how many open cursors you're likely to have, I wouldn't change this parameter.
    Justin

  • Lion 10.7.2 On both mac book pro and iMac, both with Lion 10.7.2, obtain repeated iCal event notifications from calendar or address book.  Cannot turn these off.  They repeat several times per session and every time computer is used.  How to diagnose this

    Lion 10.7.2 On both mac book pro and iMac, both with Lion 10.7.2, obtain repeated iCal event notifications from calendar or address book.  Cannot turn these off.  They repeat several times per session and every time computer is used.  How to diagnose this?

    First, uninstall "SuperTV" (whatever that is) according to the developer's instructions. It isn't working and it's filling the log with noise.
    If you have more than one user account, these instructions must be carried out as an administrator.
    Launch the Console application.
    Step 1
    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left.
    Enter "BOOT_TIME" (without the quotes) in the search box. Note the timestamps of those log messages, which refer to the times when the system was booted. Now clear the search box and scroll back in the log to the last boot time when you had the problem. Post the messages logged before the boot, while the system was unresponsive or was failing to shut down. Please include the BOOT_TIME message at the end of the log extract.
    Post the log text, please, not a screenshot. If there are runs of repeated messages, post only one example of each. Don’t post many repetitions of the same message. When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.
    PLEASE DO NOT INDISCRIMINATELY DUMP THOUSANDS OF LINES FROM THE LOG INTO A MESSAGE. If you do that, I will not respond.
    Important: Some private information, such as your name, may appear in the log. Edit it out by search-and-replace in a text editor before posting.
    Step 2
    Still in Console, look under System Diagnostic Reports for crash or panic logs, and post the most recent one, if any. In the interest of privacy, I suggest you edit out the “Anonymous UUID,” a long string of letters, numbers, and dashes in the header of the report, if present (it may not be.) Please don’t post shutdownStall, spin, or hang logs — they're very long and not helpful.

  • Public and Authenticated App with Authorization Scheme once per session

    I have a question . . .
    Let's say I have an application and at the application level I have an authorization scheme (auth1). If auth1 is set up to evaluate once per session, does it authenticate for the public user, then pass me back to the page and then check then evaluate the auth1 scheme. Or does it evaluate the auth1 scheme, then log in, then return to the page. Is it the same regardless of authentication scheme (e.g. Oracle SSO).
    It may make a big difference. If the authorization sheme is based upon the user (most will be) then setting it to evaluate once per session can be a real problem. If it evaluates before the user logs in, then it won't really work.
    This is an even bigger question when the application does not have a authorization scheme at the application level and allows public pages. If a page that is not public has an authorization scheme set, and the user goes directly to that page, it seems to authenticate the authorization scheme and then logs you in, but does not re-evaluate authorization scheme after you are logged in. Is this accurate? I realize that I could set it up to evaluate for every page view, but I really only need it once after login.
    Is this clear?

    Anton,
    It seems that all authorization schemes that are set to evaluate once per session are evaluated with the beginning establishment of a session.Sort of correct. Authorization schemes don't get evaluated until the component that uses them is considered for rendering or processing. So if the authorization scheme is attached to a page, it won't fire until the page is requested. If another component uses that scheme first, the evaluation will happen then and will not happen again during the session.
    What if I have another page that is not public. If it is the first page I go to, what happens. Obviously, I get redirected to login, then login. Do the authorization schemes get evaluated at this point?Yes, assuming the authorization scheme is used by the page, the scheme is evaluated during the first rendering or processing of the page in the session, after the authentication step.
    Now, what if I have a page that is public, but also has an auth scheme (odd, but could happen). Now what happens, does the auth scheme get evaluated before or after login?During the rendering or processing of the page after the authentication step. For a public page, the authentication step is performed up to the point where it determines that no authentication is required.
    OK, now let's add in Application level auth scheme. I can have public or private pages. If I go to a private page, when does the app level auth scheme kick in? How about for a public page?When an application uses an authorization scheme, it gets evaluated before the authorization scheme (if any) for the page that is being requested, so the public/private property of the page doesn't matter.
    General advice: when an authorization scheme uses :APP_USER, it doesn't work well to have it fire once per session because it'll get run before authentication to the application occurs, which sets APP_USER. You can have such schemes fire once per page view and for PL/SQL function-type schemes, have them give a "pass" when the current page is the login page, that kind of thing.
    In addition, if the overhead of running a scheme is high, one can set an application-level item to indicate that a once-per-page scheme has already run satisfactorily. The PL/SQL-type schemes can access the value of such an item to skip the expensive part of the evaluation and return true immediately.
    Finally, the htmldb_application.reset_security_check API can be called in order to reset the "fired" status of all authorization schemes in the session, allowing them to be re-evaluated if/when they are encountered again in the session.
    Hope this helps,
    Scott

  • Once per session, connected anyway

    I have an authentication scheme that is set to once per session. The users are defined in oid and have to logon using sso.
    So far so good. But in following scenario it goes wrong.
    1. User enters the htmldb url
    2. User gets the logon screen from sso
    3. User logs in and is than forwarded to the application where the authorisation scheme says him he has no access and he is redirected to a public page that tells him this.
    4. the user presses the 'Back' key on the browser, so he gets the login screen again.
    5. he enters again his username and password, and enters.
    -> now he is logged in and gets the screen he is not allowed to.
    What goes wrong here? Why does the session not remember that this user has no access ?
    Grtz,
    Chris.

    Scott,
    The solution of htmldb_util.reset_authorizations works fine. But in the end we choose another option.
    We are using the error page now to display wether the user has no access to the application. It looks like the user has access to the error pag even if he has no access to any of the application pages. Now it works fine.
    Now the authorization also returns false.
    Tnx for the replies,
    Chris.

  • Web service request ....one db connection per session OR all share one...

    in servlet i use
    public void init(ServletConfig config) throws ServletException { }
    so it only gets the db connection once per session
    now that I am working on a web service....im not sure how to do something similiar
    I want to either have all request coming in to use the same ONE connection OR maybe one created per session
    I have way too many web service requests and it creates too many jdbc connections....what can i do to pervent this?
    I dont care if they have to wait longer;
    I just want to cut down the number of jdbc connections to 1 to 2
    any help appreciated, thanks

    You want to use a connection pool. If you just use one connection, your web users are likely to be waiting on the availabilty of the connection. A pool will let you set whatever maximum you want; 1 or 100...
    There are a number of database connection pooling options. One of the morepopular is DBCP, part of the Apache project, which is free and open source.
    http://jakarta.apache.org/commons/dbcp/
    There are other such "drop in" poolers and some database vendors are now supplying connection pooling in their drivers.

  • Per-session VRF and IPv6

    Hello. I cant get Per-session VRF feature working with IPv6 protocol. IPv4 is working fine.
    Here is what i've got:
    test1 Cleartext-Password := "test"
    Framed-Protocol = PPP,
    Service-Type == Framed-User,
    Cisco-AVPair += "ipv6:delegated-ipv6-pool=ppp_delegate_56_v6_pool_vrf_no_nat",
    Cisco-AVPair += "ip:vrf-id=NoNAT",
    Cisco-AVPair += "ip:ip-unnumbered=Loopback1",
    Cisco-AVPair += "ip:addr-pool=real"
    Cisco-AVPair += "ipv6:ipv6-addr-pool=ppp_link_v6_pool_vrf_no_nat"
    test2 Cleartext-Password := "test"
    Framed-Protocol = PPP,
    Service-Type == Framed-User,
    Cisco-AVPair += "ipv6:delegated-ipv6-pool=ppp_delegate_56_v6_pool",
    Cisco-AVPair += "lcp:interface-config=ip nat inside"
    #sho run
    interface Loopback0
    ip address ****
    ipv6 address 2001:DB8::20/128
    ipv6 enable
    interface Loopback1
    vrf forwarding NoNAT
    ip address *****
    ipv6 address 2001:DB8::21/128
     ipv6 enable
    ipv6 dhcp pool AAA_dhcpv6_pool
    prefix-delegation aaa method-list FREERADIUS
    ip local pool pool192_168 192.168.128.0 192.168.255.254
    ip local pool real *.*.*.* *.*.*.*
    ipv6 local pool ppp_delegate_56_v6_pool 2001:DB8:3::/48 56
    ipv6 local pool ppp_link_v6_pool 2001:DB8:1::/49 64
    ipv6 local pool ppp_delegate_56_v6_pool_vrf_no_nat 2001:DB8:6::/48 56
    ipv6 local pool ppp_link_v6_pool_vrf_no_nat 2001:DB8:4::/49 64
    interface Virtual-Template1
    ip unnumbered Loopback0
    ipv6 unnumbered Loopback0
    ipv6 enable
    no ipv6 nd ra suppress
    ipv6 dhcp server AAA_dhcpv6_pool
    peer default ip address pool pool192_168
    peer default ipv6 pool ppp_link_v6_pool
    ! non-related config skipped
    User test2 receive IPv4 private address and full IPv6 service: address negotiated on the link and delegation DHCPv6 service.
    User test1 receive IPv4 real address only and no IPv6 at all.
    Here is the debug, take a look at the bold line:
    Jul  8 10:13:41: RADIUS(000000DF): Send Access-Request to 10.0.6.10:1812 id 1645/139, len 207
    Jul  8 10:13:41: RADIUS:  authenticator B8 8A 07 F3 D8 90 A5 FE - B0 10 9F 51 B2 4F 7E 0A
    Jul  8 10:13:41: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    Jul  8 10:13:41: RADIUS:  User-Name           [1]   6   "test"
    Jul  8 10:13:41: RADIUS:  CHAP-Password       [3]   19  *
    Jul  8 10:13:41: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    Jul  8 10:13:41: RADIUS:  NAS-Port            [5]   6   0
    Jul  8 10:13:41: RADIUS:  NAS-Port-Id         [87]  13  "0/1/0/2.301"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  41
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=5254.0018.9fb1"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  39
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   33  "circuit-id-tag=SNR eth 001,0301"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  39
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   33  "remote-id-tag=f8-f0-82-10-9b-9d"
    Jul  8 10:13:41: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    Jul  8 10:13:41: RADIUS:  NAS-IP-Address      [4]   6   10.0.6.21
    Jul  8 10:13:41: RADIUS(000000DF): Sending a IPv4 Radius Packet
    Jul  8 10:13:41: RADIUS(000000DF): Started 5 sec timeout
    Jul  8 10:13:41: RADIUS: Received from id 1645/139 10.0.6.10:1812, Access-Accept, len 236
    Jul  8 10:13:41: RADIUS:  authenticator 9C E6 3B 43 A3 58 06 AB - 17 99 AD 06 FF C6 9A 35
    Jul  8 10:13:41: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    Jul  8 10:13:41: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  67
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   61  "ipv6:delegated-ipv6-pool=ppp_delegate_56_v6_pool_vrf_no_nat"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  23
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   17  "ip:vrf-id=NoNAT"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  34
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   28  "ip:ip-unnumbered=Loopback1"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  25
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   19  "ip:addr-pool=real"
    Jul  8 10:13:41: RADIUS:  Vendor, Cisco       [26]  55
    Jul  8 10:13:41: RADIUS:   Cisco AVpair       [1]   49  "ipv6:ipv6-addr-pool=ppp_link_v6_pool_vrf_no_nat"
    Jul  8 10:13:41: RADIUS(000000DF): Received from id 1645/139
    Jul  8 10:13:41: ppp202 PPP SSS: Forwarding request
    Jul  8 10:13:41: ppp202 PPP: Phase is FORWARDING, Attempting Forward
    Jul  8 10:13:41: PPP: Bind ppp202 to Virtual-Access2.1
    Jul  8 10:13:41: Vi2.1 PPP: Static Bind peer_type[3]
    Jul  8 10:13:41: Vi2.1 PPP: Phase is AUTHENTICATING, Authenticated User
    Jul  8 10:13:41: Vi2.1 CHAP: O SUCCESS id 1 len 4
    Jul  8 10:13:41: Vi2.1 PPP: Phase is UP
    Jul  8 10:13:41: Vi2.1 IPCP: Protocol configured, start CP. state[Initial]
    Jul  8 10:13:41: Vi2.1 IPCP: Event[OPEN] State[Initial to Starting]
    Jul  8 10:13:41: Vi2.1 IPCP: O CONFREQ [Starting] id 1 len 10
    Jul  8 10:13:41: Vi2.1 IPCP:    Address *.*.*.8 (0x0306B92EC408)
    Jul  8 10:13:41: Vi2.1 IPCP: Event[UP] State[Starting to REQsent]
    Jul  8 10:13:41: Vi2.1 PPP: Send Message[Static Bind Response]
    Jul  8 10:13:41: Vi2.1 IPCP: I CONFREQ [REQsent] id 1 len 22
    Jul  8 10:13:41: Vi2.1 IPCP:    Address 0.0.0.0 (0x030600000000)
    Jul  8 10:13:41: Vi2.1 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
    Jul  8 10:13:41: Vi2.1 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
    Jul  8 10:13:41: Vi2.1 IPCP AUTHOR: Start.  Her address 0.0.0.0, we want 0.0.0.0
    Jul  8 10:13:41: Vi2.1 IPCP AUTHOR: Says use pool real
    Jul  8 10:13:41: Vi2.1 IPCP AUTHOR: Pool returned *.*.*.11
    Jul  8 10:13:41: Vi2.1 IPCP AUTHOR: Done.  Her address 0.0.0.0, we want *.*.*.11
    Jul  8 10:13:41: Vi2.1 IPCP: O CONFNAK [REQsent] id 1 len 22
    Jul  8 10:13:41: Vi2.1 IPCP:    Address *.*.*.11 (0x0306B92EC50B)
    Jul  8 10:13:41: Vi2.1 IPCP:    PrimaryDNS 8.8.8.8 (0x810608080808)
    Jul  8 10:13:41: Vi2.1 IPCP:    SecondaryDNS 8.8.4.4 (0x830608080404)
    Jul  8 10:13:41: Vi2.1 IPCP: Event[Receive ConfReq-] State[REQsent to REQsent]
    Jul  8 10:13:41: Vi2.1 IPV6CP: I CONFREQ [UNKNOWN] id 1 len 14
    Jul  8 10:13:41: Vi2.1 IPV6CP:    Interface-Id 11BF:9891:6F31:7C15 (0x010A11BF98916F317C15)
    Jul  8 10:13:41: Vi2.1 LCP: O PROTREJ [Open] id 2 len 20 protocol IPV6CP (0x0101000E010A11BF98916F317C15)
    Jul  8 10:13:41: Vi2.1 IPCP: I CONFACK [REQsent] id 1 len 10
    Jul  8 10:13:41: Vi2.1 IPCP:    Address *.*.*.8 (0x0306B92EC408)
    Jul  8 10:13:41: Vi2.1 IPCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
    Jul  8 10:13:41: Vi2.1 IPCP: I CONFREQ [ACKrcvd] id 2 len 22
    Jul  8 10:13:41: Vi2.1 IPCP:    Address *.*.*.11 (0x0306B92EC50B)
    Jul  8 10:13:41: Vi2.1 IPCP:    PrimaryDNS 8.8.8.8 (0x810608080808)
    Jul  8 10:13:41: Vi2.1 IPCP:    SecondaryDNS 8.8.4.4 (0x830608080404)
    Jul  8 10:13:41: Vi2.1 IPCP: O CONFACK [ACKrcvd] id 2 len 22
    Jul  8 10:13:41: Vi2.1 IPCP:    Address *.*.*.11 (0x0306B92EC50B)
    Jul  8 10:13:41: Vi2.1 IPCP:    PrimaryDNS 8.8.8.8 (0x810608080808)
    Jul  8 10:13:41: Vi2.1 IPCP:    SecondaryDNS 8.8.4.4 (0x830608080404)
    Jul  8 10:13:41: Vi2.1 IPCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
    Jul  8 10:13:41: Vi2.1 IPCP: State is Open
    Jul  8 10:13:41: Vi2.1 Added to neighbor route AVL tree: topoid 2, address *.*.*.11
    Jul  8 10:13:41: Vi2.1 IPCP: Install route to *.*.*.11
    Jul  8 10:13:41: RADIUS/ENCODE(000000DF):Orig. component type = PPPoE
    Jul  8 10:13:41: RADIUS(000000DF): Config NAS IP: 10.0.6.21
    Jul  8 10:13:41: RADIUS(000000DF): Config NAS IPv6: ::
    Jul  8 10:13:41: RADIUS(000000DF): sending
    Jul  8 10:13:41: RADIUS(000000DF): Send Accounting-Request to 10.0.6.10:1813 id 1646/109, len 264
    Any suggestions?

    Fixed one problem and moved into other.
    I've added
    Cisco-AVPair += "lcp:interface-config=ipv6 unnumbered Loopback1"
    to user profile, but stumbled into another problem: router ignores
    Cisco-AVPair += "ipv6:ipv6-addr-pool=ppp_link_v6_pool"
    regardless of vrf, even on usual user profile

  • Sort by columns once per session

    Hi there, I am using apex 3.1 and I have a report generated by a pl/sql function. There are several columns on which the user might sort. Is it possible to reset the sorting preferences when the user logs in? (like: a process running once per session?)
    thx in advance
    Edited by: 814932 on 23-Nov-2010 08:00

    You can use the <tt>apex_util.remove_sort_preferences</tt> method (although it is a bit of a blunt instrument). See the Admin guide for more information on user preferences.
    To run it once per session, code the call as an Application Process with execution point On New Session After Authentication.

  • Per session QoS for LNS

    We have some LNSs running 12.4 SP Services, running with the following config (qos specific lines and currently not working):
    class-map match-all voice-signaling
    match access-group 101
    class-map match-all voice-traffic
    match access-group 102
    policy-map sub-policy
    class voice-traffic
    priority 240
    class voice-signaling
    bandwidth 16
    policy-map XXX_qos-voice
    class class-default
    shape average 256000
    fair-queue
    service-policy sub-policy
    interface Virtual-Template1
    ip unnumbered Loopback0
    ip mroute-cache
    no peer default ip address
    ppp authentication chap
    no clns route-cache
    access-list 101 remark -- SCCP/H323/MGCP/SIP --
    access-list 101 permit tcp any any range 2000 2002
    access-list 101 permit tcp any any eq 1720
    access-list 101 permit tcp any any range 11000 11999
    access-list 101 permit udp any any eq 2427
    access-list 101 permit udp any any eq 4569
    access-list 101 permit udp any any eq 5036
    access-list 101 permit udp any any eq 5060
    access-list 102 remark -- RTP Traffic --
    access-list 102 permit udp any any range 16384 32767
    in the feature set for the IOS currently running it suggests this configuration should work, however it will not apply the policy via the Cisco-AVPair command (the command is visible via the debug AAA per user so radius is working, even when we test it by applying the service-policy to the actual virtual-template it errors saying it will only work on an MPL bundle. From what I have read it is suggested that even though this feature is supposed to work, it does not in practice and an upgrade to a feature set which includes QoS:per session shaping and queueing on LNS is needed.
    If anyone has any experience of the or has any suggestion of if we can achieve our QoS for voice per session with the current IOS that would be great.

    This feature is not related to the NPE type. This feature is performance impacting so you should do some tests to see if your NPE-400 can support the number of L2TP tunnels you want with this feature enabled. If it's not the case, you will have to upgrade your NPE.
    HTH
    Laurent.

  • Max-streaming-connections-per-session limit

    Hello,
    i'm trying BlazeDS with Air app.
    I set blazeDs on a Jboss Server with JMS adapter.
    I configure it with a streamingAMF channel.
    In user agent configuration i put msie, firefox value to 10 for the max-streaming-connections-per-session limit param.
    In Air client configuration i instantiate a producer and a consumer on the same streaming AMF channel.
    After the consumer.subscribe() i launch the producer.connect() on the server i get this error :
    14:25:20,015 INFO [STDOUT] [BlazeDS] Endpoint with id 'my-streaming-amf' cannot grant streaming connection to FlexClient with id '497031A2-7B0D-019A-0E1D-7622A-A631D28' because max-streaming-connections-per-session limit of '1' has been reached.
    Is it a limitation of use of blazeDs with Air app ?

    First, if you change the limit to 10, then it should be 10 and not 1. If you still see 1, then please log a bug.
    Second, you really want this limit to be 1 in IE and 4 in Firefox 2. But there's no reason to have more than 1 streaming connection from the server to the client unless you need to talk to two different endpoints.

  • How to find out the Transactions used per month & the USER who used that

    Hi,
    1)How to find out the Transactions used per month & the USER who used that?
    2)and can i get the above same for minimum 20 month?
    System : SAP- Enterprise Core Component.

    You can use my program...
    *& Report  Z_ABAP_TCODE_MONITOR
    *****&  Program Type          : Report                                 *
    *****&  Title                 : Z_ABAP_TCODE_MONITOR                   *
    *****&  Transaction code      : ZTCODE_USAGE                           *
    *****&  Developer name        : Shailendra Kolakaluri                  *
    *****&  Deveopment start date : 26 th Dec 2011                         *
    *****&  Development Package   : ZDEV                                   *
    *****&  Transport No          : DEVK906086                                       *
    *****&  Program Description   : This program is to display
    *List all tcodes executed during previous day.
    *& Show the number of users executing tcodes
    *& Modification history
    REPORT  Z_ABAP_TCODE_MONITOR.
    *& List all tcodes executed during previous day.
    *& Show the number of users executing tcodes
    TYPE-POOLS : slis.
    DATA: ind TYPE i,
          fcat TYPE slis_t_fieldcat_alv WITH HEADER LINE,
          layout TYPE slis_layout_alv,
          variant TYPE disvariant,
          events  TYPE slis_t_event WITH HEADER LINE,
          heading TYPE slis_t_listheader WITH HEADER LINE.
    *REPORT  z_report_usage.
    TYPES: BEGIN OF zusertcode,
      date   TYPE swncdatum,
      user   TYPE swncuname,
      mandt     TYPE swncmandt,
      tcode     TYPE swnctcode,
      report TYPE swncreportname,
      count     TYPE swncshcnt,
    END OF zusertcode.
    *data   : date type n.
    DATA: t_usertcode  TYPE swnc_t_aggusertcode,
          wa_usertcode TYPE swncaggusertcode,
          wa           TYPE zusertcode,
          t_ut         TYPE STANDARD TABLE OF zusertcode,
          wa_result    TYPE zusertcode,
          t_result     TYPE STANDARD TABLE OF zusertcode.
    PARAMETER: month TYPE dats DEFAULT sy-datum.
    *PARAMETER: date TYPE dats.
    *select-options : username for wa_usertcode-account.
    START-OF-SELECTION.
    PERFORM get_data.
    PERFORM get_fieldcatalog.
      PERFORM set_layout.
    PERFORM get_event.
    PERFORM get_comment.
      PERFORM display_data.
    FORM get_data .
    *date = sy-datum - 2 .
    After start-of-selection add this line (parameter Month required 01 as day).
      concatenate month+0(6) '01' into month.
      CALL FUNCTION 'SWNC_COLLECTOR_GET_AGGREGATES'
        EXPORTING
          component     = 'TOTAL'
          ASSIGNDSYS    = 'DEV'
          periodtype    = 'M'
          periodstrt    = month
        TABLES
          usertcode     = t_usertcode
        EXCEPTIONS
          no_data_found = 1
          OTHERS        = 2.
      wa-date  = month.
    *wa-date  = date.
      wa-mandt = sy-mandt.
    wa_usertcode-account = username.
      LOOP AT t_usertcode INTO wa_usertcode.
        wa-user = wa_usertcode-account.
        IF wa_usertcode-entry_id+72 = 'T'.
          wa-tcode  = wa_usertcode-entry_id.
          wa-report = space.
        ELSE.
          wa-tcode  = space.
          wa-report = wa_usertcode-entry_id.
        ENDIF.
        COLLECT wa INTO t_ut.
      ENDLOOP.
      SORT t_ut BY report ASCENDING.
      CLEAR: wa, wa_result.
    endform.
    FORM get_fieldcatalog .
    fcat-tabname     = 't_ut'.
    fcat-fieldname   = 'DATE'.
    fcat-seltext_l   = 'Date'.
    fcat-key         = 'X'.
    APPEND fcat.
      CLEAR fcat.
      fcat-tabname     = 't_ut'.
      fcat-fieldname   = 'MANDT'.
      fcat-seltext_l   = 'Client'.
      fcat-key         = 'X'.
      APPEND fcat.
      CLEAR fcat.
      fcat-tabname     = 't_ut'.
      fcat-fieldname   = 'USER'.
      fcat-seltext_l   = 'User Name'.
      fcat-key         = 'X'.
      APPEND fcat.
      CLEAR fcat.
      fcat-tabname     = 't_ut'.
      fcat-fieldname   = 'TCODE'.
      fcat-seltext_l   = 'Transaction Code'.
      fcat-key         = 'X'.
      APPEND fcat.
    ENDFORM.
    *&      Form  SET_LAYOUT
          text
    -->  p1        text
    <--  p2        text
    FORM set_layout .
      layout-colwidth_optimize = 'X'.
    ENDFORM.                    " SET_LAYOUT
    *&      Form  GET_EVENT
          text
    -->  p1        text
    <--  p2        text
    *FORM get_event .
    events-name = slis_ev_top_of_page.
    events-form = 'TOP_OF_PAGE'.
    APPEND events.
    *ENDFORM.                    " GET_EVENT
    **&      Form  GET_COMMENT
          text
    -->  p1        text
    <--  p2        text
    *FORM get_comment .
    DATA: text(30).
    text = 'Billing Report'.
    heading-typ = 'H'.
    heading-info = text.
    APPEND heading.
    *ENDFORM.                    " GET_COMMENT
    **&      Form  top_of_page
          text
    -->  p1        text
    <--  p2        text
    *FORM top_of_page .
    CALL FUNCTION 'REUSE_ALV_COMMENTARY_WRITE'
       EXPORTING
         it_list_commentary       = heading[]
      I_LOGO                   =
      I_END_OF_LIST_GRID       =
    *ENDFORM.                    " top_of_page
    *&      Form  DISPLAY_DATA
          text
    -->  p1        text
    <--  p2        text
    FORM display_data .
      sort t_ut[].
    DELETE ADJACENT DUPLICATES FROM t_ut[] COMPARING ALL FIELDS.
      CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'
        EXPORTING
          i_callback_program = sy-cprog
          is_layout          = layout
          it_fieldcat        = fcat[]
          i_save             = 'A'
          is_variant         = variant
          it_events          = events[]
        TABLES
          t_outtab           = t_ut
        EXCEPTIONS
          program_error      = 1
          OTHERS             = 2.
      IF sy-subrc <> 0.
        MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno
                WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4.
      ENDIF.
    ENDFORM.                    " DISPLAY_DATA

  • Windows 8.1 MDM not responding to more than one SyncML from MDM server per session

    Here is the behaviour i see, which was not expected by Windows 8.1.
    1) Device is enrolled
    2) Client initiates the connection with the MDM server defined in provisioning XML during enrollment.
    3) MDM Server sends some commands as a SyncML response.
    4) Client accepts the commands and sends Status and results.
    5) Again MDM Server sends some commands as a SyncML response.
    6) Client doesn't respond to these commands or not sending any SyncML. Here is the problem that i am referring to.
    We are capturing the traffic in fiddler and found that device is not sending the next request where we are expecting the status for these commands. 
    The same is being repeated in all the requests client initiates. DM Client responds back only for one syncML sent by the MDM server per session.
    Is this the expected behaviour with Windows 8.1? Or are we doing something wrong to see this behaviour?
    Below is the SyncML for which I am expecting the response from the DM client. (Note: I got the response for the same SyncML in the first connection, but not in the second.)
    <SyncML xml:lang="en" xmlns="syncml:SYNCML1.2">
      <SyncHdr>
        <VerDTD>1.2</VerDTD>
        <VerProto>DM/1.2</VerProto>
        <SessionID>1</SessionID>
        <MsgID>1</MsgID>
        <Target>
          <LocURI>0</LocURI>
        </Target>
        <Source>
          <LocURI>https://####</LocURI>
          <LocName>AfariaWinPhoneProvider</LocName>
        </Source>
        <RespURI>https://####</RespURI>
      </SyncHdr>
      <SyncBody>
        <Status>
          <CmdID>1</CmdID>
          <MsgRef>2</MsgRef>
          <CmdRef>0</CmdRef>
          <Cmd>SyncHdr</Cmd>
          <TargetRef>https://####</TargetRef>
          <SourceRef>0</SourceRef>
          <Data>200</Data>
        </Status>
        <Get>
          <CmdID>2</CmdID>
          <Item>
            <Target>
              <LocURI>./cimv2/Win32_ComputerSystemProduct</LocURI>
            </Target>
          </Item>
        </Get>
        <Final />
      </SyncBody>
    </SyncML>

    Hello Sreekanth,
    I am facing similar issue, here is the behaviour description:
    1) Device is enrolled
    2) Client initiates the connection with the MDM server defined in provisioning XML during enrollment.
    3) MDM Server sends some commands as a SyncML response.
     4) Client doesn't respond to these commands or not sending any SyncML. 
    The same is being repeated in all client request. 
    Below is the SyncML
    for which I am expecting the response from the DM client:
    <SyncML xmlns="SYNCML:SYNCML1.2">
        <SyncHdr>
            <VerDTD>1.2</VerDTD>
            <VerProto>DM/1.2</VerProto>
            <SessionID>1</SessionID>
            <MsgID>1</MsgID>
            <Target>
                <LocURI>9302116</LocURI>
            </Target>
            <Source>
                <LocURI>https://#####</LocURI>
            </Source>
        </SyncHdr>
        <SyncBody>
            <Status>
                <CmdID>1</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>0</CmdRef>
                <Cmd>SyncHdr</Cmd>
                <TargetRef>9302116</TargetRef>
                <Data>212</Data>
            </Status>
            <Status>
                <CmdID>2</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>2</CmdRef>
                <Cmd>Alert</Cmd>
                <Data>200</Data>
            </Status>
            <Status>
                <CmdID>3</CmdID>
                <MsgRef>1</MsgRef>
                <CmdRef>3</CmdRef>
                <Cmd>Replace</Cmd>
                <TargetRef>./devinf12</TargetRef>
                <Data>200</Data>
            </Status>
            <Get>
                <CmdID>75</CmdID>
                <Item>
                    <Target>
                        <LocURI>./DevDetail/SwV</LocURI>
                    </Target>
                </Item>
            </Get>
        </SyncBody>
    </SyncML>
    Here
    we had tried sending 
     <Target>
                <LocURI>0</LocURI>
            </Target>
    But it didn't worked.

  • Grant debug connect session to user

    I understand that if DBA hasn't granted following option to "user" following way:
    grant debug connect session to user;, then "user" wil lget following error when she tries to debug:
    ORA-0131:Insufficient Priviledges
    Debugging requires Debug connect session system priviledgesIs there any explanation why DBA decides to not grant such privilege? Maybe such privilege slows down something? Maybe it can create security "hole"? Maybe there is another good explanation?
    The "user" in this example was Schema/Account ment for Development personell who developes functionality, but it doesn't matter i think what kind the "user" is.
    so why you think i don't have such privilege, what bad could such privilege when granted give?

    Its just that You have not been Granted that Privilege. Mostly in what ever shop i have worked Such grants are given on request Base.
    Debugging is a Developers Right and no one can denie it.
    But i never use any debugging tool. I only relay on my Instrumented Code.

Maybe you are looking for

  • How can i get an MP4 video file to work in iMovie 08'?

    I'm currently editing a wedding video i recorded on my Sony DV camcorder in iMovie 08' and want to splice a MP4 video file (from a mobile phone- make unknown) of the married couple on their first dance into the footage but can't How do i go about ach

  • How to get yahoo mail in notification in macbook pro in mountain lion os

    how to get yahoo mail in notification in macbook pro in mountain lion os??

  • Environment recommendations

    Hey everyone. I was hoping I could get some advice from those of you who have set up a production servlet environment before with regards to what components you are using. As this is a small servlet/jsp application and I am just outta school I don't

  • "+" Next to ringtone

    Hi, I read through the user manual but didn't see this one listed. When I'm looking at my contacts and choose to edit information, there is a green "+" next to the ringtone field. I'm really just wondering what this does, as nothing happens once I ta

  • Photoshop CS5 canvas missing.

    Hello, recently I have been running into an issue whenever I try to open up PhotoShop CS5 on my Mac. While trying to open up a document, whether it be a brand new one or opening up a previous file, the canvas is missing. On the side in my workspace a