Issue with af:tree's visible=false on IE

Hello,
I have an ADF page containing two af:tree components. For both rendered is set to true and visibility is set to false. For both the trees height has been set to 500px. Based on selection criteria either of the two trees has to be made visible. No issues on Firefox. However on IE, both the trees are occupying space even though visibility is set to false. When I try to show the second tree, it shows up down below after 500px of white space. So, even though first tree is not displayed, it still occupies the space. Please let me know the solution.
Thanks,
Lalitha.

Hi,
sounds like a bug to me. You can try an af:switcher component, though it only shows one tree at a time then
Frank

Similar Messages

  • Layout issue with af:tree component

    I am using af:tree component but I am finding layout issue with it. I have a requirement where in I need the tree to stretch to the available space but a horizontal and a vertical scrollbar comes up automatically. Is there a way to handle this issue?

    User, without your jdev version it's hard to help.
    Have you embedded the tree component in a stretch layout?
    Timo

  • Issue with ADF Tree Table

    Hi,
    I have the following requirement where i need to display a tree table. Here is how the initial implementation is:
    I have created the read only view for : ManagersVO > PoolsVO > MachinesVO. Where 'MachinesVO' is the destination view. And created view links between ManagersVO & PoolsVO using ManagerId and PoolsVO & MachinesVO using PoolId.
    And using this implementation, successfully created tree table on the UI. Now we got an enhancement for this:
    i.e., MachinesVO should return list of machines as per user logs in. i.e., we have 4 different roles. 'Super Admin', 'Sys Admin', 'App Admin', 'End User'. The default query for MachinesVO is for 'Super Admin'. The query for other user roles is different except the SELECT statement.
    The requirement is to dynamically change the query of MachinesVO based on user logs in and display the tree table accordingly. To implement the same i have tried using setQuery() operation on 'MachinesVO' which results with the following error:
    JBO-26016: InvalidOperException
    Cause: You cannot set customer query (calling setQuery()) on a view object if it is the detail view object in a master detail view link.
    Action: Do not call setQuery() if the view object is a detail.
    Can one suggest me a best solution to implement this.
    Thanks & Regards,
    Kiran

    Hi Navaneetha Krishnan,
    Here is how i implemented based on your comments. As i have tree table based 3 different VO's, created the following method at middle view(i.e., PoolsVO).
    1.Tree Model hierarchy
    ManagersVO > PoolsVO > MachinesVO
    I actually want to filter the data at Machines level. Hence wrote a method at PoolsVOImpls and exposed it in the PoolsVO client interface. Here is the code that i have placed in the PoolVOImpl
    public class PoolsVOImpl extends ViewObjectImpl implements PoolsVO{
         * This is the default constructor (do not remove).
        public PoolsVOImpl () {
      public void filterMachinesDataByUserRole(String userRole,String vzId){
        Row row = getCurrentRow();
        String query = "";
        if(row != null){
          RowSet rowSet = (RowSet)row.getAttribute("MachinesVO");
          if(rowSet != null){
            MachinesVOImpl machinesVOImpl = (MachinesVOImpl)rowSet.getViewObject();
            if(userRole.equalsIgnoreCase("SYS ADMIN")){
                    machinesVOImpl .setWhereClause(query related to sysadmin);
             //Similarly for other user roles.
             executeQuery();
    }And this piece of code needs to be executed before the jsff(which has the tree table) renders. Hence, i created a this methodAction as a default activity in the respective taskflow where the jsff is placed. Once this method get executed, the page should render the machines specific to the user.
    Here is the issue: getCurrentRow() method call is returning always NULL.
    Please correct me if i'm doing something wrong. I do tried the above mentioned approach by creating the method at '*ManagersVOImpl*' level too. Still the same issue.
    Thanks & Regards,
    Kiran

  • Issue With ADF Tree Expand/Collapse

    Hi All,
    I have a customer who is having issues using the af:tree component on a deployed application. When he tries to expand or collapse a node of the tree, the icon just blinks. This is occurring not only on our application, but also the Oracle ADF Rich Client Demo on http://jdevadf.oracle.com/adf-richclient-demo/faces/components/tree.jspx. He is using Internet Explorer v7.0.5730.13. As far as I can tell, our browser settings are identical, but I can use the tree without a problem.
    Any ideas as to what the problem could be?
    Thanks,
    Brad

    Unfortunately, Internet Explorer is the only browser that is authorized to run on his computer.
    Do you know of any specific IE settings that would cause the af:tree not to work?

  • Issue with alv tree

    Hello,
    Im using cl_gui_alv_tree_simple to display my internal table in a tree format with the internal table sorted out for three columns. Now when I click on the parent node i shud do an action and when I click at child i need to do a dofferent action. How do i know whether i clicked at the parent node or child node? Is there any event to identify this so that I can go ahead and do my operation for the respective parent and child. Thanks

    Use method get_outtab_line
    then you get the content of the clicked node
    METHOD handle_item_double_click.
        PERFORM detail USING node_key.
      ENDMETHOD.  
    FORM detail  USING    p_node_key.
      CALL METHOD tree1->get_outtab_line
        EXPORTING
          i_node_key    = p_node_key
        IMPORTING
          e_outtab_line = wa_tree.
      IF wa_tree-matnr IS INITIAL .
      ENDIF.
    if .
    endif.
    best regards
    Joerg

  • Issue with af:tree component

    Hi All,
    I am using JDev 11.1.1.6
    I am creating a tree component with collection model.I want to provide different action to each node,so I have defined an action attribute in the bean
    which I set in the constructor as shown below
    TestTree node1 = new TestTree("node1", "#{TreeBean.action1}");
    Is this the correct approach..This gives me "method not found " error when I click on the node.
    Below is the code for tree component :
    <af:tree value="#{TreeBean.model}" id="t1" var="node"
    styleClass="AFStretchWidth" inlineStyle="height:600.0px;">
    <f:facet name="nodeStamp">
    <af:commandLink text="#{node.label}" id="cl1" immediate="true"
    actionListener="#{node.action}"/>
    </f:facet>
    <f:facet name="pathStamp"/>
    </af:tree>

    Hi Vinay,
    UseCase :
    I want a tree showing navigation links . these navigation links will be used to open a new page in panelTabbed Layout.

  • Issue with af:tree

    The af:tree element always tries to display a node as if it has children, even if its child List is of size 0. The result is that all nodes appear as expandable folders and when you expand on a node that has no children you get a vertical line leading to nothing. Clearly this isn’t desirable. This behavior is seen even when using your packaged sample code as shown below:
    public class Person
    public Person(String name)
    _name = name;
    public String getName()
    return _name;
    public List getKids()
    return _kids;
    private final String _name;
    private final List _kids = new ArrayList();
    You can construct a tree by:
    Person john = new Person("John Smith");
    Person kim = new Person("Kim Smith");
    Person tom = new Person("Tom Smith");
    Person ira = new Person("Ira Wickrememsinghe");
    Person mallika = new Person("Mallika Wickremesinghe");
    john.getKids().add(kim);
    john.getKids().add(tom);
    ira.getKids().add(mallika);
    List people = new ArrayList();
    people.add(john);
    people.add(ira);
    Now you can construct a TreeModel by:
    TreeModel model = new ChildPropertyTreeModel(people, "kids");

    Hi,
    Even I have the same issue. How can I get it right in ADF Faces tree component.
    Thanks,
    Ankit

  • Navigation issue with af :tree

    Hi,
    I'm using an af: tree for navigation. My code looks like
    <af:tree var="node"
    value="#{navigationContext.treeNavigation.treeModel['startNode=/, includeStartNode=true, depth=1']}"
    id="t1" initiallyExpanded="true">
    <f:facet name="nodeStamp">
    <af:commandImageLink text="#{node.title}"
    id="sm_c1b"
    action="pprnav"
    actionListener="#{navigationContext.processAction}"
    inlineStyle="#{node.selected ? 'font-weight:bold;' : ''}">
    <f:attribute name="node" value="#{node}"/>
    </af:commandImageLink>
    </f:facet>
    </af:tree>
    The problem here is, I'm not able to navigate by clicking the link once all the nodes are expanded. When I collapse that node and click after expanding again, it works. But Once expanded I can go to only one child node. After that if i need to go to another link I need to collapse it and expand again. What is wrong here?

    Hi again.
    I have some doubts about your code
    What version of WebCenter are you?.
    About #{navigationContext.*treeNavigation*.treeModel['startNode=/, includeStartNode=true, depth=1']}.
    I never saw navigationContext.treeNavigation. It could be #{navigationContext.currentNavigationModel.treeModel[...?
    Your tree navigation is based on official doc http://docs.oracle.com/cd/E25054_01/webcenter.1111/e10148/jpsdg_view_comps.htm point Example 13-2 Simple Tree Navigation UI?
    Regards.

  • Issue with Performance Point Filters and SSRS when visibility is toggled

    I have a SSRS report that has the visibility toggled with the (+/-) sign. The report is SQL Server 2008 R2 / SharePoint Integrated in a SharePoint 2010 Site. The reports datasource is an Analysis Services database.
    I am displaying the report in a Performance Point Dashboard and am connecting it to Performance Point filters using the member unique name. The report filters correctly when the dashboard filters change. However, when I click to expand a plus sign to toggle
    the visibility, the report goes back to it's default filters of '[Dimension].[All]' and all data is returned, and the visibility is not expanded.
    I have confirmed that the report visibility toggling works in BIDS and via the report that is stored in SharePoint. I have also confirmed that it works when the report is stored in the native mode report server, and integrated with Performance
    Point in the same manner.
    So, I 'think' I have whittled the problem down to be the combination of SharePoint Integrated and Performance Point.
    Anyone have any ideas?
    Jewels

    Hi,
    I am having a similar issue with PerformancePoint SSRS and visibility togle. Were you able to figure this out?
    I have a report which calls a sub report. When I click on the report it passes parameters to sub report which works fine. But as soon as I click the visibility toggle, it goes back to default. Strange thing is that it works in PerformancePoint as a 
    stand alone report (sub report alone in PP). Just when it is a sub report and parameters are passed through url this issue happens.
    Any suggestions are welcome. I have spent hours trying to figure this one out.

  • Issue with child items of flex tree using QTP

    Hi,
    We are trying to automate Flex web application using QTP10.
    We are facing below issue with Flex tree when we try to automate a scenario of selecting a child item displayed in flex tree.
    Issue:
    On recording the step of selecting an item from Flex tree using QTP, the script displayed is .Select Index1. But when we replay it back no action is being performed.
    Also on object spy we are able to navigate only till flex tree and we are not able to spy child items of flex tree.On the web page the child items are displayed as radio buttons/checkboxes.
    Please provide a solution for me to this problem.
    Thanks

    Hi,
    You could perform a HTTP trace (using HTTP watch) and compare the OCI data in POST method for both users (the correct and incorrect ones).
    Perhaps there is some additional/missing information being passed from catalog to SRM.
    Kind regards,
    Ricardo

  • Continuing issues with two podcasts...

    I am back to having issues with posts not being visible in iTunes...
    The feeds are:
    feeds.feedburner.com/SosChurchStockholm
    and
    feeds,feedbruner.com/JohannesAmritzersPodcast
    And they do not validate when trying to verify them through feedvalidator.org.
    Again, thankful for any help that I can get on this.
    Thanks.
    /Peter

    Both feeds work as would be expected. However both have some episodes which do not have 'enclosure' tags containing the URLs of the media files, and as these are seen as not having any playable media by iTunes it does not display them.
    For example in 'Johannes Amritzer's Podcasts' the episode 'Signs of Hope' has the URL of a media file in the 'link' tag but this won't do you any good. So you need to do for that and similar episodes something that you did with others to make them iTunes-compliant but didn't do with these.
    The FeedValidator errors are not serious but should be addressed. In SOS Church Stockhom, in line 84 you need Jan not January (though it doesn't seem to upset iTunes) and there are other similar cases; and your duration in line 146 should be 1:25:15
    In the other feed Christianity is a sub-category, not a category - see
    http://www.apple.com/itunes/podcasts/specs.html#categories
    Similar points about the dates, and you have an incorrect day of the week. Not having a guid tag isn't fatal but it's preferable to have them as elsewhere.

  • Sg-300 - 3750 stack with SPANNING-TREE root problem.

    Morning. I think ive configured a few hundred switches, maybe a thousand in my time, but never have a faced such horribleness that is the SG-300. After this week, I think ill refuse to touch them.
    Got 2 voice vlans and running a few vrf's on a 3750 stack. but this discussion is about layer 2.
    2 x 3750 stacked
    1 x voice switch sg-300 company A voice vlan 18 - Po1 up to 3750 distributed etherchannel Po1 (LACP active both sides) 2 ports in channel
    1 x voice switch sg-300 company B voice vlan 19 - Po1 up to 3750 distributed etherchannel Po2 (LACP active both sides) 2 ports in channel
    Allowed vlans on both sides (command on Port-channel) are data A, Voice A, Mgt A to switch A
    Allowed vlans on both sides (command on Port-channel) are data B, Voice B, Mgt B to switch B
    It seems that these switches are limited to one voice vlan....
    and that spanning tree BPDU's are ignored (or not recevied- havnt released the shark yet).  let me explain.
    originally when using "smart port" the switch with the lowest mac address, whatever Voice vlan was configured would take over the other switche's voice vlan, argh what a nightmare.
    I gave up on the GUI as its far to complcated and have Almost got this working.
    I am now using auto voice vlan, but have disabled smart macro. I hope that disabling smart macro stop other switches from learning the switch with the lowest mac address's voice vlan.  So far so good - in the LAB. No where was it documented in the cli guide how do disable this stupid feature.
    DHCP is working from scope on core, can mange the switches etc etc, access vlan voice vlan all good (after a monster battle).
    Now I have an issue with spanning tree.
    spanning tree priority for vlans 1-4094 on the 3750 is 4096.
    spanning tree priority for vlans 1-4094 on the SG-300's is 6xxxx.
    ALL switches think that they are the root. (well the "logical" 3 of them) The 3750's for all vlans, and the SG-300 for the one instance as it doesnt support per vlan.  (I am not interested in trying MST here..this is not a datacentre)
    On the 3750's Ive tried ieee, pvst, rpvst, while matching the non per-vlan equivalent on the SG series.
    What is the difference between a General port and Trunk Port on a SG-300 specific to spanning tree, native vlans (when you can just configure an untagged vlan anyway!!) and what is the relevance to the way the bpdu's are carried?
    And why the need for a PVID, when you can tell a port what is tagged and what isnt.
    Does the trunk need Vlan1 to be explicitly allowed, and untagged? Does the Po trunk need to be a general port with PVID configured? in vlan 1?
    I need to sort this, as cannot put an access switch into production that thinks it is the root of the tree.  I wish I had a 2960.... a 3500XL..anything
    Does anyone have CLI commands that can help here?

    F.Y.I for catylyst heroes - here is the equivalent config for SG-300 - Vlan1 is required on the allowed list on the catylyst side (3xxx/4xxx/6xxx)
    In this example:
    VLANS - Voice on 188, data on 57, management on 56.
    conf t
    hostname XXX-VOICE-SWXX
    no passwords complexity enable
    username xxxx priv 15 password XXXXX
    enable password xxxxxx
    ip ssh server
    ip telnet server
    crypto key generate rsa
    macro auto disabled
    voice vlan state auto-enabled !(otherwise one switch controls your voice vlan….)
    vlan 56,57,188
    voice vlan id 188
    int vlan 56
    ip address 10.230.56.12 255.255.255.0
    int vlan1
    no ip add dhcp
    ip default-gateway 10.230.56.1
    interface range GE1 - 2
    switchport mode trunk
    channel-group 1 mode auto
    int range fa1 - 24
    switchport mode trunk
    switchport trunk allowed vlan add 188
    switchport trunk native vlan 57
    qos advanced
    qos advanced ports-trusted
    exit
    int Po1
    switchport trunk allowed vlan add 56,57,188
    switchport trunk native vlan 1
    do sh interfaces switchport po1
    !CATYLYST SIDE
    !Must Explicitly allow VLan1, this is not normal for catalysts - or spanning tree will not work ! Even though it’s the native vlan on both sides.
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,56,57,189
    switchport mode trunk

  • Issue with HTML tags visible in Outlook emails

    Hi everyone, I'm having an issue with a website I'm working on.
    On our site, we have a page that generates emails after certain events occur. These are sent to a forwarding address on our mail server, which is then sent to several users on our mail server. These users have their accounts set up in Outlook (one in 2007,
    one in Mac 2011).
    We're are having an issue where these emails are displaying in Outlook with all of the HTML tags in the email visible. One of the users spoke to Microsoft support, and they remoted in and went through their Outlook settings and were not able to find any issues
    there.
    This issue is not global exactly. When one of the users added their email to their iPhone, the email displayed correctly. We added a Gmail account and my work account (which I also access through Outlook) to the forwarding list, and it displayed correctly in
    both. When we view these emails in the server's webmail client, the emails display fine. The issue seems to be with some discrepancy between Outlook and our email server.
    I spoke to our webhost about the issue, and they swore up and down the issue had nothing to do with them, and that it had to be an Outlook issue. I've had several professional web developers analyze the code that creates these emails, and they found nothing
    wrong with it. Something that several of my colleagues and our webhost suggested is that the issue could be with the email headers. This is the header for the email, as viewed through Outlook:
    Return-Path: <[email protected]>
    X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on clubcrown.com
    X-Spam-Level: *
    X-Spam-Status: No, score=1.5 required=7.0 tests=HTML_MESSAGE,MIME_HTML_ONLY,
    NO_DNS_FOR_FROM,NO_RELAYS autolearn=no version=3.3.1
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: by x.com (Postfix, from userid 30)
    id 50F7123D9E; Tue, 11 Feb 2014 14:20:00 -0500 (EST)
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: by x.com (Postfix, from userid 10000)
    id EC28323DA2; Tue, 11 Feb 2014 14:19:58 -0500 (EST)
    To: [email protected]
    Subject: A wholesale order has been placed
    X-PHP-Originating-Script: 10000:thanks.php
    MIME-Version: 1.0
    Any help would be greatly appreciated. Let me know if more information is needed. Thank you.

    Glad to hear that you have found the solution. And thank you for sharing the solution here, it will be helpful to other community members who have same questions.
    Cheers,
    Steve Fan
    TechNet Community Support

  • I'm having issues with text layers in photoshop. Text layers show it's there but not visible on the canvas.

    I'm having issues with text layers in photoshop. They aren't visible. I've checked font size, alignment, layer order and color. And the layer list shows that it's there. All seems well but I still can't see the text that I write. Need help trouble shooting. (I asked this question about a month ago but I got sidetracked and never circled back.) Thanks.

    Please refer to your original topic (Text Layer not Visible.) instead of posting a new topic.

  • Issue with Tree view

    Hello experts,
    I am facing a very strange issue with tree view.
    I have created a custom component with a tree view. All data are coming in the tree view. But the strange thing is that the data is not getting displayed on the screen.
    I am sure about the data because, when I am selecting a line from the tree, the data from that line is coming to the main screen.
    Please help!!
    Regards
    Debolina

    Hi experts...
    Any pointers to this issue???
    Please help!
    Regards,
    Debolina

Maybe you are looking for