Issue with af:tree

The af:tree element always tries to display a node as if it has children, even if its child List is of size 0. The result is that all nodes appear as expandable folders and when you expand on a node that has no children you get a vertical line leading to nothing. Clearly this isn’t desirable. This behavior is seen even when using your packaged sample code as shown below:
public class Person
public Person(String name)
_name = name;
public String getName()
return _name;
public List getKids()
return _kids;
private final String _name;
private final List _kids = new ArrayList();
You can construct a tree by:
Person john = new Person("John Smith");
Person kim = new Person("Kim Smith");
Person tom = new Person("Tom Smith");
Person ira = new Person("Ira Wickrememsinghe");
Person mallika = new Person("Mallika Wickremesinghe");
john.getKids().add(kim);
john.getKids().add(tom);
ira.getKids().add(mallika);
List people = new ArrayList();
people.add(john);
people.add(ira);
Now you can construct a TreeModel by:
TreeModel model = new ChildPropertyTreeModel(people, "kids");

Hi,
Even I have the same issue. How can I get it right in ADF Faces tree component.
Thanks,
Ankit

Similar Messages

  • Layout issue with af:tree component

    I am using af:tree component but I am finding layout issue with it. I have a requirement where in I need the tree to stretch to the available space but a horizontal and a vertical scrollbar comes up automatically. Is there a way to handle this issue?

    User, without your jdev version it's hard to help.
    Have you embedded the tree component in a stretch layout?
    Timo

  • Issue with ADF Tree Table

    Hi,
    I have the following requirement where i need to display a tree table. Here is how the initial implementation is:
    I have created the read only view for : ManagersVO > PoolsVO > MachinesVO. Where 'MachinesVO' is the destination view. And created view links between ManagersVO & PoolsVO using ManagerId and PoolsVO & MachinesVO using PoolId.
    And using this implementation, successfully created tree table on the UI. Now we got an enhancement for this:
    i.e., MachinesVO should return list of machines as per user logs in. i.e., we have 4 different roles. 'Super Admin', 'Sys Admin', 'App Admin', 'End User'. The default query for MachinesVO is for 'Super Admin'. The query for other user roles is different except the SELECT statement.
    The requirement is to dynamically change the query of MachinesVO based on user logs in and display the tree table accordingly. To implement the same i have tried using setQuery() operation on 'MachinesVO' which results with the following error:
    JBO-26016: InvalidOperException
    Cause: You cannot set customer query (calling setQuery()) on a view object if it is the detail view object in a master detail view link.
    Action: Do not call setQuery() if the view object is a detail.
    Can one suggest me a best solution to implement this.
    Thanks & Regards,
    Kiran

    Hi Navaneetha Krishnan,
    Here is how i implemented based on your comments. As i have tree table based 3 different VO's, created the following method at middle view(i.e., PoolsVO).
    1.Tree Model hierarchy
    ManagersVO > PoolsVO > MachinesVO
    I actually want to filter the data at Machines level. Hence wrote a method at PoolsVOImpls and exposed it in the PoolsVO client interface. Here is the code that i have placed in the PoolVOImpl
    public class PoolsVOImpl extends ViewObjectImpl implements PoolsVO{
         * This is the default constructor (do not remove).
        public PoolsVOImpl () {
      public void filterMachinesDataByUserRole(String userRole,String vzId){
        Row row = getCurrentRow();
        String query = "";
        if(row != null){
          RowSet rowSet = (RowSet)row.getAttribute("MachinesVO");
          if(rowSet != null){
            MachinesVOImpl machinesVOImpl = (MachinesVOImpl)rowSet.getViewObject();
            if(userRole.equalsIgnoreCase("SYS ADMIN")){
                    machinesVOImpl .setWhereClause(query related to sysadmin);
             //Similarly for other user roles.
             executeQuery();
    }And this piece of code needs to be executed before the jsff(which has the tree table) renders. Hence, i created a this methodAction as a default activity in the respective taskflow where the jsff is placed. Once this method get executed, the page should render the machines specific to the user.
    Here is the issue: getCurrentRow() method call is returning always NULL.
    Please correct me if i'm doing something wrong. I do tried the above mentioned approach by creating the method at '*ManagersVOImpl*' level too. Still the same issue.
    Thanks & Regards,
    Kiran

  • Issue With ADF Tree Expand/Collapse

    Hi All,
    I have a customer who is having issues using the af:tree component on a deployed application. When he tries to expand or collapse a node of the tree, the icon just blinks. This is occurring not only on our application, but also the Oracle ADF Rich Client Demo on http://jdevadf.oracle.com/adf-richclient-demo/faces/components/tree.jspx. He is using Internet Explorer v7.0.5730.13. As far as I can tell, our browser settings are identical, but I can use the tree without a problem.
    Any ideas as to what the problem could be?
    Thanks,
    Brad

    Unfortunately, Internet Explorer is the only browser that is authorized to run on his computer.
    Do you know of any specific IE settings that would cause the af:tree not to work?

  • Issue with alv tree

    Hello,
    Im using cl_gui_alv_tree_simple to display my internal table in a tree format with the internal table sorted out for three columns. Now when I click on the parent node i shud do an action and when I click at child i need to do a dofferent action. How do i know whether i clicked at the parent node or child node? Is there any event to identify this so that I can go ahead and do my operation for the respective parent and child. Thanks

    Use method get_outtab_line
    then you get the content of the clicked node
    METHOD handle_item_double_click.
        PERFORM detail USING node_key.
      ENDMETHOD.  
    FORM detail  USING    p_node_key.
      CALL METHOD tree1->get_outtab_line
        EXPORTING
          i_node_key    = p_node_key
        IMPORTING
          e_outtab_line = wa_tree.
      IF wa_tree-matnr IS INITIAL .
      ENDIF.
    if .
    endif.
    best regards
    Joerg

  • Issue with af:tree component

    Hi All,
    I am using JDev 11.1.1.6
    I am creating a tree component with collection model.I want to provide different action to each node,so I have defined an action attribute in the bean
    which I set in the constructor as shown below
    TestTree node1 = new TestTree("node1", "#{TreeBean.action1}");
    Is this the correct approach..This gives me "method not found " error when I click on the node.
    Below is the code for tree component :
    <af:tree value="#{TreeBean.model}" id="t1" var="node"
    styleClass="AFStretchWidth" inlineStyle="height:600.0px;">
    <f:facet name="nodeStamp">
    <af:commandLink text="#{node.label}" id="cl1" immediate="true"
    actionListener="#{node.action}"/>
    </f:facet>
    <f:facet name="pathStamp"/>
    </af:tree>

    Hi Vinay,
    UseCase :
    I want a tree showing navigation links . these navigation links will be used to open a new page in panelTabbed Layout.

  • Issue with af:tree's visible=false on IE

    Hello,
    I have an ADF page containing two af:tree components. For both rendered is set to true and visibility is set to false. For both the trees height has been set to 500px. Based on selection criteria either of the two trees has to be made visible. No issues on Firefox. However on IE, both the trees are occupying space even though visibility is set to false. When I try to show the second tree, it shows up down below after 500px of white space. So, even though first tree is not displayed, it still occupies the space. Please let me know the solution.
    Thanks,
    Lalitha.

    Hi,
    sounds like a bug to me. You can try an af:switcher component, though it only shows one tree at a time then
    Frank

  • Navigation issue with af :tree

    Hi,
    I'm using an af: tree for navigation. My code looks like
    <af:tree var="node"
    value="#{navigationContext.treeNavigation.treeModel['startNode=/, includeStartNode=true, depth=1']}"
    id="t1" initiallyExpanded="true">
    <f:facet name="nodeStamp">
    <af:commandImageLink text="#{node.title}"
    id="sm_c1b"
    action="pprnav"
    actionListener="#{navigationContext.processAction}"
    inlineStyle="#{node.selected ? 'font-weight:bold;' : ''}">
    <f:attribute name="node" value="#{node}"/>
    </af:commandImageLink>
    </f:facet>
    </af:tree>
    The problem here is, I'm not able to navigate by clicking the link once all the nodes are expanded. When I collapse that node and click after expanding again, it works. But Once expanded I can go to only one child node. After that if i need to go to another link I need to collapse it and expand again. What is wrong here?

    Hi again.
    I have some doubts about your code
    What version of WebCenter are you?.
    About #{navigationContext.*treeNavigation*.treeModel['startNode=/, includeStartNode=true, depth=1']}.
    I never saw navigationContext.treeNavigation. It could be #{navigationContext.currentNavigationModel.treeModel[...?
    Your tree navigation is based on official doc http://docs.oracle.com/cd/E25054_01/webcenter.1111/e10148/jpsdg_view_comps.htm point Example 13-2 Simple Tree Navigation UI?
    Regards.

  • Issue with child items of flex tree using QTP

    Hi,
    We are trying to automate Flex web application using QTP10.
    We are facing below issue with Flex tree when we try to automate a scenario of selecting a child item displayed in flex tree.
    Issue:
    On recording the step of selecting an item from Flex tree using QTP, the script displayed is .Select Index1. But when we replay it back no action is being performed.
    Also on object spy we are able to navigate only till flex tree and we are not able to spy child items of flex tree.On the web page the child items are displayed as radio buttons/checkboxes.
    Please provide a solution for me to this problem.
    Thanks

    Hi,
    You could perform a HTTP trace (using HTTP watch) and compare the OCI data in POST method for both users (the correct and incorrect ones).
    Perhaps there is some additional/missing information being passed from catalog to SRM.
    Kind regards,
    Ricardo

  • Sg-300 - 3750 stack with SPANNING-TREE root problem.

    Morning. I think ive configured a few hundred switches, maybe a thousand in my time, but never have a faced such horribleness that is the SG-300. After this week, I think ill refuse to touch them.
    Got 2 voice vlans and running a few vrf's on a 3750 stack. but this discussion is about layer 2.
    2 x 3750 stacked
    1 x voice switch sg-300 company A voice vlan 18 - Po1 up to 3750 distributed etherchannel Po1 (LACP active both sides) 2 ports in channel
    1 x voice switch sg-300 company B voice vlan 19 - Po1 up to 3750 distributed etherchannel Po2 (LACP active both sides) 2 ports in channel
    Allowed vlans on both sides (command on Port-channel) are data A, Voice A, Mgt A to switch A
    Allowed vlans on both sides (command on Port-channel) are data B, Voice B, Mgt B to switch B
    It seems that these switches are limited to one voice vlan....
    and that spanning tree BPDU's are ignored (or not recevied- havnt released the shark yet).  let me explain.
    originally when using "smart port" the switch with the lowest mac address, whatever Voice vlan was configured would take over the other switche's voice vlan, argh what a nightmare.
    I gave up on the GUI as its far to complcated and have Almost got this working.
    I am now using auto voice vlan, but have disabled smart macro. I hope that disabling smart macro stop other switches from learning the switch with the lowest mac address's voice vlan.  So far so good - in the LAB. No where was it documented in the cli guide how do disable this stupid feature.
    DHCP is working from scope on core, can mange the switches etc etc, access vlan voice vlan all good (after a monster battle).
    Now I have an issue with spanning tree.
    spanning tree priority for vlans 1-4094 on the 3750 is 4096.
    spanning tree priority for vlans 1-4094 on the SG-300's is 6xxxx.
    ALL switches think that they are the root. (well the "logical" 3 of them) The 3750's for all vlans, and the SG-300 for the one instance as it doesnt support per vlan.  (I am not interested in trying MST here..this is not a datacentre)
    On the 3750's Ive tried ieee, pvst, rpvst, while matching the non per-vlan equivalent on the SG series.
    What is the difference between a General port and Trunk Port on a SG-300 specific to spanning tree, native vlans (when you can just configure an untagged vlan anyway!!) and what is the relevance to the way the bpdu's are carried?
    And why the need for a PVID, when you can tell a port what is tagged and what isnt.
    Does the trunk need Vlan1 to be explicitly allowed, and untagged? Does the Po trunk need to be a general port with PVID configured? in vlan 1?
    I need to sort this, as cannot put an access switch into production that thinks it is the root of the tree.  I wish I had a 2960.... a 3500XL..anything
    Does anyone have CLI commands that can help here?

    F.Y.I for catylyst heroes - here is the equivalent config for SG-300 - Vlan1 is required on the allowed list on the catylyst side (3xxx/4xxx/6xxx)
    In this example:
    VLANS - Voice on 188, data on 57, management on 56.
    conf t
    hostname XXX-VOICE-SWXX
    no passwords complexity enable
    username xxxx priv 15 password XXXXX
    enable password xxxxxx
    ip ssh server
    ip telnet server
    crypto key generate rsa
    macro auto disabled
    voice vlan state auto-enabled !(otherwise one switch controls your voice vlan….)
    vlan 56,57,188
    voice vlan id 188
    int vlan 56
    ip address 10.230.56.12 255.255.255.0
    int vlan1
    no ip add dhcp
    ip default-gateway 10.230.56.1
    interface range GE1 - 2
    switchport mode trunk
    channel-group 1 mode auto
    int range fa1 - 24
    switchport mode trunk
    switchport trunk allowed vlan add 188
    switchport trunk native vlan 57
    qos advanced
    qos advanced ports-trusted
    exit
    int Po1
    switchport trunk allowed vlan add 56,57,188
    switchport trunk native vlan 1
    do sh interfaces switchport po1
    !CATYLYST SIDE
    !Must Explicitly allow VLan1, this is not normal for catalysts - or spanning tree will not work ! Even though it’s the native vlan on both sides.
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,56,57,189
    switchport mode trunk

  • Issue with Tree view

    Hello experts,
    I am facing a very strange issue with tree view.
    I have created a custom component with a tree view. All data are coming in the tree view. But the strange thing is that the data is not getting displayed on the screen.
    I am sure about the data because, when I am selecting a line from the tree, the data from that line is coming to the main screen.
    Please help!!
    Regards
    Debolina

    Hi experts...
    Any pointers to this issue???
    Please help!
    Regards,
    Debolina

  • Issue With Tree

    Hi All,
    We have an strange problem in tree population.
    We are using ftreen.add_tree_data built-in for the population of the next level on when-tree-node-expand trigger.
    On the population of the specific data it is giving the error FRM-47337 Tree node cannot be null
    I had checked the tree query on backend it does not return null.
    But when i do the same functionalty with ftreen.add_tree_node with help of loop means now node add one by one it is working fine.
    I donot have the reason why ftree.add_tree_data giving the error and why it is working fine by ftreen.add_tree_node.
    I hope experts will help me out.

    Your thread Issue with Tree in Apex 4 is still open!
    Isn't it the same thing?
    Regards,

  • VLAN Spanning-tree (VSTP) issue with Metro-E links

    Hi Everyone,
    We have Juniper EX 4200 as core switch at two sites connected Cisco  2960s and Cisco 3560s (access layer switches). For even-numbered VLANs,  one Juniper switch is root bridge and for odd-numbered VLANs, other  Juniper switch is the root bridge.
    We have Cox and Verizon Metro-E links connecting core switches (Juniper EX 4200 at both sites).
    I want to do VLAN load sharing using VSTP but somehow it is not  working as expected. I want to pass some VLANs through COX and some  through Verizon. When there is any issue with Cox, all VLAN traffic pass  through Verizon and vice-versa. RSTP is also enabled on both Juniper  switches.
    I see MAC flapping in log messages on all Cisco access layer switches  when I bring up both Metro-E links together. When only Cox is  connected, everything works fine. When only Verizon is connected,  everything works fine. But when BOTH COX and Verizon are connected,  network gets disrupt and I see MAC flapping on all Cisco switches. All  cisco switches are running PVST.
    Anybody knows what is happening  and why VSTP is not working when both COX and VERIZON Metro-E links are active ?

    Hi Tojackson, I guess this depends on how stuff is interconnecting. It's obvious gi1/1 is forwarding and gi1/2 is blocking. So from the furthest access switch, what path must it take to reach gi1/1? That is the number of hops involved for normal traffic.
    Now, if you're concerned about a specific VLAN and you need gi1/2 forwarding to reduce travel time for other traffic, you may employ RPVST to have that specific VLAN and cost to go to gi1/2.
    In some part of the network I support we have a pair of Cisco 7606 which feeds in to a 4507R and off the 4507R we have a ring of 2955 with even 10-12 L2 switches on the ring. The consequence of multiple layer 2 hops is not of much concern and our spanning tree stops with the 4507 since we're not concerned about broadcast storm on the routed interfaces on the 7600.
    -Tom
    Please mark answered for helpful posts

  • RTF templates- Issue with inconsistent outputs

    Hi All,
    I have an issue with rtf templates.We are on XML Publisher 5.6.3 with EBS with Bursting.Bursting is set at G_HEADERS in the contorl file.
    I am using the <?start@last-page-first:body?><?end body?> function.It displays amount total for single page output and amount total only on the last page for multiple pages output.The above logic works perfectly when I have single header data in the XML file(single G_HEADERS).
    <XX_MAIN>
    -<LIST_G_HEADERS>
    <G_HEADERS>
    Lines Data(tree sub levels)
    </G_HEADERS
    <G_HEADERS>
    Lines Data(tree sub levels)
    </G_HEADERS
    <G_HEADERS>
    Lines Data(tree sub levels)
    </G_HEADERS
    </LIST_G_HEADERS>
    </XX_MAIN>
    However when there are multiple headers(G_HEADERS) in the same XML data file at the same tree level, all the outputs get generated as minimum 2 page outputs.Even though the data fits in 1 page for some of the G_HEADERS, it shows continued on the first page and just prints the total on the last page along with the header.
    I appreciate your help with this.
    Thanks,
    Lavina

    Hi,
    I'd like to know if anyone out there has come across this issue before..
    Thanks
    Lavina

  • An issue with authentication and authorization on ISE 1.2

    Hi, I'm new to ISE.
    I have an issue with authentication and authorization.
    I have ISE 1.2 plus patch 6 installed on VMware.
    I have built-in Windows XP supplicant and 2960 cisco switch with IOS c2960-lanbasek9-mz.150-2.SE5.bin
    On supplicant I use EAP(PEAP) with EAP-MSCHAP v2.
    I created  authentication and authorization rules with Active Directory  as External Identity Source. Also I applied  authorization profile with DACL.I login on Windows XP machine under different Active Directory accounts. Everything works fine (authentication, authorization ), but only for several hours. After several hours passed , authentication and authorization stop working . I can see that ISE trying authenticate and authorize users, but ISE always use only one account for  authentication and authorization . Even if I login under different accounts ISE continue to use only one last account.
    I traied to reboot switch and PC,but it didn’t help. Only rebooting of ISE helps. After ISE rebooting, authentication and authorization start to work properly for several hours.
    I don’t understand is it a glitch or I misconfigured ISE or switch, supplicant?
    What  should I do to resolve this issue?
    Switch configuration:
     testISE#sh runn
    Building configuration...
    Current configuration : 7103 bytes
    ! Last configuration change at 12:20:15Tue Apr 15 2014
    ! NVRAM config last updated at 10:35:02  Tue Apr 15 2014
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname testISE
    boot-start-marker
    boot-end-marker
    no logging console
    logging monitor informational
    enable secret 5 ************
    enable password ********
    username radius-test password 0 ********
    username admin privilege 15 secret 5 ******************
    aaa new-model
    aaa authentication dot1x default group radius
    aaa authorization network default group radius
    aaa authorization auth-proxy default group radius
    aaa accounting update periodic 5
    aaa accounting dot1x default start-stop group radius
    aaa server radius dynamic-author
     client 172.16.0.90 server-key ********
    aaa session-id common
    clock timezone 4 0
    system mtu routing 1500
    authentication mac-move permit
    ip dhcp snooping vlan 1,22
    ip dhcp snooping
    ip domain-name elauloks
    ip device tracking probe use-svi
    ip device tracking
    epm logging
    crypto pki trustpoint TP-self-signed-1888913408
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1888913408
     revocation-check none
     rsakeypair TP-self-signed-1888913408
    crypto pki certificate chain TP-self-signed-1888913408
    dot1x system-auth-control
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    ip ssh version 2
    interface FastEthernet0/5
     switchport mode access
     ip access-group ACL-ALLOW in
     authentication event fail action next-method
     authentication event server dead action reinitialize vlan 1
     authentication event server alive action reinitialize
     authentication host-mode multi-auth
     authentication open
     authentication order dot1x mab
     authentication priority dot1x mab
     authentication port-control auto
     authentication periodic
     authentication timer reauthenticate server
     authentication violation restrict
     mab
     dot1x pae authenticator
     dot1x timeout tx-period 10
     spanning-tree portfast
    interface FastEthernet0/6
     switchport mode access
     ip access-group ACL-ALLOW in
     authentication event fail action next-method
     authentication event server dead action reinitialize vlan 1
     authentication event server alive action reinitialize
     authentication order dot1x mab
     authentication priority dot1x mab
     authentication port-control auto
     authentication periodic
     authentication timer reauthenticate server
     authentication violation restrict
     mab
     dot1x pae authenticator
     dot1x timeout tx-period 10
     spanning-tree portfast
    interface FastEthernet0/7
    interface Vlan1
     ip address 172.16.0.204 255.255.240.0
     no ip route-cache
    ip default-gateway 172.16.0.1
    ip http server
    ip http secure-server
    ip access-list extended ACL-ALLOW
     deny   icmp any host 172.16.0.1
     permit ip any any
    ip radius source-interface Vlan1
    logging origin-id ip
    logging source-interface Vlan1
    logging host 172.16.0.90 transport udp port 20514
    snmp-server community public RO
    snmp-server community ciscoro RO
    snmp-server trap-source Vlan1
    snmp-server source-interface informs Vlan1
    snmp-server enable traps snmp linkdown linkup
    snmp-server enable traps mac-notification change move
    snmp-server host 172.16.0.90 ciscoro
    radius-server attribute 6 on-for-login-auth
    radius-server attribute 6 support-multiple
    radius-server attribute 8 include-in-access-req
    radius-server attribute 25 access-request include
    radius-server dead-criteria time 5 tries 3
    radius-server vsa send accounting
    radius-server vsa send authentication
    radius server ISE-Alex
     address ipv4 172.16.0.90 auth-port 1812 acct-port 1813
     automate-tester username radius-test idle-time 15
     key ******
    ntp server 172.16.0.1
    ntp server 172.16.0.5
    end

    Yes. Tried that (several times) didn't work.  5 people in my office, all with vers. 6.0.1 couldn't access their gmail accounts.  Kept getting error message that username and password invalid.  Finally solved the issue by using Microsoft Exchange and "m.google.com" as server and domain and that the trick.  Think there is an issue with imap.gmail.com and IOS 6.0.1.  I'm sure the 5 of us suddently experiencing this issue aren't the only ones.  Apple will figure it out.  Thanks.

Maybe you are looking for

  • I'm having an issue with my 7130c

    Hi, I'm new here so im not sure if this is a stupid question or not, but I recently bought a 7130c and I'm having trouble getting it to work properly. When i insert the battery that came with it the led blinks once then the screen shows a battery ico

  • Background Schedule - Hardcore Input data

    Hi Experts          I am developing a BDC, now i want to schedule the program into background.         So i want to hardcore the input data like          Select Method (Genrate session/Call transaction)          Processing Mode          Update Mode  

  • The geo-fence in Reminders doesn't work on my 4S since ios7.

    The geo-fence in Reminders doesn't work on my 4S since ios7.  Any reminders I put in as remind me at a location do not work.  Location services are turned on.  Maps work fine & show my location.  Reminders are turned on in location services & I see t

  • What are the differences between oracle adf 10g and adf 11g

    Could you please let me know what are the diff b/w oracle adf 10g and 11g, i tried in many user guides but i could not find it. Thanks in advance, Poli Reddy P

  • List all servers with OS and service pack

    Is there an easy way using any script or software to list all servers joined to your domain including operating system (i.e. server 2008) and service pack level, without having to check each manually?