Issue with sequence

Hi!
I created a sequence:
CREATE SEQUENCE "XXX"."FLIGHT_LEG_SEQ"
MINVALUE 0 MAXVALUE 100000 INCREMENT BY 1 START WITH 1 CACHE 20 NOORDER CYCLE ;
Sequence after inserting a row into table:
CREATE SEQUENCE "XXX"."FLIGHT_LEG_SEQ"
MINVALUE 0 MAXVALUE 100000 INCREMENT BY 1 START WITH 24 CACHE 20 NOORDER CYCLE ;
Here is the trigger that uses this sequence:
create or replace TRIGGER NEW_LEG_ID
BEFORE INSERT ON FLIGHT_LEGS
FOR EACH ROW
BEGIN
SELECT flight_leg_seq.NEXTVAL INTO :new.leg_id
FROM dual;
END;
The sequence is set to increment by 1, however the next value is 24? What could be the reason for this?
Thanks!

> Let's don't waste each other's time with my first post.
Correctly said. If you yourself are not sure about what you have typed, I should really retire from this thread. By the way, am not wasting your time, was trying to help you out. Oracle never does anything wrong. Its a computer program. So there should be something wrong with your code only.
Cheers
Sarma.

Similar Messages

  • Issue with sequence.currval in INSERT ALL...

    Hi Gurus,
    I am having an issue with using sequence.currval in INSERT ALL with WHEN clause.Please check following example
    Let say I have 4 tables
    1) SOURCE_PARENT
    PARENT_ID
    ========
    10
    20
    2) SOURCE_CHILD
    PARENT_ID CHILD_ID
    ========= ========
    10     1
    10     2
    20     1
    20     2
    Now i have another 2 tables same as above definition(DEST_PARENT, DEST_CHILD),which i want to populate with above source data with new parent_id's from a sequence.
    So I have used INSERT ALL as follows.
    =====================================================
    INSERT ALL
    WHEN (prev_parent_id = 0)THEN
    INTO dest_parent
    values(test_s.nextval)
    when 1 = 1 then
    INTO dest_child
    values(test_s.currval,child_id)
    select
    p.parent_id
    ,c.child_id
    ,LAG(c.parent_id, 1, 0) OVER (PARTITION BY c.parent_id ORDER BY c.child_id) prev_parent_id
    from
    source_parent p
    ,source_child c
    where
    p.parent_id = c.parent_id
    order by p.parent_id
    ========================================================
    Above INSERT ALL created following rows in DEST tables
    1) DEST_PARENT
    PARENT_ID
    =========
    75
    77
    2)DEST_CHILD
    PARENT_ID CHILD_ID
    ========= =======
    75     1
    76     2 --- this should be same as above record
    77     1
    78     2 --this should be same as above record
    As you can see test_s.nextval is executed 4 times even we do have WHEN Clause in INSERT ALL
    Can you please check what's wrong in this INSERT ALL statement?
    (or)
    Any otherway of doing these INSERTS in a single SQL statement?
    Any help would be appreciated!!
    Thanks
    srinivas.L

    Sorry, but this solution does not work. I had to remove the constraints on the two tables dest_parent and dest_child just to show you, how bad your solution is
    SQL> select * from source_parent;
    PARENT_ID
            10
            20
    2 rows selected.
    SQL> select * from source_child;
    PARENT_ID   CHILD_ID
            10          1
            10          2
            20          1
            20          2
            20          3
    5 rows selected.
    SQL> select * from dest_parent;
    no rows selected
    SQL> select * from dest_child;
    no rows selected
    SQL> insert all when
      2       (PREV_PARENT_ID = 0) then into DEST_PARENT
      3  values
      4       (TEST_S.nextval) when 1 = 1 then into DEST_CHILD
      5  values
      6       (case when PREV_PARENT_ID != 0 then TEST_S.currval - 1 else TEST_S.currval end,
      7        CHILD_ID)
      8       select P.PARENT_ID,
      9              C.CHILD_ID,
    10              LAG(C.PARENT_ID, 1, 0) OVER(partition by C.PARENT_ID order by C.CHILD_ID) PREV_PARENT_ID
    11       from SOURCE_PARENT P, SOURCE_CHILD C
    12       where P.PARENT_ID = C.PARENT_ID
    13       order by P.PARENT_ID
    14  /
    7 rows created.
    SQL> select * from dest_parent;
    PARENT_ID
            23
            26
    2 rows selected.
    SQL> select * from dest_child;
    PARENT_ID   CHILD_ID
            21          2   -- ??? !!!
            23          1
            23          2
            24          3   -- !!!
            26          1
    5 rows selected.
    SQL>

  • LR5.3 Export issue with Sequence Renumbering

    I just discovered an issue with the LR5.3 Export module on my Windows 7 system when exporting JPEG image files with 'Sequence' File renaming and 'Original' File Settings to a subfolder. When exporting approximately 100 JPEG image files LR shows a file count in the subfolder of ~1/2 the actual file count and the ability to 'Synchronize Folder' disappears. The correct number of files appear in the subfolder using Windows Explorer, so they all were successfully exported and renamed properly. LR must be closed and reopened to restore the ability to 'Synchronize Folders' and/or 'Import' images using the Import module. I've never encountered this problem before since I normally process raw image files, which do not exhibit this issue.
    Here are screenshots:

    Posted to the Photoshop Family site as a problem:
    http://feedback.photoshop.com/photoshop_family/topics/lr5_3_export_sequence_numbering_issu e

  • Issues with Sequence Generator

    I'm having trouble with Sequence generator not generating continuous numbers starting from 1, each time I run the mapping.
    I want the Sequence to start from 1, each time the mapping is run. For this to happen, I'm using a pre-mapping operator which uses an oracle procedure to reset the sequence.
    But, the sequence generates the numbers from some weird number, say 3508 and then jumps to 5006 and so on. I'm not able to track what's wrong with the sequence. I have stopped the caching in Sequence but still it hasn't helped. I'm sure and have verified that the procedure being used to reset the sequence is running fine.
    Please suggest some additional parameters/properties at OWB level to be checked for the sequence, if any OR any thoughts on why the sequence is not starting from 1. Thanks in advance.
    Thanks,
    Sachin
    Edited by: 850549 on Apr 23, 2011 11:43 AM
    Edited by: 850549 on Apr 23, 2011 11:44 AM

    Could you check whether the sequence you use has a cache value greater than 1 defined in the database. This way if your database regularly should be stoped, e.g for offline backup, you'll loose the sequence values that were unused in memory at that time. That way the gaps in your surrogate ids would be explainable.

  • 9.2 issue with  Sequence Numbers

    We are using OWB 9.2 and RDBMS 9.2 on windows NT.
    When using set based functionality i.e. Merge Statement, or Row Based, we have noticed that our sequence object gets incremented during updates even though it is only associated with the insert and not the update.
    Is this normal behaviour or an issue ???

    Jagadish,
    You will not get updates because you by default match on the keys on the table. In other words you emp_id and the seq.nextval are matched to what you have in the table and they will never match (because of the nextval).
    Two things you can do:
    - Change the composite key (e.g. change the design)
    - Change the configuration in OWB
    Let's look at the second one, what you must do is the following:
    1) On the target table, select operator properties and find "Match by Constraint". Highlight that and change this setting to No Constraints.
    You now are not using the constraint, so you must tell OWB what to match on. You do this by:
    2) Highlight the EMPID column and select attribute properties
    3) In the loading properties node set the following for EMPID:
    Load column when inserting row => Yes
    Load column when updating row => No
    Match column when updating row => Yes
    4) Highlight the other columns, for example ATTEMPT_COUNT and select attribute properties
    5) In the loading properties node set the following for ATTEMTP_COUNT:
    Load column when inserting row => Yes
    Load column when updating row => Yes
    Match column when updating row => No
    This should allow you to update based on the EMPID alone.
    Hope this helps,
    Jean-Pierre

  • JBoss Clustering | Issue with sequence generator

    Hi all,
    I am facing a strange issue. I have 2 instances of jboss on the same machine and we have a number of stateless session beans used in our application. Now, I have written a Stateless session bean for sequence generator. I am able to run it on one instance but it is failing on another instance (even if I am only this running this one instance).
    It gives the following error:
    com.proximities.common.utils.SequenceIdGeneratorUtil: Method: getSequence(): Message: TableKey : VENUE
    2005-08-02 11:19:58,406 DEBUG [com.proximities] Class: utils.SequenceIdGeneratorUtil: Method: getSequence(): Message: Fetching from sequence proxy factory: VENUE
    2005-08-02 11:19:58,406 DEBUG [com.proximities] Class: ejb.EJBLookupUtil: Method: getInitialContext: Message: Using JNDI initial context: org.jnp.interfaces.NamingContextFactory
    2005-08-02 11:19:58,406 DEBUG [com.proximities] Class: ejb.EJBLookupUtil: Method: getInitialContext: Message: Using JNDI URL: jnp://localhost:11099
    2005-08-02 11:19:58,406 DEBUG [com.proximities] Class: ejb.EJBLookupUtil: Method: getInitialContext: Message: Using JNDI initial context prefix: org.jboss.naming:org.jnp.interfaces
    2005-08-02 11:19:58,421 DEBUG [com.proximities] Class: ejb.EJBLookupUtil: Method: getSequenceFacade: Message: SequenceStoreFacadeHome - Sequence store facade home returned from ejbHomeFactory isnull
    2005-08-02 11:19:58,421 FATAL [com.proximities] Class: ejb.EJBLookupUtil: Method: getSequenceFacade: Message: Exception during the invoking the remote interface
    2005-08-02 11:19:58,421 INFO [STDOUT] java.lang.NullPointerException
    2005-08-02 11:19:58,421 INFO [STDOUT] ejb.EJBLookupUtil.getSequenceFacade(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] sequence.SequenceProxyFactory.getSequenceStore(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] sequence.SequenceProxyFactory.reserveBlock(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] sequence.SequenceProxyFactory.<init>(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] sequence.SequenceProxyFactory.getSequence(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at common.utils.SequenceIdGeneratorUtil.getSequence(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at dataaccess.VenueDAO.add(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at dataaccess.VenueDAO.update(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at dataaccess.common.GenericDataAccessManager.executeModify(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at business.mediator.ManageVenueMediator.insertIntoVenues(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at business.sessionfacade.VenueManagementFacadeEJBean.insertIntoVenues(Unknown Source)
    2005-08-02 11:19:58,421 INFO [STDOUT] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2005-08-02 11:19:58,421 INFO [STDOUT] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    2005-08-02 11:19:58,421 INFO [STDOUT] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    2005-08-02 11:19:58,421 INFO [STDOUT] at java.lang.reflect.Method.invoke(Method.java:585)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.invocation.Invocation.performCall(Invocation.java:345)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor.invoke(StatelessSessionContainer.java:214)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.resource.connectionmanager.CachedConnectionInterceptor.invoke(CachedConnectionInterceptor.java:185)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.StatelessSessionInstanceInterceptor.invoke(StatelessSessionInstanceInterceptor.java:130)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.webservice.server.ServiceEndpointInterceptor.invoke(ServiceEndpointInterceptor.java:51)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.CallValidationInterceptor.invoke(CallValidationInterceptor.java:48)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.AbstractTxInterceptor.invokeNext(AbstractTxInterceptor.java:105)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.TxInterceptorCMT.runWithTransactions(TxInterceptorCMT.java:335)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.TxInterceptorCMT.invoke(TxInterceptorCMT.java:166)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.SecurityInterceptor.invoke(SecurityInterceptor.java:139)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.LogInterceptor.invoke(LogInterceptor.java:192)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.CleanShutdownInterceptor.invoke(CleanShutdownInterceptor.java:264)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor.invoke(ProxyFactoryFinderInterceptor.java:122)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.SessionContainer.internalInvoke(SessionContainer.java:624)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.ejb.Container.invoke(Container.java:873)
    2005-08-02 11:19:58,421 INFO [STDOUT] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2005-08-02 11:19:58,421 INFO [STDOUT] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    2005-08-02 11:19:58,421 INFO [STDOUT] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    2005-08-02 11:19:58,421 INFO [STDOUT] at java.lang.reflect.Method.invoke(Method.java:585)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:141)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.mx.server.Invocation.dispatch(Invocation.java:80)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.mx.server.Invocation.invoke(Invocation.java:72)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:249)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:644)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.invocation.local.LocalInvoker$MBeanServerAction.invoke(LocalInvoker.java:155)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.invocation.local.LocalInvoker.invoke(LocalInvoker.java:104)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.invocation.InvokerInterceptor.invokeLocal(InvokerInterceptor.java:179)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.invocation.InvokerInterceptor.invoke(InvokerInterceptor.java:165)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.proxy.TransactionInterceptor.invoke(TransactionInterceptor.java:46)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.proxy.SecurityInterceptor.invoke(SecurityInterceptor.java:55)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.proxy.ejb.StatelessSessionInterceptor.invoke(StatelessSessionInterceptor.java:97)
    2005-08-02 11:19:58,421 INFO [STDOUT] at org.jboss.proxy.ClientContainer.invoke(ClientContainer.java:86)
    2005-08-02 11:19:58,421 INFO [STDOUT] at $Proxy92.insertIntoVenues(Unknown Source)
    Now within the server logs, I can see that it has loaded and cached the home interface of that bean, but dont know why its not picking it up.
    Here are the logs for the same:
    [org.jboss.ejb.EjbModule] startService, starting container: SequenceStoreFacade
    [org.jboss.system.ServiceController] starting service jboss.j2ee:jndiName=ejb.SequenceStoreFacadeHome,service=EJB
    [org.jboss.ejb.StatelessSessionContainer] Starting jboss.j2ee:jndiName=ejb.SequenceStoreFacadeHome,service=EJB
    [org.jboss.ejb.StatelessSessionContainer] Begin java:comp/env for EJB: SequenceStoreFacade
    [org.jboss.ejb.StatelessSessionContainer] TCL: org.jboss.util.loading.DelegatingClassLoader@188d92e
    [org.jboss.ejb.StatelessSessionContainer] Bound java:comp/ORB for EJB: SequenceStoreFacade
    [org.jboss.ejb.StatelessSessionContainer] Bound java:comp:/HandleDelegate for EJB: SequenceStoreFacade
    [org.jboss.ejb.StatelessSessionContainer] End java:comp/env for EJB: SequenceStoreFacade
    [org.jboss.ejb.plugins.local.BaseLocalProxyFactory] SequenceStoreFacade cannot be Bound, doesn't have local and local home interfaces
    [org.jboss.proxy.ejb.ProxyFactory] (re-)Binding Home ejb.SequenceStoreFacadeHome
    [org.jboss.proxy.ejb.ProxyFactory] Bound SequenceStoreFacade to ejb.SequenceStoreFacadeHome
    [org.jboss.system.ServiceController] starting service jboss.j2ee:service=EJB,plugin=pool,jndiName=ejb.SequenceStoreFacadeHome
    [org.jboss.ejb.plugins.StatelessSessionInstancePool] Starting jboss.j2ee:service=EJB,plugin=pool,jndiName=ejb.SequenceStoreFacadeHome
    [org.jboss.ejb.plugins.StatelessSessionInstancePool] Started jboss.j2ee:service=EJB,plugin=pool,jndiName=ejb.SequenceStoreFacadeHome
    [org.jboss.system.ServiceController] Starting dependent components for: jboss.j2ee:service=EJB,plugin=pool,jndiName=ejb.SequenceStoreFacadeHome dependent components: []
    [org.jboss.resource.connectionmanager.CachedConnectionInterceptor] start called in CachedConnectionInterceptor
    [org.jboss.ejb.StatelessSessionContainer] Started jboss.j2ee:jndiName=ejb.SequenceStoreFacadeHome,service=EJB
    [org.jboss.system.ServiceController] Starting dependent components for: jboss.j2ee:jndiName=ejb.SequenceStoreFacadeHome,service=EJB dependent components: []
    BTW, I am using JCS for caching and JBoss 4.0. Any pointers will be most appreciated?
    Thanks,
    Vikrant Verma

    You'll get a lot more help with this by posting this to the JBoss forums. This forum is about the J2EE SDK which uses the Sun Java System Application Server.
    -Ian Evans

  • I have a editing issue with (sequence) rating system in Bridge.

    So I am editing in Bridge staring each keeper photo and as I do so the newly rated or 1 star photo I just  marked skips ahead in front of the  next photo. So in other words lets say I rated or stared photo number 1278 and the next one is 1279 and after marking 1278 it goes in front of 1279 reversing the sequence? What is causing this to happen. Also yesterday a whole batch of photos from a shoot (3500 of them) lost all time sequence ( I am viewing as "Date created" reverted to one time rather than when they were actually shot much later. I had two hardrives of the same photos and on my backup folder on the other hard drive this did not occur. Unfort I had edited almost the whole corrupted folder so going back to the clean back up HD was not what I wanted to do. Any ideas on this. the files that converted to the wrong date created also have a  out of focus quality as if the file is opening but never clears up.

    DOes tha make sense? Before you had me reset it I could
    scroll thru in bridge and use just single key grading actions  and now I must
    use command Action.
    Your Bridge set up must have been really messed because the normal behavior
    to set rate and label has always been with the two key combination when in a
    workspace with content window set up. When in content panel pressing a key
    without command brings you straight to the file (or first in series) with
    the first character that equals the key you pressed. If you have a filename
    starting with 3 pressing the key 3 for 3 star rating would move the focus
    from your selected file and bring you straight to that other file with a
    name starting with 3.
    However you could also use other options. Not only slideshow allows you to
    use one key, also the full screen (hit space bar to get there) or the Review
    mode (hit cmd+B to get there) in both mode you can move the files with arrow
    key and use one key for rate or label.
    two key  action such as COMMAND 1 to make it a 1 star or COMMAND 6 to make it
    this makes for allot more work and more carpal tunnel 
    nightmare lol!
    It is also not more work to hit one ore two keys at the same time and using
    the cmd + . (dot) and Cmd+ , (comma) also increases or decreases your rating
    with one star.
    Carpal tunnel syndrome is nothing to laugh about but highly unlikely to get
    from using a key board.
    There must be a fucntion to make thsi change?
    No, there is not.

  • Issue with getting sequance number from db in EO for a primary key column

    Hello Experts,
    we are working on ADf 11.1.1.2.
    we are facing issue with sequence number in our UAT instance.
    dev instance and sit instances did not gave any issues.
    We have one EO in that for one attribute we have given the value as
    new oracle.jbo.server.SequenceImpl("XXOZF_QA_CODE_S", object.getDBTransaction())).getSequenceNumber()
    in order to get the primary key column value from db sequance .
    <TransientExpression><![CDATA[(
    new oracle.jbo.server.SequenceImpl("XXOZF_QA_CODE_S", object.getDBTransaction())).getSequenceNumber()
    ]]></TransientExpression>
    now the issue is "I have incremented the sequence number through SQL plus from 10 to 20. And created a record on a VO which is based on above EO.
    But the sequence iam getting is 11 instead of 21."
    This is happening only in our uat instance all other instances are working fine.
    Can any one tell us how this frame work is still pointing tho the old sequnce number.
    regards
    Gayaz

    Also make sure that your sequence has NOCYCLE option.
    some thing like this:
    CREATE SEQUENCE test_seq
    START WITH 1
    INCREMENT BY 1
    NOCACHE
    NOCYCLE;

  • Problem with sequences after import

    We recently imported some table data from QA to DEV and now the DEV database has issues with sequences errors. How can I resolve the problem with sequences since we have constraint violation errors as a result of the table sequences being out of sync after the import of several schema tables.

    We run a script like the following to get the sequences as close as possible after importing from PROD to DEV:
    set serveroutput on;
    DECLARE
         CURSOR CUR IS
              SELECT      otherdb_seq.sequence_owner AS owner,
                        otherdb_seq.sequence_name AS seq_nm,
                        TO_CHAR(otherdb_seq.last_number) AS start_nr
              FROM           dba_sequences currdb_seq,
                        dba_sequences@prod otherdb_seq
         WHERE      currdb_seq.sequence_owner IN ('~schemaname~') AND
                        currdb_seq.sequence_owner = otherdb_seq.sequence_owner AND
                   currdb_seq.SEQUENCE_NAME = otherdb_seq.sequence_name
              ORDER BY      1, 2;
         sql_string VARCHAR2(500);
    BEGIN
         FOR REC IN CUR
         LOOP
         sql_string := 'DROP SEQUENCE '||REC.owner||'.'||REC.seq_nm;
              DBMS_OUTPUT.PUT_LINE(sql_string||';');
              EXECUTE IMMEDIATE sql_string;
              sql_string := 'CREATE SEQUENCE '||REC.owner||'.'||REC.seq_nm;
              sql_string := sql_string ||' START WITH '||REC.start_nr;
              sql_string := sql_string ||' MAXVALUE 999999999999999999999999999';
              sql_string := sql_string ||' MINVALUE '||REC.start_nr;
              sql_string := sql_string ||' NOCYCLE NOCACHE ORDER';
              DBMS_OUTPUT.PUT_LINE(sql_string||';');
              EXECUTE IMMEDIATE sql_string;
              sql_string := 'DROP PUBLIC SYNONYM '||REC.seq_nm;
              DBMS_OUTPUT.PUT_LINE(sql_string||';');
              EXECUTE IMMEDIATE sql_string;
              sql_string := 'CREATE PUBLIC SYNONYM '||REC.seq_nm||' FOR '||REC.owner||'.'||REC.seq_nm;
              DBMS_OUTPUT.PUT_LINE(sql_string||';');
              EXECUTE IMMEDIATE sql_string;
              sql_string := 'GRANT SELECT ON '||REC.owner||'.'||REC.seq_nm||' TO PUBLIC';
              DBMS_OUTPUT.PUT_LINE(sql_string||';');
              EXECUTE IMMEDIATE sql_string;
         END LOOP;
    END;

  • Issue with order or sequence of wbs elements appearance in planning layout

    Hi Experts
    we have an issue with order or sequence of wbs elements appearance in BPS planning layout.
    In BW - 0wbs element -  hierarchy order is as below
    1
    2
    3
    4
    5
    6
    7
    8
    but when we check the same wbs element in BPS planning layout, it appears as below
    1
    2
    3
    4
    6
    7
    5
    8
    Request you to advice how to correct the order.
    Best Regards
    krishna

    Hi,
    I came across a similar situation once. I dont remember exactly.
    We have two different DataSources on wbs hierarchy. The hiearchy was loaded using the two datasources.
    By mistake we were trying to use the hierarchy created by Datasource2, instead of hier created by datasource1.
    Can you check that.

  • Having issues with patches that require multiple reboots in a task sequence?

    Are you guys having issues doing a build and capture or deployment, while including the recent patches ?
    It looks like another patch is requiring multiple reboots which breaks the task sequence...
    Long story short... the last time I created a .Wim file was in June (with ZTIWindowsUpdate) - it included all the patches as of June 2014. This image has been deployed since then with no problem. All the other monthly patches (07/08/09/10/11/12/01) can be
    installed successfully through the deployment task sequence with no problem.
    Then last week, I decided to create a new .Wim file to include all the patches as of January 2015. In my build and capture step, it exits because one of the updates requires multiple reboot. I checked on the following website and it has not been updated
    since October 22nd : http://support.microsoft.com/kb/2894518
    Do any of you experiences issues with a WSUS that requires multiple reboot recently ?
    Thanks!

    As mentioned, the MDT offline updates task will do it. Add it to your build and capture and it will do the work for you using the updates in an update package that you've previously created. Alternatively, use a stand-alone instance of MDT to create your
    image (using a build and capture TS of course) -- this can then use a stand-alone instance of WSUS to install the updates into your image which you then import into ConfigMgr.
    Jason | http://blog.configmgrftw.com | @jasonsandys

  • Issue with xsd Data type mapping for collection of user defined data type

    Hi,
    I am facing a issue with wsdl for xsd mapping for collection of user defined data type.
    Here is the code snippet.
    sample.java
    @WebMethod
    public QueryPageOutput AccountQue(QueryPageInput qpInput)
    public class QueryPageInput implements Serializable, Cloneable
    protected Account_IO fMessage = null;
    public class QueryPageOutput implements Serializable, Cloneable
    protected Account_IO fMessage = null;
    public class Account_IO implements Serializable, Cloneable {
    protected ArrayList <AccountIC> fintObjInst = null;
    public ArrayList<AccountIC>getfintObjInst()
    return (ArrayList<AccountIC>)fintObjInst.clone();
    public void setfintObjInst(AccountIC val)
    fintObjInst = new ArrayList<AccountIC>();
    fintObjInst.add(val);
    Public class AccountIC
    protected String Name;
    protected String Desc;
    public String getName()
    return Name;
    public void setName(String name)
    Name = name;
    For the sample.java code, the wsdl generated is as below:
    <?xml version="1.0" encoding="UTF-8" ?>
    <wsdl:definitions
    name="SimpleService"
    targetNamespace="http://example.org"
    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
    xmlns:tns="http://example.org"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/"
    >
    <wsdl:types>
    <xs:schema version="1.0" targetNamespace="http://examples.org" xmlns:ns1="http://example.org/types"
    xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import namespace="http://example.org/types"/>
    <xs:element name="AccountWSService" type="ns1:accountEMRIO"/>
    </xs:schema>
    <xs:schema version="1.0" targetNamespace="http://example.org/types" xmlns:ns1="http://examples.org"
    xmlns:tns="http://example.org/types" xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import namespace="http://examples.org"/>
    <xs:complexType name="queryPageOutput">
    <xs:sequence>
    <xs:element name="fSiebelMessage" type="tns:accountEMRIO" minOccurs="0"/>
    </xs:sequence>
    </xs:complexType>
    <xs:complexType name="accountEMRIO">
    <xs:sequence>
    <xs:element name="fIntObjectFormat" type="xs:string" minOccurs="0"/>
    <xs:element name="fMessageType" type="xs:string" minOccurs="0"/>
    <xs:element name="fMessageId" type="xs:string" minOccurs="0"/>
    <xs:element name="fIntObjectName" type="xs:string" minOccurs="0"/>
    <xs:element name="fOutputIntObjectName" type="xs:string" minOccurs="0"/>
    <xs:element name="fintObjInst" type="xs:anyType" minOccurs="0" maxOccurs="unbounded"/>
    </xs:sequence>
    </xs:complexType>
    <xs:complexType name="queryPageInput">
    <xs:sequence>
    <xs:element name="fPageSize" type="xs:string" minOccurs="0"/>
    <xs:element name="fSiebelMessage" type="tns:accountEMRIO" minOccurs="0"/>
    <xs:element name="fStartRowNum" type="xs:string" minOccurs="0"/>
    <xs:element name="fViewMode" type="xs:string" minOccurs="0"/>
    </xs:sequence>
    </xs:complexType>
    </xs:schema>
    <schema xmlns="http://www.w3.org/2001/XMLSchema" targetNamespace="http://example.org"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:tns="http://example.org" xmlns:ns1="http://example.org/types">
    <import namespace="http://example.org/types"/>
    <xsd:complexType name="AccountQue">
    <xsd:sequence>
    <xsd:element name="arg0" type="ns1:queryPageInput"/>
    </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="AccountQue" type="tns:AccountQue"/>
    <xsd:complexType name="AccountQueResponse">
    <xsd:sequence>
    <xsd:element name="return" type="ns1:queryPageOutput"/>
    </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="AccountQueResponse" type="tns:AccountQueResponse"/>
    </schema>
    </wsdl:types>
    <wsdl:message name="AccountQueInput">
    <wsdl:part name="parameters" element="tns:AccountQue"/>
    </wsdl:message>
    <wsdl:message name="AccountQueOutput">
    <wsdl:part name="parameters" element="tns:AccountQueResponse"/>
    </wsdl:message>
    <wsdl:portType name="SimpleService">
    <wsdl:operation name="AccountQue">
    <wsdl:input message="tns:AccountQueInput" xmlns:ns1="http://www.w3.org/2006/05/addressing/wsdl"
    ns1:Action=""/>
    <wsdl:output message="tns:AccountQueOutput" xmlns:ns1="http://www.w3.org/2006/05/addressing/wsdl"
    ns1:Action=""/>
    </wsdl:operation>
    </wsdl:portType>
    <wsdl:binding name="SimpleServiceSoapHttp" type="tns:SimpleService">
    <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
    <wsdl:operation name="AccountQue">
    <soap:operation soapAction=""/>
    <wsdl:input>
    <soap:body use="literal"/>
    </wsdl:input>
    <wsdl:output>
    <soap:body use="literal"/>
    </wsdl:output>
    </wsdl:operation>
    </wsdl:binding>
    <wsdl:service name="SimpleService">
    <wsdl:port name="SimpleServicePort" binding="tns:SimpleServiceSoapHttp">
    <soap:address location="http://localhost:7101/WS-Project1-context-root/SimpleServicePort"/>
    </wsdl:port>
    </wsdl:service>
    </wsdl:definitions>
    In the above wsdl the collection of fintObjInst if of type xs:anytype. From the wsdl, I do not see the xsd mapping for AccountIC which includes Name and Desc. Due to which, when invoking the web service from a different client like c#(by creating proxy business service), I am unable to set the parameters for AccountIC. I am using JAX-WS stack and WLS 10.3. I have already looked at blog http://weblogs.java.net/blog/kohlert/archive/2006/10/jaxws_and_type.html but unable to solve this issue. However, at run time using a tool like SoapUI, when this wsdl is imported, I am able to see all the params related to AccountIC class.
    Can some one help me with this.
    Thanks,
    Sudha.

    Did you try adding the the XmlSeeAlso annotation to the webservice
    @XmlSeeAlso({<package.name>.AccountIC.class})
    This will add the schema for the data type (AccountIC) to the WSDL.
    Hope this helps.
    -Ajay

  • Routing Issue with 3550 Switch

    I am having an issue with routing with one of my Cisco 3550 switches.  I know the 3550s are EoL but some of us have to work with what we have.
    I am using a 3550 on either side of a Layer 2 link.  The Layer 2 link is 2 Extreme Summit X-440 switches with Microwave between the switches.  I have a VLAN configured on both switches and tagged on the ports connected to the Microwave.  The 3550 switch on each end is configured for IP routing but I cannot pass traffic between the switches.  If I unplug the switch on the local end and plug in a laptop, I can ping the switch on the remote end and access devices at the remote end. 
    I know this should work because I am doing the same thing over another Microwave link and Layer 2 link using another 3550 and a HP ProCurve at the remote end.
    Here are the configs for each 3550:
    Local end;  Port Fa0/23 goes to the Remote Side.  Port Fa0/24 goes to the rest of the network
    Current configuration : 5417 bytes
    ! No configuration change since last restart
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname Brindley3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring 1 Sun Apr 2:00 1 Sun Nov 2:00
    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos min-reserve 5 170
    mls qos min-reserve 6 10
    mls qos min-reserve 7 65
    mls qos min-reserve 8 26
    mls qos
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    ip name-server 1.2.150.5
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 18
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    |
    interface FastEthernet0/7
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/8
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     description To Gum Springs via Extreme P10
     no switchport
     ip address 1.2.147.1 255.255.255.252
     speed 100
     duplex full
    interface FastEthernet0/24
     description To Flint via Ceragon Eth 2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     mls qos trust cos
     auto qos voip trust
     wrr-queue bandwidth 20 1 80 1
     wrr-queue min-reserve 1 5
     wrr-queue min-reserve 2 6
     wrr-queue min-reserve 3 7
     wrr-queue min-reserve 4 8
     wrr-queue cos-map 1 0 1 2 4
     wrr-queue cos-map 3 3 6 7
     wrr-queue cos-map 4 5
     priority-queue out
     spanning-tree link-type point-to-point
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport access vlan 10
     switchport trunk native vlan 50
     switchport mode dynamic desirable
     spanning-tree portfast trunk
    interface Vlan1
     ip address 1.2.145.2 255.255.255.0
    ip default-gateway 1.2.145.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.145.1
    ip route 1.2.165.0 255.255.255.240 1.2.147.2
    ip route 1.2.166.0 255.255.255.240 1.2.147.2
    ip http server
    snmp-server community public RO
    snmp-server community public/RO RO
    snmp-server location Brindlee Mountain Tower Site
    snmp-server contact Jamey Wright
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  tty envmon syslog snmp
    control-plane
    ntp clock-period 17180143
    ntp server 1.2.150.21
    end
    And this is the config for the remote end.  Port Fa0/24 is the port for the link back to the local end.
    Current configuration : 5058 bytes
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname GS3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring
    mls qos map cos-dscp 0 8 16 24 32 46 46 56
    udld aggressive
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 21
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/2
     switchport access vlan 21
     switchport mode dynamic desirable
     power inline delay shutdown 20 initial 300
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     switchport access vlan 22
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     spanning-tree portfast
    interface FastEthernet0/24
     description To Brindlee via Extreme P10
     switchport mode dynamic desirable
    (Is a member of VLAN 1)
     speed 100
     spanning-tree portfast
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     spanning-tree portfast
    interface Vlan1
     ip address 1.2.147.2 255.255.255.252
    interface Vlan21
     ip address 1.2.165.1 255.255.255.240
     ip helper-address 1.2.150.11
     ip helper-address 1.2.150.5
    interface Vlan22
     ip address 1.2.166.1 255.255.255.240
     ip helper-address 1.2.150.5
     ip helper-address 1.2.150.11
    ip default-gateway 1.2.147.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.147.1 10
    ip http server
    snmp-server community public RO
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps hsrp
    snmp-server enable traps bridge newroot topologychange
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  envmon syslog snmp
    control-plane
    ntp clock-period 17180192
    ntp server 1.2.150.21 key 0 prefer
    Ideas?  Anything stand out as grossly wrong?  I have worked on this for 2 days and am at a loss.
    Thanks
    Jamey

    Sorry for the delay in replying.  Other items at the office took priority over this project.  I tried that and no change.  I pulled the switch from the remote site and took it back to the local end and connected the switches with a crossover cable and everything works fine.  I have pretty much determined that it is an issue with the config in one of the Extreme switches.  The config in those look pretty normal but there are a few things I am unsure of.  Guess I'll see if there is a similar site for Extreme gear.
    Thanks
    Jamey

  • Performance issues with Homesharing?

    I have a Time Capsule as the base station for my wireless network, then 2 Airport Express setup to extend the network around the house, an iMac i7 as the main iTunes Library and couple of iPads, and a couple of Apple TVs. Everything has the latest software, but I have several performance issues with Home sharing. I've done several tests making sure nothing is taking additional bandwidth, so here are the list of issues:
    1) With nothing else running, trying playing a movie via home sharing in an iPad 2 which is located on my iMac, it stops and I have to keep pressing the play button over and over again. I typically see that the iPad tries to download part of the movie first and then starts playing so that it deals with the bandwidth, but in many cases it doesn't.
    2) When trying to play any iTunes content (movies, music, photos, etc) from my Apple TV I can see my computer library, but when I go in on any of the menus, it says there's no content. I have to reboot the Apple TV and then problem fixed. I's just annoying that I have to reboot.
    3) When watching a Netflix movie on my iPad and with Airplay I send the sound to some speakers via Airplay through an Airport Express. At time I lose the connection to the speakers.
    I've complained about Wifi's instability, but here I tried to keep everything with Apples products to avoid any compatibility issues and stay within N wireless technology, which I understood it was much more stable.
    Has anyone some suggestions?

    Hi,
    you should analyze the db after you have loaded the tables.
    Do you use sequences to generate PKs? Do you have a lot of indexex and/or triggers on the tables?
    If yes:
    make sure your sequence caches (alter sequence s cache 10000)
    Drop all unneeded indexes while loading and disable trigger if possible.
    How big is your Redo Log Buffer? When loading a large amount of data it may be an option to enlarge this buffer.
    Do you have more then one DBWR Process? Writing parallel can speed up things when a checkpoint is needed.
    Is it possible using a direct load? Or do you already direct load?
    Dim

  • Performance issues with Planning data load & Agg in 11.1.2.3.500

    We recently upgraded from 11.1.1.3 to 11.1.2.3. Post upgrade we face performance issues with one of our Planning job (eg: Job E). It takes 3x the time to complete in our new environment (11.1.2.3) when compared to the old one (11.1.1.3). This job loads then actual data and does the aggregation. The pattern which we noticed is , if we run a restructure on the application and execute this job immediately it gets completed as the same time as 11.1.1.3. However, in current production (11.1.1.3) the job runs in the following sequence Job A->Job B-> Job C->Job D->Job E and it completes on time, but if we do the same test in 11.1.2.3 in the above sequence it take 3x the time . We dont have a window to restructure the application to before running Job E  every time in Prod. Specs of the new Env is much higher than the old one.
    We have Essbase clustering (MS active/passive) in the new environment and the files are stored in the SAN drive. Could this be because of this? has any one faced performance issues in the clustered environment?

    Do you have exactly same Essbase config settings and calculations performing AGG ? . Remember something very small like UPDATECALC ON/OFF can make a BIG difference in timing..

Maybe you are looking for