Javascript problem: can't update Select's option

Hi All,
I can't update a "Select" menu in a jsp page.
What I want to do is to create a menu list where I can insert elements clicking on a input button that calls the JavaScript function 'addctypeformat':
<input type="submit" name="addctypeformat" value="Add" onclick="confirmCtype('addctypeformat')">
but when i call the JavaScript function, the new element appears and suddenly desappears in the select element.
Here is the JavaScript code:
<SCRIPT LANGUAGE="JavaScript">
function confirmCtype(command) {
if(command=='addctypeformat') {
var current = "text_to_show_in_select";
addformat.imgctype.options[addformat.imgctype.length] = new Option(current);
</SCRIPT>
Can anybody help me?
Thank You very much
David

http://forums.webdeveloper.com has an excellent javascript forum.
And probably if you change your input from type="submit" to type="button" it will work a lot better.
The submit button will automatically reload the page for you - hence why it appears and immediately disappears
Cheers,
evnafets

Similar Messages

  • Can't update XML with optional element

    Hi,
    I'm trying to update an XML document (global XML Schema based) with an optional element (insert an optional element into an existing xml document).
    The update statement seems to work but the optional element is missing when I select the document!
    How can I update (insert) an optional element in an XML document?
    Thanx for your comments,
    Markus
    My scenario:
    ============
    XML Schema:
    <?xml version='1.0'?>
    <xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:xdb="http://xmlns.oracle.com/xdb">
    <xsd:element name="TestUpdate" xdb:defaultTable="TESTUPDATE">
    <xsd:complexType>
    <xsd:sequence>
    <xsd:element name="anElement" type="xsd:string" />
    <xsd:element name="optElement" type="xsd:string" minOccurs="0" />
    </xsd:sequence>
    </xsd:complexType>
    </xsd:element>
    </xsd:schema>
    SQL:
    begin
    dbms_xmlschema.registerSchema('xsd/TestUpdate.xsd',
    getDocument('testupdate.xsd'),
    FALSE);
    end;
    ALTER TABLE TestUpdate
    add constraint VALID_TestUpdate
    check (XMLIsValid(sys_nc_rowinfo$)=1);
    INSERT INTO TestUpdate values (xmltype(getDocument('TestUpdate.xml')))
    update TestUpdate x
    SET x = UPDATEXML(value(x),
    '/TestUpdate/optElement','<optElement> my optional Element</optElement>');
    ==> Message is: 1 row updated !!!!!!!!!!
    SQL> select * from testupdate;
    SYS_NC_ROWINFO$
    <TestUpdate xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespac
    eSchemaLocation="xsd/TestUpdate.xsd">
    <anElement>more text....</anElement>
    </TestUpdate>
    ==> No UPADATE performed!!!

    Thanks Pete,
    XPath evaluation may return no data and may cause the trouble of giving an 'success' answer.
    On the other side I have rewritten the statement:
    SQL> update testupdate x set x.XMLData."optElement" = ' just some text';
    SQL> select * from testupdate;
    SYS_NC_ROWINFO$
    <TestUpdate xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespac
    eSchemaLocation="xsd/TestUpdate.xsd">
    <anElement>more text....</anElement>
    </TestUpdate>
    ===> no UPDATE ???????
    SQL> select x.xmldata."optElement" from testupdate x;
    XMLDATA.optElement
    just some text
    ===> WOW, row is updated!!!!!!!!
    This result is more wired than before :-)
    (at least for myself)
    Can somebody explain the result?
    bye,
    Markus

  • Why is select calendar and address book greyed out? Why can we not select these options?

    Why can we not select address books or calendars? Why is this option greyed out in ITunes 12?

    You have to make the selection active.
    Go to Select>all, then Select>modify>border.
    Another way is to use a stroke:
    Open your picture file
    Go to Select>all
    Open a blank layer above this
    Go to Edit>stroke(outline) selection. In the  dialog, enter the width of the stroke, choose color, place it inside, ok it.
    If you don't like the border, delete the layer with the stroke, and adjust to suit, then do it over starting with step #3

  • Javascript problems after the update

    Ever since the latest software update on my Galaxy S3, I've been having problems with my internet.  I keep getting a message that I need to turn on JavaScript, but I already have JavaScript enabled in my browser.  I go into the settings, and then click advanced, and the box next to "Turn on JavaScript" has a check mark in it, and yet I can't do diddly squat on the internet.  This seems to be a sporadic problem.  One second everything will be working fine, and then all of the sudden I can't access any sites.  I Come back the next day and it's fine. For a little while, and then suddenly I'll get the message again.  Even if I'm on the internet and get the message and hit the back button to go to what I was just viewing, it suddenly won't be able to load.  Soooooo irritating!!  Anyone know how to fix this problem?

        I want to ensure you have a positive experience with your S3. What I would suggest is clearing data and cache from the browser. You may complete this by heading into Settings > Applications > Manage Apps > All > Browser -- Clear Data and Cache.
    YosefT_VZW
    Follow us on Twitter @VZWSupport

  • Apple account problem - can't update apps

    My daughter forgot her password for her apple account so we created a new account for her, one that I know the password for. She also doesn't remember the password for the email address attached to that account.
    We now get a message saying the account has been closed for security reasons.
    I don't know how we can get her updates now that when she tries to sync with the newly created account we get a message that says she "does own the major app" so it cannot update. How do I get the account information situation fixed with apple?!!! She has over 100 apps....some as much as $10/ea.

    I would give the itunes Apple people a call or email. I do not know a number or email address. When I click on the Support button in iTunes it times out.

  • 2611xm Terminal Server + ACS + reauthentication when selecting menu options

    Hi,
    I've managed to setup ACS Authentication on my  2611xm router,
    after you login to the router I have a autocommand setup to run a menu.
    My problem is  when you select the option on the menu,
    You are then re prompted to reauthenicated against  the router again before connecting to the line,
    can any one tell me how  to stop this from happening.
    Thanks for your time and effort in advance, I  have enclosed a config below.
    DDRAS01#sh running-config
    Building  configuration...
    Current configuration : 6854 bytes
    ! Last  configuration change at 10:28:49 AEST Sun Feb 21 2010 by <removed>
    !  NVRAM config last updated at 19:25:53 AEST Sat Feb 20 2010 by  <removed>
    version 12.4
    service timestamps  debug datetime msec
    service timestamps log datetime msec
    service  password-encryption
    service linenumber
    service  sequence-numbers
    hostname DDRAS01
    boot-start-marker
    boot-end-marker
    security  authentication failure rate 3 log
    security passwords min-length 6
    logging  buffered 51200 informational
    logging rate-limit all 10000
    logging  console critical
    enable password 7 <removed>
    aaa  new-model
    aaa authentication login default group  tacacs+ local
    aaa authentication login if_needed local
    aaa  authentication enable default enable
    aaa authentication ppp  default local
    aaa authorization exec default group tacacs+ local  if-authenticated
    aaa accounting exec default start-stop group  tacacs+
    aaa accounting commands 15 default start-stop group  tacacs+
    aaa session-id common
    clock timezone AEST 10
    clock  summer-time AEST recurring last Sun Oct 2:00 last Sun Mar 3:00
    no  network-clock-participate slot 1
    no network-clock-participate wic  0
    ip cef
    ip domain list  <removed>
    ip domain list <removed>
    ip domain  name <removed>
    ip host dd-cr-01e 2033 172.16.1.1
    ip  host ddsws01 2034 172.16.1.1
    ip host ddsws04 2035 172.16.1.1
    ip  host ddce565 2040 172.16.1.1
    ip name-server <removed>
    ip  name-server <removed>
    username  netops privilege 15 password 7 <removed>
    ip  ssh source-interface FastEthernet0/0
    ip ssh logging events
    ip  ssh version 2
    interface Loopback0
    ip  address 172.16.1.1 255.255.255.255
    interface  FastEthernet0/0
    ip address <removed> 255.255.255.0
    speed 100
    full-duplex
    interface Serial0/0
    no  ip address
    shutdown
    interface BRI0/0
    no ip  address
    encapsulation hdlc
    shutdown
    interface  FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    ip forward-protocol nd
    ip route 0.0.0.0  0.0.0.0 <removed>
    ip http server
    no ip http  secure-server
    ip tacacs source-interface FastEthernet0/0
    ip  radius source-interface FastEthernet0/0
    logging facility local6
    logging  <removed>
    snmp-server community <removed> RO
    snmp-server  community <removed> RW
    snmp-server location <removed>
    snmp-server  contact NetOps
    menu ddras01 title ^C
    Cisco  Terminal Server
    Select the number from the list below
    Use  'ctrl+shift+6' then 'x' to switch back to the menu
    ^C
    menu  ddras01 text 1 Connect to DD-CR-01
    menu ddras01 command 1 resume  dd-cr-01 /connect telnet dd-cr-01 2033
    menu ddras01 text 2 Connect  to DDSWS01
    menu ddras01 command 2 resume ddsws01 /connect telnet  ddsws01 2034
    menu ddras01 text 3 Connect to DDSWS04
    menu  ddras01 command 3 resume ddsws04 /connect telnet ddsws04 2035
    menu  ddras01 text 8 Connect to DDCE565
    menu ddras01 command 8 resume  ddce565 /connect telnet ddce565 2040
    menu ddras01 text 9 Exit
    menu  ddras01 command 9 menu-exit
    menu ddras01 clear-screen
    menu  ddras01 status-line
    menu ddras01 line-mode
    tacacs-server  host 10.2.0.50
    tacacs-server directed-request
    tacacs-server  key 7 <removed>
    control-plane
    privilege  exec level 15 write terminal
    privilege exec level 15 write
    privilege  exec level 1 ping
    privilege exec level 10 undebug ip icmp
    privilege  exec level 10 undebug ip
    privilege exec level 10 undebug all
    privilege  exec level 10 undebug
    privilege exec level 10 terminal monitor
    privilege  exec level 10 terminal
    privilege exec level 15 show  running-config
    privilege exec level 5 show configuration
    privilege  exec level 5 show
    privilege exec level 10 debug ip icmp
    privilege  exec level 10 debug ip
    privilege exec level 10 debug all
    privilege  exec level 10 debug
    privilege exec level 10 clear interface
    privilege  exec level 10 clear counters
    privilege exec level 10 clear
    line  con 0
    password 7 <removed>
    logging synchronous
    line  33 64
    no exec-banner
    exec-timeout 0 0
    no  activation-character
    no exec
    transport preferred telnet
    transport input all
    escape-character 27
    stopbits 1
    flowcontrol hardware
    line aux 0
    line vty 0 4
    password 7 <removed>
    logging synchronous
    autocommand  menu ddras01
    line vty 5 181
    password 7  <removed>
    logging synchronous
    autocommand  menu  ddras01
    ntp clock-period 17208487
    ntp source  FastEthernet0/0
    ntp server <removed>
    end

    Hi Jesse
    I have made the changes you recommended however i'm still getting prompted to reauthenticate each time I choose a menu entry,
    I have included a updated copy of the config, any help you can provide if greatly appreaciated.
    Thanks
    DDRAS01(config)#do sh runnin
    Building configuration...
    Current configuration : 7371 bytes
    ! Last configuration change at 17:55:22 AEST Sun Feb 21 2010 by david
    ! NVRAM config last updated at 11:07:30 AEST Sun Feb 21 2010 by david
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service linenumber
    service sequence-numbers
    hostname DDRAS01
    boot-start-marker
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200 informational
    logging rate-limit all 10000
    logging console critical
    enable password 7
    aaa new-model
    aaa authentication login default group tacacs+ local
    aaa authentication login if_needed local
    aaa authentication login NOAUTH none
    aaa authentication enable default enable
    aaa authentication ppp default local
    aaa authorization exec default group tacacs+ local if-authenticated
    aaa authorization exec NOAUTH none
    aaa accounting exec default start-stop group tacacs+
    aaa accounting commands 15 default start-stop group tacacs+
    aaa session-id common
    clock timezone AEST 10
    clock summer-time AEST recurring last Sun Oct 2:00 last Sun Mar 3:00
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    ip domain list
    ip domain list
    ip domain name
    ip host dd-cr-01 2033 172.16.1.1
    ip host ddsws01 2034 172.16.1.1
    ip host ddsws04 2035 172.16.1.1
    ip host ddce565 2040 172.16.1.1
    ip name-server
    ip name-server
    username netops privilege 15 password 7
    ip ssh source-interface FastEthernet0/0
    ip ssh logging events
    ip ssh version 2
    interface Loopback0
    ip address 172.16.1.1 255.255.255.255
    interface FastEthernet0/0
    ip address 255.255.255.0
    speed 100
    full-duplex
    interface Serial0/0
    no ip address
    shutdown
    interface BRI0/0
    no ip address
    encapsulation hdlc
    shutdown
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0
    ip http server
    no ip http secure-server
    ip tacacs source-interface FastEthernet0/0
    ip radius source-interface FastEthernet0/0
    logging facility local6
    logging
    snmp-server community RO
    snmp-server community RW
    snmp-server location
    snmp-server contact
    menu ddras01 title ^C
    Cisco Terminal Server
    Select the number from the list below
    Use 'ctrl+shift+6' then 'x' to switch back to the menu
    ^C
    menu ddras01 text 1 Connect to DD-CR-01
    menu ddras01 command 1 resume dd-cr-01 /connect telnet dd-cr-01 2033
    menu ddras01 text 2 Connect to DDSWS01
    menu ddras01 command 2 resume ddsws01 /connect telnet ddsws01 2034
    menu ddras01 text 3 Connect to DDSWS04
    menu ddras01 command 3 resume ddsws04 /connect telnet ddsws04 2035
    menu ddras01 text 8 Connect to DDCE565
    menu ddras01 command 8 resume ddce565 /connect telnet ddce565 2040
    menu ddras01 text a Clear connection to DD-CR-01
    menu ddras01 command a clear line 33
    menu ddras01 text b Clear connection to DDSWS01
    menu ddras01 command b clear line 34
    menu ddras01 text c Clear connection to DDSWS04
    menu ddras01 command c clear line 35
    menu ddras01 text h Clear connection to DDCE565
    menu ddras01 command h clear line 40
    menu ddras01 text x Exit Menu
    menu ddras01 command x menu-exit
    menu ddras01 text l Logout
    menu ddras01 command l logout
    menu ddras01 clear-screen
    menu ddras01 status-line
    tacacs-server host
    tacacs-server directed-request
    tacacs-server key 7
    control-plane
    privilege exec level 15 write terminal
    privilege exec level 15 write
    privilege exec level 1 ping
    privilege exec level 10 undebug ip icmp
    privilege exec level 10 undebug ip
    privilege exec level 10 undebug all
    privilege exec level 10 undebug
    privilege exec level 10 terminal monitor
    privilege exec level 10 terminal
    privilege exec level 15 show running-config
    privilege exec level 5 show configuration
    privilege exec level 5 show
    privilege exec level 10 debug ip icmp
    privilege exec level 10 debug ip
    privilege exec level 10 debug all
    privilege exec level 10 debug
    privilege exec level 10 clear interface
    privilege exec level 10 clear counters
    privilege exec level 10 clear
    line con 0
    password 7
    logging synchronous
    line 33 64
    no exec-banner
    exec-timeout 0 0
    no activation-character
    no exec
    transport preferred telnet
    transport input all
    escape-character 27
    stopbits 1
    flowcontrol hardware
    line aux 0
    line vty 0 4
    password 7
    logging synchronous
    autocommand  menu ddras01
    line vty 5 181
    password 7
    authorization exec NOAUTH
    logging synchronous
    login authentication NOAUTH
    autocommand  menu ddras01
    ntp clock-period 17208478
    ntp source FastEthernet0/0
    ntp server
    end

  • How can we create save layout option in grid tool bar

    hi,
    how can we create select layout option in grid tool bar to save my own layout. if any one knows tell me immediately
    thanks

    Hi again,
    1. We need to do 1 additional thing.
    data : GS_variant TYPE DISVARIANT.
    GS_variant-REPORT = sy-repid.
    2.  while calling pass this parameter also.
         IS_VARIANT                    = GS_variant
    It will work now.
    3. Moreover, I_SAVE has 3 options.
    I_SAVE = SPACE
    Layouts cannot be saved.
    I_SAVE = 'U'
    Only user-defined layouts can be saved.
    I_SAVE = 'X'
    Only global layouts can be saved.
    I_SAVE = 'A'
    Both user-defined and global layouts can be saved.
    regards,
    amit m.
    Message was edited by: Amit Mittal

  • E72 can't update important updates except via pc o...

    hello guys 
    how can i update my nokia e72 via fota 
    when i open the update app to update my device firmware i find only optional updates only can be updated , but important >options >only update via pc is the available option why?
    thanks  plz reply
    my current firmware ver. is in my signature
    Nokia E72-1 Black
    firmware : 053.001
    of 26 of nov 2010

    hello again now i'm running my e72 with fw 81.03
    but i noticed the following
    i tried the steps as u told me
    1) opened ovi and sure 1st time it crashed so i reopened and updated it successfully
    2) restarted device and pc and then connected them using usb cable
    3) started update
    1st time :160mb then at the end of download part (nokia updates is not available now plz try again later)
    2nd time 80 mb (wiered) anyways the same as above message
    3rd time (after 3 days) to be accurate 30/11 at 6:30 am egypt local time
    restarted both and tried and voilla 14 mb still wiered
    but it finished and device restarted but after the restart the device asked for pin and the quick start wizard which is normal as stated in nokia suite instructions
    but while was nokia suite at the finishing part (checking applications updates) a
    message appeared something went wrong plz go to nokia.com and reinstall the latest ver of nokia suite and try again  
    (12084)
    and when i pressed more details
    a green check mark was in a message with details
    firmware 81.3 with more enchantments and improvements
    so should i worry
    my device is now updated and it works and it was checking m card and the a message apppeared on phone (restart phone to see changes) nothing was removed even my installed apps like whatsapp and u tube and skype
    and i received a message from my nokia which wasn't optional (only ok option was available )
    but i found something suspicious
    which is i found a five digits no (delivered) at the reports section of messages (what was that? ) so i opened the sent items nothing was there so i opened log and only connections and incomming message from nokia was there, shall i worry for this too.
    Nokia E72-1 Black
    firmware : 053.001
    of 26 of nov 2010

  • Why can't I select all text in mail?

    I just upgraded my iPhone 4 to IOS 5, and noticed that I no longer have the option to 'select all' in a mail document?!?  If I tap &amp; hold on the document, my choices are 'copy', 'define', and 'speak'. The select all option is no longer present. I use this feature quite a bit &amp; I really want it back.  Is there some setting I can change somewhere?
    Thanks, anyone who can help
    Natalie

    i got same issue like you on iOS 5.0.1, not only in mail but also in safari or other apps.
    sometimes i can make the 'select all' option out but when i did it, did nothing.

  • I was getting messages that my Aperture Library was full, so I updated to Aperture 5.3.1. When I open it, I'm asked to update my library. When I select that option, I'm told that my library is full. Now I can't access my library at all. What should I do t

    Hi all,
    I was getting messages that my Aperture Library was full, so made an appointment at my closest Mac store, but have to wait 2 days. They advise you to update saoftware before coming in, so I updated to Aperture 5.3.1. When I open it, I'm asked to update my library. When I select that option, I'm told that my library is full. Now I can't access my library at all. What should I do to access my library? Do I have to uninstall 5.3.1 and reinstall an older version?
    Another problem I have recently encountered ... all the up and down scrollers on various screens have disappeared. They reappear fleetingly when I use my up and down arrowa, but I can't always catch them. How do I get my scrollers back?

    Thank you so much for your patient guidance and screen captures.
    You are welcome.
    My external hard drive is properly formatted for Aperture, so I am currently copying my Aperture library to it. That will take hours since it is copying 101 GB.
    o.k.
    I understand that I need to clean some space on my internal hard drive and reformat the Aperture library to get back in operation.
    You need to upgrade the Aperture library to be used with Aperture 3.5.1.  That will happen automatically, when you first double click the copied lirary to open it in Aperture.
    I'll also need to back up my external drive with a new external drive if I make space on my internal drive by removing some photos from there and store them on my current external drive.
    What do you use for backup? If you are using TimeMachine it is better to have only the Time Machine backup on the Time Machine drive . In that case would I put the Aperture library and other data on a new drive and keep the old drive for backup.

  • How can i remove my credit card from app store, the none option its not there and i don't Owen  nothing to apple, my last in app purchase was in clash of clans, please help!!! Because of that problem i cant update my apps! Plz help!!!!!

    How can i remove my credit card from app store, the none option its not there and i don't Owen  nothing to apple, my last in app purchase was in clash of clans, please help!!! Because of that problem i cant update my apps! Plz help!!!!!

    You've logged into your account and viewed your purchase history and there aren't any error messages shown (e.g. 'problem with a previous purchase'), and you haven't got any purchases due (e.g. pre-orders and/or subscriptions) : Why can’t I select None when I edit my Apple ID payment information ?

  • My keyboard is locked with a message that says, "carrier settings update available" but I can't select either option.....please advise

    My keyboard is locked with an update message and I can't select either option....how can I get going again?

    1. Hold the Sleep and Home button down together
    2. For about 10 seconds
    3. Until you see the Apple logo
    4. Ignore the red slider

  • HT4623 How can I update the IOS on my first generation IPAD? There is no software update option in my settings

    How can I update the IOS on my first generation IPAD? There is no software update option in my settings

    See the chart below to determine whether you can upgrade your device and what you can upgrade to. If you do not have a Software Update option present on your iDevice, then you are trying to upgrade to iOS 5 or higher. You will have to connect your device to your computer and open iTunes in order to upgrade.
    IPhone, iPod Touch, and iPad iOS Compatibility Chart
         Device                                       iOS Verson
    iPhone 1                                      iOS 3.1.3
    iPhone 3G                                   iOS 4.2.1
    iPhone 3GS                                 iOS 6.1.x
    iPhone 4                                      iOS 6.1.x
    iPhone 4S                                    iOS 6.1.x
    iPhone 5                                      iOS 6.1.x
    iPod Touch 1                               iOS 3.1.3
    iPod Touch 2                               iOS 4.2.1
    iPod Touch 3                               iOS 5.1.1
    iPod Touch 4                               iOS 6.1.x
    iPod Touch 5                               iOS 6.1.x
    iPad 1                                          iOS 5.1.1
    iPad 2                                          iOS 6.1.x
    iPad 3                                          iOS 6.1.x
    iPad 4                                          iOS 6.1.x
    iPad Mini                                     iOS 6.1.x
    =====================================
    Select the method most appropriate for your situation.
    Upgrading iOS
       1. How to update your iPhone, iPad, or iPod Touch
       2. iPhone Support
       3. iPod Touch Support
       4. iPad Support
         a. Updating Your iOS to Version 6.0.x from iOS 5
              Tap Settings > General > Software Update
         If an update is available there will be an active Update button. If you are current,
         then you will see a gray screen with a message saying your are up to date.
         b. If you are still using iOS 4 — Updating your device to iOS 5 or later.
         c. Resolving update problems
            1. iOS - Unable to update or restore
            2. iOS- Resolving update and restore alert messages

  • HT4623 How can I update ios if "software update" option is not showing on the page "General"?  On my Iphone, it only show "About" and "Usage" next to each other.

    How can I update iOS 4.2.1 to the latest iOS if "software update" option is not showing on the page "General"? On my Iphone, it only show "About" and "Usage" . Please help.

    See the chart below to determine whether you can upgrade your device and what you can upgrade to.
    IPhone, iPod Touch, and iPad iOS Compatibility Chart
         Device                                       iOS Verson
    iPhone 1                                      iOS 3.1.3
    iPhone 3G                                   iOS 4.2.1
    iPhone 3GS                                 iOS 6.1.x
    iPhone 4                                      iOS 6.1.x
    iPhone 4S                                    iOS 6.1.x
    iPhone 5                                      iOS 6.1.x
    iPod Touch 1                               iOS 3.1.3
    iPod Touch 2                               iOS 4.2.1
    iPod Touch 3                               iOS 5.1.1
    iPod Touch 4                               iOS 6.1.x
    iPod Touch 5                               iOS 6.1.x
    iPad 1                                          iOS 5.1.1
    iPad 2                                          iOS 6.1.x
    iPad 3                                          iOS 6.1.x
    iPad 4                                          iOS 6.1.x
    iPad Mini                                     iOS 6.1.x
    =====================================
    Select the method most appropriate for your situation. If you are trying to upgrade to iOS 5 or higher, then you will have to connect your device to your computer and open iTunes in order to upgrade.
    Upgrading iOS
       1. How to update your iPhone, iPad, or iPod Touch
       2. iPhone Support
       3. iPod Touch Support
       4. iPad Support
         a. Updating Your iOS to Version 6.0.x from iOS 5
              Tap Settings > General > Software Update
         If an update is available there will be an active Update button. If you are current,
         then you will see a gray screen with a message saying your are up to date.
         b. If you are still using iOS 4 — Updating your device to iOS 5 or later.
         c. Resolving update problems
            1. iOS - Unable to update or restore
            2. iOS- Resolving update and restore alert messages

  • My Itunes is no longer allowing me to manage my music on my phone i can no longer select on my iphone to make playlists and delete music. Please help fix my problem.

    My Itunes is no longer allowing me to manage my music on my phone i can no longer select on my iphone to make playlists and delete music. Please help fix my problem. Iphone4s, 32gigs, IOS 7.1.2
    I don't know why it stopped working but it happened a month or two ago but the option on this phone that's usually all the way to the left when you select your device but now its not and I don't know what caused it. ive already tried troubleshooting my problem but have found no help.

    Hello Salmomma,
    Thank you for the details of the issue you are experiencing when trying to connect your iPhone to your Mac.  I recommend following the steps in the tutorial below for an issue like this:
    iPhone not appearing in iTunes
    http://www.apple.com/support/iphone/assistant/itunes/
    Additionally, you can delete music directly from the iPhone by swiping the song:
    Delete a song from iPhone: In Songs, swipe the song, then tap Delete.
    iPhone User Guide
    http://manuals.info.apple.com/MANUALS/1000/MA1658/en_US/iphone_ios6_user_guide.p df
    Thank you for using Apple Support Communities.
    Best,
    Sheila M.

Maybe you are looking for

  • What is a good case for iPhone 5? both stylish and protective.

    I want a new case for my iphone 5 i want something thats both good looking and can protect my Phone. especialy shock absorbing. my phone fell like 7 times including 1 hard fall ever since Google app is messed up ( letters override eachother) so yeah.

  • Making the thumbnail view larger for templates

    Hello - I was working on my resume last night on Pages (new to mac) and found myself having to click on a template to be able to see the layout, then close it out if I did not like and repeat ad nauseum. Is there a way to make the view of the templat

  • Can't see words in browsers and Mail

    Hi, I started having issues with the way words (letters) are been displayed in Mac Mail or any of y browsers. Basically, they do not show (see attached). Notice how the text inside the buttons is not been displayed. Any idea how to fix this? I've sea

  • How to transfer my itunes library to my new laptop

    i will be buying a laptop soon and want to transfer my library to my new laptop permanently, how do i get this done. or does both computers automatically have the same songs even months after

  • Games crashing - sim city 4, kelly slater surfer

    Sim City 4 crashes on install unknown error has occurred...and kelly slater crashes when opening surf location. I've downloaded the KSS patch - doesn't work. And since Sim City 4 won't install, I can't install the patch. I have a 17" Macbook pro 2 gi