JMF over the Internet / NAT problems

Hi folks,
I wonder if someone could help me out. I'm trying to get RTP streaming to work over the internet; specifically to get a server (with a public IP) to send an RTP stream to a client behind a NAT (so with a private IP address). This is the set-up I have at the moment:
Client expects RTP traffic from server to arrive at its local port A. The server sends out RTP traffic from its local port B (i.e. the RTPManager running on the server is initialised with port B).
Before any RTP transmission occurs, the client sends a few UDP packets from its local port A to the server's port B and also to a different port C. The server listens to these packets on port C, and extracts the client's public IP and port (i.e. the IP address of the NAT router plus the public port on the NAT that is mapped to port A on the client).
When the server starts the streaming shortly afterwards, it sends the RTP packets to the public IP/port it detected earlier. The idea being the NAT should forward those packets to port A on the client. But this doesn't seem to be working....
Does anyone have any ideas what's going wrong? Has anyone else had to tackle similar issues?
Thanks in advance for any help.

* @(#)RTPSocketAdapter.java     1.2 01/03/13
* Copyright (c) 1999-2001 Sun Microsystems, Inc. All Rights Reserved.
* Sun grants you ("Licensee") a non-exclusive, royalty free, license to use,
* modify and redistribute this software in source and binary code form,
* provided that i) this copyright notice and license appear on all copies of
* the software; and ii) Licensee does not utilize the software in a manner
* which is disparaging to Sun.
* This software is provided "AS IS," without a warranty of any kind. ALL
* EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY
* IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR
* NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN AND ITS LICENSORS SHALL NOT BE
* LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING
* OR DISTRIBUTING THE SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN OR ITS
* LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT,
* INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER
* CAUSED AND REGARDLESS OF THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF
* OR INABILITY TO USE SOFTWARE, EVEN IF SUN HAS BEEN ADVISED OF THE
* POSSIBILITY OF SUCH DAMAGES.
* This software is not designed or intended for use in on-line control of
* aircraft, air traffic, aircraft navigation or aircraft communications; or in
* the design, construction, operation or maintenance of any nuclear
* facility. Licensee represents and warrants that it will not use or
* redistribute the Software for such purposes.
package org.zajacslv.java.Telefon;
import java.io.IOException;
import java.net.InetAddress;
import java.net.DatagramSocket;
import java.net.MulticastSocket;
import java.net.DatagramPacket;
import java.net.SocketException;
import javax.media.protocol.DataSource;
import javax.media.protocol.PushSourceStream;
import javax.media.protocol.ContentDescriptor;
import javax.media.protocol.SourceTransferHandler;
import javax.media.rtp.RTPConnector;
import javax.media.rtp.OutputDataStream;
* An implementation of RTPConnector based on UDP sockets.
public class RTPSocketAdapter implements RTPConnector {
DatagramSocket dataSock;
DatagramSocket ctrlSock;
InetAddress addr;
int port;
int portC;
SockInputStream dataInStrm = null, ctrlInStrm = null;
SockOutputStream dataOutStrm = null, ctrlOutStrm = null;
public RTPSocketAdapter(InetAddress addr, int port) throws IOException {
     this(addr, port, 1);
public RTPSocketAdapter(DatagramSocket dsRTP, DatagramSocket dsRTCP,
InetAddress IaRTP, int portRTP, InetAddress IaRTCP, int portRTCP)
dataSock = dsRTP;
ctrlSock = dsRTCP;
//IaRTP == IaRTCP;
//portRTP+1 == portRTCP przez firewoll moze byc inaczej !!!
addr = IaRTP;
port = portRTP;
portC = portRTCP;
public RTPSocketAdapter(InetAddress addr, int port, int ttl) throws IOException {
     try {
     if (addr.isMulticastAddress()) {
          dataSock = new MulticastSocket(port);
          ctrlSock = new MulticastSocket(port+1);
          ((MulticastSocket)dataSock).joinGroup(addr);
          ((MulticastSocket)dataSock).setTimeToLive(ttl);
          ((MulticastSocket)ctrlSock).joinGroup(addr);
          ((MulticastSocket)ctrlSock).setTimeToLive(ttl);
     } else {
          dataSock = new DatagramSocket(port, InetAddress.getLocalHost());
          ctrlSock = new DatagramSocket(port+1, InetAddress.getLocalHost());
     } catch (SocketException e) {
     throw new IOException(e.getMessage());
     this.addr = addr;
     this.port = port;
portC = port+1;
* Returns an input stream to receive the RTP data.
public PushSourceStream getDataInputStream() throws IOException {
     if (dataInStrm == null) {
     dataInStrm = new SockInputStream(dataSock, addr, port);
     dataInStrm.start();
     return dataInStrm;
* Returns an output stream to send the RTP data.
public OutputDataStream getDataOutputStream() throws IOException {
     if (dataOutStrm == null)
     dataOutStrm = new SockOutputStream(dataSock, addr, port);
     return dataOutStrm;
* Returns an input stream to receive the RTCP data.
public PushSourceStream getControlInputStream() throws IOException {
     if (ctrlInStrm == null) {
     ctrlInStrm = new SockInputStream(ctrlSock, addr, portC);
     ctrlInStrm.start();
     return ctrlInStrm;
* Returns an output stream to send the RTCP data.
public OutputDataStream getControlOutputStream() throws IOException {
     if (ctrlOutStrm == null)
     ctrlOutStrm = new SockOutputStream(ctrlSock, addr, portC);
     return ctrlOutStrm;
* Close all the RTP, RTCP streams.
public void close() {
     if (dataInStrm != null)
     dataInStrm.kill();
     if (ctrlInStrm != null)
     ctrlInStrm.kill();
     dataSock.close();
     ctrlSock.close();
* Set the receive buffer size of the RTP data channel.
* This is only a hint to the implementation. The actual implementation
* may not be able to do anything to this.
public void setReceiveBufferSize( int size) throws IOException {
     dataSock.setReceiveBufferSize(size);
* Get the receive buffer size set on the RTP data channel.
* Return -1 if the receive buffer size is not applicable for
* the implementation.
public int getReceiveBufferSize() {
     try {
     return dataSock.getReceiveBufferSize();
     } catch (Exception e) {
     return -1;
* Set the send buffer size of the RTP data channel.
* This is only a hint to the implementation. The actual implementation
* may not be able to do anything to this.
public void setSendBufferSize( int size) throws IOException {
     dataSock.setSendBufferSize(size);
* Get the send buffer size set on the RTP data channel.
* Return -1 if the send buffer size is not applicable for
* the implementation.
public int getSendBufferSize() {
     try {
     return dataSock.getSendBufferSize();
     } catch (Exception e) {
     return -1;
* Return the RTCP bandwidth fraction. This value is used to
* initialize the RTPManager. Check RTPManager for more detauls.
* Return -1 to use the default values.
public double getRTCPBandwidthFraction() {
     return -1;
* Return the RTCP sender bandwidth fraction. This value is used to
* initialize the RTPManager. Check RTPManager for more detauls.
* Return -1 to use the default values.
public double getRTCPSenderBandwidthFraction() {
     return -1;
* An inner class to implement an OutputDataStream based on UDP sockets.
class SockOutputStream implements OutputDataStream {
     DatagramSocket sock;
     InetAddress addr;
     int port;
     public SockOutputStream(DatagramSocket sock, InetAddress addr, int port) {
     this.sock = sock;
     this.addr = addr;
     this.port = port;
     public int write(byte data[], int offset, int len) {
     try {
          sock.send(new DatagramPacket(data, offset, len, addr, port));
     } catch (Exception e) {
          return -1;
     return len;
* An inner class to implement an PushSourceStream based on UDP sockets.
class SockInputStream extends Thread implements PushSourceStream {
     DatagramSocket sock;
     InetAddress addr;
     int port;
     boolean done = false;
     boolean dataRead = false;
     SourceTransferHandler sth = null;
     public SockInputStream(DatagramSocket sock, InetAddress addr, int port) {
     this.sock = sock;
     this.addr = addr;
     this.port = port;
     public int read(byte buffer[], int offset, int length) {
     DatagramPacket p = new DatagramPacket(buffer, offset, length, addr, port);
     try {
          sock.receive(p);
     } catch (IOException e) {
          return -1;
     synchronized (this) {
          dataRead = true;
          notify();
     return p.getLength();
     public synchronized void start() {
     super.start();
     if (sth != null) {
          dataRead = true;
          notify();
     public synchronized void kill() {
     done = true;
     notify();
     public int getMinimumTransferSize() {
     return 2 * 1024;     // twice the MTU size, just to be safe.
     public synchronized void setTransferHandler(SourceTransferHandler sth) {
     this.sth = sth;
     dataRead = true;
     notify();
     // Not applicable.
     public ContentDescriptor getContentDescriptor() {
     return null;
     // Not applicable.
     public long getContentLength() {
     return LENGTH_UNKNOWN;
     // Not applicable.
     public boolean endOfStream() {
     return false;
     // Not applicable.
     public Object[] getControls() {
     return new Object[0];
     // Not applicable.
     public Object getControl(String type) {
     return null;
     * Loop and notify the transfer handler of new data.
     public void run() {
     while (!done) {
          synchronized (this) {
          while (!dataRead && !done) {
               try {
               wait();
               } catch (InterruptedException e) { }
          dataRead = false;
          if (sth != null && !done) {
          sth.transferData(this);
}

Similar Messages

  • Bought 4th Gen 3TB TC - streaming TV over the internet is now so slow and now is constantly buffering.  It seems the Airport Utility is always 'searching for new networks' - don't know if this is the problem.  It's not the internet speed as checked that.

    Bought 4th Gen 3TB TC - streaming TV over the internet is now so slow and now is constantly buffering.  It seems the Airport Utility is always 'searching for new networks' - don't know if this is the problem.  It's not the internet speed as checked that.  I took my old router upstairs and was streaming TV via my ipad seamlessly - the same program via the TC was constantly buffering.
    I just expected to be able to plug in the TC, so a simple set-up and experience wireless both upstairs and downstairs in my house.  For some reason the range is low and speed veru disappointing.
    I am far from being an IT expert but I would welcome advice about setting up this TC so we can enjoy the product as it was designed.  Please HELP!

    No silver bullet........but my suggestions may drive you in the right direction.
    1.  Unplug the power cable from the TC and wait 10-15 minutes before powering back up.   Seriously wait!
          Proceed to #2 if this dosen't help.
    2.  Unplug the power cable from the TC, ubplug the power cable from your Broadband Modem (assuming it's a cable modem), disconnect ethernet, and cable from modem. 
    2a.  Wait 10-15 minutes then re-connect cable, ethernet, and power back to modem (your modem should power up unless you have a power switch)  wait for all the modem lights to come on EXCEPT activity.
    2b.  Connect ethernet from modem to TC, and plug in the power cable to TC.
          Proceed to #3 if this dosen't help.
    3.  Reconfigure the TC.........Read here........http://support.apple.com/kb/HT3728
    All really simple to do....if you need additional help let me (us) know.

  • A problem was encountered while trying to send information over the Internet.

    I have CS3 - Design Premium.
    I had it installed on my old computer which crashed and was reformatted. I have a new computer now and am trying to install it again but I am getting an error that says:
    Registration Unscuccessful
    A Problem was encountered while trying to send information over the internet.
    My internet is obviously working since this is the same computer...

    I was getting the error “Registration Unsuccessful”, “A problem was encountered while trying to send information over the Internet” at start-up of "Acrobat 8 Pro" on Windows 8.1.
    Setting compatibility on the .exe file to "Windows XP, Service Pack 3" didn't work for me.   The problem persisted.
    I was told by someone at Adobe support (by chat) to try this, but this didn't work either:
    1. Disconnect your Internet connection by disconnecting the cable or by turning off Wi-Fi.
    2. Relaunch the Adobe application.
    3. When the registration prompt appears, select "Never Register."
    4. Connect to the Internet.
    I finally made the error at start up go away as follows: 
    First I found that if I run the Acrobat.exe file as Administrator it doesn't give the error. (I do have to approve a user account control to do this.)  I right clicked the actual Acrobat.exe file and selected "Run as administrator".  You may be able to also right click the icon on you desktop and do the same.
    While running the application as Administrator, I then tried a few things:  Clicking “Never Register”, and “Deactivating” and “Reactivating” the license, and then clicking “Never Register” again... while running the application as Administrator. Some combination of those actions seems to have cleared up the problem for when I run the application with normal privileges.

  • Accessing my Time Capsule hard drive over the internet via iCloud doesn't work.

    Hi Everyone,
    I have an iCloud account and read recently, that it is possible to acces the hard drive of an Time Capsule over the internet, if "Back to my Mac" is activated on my MacBook an the Time Capsule.
    I updated the Time Capsule to Firmware Version 7.6.1 and the Airport Utility to version 6. Actually the Time Capsule HDD is displayes in Finder's Sidebar, when I'm using a forreign internet connection. But when I click on it an error message tells me that a connection to the server (I assume server=Time Capsule) cannot be established. Funnily enough I can access the HDD of my iMac at home.
    The Time Capsule network setting is "Bridge Mode" Since I can't deactivate the DNS functionality of my router/mode, an easybox 803 A, unfortunately which I cannot replace, because it is also used for hosting the telephone.
    Does anybody have an idea, where the problem could be? Wrong settings in the Time Capsule config or maybe the blocking by the router?
    Thank you all in advance,
    Markus
    Please consider, that I have absolutely no idea of networking.

    I don't know exactly how, but I got it working. I will try to explain, what I did.
    1. I used the easybox as DHCP-Server an set the TC to Bridge Mode.
    2. Then I gave the TC a fixed IP in the easbybox menu by using it's MAC-address (It seems that the address range has to be either 192.168.X.Y or 10.0.X.Y to make the TC accessable later).
    3. I made the TC a DHCP-Server (DHCP only, not also NAT). The IP addess range of the TC starts after it's own IP adress (10.0.0.111) and ends at (10.0.0.250). The IP range of the easybox starts with 10.0.0.1 (it's own) and end with the TC's (10.0.0.111).
    4. Then the Airport Utility told me that if I want to share an DHCP range the TC has to be set to a fixed IP setting, which I set up, leaving the IP-address 10.0.0.111 and the Router IP 10.0.0.1 (the easyboxs').
    5. Then it worked in my case. Since I don't even know what I did, I'm not shure if it workes under other circumstances.
    There are of course many variables. Such as the type of the router and the TC or the kind of the internet connection.

  • RTP Streaming over the internet

    Having some problems streaming over the internet - probably because im doing it wrong.
    I can stream over a network fine using Transmit2.java.
    But when i try over the internet cant pick up the stream.
    Im using www.whatismyip.com to get the internet IP of the 2 computers im trying to stream to and from - and using these in the code, but nothing happens.
    Help?

    natdeamer wrote:
    Having some problems streaming over the internet - probably because im doing it wrong.That's correct, you're doing it wrong.
    Im using www.whatismyip.com to get the internet IP of the 2 computers im trying to stream to and from - and using these in the code, but nothing happens.99% of the time, your public IP actually addresses your router, rather than your computer. That means your computer is not publically addressably by it's IP address alone. You'll need to do something called a "NAT holepunch", which you can look up online. Also, I've included two links to discussions I've had with people about the same issue.
    [http://forums.sun.com/thread.jspa?forumID=28&threadID=5355413]
    [http://forums.sun.com/thread.jspa?forumID=28&threadID=5356672]

  • SNA over the Internet

    I am tasked with finding cheaper broadband solutions for connecting remote facilities back to corporate. I need to set up IPSEC tunnels from the remote to corporate that allow me to not have to change my current private addressing. This I believe I should have no problems accomplishing. The tricky part is I also have to run SNA over the Internet. Has any one tried to run a DLSW type connection over a DSL or Cable modem IPSEC tunnel. If so did, did it work or was the latency of the Internet too large to keep the dlsw peers active?
    Any suggestions are appreciated.

    Hi,
    if you want to run dlsw over a vpn/nat solution you need to look at the following:
    http://www.cisco.com/en/US/partner/tech/tk331/tk336/technologies_tech_note09186a0080093db6.shtml
    this discusses problems with dlsw version 1, RFC1795, this is the default for cisco routers. The point is that the dlsw peer establishment is defined as a bringup of two single tcp connections until the capabilities exchange is done. Each router opens his own write pipe and recieves the read pipe from the other one. So each of them has two tcp pipes open at that point. Then the router with the "numerical" higher ip address drops his pipe on the local tcp port 2065.
    This can cause quite some trouble if you dont control the ip nat translation inbetween. So both sides either think they have the numericaly higher ip address on its local peer and both drop the connection or both think they have the lower one and the connection times out.
    Additional we commited a change to dlsw with CSCeb47150 which allows the remote device to bring up a dlsw version 2, RFC2166, peer to head end system, and in that case the peer bringup is defined with only one tcp pipe and the whole problem with who has the numericaly higher or lower ip address does not exist anymore. I copy the release note for CSCeb47150 right below here:
    Symptom: Customer has DLSW defined at two locations. The locations are connected together over a
    VPN tunnel. The peers start to establish and drop after capabilities excahnge.
    Conditions: NAT is being used but outside the customer's point of control.
    Problem: DLSw Version 1, RFC1795, defines the dlsw peer with tcp encapsulation to use 2 tcp pipes
    for the peer bringup. A Write and a Read pipe. Both routers establish their respective Write pipe.
    That means that if router A opens a dlsw peer to router B router A establishes his Write pipe to
    router B and router B than establishes his Write Pipe back to router A. Next the capabilities
    exchange happens and during this exchange the two routers decide if they can drop one tcp
    connection and use the resulting tcp session for traffic in both directions. This decision is
    based on the numericaly order of the local peer ip addresses. The peer with the numericaly higher
    ip address is supposed to drop his tcp pipe. This is defined in RFC 1795 section 7.6.7.
    If ip NAT is used inbetween the two dlsw peer routers and the NAT is changing the order of numericaly
    higher or lower local peer ip address the peer may fail to establish. Both routers may think that they
    are the higher ip address and both drop their tcp session or both think they are the lower ip address
    and wait for the other end to take action.
    Workaround: The user must preserve the numericaly order of the dlsw local peer ip addresses through
    ip NAT. This is not always possible and in any case it is not an easy task.
    Solution:
    This ddts added a new configuration option to the dlsw peer statements:
    v2-single-tcp
    This is intended to do the following:
    DLSw Version 2, RFC2166, defines the dlsw tcp peer bringup with a single tcp session. So above Problem
    does not exist anymore since there is only one tcp session and it makes no difference which end has the
    numericaly higher or lower ip address.
    The v2-single-tcp keyword will instruct this router to bring up a dlsw Version 2 peer and thus both routers
    will automatically only use 1 tcp session to establish the peer.
    The usage of the new keyword should be like this:
    Branch router A tries to establish a dlsw peer to data center router B.
    Data center router B is running ios 12.0 or higher and thus already supporting dlsw version 2.
    The dlsw local peer configuration on data center router B is either promiscous, to allow any incoming
    peer connection, or if you have to configure each connection individual the peer to branch router A is
    configured to be passive.
    Branch router A is configured on his dlsw remote-peer statement with the new keyword v2-single-tcp and thus
    it starts a version 2 peer to the central data center router A.
    Caveats:
    DLSw version 2 does not support priority peers.
    thanks...
    Matthias

  • Accessing a local server web service over the internet

    Hello,
    This is not the first time i will configure over the internet access to a local server but this particular one is giving me a major headache and i thought to share the config with anyone who can help ppoint where the problem may be. While my NAT transalations seem to be working, when i attempt to browse the public IP, i am supposed to be routed to the local server, but this doesnt happen and i just get a blank page on my web browser. Please see config below:
    J#sh run
    Building configuration...
    Current configuration : 5368 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname J
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$aNyD$j4lIgFXI84Xp9RR5dzwVk0
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    clock timezone PCTime 1
    crypto pki trustpoint TP-self-signed-1366127775
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1366127775
    revocation-check none
    rsakeypair TP-self-signed-1366127775
    crypto pki certificate chain TP-self-signed-1366127775
    certificate self-signed 01
      30820255 308201BE A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31333636 31323737 3735301E 170D3032 30333031 30303533
      35315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33363631
      32373737 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100CCDC 58E9E078 C978DBC5 CD0D97A0 6B506E2B 4843F38C 578721BF 285EC7BF
      F3700E9C FAD9233C A4CC95F6 F29FE5CD 4664F85F 862FB879 1255F21B 725A2773
      E1E4BEC0 632A7FFD C383F08E D5FAA4FC 4558BE6B 1B383D7E 19A871F6 3BAB9BAE
      B7CB84BB 510A09A3 FA260893 B0BD5AB1 027C97C6 2B2D2B6C AE2683FC AC3015B6
      CE8F0203 010001A3 7D307B30 0F060355 1D130101 FF040530 030101FF 30280603
      551D1104 21301F82 1D4C494E 45545241 4C455F41 424A2E6C 696E6574 72616C65
      2E6C6F63 616C301F 0603551D 23041830 16801434 DD7F3F33 59A951AA 1BBBF414
      59302323 10248530 1D060355 1D0E0416 041434DD 7F3F3359 A951AA1B BBF41459
      30232310 2485300D 06092A86 4886F70D 01010405 00038181 00A9C9DF 5D2F2042
      0AA151FF 72F7D52A 8244C102 4AEDDB6E C7FBA201 A283D693 5F5E9376 0D15E7FE
      EBB804A5 C08F6CA1 A416118F D5A06864 EF242404 091F2FFE 3F85B0DE 98E1F747
      AC5FBBDE 1E27AE14 64D71B5F A1A48EC7 90882BD2 C3617E7C 8D6426A0 EDA23AB1
      32350B15 5E2489F6 018A76A0 3E1595DA 6797723E 563D268A 66
                quit
    dot11 syslog
    no ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.111 192.168.1.254
    ip dhcp pool J
       import all
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.254
       domain-name linetrale.local
       dns-server 192.168.1.254
    no ip bootp server
    ip domain name linetrale.local
    crypto ipsec transform-set 3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set AES-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set 3DES-SHA-compression esp-3des esp-sha-hmac comp-lzs
    crypto ipsec transform-set AES-SHA-compression esp-aes esp-sha-hmac comp-lzs
    crypto ipsec transform-set ESP-3DES-SHA2 esp-3des esp-sha-hmac
    archive
    log config
      hidekeys
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh authentication-retries 2
    interface FastEthernet0
    switchport access vlan 101
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description WAN_FW_OUTSIDE$ETH-WAN$
    ip address x.x.x.x 255.255.255.192
    ip verify unicast reverse-path
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1400
    ip nat outside
    ip virtual-reassembly
    ip route-cache flow
    ip tcp adjust-mss 1380
    duplex auto
    speed auto
    interface Vlan1
    no ip address
    interface Vlan101
    description LAN_FW_INSIDE
    ip address 192.168.1.254 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip accounting output-packets
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 y.y.y.y
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip dns server
    ip nat inside source list 1 interface FastEthernet4 overload
    ip nat inside source static tcp 192.168.1.243 80 x.x.x.x 80 extendable
    ! x.x.x.x is the public IP
    access-list 1 remark INSIDE_IF=VLAN101
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.1.0 0.0.0.255
    control-plane
    line con 0
    no modem enable
    transport output telnet
    speed 115200
    line aux 0
    modem InOut
    transport output telnet
    stopbits 1
    speed 115200
    flowcontrol hardware
    line vty 0 4
    privilege level 15
    terminal-type moni
    transport input telnet ssh
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    webvpn context Default_context
    ssl authenticate verify all
    no inservice
    end
    Any help will be really appreciated.
    Regards,
    Femi

    Hi Alain,
    Browsing the public IP from a remote location to the site, so its over the internet.
    Not sure I understand what you refer to as SVI, could this be the VLAN? If it is, then I can say it is up because I can ping the server which is on this VLAN from within the router when I log into it. Also, when I am within the LAN, I am able to browse to the local IP on the server.
    I suspect some firewall or access list issue may be preventing something...
    Regards,
    Femi

  • How do I backup my time capsule to another time capsule over the internet

    I have a Time Capsule that I use for backups locally within my own home. My parents have one as well that they use for their backups. Ideally it would be great to have my backups offsite -- if your house burns down it doesn't help that your backups were in the house...
    So is there a way to copy (automatically) the image from one TC to another and vice versa over the internet?

    No, there isn't, and even if there was, it would take forever, or possibly longer. 
    Any backup done over the internet will be quite slow; upload speeds are generally much, much slower than download speeds.  Some of the companies that do internet backups, such as Mozy, Carbonite, etc., actually ship you an external HD for the first backup.  You ship that back, they load it onto their servers, then do "incremental" backups of what's changed over the net.
    In addition, it's not a good idea to back up a backup; any problem with the original will be copied to, and perhaps magnified, on the copy. 
    A much better approach is to get a portable external HD; do backups to it, then take it to a secure off-site location.  See #27 in Time Machine - Frequently Asked Questions for some suggestions, especially the pink box there.
    It still might be a good idea to have some limited data backed-up over the internet, such as relatively-small things and/or things that rarely change.

  • Unable to see Dashboard over the internet (Portal)

    Dear All,
    I have one issue here which is bit technical,
    I have made an Xcelsius Dashboard (Connection Type: Excel XML Maps (BW Queries)) and uploaded SWF file on to KM Repository in Portal. I have created Document iview and a role to published the dashboard on Enterprise Portal.
    Now when i am trying to access that Dashboard from Portal within local network it works fine but when i try opening the same Dashboard over the internet from home it gives an error.
    ERROR DETAILS:
    To access external data, add a cross-domain policy file to the external data web server.
    For more information, on the Adobe website, see the article u201CCross-domain Policy File Specificationu201D.
    If the problem persists, contact the file creator or your system administrator.
    Error: Error #2048
    Connection Type: Excel XML Maps
    File URL: https://www.portal.com/irj/go/km/docs/documents/dashboards/dashboard1.swf
    External Data URL: http://bwserver.domain.com:8000/sap/bc/bsp/sap/zbo_data/Data.xml?infocube=ZFIGL_FM&query=ZFIGL_FM_Q0003_BO&VAR_NAME_1=0P_FYRA&VAR_VALUE_EXT_1=2009
    I have added crossdomain into WebAppl Srvr of BW Server .. Created BSP Application ---> Imported crossdomain file ---> set BSP App in Default Service.
    Please suggest me possible Solutions.

    Closing Thread

  • Unable to see Dashboard over the internet Using Enterprise Portal

    Dear All,
    I have one issue here which is bit technical,
    I have made an Xcelsius Dashboard (Connection Type: Excel XML Maps (BW Queries)) and uploaded SWF file on to KM Repository in Portal. I have created Document iview and a role to published the dashboard on Enterprise Portal.
    Now when i am trying to access that Dashboard from Portal within local network it works fine but when i try opening the same Dashboard over the internet from home it gives an error.
    ERROR DETAILS:
    To access external data, add a cross-domain policy file to the external data web server.
    For more information, on the Adobe website, see the article u201CCross-domain Policy File Specificationu201D.
    If the problem persists, contact the file creator or your system administrator.
    Error: Error #2048
    Connection Type: Excel XML Maps
    File URL: https://www.portal.com/irj/go/km/docs/documents/dashboards/dashboard1.swf
    External Data URL: http://bwserver.domain.com:8000/sap/bc/bsp/sap/zbo_data/Data.xml?infocube=ZFIGL_FM&query=ZFIGL_FM_Q0003_BO&VAR_NAME_1=0P_FYRA&VAR_VALUE_EXT_1=2009
    I have added crossdomain into WebAppl Srvr of BW Server .. Created BSP Application ---> Imported crossdomain file ---> set BSP App in Default Service.
    Please provide possible solutions

    We have the same problem.
    The Solution 1.
    http://wiki.sdn.sap.com/wiki/display/EmTech/Addcrossdomain.xmlontherootofSAPWebapplication+server
    and 2.
    http://www.asabau.com/2009/04/crossdomain-policy-file-in-sap-web-application-server/
    does not work.
    How you have fix it?
    regards
    Chris

  • Access Time Capsule over the internet

    Hey guys! I have a problem. I cannot access my Time Capsule over the internet.
    I have a Time Capsule 2013 which connects to the internet using a PPPoE connection and which provides wireless connection to other peripherals in my house.
    The TC is running the latest firmware and I've added my iCloud account in AirPort Utility settings, in order to access the TC over the internet, via Back to My Mac.
    Whenever I'm away from home, I cannot access the TC.
    I see it in Finder's sidebar, but whenever I press the "Connect As.." button I get the following error:
    "There was a problem connecting to the server “Time Capsule”.
    The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again."
    I must add that I have a dynamic IP. Whenever the Time Capsule restarts, it gets a different IP.
    Am I missing something?
    Please help me. It's really important for me to be able to reach it when I'm away from home.

    So the modem is bridged and the TC is doing the PPPoE authentication.. and it gets a public IP on the WAN interface.
    The dynamic nature of the IP is not a problem with the BTMM and iCloud type system which should keep the intermediate connection in the cloud up to date.
    What about the connection at the other side.. are you getting a public IP.. are you behind a firewall or restricted access? Remember both sides of this have to work.
    See this thread.. you are not alone.. all is not sweetness and light unless you get a proper business account with static IP.
    https://discussions.apple.com/thread/3699096?start=0&tstart=0
    Apple info has a bit about issues that people experience.. and Tesserax has some setup info.
    Remote Access
    I would use the public IP and see if it works.. that means you need to check the IP before you leave home or use your phone tether and do the test at home so you can type in the public ip and use direct access .. at least to test it.

  • Time Capsule - how to gain "over-the-internet" access from Windows 7!

    Hi guys,
    I've been fighting for such a long time with my Time Capsule. I have no idea how to gain access "over-the-internet" on a PC (Windows 7) which is running on  another network. My Time Capsule is set up with my Macbook Pro at home running Lion OSX, and i have internet connection. My brother who also uses Macbook has no problems connecting to my Time Capsule - through finder (connect to a server). But how do I gain "over-the-internet" access to my Time Capsule through a PC (Windows 7) from my office? Is there please someone who can guide me step-by-step, how to gain connection to my TC through a PC? Or maybe just an explantaion what has to be done on the PC before this thing can work out! This was the main reason to why i bought Time Capsule - besides of the Time Machine function. I also have an iCloud account (earlier Mobile Me), if that makes any difference.
    Thanks!

    There is no way to do it from windows direct to the TC.
    It only presents AFP to the WAN side. And most ISP block SMB from internet access due to risks. There is AFAIK, no suitable AFP protocol utility for windows at the moment. If you google and find one, be aware it probably will not work to your satisfaction anyway.
    You must use a Mac to access AFP but even then it is not a secure protocol and I would recommend against it anyway.
    So basically if you had have asked before purchasing, I would have said, TC is unsuitable product. It is a backup drive for a Mac. It is not a NAS.. it is not designed for remote access by any computer other than a Mac. It does not support any other file protocol to the WAN interface.. and no secure protocol even there.
    A NAS with Time Machine extensions from QNAP, Synology, Netgear all are designed for web access and are far more suitable. Researching a purchase beforehand is always worthwhile.
    Anyway, your choices are.. return the TC and buy something more suited to the job.
    Or if return is now impossible sell the TC on ebay.. etc and do the same thing.. buy a more suitable NAS.
    Or buy a cheap mac mini (even second hand) and use that for communications with home.
    Or, replace your current router with something that includes vpn. This is actually a good and commercially sound decision. VPN is generally used by business to connect to remote locations, because it is secure and will allow the greatest flexibility of connection. How hard or easy depends on the current setup. I would recommend a combined modem router with vpn server if you have adsl. Or for cable you can find plenty of routers with combined vpn. You can also use those for adsl if your ISP allows pppoe with bridged modem. The TC will have to be bridged as well. For other broadband it might be harder to find the right kind of box.
    Once you setup a vpn you can access it from work using the appropiate vpn client in your work computer.

  • I have a BTHub4 - My iMac, iPhone, and children's iPads all connect to the internet no problem. I cannot get my 2 MacBook Pros or my partners MacBook Air to connect. Have tried diagnostics - says to change DNS but  it is correct.

    I have a BTHub4 - My iMac, iPhone, and children's iPads all connect to the internet no problem. I cannot get my 2 MacBook Pros or my partners MacBook Air to connect. Have tried diagnostics - says to change DNS but  it is correct. I have re-set both router and all laptops - no joy. They can all see the network but cannot connect.

    This is extraordinary. I have moved the router and also tried resetting it to its factory strings.  We have had this router for over a year and all our devices have always worked. Now all four laptops will not connect to the internet. Only one oMac and our phones and iPad.
    I have had far more devices running at once before but now all laptops are timing out on connection. Some say this iIP address is already being used but if I manually set to a slightly different IP address it does not help, noir if I manually set to the correct IP address. Why would all our laptops (four) suddenly be unable to connect?

  • Connecting to a database over the internet

    Hello ,
    Ok heres an interesting question -
    I would like to have an applet running on my browser which needs to connect to a central server over the internet, which in turn will need to connect to a database and query some results. These results will be stored as flat files within the server.
    At the moment, I have a URL that connects to the database via the
    internet and that is working. However I don't think my applet on my browser will be able to create a flat file on that server direclty.
    Could some one please tell me how to go about this problem?
    Shalini

    Yes, put a servlet in between the applet and database. Let the servlet interace with the database on the applet's behalf and write that file on the server side.
    %

  • Technical Details: The website does not support encryption for the page you are viewing. Information sent over the internet withour encryption can be seen by other people while it is in transit

    Technical Details:
    The website does not support encryption for the page you are viewing.
    Information sent over the internet withour encryption can be seen by other people while it is in transit
    == This happened ==
    Not sure how often
    == started few days ago. previously never happened before.

    I was loading a website, it then stated as below, it wasnt any of the problems stated below.
    SERVER NOT FOUND
    # Check the address for typing errors such as
    ww.example.com instead of
    www.example.com
    # If you are unable to load any pages, check your computer's network
    connection.
    # If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.
    Thus i checked the Page Info, it states that:
    Security Info on page:
    '''This website does not supply ownership information.
    Connection not Encrypted.'''
    Technical Details:
    The website does not support encryption for the page you are viewing.
    Information sent over the internet withour encryption can be seen by other people while it is in transit

Maybe you are looking for

  • Text layers not saved correctly as PDF from PS?

    I frequently save layouts I do in Photoshop as PDF's. Lately I very often will discover the text does not display correctly in the PDF. One or two lines of text will display as white with a thin black outline, rather than as the basic solid black I'd

  • BBM chat won't work

    Hi all,  Since I upgraded my BBM, when I try to send a BBM message, I get the unfriendly red x. I have gone through most of the post on this wall yet nothing. My edge is Capitalised (EDGE) all other applications work just fine, whatsapp, email, Appwo

  • TSQL to know if an update was run at a specific time

    Hello, I am using SQL 2008 R2 SE and would like to know if I will be able to trace with a tsql if a record in a table was updated from an older time. Like in table abc if a record was updated on jan1, 2014? Is this possible. Since I am using SE i kno

  • The strange case of the disappeared mails...

    I've two mail accounts set on my ipad and I'm having some funny problems... both accounts are POP3 first, it sometimes happens that mails downloaded AND deleted from my inbox (but still on the server) are downloaded a second and even a third time, wi

  • Generally positive impression...

    After some frustration with Firefox, I decided to try Safari for the first time. I'm a PC user because I like to tinker (in fact, am a professional tinkerer), and demand a computer conforms to me rather than the other way around. Consequently, a Mac