Learning Java On Apple Mac OS 10

Hi
I am just in the early stages of learning Java, using an Apple Mac G4 running OS 10.2.3
Does anyone know the best software to download to practice, Type /compile and run my programmes on without having to use the Unix Terminal interface...
The Apple Project Builder is too advanced.
Thanks
Steve

Im not a mac user but the mac osx is unix based and as i use unix all the time...there are two other editors you can use in unix that i dont know if you can use them in mac osx
one is pico just go to your command prompt and type pico filename
or if you dont have that you may have vim filename
using pico is very straight forward and vim is a bit better than vi.
goodluck

Similar Messages

  • Java on Apple Mac???

    Hi,
    I was just wondering does Java runs on Mac with MacOS X? Is there a JDK for Mac?
    Thank you very much :)

    If I remember right, Apple announced that they would be bundling JRE 1.3 support with Mac OS X. I'm assuming this means you can compile as well, because the compiler is written in Java.
    Sun don't have any obvious information on their site though, because the Mac versions of the JDK aren't released by them (why, oh why .. )

  • OSDG, Java 7u21 & Apple Mac

    Environment:
    1. OSGD v4.60.911 (x86 Solaris 10)
    2. MacBook Pro Retina (OS X 10.8.3)
    3. Java 7u21 (JDK)
    I'm hoping someone has come across this and has a fix, workaround etc. and are willing to share?
    Prior to the latest Java 7 update, everything was working fine. I was able to natively login from the MacBook (i.e., no Parallels, VBox or the like), and launch MS Windows desktops from the OSGD WebTop without difficulty. Since the update to Java 7u21, I've been having nothing but grief. Firstly I could not login to OSGD at all. After entering login details, the webpage just sit as though it was trying to authenticate. Then earlier today I took the drastic step of installing the JDK variant of Java 7u21. This immediately cured my OSGD login issue(s). However the problem I'm now experiencing is that I cannot launch any of my applications from the OSGD WebTop. Basically nothing happens. After a period of time, a session is sometimes but not always listed, but then almost immediately disappears. No errors appear on the WebTop.
    Anyone any ideas?
    TIA,
    Robert.

    Many thanks for the feedback.
    Is there a direct upgrade path from my version (4.60.911) to version 5 or will there have to be intermediate upgrades? Also is there a step-by-step for performing an upgrade?
    TIA,
    Robert.
    Edited by: rabjac on 13-May-2013 09:11

  • Learning Java on Leopard

    I wanted to learn java and have Mac OS X 10.5.1 (Leopard). When I type in "java -version" it says I have version 1.5 (which I guess is Java 5). But the tutorials on the java.sun.com website are for java 6. It gives a link to download java 6 for Mac OS X at apple's developer's site. The download at the site, however, is for Mac OS X 10.4. Will this work for Leopard? Is there another place to download Java 6 for Leopard? Thank you in advance.

    I've been learning Java on windows for a while now using Java 6 (and the tutorials it has), and when I switched to mac all I had to do was recompile the files and they worked fine. It doesn't seem there's any major differences between the versions that someone just starting out would notice.
    (I think it's actually better to keep java 1.5, since when you compile from it for web applets you know they'll work on other macs, whereas the programs I'd compiled using Java 6 weren't working on my mac)

  • Recommendations for Book on Learning Java on Mac OS X Tiger?

    Can anyone recommend a book title or two on Learning Java on Mac OS X Tiger? A generic learn-java-book is fine -- it just has to not be Windows-only. ie. the examples or included CD should at least include instructions for running the examples on a JAVA IDE available for other platforms such as Mac OS X (e.g. Eclipse).
    Thanks in advance,
    ...ben
    PS. Wish Dave Mark had a Java version of his classic: Learn C on the Macintosh
    PB G4 15 1.67 GHz, iBook SE 0.47 GHz Mac OS X (10.4.3)
    PB G4 15 1.67 GHz, iBook SE 0.47 GHz   Mac OS X (10.4.3)  

    Just download eclipse and do sun's java tutorials. They're very well written and cover pretty much anything you need to do with Java.
    http://java.sun.com/learning/tutorial/index.html
    cheers,
    /john patton/

  • Cisco wireless and Apple Mac woes

    Hello all,
    I've been working with Cisco wireless and WLC's for a couple of years now but the recent onslaught of Apple Mac's is giving me heart burn.  I've seen this at numerous sites now and need to throw it to eht community for guidance.
    Basically we have had a number of instances where the Macs just fall off the wifi.  Sometimes it's when they wake from sleep and other times when roaming between AP's (1131s with same SSID's).  Our standard install is WPA2 and per ap local authentication.  PC's work fine and never an issue.
    We have completed a survey with a spectrum analyser and no RF interefence is present nor errors on the radio interface.
    Questions:
    - Is there a preferred Cisco config/setup for Mac's to work reliably?  I've heard loads of rumors but nothing concrete and nor can I find anything specific.
    - Should I be setting up WDS in case there is an authenticating issue.
    - For those who are Mac gurus and happen to be reading. What Mac options we should look at?
    This has all come to a head because the clients IT company who recommended the Macs (different from us doing the network infrastructure) are insisting that the problem is Cisco incompatibility and that we should rip out the Cisco kit and install airports (what tha!!!).
    Thanks in advance for any pointers.
    For those who like a config here it is .... Vanilla stuff really
    Building configuration...
    Current configuration : 2236 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname AP4
    no logging console
    enable secret xxxxxxxxxxxxxxxxx
    no aaa new-model
    dot11 syslog
    dot11 ssid Home
       vlan 1
       authentication open
       authentication key-management wpa
       guest-mode
       mbssid guest-mode
       wpa-psk ascii xxxxxxxxxxxx
    dot11 ssid avnet
       vlan 2
       authentication open
       authentication key-management wpa
       mbssid guest-mode
       wpa-psk ascii xxxxxxxxxxxxxxxx
    username abcd password 1234
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 1 mode ciphers tkip
    encryption vlan 2 mode ciphers tkip
    ssid Home
    mbssid
    speed  basic-1.0 basic-2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
    channel 2412
    station-role root
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.2
    encapsulation dot1Q 2
    no ip route-cache
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    bridge-group 2 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    hold-queue 80 in
    interface FastEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface FastEthernet0.2
    encapsulation dot1Q 2
    no ip route-cache
    bridge-group 2
    no bridge-group 2 source-learning
    bridge-group 2 spanning-disabled
    interface BVI1
    ip address 192.168.10.54 255.255.255.0
    no ip route-cache
    ip default-gateway 192.168.10.1
    no ip http server
    no ip http secure-server
    bridge 1 route ip
    line con 0
    line vty 0 4
    login local
    end

    Yeah!! even i have come across multiple issue with MAC and Cisco.. these are the below settings which i normally do on the cisco gears and most of the times this solved the issue..
    on the IOS AP disable Aironet Extentions and set the poer local and ofdm to max
    no dot11 extension aironet
    power local cck max
    power local ofdm max
    end
    On the WLC, disable Aironet IE..
    lemme know if this answered your question..
    Regards
    Surendra
    ====
    Please dont forget to rate the posts which answered your question and mark it as answered or was helpfull

  • How could i install Java on my Mac OS X 10.6.8 ?

    Hello.
    First of all I am French so please excuse me for my English.
    I tried to install Java on my MAC but unfortunately the download of the software always meets the same problem... It asks me to be under mac OS X 10.7 but my computer does not propose me update. What should i do ?
    Thank you

    http://support.apple.com/kb/DL1360
    Note: Java 1.6 for Leopard is 64 bit only, but for Snow Leopard it is available for both 32 and 64 bit.
    http://www.roguish.com/blog/?p=266
    Since August 2012 updates for Java (and especially Java Runtime Environment, which is what you actually need) must now be downloaded direct from Oracle:
    http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1637588.h tml
    Further information here:
    http://www.oracle.com/us/corporate/press/1735645
    and their FAQ’s:
    http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/mac-faq.html
    However, if you need the Jave 6 JRE and plug-in, MadMAC0 has posted at
    https://discussions.apple.com/message/20107182?ac_cid=tw123456#20107182
    Apple has also posted (Oct 22/12) the approved solution for restoring the Java 6 plug-in:
    Java for OS X 2012-006: How to re-enable the Apple-provided Java SE 6 applet plug-in and Web Start functionality.
    Interesting article here on why Apple removed Mac browsers’ ability to run Jave Applets:
    http://www.techweekeurope.co.uk/news/apple-java-browser-mac-os-x-96827

  • How can install java sdk for mac os x 10.6.8

    How can install java sdk for mac os x 10.6.8?

    Deanwdd wrote:
    I mean to update Quicktime for Mac Os X 10.6.8...
    If you're running 10.6.8, Apple menu > Software Update. What version of QT do you have?

  • HT1338 I'm trying to download java on my Mac machine but the software update doesn't show me anything. Please advise what I should do to get the application.

    I'm trying to download java on my Mac machine but the software update doesn't show me anything. Please advise what I should do to get the application.

    If you can run it under chrome, you have java installed.
    There was some malware that exploited an older version of Java (not javascript) running in a Browser. Since few people use it Apple turned off Java by default in the Safari Browser.
    If you need it for something, just turn it back on in Safari preferences (inside Safari). After a few months of non-use, you may find it has turned itself off again.

  • I heard there was a security breach in Java installed in Macs and that there is a patch to fix it.  But that's all I know.  Is there more info available?

    I heard there was a security breach in Java installed in Macs and that there is a patch to fix it, but that's all I know.  Does anyone know how to fix it?

    There isn't a patch for a computer running Leopard .
    Leopard and earlier users see recommendations at: https://discussions.apple.com/thread/3872491

  • I am planning to buy apple air mac book. i am not that technical will i be able to handle apple mac book. i am aware of using windows os but can i get software like that of notepad, word pad in os X lion. can i get partitioning in macbook,

    I am planning to buy apple air mac book. i am not that technical will i be able to handle apple mac book. i am aware of using windows os but can i get software like that of notepad, word pad in os X lion. can i get partitioning in macbook,

    Yes.  Switching to Mac might be overwhelming at first, but it is not difficult.  I Just started using Macs regularly about 9 months ago after using only Windows based pc's for over 15 years.  Macs come with TextEdit , but you can also purchase MS Office for Mac or use Apple's version, called iWork.Yes, you can partition the hard drive of a Mac.  Read these also: http://www.apple.com/support/switch101/, http://www.apple.com/support/mac101/.  With regular use of a Mac, you will be able to use it without even thinking about it, just like how you learned to use a WIndows pc.

  • What is similar to Java for a mac?

    What is similar to Java for a Mac?
    I'm running Mac OS X version 10.5.8, can I step up to Mountain Lion??
    Thanks

    Java is similar to Java for a Mac.
    You can upgrade if your computer meets the minimum system requirements:
    Snow Leopard General requirements
    Mac computer with an Intel processor
    1GB of memory
    5GB of available disk space
    DVD drive for installation
    Some features require a compatible Internet service provider; fees may apply.
    Some features require Apple’s MobileMe service; fees and terms apply.
    Lion System Requirements
    Mac computer with an Intel Core 2 Duo, Core i3, Core i5, Core i7, or Xeon processor
    2GB of memory
    OS X v10.6.6 or later (v10.6.8 recommended)
    7GB of available space
    Some features require an Apple ID; terms apply.
    Apple - OS X Mountain Lion - Read the technical specifications.

  • I need java on my mac 10.5.8 and it fails to mount each time! Please help!

    I am using an imac 10.5.8 and can't seem to download the java i need to print coupons! Each time I try it fails to mount! Please help!

    The last Java update for Leopard was:
    Update 10, 29 June 2011 - This release updates J2SE 5.0 to 1.5.0_30, and updates Java SE 6 to 1.6.0_26. J2SE 1.4.2 is no longer being updated to fix bugs or security issues and remains disabled by default in this update. Support for out-of-process Java applets on Mac OS X 10.5 Leopard has been removed with this update.
    This release is only for Mac OS X 10.5.8 or later versions of Mac OS X 10.5. http://support.apple.com/kb/DL1359
    and for Snow Leopard:
    http://support.apple.com/kb/DL1360
    Note: Java 1.6 for Leopard is 64 bit only, but for Snow Leopard it is available for both 32 and 64 bit.
    http://www.roguish.com/blog/?p=266
    Since August 2012 updates for Java (and especially Java Runtime Environment, which is what you actually need) must now be downloaded direct from Oracle:
    http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1637588.h tml
    Further information here:
    http://www.oracle.com/us/corporate/press/1735645
    and their FAQ’s:
    http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/mac-faq.html
    However, if you need the Jave 6 JRE and plug-in, MadMAC0 has posted at
    https://discussions.apple.com/message/20107182?ac_cid=tw123456#20107182
    Apple has also posted (Oct 22/12) the approved solution for restoring the Java 6 plug-in:
    Java for OS X 2012-006: How to re-enable the Apple-provided Java SE 6 applet plug-in and Web Start functionality.
    Interesting article here on why Apple removed Mac browsers’ ability to run Jave Applets:
    http://www.techweekeurope.co.uk/news/apple-java-browser-mac-os-x-96827

  • How do I update Java on my Mac

    Does anyone know how I can update Java on my Mac (OS X 10.6.8)??

    http://support.apple.com/kb/dl1573

  • Java and Apple

    Hi, I'm aware this post may seem incredibly ignorant.
    I'm a Java programmer, who is considering switching from a PC to an Apple Mac. I know very little about Macs, having done all my programming in the Windows/DOS environment. Would anyone be able to tell me if there are versions of the JAVA SDKs for use within the Mac framework? This would greatly affect my decision of whether or not to switch platforms.
    Any help is greatly appreciated.

    Note though that since Apple rather than Sun produces the VMs (in co-operation with Sun to a certain extent) they tend to be slightly later in releasing new versions. I'd expect 1.5 to come out between 3 and 6 months after other platforms.

Maybe you are looking for

  • Saving PDF in Preview results in unsearchable File

    Hi I found an archieved discussion (but without a single answer to the question), so I'm reproducing it here again because I have the exact same problem and am hoping for suggestions for a solution: "If I take any PDF that is searchable (say from the

  • Gathering Statistics in 10.7 NCA with 8i Database

    In preparation for the 11i upgrade we are first migrating our database to 8i (strongly recommended Category 1 pre-upgrade step 5). I have contacted Oracle Support on whether it is recommended to gather statistics in a 10.7 NCA environment (optimizer_

  • Subcontracting for Sales Order Stock and collective Transfer Posting

    Dear Expert, We have a scenario in subcontracting wherein the sales order the customer also wants to see the components and as such along with the Header item of subcontracting ,we also mention the components as another line item in the sane Sales Or

  • Adobe Illustrator(CS6) NOT running on OS X Yosemite

    Hi all, after upgrading to OS X Yosemite today, I just realised that I am not able to open AI (CS6) anymore, I'd appreciate if there is any suggestion to fix this problem? or if there is any upcoming update from Adobe which might address this issue?

  • Slides with Quotes in iDVD (iLife '09)?

    is there a way to add slides with quotes on them within a slideshow in iDVD? My slideshow consists of all photos but I would like to add slides with quotes and I didn't know if it was possible. thanks for any help available