Mapping 2 contents to single real server port on CSS

Hi
I need to configure CSS accept connections to VIP on 2 different TCP ports and forward them to the same tcp port on real servers.
I cannot use secondary IP addresses on real servers.
Planned configuration is
service REALSERVER1
port 80
ip address 1.1.1.1
active
service REALSERVER2
port 80
ip address 1.1.1.2
active
owner WEB
content WWW-80
balance weightedrr
protocol tcp
port 80
add service REALSERVER1 weight 1
add service REALSERVER2 weight 1
vip address 2.2.2.2
active
content WWW-8080
balance weightedrr
protocol tcp
port 8080
add service REALSERVER1 weight 1
add service REALSERVER2 weight 1
balance weightedrr
vip address 2.2.2.2
active
CSS box runs software 07.50.1.03
Will this scenario work? Does it seems to is stable and scalable? I.e., I am concerned what may happen if client connections will arrive from the same source IP address and the same source TCP port.
Modestas

for your concern, if you make the content rule layer 5 by adding the command 'url "/*"' the CSS will modify the client source port when connecting to the servers.
However, the chance is very little and personally I would not bother.
So, this config looks valid to me.
Gilles.

Similar Messages

  • Content engine 565 - real server relay

    hi all,
    we have a standalone content engine 565 running acns 5.3.1. we would like to realize something like a live stream 'relay':
    we place the ce on the network edge and it receives a live stream (rtsp) directly from a content provider. the internal clients send their rtsp requests for that live stream directly to the ce which answers the requests. one important thing is that we cannot use a proxy configuration, because a proxy config on the client is not possible - meaning that we need to place requests directly (no direct or transparent proxy). in the real subscriber config interface I saw the receiver/transmitter section - is that the right way to go? where can I find config examples or documentation for that issue. on the cisco website I could not find any detailed documentation for real subscriber configs.

    thanks for the answer - i realized it rather late. can you help me in configuring this setup? as i said I cannot find any documentation support for such a setup...I would really appreciate any help.
    thanks,
    daniel

  • Can a real Server be applied in two different server farms associated with two different VIP IP and TCP Port

    Good day everyone,
    I have a question in regard to real server operation with different server farms, and VIPs
    Can a Real Server be associated ( for simpliciy) with two different Server Farms that have a VIP associated with each, servicing the same TCP Port (443).
    Example:
    SF-A
    RSRV-1: 192.168.1.10 /24
    RSRV-2: 192.168.1.11 /24
    VIP-A: 192.168.1.20 /24
    VIP-A: https:web-A
    Protocol: HTTPS
    SF-B
    RSRV-2: 192.168.1.11 /24
    RSRV-3: 192.168.1.12 /24
    VIP-B: 192.168.1.30 /24
    VIP-b: https:web-B
    Protocol: HTTPS
    Client-A: 172.16.128.10
    Client-B: 172.16.128.15
    I have attached an sketch depicting the connectivity.
    As always any feedback/Suggestions will be greatly apprecaited.
    Cheers,
    Raman Azizian

    Raman,
    This type of config is no problem. What the server is doing is virtual web hosting. The server would have two different web services running for the same IP, but each listening for a unique host header.
    From an IP point of view both connections would be destined to the rserver address on port 80, but in the http header they would have two different Host headers.
    one for www.example1.com and the second for www.example2.com. If the web server is configured correct so each host name is tied to one web service it will not have any issues.
    The config you attached looks ok. The way you have the sticky group is ok doing source IP. If you use cookies for the sticky group I would suggest you create two sticky groups each with a different cookie name and add the same serverfarm to both groups. The client will only send a cookie for the domain it received it from so using the same cookie in two vips could cause problems if the same client hits both vips.
    Hope that helps
    Regards
    Jim

  • Two FTP ports on a single solaris server

    can i have two FTP ports on single Solaris server ? If yes, HOW ??

    Hi adiyakiran,
    This is possible in third party ftp server wu-ftpd. you can download it from http://www.sunfreeware.com.
    read wu-ftpd faq URL: http://www.wu-ftpd.org/wu-ftpd-faq.html
    Testing on a different port number then ftp:21
    This can be done from the command line or with a special definition in /etc/services ,/etc/inetd.conf. For command-line, look up -P and -p in the ftpaccess(5) manpage.
    To set up with special definitions, add 2 ports with consecutive numbers in /etc/services, and then start wu-ftpd on these ports. Add to /etc/services something like :
    ftptest 4021/tcp #command port
    ftptest-data 4020/tcp #data port
    Then start wu-ftpd from /etc/inetd.conf like :
    ftptest stream tcp nowait root /usr/etc/in.ftpd in.ftpd
    The key is the name 'ftptest' which associates the port assignment in the /etc/services file to that in the inetd.conf file. Make certain the choice of ports in /etc/services (4021 and 4020 above) are from the local use list and don't conflict with other port assignments (see RFC1700, ASSIGNED NUMBERS). One important subtlety. The data
    port is not really derived from the data port declaration in the /etc/services file. The FTP specification (RFC765) states the data port is defined as one less than the command port. However, including the data port declaration in the /etc/services file prevents it from being accidentally assigned to something else.
    Thanks.
    regards,
    senthilkumar.
    SUN - DTS

  • Single Nexus 5548UP- FCoE configuration with multiple server ports

    Hello Everyone,
    I am new to Networking so please bear with me.
    Here is some background information. We have a SINGLE Nexus 5548 UP switch to which we are connecting both the storage and the UCS C240 M3 servers (with CNA). Both the storage and server has 2 ports each going to this nexus switch.
    We want to implement FCoE with this solution.
    Below are the steps (for server ports) that I have followed to configure the nexus. But the port not logging into the SAN (no flogi) with the config.
    Enable Features
    config t
    feature lacp
    feature dot1x
    feature interface-vlan
    feature sshServer
    feature npiv
    end
    Confgure Ethernet Ports - Server 
    configure
    interface ethernet 1/17
    description To_UCS_rack_server_1_FCoE_port_1
    switchport mode trunk
    switchport trunk native vlan 6
    switchport trunk allowed vlan 1,6
    spanning-tree port type edge trunk
    priority-flow-control mode on
    no shutdown
    end
    configure
    interface ethernet 1/18
    description To_UCS_rack_server_1_FCoE_port_2
    switchport mode trunk
    switchport trunk native vlan 6
    switchport trunk allowed vlan 1,6
    spanning-tree port type edge trunk
    priority-flow-control mode on
    no shutdown
    end
    Create VLAN
    configure
    vlan 6
    name FCOE_VLAN
    fcoe vsan 6
    end
    Setup FCoE QOS
    configure terminal
    system qos
    service-policy type qos input fcoe-default-in-policy 
    service-policy type queuing input fcoe-default-in-policy 
    service-policy type queuing output fcoe-default-out-policy 
    service-policy type network-qos fcoe-default-nq-policy 
    end
    Create vfc for Initiators (UCS Servers)
    configure
    interface vfc 17
    bind interface ethernet 1/17
    switchport description virtual_fiber_channel_Server1_Port1
    end
    configure
    interface vfc 18
    bind interface ethernet 1/18
    switchport description virtual_fiber_channel_Server1_Port2
    end
    Adding vFC’s to VSAN
    configure
    vsan database
    vsan 6 interface vfc 17
    vsan 6 interface vfc 18
    Create Zonesets and Zones
    configure
    show flogi database vsan 6      ----> Do not see any pwwn here???
    show fcns database vsan 6
    Any help in the regard would be highly appreciated.
    Cheers,
    KS

    Fixed the issue. "switchport trunk native vlan 6" was causing the issue. Maybe the storage and Servers were not configured with proper VLAN's. I removed the native vlan and everything logged in fine.
    Any how I have configured a single zone with all 3 servers pWWN's. I know single initiator zoning is the way to go.
    Can you please guide me if I can move these servers in their separate zones without any outages?  If it helps, all severs have 2 pWWN's. The current zoneset is active with that single zone.
    Please let me know if you need any additional details.
    Cheers,
    KS

  • Basic configuration question on Server port configuration

    Hi,
    I'm a newbie in Cisco configuration. Using the Cisco 7604 load balancer, wanted to acheive two things firstly single ip for the applications and the failover of my servers.
    Configuration description
    I have an Application client connected to the vserver configuration (LAVSERV) on Cisco 7604 Load Balancer and two servers (JBoss) S1 and S2 configured to the real ip as configured in the serverFarm. All the three systems (Load Balancer,S1 and S2) are in the same LAN.
    IOS configuration details
    ip slb serverfarm LA
    nat server
    predictor leastconns
    real 10.2.11.11
    weight 255
    inservice
    real 10.2.11.211
    weight 255
    inservice
    ip slb vserver LAVSERV
    virtual 10.2.11.141 255.255.255.0 tcp 1813
    serverfarm LA
    no advertise
    idle 65535
    inservice
    When I try connect to my servers through the client application I get connection exception. Basically I'm telling my client application to connect to webservice url http://10.2.11.141:1813. Due to the configuration on Load Balancer for servers, Load balancer should route my request to either of the Servers S1 or S2.
    I have a doubt here, have not mentioned the port anywhere on which my JBoss (S1 or S2) is running.Is beacuse of this I'm getting connection exception, if yes, kindly let me know how to configure the port along with the real server IP.
    Thanks in advance
    Sanjeev.

    Hi,
         I have moved my client to the system in other LAN, current client ip is 10.232.66.67.
    and my current configs in 7604 are follows
    Router#show ip slb serverfarm
    server farm      predictor           nat   reals   bind id  interface(s)
    LA             LEASTCONNS          S     2       0       
    Router#show ip slb vserver
    slb vserver      prot  virtual                  state         conns    interface
    (s)
    LAVSERV        TCP   10.232.11.239/32:8080    OPERATIONAL   0       
    Router#show ip slb real
    real                  farm name        weight  state          conns
    10.232.11.11          LA               255     OPERATIONAL    0
    10.232.11.211         LA               255     OPERATIONAL    0
    Now on both the real servers I see the request is coming but still the request doesn't reach my application (JBoss).
    $ netstat -plan | grep :80
    tcp        0      0 10.232.11.11:8080           10.232.66.67:6307           SYN_RECV    -                 
    $ netstat -plan | grep :80
    tcp        0      0 10.232.11.211:8080           10.232.66.67:6307          SYN_RECV    -                 
    During the client application invocation I see the following changes in the detail ouput of 7604. From the wireshark logs (attached pic) I could see the request (SYN) goes to the servers but servers are not responding. My server application doesn't respond because it has not got the request. 7604 invokes 11.11 it doesn't respond to SYN request so it invokes 11.211.
    LAVSERV, state = OPERATIONAL, v_index = 7, interface(s) =
      virtual = 10.232.11.239/32:8080, TCP, service = NONE, advertise = TRUE
      server farm = LAMP, delay = 10, idle = 65535
      sticky:
      sticky: group id = 0
      synguard counter = 0, synguard period = 0
      conns = 1, total conns = 30, syns = 94,  syn drops = 0
      standby group = None
    Router#show ip slb serverfarm name LAMP de
    LA, predictor = LEASTCONNS, nat =SERVER, interface(s) =
      virtuals inservice: 1, reals = 2, bind id = 0
      Real servers:
        10.232.11.11, weight = 255, OPERATIONAL, conns = 1
        10.232.11.211, weight = 255, OPERATIONAL, conns = 0
      Total connections = 1
    Router#show ip slb serverfarm name LAMP de
    LA, predictor = LEASTCONNS, nat =SERVER, interface(s) =
      virtuals inservice: 1, reals = 2, bind id = 0
      Real servers:
        10.232.11.11, weight = 255, OPERATIONAL, conns = 0
        10.232.11.211, weight = 255, OPERATIONAL, conns = 1
      Total connections = 1
    If my client application talk to the real servers directly my server application gets invoked and client get the reply.
    But same is not happening through the 7604.
    Only change I do on my client config file is just uncomment the 7604 vip or the real ip for my client to connect:
    #for real server
    #webservice.url: http://10.232.11.11:8080
    #for 7604
    webservice.url: http://10.232.11.239:8080
    I feel the packets which are reaching my real server through 7604 are not proper so my server application doesn't get invoked.
    Sanjeev

  • Cisco ASA, skipping real source port number with PAT.

    Hi Experts,
    Cisco ASA configuration guide says:
    "PAT translates multiple real addresses to a single mapped IP address by translating the real address and source port to the mapped address and a unique port. If available, the real source port number is used for the mapped port. "
    Is it possible to skip this ? I do not want to use real source port number. The issue is, when I have a PAT entry with real source port (port 5060), - SIP session doesn't work. With all the other ports numbers,- everything works.

    Hi,
    Notice that the configuration you try does not modify the real source port at all.
    Since you are using the same "object" for the real/mapped service then the configuration above matches traffic where the connections destination is "any" and the destination is "udp 6000 65535" and only when the source is "udp sip" and in that event it keeps the exact same "udp sip" source port as you are using the same "object".
    I am not sure if its a software or configuration related issue but I have not gotten this to work reliably on my ASA. I might have to try some other software level.
    I guess you would want to match the SIP source port in the Dynamic PAT and avoid using the SIP port as the mapped port?. With that in mind I was thinking something like this
    object service UDP-SIP
     service udp source eq sip
    object service UDP-SIP-MAPPED
     service udp source range 30000 31000
    nat (VoiP,outside) source dynamic <source network object> interface service UDP-SIP UDP-SIP-MAPPED
    Though it seems the above configuration seems to be bypassed by the ASA completely and it seems to use the identical source port as the mapped port even though it matches the configuration.
    If I were to change the above configuration from "dynamic" to "static" then the configuration matches but it uses only the first mapped "source" port of "30000". I guess it would only use a different mapped port if you used multiple real source ports also instead of the current single source port "sip".
    nat (VoiP,outside) source static <source network object> interface service UDP-SIP UDP-SIP-MAPPED unidirectional
    Example from my own ASA.
    DYNAMIC
    - Matches the configuration but doesnt map the port at all
    Phase: 5
    Type: NAT
    Subtype:
    Result: ALLOW
    Config:
    nat (LAN,WAN) source dynamic LAN-NETWORK interface service SIP SIP-MAPPED
    Additional Information:
    Dynamic translate 10.0.0.123/5060 to <my pat ip>/5060
    STATIC
    - Matches the configuration and maps the source port but only uses the first mapped port from the range
    Phase: 4
    Type: NAT
    Subtype:
    Result: ALLOW
    Config:
    nat (LAN,WAN) source static LAN-NETWORK interface service SIP SIP-MAPPED unidirectional
    Additional Information:
    Static translate 10.0.0.123/5060 to <my pat ip>/30000
    I am not really sure if this configuration is reliable at all but its the only thing I can think of at the moment.
    Hope this helps :)
    - Jouni

  • ACE- From one real server to another VIP

    Hi,
    I have a problem with ACE;
    We have multiple serverfarms configured in the ACE module based on the application and different VIPs related to it. We are running the ACE in bridging mode. Now the requirement is from one serverfarm real server wants communicate to the VIP of the second serverfarm...Is this possible..???? Wil some NATing help in this situation. Below is the configuration.
    ======================
    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Table Normal";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-priority:99;
    mso-style-qformat:yes;
    mso-style-parent:"";
    mso-padding-alt:0in 5.4pt 0in 5.4pt;
    mso-para-margin:0in;
    mso-para-margin-bottom:.0001pt;
    mso-pagination:widow-orphan;
    font-size:11.0pt;
    font-family:"Calibri","sans-serif";
    mso-ascii-font-family:Calibri;
    mso-ascii-theme-font:minor-latin;
    mso-fareast-font-family:"Times New Roman";
    mso-fareast-theme-font:minor-fareast;
    mso-hansi-font-family:Calibri;
    mso-hansi-theme-font:minor-latin;
    mso-bidi-font-family:"Times New Roman";
    mso-bidi-theme-font:minor-bidi;}
    access-list LAN_Traffic remark For all IP Traffic
    access-list LAN_Traffic line 10 extended permit ip any any
    access-list LAN_Traffic line 20 extended permit icmp any any
    probe http PORTAL_HTTP
      passdetect interval 20
      passdetect count 2
      request method get url http://portal
      expect status 0 600
    probe http RMS_HTTP
      request method get url /_wmcs
      expect status 0 600
    rserver host PORTAL1
      ip address 172.22.11.241
      inservice
    rserver host PORTAL2
      ip address 172.22.11.243
    rserver host QGLRSPW1
      inservice
    rserver host RMS01
      ip address 172.22.10.12
      inservice
    rserver host RMS02
      ip address 172.22.10.8
      inservice
    serverfarm host PORTAL
      failaction purge
      probe PORTAL_HTTP
      rserver PORTAL1
        inservice
      rserver PORTAL2
        inservice
    serverfarm host RMS
      failaction purge
      probe RMS_HTTP
      rserver RMS01
        inservice
      rserver RMS02
        inservice
    class-map match-any PORTAL
      2 match virtual-address 172.22.10.166 tcp any
    class-map match-any RMS
      2 match virtual-address 172.22.10.52 tcp eq www
      3 match virtual-address 172.22.10.52 tcp eq https
    policy-map type loadbalance first-match RMS-POLICY
      class class-default
        serverfarm RMS
    policy-map type loadbalance first-match PORTAL-POLICY
      class class-default
        serverfarm PORTAL
    policy-map multi-match SFARM-LB-POLICY
      class RMS
        loadbalance vip inservice
        loadbalance policy RMS-POLICY
        loadbalance vip icmp-reply active
    class PORTAL
        loadbalance vip inservice
        loadbalance policy PORTAL-POLICY
        loadbalance vip icmp-reply active
    interface vlan 800
      description ACE Client Interface
      bridge-group 1
      mac-sticky enable
      service-policy input SFARM-LB-POLICY
      no shutdown
    interface vlan 898
      description ACE Server Interface
      bridge-group 1
      mac-sticky enable
      no shutdown
    interface bvi 1
      ip address 172.22.11.151 255.255.252.0
      alias 172.22.11.153 255.255.252.0
      peer ip address 172.22.11.152 255.255.252.0
      description Bridge Group for 800 and 898 Interfaces
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.22.8.17
    ===================================
    Pleae help..Thanks in advance

    Hello!
    Well yes it would work. BUT...you have to change your config a bit. First you need to apply your accesslist to both interfaces, or the ACE will reject it, because it is acting as a firewall by default. And second you have to apply the policymap to both interfaces as well or you put the policymap globally on the ACE.

  • Deploy to single managed server checked and greyed out while performing upgrade to EPM 11.1.2.4

    Hi Gurus,
    We are trying to upgrade EPM from 11.1.2.2 to EPM 11.1.2.4 and have applied the maintenance release successfully.
    Issue:
    When we are trying to configure EPM 11.1.2.4 and are providing the same Shared Service database details, at the summary screen, we are not able to uncheck the option "Deploy to Single Managed server" which is checked and is greyed out.
    We have tried the following:
    1. We updated the HSS_COMPONENT_PROPERTY_VALUE table  and updated the PROPERTY_NAME "isCompact" to false.
    2. Modified the config.xml file located at EPMSystem/config and epmsystem1/config to remove the property for compactState.
    We are still having the issue where we are not able to uncheck the option for Compact Deployment. Any help would be appreciated.
    Thanks in advance.

    As it is a maintenance release and it deployed as a single managed server then you will not be able to change the deployment type when applying the maintenance release.
    There is a procedure to change a deployment type from compact to single managed server that I created as an internal document.
    you may want to give it a go but you would need to test this first as this was an in house test that I carried out.
    Hyperion Planning - Version 11.1.2.2.300 and later
    Information in this document applies to any platform.
    Goal
    The scenario:
    EPM system 11.1.2.3 was configured and deployed as a single managed server compact deployment so that only one JVM was used for all products EPMServer0.
    Later on, due to performance issues, the decision was made to go for using a JVM for each product and get rid of the compact deployment.
    The administrator went ahead and redeployed the application servers individually into their own JVM.
    However everytime the webserver is reconfigured, the weblogicCluster entry in the OHS file mod_wl_ohs has 2 servers, one for EPMSserver running on port 9000 and another server running on the product default port (as if it was being load balanced)
    The aim:
    It is clear that initial compact deployment has not been cleared from the EPM environment and the aim in this exercise is to clear the registry and the file system so that the compact deployment is removed fromthe EPMenvironment and we are left with the desired configuration Single JVM deployment for earch web application.
    Solution
    Caution:
    Make sure that you take a backup of the following:
    - TheFoundation Services database schema backup
    - Take a backup of the following folders:
    \Oracle\Middleware\user_projects\FOUNDATION1\httpConfig\ohs\config\OHS\ohs_component
    \Oracle\Middleware\user_projects\domains\EPMSystem\servers
    \Oracle\Middleware\user_projects\domains\EPMSystem\config\fmwconfig\servers
    Disclaimer:
    This was tested in House and it worked for this specific environment and it may not work for your environment. So the suggestion is to test first in a development environment and make sure that you take the appropriate backups in case it does not go according to plan.
    Use at your own discretion.
    Procedure:
    1- Run the epmsys_registry to generate the Registry report
    2- Search through the report for the word applicationServerDeployment with a corresponding value of configured and take the ObjectID number down for any entry of applicationServerDeployment that has a value of Configured
    i.e:
    Instance Tasks Configuration (INSTANCE_TASKS_CONFIGURATION)
    Object ID:   e4b3a86a82c26941S32ef81a1455fe48473S7adf
    3- use the object ID of each entry you have taken down throughout the Registry HTML Report to manually set it back to Pending using the following procedure:
                    Start a command prompt and set the working directory to
                     \Oracle\Middleware\user_projects\epmsystem1\bin
                    run the command:
                     epmsys_registry.bat updateproperty #e4b3a86a82c26941S32ef81a1455fe48473S7adf/@applicationServerDeployment=Pending
                    Repeat this command for each ObjectID that has its applicationServerDeployment
                     property set to Configured
    4- rerun the epmsys_registry.bat to generate the Registry HTML report and search for applicationServerDeployment in the newly generated report to make sure that they are all set to Pending and there none missed (very Important).
    5- Search the registry HTML report this time for EPMServer0 which is the default serverName given to the single managed server deployment (there will be multiple entries)
    Take note of the first ObjectID entry in the section header: for example
    WORKSPACE_WEBAPP (WORKSPACE_WEBAPP)
    Object ID:   e4b3a86a82c26941S32ef81a1455fe48473S7bd3
    - Start a command prompt and set the working directory to
                     \Oracle\Middleware\user_projects\epmsystem1\bin
    - run the command:
                     epmsys_registry.bat view #e4b3a86a82c26941S32ef81a1455fe48473S7bd3
    -Note the Parents ID in the output:
    For example:
    Parent 1
    NAME -  WORKSPACE_LWA
    ID -  e4b3a86a82c26941S32ef81a1455fe48473S7bd0
    TYPE -  LOGICAL_WEB_APP
    Parent 2
    NAME -  HOST:BACHVMPS3TR
    ID -  e4b3a86a82c26941S32ef81a1455fe48473S7ffe
    TYPE -  HOST
    - Note the single child ID:
    For Example:
    Child 1
    NAME -  WebLogic 10
    ID -  e4b3a86a82c26941S32ef81a1455fe48473S7fd6
    TYPE -  APP_SERVER
    Now run the following command to remove the Link between Parent and child:
    epmsys_registry removelink #parentObjectID #childObjectID
    In this example that would translate to:
    To remove the single child1 link to the WORKSPACE_WEBAPP (#e4b3a86a82c26941S32ef81a1455fe48473S7bd3 ):
    epmsys_registry removelink #e4b3a86a82c26941S32ef81a1455fe48473S7bd3 #e4b3a86a82c26941S32ef81a1455fe48473S7fd6
    And do the following To remove the link between WORKSPACE_WEBAPP (#e4b3a86a82c26941S32ef81a1455fe48473S7bd3 ) and Parent1 and Parent2:
    epmsys_registry removelink #e4b3a86a82c26941S32ef81a1455fe48473S7bd0
    #e4b3a86a82c26941S32ef81a1455fe48473S7bd3
    epmsys_registry removelink #e4b3a86a82c26941S32ef81a1455fe48473S7ffe
    #e4b3a86a82c26941S32ef81a1455fe48473S7bd3
    - Now that the link has been removed, delete the WORKSPACE_WEBAPP component using its ObjectID :
    epmsys_registry deletecomponent #parentObjectID
    In this example:
    epmsys_registry deletecomponent #e4b3a86a82c26941S32ef81a1455fe48473S7bd3
    - Delete also the Parent representing the WORKSPACE_LWA
    epmsys_registry deletecomponent #e4b3a86a82c26941S32ef81a1455fe48473S7bd0
    Note:So we have now deleted the WEBAPP and LWA for workspace.
    6- Repeat steps in section No 5 for every WEBAPP with EPMServer0
    7- Start the Weblogic admin console and login
    Then go to the left panel and Expand Environment -> Server
    Click on Lock & Edit -> Select EPMServer0 -> click on Delete and confirm
    Activate Changes and Log off
    8- Stop the weblogic admin console server
    9- Go to the following location and delete the folder EPMServer0:
    \Oracle\Middleware\user_projects\domains\EPMSystem\servers
    Delete also EPMServer0 from the following location:
    \Oracle\Middleware\user_projects\domains\EPMSystem\config\fmwconfig\servers
    10- Start a command prompt and delete the Windows service that was created for EPMServer0 (if using Microsoft Windows Operating System):
    Right click on the service 'OracleHyperion EPM Server - Java Web Application (epmssystem1)' and get its service name i.e: HyS9EPMServer_FOUNDATION1
    Run the following command: sc delete HyS9EPMServer_FOUNDATION1
    11- Launch the EPMSystem configurator and redeploy the web application server to their own JVM
    12- Go to the following location \Oracle\Middleware\user_projects\FOUNDATION1\httpConfig\ohs\config\OHS\ohs_component and rename the file mod_wl_ohs.conf to mod_wl_ohs.conf.old.
    13- Copy the unconfigured mod_wl_ohs.conf file from the location C:\Oracle\Middleware\ohs\ohs\conf to the location \Oracle\Middleware\user_projects\FOUNDATION1\httpConfig\ohs\config\OHS\ohs_component
    14- Run the EPM System Configurator again and configure the WebServer to reconfigure the OHS configuration file mod_wl_ohs.conf.
    Once done then open the mod_wl_ohs.conf file and make sure that there are no servers configured with Port 9000.
    15- Start the services and test the workspace

  • How can i see the content of the cache server 2 ?

    How can i see the content of the cache server 2 ?

    Caching server is backed by an sqlite database.  If you want to see what you currently have downloaded, you can glean some information by accessing the database.  Use this command to connect to the database:
    sudo sqlite3 /Library/Server/Caching/Data/AssetInfo.db
    Once connected, you can use .tables to see the tables in the database but the one with the most information appears to be ZASSET.  Use:
       select * from ZASSET;
    To list the current contents.  You will get a series of records similar to the following:
    26|1|5|0|868991341|402440412.42114|402507221.969799|ffaf18a45cd5dd5e853233629036 5767|30B9108D-ABE4-4061-A2E0-42E91301249B|Fri, 06 Sep 2013 18:21:34 GMT|/content/downloads/14/11/091-9722/ognnjd4fno85m4pbapjtnv23b7rf1mkufx/OSXUpd Combo10.8.5.pkg|
    Note that the final value is a human recognizable name of the package.  However, you may also see items like this:
    125|1|4|0|11622676|406739736.508118|406739736.508125|4f1f9b08b32f9f6211e4569604b 1efef|481BF3D9-99BB-415F-ADB6-860EDD24B08E|Thu, 14 Nov 2013 10:24:30 GMT|/us/r1000/032/Purple6/v4/37/a3/d2/37a3d2f7-2594-8224-7eda-712f17a3fd8b/mzps 6227198657217312566.D2.pd.ipa|
    This is an iOS application.  There is no real way that I know of yet to match the package name (mzps6227198657217312566.D2.pd.ipa) to a product name.
    When finished, type .quit
    R-
    Apple Consultants Network
    Apple Professional Services
    Author "Mavericks Server – Foundation Services" :: Exclusively available on the iBooks Store

  • Multiple ESS access to single EP server from two backend servers.

    Hi Experts,
    I have one concern regarding ESS.
    Can we do or can we make   two ESS access (R3 server1 and R3 Server2)  from one Portal server.
    I heard  that from one portal server (ESS)  we can connect multiple clients which are from backend R3 (example client 100 and client 200)
    My requirement is  :
    We have two R3 backend servers and one EP(ESS) server.
    Can we access two backend systems from one EP server with Two ESS tabs.
    I am expecting Multiple jco settings, multiple SSo, Multiple SLD, Multiple SPRO Menu settings, UWL settings.
    Multiple service specific settings to be access  by using  single EP server(Multiple ESS Tabs)
    Please help me for doing this.
    Regards
    Kumar.

    yes you can do so As Pooja indicated also refer
    Please have a look  at the Note 596698
    Thanks for clearing that up, Now if I understand the issue
    correctly :
    1 Portal, Two backend R/3 System, This can be done, Now then
    if you dont want the particular application disable that
    r/3 as you are aware that the links appear from V_T7XSSSERRES.
    Here you can also make sure some applications appear or no.
    Accessing multiple Backends in WebDynpro:
    How it can be done?
    1) Define different JCO Destinations
      The logical System names have to be defined in the Web Dynpro Content
    Administrator.
      Different clients or completely different Systems can be accessed
    given that the function modules called exist in those systemsThe logical System to be used can be passed to the Web Dynpro
    Application by using a URL Parameter
      The URL Parameter can be easily maintained in the iView Property when
    using the portal.
    The standard way to handle this is to create copies (via delta-link) of
    all the business package iviews and change the 'System' property in the
    newly created iviews to point to the correct system Alias. From the
    portal point of view this is all that is required in order to point an
    view to a different system
    Refer these links for further information:
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.
    docs/library/webas/webdynpro/How%20to%20Use%20the%20Web%20Dynpro%20Conte
    nt%20Administrator.pdf

  • Dynamically changing an existing dataconnection's server / port

    Hi All,
    Moving from one development environment to the next is sometimes a real pain.
    Scenario:
    - I have three environments: DEV, QA & PROD
    - I have a livecycle designer pdf - FORM A - that has the following dataconnection: http://DEVserver:8080/....
    - When I move FORM A from DEV to QA, i need to update the dataconnection to http://QAserver:8090/...
    - When I move FORM A from QA to PROD, I need to update the dataconnection (again) to http://PRODserver:7890/...
    1) this is a pain
    2) this is a nightmare, when you have multiple dataconnections and many forms.
    Proposed Solution, that I need input on.
    The binding XML, will pass in the server name and required port number.
    Then via code, I change the server & port of an existing dataconnection dynamically.
    I tried: WebserviceCallButton.event__click.submit.target = "http://" + vServer + ":" + vPort + vURLCall;
    However, it does not allow the change.
    Am I missing something?
    ANY INPUT OR ALTERNATIVE IDEAS
    Thanks alot in advance.
    I thought of maybe a trying to wrap a dataconnection into a fragment... no luck!

    legendry response...
    makes sense why they wouldn't want one to change the "set" dataconnection.
    thanks for this...
    will try it on monday!

  • Weblogic Admin server port configuration

    Hi All,
    I want to configure the Admin server port from 7001 to 80. Since I cant access Admin console, can we change this using the config files.If so, which file I need to
    modify.
    Environment: Oracle Enterprise Linux
    Pl. provide me some inputs.
    THanks
    Raj

    Hi Raj
    1. By default when you create a Weblogic Domain and choose all the defaults, it uses default port as 7001. There will NOT be any entry for this in config.xml file. Look for the file named config.xml file under yourDomain/config/ folder. You will not find any word like "7001" most of the times.
    The entries related to this section are something like this in addition to extra tags between <server>...</server> for example:
    <server>
    <name>yourAdminServerName</name>
    <listen-address/>
    </server>
    2. Take a back up of config.xml file. Make sure Server is not running. If someting goes wrong, use this backup config.xml file to restart the server.
    3. Carefully edit config.xml file, the contents inside the above tag <server>...</server> by adding a new attribute as shown below by name <listen-port>
    <server>
    <name>DefaultServer</name>
    <listen-port>80</listen-port>
    <listen-address></listen-address>
    <tunneling-enabled>true</tunneling-enabled>
    </server>
    All you do is add this one line: <listen-port>80</listen-port> within the <server>...</server> tags.
    Restart the server. Access the weblogic console like this now http://localhost:80/console or http://localhost/console (port 80 is default and we do not need to type it manually).
    Thanks
    Ravi Jegga
    NOTE: You can change the port from Admin Console also, siince you mentioned you do not have access to console, you can manually edit config.xml file.

  • 10.3, how to configure cluster as "single Weblogic server"

    Hello,
    We have a Cluster with Two Managed servers. The ports for the MS's are 7002, 7003. We want deployments for these servers to be visible through port 80/443. Currently we have Mapviewer application deployed and targeted to the cluster. All servers are RUNNING and the deployment is active. However we are only able to access the deployment on ports 7002, 7003.
    The documentation states: "A WebLogic Server cluster consists of multiple WebLogic Server server instances running simultaneously and working together to provide increased scalability and reliability. A cluster appears to clients to be a single WebLogic Server instance."
    But nowhere does it state how to get a cluster to appear as a "single Weblogic server instance". Where does this happen in the admin console or config files? Perhaps its a node manager function? Please help. Thank you.

    Thank you. I was beginning to think it was something external to Weblogic. I saw alot in the docs about Load Balancing within Weblogic but didn't read much into it. I'm assuming its more at the application level? Anyhow..
    Reading the description of the FrontEndHttpPort config option for Clusters made me think it was the solution:
    "Sets the FrontendHTTPPort for the default webserver (not virtual hosts) for all the servers in the cluster. Provides a method to ensure that the webapp will always have the correct PORT information, even when the request is coming through a firewall or a proxy. If this parameter is configured, the HOST header will be ignored and the information in this parameter will be used in its place, when constructing the absolute urls for redirects."
    I would set FrontendHTTPPort to 80, restart everything and get strange results. If I typed in http://localhost:7003/mapviewer it will redirect browser to http://localhost/mapviewer/faces/home.jspx and give a 404 type error. Using this new URL if I inserted the :7003 port again and hit go, the page would come up...but submitting a form or link on the page it would redirect back to port 80 and a 404 error. edit: this is probably working as intended.
    So is there a popular solution or plugin for this issue?
    Edited by: jstretch on Jan 21, 2009 2:06 PM

  • EPM 11.1.2.x deployment to single managed server

    Hi Gurus,
    I have 2 questions:
    1) If we install some applications on single port number:9000(deploy to single managed server), after that if we deploy some applications to individual ports. is this installation work?
    2) for example we have installed and configured all applications to single managed server:9000. Now can we change this to individual port numbers??
    I mean can we configure all application to individual port numbers??
    Just asking with curiosity to know about this scenarios.
    Thanks,
    mady

    Hi Pablo,
    Hope you are doing good. In Starting of Carrer on Hyperion, JohnGoodwin and Your replies on the Forum was very helpful to me.  Nowadays,you are busy i think, and we are not getting more responses from you .
    Pablo wrote:
    If what you're trying to do is deploy everything to 9000, test that and then deploy everything to its own managed server, the answer is yes you can but you need to re-run the OHS configuration at the end everytime as it will need to update the mod_wl_ohs.conf file to update the ports/# of managed servers.
    Pablo
    In the response, Can we get any conflict between services if we do reconfigure to the Own managed server.?
    (why i am asking this question is, at the time of configuration to single managed server, we get EPM Server Service, then some more services only. But if we do reconfigure to the Own managed server, we will get more services in Services.msc)
    I didn't test this yet, just i got this doubt if we do like this what will happens. is it work or not?
    Thanks for your valuable time Pablo.
    Thanks,
    mady

Maybe you are looking for

  • Oracle BI  Publisher installation - need help asap

    Hi, I have a laptop with Windows Vista Home Premium with service pack 1 and Mircosoft office word 2007. I have to write template layout for ORACLE Report. I went to OTN website and installed ORACLE BI Publisher DeskTop - bipublisher_desktop_windows_x

  • How to have a UILabel with dynamic height?

    Hi, I have a UILabel which I created it programmatically. This UILabel consists of dynamic data and has line break. I tried setting this to my UILabel: CGRect cuisineRect = CGRectMake(94, 66, 180, 50); UILabel *cuisineStr = [[UILabel alloc] initWithF

  • Fin year is oct -sep (ie: leading ledger), want to see the report Apr - mar

    Dear All Case 1) Our Company finacial year is Oct2007 - Sep2008,( ie : Leading Ledger) and we have run the dep , and I want to see the effect on Non Leading ldger ( April - March).Please let me know how do i check the report. With Regards, kamalnatha

  • GREP code for find/change

    Hi everyone, I have a list of about 500 entries, with each entry being formatted as follows: Firstname [tab] Lastname [tab] State [tab] Level I need to perform a find/change operation using some GREP code that will target the tab between the first an

  • The what color become blue in Bridge CS5

    the same photo I open in Photoshop and Bridge but inside Bridge it become so blue tone~! is it the ICC profile or any color preview setting not correct? Pls. advice., where the manual set up?? thx