Monitoring TCP port status

I would like to know if a tcp port is open or not. How can i do it ?

Hello IDS,
Thank you for contacting National Instruments.
I have created an example VI that expands on Stijn's response. The TCP listen will return IP and port information if the selected port is open. If it is not, the VI will time out and send an error. By putting the TCP Listen VI in a while loop and monitoring the error status, you can monitor the status of the TCP port.
You can adjust the timeout according to your needs.
I hope this helps,
Sean C.
Applications Engineer
National Instruments
Attachments:
ExampleVI.vi ‏26 KB

Similar Messages

  • Monitoring TCP ports

    Utilizing a 1605, is there a MIB or another way to show amount of traffic by tcp or udp port on a particular interface?

    Brian
    If you want reporting on specific TCP ports and packet count is sufficient then an alternative to consider would be to create an access list and assign it to the interface (depending on your requirements you might want one access list for inbound and a similar access list for outbound). This access list would not necessarily deny anything. But it would have permit statements for the particular tcp ports that you are interested in and a permit any at the bottom. This way the access list would count packets for the TCP (or UDP) port.
    An example would be this:
    ip access-list extended count_in
    remark count tcp packets inbound
    permit tcp any any eq 23
    permit tcp any any eq 80
    permit tcp any eq 23 any
    permit tcp any eq 80 any
    permit any any
    ip access-list extended count_out
    remark count tcp packets outbound
    permit tcp any any eq 23
    permit tcp any any eq 80
    permit tcp any eq 23 any
    permit tcp any eq 80 any
    permit any any
    interface fastethernet0/0
    ip access-group count_in in
    ip access-group count_out out
    then show access-list count_in and show access-list count_out would show the number of hits for each line and you would have packet counts for your specific TCP ports.
    HTH
    Rick

  • [SQL QUERY] Select TCP Port Monitors and their related Watcher Node

    Hi everybody,
    I'm working on a SSRS report and SQL Query, I have no problem to find all my TCP Port Monitor (SCOM 2012 R2) based on the DisplayName, but I can't figure out how to get their related watcher nodes (in my case only 1 computer is a watcher node).
    I can't find which table, which field, contains this information..?
    Here is the query i started to write (i select * since i still searching for the right column):
    SELECT
    FROM StateView s
    INNER JOIN BaseManagedEntity me on me.BaseManagedEntityId=s.BaseManagedEntityId
    INNER JOIN MonitorView mv on mv.Id=s.MonitorId
    INNER JOIN ManagedTypeView mtv on mtv.Id=s.TargetManagedEntityType
    --where mv.DisplayName like 'Ping Target Status Check%'
    AND me.IsDeleted = '0'
    where mv.DisplayName like '%tcpmon%'
    and mv.LanguageCode = 'ENU'
    --and s.HealthState in (@state)
    ORDER BY s.Lastmodified DESC
    It would be great if someone can help me !
    Thanks,
    Julien

    Hi,
    After creating a TCP port monitor, we can find a table for this monitor under operationsmanager database :
    SELECT *
    FROM [OperationsManager].[dbo].[MT_TCPPortCheck_******WatcherComputersGroup]
    You will find the warcher computer group.
    Regards,
    Yan Li
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact [email protected]

  • Operations Manager 2012 - TCP Port Monitor

    Hi,
    Is it possible to have the TCP port monitor only alert if it fails on subsequent polls, instead of the single connection failure which is the default? We have 3 GPRS connections which intermittently
    fail, so we only need to be alerted if they don't come back online after a 5-10 minute inverval and 2 failed connection attempts in a row.  We have orchestrator so perhaps a runbook needs to be created?
    Thanks

    Hi,
    Yes. The Runbook could do this trick. I think you need to make the monitors not to generate alerts when health state changes. Then use runbook to monitor the Health State, if some conditions are ture, an alert will be generated.
    I am not so familiar with Orchestrator, you may ask at Orchestrator to get answered of how to design the Runbook.
    Juke Chou
    TechNet Community Support

  • Monitor a TCP port but alert only if timed out X times

    Hello,
    I need to build a moniotr that will probe a TCP port but alert only if timed out X times
    I was looking at Microsoft.SystemCenter.SyntheticTransactions.TCPPortCheckProbe module but it doesn't have this options
    Thanks,
    Marius

         You can check 
       http://www.ghacks.net/2010/05/25/tcp-port-monitor-port-alert/
         for TCP Port Monitor Port Alert

  • Create TCP port monitor to ping windows server or network device

    Dears
    I'm trying to create TCP port monitor which tests the ping of a remote network device or windows computer from the watcher node, but I don't know which port to use, is there a specific port number?
    Thanks
    Mohammad, IT NOC Team

    I also would like to share the following article with you. It is a sample script that will use netstat –an to check the TCP ports currently in a listening state on the local system 
    and parse the output to determine that the defined TCP port is in a listening state.
    http://operatingquadrant.com/2009/08/13/scom-locallly-monitoring-a-listening-tcp-port/
    Niki Han
    TechNet Community Support

  • Http probe on non-standard tcp port 8021

    I've configured http probe on standard port 80 with no issue. I'm now trying http probe on non-standard tcp port 8021, confirmed with packet capture to confirm that the CSM is indeed probing, status code 403 is returned but the reals are showing "probe failed". Am I missing something? Thank you in advance.
    CSM v2.3(3)2
    probe 8021 http
    request method head
    interval 2
    retries 2
    failed 4
    port 8021
    serverfarm TEST
    nat server
    no nat client
    real 10.1.2.101
    inservice
    real 10.1.2.102
    inservice
    probe 8021
    vserver TEST
    virtual 10.1.2.100 tcp 8021
    serverfarm TEST
    replicate csrp connection
    persistent rebalance
    inservice
    VIP and real status:
    vserver type prot virtual vlan state conns
    Q_MAS_8021 SLB TCP 10.1.2.100/32:8021 ALL OUTOFSERVICE 0
    real server farm weight state conns/hits
    10.1.2.101 TEST 8 PROBE_FAILED 0
    10.1.2.102 TEST 8 PROBE_FAILED 0

    you need to specify what HTTP response code you expect.
    The command is :
    gdufour-cat6k-2(config-slb-probe-http)#expect status ?
    <0-999> expected status - minimum value in a range
    The default is to expect only 200.
    This is why your 403 is not accepted.
    Gilles.

  • Monitoring access ports with DFM

    Hello,
    I need to monitor access port for utilization and high broadcasts and errors on Catalyst switch.
    I can easily change access port in device details of the switch to managed state and it detects the thresholds fine.
    Problem comes when user turn off the PC. The port comes to operationally down status which appears as a critical error in DFM.
    I don´t want to monitor up-down status of access ports, but I can´t find out how to turn it off.
    Do you have any idea?
    Thank you.

    sistemas2.macae.rj.gov.br:82
    That should work.  I confirmed it on my server using http on port 84.
    Are you sure that the server is working and you have access?  When I tried the example you gave, I get access denied.

  • ACE Probe Config for Blue Coat Proxy TCP Port 74 NETRJS-4

    We are running 4710's with A5(2.2). We use Blue Coat proxies for our internet connections, specifcally TCP port 74. So when we open up a browser connection to www.cisco.com, the HTTP GET is actually encapsulated in TCP port 74 netrjs-4. We want to load-balance these proxies with ACE and I'm trying to setup health probes, but the only ones that work are the tcp probes PROXY_BCC_PROBE and PROXY_PROBE. I'd like to have health probes that hit external websites, but I'm confused whether the "ip address" Probe sub command is all I need, and netrjs is simple encapsulation of the HTTP request (which is what it looks like on a sniffer). Does anyone have Blue Coat proxies/ACE working? If so, how are your probes configured?
    Thanks,
    probe tcp PROXY_BCC_PROBE
      port 8084
      interval 3
      passdetect interval 3
    probe http PROXY_HTTP1_PROBE
      ip address 198.133.219.25
      port 74
      interval 3
      passdetect interval 3
      request method head url /index.html
      expect status 200 299
    probe http PROXY_HTTP2_PROBE
    ip address 198.133.219.25
      port 74
      interval 3
      request method get url /
      expect status 200 299
    probe tcp PROXY_PROBE
      port 74
      interval 3
      passdetect interval 3

    Hi,
    I have seen this working for one of the customer.
    probe http HTTPGET
      description Tests that www.gmail.com returns 302 redirect
      interval 10
      request method get url http://www.gmail.com
      expect status 302 302
    If I modify your probe :
    probe http PROXY_HTTP1_PROBE
      ip address 198.133.219.25
      port 74
      interval 3
      passdetect interval 3 
    request method get url
      http://www.gmail.com
    expect status 302 302
    Give it a try and see if that helps.
    regards,
    Ajay Kumar

  • ACE VIP OK HTTP, NOK other TCP port

    Hi,
    we are having issues in configuring load balancing for a TCP port. For HTTP it's working without issues and we have the ACE also balancing for other TCP ports.
    Here goes the relevant config:
    probe http PROBE-HTTP
      interval 5
      passdetect interval 2
      passdetect count 1
      request method get url /idc/
      expect status 200 200
    probe tcp PROBE-TCP
      port 4444
      interval 5
      passdetect interval 10
    rserver host PRD1
      ip address 10.10.10.1
      inservice
    rserver host PRD2
      ip address 10.10.10.2
      inservice
    serverfarm host SF-HTTP
      probe PROBE-HTTP
      rserver PRD1 80
        inservice
      rserver PRD2 80
        inservice
    serverfarm host SF-TCP
      probe PROBE-TCP
      rserver PRD1 4444
        inservice
      rserver PRD2 4444
        inservice
    sticky ip-netmask 255.255.255.255 address source SC-IP-PRD-HTTP
      timeout 10
      serverfarm SF-HTTP
    class-map match-all NAT-VIP-HTTP
      2 match virtual-address 10.10.35.1 any
    class-map match-all NAT-VIP-TCP
      2 match virtual-address 10.10.35.1 tcp eq 4444
    policy-map type loadbalance first-match LB-VIP-HTTP
      class class-default
        sticky-serverfarm SC-IP-PRD-HTTP
        insert-http x-forward header-value "%is"
    policy-map type loadbalance first-match LB-NAT-VIP-TCP
      class class-default
        serverfarm SF-TCP
    policy-map multi-match POLICY-RSERVER-VIP
      class NAT-VIP-TCP
        loadbalance vip inservice
        loadbalance policy LB-NAT-VIP-TCP
        loadbalance vip icmp-reply active
        nat dynamic 1 vlan 200
      class NAT-VIP-HTTP
        loadbalance vip inservice
        loadbalance policy LB-VIP-HTTP
        loadbalance vip icmp-reply active
        nat dynamic 1 vlan 200
    interface vlan 200
      description SERVER-SIDE
      ip address 10.10.14.2 255.255.255.0
      alias 10.10.14.1 255.255.255.0
      peer ip address 10.10.14.3 255.255.255.0
      access-group input EVERYONE
      nat-pool 1 10.10.4.6 10.10.4.6 netmask 255.255.255.255 pat
      service-policy input AllowICMP
      service-policy input POLICY-RSERVER-VIP
      no shutdown
    The probe are OK, but nothing seems to get to the VIP:
    ACE/CTX# show probe PROBE-TCP
    probe       : PROBE-TCP
    type        : TCP
    state       : ACTIVE
       port      : 4444    address     : 0.0.0.0         addr type  : -
       interval  : 5       pass intvl  : 10              pass count : 3
       fail count: 3       recv timeout: 10
                           --------------------- probe results --------------------
       probe association   probed-address  probes     failed     passed     health
       ------------------- ---------------+----------+----------+----------+-------
       serverfarm  : SF-TCP
         real      : PRD1[4444]
                           10.10.10.1     8853       1          8852       SUCCESS
         real      : PRD2[4444]
                           10.10.10.2     8853       1          8852       SUCCESS
    ACE/CTX# show serverfarm SF-TCP detail
    serverfarm     : SF-TCP, type: HOST
    total rservers : 2
    active rservers: 2
    description    : -
    state          : ACTIVE
    predictor      : ROUNDROBIN
    failaction     : -
    back-inservice    : 0
    partial-threshold : 0
    num times failover       : 0
    num times back inservice : 1
    total conn-dropcount : 0
    Probe(s) :
        PROBE-TCP,  type = TCP
                                                    ----------connections-----------
           real                  weight state        current    total      failures
       ---+---------------------+------+------------+----------+----------+---------
       rserver: PRD1
           10.10.10.1:4444      8      OPERATIONAL  0          0          0
             max-conns            : -         , out-of-rotation count : -
             min-conns            : -
             conn-rate-limit      : -         , out-of-rotation count : -
             bandwidth-rate-limit : -         , out-of-rotation count : -
             retcode out-of-rotation count : -
             load value           : 0
       rserver: PRD2
           10.10.10.2:4444      8      OPERATIONAL  0          0          0
             max-conns            : -         , out-of-rotation count : -
             min-conns            : -
             conn-rate-limit      : -         , out-of-rotation count : -
             bandwidth-rate-limit : -         , out-of-rotation count : -
             retcode out-of-rotation count : -
             load value           : 0
    ACE/CTX# show service-policy POLICY-RSERVER-VIP
    Status     : ACTIVE
    Interface: vlan 1 200
      service-policy: POLICY-RSERVER-VIP
        class: NAT-VIP-TCP
          nat:
            nat dynamic 1 vlan 200
            curr conns       : 0         , hit count        : 0
            dropped conns    : 0
            client pkt count : 0         , client byte count: 0
            server pkt count : 0         , server byte count: 0
            conn-rate-limit      : 0         , drop-count : 0
            bandwidth-rate-limit : 0         , drop-count : 0
          loadbalance:
            L7 loadbalance policy: LB-NAT-VIP-TCP
            VIP ICMP Reply       : ENABLED-WHEN-ACTIVE
            VIP State: INSERVICE
            curr conns       : 0         , hit count        : 0
            dropped conns    : 0
            client pkt count : 0         , client byte count: 0
            server pkt count : 0         , server byte count: 0
            conn-rate-limit      : 0         , drop-count : 0
            bandwidth-rate-limit : 0         , drop-count : 0
          compression:
            bytes_in  : 0
            bytes_out : 0
    I see a lot of this messages in the logging of the ACE:
    show logging | i 4444
    22:02:52 : %ACE-6-302023: Teardown TCP connection 0x18b6 for vlan200:10.10.14.2/26768 to vlan200:10.10.10.2/4444 duration 0:00:00 bytes 1051 TCP FINs
    22:02:55 : %ACE-6-302022: Built TCP connection 0x14dc for vlan200:10.10.14.2/30318 (10.10.10.1/30318) to vlan200:10.10.10.1/4444 (10.10.14.2/4444)
    22:02:55 : %ACE-6-302023: Teardown TCP connection 0x14dc for vlan200:10.10.14.2/30318 to vlan200:10.10.10.1/4444 duration 0:00:00 bytes 1103 TCP FINs
    22:02:57 : %ACE-6-302022: Built TCP connection 0xc6c for vlan200:10.10.14.2/26784 (10.10.10.2/26784) to vlan200:10.10.10.2/4444 (10.10.14.2/4444)
    22:02:57 : %ACE-6-302023: Teardown TCP connection 0xc6c for vlan200:10.10.14.2/26784 to vlan200:10.10.10.2/4444 duration 0:00:00 bytes 1103 TCP FINs
    22:03:02 : %ACE-6-302022: Built TCP connection 0x151a for vlan200:10.10.14.2/26800 (10.10.10.2/26800) to vlan200:10.10.10.2/4444 (10.10.14.2/4444)
    show logging | i 4444
    22:02:52 : %ACE-6-302023: Teardown TCP connection 0x18b6 for vlan200:10.10.14.2/26768 to vlan200:10.10.10.2/4444 duration 0:00:00 bytes 1051 TCP FINs
    22:02:55 : %ACE-6-302022: Built TCP connection 0x14dc for vlan200:10.10.14.2/30318 (10.10.10.1/30318) to vlan200:10.10.10.1/4444 (10.10.14.2/4444)
    22:02:55 : %ACE-6-302023: Teardown TCP connection 0x14dc for vlan200:10.10.14.2/30318 to vlan200:10.10.10.1/4444 duration 0:00:00 bytes 1103 TCP FINs
    22:02:57 : %ACE-6-302022: Built TCP connection 0xc6c for vlan200:10.10.14.2/26784 (10.10.10.2/26784) to vlan200:10.10.10.2/4444 (10.10.14.2/4444)
    22:02:57 : %ACE-6-302023: Teardown TCP connection 0xc6c for vlan200:10.10.14.2/26784 to vlan200:10.10.10.2/4444 duration 0:00:00 bytes 1103 TCP FINs
    22:03:02 : %ACE-6-302022: Built TCP connection 0x151a for vlan200:10.10.14.2/26800 (10.10.10.2/26800) to vlan200:10.10.10.2/4444 (10.10.14.2/4444)
    The client request it's going trough an ASA, in the ASA side I see that the TCP connection it' half-open with SAaB flags. It seems that the VIP never replies with SYN+ACK to the ASA...
    Thank you.
    Best regards

    Hi Norberto,
    The log messages you are getting are most probably the probe connections and not a failure, looking to them you will see your ACE is establishing TCP connection on 4444 then it will teardown the connection with FIN which is expected since you are using TCP keepalives.
    I would recommend to go back and define the problem exactly, what are you exteriancing when you try to telnet on port 4444 toward the VIP from the client?
    Run sniffing software on the client, the server and enable capture on ACE and ASA will give you exact idea what you are experiencing.
    Note: The ASA and the ACE has great capture feature which will show you exactly the packet flows.
    Note: Since you are applying NAT on the client requests, you should see the NATed IP address on the server capture.
    Note: With L4 load balancing the ACE is not spoofing the clients' request, it just forward the SYN, SYN+ACK and ACK between the server and the client.
    Let me know if you have any other questions.
    Best regards,
    Ahmad

  • ON RWB - CC Monitoring - SOAP Channel. status says  "inactive or unregister

    Hi,
    I am working on SOAP Webservices.
    My Scenario is working fine ... But Some How on RWB - CC Monitoring - SOAP Channel. status says  "inactive or unregistered".
    On the otherside , my SOAP Scenario is working fine...
    But why for that status " "inactive or unregistered"." , I dont Know?
    Please Suggest, How to Deal with this ........?
    I executed transaction code " se38 - > SRT_ADMIN_CHECK report "
    It states me almost every thing unregistered/ inactive/ not configured except ICM Services ..
    are these services shoud active and registered for SOAP Scenario?
    how to activate them .............????????
    That CC status " "inactive or unregistered" has anything to do with this  SRT_ADMIN_CHECK report????
    Regards
    Prabhat Sharma.

    Hi
    This is the problem which i recently faced and solved.
    Cause: Saop related  J2EE application are stoped or not set to  default start as initial state.This is also a reason
                 for 503 service unavailable error while soap posting.
    Solution : start the J2EE app , com.sap.aii.adapter.soap.app & com.sap.aii.adapter.soap.lib  set them as defualt started
                   as initial state.
    Where  : If you are in PI 7.1 ,  http:<host>:<port>/nwa->Operations Management  -> Systems -> Start & Stop -> Java EE      
                   Applications.
                    Refer http://wiki.sdn.sap.com/wiki/display/XI/start_stop_applications for more help.
                   Also in Start button , there will be a dropdown where you can set the  default initial state as started.Simply starting may
                   cause similar problem ( not registered ????????) again ,so better to set initial as started state.
    Regards,
    $rinivas

  • Monitoring open ports and IP adresses on Windows clients

    I'm using SCOM 2012 for monitoring system. 
    I cannot find how to monitor open ports (TCP, UDP) and IP addresses on Windows based PCs. I need that kind of report for Internal auditors and Security officer.
    Is it possible to get Windows Firewall State, collect it in SCOM and prepare report on monthly base?
    tnx in advance

    I have found a possibility to do this. Hope you understand this and it is helpful. This is a two step process but guess will definitely server the purpose.
    Scope: We will be running a tool which will monitor a port (TCP or UDP) for a specific host / IP and will throw a log file.
    SCOM will monitor the log file and will throw a alert if the log file contains the string NOT LISTENING (Port not working or unable to open the port) which the program will create the log with the results.
    First download the program named: PortQry Command Line Port Scanner Version 2.0 from microsoft using the below link. It is a command line tool.
    http://www.microsoft.com/en-in/download/details.aspx?id=17148
    Run it using by making a batch file or powershell script using task scheduler as per your time requirement (Every 5 min or 1Hr).
    Use this command to monitor a ip / hostname and its port with TCP or UDP.
    I have pasted the command file of the program in C:\Port_checker directory so i am using the below syntax
    C:\Port_checker\PortQry.exe -N 192.168.1.1 -e 5723 -p UDP -l C:\Port_checker\Result.log /y
    -N = Hostname / FQDN of agent or Ip address
    -E = Port # what you want to monitor
    -P = Protocol (TCP or UDP)
    -L = Generate log on the following location and name
    /Y = To replace the existing log file name to fresh one without prompt.
    The result in the log file will be as follows:
    ============================
    For successful port open:
    PortQry Version 2.0 Log File
    System Date: Tue Oct 07 09:42:32 2014
    Command run:
     C:\PortQryV2\PortQry.exe -N 192.168.1.1 -e 5723 -p UDP -l C:\Portqryv2\Result.log /y
    Local computer name:
     192.168.1.2
    Querying target system called:
     192.168.1.1
    Attempting to resolve name to IP address...
    Name resolved to 192.168.1.1
    querying...
    UDP port 5723 (unknown service): LISTENING
    ========= end of log file ========= 
      PortQry developed by Tim Rains
    For failure port open:
    PortQry Version 2.0 Log File
    System Date: Tue Oct 07 09:42:32 2014
    Command run:
     C:\PortQryV2\PortQry.exe -N 192.168.1.1 -e 5723 -p UDP -l C:\Portqryv2\Result.log /y
    Local computer name:
     192.168.1.2
    Querying target system called:
     192.168.1.1
    Attempting to resolve name to IP address...
    Name resolved to 192.168.1.1
    querying...
    UDP port 5723 (unknown service): NOT
    LISTENING
    ========= end of log file ========= 
      PortQry developed by Tim Rains
    Now as per the above results NOT LISTENING Port is blocked or is not opened and LISTENINGmeans
    working or port is opened.
    So now using SCOM you will monitor the log file Result.log in the location C:\Port_checker\ saying
    if NOT LISTENING comes in the log file throw me a alert in SCOM consle or via email.
    To configure that alert you need to create a Generic text log alerting Rule which will throw a alert if any thing added in that log which is not to be added and if it is added like NOT
    LISTENING then it will throw a alert.
    Refer this link on how to open a Generic text log alerting Rule.
    http://blogs.technet.com/b/kevinholman/archive/2009/06/20/using-a-generic-text-log-rule-to-monitor-an-ascii-text-file-even-when-the-file-is-a-unc-path.aspx
    Gautam.75801

  • Dashboard for only Monitoring uplink ports ~~~~~SCOM 2012 R2

    Hi Guys,
    I want to monitoring signal interface of switch like uplink port. And same i want create dashboard.
    Please help me out for creating dashboard for only signal uplink interface port.

    If you want to monitor the interface status on a switch, you'll have to build a custom monitor. (Unless you use supported devices e.g. Cisco Catalyst).
    Go to authoring > monitors. Under the class 'Node' you can make a new monitor. Choose for SNMP and follow the wizard.
    You'll need the OID to monitor. Usually you can find this OID in the MIB's (using a MIB browser) of your device.
    MIB's can be found on the vendor website.

  • Bridged Wireless Blocks TCP Port 9100?

    On one of my networked computers, HP "Solutions Center" driver says HP 6310xi networked printer is connected, shows detail status & will print the HP diagnostic report direct to printer. Windows 7 shows printer on network map, & gives detailed status & setup info from printer internal data via IE through printer's IP address page (192.168.1.100); i.e. I can ping it. However, Win 7 printer control panel shows printer as "offline" on printers list & just ques up print requests. Troubleshooting gives error message "turn power on printer". Other networked PCs print OK. Bad computer is on a separate subnet of my home network, with a LinkSys wireless bridge WET610n connection, & printer is on another wireless LinkSys WET610n subnet. My network is totally LinkSys N, with a WRT 610n as main hub. All other network functions work for all other devices on the network, including DirecTV DVR receivers & Wii console!! I have moved the printer to the other subnet, & the problem is now mirrored by the computer on the remote subnet. It is not a firewall problem, but appears that the variables are the 2 wireless bridges that seem to conspire to block TCP port 9100 when in series. A single WET610n between the printer & a computer allows printing, proven by my roaming wireless laptop having access through the WET610n via the central wireless router. Very stange!! CTH

    If I understand correctly, you have a Linksys WRT610N as your main wireless-router with two satellite Linksys WET610N configured as Ethernet bridges -- right?
    You also have this setup:
    Win7 PC -> WET610N -> WRT610N -> WET610N -> Officejet 6310
    If I got this right, then the issue is probably the transit delay between the Win7 PC and the Officejet confusing HP's Solution Center.
    I think you have two options:
    1) Connect the Win7 PC directly to the WRT610N or connect the Officejet 6310 directly to the WRT610
    2) Manually install the printer.
    Let's try a manual installation:
    1. Click >> Start >> Control panel >> Printers.
    3. Click the Add a printer
    3. Select Local printer
    4. Select Create a new port and select Standard TCP/IP Port and click Next button.
    5. Under Device type, select TCP/IP Device. Under Hostname or IP address, enter the printer's host name (found on the printer's network configuration report the generated above). Click Next.
    If you get a message about Additional Port Information Required, then the printer was not found using the host name. You can go back and retry or using the printer's IP address instead of the host name.
    6. Select Hewlett-Packard from the list of manufacturers and select and select your printer model. Click Next.
    If your printer model was not listed, then select Have Disk, browse the HP CD that came with your printer and select the first file that starts with hp and ends with inf. Click Open then OK. Select your printer model. Click Next.
    7. If you are asked, use the currently installed driver.
    8. It will ask for the Printer name -- enter a new name or use the existing one. This will be the name of the printer that you select from other applications.
    9. You may be asked to share the printer. Make a choice and click Next.
    10. The Print Test Page box appears. Go ahead and print it.
    11. Click Finish.
    That should be it.
    Regards / Jim B / Wireless Enthusiasts
    ( While I'm an embedded wireless systems engineer at work, on this forum I do not represent my former employer, Hewlett-Packard, or my current employer, Microsoft )
    + Click the White Kudos star on the left as a way to say "thank you" for helpful posts.

  • Selector.open() uses two TCP ports on Windows

    As part of a security review, we are monitoring the ports opened by our application (which uses NIO) using TCPView on Windows Vista Business with sp1.
    I ran the NIO test below.
    public class NioSelectorMain {
    public static void main(String[] args) throws Exception {
    Selector selector = Selector.open();
    System.out.println(selector);
    Thread.sleep(Integer.MAX_VALUE);
    Example output is:
    sun.nio.ch.WindowsSelectorImpl@b1c5fa
    TCPView showed the following two ports opened - the numbers change each time obviously, but there are always two ports.
    javaw.exe:8224     TCP     aled-PC:50741     localhost:50742     ESTABLISHED     
    javaw.exe:8224     TCP     aled-PC:50742     localhost:50741     ESTABLISHED     
    I've tried this with sun jdk1.6.0_05 and jdk1.5.0_14. When running the same test on Linux, no ports are opened.
    Why are these ports used, and is there any way to either prevent them from being opened or to specify which ports should be used?
    Thanks in advance, Aled

    Thanks for the very prompt reply!
    or to specify which ports should be used?Why would you want to do that?Our enterprise customers would like to know which ports will be used so that they can lock down the machine as much as possible, and can better detect malicious programs/usage.
    I presume by "why would you want to do that" that it's not possible?

Maybe you are looking for