MPLS TE tunnel not coming up - RSVP issue?

Hello,
I have two routers R2 and R5 back to back and I am trying to create an MPLS TE tunnel between them. R2 already has one tunnel up and running to another router R1.
I think my issue is that no RSVP traffic is being sent by R2 or R5. Here is my interface config on R5 and some show commands:
R5#show run int s2/0
Building configuration...
Current configuration : 143 bytes
interface Serial2/0
ip address 192.168.25.5 255.255.255.0
mpls traffic-eng tunnels
fair-queue 64 256 32
ip rsvp bandwidth 1000 1000
end
R5#show ip int brief s2/0
Interface IP-Address OK? Method Status Protocol
Serial2/0 192.168.25.5 YES NVRAM up up
R5#show ip rsvp counters in s2/0
Serial2/0 Recv Xmit Recv Xmit
Path 0 0 Resv 0 0
PathError 0 0 ResvError 0 0
PathTear 0 0 ResvTear 0 0
ResvConfirm 0 0 ResvTearConfirm 0 0
UnknownMsg 0 0 Errors 0 0
R5#
I have mpls traffic-eng tunnels on all routers and interfaces. Here here is my tunnel config on R5 towards R2:
R5#show run int tun 2
Building configuration...
Current configuration : 174 bytes
interface Tunnel2
ip unnumbered Loopback0
tag-switching ip
tunnel destination 10.0.0.2
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
end
I also am learning all addresses via OSPF so R5 does have a route (and can ping) 10.0.0.2 (R2's loopback)
Any ideas where this is failing? Why isn't RSVP sending packets?
Thanks,

Here you go. I have made some changes since then but nothing major. Just adding interfaces under the OSPF MPLS traffic-eng to see if that will work. Also, there is a couple tunnels you see that I have not started to work on yet. Tunnel 5 on R2 points to R5. Tunnel 2 on R5 points to R2.
=====================================
R2:
R2# show run
Building configuration...
Current configuration : 1965 bytes
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname R2
logging buffered 16384 debugging
ip subnet-zero
ip cef
no ip domain-lookup
mpls label protocol ldp
mpls traffic-eng tunnels
tag-switching tdp router-id Loopback0
interface Loopback0
ip address 10.0.0.2 255.255.255.255
interface Tunnel1
ip unnumbered Loopback0
tunnel destination 10.0.0.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
interface Tunnel3
ip unnumbered Loopback0
tag-switching ip
tunnel destination 10.0.0.3
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
interface Tunnel5
ip unnumbered Loopback0
tunnel destination 10.0.0.5
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
interface FastEthernet1/0
ip address 205.127.233.242 255.255.254.0
speed 100
full-duplex
interface Serial2/0
ip address 192.168.12.2 255.255.255.0
mpls traffic-eng tunnels
fair-queue 64 256 37
ip rsvp bandwidth 1500 1500
interface Serial2/1
bandwidth 20000
ip address 192.168.25.2 255.255.255.0
mpls traffic-eng tunnels
fair-queue 64 256 37
ip rsvp bandwidth 1000 1000
interface Serial2/2
no ip address
shutdown
interface Serial2/3
no ip address
shutdown
router ospf 1
router-id 10.0.0.2
log-adjacency-changes
network 10.0.0.2 0.0.0.0 area 0
network 192.168.12.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 0
network 192.168.25.0 0.0.0.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng interface Serial2/0 area 0
mpls traffic-eng interface Serial2/1 area 0
mpls traffic-eng interface Loopback0 area 0
ip classless
ip http server
ip pim bidir-enable
call rsvp-sync
mgcp profile default
dial-peer cor custom
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
end
R2#
====================================
R5:
R5#show run
Building configuration...
Current configuration : 1492 bytes
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname R5
logging buffered 16384 debugging
ip subnet-zero
no ip domain-lookup
mpls label protocol ldp
mpls traffic-eng tunnels
tag-switching tdp router-id Loopback0
interface Loopback0
ip address 10.0.0.5 255.255.255.255
interface Tunnel2
ip unnumbered Loopback0
tunnel destination 10.0.0.2
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
interface Serial2/0
ip address 192.168.25.5 255.255.255.0
mpls traffic-eng tunnels
fair-queue 64 256 32
ip rsvp bandwidth 1000 1000
interface Serial2/1
ip address 192.168.45.5 255.255.255.0
shutdown
mpls traffic-eng tunnels
fair-queue 64 256 37
ip rsvp bandwidth 1000 1000
interface Serial2/2
no ip address
shutdown
fair-queue 64 256 37
ip rsvp bandwidth 10000 10000
interface Serial2/3
no ip address
shutdown
router ospf 1
router-id 10.0.0.5
log-adjacency-changes
network 10.0.0.5 0.0.0.0 area 0
network 192.168.25.0 0.0.0.255 area 0
network 192.168.45.0 0.0.0.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng interface Serial2/0 area 0
mpls traffic-eng interface Loopback0 area 0
ip classless
ip http server
ip pim bidir-enable
call rsvp-sync
mgcp profile default
dial-peer cor custom
end
R5#
======================================
thanks

Similar Messages

  • MPLS TE tunnel Bandwidth and ip rsvp bandwidth

    I have some questions about how to reserve bandwidth in MPLS TE enviorment.
    1. We must IP RSVP bandwidth in all concern interface in MPLS TE enviroment, right?
    2. What's the goal of ip rsvp bandwidth?
    3. Tunnel MPLS traffic-enginerring bandwitdh XXX, the command define flow bandwidth initiated by head-end, if sending more than XXX flow, how does it work? Drop excessive packet in the flow?
    Any point is welcome! Thanks!

    Hello,
    just today I found some time to read RFCs. and found:
    4124 Protocol Extensions for Support of Diffserv-aware MPLS Traffic Engineering. F. Le Faucheur, Ed.. June 2005. (Format: TXT=79265 bytes) (Status: PROPOSED STANDARD)
    4125 Maximum Allocation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering. F. Le Faucheur, W. Lai. June 2005. (Format: TXT=22585 bytes) (Status: EXPERIMENTAL)
    4126 Max Allocation with Reservation Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering & Performance Comparisons. J. Ash. June 2005. (Format: TXT=51232 bytes) (Status: EXPERIMENTAL)
    4127 Russian Dolls Bandwidth Constraints Model for Diffserv-aware MPLS Traffic Engineering. F. Le Faucheur, Ed.. June 2005. (Format: TXT=23694 bytes) (Status: EXPERIMENTAL)
    4128 Bandwidth Constraints Models for Differentiated Services (Diffserv)-aware MPLS Traffic Engineering: Performance Evaluation. W. Lai. June 2005. (Format: TXT=58691, PDF=201138 bytes) (Status: INFORMATIONAL)
    4201 Link Bundling in MPLS Traffic Engineering (TE). K. Kompella, Y. Rekhter, L. Berger. October 2005. (Format: TXT=27033 bytes) (Updates RFC3471, RFC3472, RFC3473) (Status: PROPOSED STANDARD)
    Basically these standards allow to combine congestion management and MPLS TE. The standard says a router "may allocate ressources" based on the MPLS TE reservations.
    So MPLS DiffServ-aware TE can deliver both TE and QoS.
    Regards, Martin

  • MPLS-TE Tunnel (FRR) Issue

    Hi
    Need some discussion on MPLS - TE tunnel issue.
    One of Tunnel with FRR configured, creates problem after a while affects the traffic running on the link until I shut the tunnel manually.
    Configs are ok because same configurations made for different cities to authenticate to a AAA server located in one of city.
    following is the generic diagram and complete config for respective links in all 3 cities but the tunnel on link highlighted with RED arrow creates problem after a while not at once until I shut the tunnel,
    The Platform is Cisco CISCO7609-S and all links are on 7600-SIP-400 module
    interface GigabitEthernet2/2/0
    description *** Physical Interface ***
    dampening
    mtu 9216
    ip address x.x.x.x x.x.x.x
    no ip redirects
    no ip proxy-arp
    ip ospf message-digest-key 1 md5 7 xxx
    ip ospf network point-to-point
    load-interval 30
    carrier-delay msec 0
    negotiation auto
    mpls traffic-eng tunnels
    mpls traffic-eng backup-path Tunnel2300
    mpls ip
    service-policy output egress_policy
    hold-queue 4096 in
    hold-queue 4096 out
    ip rsvp bandwidth percent 95
    ip rsvp signalling dscp 48
    end
    x.x.x.x#sh running-config int tun 1300
    Building configuration...
    Current configuration : 377 bytes
    interface Tunnel1300
    description *** Primary Tunnel ***
    ip unnumbered Loopback0
    shutdown
    mpls ip
    tunnel destination x.x.x.x
    tunnel mode mpls traffic-eng
    tunnel mpls traffic-eng autoroute announce
    tunnel mpls traffic-eng path-option 10 explicit name path-1300
    tunnel mpls traffic-eng fast-reroute
    end
    x.x.x.x#sh running-config int tun 2300
    Building configuration...
    Current configuration : 332 bytes
    interface Tunnel2300
    description *** Backup Tunnel ***
    ip unnumbered Loopback0
    shutdown
    mpls ip
    tunnel destination x.x.x.x
    tunnel mode mpls traffic-eng
    tunnel mpls traffic-eng path-option 10 explicit name path-2300
    tunnel mpls traffic-eng record-route
    end

    Hi,
    Issue was figured out, the traffic was dropping dut to EF tagged traffic in the service policy applied under the physical interface.
    The limit of EF tagged traffic was defined less as per actual traffic which was causing drop in peak hours

  • Has anyone had issues with their itunes not coming up?

    Has anyone had issues with their itunes not coming up?  I keep getting error message 13014.  I just bought a new classic ipod and am not sure if this is the problem.

    Hi
    Your new iPod has certain operating system requirements. Does your iMac meet those requirements?
    http://www.apple.com/ipodclassic/specs.html
    3rd Column on the right hand side, about a 3rd of the way down. To find out which version of iTunes you have, launch it and select "About iTunes" from the iTunes menu.
    HTH?
    Tony

  • Finder windows not coming to front and other issues

    Hey Guys,
    I've been having some issues with finder not coming to the front when clicking on the Finder icon on the dock, like it used to.
    Also, if I have a finder window on the front, and I click to an application behind it, the application doesn't come back in front again.
    Anyone else having these issues, anyone know of a fix? Not sure if it's related, but in the force quit window, finder is shown twice?
    It's happening on both my macbook pro and my mac pro, both running mavericks.

    Do you have StuffIt Deluxe installed? If so, see this thread:
    http://discussions.apple.com/thread.jspa?messageID=4195602
    What is happening is that your Finder is crashing.
    Francine
    Francine
    Schwieder

  • CRIO DMA FIFO transfer Issue-Voltage not coming to correct channels

    Hi All,
    Using crio 9073 and NI 9205, I am transferring Data (Channel data type = FXP, Word length 37 bits, 16 bits and FIFO also same data type) from FPGA DMA (Requested No of elements configured in FPGA is 16383) To RT DMA (Requested number of elements in 32744)
    FPGA notes:
    Total channels =16 (Differential mode)
    Loop time of FPGA =20 ms (Per read 20 samples from each channel, so 320 samples per iteration)
    RT notes:
    SCTL=running at 10 ms where DMA transfer happening do that check remaining elements and then do DMA as well.
    Issue:
    When I run the code in above scenario, whatever different voltages given to 4 channels (loop backed 9263 to 9205, fpga interactive mode and only giving 4 channels voltages now just for testing) and i do DMA in RT side, decimate the 320 data and i found Channel 0 voltage given in FPGA is not coming in 0 index of the decimated array in RT DMA read data, instead Channel 0 voltage is coming in Index 7 of the RT DMA read data.  Channel 1 coming at index 8...vice versa… Seems, some data shifting happening.
    But in FPGA i could see correct differential voltage coming to correct channels (Ch 0 is 1.4 V ,FPGA indicator shows me correct voltage at index 0 a 1.4 and vice versa)..
    Please suggest me why this is happening and what is best way i can get correct channel voltage data in RT based on my above conditions.

    This is how I do where I need to only measure continuos analog values through FIFO. I don't use calibrated analog channel. I use raw analog channel and do calibration in host VI. I have attached screenshot of my code. I put 123456789 check sequence in build array function in FPGA VI.
    If I want to read 2000 samples then I keep FIFO 4000 at host side.
    I keep sample count in multiple of no. of channel. In my code build array has 3 element so I read 3*X. where X number of sample required per channel.
    If you don't understand from code let me know.
    PBP (CLAD)
    Labview 6.1 - 2014
    KUDOS ARE WELCOMED.
    If your problem get solved then mark as solution.
    Attachments:
    FPGA VI.jpg ‏205 KB
    FPGA 2.png ‏92 KB
    Host VI.jpg ‏168 KB

  • My c700 laptop power light is not coming on. what can i do to resolve this issue?

    My c700 laptop power light is not coming on. what can i do to resolve this issue?

    Will it read audio CDs? (In other words, is it just a problem with DVDs, or are CDs not read, either?)

  • Updated my iPhone to new iOS6 and my Memory Loader app does not work!  Is there a fix for the problem as it seems I am not the only one coming across this issue?

    Updated my iPhone to new iOS6 and my Memory Loader app does not work!  Is there a fix for the problem as it seems I am not the only one coming across this issue?

    Other than what you have already done, you should clear the cache from your browser and, if you use it, your Facebook app.  Also, deleting old texts can free up some room.

  • Mapping Condition issue, Value not coming in multiple segments.

    Hi All,
    File to Idoc scenario.
    My file looks like below.
    HD 89650 28/01/11 "Presciber tan"
    AF "disc-rsn"
    RK "007287001" A
    KE disc-code "007287"
    KE addr-num "001"
    DF w-phone "03 98483299"
    AF "drs"
    RK "007287" A
    KE dr-num "007287"
    DF affil "OPSM"
    DF country "0"
    AF "disc-rsn"
    RK "dr-addraddress-1 17287|1EN" A
    KE disc-code "008287"
    KE field-name "address-1"
    KE element " 1"
    T         16
    Condition:
    I have a condition where I need to create an Idoc segment Z1disc when row - "AF "disc-rsn"" exists.
    For the filed "Z1disc-CODE", I need to pass the value when row "KE disc-code" exists,
    Result:
    From my file, AF "disc-rsn" exists twice, so I created 2 Z1disc segments.
    Coming to the field "Z1disc-CODE", the value "KE disc-code" exists twice in the file. After mapping, the value is coming only once in the first segment. The field "CODE" is not coming in the second segment like below.
    Idoc
    -- Zdisc
    --- Lang -- E    
    --- Code --  "007287"
    ---Zdisc
    Lang -- E
    When the check the display queue, it is showing like below
    SUPPRESS
    007287
    007287 -- (Context)
    008287
    008287-- (Context)
    It showing correctly from display queue, but the value are not populating except in first segement.
    For your information, After content conversion, my source xml will look like below.
    <?xml version="1.0" encoding="utf-8" ?>
    - <ns:MT_Optum xmlns:ns="http://luxottica.com/SAP_CRM/DirectSales/OptomDiscount">
    - <RecordSet>
      <Row>HD 89650 28/01/11 "Presciber tan"</Row>
      </RecordSet>
    - <RecordSet>
      <Row>AF "disc-rsn"</Row>
      </RecordSet>
    - <RecordSet>
      <Row>RK "007287001" A</Row>
      </RecordSet>
    - <RecordSet>
      <Row>KE disc-code "007287"</Row>
    Kindly help me, I'm trying all the options and it is not working.
    Is there anything I need to change in Source structure?
    Thanks
    Deepthi.

    Hi Aravind,
    Here is my Source message.
      <?xml version="1.0" encoding="UTF-8" ?>
    - <MT_XIOptum>
    - <Header>
      <HRow>HD 89650 28/01/11 "Presciber tan"</HRow>
      </Header>
    - <Detail>
      <Row>AF "disc-rsn"</Row>
      <Row>RK "007287001" A</Row>
      <Row>KE disc-code "007287"</Row>
      <Row>KE addr-num "001"</Row>
      <Row>DF fax-num ""</Row>
      <Row>DF in-out "I"</Row>
      <Row>DF phone-2 ""</Row>
      <Row>DF post-code "3108"</Row>
      <Row>DF provider-num "4349201J"</Row>
      <Row>DF rec-stat "A"</Row>
      <Row>DF w-phone "03 98483299"</Row>
      <Row>AF "drs"</Row>
      <Row>RK "007287" A</Row>
      <Row>KE dr-num "007287"</Row>
      <Row>DF affil "OPSM"</Row>
      <Row>DF country "0"</Row>
      <Row>DF descript "KK"</Row>
      <Row>DF rec-stat "A"</Row>
      <Row>AF "disc-rsn"</Row>
      <Row>RK "dr-addraddress-1 17287|1EN" A</Row>
      <Row>KE disc-code "008287"</Row>
      <Row>KE field-name "address-1"</Row>
      <Row>KE element " 1"</Row>
      </Detail>
    - <Trailer>
      <TRow>T 25</TRow>
      </Trailer>
      </MT_XIOptum>
    Row> -> [removeContext] ->[ equalsS "disc-rsn" ] -> [createIf] -> <Zdisc>
    This Part is working.
    <Row>> startWith2>IF
    KE disc-code-->THEN > removeContexts>SplitbyValue>SUBSTRING>Code.
    When I check the display queue at Code. I'm getting the below values.
    SUPPRESS
    007287
    007287 -- Context change
    008287
    008287-- Context Change
    Only 007287 is displaying in FIrst segment "Z1Disc" and second value "008287" not coming in second segment "Z1Disc".
    Anything is wrong?

  • Workflow Issue- Value not coming in BUS2032

    Hi
    I am creating a Workflow for Sales order. In USer Exit , i am calling FM "SAP_WAPI_CREATE_EVENT" to trigger the custom workflow with event TRIGGER created in BO ZBUS2032 which is delegated to BUS2032.
    In Workflow Trigerring Event , I am binding._EVT_OBJECT with BO- BUS2032 and created BUS2032 a workflow container.
    When i am triggering the workflow , Workflow is getting trigerred, But nothing is getting passed to BUS2032 due to which Workflow is not coming in Workflow Overview of Sales Order but workflow gets trigerred via SWIA and if i check workflow container values at runtime - BUS2032 is blank.
    Can you please advise.

    Hi Silky,
    Did you debug and see.Check this documentation on this from sap-img.Check this and post.
    http://help.sap.com/saphelp_40b/helpdata/fr/fb/135de9457311d189440000e829fbbd/content.htm
    Regards,
    Madhu.

  • MPLS TE tunnel autoroute announce metric in SPF computation

    Hi, I have a doubt whether MPLS TE tunnel metric is taking into SPF computation when the tunnel has "autoroute announce" configured.
    From the book "MPLS traffice enginnering" written by Osbourn, IGP SPF computation is always performed before tunnel metric is modified, I found this is only true if IGP is ISIS, but if IGP is OSPF, tunnel metric specified by "autoroute metric" will always be taken into SPF computation, a.k.a, if tunnel metric is configured to be less than underlying IGP metric, a suboptimal routing will always happen to destination routers that are in between tunnel head and tunnel tail.
    Any idea why there is a inconsistent behavior between OSPF and ISIS SPF computation? or I missed anything?

    Hi,
    You're right. There is a different behavior between OSPF and ISIS on how they handle the autoroute metric feature.
    ISIS: TE tunnel metric is not taken into account during SPF computation.
    OSPF: TE tunnel metric is taken into account during SPF computation.
    So playing with this feature can change the SPT if your IGP is OSPF.
    The difference seems coming from the SPF implementation of OSPF and ISIS
    HTH
    Laurent.

  • HT5429 direction is not coming in IOS 6 in india. can someone help me for the same?

    direction is not coming in IOS 6 in india. can someone help me for the same? i'm using iphone 4

    Hi Civilclerk1,
    In order to achieve your requirement, we can try to use the following expression to instead the last_name column and first_name field:
    last_name: =iif(Fields! staff_role.Value="Lead Atty" or Fields! staff_role.Value="BK Mgr" or Fields! staff_role.Value="Partner" ,Fields! last_name.Value,nothing)
    first_name: =iif(Fields! staff_role.Value="Lead Atty" or Fields! staff_role.Value="BK Mgr" or Fields! staff_role.Value="Partner" ,Fields! first_name.Value,nothing)
    Besides, if we don’t want see the blank row in the tablix, we can add a filter as below in the tablix:
    Expression:=iif(Fields! staff_role.Value="Lead Atty" or Fields! staff_role.Value="BK Mgr" or Fields! staff_role.Value="Partner" ,1,0)
    Operator:=
    Value:=1
    If there are any misunderstanding, please elaborate the issue for further investigation.
    Thanks,
    Katherine Xiong
    Katherine Xiong
    TechNet Community Support

  • In portal after clicking the search field of table UI popup  is not coming

    Hi Experts,
    I have a problem in portal . In "RecordWorkingTime" when I select any search field of this table Ui  it is refreshing for unlimited time  period and the pop up window is not coming .
    Can you suggest me any possible solution for this strange problem ?
    Regards,
    Sumana
    Edited by: sumana05 on Mar 9, 2012 10:58 AM

    Hi
    In addition to this, we also put the trace on the application. During the trace analysis we found that the RFC: HRXSS_CAT_WD_F4_SELFLD_DEFAULT doesn't seem to get called.
    Not sure what could be the issue.

  • ESI not coming for some employees

    Hi,
    For some Employees ESIC is not Deducting, though i have maintained Infotype 0588, but for some employees its coming...and in RT table Employer ESIC Contribution is coming, but in payslip Employees ESIC is not coming...please help me in this issue...
    Thanks & Regards
    Ragini NIkam
    SAP-HR Consultant

    Hi,
    Please confirm the followings:
    a) Are you able to see /3E1 & /3E1 for those cases in RT?
    Ans: In RT Table only i am able to see /3er and not /3e1
    b) Value of /112
    Ans: /112 is coming Rs. 7988.50 thats my gross amount
    c) Validity of IT0588 (ESI)Please confirm the followings:
    Ans: Validity is 01.04.2011 to 31.12.9999,
    But sir how its coming for some employees and and for some its not.
    Thanks & Regards
    RAGINI Nikam
    SAP-HR Consultant

  • Few line items are not coming at the time of creation of delivery

    Dear Experts,
    When the user creating the delivery few line items are not picking in the delivery document
    the following checks i verified,
    Stock is available
    shpping condition is differ from sold to party and sales document
    Plants are same for all the line items
    why the few line items are not coming in the delivery document creation,
    please help me to sort out this issue
    Thanks and Best Regards,
    Muralidharan S

    Hi,
    Check below points.
    Point 1:
    When you create a delivery document, you create it for a Shipping Point.
    So whatever the line that came in to one delivery has determined same shipping point that you entered in VL01N screen.
    Others got a different shipping point and that's why it didn't come to the same delivery document.
    Shipping point determined based on below criteria
    - Shipping Condition - From customer master
    - Loading Group - Material
    - Plant  - Delivery Plant of the sales order line item
    You assign a proffered shipping point for above combination in configuration.
    If that combination is not find, those line items are not going in to the delivery.
    You can check the log of the delivery document for more information as well.
    Point 2:
    Check the line item Requested delivery date and the "Selection Date" you entered in the VL01N screen.
    Al  Requested delivery dates has to be on or before the  "Selection Date" you entered in the VL01N screen.
    Those line items which has a date more than that will dropped in the delivery.
    Best regards,
    Anupa

Maybe you are looking for