Multiple NetStreams - IE 6/7 Issue

Hello folks,
I need help with a NetStream/IE specific issue (possibly bug
in IE or IE FlashPlayer 9).
Problem Background:
- I made flash flv player for client to play multiple FLV
pseudo-streams (php-streamed) and keep them synchronized
- I have 2 NetStream objects for two separate streams
- Each stream can be changed via a list component to a
different FLV while it's playing - it pauses, starts loading the
new stream, then keeps playing the 2 streams, in sync
- The "player" resides on one domain, and the videos on another
(simply due to more storage space available on the other domain)
The "Blockage" Problem:
- Works great in FF on OS X 10.4, Win2K, WinXP and WinVISTA
- Works the first time in Win2K IE (Internet Explorer) 6, and
WinXP IE7 - but when you close the tab or window, without closing
the browser entirely (have another tab or window open - such as the
one with the link to the flv player), then try opening the same URL
again, or a similar one, IE browser will not load the FLV file
"stream" anymore - again it works fine the first time around. This
problem is so severe that the entire domain that the video was
being loaded from in the first place can no longer be visited by
the browser; i.e. if the domain the video was being loaded from was
http://domain.com" - IE can no longer
visit it (any page on it anywhere...) but it can visit "
http://www.domain.com". To clear
up the browser "blockage," I have to close the browser completely,
then re-launch it.
What I've Tried:
- In places where I'd call "netStrmObj.close()" - I tried
adding "myVideo.attachVideo(null);myVideo.attachAudio(null);" -
this just makes the player really freak out for a while before
changing to a new video, which still happens, but the doesn't do
anything for the problem
- I tried not using "netStrmObj.close()" at all... no
noticeable difference
- I added "_root.onUnload = function()
{myVideo.attachVideo(null);myVideo.attachAudio(null);}" instead.
This definitely made a difference. On Win2K the player worked on
repeated calls for a while, but the response was terribly slow -
take almost a minute to respond at times (where normal response
time would be 2-3sec), then the same problem would occur. Sometimes
the same problem would occur right away, like it did at first. On
WinXP it worked like a charm, even on repeated calls (closing
tabs/windows in between each call); then I interrupted my testing,
which had been going so nicely, and had a short dinner for about
15-20 minutes, then resumed testing - the browser "blockage" had
returned (I don't know if the delay was just fluke or not - but the
problem is obviously still there...)
Is there any *NetStream*/Flash/IE wizard out there who has any
ideas about this? I will be gone for a few days before I can
check this posting - but I need results by Wed/Thurs next week, so
any help before then would be greatly appreciated.
Thanks for your time!

John Waller wrote:
Right, ok. Are many using this at the moment?
The progressive HTML5-ers are using shiv files or some description.
Is it completely without any issues if we move from html 4 to 5 now then?
I'm sure shiv files have their limitations but most reports/blog I see online are reporting good results (or they're not howling loudly about bad results).
Only one issue for me then DWCS4. Don't think its worth the upgrade to DW5.5 at the moment needed to be able to see html 5 in design view. Probably wait for DW6 and get up to speed with html5 in the meantime as I don't fully know the new tags yet

Similar Messages

  • Multiple NetStreams

    Hi, I'm building a video player which loads .flvs into a
    movie clip from a menu and places the movie clip on the stage using
    getNextHighestDepth. Everything works great except the client would
    like the viewer to be able to leave clip A, view clip B and return
    to the last viewed point in the A clip's timeline. Is this possible
    without getting into a serverside streaming application? Would I
    need to create multiple movieclips with embedded video objects, and
    start swapping depths on the stage? Or can it be done with multiple
    netStream objects? Thanks for any guidance.

    I'm working on a chat app that shows up to 10 live cams at a
    time in one swf. When a user joins the room the publish through a
    separate connection, but all of the subscribes are through one
    connection - I thought it would help to minimize connections to the
    server to stream through one connection.
    Is it recommended to separate these out into individual
    connections?

  • Issues pre-buffering multiple NetStreams

    Hi,
    I am running into some streaming bugs and am wondering if anyone else has come across them. Very grateful in advance for any help as I've been banging my head against this for a week now.
    First of all, I'm finding that no matter what value I set for a NetStream's bufferTime property, the NetStream will not begin actually playing until the bufferLength property is over 2 seconds. This is not what Flash documentation says (that the default value of bufferLength is .1 seconds). Could this issue a function of the FMS configuration with my RTMP hosting account? Is it something I can resolve with my asc file?
    Also: In my Actionscript 3 app, I need to pre-buffer a number of video streams so that any one of them can be triggered immediately later in the program. I do this by building an array of NetStreams (within a single NetConnection), then playing each of the streams I need to pre-buffer and immediately pausing each too. This is successfully causing them to buffer in the background, so that they're ready for immediate play when I need them. When I do this with just one NetStream, it works fine. But with more, the streams are behaving unpredictably. They are successfully buffering, but when I need to actually play them and I go to unpause them (Netstream.resume), the NetStreams are generally NOT playing back correctly. Their behavior is not consistent, and they mostly play with no video, or no audio OR video. The one exception is the FIRST NetStream that I started pre-buffering, which is the only one that's consistently playing back fine with its audio and video. Again, if I unpause any of the other NetStreams, they play back with just audio, or not at all. Do you have any idea why this could be happening? I have the app working perfectly with local files, so I know it has to do with the streaming piece.
    Thanks so much!

    Hello,
    I can help you with your first problem. In your Aplication.xml there are some lines like this:
             <Live>
                    <!-- Drop live audio if audio q exceeds time specified. time in milliseconds -->
                    <MaxAudioLatency>2000</MaxAudioLatency>
                    <!-- Default buffer length in millisecond for live audio and video queue. -->
                    <MinBufferTime>2000</MinBufferTime>
                </Live>
                <Recorded>
                    <!-- Default buffer length in millisecond for live audio and video, value cannot be set below this by Flash player. -->                                                  <MinBufferTime>2000</MinBufferTime>
                </Recorded>
    This lines configure the min buffer timer, put a lower value on them (use the one on the live tag to live stream and recorded tag to recorded stream).
    I holpe it could help you
    Mairum

  • ME01 LSMW multiple record for same material issue.

    Hi Experts,
    I have an issue with multiple record for the same material and plant when I upload the data from the file.  Lets I have the records.
    Material        Plant              Start date      Enddate        Vendor          Porg.
    1     0010     20060101     99991231     2     0010
    1     0010     20060101     99991231     3     0010
    When I upload the above data there are 2 IDOCs created when I am using the method LSMW-IDOC method, but only last record is getting updated and the first one is not getting updated in ME01 souce list. But I am getting the success message for both IDOC in LSMW. So I am not sure how to fix this why only last record is updated and not other records??

    why do you have 2 idocs?
    wouldn't be 1 idoc with 2 items be more logical?
    1 record in structure E1EORDH
    and 2 records in structure E1EORDM
    I believe your 2 IDOCs get posted, but I think your 2nd Idoc overwrites the values entered from the first IDOC.

  • NetStream Video Control button issue

    The stop button plays as expected.  The play/pause button plays as expected.  The issue is when you press pause which will cause the play button to appear, then press stop.  the video automatically plays and it shouldn't. I have bolded the control button script for convenience.
    var nc:NetConnection = new NetConnection();
    nc.connect(null);
    var ns:NetStream = new NetStream(nc);
    theVideo.attachVideo(ns);
    ns.play("LOB2_0644_new.flv");
    stop_mc.onRelease = function(){
    playpause_mc.gotoAndStop("playing");
    ns.seek(0);
    ns.pause();
    playpause_mc.onRelease = function(){
    ns.pause();
      if (this._currentframe == 1)
            this.gotoAndStop("playing");
            movie_mc.play();
        else
            this.gotoAndStop("paused");
            movie_mc.stop();
        } // end else if
    } // End of the function
    var videoInterval = setInterval(videoStatus,100);
    var amountLoaded:Number;
    var duration:Number;
    ns["onMetaData"] = function(obj){
    duration = obj.duration;
    function videoStatus(){
    amountLoaded = ns.bytesLoaded / ns.bytesTotal;
    loader.loadbar._width = amountLoaded * 424;
    loader.scrub._x = ns.time / duration * 424;
    var scrubInterval;
    loader.scrub.onPress = function(){
    clearInterval(videoInterval);
    scrubInterval = setInterval(scrubit,10);
    this.startDrag(false,0,this._y,424,this._y);
    loader.scrub.onRelease = loader.scrub.onReleaseOutside = function(){
    clearInterval(scrubInterval);
    videoInterval = setInterval(videoStatus,100);
    this.stopDrag();
    function scrubit(){
    ns.seek(Math.floor((loader.scrub._x/424)*duration));
    _root.createEmptyMovieClip("vSound",_root.getNextHighestDepth());
    vSound.attachAudio(ns);
    var so:Sound = new Sound(vSound);
    so.setVolume(100);

    before executing gotoAndStop("playing") check if playpause_mc is already on the "playing" frame.   if it is, do nothing.  if it's not, execute your gotoAndStop().
    also, you probably want:
       else
    ns.play();
            this.gotoAndStop("paused");
            movie_mc.stop();
        } // end else if

  • Installing Multiple Custom Resource Providers - Overwriting Issue

    Hi everyone!
    I am working in a POC environment for WAP.
    My current situation is the following:
    I am experiencing what seems to be an overwriting issue since the extension of the custom resource provider installed last always appears while the extensions of previously installed custom resource providers disappear from the WAP management portals. 
    How would I go about installing two different custom resource providers in WAP so that their extensions may co-exist in the left navigation pane in the management portals? Although I know I can just declare multiple extensions within the same resource provider
    to achieve a similar result, I would still like to know how to correctly present multiple co-existing extensions using two different custom resource providers in WAP.
    Thank you!

    If you are getting this only first time, you should look at all the global registrations done (like navigation view model etc.) to see if you are somehow ending calling this up twice and the dataset accumulate it. When you navigate to some other page and
    comes back, the data fetch is happening again and it replaces the old duplicated dataset some how. With everything happening async, it is a bit tricky to debug this. Try to match the code with the provided samples and see if you can find something different.
    One time I have seen this issue consistently happening for tenant. It was happening when I had two subscription on that tenant for the same RP, and the RP code was not filtering results based on subscription. So the same information was returned twice.

  • Can one connect multiple NetStreams to the same peerID?

    Does it make sense to have two separate netstreams connected to the same remote p2p connection?
    I think I would like to separate the audio and video publishing and playing so that I can fine tune permissions (e.g. publish audio but not video to some users but not others).
    Equally, are there issues with publishing two separate NetStreams on the same p2p connection?
    Initially I thought this would be possible, but I am having problems playing streams when connecting users on different ip addresses.

    You can play or publish as many streams as you wish on the same connection. Just mind the bandwidth.
    However, publishing audio and video on different streams may not be a good idea as they're sure to be out of sync.
    To save bandwidth and play only the audio of an audio/video stream set NetStream's receiveVideo to false.
    Or, in your fine-tuned permissions scenario, you can publish one stream with audio only and one with audio/video. A little redundant but audio datarate is small and may be worth it.

  • BlazeDS, multiple Module instances with Consumers issue

    I have an application that can load multiple instances of a module. The module has a consumer that connects to a destination and listens for messages pushed from a JMS topic. In order for me to be able to load and unload multiple instances of the module I'm appending a uid to the url of the swf. When the first instance of the module is loaded everything works as expected and the consumer successfully subscribes to the destination. However, if a second instance of the module is loaded the consumer fails to subscribe and I see the following error in the server log:
    [#|2010-10-28T15:05:33.666+0100|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ ThreadID=17;_ThreadName=httpSSLWorkerThread-8080-1;|
    [BlazeDS]10/28/2010 [INFO] [Endpoint.General] Channel endpoint channel-streaming-amf received request.|#]
    [#|2010-10-28T15:05:33.671+0100|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ ThreadID=17;_ThreadName=httpSSLWorkerThread-8080-1-in-streaming-mode;|
    [BlazeDS]10/28/2010 [WARN] [Endpoint.StreamingAMF] Endpoint with id 'channel-streaming-amf' received a duplicate streaming connection request from, FlexClient with id '4CA3967A-071C-AB24-D5B9-CAB9D20F14B5'. Faulting request.|#]
    [#|2010-10-28T15:05:33.671+0100|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ ThreadID=17;_ThreadName=httpSSLWorkerThread-8080-1;|
    [BlazeDS]10/28/2010 [INFO] [Endpoint.FlexSession] Number of streaming clients for FlexSession with id '3275dcec0f5dc0c30a7381fa6044' is 0.|#]
    [#|2010-10-28T15:05:33.672+0100|INFO|sun-appserver2.1|javax.enterprise.system.stream.out|_ ThreadID=17;_ThreadName=httpSSLWorkerThread-8080-1;|
    [BlazeDS]10/28/2010 [DEBUG] [Endpoint.StreamingAMF] Number of streaming clients for endpoint with id 'channel-streaming-amf' is 0.|#]
    [#|2010-10-28T15:05:33.673+0100|SEVERE|sun-appserver2.1|javax.enterprise.system.container. web|_ThreadID=17;_ThreadName=httpSSLWorkerThread-8080-1;_RequestID=96f36b13-0da4-49ad-b788 -bc6d1413da3b;|StandardWrapperValve[MessageBrokerServlet]: PWC1406: Servlet.service() for servlet MessageBrokerServlet threw exception
    java.lang.IllegalStateException
    at org.apache.coyote.tomcat5.CoyoteResponseFacade.sendError(CoyoteResponseFacade.java:449)
    at flex.messaging.endpoints.BaseStreamingHTTPEndpoint.handleFlexClientStreamingOpenRequest(B aseStreamingHTTPEndpoint.java:732)
    at flex.messaging.endpoints.BaseStreamingHTTPEndpoint.serviceStreamingRequest(BaseStreamingH TTPEndpoint.java:1022)
    at flex.messaging.endpoints.BaseStreamingHTTPEndpoint.service(BaseStreamingHTTPEndpoint.java :430)
    at flex.messaging.MessageBrokerServlet.service(MessageBrokerServlet.java:322)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
    at org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.jav a:427)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.j ava:333)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
    at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncoding Filter.java:88)
    at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76 )
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.j ava:246)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:313)
    at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:28 7)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218)
    at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
    at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
    at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
    at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPi peline.java:98)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
    at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
    at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
    at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
    at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
    at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
    at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
    at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
    at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
    at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:291)
    at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProces sorTask.java:666)
    at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorT ask.java:597)
    at com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTas k.java:872)
    at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultRead Task.java:341)
    at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
    at com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
    at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:264)
    at com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106 )
    |#]
    Can anyone explain to me what is happening here and suggest a solution please? I'm not sure if it's a BlazeDS issue or a Flex Module issue but I can't seem to find any references to this issue and the last 2 days have been spent trying to resolve this without any success.
    Any help appreciated.
    If I don't append the uid to the module url then the consumers subscribe as expected but then I'm unable to unload individual instances of the module as they all share the same url property.
    Thanks in advance.

    I have similar problem, but I don't understand your solution.
    Hypothetically, let’s say I use 2 separate sets of Consumer/Producer components in my flex app.
    There is no problem with connecting first set of Consumer/Producer to a particular channel.
    For second set of Consumer/Producer I create new ChannelSet  and new StreamingAMFChannel instances (but the channel has the same URL as the one used in first set, because I want to use the same channel).
    When I try to connect another set of Consumer/Producer to the same channel I get the error on BlazeDS: "... Endpoint with id 'streaming-amf' received a duplicate streaming connection request from, FlexClient with id ..."
    There is no such problem when I define additional channel in BlazeDS configuration an use this new channel with second set of Consumer/Producer components. This solution requires this additional channel so it’s not fully satisfying for me.
    Could you post some code samples of your solution or describe it in more detail?
    I will be grateful for any useful tips.

  • Primary Key Multiple Column with Date - parameter issue

    All,
    I am having an issue that I cannot find the answer to. I have looked high and low to no avail. Please help.
    The issue at hand is that I have a table that has a multiple column primary key and one of the columns happens to be a date and the other is a string. I have a basic search and I want an update picture in the results table that the users can click on and go to a different page to update that record. The issue is when I fire an action based on the update picture I also want to set parameters based on the record that I selected. So I set the string parameter and that works fine. The issue is with the date. When i set the date parameter it works but it chops off the timestamp. Later when I try to get this parameter 'pageContext.getParameter("dateParameter");' it will bring in a date like 15-Dec-2008 but I need the entire date and timestamp (i.e. 15-Dec-2008 10:20:33) to correctly identify the record.
    Please help!
    Thanks,
    Colby J

    Hi
    since every parameter go in url as a string format so u will never get the date parameter with complete timestamp,the solution would de
    1.) Set a fire action on update picture,give its event name as "update",
    2.) clicking on update picture will fire this event .
    3.) in processFormrequest method of controller
    OAApplicationModule am = pageContext.getApplicationModule(webBean);
    if ("update".equals(pageContext.getParameter("event")))
    // this will give the select row where update is clicked
    String rowReference = pageContext.getParameter(OAWebBeanConstants.EVENT_SOURCE_ROW_REFERENCE);
    VORowImpl row = (EmployeeSummaryVORowImpl)am.findRowByRef(rowReference);
    Timestamp sdateVal=(String)row.getAttribute("Date value");
    // this will transfer the values to next page
    pageContext.putTransactionTransientValue("transferdvalue",sdateVal);
    // and in the next page u can get the value like this
    timestamp getDateVal=pageContext.getTransactionTransientValue("transferdvalue"l);
    hope this will resolve your issue,Please let me know if u face any issue
    thanx
    Pratap

  • ZEN VISION:M Multiple Artist Directories/Album Art Issues/e

    I recently bought a Zen Vision:M (got talked out of the IPod) and for the most part I'm very happy with it. However these two small issues are so irritating that they make me want to get rid of it.
    Firstly a few artists on my player have multiple directories/folders. Some have two, some have as many as fi've. I am extremely particular about my music so I know that they are properly tagged and the artist name matches exactly. It only does this with when I add media with the zen media explorer, however if I use any other program to add files, such as windows media (don't tell anyone that I used that terrible excuse for a media player!) or MusicMatch (my preferred choice), my album art won't display. I find this interesting, and extremely irritating, considering I used MusicMatch to tag the art to the files). I can only get the art to display using the zen media explorer.
    Also is there a way to have the zen organize tracks by name and not into album directories? I refuse to believe that I am the only one who listens to my music by track title as opposed to album title, otherwise I'd just pop the cd in!!! And what is the deal with playing one track plays the whole album? I have to add track to playlist just so it doesn't throw all the songs in there.

    Windows Media Player does not write the album art to the ID3 tag of the mp3 file. It keeps the image file separated from the mp3 and makes a link to it.
    You need something that can write the image file to the mp3 file itself. Zen Explorer can do this.
    As for the multiple artist names showing up. I've never seen that before, and I feel like I need more details. Do the Artist names show up under the Artist Catagory view or the Album catagory view? And I misundertood if you were trying to say this only happens when you transfer music using the Zen Explorer and not Media Playper or MusicMatch since you changed subjects midway through the sentence.
    But in a general sense, this would happen if you are spelling the two directories differently. Like for example Tom Jones, Tom Jone, or ( )Tom Jones. the ( ) means theres a space in front of the T. Those would all show up under different album names.Message Edited by TimT on 07-0-2006 2:04 PM

  • CP-8941 Multiple Call/Call Waiting Settings issue

    Hi,
    i want to change the cisco ip phone 8941 busytrigger to 1 but in all my phones its grayed.
    i upgraded the firmware to SIP 9-2-3-5. and restarted the call manager servers, but still i am not able to change it.
    i am using CUCM 8.6.2.
    is there a way to do this...
    my actual problem is  if
    user1-------calls-----------user2(both phones gets busy)
    user3-------calls----------user2(user3 must listen busy tone, and user2 should be notified of a call from user3).
    but in my case user3 is not getting busy tone instead he is getting ringback and thinks user2 is ignoring the call of user3.
    so can i solve this issue in any other way...

    Hi Mohammed,
    You need to install cmterm-894x-qed.9-2-2-0.cop.sgn from the following link on all the servers and restart the TFTP service and then reset the 8941 IP phones
    http://software.cisco.com/download/release.html?mdfid=283095470&flowid=46243&softwareid=282074289&release=9.4%281%29&relind=AVAILABLE&rellifecycle=&reltype=latest
    Release notes for this cmterm-894x-qed.9-2-2-0.cop.sgn
    http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cuipph/8941_8945/firmware/9_2_2/english/release/notes/8941_8945_922.html
    Multiple Calls Per Line
    The Cisco Unified IP Phones 8941 and 8945 now support Multiple Calls Per Line.
    Each line can support multiple calls. By default, the Cisco Unified IP  Phones 8941 and 8945 support four active calls per line, and a maximum  of 24 active calls per line. Only one call can be connected at any time;  other calls are automatically placed on hold.
    The system allows you to configure the maximum calls/busy trigger to not  more than 24/24 both for SCCP and SIP. The default call/busy trigger  value is 4/2.
    This feature is supported on both SIP and SCCP phones, with Unified CM 7.1(5) and later.
    HTH
    Manish

  • ASA 5510 Multiple Public IP - Static NAT Issue - Dynamic PAT - SMTP

    Running into a little bit of a roadblock and hoping someone can help me figure out what the issue is.  My guess right now is that it has something to do with dynamic PAT.
    Essentially, I have a block of 5 static public IP's.  I have 1 assigned to the interface and am using another for email/webmail.  I have no problems accessing the internet, receving emails, etc...  The issue is that the static NAT public IP for email is using the outside IP instead of the one assigned through the static NAT.  I would really appreciate if anyone could help shed some light as to why this is happening for me.  I always thought a static nat should take precidence in the order of things.
    Recap:
    IP 1 -- 10.10.10.78 is assigned to outside interface.  Dynamic PAT for all network objects to use this address when going out.
    IP 2 -- 10.10.10.74 is assgned through static nat to email server.  Email server should respond to and send out using this IP address.
    Email server gets traffic from 10.10.10.74 like it is supposed to, but when sending out shows as 10.10.10.78 instead of 10.10.10.74.
    Thanks in advance for anyone that reads this and can lend a hand.
    - Justin
    Here is my running config (some items like IP's, domain names, etc... modified to hide actual values; ignore VPN stuff -- still work in progress):
    ASA Version 8.4(3)
    hostname MYHOSTNAME
    domain-name MYDOMAIN.COM
    enable password msTsgJ6BvY68//T7 encrypted
    passwd msTsgJ6BvY68//T7 encrypted
    names
    interface Ethernet0/0
    speed 100
    duplex full
    nameif outside
    security-level 0
    ip address 10.10.10.78 255.255.255.248
    interface Ethernet0/1
    nameif inside
    security-level 100
    ip address 192.168.2.2 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    boot system disk0:/asa843-k8.bin
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    dns server-group DefaultDNS
    domain-name MYDOMAIN.COM
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network inside-network
    subnet 192.168.2.0 255.255.255.0
    object network Email
    host 192.168.2.7
    object network Webmail
    host 192.168.2.16
    object network WebmailSecure
    host 192.168.2.16
    access-list inside_access_out extended permit ip any any
    access-list inside_access_out extended permit icmp any any
    access-list VPN_Split_Tunnel_List remark The corporate network behind the ASA (inside)
    access-list VPN_Split_Tunnel_List standard permit 192.168.2.0 255.255.255.0
    access-list outside_access_in extended deny icmp any any
    access-list outside_access_in extended permit tcp any object Email eq smtp
    access-list outside_access_in extended permit tcp any object Webmail eq www
    access-list outside_access_in extended permit tcp any object WebmailSecure eq https
    pager lines 24
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-647.bin
    asdm history enable
    arp timeout 14400
    nat (inside,outside) source static inside-network inside-network destination static inside-network inside-network no-proxy-arp route-lookup
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Email
    nat (inside,outside) static 10.10.10.74 service tcp smtp smtp
    object network Webmail
    nat (inside,outside) static 10.10.10.74 service tcp www www
    object network WebmailSecure
    nat (inside,outside) static 10.10.10.74 service tcp https https
    access-group outside_access_in in interface outside
    access-group inside_access_out out interface inside
    route outside 0.0.0.0 0.0.0.0 10.10.10.73 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server MYDOMAIN protocol kerberos
    aaa-server MYDOMAIN (inside) host 192.168.2.8
    kerberos-realm MYDOMAIN.COM
    aaa-server MYDOMAIN (inside) host 192.168.2.9
    kerberos-realm MYDOMAIN.COM
    aaa-server MY-LDAP protocol ldap
    aaa-server MY-LDAP (inside) host 192.168.2.8
    ldap-base-dn DC=MYDOMAIN,DC=com
    ldap-group-base-dn DC=MYDOMAIN,DC=com
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password *****
    ldap-login-dn CN=SOMEUSER,CN=Users,DC=MYDOMAIN,DC=com
    server-type microsoft
    aaa-server MY-LDAP (inside) host 192.168.2.9
    ldap-base-dn DC=MYDOMAIN,DC=com
    ldap-group-base-dn DC=MYDOMAIN,DC=com
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password *****
    ldap-login-dn CN=SOMEUSER,CN=Users,DC=MYDOMAIN,DC=com
    server-type microsoft
    user-identity default-domain LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 192.168.2.0 255.255.255.0 inside
    http redirect outside 80
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map inside_map interface inside
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    email [email protected]
    subject-name CN=MYHOSTNAME
    ip-address 10.10.10.78
    proxy-ldc-issuer
    crl configure
    crypto ca certificate chain ASDM_TrustPoint0
    certificate e633854f
        30820298 30820201 a0030201 020204e6 33854f30 0d06092a 864886f7 0d010105
        0500305e 31143012 06035504 03130b47 46472d53 55532d41 53413146 301a0609
        2a864886 f70d0109 08130d39 382e3130 302e3232 322e3738 30280609 2a864886
        f70d0109 02161b47 46472d53 55532d41 53412e47 46472d50 4541424f 44592e43
        4f4d301e 170d3132 30343131 30373431 33355a17 0d323230 34303930 37343133
        355a305e 31143012 06035504 03130b47 46472d53 55532d41 53413146 301a0609
        2a864886 f70d0109 08130d39 382e3130 302e3232 322e3738 30280609 2a864886
        f70d0109 02161b47 46472d53 55532d41 53412e47 46472d50 4541424f 44592e43
        4f4d3081 9f300d06 092a8648 86f70d01 01010500 03818d00 30818902 818100b4
        aa6e27de fbf8492b 74ba91aa e0fd8361 e0e85a31 f95c380d 6e5f43ac a695a810
        f50e893b 82b91870 a32f7e38 8f392607 7a69c814 36a71a9c 2dccca07 24fe7f88
        0f3451ed c64e85fc 8359c87e 62ebf166 0a570ac5 f9f1c64b 262eca66 ea05ab65
        78da1ac2 9867a115 b14a6ba1 cd82d04e 00fc6557 856f7c04 ab1b08a0 b9de8b02
        03010001 a3633061 300f0603 551d1301 01ff0405 30030101 ff300e06 03551d0f
        0101ff04 04030201 86301f06 03551d23 04183016 801430cf 97ef92bb 678e3ba3
        0002069c 8130550a 2664301d 0603551d 0e041604 1430cf97 ef92bb67 8e3ba300
        02069c81 30550a26 64300d06 092a8648 86f70d01 01050500 03818100 64c403bd
        d75717ab 24383e77 63e10ba7 4fdef625 73c5a952 19ceecbd 75bd23ca 86dc0298
        e6693a8a 2c7fb85f 096497a7 8d784ada a433ee0d d88e9219 f0615f3c 7814bf1c
        5b4fe847 7d8894eb 18fe2da7 05f15ae9 bc2c17ec 3a7831ee f95d6ced 4799fba2
        781c8228 48224843 dc07ebb5 d20abf2a b68cfa62 ac71a41b 1196a018
      quit
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable outside client-services port 443
    crypto ikev2 enable inside client-services port 443
    crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.2.0 255.255.255.0 inside
    telnet 192.168.1.0 255.255.255.0 management
    telnet timeout 20
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcpd enable management
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ntp server 192.168.2.8 source inside prefer
    ssl trust-point ASDM_TrustPoint0 inside
    ssl trust-point ASDM_TrustPoint0 outside
    webvpn
    enable outside
    enable inside
    anyconnect-essentials
    anyconnect image disk0:/anyconnect-win-3.0.5080-k9.pkg 1
    anyconnect profiles VPN_client_profile disk0:/VPN_client_profile.xml
    anyconnect enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol ikev1 l2tp-ipsec
    group-policy GroupPolicy_VPN internal
    group-policy GroupPolicy_VPN attributes
    wins-server value 192.168.2.8 192.168.2.9
    dns-server value 192.168.2.8 192.168.2.9
    vpn-filter value VPN_Split_Tunnel_List
    vpn-tunnel-protocol ikev2 ssl-client
    group-lock value VPN
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value VPN_Split_Tunnel_List
    default-domain value MYDOMAIN.COM
    webvpn
      anyconnect profiles value VPN_client_profile type user
    group-policy GroupPolicy-VPN-LAPTOP internal
    group-policy GroupPolicy-VPN-LAPTOP attributes
    wins-server value 192.168.2.8 192.168.2.9
    dns-server value 192.168.2.8 192.168.2.9
    vpn-filter value VPN_Split_Tunnel_List
    vpn-tunnel-protocol ikev2
    group-lock value VPN-LAPTOP
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value VPN_Split_Tunnel_List
    default-domain value MYDOMAIN.COM
    webvpn
      anyconnect profiles value VPN_client_profile type user
    tunnel-group VPN type remote-access
    tunnel-group VPN general-attributes
    authentication-server-group MYDOMAIN
    default-group-policy GroupPolicy_VPN
    dhcp-server 192.168.2.8
    dhcp-server 192.168.2.9
    dhcp-server 192.168.2.10
    tunnel-group VPN webvpn-attributes
    group-alias VPN enable
    tunnel-group VPN-LAPTOP type remote-access
    tunnel-group VPN-LAPTOP general-attributes
    authentication-server-group MY-LDAP
    default-group-policy GroupPolicy-VPN-LAPTOP
    dhcp-server 192.168.2.8
    dhcp-server 192.168.2.9
    dhcp-server 192.168.2.10
    tunnel-group VPN-LAPTOP webvpn-attributes
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    class class-default
      user-statistics accounting
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    hpm topN enable
    Cryptochecksum:951faceacf912d432fc228ecfcdffd3f

    Hi ,
    As per you config :
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Email
    nat (inside,outside) static 10.10.10.74 service tcp smtp smtp
    object network Webmail
    nat (inside,outside) static 10.10.10.74 service tcp www www
    object network WebmailSecure
    nat (inside,outside) static 10.10.10.74 service tcp https https
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network inside-network
    subnet 192.168.2.0 255.255.255.0
    object network Email
    host 192.168.2.7
    object network Webmail
    host 192.168.2.16
    object network WebmailSecure
    host 192.168.2.16
    The flows from email server ( 192.168.2.7 ) , will be NATed to 10.10.10.74, only if the source port is TCP/25. Any other souce port will use the interface IP for NAT.
      Are you saying that this is not happening ?
    Dan

  • Multiple email accounts on Mail issue

    Hi there, just wondering if anyone cn help with my Mail email issue. I have scoured the net but can't find anyone with the exact same or similar issue.
    For simplicitys sake, letes say I have 3 email accounts, [email protected], [email protected] and [email protected] I have set alpha to be the default account and this works fine, when I click new email the sender is by default [email protected] The problem arises when I want to send an email from the bravo or charlie accounts. I click on ne email and in the drop down "From" window I select the bravo account I want to send from, compose my email and click send. Away it goes but the recipient recieves and email from "bravo" but with the email address [email protected] and if he hits reply it will come back addressed to [email protected] Arghhhhhhhhhhh! I have tried everything but for the life of me can't see where the issue lies. Incidentally the same happens if I use the charlie account.
    I am using OSX 10.8.4 with Mail version 6.5 (1508)
    Any help/pointers would be appreciated, thanks in advance,
    Phil

    Assuming that these really are three gmail accounts, in Mail > Preferences > Accounts Click on the down arrow for SMTP server, select Edit SMTP Server list and be sure you have a separate SMTP listing and name for each of the three accounts together with a username and password for each occurance of SMTP.gmail.com. Then in account information for each account, be sure you have the correct SMTP server selected and "Use only this server" checked. 

  • Multiple Apple IDs causing activation issue

    Hello,
    I just got a new iPad for christmas and I'm setting it up now.  Turns out I have two apple IDs: the one I actually used (which I dumbly keyed to a spam email address years ago) and one associated with my real email address.  The one associated with my real email address has no content associated; that's not the problem.  But I'm trying to set up iMessage to speak to the email address I actually use and when I do i get an error message that reads as follows:
    iMessage Activation
    Unable to verify email because it is already in use.
    It won't let me go any further from there.  I successfully set up email, but this seems to work differently.  Any suggestions?
    Thanks,
    BearPuncher

    Each Apple ID must have a different associated email address - the easiest workaround is to get a free one from Yahoo, Gmail or Hotmail.
    You cannot transfer purchases between iTunes accounts so you don't want to start changing the login there: but the ID for iTunes doesn't have to be the same as the ID for iCloud if you are going to use that.
    As you don't have any points you have nothing to choose by changing your ID for these forums: change the associated email address to something else if that's the cause of the problem.
    The iTunes authorisation problem doesn't sound as if it's related to the multiple IDs - it woudn't know anything ahout the others - the best place to ask would be in the iTunes forum.

  • Multiple 160 GB iPod Classic issues

    Last August, I purchased a 160GB iPod Classic. For the first several months, it worked just fine. I hooked it up with the audio cable and it would play in my Hyundai Tucson. One day in the Spring, the volume stopped working in the vehicle. I tried other cables and reset the device several times. It started to work again. About a week later, nothing. It wouldn't even have sound when hooked up to headphones.
    I took it the Apple store and we tried it out in a vehicle of one of the associates, it worked. Took it home, down again. Had it replaced. Tried it all different wasy, bought a new audio cable for the car, headphones, etc. NOTHING. Had it replaced last Saturday for the second time. Used it everywhere but the car and it worked. Yesterday, I put headphones on and it crash. (Did not try in car yet).
    My questions are these: I have a 30GB Classic that has the same library on it. Could there be something wrong with the library? Corrupt? Could the vehicle need a certain something installed? My dealership knows nothing. I've searched online forums for the issue (thinking maybe it was the car). But this one didn't even go in the car and it crashed after a full charged and library sync.
    In case it matters, I have a MacBook Pro 13inch using the most updated iTunes and software.
    If anyone can help-Thank you!

    Also, I am using my older 30GB iPod classic and it works fine with all outlets, headphones, vehicle, etc.

Maybe you are looking for

  • My yahoo and work emails are going into same folder - how do i stop

    i just set up my enterprise email and my yahoo was going into the main "folder" on my bb prior to setting up my work/enterprise email. i still have the yahoo icon/folder as well. how do i change it to only have my work/enterprise emails go into the m

  • Get contacts of iPhone (Exchange server sync)

    Hi, I recently left my old job to start a new one. I have my iPhone setup to syncronize all my emails, contacts and calendars with my old companys Exchange server. My account on their Exchange server has now been disabled and I no longer have access

  • Bayside Beat tutorial missing a java script in the files

    So I opened the file and I unzipped it.  Figure 4. http://wwwimages.adobe.com/www.adobe.com/content/dam/Adobe/en/devnet/dreamweaver/articles/ first_website_pt1/first_website_cc_pt1_fig04.jpg shows a JS and it is not in the file...I'll work around it,

  • How to resolve error 50103

    Dear All I am trying to collect data from two sensors. Both sensors ouput is Analoge Voltage. My purpose is to acquire data from both sensors and then plot thier waveforms, multiply both waveforms and get FFT. The error coming is 50103. The immage of

  • E- Recruitment - Business Partner

    Hi All, Iam currently working on E-Recruitment and as of now we are running HR and E-Rec on the same system and Enhancement pack 1. 1. When i try running the HRALXSYNC the internal candidate column is showing a Red warning and iam not able to repair.