My Tcp/ip multi-client server is not passing the data string into the flatten to string vi

I am using labview Multi-connection cleint and server to build my own multi-client server connection.
  The problem i am having is that the data does not get through the flatten to string vi. Would anyone be kind enough to tell me why is that happening? and what I do to fix it.
  Attached code . My goal is to send data to the client via tcp/ip and use the data to perform certain task.
  Thanks a whole lot
Attachments:
multiconnection-server.vi ‏39 KB
multiconnection-client.vi ‏21 KB

Instead, I decided to upload the code and recent mods I have made to it .
see attached
Attachments:
multiconnection-clienttest.vi ‏43 KB
multiconnection-servertest.vi ‏21 KB

Similar Messages

  • TCP IP multi client connection is not working properly

    My Program is a client server software communication where the server collector data from a cDaq and sends data to the client then the client sends command to the server to execute. The problem I encountered is when I sedn a command to the server, It shows that the server receives it but it doesnt execute it properly. Please take it a look, and see where I went wrong. I have been stuck on this for a while. I will add the more subvis after this post 
    Solved!
    Go to Solution.
    Attachments:
    multiconnection-server-with waveformGen.vi ‏102 KB
    Daqmx channels config.vi ‏36 KB
    Waveform command receiver.vi ‏27 KB

    It's missing Untitled Library 1.
    What does  "not execute properly" mean?  Waht is it doing or not doing and what are you expecting it to do?
    I see a problem in the TCP-IP subVI client.  Why are you enqueueing an element then immediately dequeueing it?  Then you proceed to to enqueue it again after the subVI ends.  But you have a parallel loop where you dequeue the element.  You've got a race condition.  One of two things could happen.
    1.  The data gets enqueued and dequeued inside the subVI.  When it ends, it gets enqueued again in the same queue.  Then the parallel loop could dequeue it and work with it.  I'm guessing if this order of execution happens, it probably behaves properly for you.
    OR.
    2.  The data gets enqueued inside the subVI.  The parallel loop with the dequeue is sitting there waiting for something, dequeues the element and works with.  Then the dequeue inside the subVI sits there forever waiting for an element in the queue that will never come because now you've locked up the code.  The loop can't iterate to ever get more data in the queue.
    You have a lot of strange queue operations going on in that subVI and another subVI in the parallel loop.  Why are you obtaining another reference to the queue, flushing it, then releasing that queue reference.  I'm not even going to try to guess how that would complicate the 2 scenarios I already listed above.
    I suggest looking at more queue examples to understand how they work.  Any given queue should only have 1 dequeue operation, otherwise the dequeues will race to steal the data from each other.

  • SSL VPN message "This (client) machine does not have the web access privilege."

    Hello!
    I am trying to configure the SSL VPN (WebVPN) and I am almost done but when clicking on the URL's I configured in the bookmarks, I get the message "This (client) machine does not have the web access privilege. Please contact your SSLVPN provider for assistance." I looked through the many tutorials and guides in existence and none talks about such error and the fix for it. In fact, if I search the net for this error message I get only one match, in the Cisco website, where is say that "The client computer does not meet the security criteria of having web access functionality through the SSL VPN gateway." and as fix it gave this tip "Check the URL to the gateway or contact the administrator if it persists." So, nothing on the website about what this issue is and how to fix it. I will provide my IOS configuration and hopefully someone will spot the issue. Here it goes:
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname R1
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    no logging buffered
    enable secret 5 $1$1LLX$u7aTc8XfNqPZhPVGwEF/J0
    enable password xxxxxxxx
    aaa new-model
    aaa authentication login userAuthen local
    aaa authentication login sdm_vpn_xauth_ml_1 local
    aaa authorization network groupauthor local
    aaa session-id common
    crypto pki trustpoint TP-self-signed-1279712955
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1279712955
    revocation-check none
    rsakeypair TP-self-signed-1279712955
    crypto pki certificate chain TP-self-signed-1279712955
    certificate self-signed 01
      3082023A 308201A3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31323739 37313239 3535301E 170D3130 30333233 31313030
      33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373937
      31323935 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100A8EF 34E3E792 36660498 9801F934 E8A41865 3599EA35 B073AC91 D7A53AF4
      A4390D2F CB3DB2DE 936B28F0 A25F3CE1 6F40FD9E E79096F2 F89620E0 B31A7B34
      649BBA22 AE44CB55 9F38BF0C 2F2770CF 8380C167 C17D760C 380E28E4 FF7D6874
      9EFC310A 2AA60835 F1AA384F CD1A0173 19C98192 EBFBD531 24CB9203 EA9E7D54
      B2C30203 010001A3 62306030 0F060355 1D130101 FF040530 030101FF 300D0603
      551D1104 06300482 02523130 1F060355 1D230418 30168014 0D9D62EC DA77EAF3
      11ABF64D 933633F9 2BA362DC 301D0603 551D0E04 1604140D 9D62ECDA 77EAF311
      ABF64D93 3633F92B A362DC30 0D06092A 864886F7 0D010104 05000381 81006853
      48ED4E3E 5721C653 D9A2547C 36E4F0CB A6764B29 9AFFD30A 1B382C8C C6FDAA55
      265BCF6C 51023F5D 4AF6E177 C76C4560 57DE5259 40DE4254 E79B3E13 ABD0A78D
      7E0B623A 0F2D9C01 E72EF37D 5BAB72FF 65A176A1 E3709758 0229A66B 510F9AA2
      495CBB4B 2CD721A7 D6F6EB43 65538BE6 B45550D7 A80A4504 E529D092 73CD
       quit
    dot11 syslog
    ip source-route
    ip dhcp excluded-address 192.168.0.1 192.168.0.10
    ip dhcp pool myPOOL
       network 192.168.0.0 255.255.255.0
       default-router 192.168.0.1
       dns-server 87.216.1.65 87.216.1.66
    ip cef
    ip name-server 87.216.1.65
    ip name-server 87.216.1.66
    ip ddns update method mydyndnsupdate
    HTTP
      add http://username:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 1 0 0 0
    no ipv6 cef
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group pppoe
    request-dialin
      protocol pppoe
    username cisco privilege 15 password 0 xxxxxxxx
    crypto isakmp policy 3
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp fragmentation
    crypto isakmp client configuration group vpnclient
    key cisco123
    domain selfip.net
    pool ippool
    acl 110
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    crypto dynamic-map dynmap 10
    set transform-set myset
    reverse-route
    crypto map clientmap client authentication list userAuthen
    crypto map clientmap isakmp authorization list groupauthor
    crypto map clientmap client configuration address respond
    crypto map clientmap 10 ipsec-isakmp dynamic dynmap
    archive
    log config
      hidekeys
    interface Loopback0
    ip address 10.11.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface Loopback2
    description SSL VPN Website IP address
    ip address 10.10.10.1 255.255.255.0
    interface Loopback1
    description SSL DHCP Pool Gateway Address
    ip address 192.168.250.1 255.255.255.0
    interface FastEthernet0
    description $ES_LAN$
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    interface FastEthernet1
    interface FastEthernet2
    switchport access vlan 2
    interface FastEthernet3
    interface FastEthernet4
    interface FastEthernet5
    interface FastEthernet6
    interface FastEthernet7
    interface FastEthernet8
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
    bundle-enable
    dsl operating-mode auto
    interface Vlan1
    no ip address
    interface Dialer1
    ip ddns update hostname myserver.selfip.net
    ip ddns update mydyndnsupdate host members.dyndns.org
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip policy route-map VPN-Client
    dialer pool 1
    ppp chap hostname xxx
    ppp chap password 0 xxxx
    ppp pap sent-username xxx password 0 xxxx
    crypto map clientmap
    ip local pool ippool 192.168.50.100 192.168.50.200
    ip local pool sslvpnpool 192.168.250.2 192.168.250.100
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source static tcp 192.168.0.2 21 interface Dialer1 790
    ip nat inside source static tcp 192.168.0.15 21 interface Dialer1 789
    ip nat inside source list 102 interface Dialer1 overload
    ip nat inside source static tcp 10.10.10.1 443 interface Dialer1 443
    ip nat inside source static tcp 10.10.10.1 80 interface Dialer1 80
    access-list 102 deny   ip 192.168.0.0 0.0.0.255 192.168.50.0 0.0.0.255
    access-list 102 permit ip 192.168.0.0 0.0.0.255 any
    access-list 110 permit ip 192.168.0.0 0.0.0.255 192.168.50.0 0.0.0.255
    access-list 144 permit ip 192.168.50.0 0.0.0.255 any
    route-map VPN-Client permit 10
    match ip address 144
    set ip next-hop 10.11.0.2
    control-plane
    banner motd ^C
    ================================================================
                    UNAUTHORISED ACCESS IS PROHIBITED!!!
    =================================================================
    ^C
    line con 0
    line aux 0
    line vty 0 4
    password mypassword
    transport input telnet ssh
    webvpn gateway MyGateway
    ip address 10.10.10.1 port 443 
    http-redirect port 80
    ssl trustpoint TP-self-signed-1279712955
    inservice
    webvpn install svc flash:/webvpn/svc_1.pkg sequence 1
    webvpn install csd flash:/webvpn/sdesktop.pkg
    webvpn context SecureMeContext
    title "My SSL VPN Service"
    secondary-color #C0C0C0
    title-color #808080
    ssl authenticate verify all
    url-list "MyServers"
       heading "My Intranet"
       url-text "Cisco" url-value "http://192.168.0.2"
       url-text "NetGear" url-value "http://192.168.0.3"
    login-message "Welcome to My VPN"
    policy group MyDefaultPolicy
       url-list "MyServers"
       functions svc-enabled
       svc address-pool "sslvpnpool"
       svc keep-client-installed
    default-group-policy MyDefaultPolicy
    aaa authentication list userAuthen
    gateway MyGateway domain testvpn
    max-users 100
    csd enable
    inservice
    end
    Thank you!

    Hi,
    Please check SAP note:
    2004579 - You cannot create a FR company from a Package
    Thanks & Regards,
    Nagarajan

  • DHCP Server is not passing out DHCP Leases

    I can't seem to figure out why DHCP server is not passing out DHCP lease a client?
    Also I can't seem to figure out why NVI0 interface is UP? I have setup another box similarly and NVI0 is down on that and the DHCP server is working fine on that too. Strange!
    I am working on CISCO 881 VPN Router...Please have a look at it and let me know. Thanks
    Here is the configuration in the box...
    sh run
    Building configuration...
    Current configuration : 6543 bytes
    ! Last configuration change at 17:09:54 CST Fri Sep 14 2012 by XXXXX
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname XXXXX
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    aaa new-model
    aaa authentication login default local
    aaa authentication login vpn_xauth_ml_1 local
    aaa authentication login sslvpn local
    aaa authorization network vpn_group_ml_1 local
    aaa session-id common
    memory-size iomem 10
    clock timezone CSTime -6
    clock summer-time CST recurring
    crypto pki trustpoint TP-self-signed-3079619067
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3079619067
    revocation-check none
    rsakeypair TP-self-signed-3079619067
    crypto pki certificate chain TP-self-signed-3079619067
    certificate self-signed 01
      30820252 308201BB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 33303739 36313930 3637301E 170D3132 30393134 31393231
      32375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 30373936
      31393036 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100993C D622004B F3AEA1E5 81106C28 36EC52D0 5435ABC3 8912095F 3641168A
      B67D97AF AEB43CF3 00A00EB5 702FA355 9F58EBEF F42294DC 0E32CF40 E17D372A
      3BC36401 55EDBA5C 910B7A51 89D709A8 7EAB3FF0 E4C99D34 CBE3F316 069C0E16
      BC284055 35E3D762 463DABF6 852C4E7A D2EF45A4 21F08689 4DF17870 9E2A6C27
      1BFB0203 010001A3 7A307830 0F060355 1D130101 FF040530 030101FF 30250603
      551D1104 1E301C82 1A506F70 6C617276 696C6C65 2E796F75 72646F6D 61696E2E
      636F6D30 1F060355 1D230418 30168014 64EA4CAE 2029E4C2 702584C6 B5732464
      5C9DA38A 301D0603 551D0E04 16041464 EA4CAE20 29E4C270 2584C6B5 7324645C
      9DA38A30 0D06092A 864886F7 0D010104 05000381 81006C27 96E06B83 04DBDA81
      EEB0AF35 84ED370E A8C9694E F9B9326D 69CB1043 9C396D7B 760D252F 4881926D
      878E434F 9AFC3E6D A5BF43F2 E619D6EC F45C039A 5FFB478F A99F7EE5 274E37D5
      11976FDE 823FD1A9 700203E5 67A329B3 F4CF45F0 245757C8 E2349276 B13414D1
      017616FA 38A40BA8 42545AC5 C7676D21 29E4F491 CADB
            quit
    ip source-route
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.1.1 192.168.100.101
    ip dhcp excluded-address 192.168.1.254
    ip dhcp pool ccp-pool
       import all
       network 10.10.10.0 255.255.255.248
       default-router 10.10.10.1
       lease 0 2
    ip dhcp pool Internal_Network
       network 192.168.1.0 255.255.255.0
       dns-server 192.168.100.254
       default-router 192.168.1.254
    ip cef
    ip domain name yourdomain.com
    ip name-server 192.168.100.254
    no ipv6 cef
    license udi pid CISCO881-K9 sn FTX1604828T
    username XXXXX privilege 15 secret 5 $1$QEcR$96cmvs/h/.05G6BnorcWG/
    username XXXXX secret 5 $1$PQQ1$3.Vin0i/2uZ/KD0xEJ8GC.
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp policy 2
    encr 3des
    hash md5
    authentication pre-share
    group 2
    crypto isakmp client configuration group YYYYYYY
    key XXXXX_XXXXX_XXXXX
    pool VPN-Pool
    acl VPN-Access-List
    crypto isakmp profile vpn-isakmp-profile-1
       match identity group YYYYYYY
       client authentication list vpn_xauth_ml_1
       isakmp authorization list vpn_group_ml_1
       client configuration address respond
       virtual-template 2
    crypto ipsec transform-set encrypt-method-1 esp-3des esp-sha-hmac
    crypto ipsec profile VPN-Profile-1
    set transform-set encrypt-method-1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description WAN_INTERFACE
    ip address 192.168.100.3 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface Virtual-Template2 type tunnel
    ip unnumbered FastEthernet0
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VPN-Profile-1
    interface Vlan1
    description VLAN1_INTERFACE
    ip address 192.168.1.254 255.255.255.0
    no ip redirects
    no ip unreachables
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    ip local pool VPN-Pool 192.168.1.151 192.168.1.200
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 100 interface FastEthernet4 overload
    ip nat inside source static tcp 192.168.1.100 21 192.168.100.3 21 extendable
    ip nat inside source static tcp 192.168.1.100 80 192.168.100.3 80 extendable
    ip route 0.0.0.0 0.0.0.0 192.168.100.254
    ip access-list extended VPN-Access-List
    permit ip 192.168.1.0 0.0.0.255 any
    permit tcp host A.B.C.D host 192.168.1.100 eq ftp
    permit tcp host A1.B1.C1.D1 host 192.168.1.100 eq ftp
    permit tcp host A2.B2.C2.D2 host 192.168.1.100 eq ftp
    permit tcp 192.168.1.0 0.0.0.255 host 192.168.1.100 eq ftp
    permit tcp host A3.B3.C3.D3 host 192.168.1.100 eq ftp
    permit tcp any host 192.168.1.100 eq XXX
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 23 permit 192.168.1.0 0.0.0.255
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any
    no cdp run
    control-plane
    banner exec ^C
    % Password expiration warning.
    Cisco Configuration Professional (Cisco CP) is installed on this device
    and it provides the default username "cisco" for  one-time use. If you have
    already used the username "cisco" to login to the router and your IOS image
    supports the "one-time" user option, then this username has already expired.
    You will not be able to login to the router with this username after you exit
    this session.
    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.
    username <myuser> privilege 15 secret 0 <mypassword>
    Replace <myuser> and <mypassword> with the username and password you
    want to use.
    ^C
    banner motd ^C XXXXX-XXXXX VPN Router ^C
    line con 0
    exec-timeout 30 0
    logging synchronous
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    password 7 124A50424A5E5550
    transport input telnet ssh
    scheduler max-task-time 5000
    end

    Hi Jennifer,
    I have gotten it resolved. Per your suggestion, I have turned on debug ip dhcp events and found that POOL EMPTY message. After little research, I found out that I have made a mistake in my excluded-address range.
    I have had it as 
    ip dhcp excluded-address 192.168.1.1 192.168.100.101
    It should have been
    ip dhcp excluded-address 192.168.1.1 192.168.1.101.
    It was a typo.
    Thank you for the suggestion.
    Srini

  • BC Ecommerce SOAP Error: Server did not recognize the value of HTTP Header SOAPAction

    I am trying to add a product to an ecommerce site with this soap action: Product_UpdateInsert
    I have followed this very brief instruction: https://jollyrogers.worldsecuresystems.com/catalystwebservice/catalystecommercewebservice. asmx?op=Product_UpdateInsert
    I have a html page in a secure area with a jQuery ajax soap script.
    I get the this error when I run the script:
    <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><soap:Fault><faultcode>soap:Client</faultcode><faultstring>Server did not recognize the value of HTTP Header SOAPAction: https://jollyrogers.worldsecuresystems.com/CatalystDeveloperService/CatalystEcommerceWebse rvice/Product_UpdateInsert.</faultstring><detail /></soap:Fault></soap:Body></soap:Envelope>
    I have also tried to add a header with the Soap action with the beforeSend in the ajax call.
    This must have been solved before I suppose?
    Here is my script:
    <!DOCTYPE html>
    <html lang="en">
    <head>
    <title>Test SOAP Request</title>
        <script type="text/javascript" src="//code.jquery.com/jquery-1.10.2.min.js"></script>
        <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/jquery-cookie/1.3.1/jquery.cookie.min.js"></script>
        <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/underscore.js/1.5.1/underscore-min.js"></script>
        <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/backbone.js/1.0.0/backbone-min.js"></script>
        <script type="text/javascript" src="//cdn.worldsecuresystems.com/bcapi/bcapi-0.0.1.min.js"></script>
    </head>
    <body>
    <script>
    var wsUrl = "https://jollyrogers.worldsecuresystems.com/catalystwebservice/catalystecommercewebservice. asmx";
    var soapRequest =
    '<?xml version="1.0" encoding="utf-8"?> \
    <soap12:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap12="http://www.w3.org/2003/05/soap-envelope"> \
      <soap12:Body> \
        <Product_UpdateInsert xmlns="https://jollyrogers.worldsecuresystems.com/CatalystDeveloperService/CatalystEcommerceWebse rvice"> \
          <username>myEmailAdress</username> \
          <password>mySecretPassw</password> \
          <siteId>1894001</siteId> \
          <productList> \
            <Products> \
              <productCode>ZJAWEyuuyN</productCode> \
              <productName>My test product</productName> \
              <description>Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.</description> \
              <smallImage>/images/product1/small.jpg</smallImage> \
              <largeImage>/images/product1/large.jpg</largeImage> \
             <cataloguesArray> \
                 <string>/Store/</string> \
              </cataloguesArray> \
              <pricesSaleArray> \
                <string>US/19.95,3/17.96,7/16.96</string> \
              </pricesSaleArray> \
              <pricesRetailArray> \
                <string>US/20,5/19,8/20</string> \
              </pricesRetailArray> \
              <pricesWholesaleArray> \
                <string>US/20,5/19,8/20</string> \
              </pricesWholesaleArray> \
              <wholesaleTaxCodeArray> \
                <string>US/0.00</string> \
              </wholesaleTaxCodeArray> \
              <taxCodeArray> \
                <string>GB/VAT</string> \
              </taxCodeArray> \
              <groupProducts> \
                <string>580H0036BL</string> \
                <string>ACAI60</string> \
                <string>ABC-123</string> \
              </groupProducts> \
              <groupProductsDescriptions> \
                <string>Lorem ipsum dolor sit amet</string> \
                <string>consectetur adipisicing elit</string> \
              </groupProductsDescriptions> \
              <supplierEntityId>1234</supplierEntityId> \
              <supplierCommission>0</supplierCommission> \
              <weight>30</weight> \
              <tags>NEW!</tags> \
              <unitType>string</unitType> \
              <minUnits>0</minUnits> \
              <maxUnits>2</maxUnits> \
              <inStock>43</inStock> \
              <onOrder>3</onOrder> \
              <reOrder>2</reOrder> \
              <inventoryControl>true</inventoryControl> \
              <canPreOrder>true</canPreOrder> \
              <custom1>Text in custom field 1</custom1> \
              <custom2>Text in custom field 2</custom2> \
              <custom3>Text in custom field 3</custom3> \
              <custom4>Text in custom field 4</custom4> \
              <popletImages>/images/image1.jpg;/images/image2.jpg;</popletImages> \
              <enabled>true</enabled> \
              <deleted>false</deleted> \
              <captureDetails>true</captureDetails> \
              <downloadLimitCount>20</downloadLimitCount> \
              <limitDownloadsToIP>0</limitDownloadsToIP> \
              <isOnSale>true</isOnSale> \
              <hideIfNoStock>true</hideIfNoStock> \
              <productAttributes>Size*|5|Y:L||UK/2|US/20,S||UK/1|US/10</productAttributes> \
              <isGiftVoucher>false</isGiftVoucher> \
              <enableDropShipping>true</enableDropShipping> \
              <productWeight>0</productWeight> \
              <productWidth>0</productWidth> \
              <productHeight>0</productHeight> \
              <productDepth>0</productDepth> \
              <excludeFromSearch>false</excludeFromSearch> \
              <productTitle>My product title</productTitle> \
              <cycletypeId>3</cycletypeId> \
              <cycletypeCount>-1</cycletypeCount> \
              <slug>my-product</slug> \
              <hasVariations>true</hasVariations> \
              <variations> \
                <ProductVariation xsi:nil="true" /> \
                <ProductVariation xsi:nil="true" /> \
              </variations> \
            </Products> \
          </productList> \
        </Product_UpdateInsert> \
      </soap12:Body> \
    </soap12:Envelope>';
    $.ajax({
         type: "POST",
         beforeSend: function(xhr){xhr.setRequestHeader('SOAPAction', 'https://jollyrogers.worldsecuresystems.com/CatalystDeveloperService/CatalystEcommerceWebse rvice/Product_UpdateInsert');},
         url: wsUrl,
         contentType: "text/xml",
         dataType: "xml",
         data: soapRequest,
         success: processSuccess,
         error: processError
    function processSuccess(data, status, req)
       if (status == "success")
       alert("Success!");
    function processError(data, status, req)
       alert("Failed!");
       alert(req.responseText + " " + status);
    </script>
    </body>
    </html>

    This line is a target namespace so it should not be changed: <Product_Retrieve xmlns="http://tempuri.org/CatalystDeveloperService/CatalystEcommerceWebservice"> It is very easy to think that it's a placeholder and that it should be replaced with your own url, which it should not and which will fail.
    This works now:
    <!DOCTYPE html>
    <html lang="en">
        <head>
            <title>Test 7 SOAP Request</title>
            <script type="text/javascript" src="//code.jquery.com/jquery-1.10.2.min.js"></script>
        </head>
        <body>
            <script>    
                var SoapMessage = '<?xml version="1.0" encoding="utf-8"?> \
    <soap12:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap12="http://www.w3.org/2003/05/soap-envelope"> \
    <soap12:Body> \
    <Product_Retrieve xmlns="http://tempuri.org/CatalystDeveloperService/CatalystEcommerceWebservice"> \
    <username>Your Email</username> \
    <password>Your password</password> \
    <siteId>1894001</siteId> \
    <productCode>HHKDKXS5MB</productCode> \
                </Product_Retrieve> \
                </soap12:Body> \
                </soap12:Envelope>';
                var url = "https://jollyrogers.worldsecuresystems.com/catalystwebservice/catalystecommercewebservice. asmx";
                $.support.cors = true;
                $.ajax({
                    type: "POST",
                    url: url,
                    data: SoapMessage,
                    dataType: "xml",
                    processData: true,
                    contentType: "text/xml; charset=\"utf-8\"",
                    success: function (msg) {
                        alert("suc: " + msg);
                    error: function (msg) {
                        alert("Failed: " + msg);
            </script>
        </body>
    </html>   

  • The Remote Desktop Connection Broker server could not enumerate the targets for the provider named NULL from the database.

    When I try to install Connection Broker on a Windows 2012 R2 Server in a Windows 2003 domain I get this error:
    The Remote Desktop Connection Broker server could not enumerate the targets for the provider named NULL from the database.
    Pooled virtual desktop collection name: NULL
    Error: Logon to the database failed.
    I have added both the Connection Broker server and the 2 remote desktop servers (also Windows 2012 R2 Servers) to the "Windows Authorization Access Group" in the domain according to this: http://support.microsoft.com/kb/331951
    But it still does not work :-(
    I keep getting same error....
    Any idea what I might be missing ?

    Hi,
    Thank you for posting in Windows Server Forum.
    Firstly please let us know by which method you have setup RDS role. You can have more advantage and feature when you will install with Standard deployment instead of Quick start deployment. So if you have setup with quick start option then you can try installing
    with standard type and check the result.
    In addition, please check SQL server database is properly configured for RDS server. Also check that domain controller properly communicates. Kindly go through below thread for more information.
    Server 2012 RDS - Remote
    Desktop Connection Broker Client failed to redirect the user domain\username. Error: NULL
    Hope it helps!
    Thanks.
    Dharmesh Solanki

  • Server did not recognize the value of HTTP Header SOAPAction: .

    hello friends,
    I am wrote a WebService client as below
    import org.apache.axis.client.Call;
    import org.apache.axis.client.Service;
    import javax.xml.namespace.QName;
    public class AtmuClient
    public static void main(String [] args) {
    try {
    String req="request";
    String endpoint ="http://10.1.3.104/mims/service.asmx?WSDL";
    String nameSpaceUri = "http://www.cum.com/MIMS";
    Service service = new Service();
    Call call = (Call) service.createCall();
    call.setTargetEndpointAddress( new java.net.URL(endpoint) );
    call.setOperationName(new QName(nameSpaceUri, "echoString") );
    String ret = (String) call.invoke( new Object[] { req } );
    System.out.println("Sent 'Hello!', got '" + ret + "'");
    } catch (Exception e) {
    System.err.println(e.toString());
    the out put I am getting is
    Server did not recognize the value of HTTP Header SOAPAction: .
    what still I need to incorporate to my code. Do i need to add any methods still ? and one more thing is do i need to write WSDD for this? how ?. can any bady guide me
    thanQ for any greatful guidance.
    HAN.

    Try setting an empty header object for the Call
    SOAPContext ctx = new SOAPContext();
         Header header = new Header();
         Call call = new Call("", "", params, header, "", ctx);   Regards
    Byju Joy

  • Log onto incoming mail server (POP3): Your server does not support the connection encryption type you have specified. Try changing the encryption method. Contact your mail server administrator or Internet service provider (ISP) for additional assistance.

    Hi All,
    This is my first post to ms exchange forum am getting  Log onto incoming mail server (POP3): Your server does not support the connection encryption type you have specified. Try changing the encryption method. Contact your mail server administrator
    or Internet service provider (ISP) for additional assistance. in my outlook clients, till last Sunday (12.04.15) my exchange was well & good, Monday morning suddenly the problem started like none of our outlook pop3 clients are able to communicate
    with exchange (rest  IMAP, SMTP & Exchange accounts are working fine). i have tried with all port no but no luck. please help me to get raid of this one.
    Exchange 2013 CU6 with server 2012 Std 64Bit
    Thanks,
    Murali 

    Dear All,
    I have found the solution for above problem, the problem has occur due to PopProxy inactivity
    please find relevant exchange management shell commends below.
    1. Get-ServerComponentstate -Identity <yourmailserver.com> 
    Server Component State
    yourmailserver.com ServerWideOffline Active
    yourmailserver.com HubTransport Active
    yourmailserver.com FrontendTransport Active
    yourmailserver.com Monitoring Active
    yourmailserver.com RecoveryActionsEnabled Active
    yourmailserver.com AutoDiscoverProxy Active
    yourmailserver.com ActiveSyncProxy Active
    yourmailserver.com EcpProxy Active
    yourmailserver.com EwsProxy Active
    yourmailserver.com ImapProxy Active
    yourmailserver.com OabProxy Active
    yourmailserver.com OwaProxy Active
    yourmailserver.com PopProxy Inactive
    yourmailserver.com PushNotificationsProxy Active
    yourmailserver.com RpsProxy Active
    yourmailserver.com RwsProxy Active
    yourmailserver.com RpcProxy Active
    yourmailserver.com UMCallRouter Active
    yourmailserver.com XropProxy Active
    yourmailserver.com HttpProxyAvailabilityGroup Active
    yourmailserver.com ForwardSyncDaemon Active
    yourmailserver.com ProvisioningRps Active
    yourmailserver.com MapiProxy Active
    yourmailserver.com EdgeTransport Active
    yourmailserver.com HighAvailability Active
    yourmailserver.com SharedCache Active
    2. Set-ServerComponentState -Identity <yourmailserver.com> -Component PopProxy -Requester HealthAPI
    -State Active
    3. Get-ServerComponentstate -Identity <yourmailserver.com> 
    Server Component State
    yourmailserver.com ServerWideOffline Active
    yourmailserver.com HubTransport Active
    yourmailserver.com FrontendTransport Active
    yourmailserver.com Monitoring Active
    yourmailserver.com RecoveryActionsEnabled Active
    yourmailserver.com AutoDiscoverProxy Active
    yourmailserver.com ActiveSyncProxy Active
    yourmailserver.com EcpProxy Active
    yourmailserver.com EwsProxy Active
    yourmailserver.com ImapProxy Active
    yourmailserver.com OabProxy Active
    yourmailserver.com OwaProxy Active
    yourmailserver.com PopProxy Active
    yourmailserver.com PushNotificationsProxy Active
    yourmailserver.com RpsProxy Active
    yourmailserver.com RwsProxy Active
    yourmailserver.com RpcProxy Active
    yourmailserver.com UMCallRouter Active
    yourmailserver.com XropProxy Active
    yourmailserver.com HttpProxyAvailabilityGroup Active
    yourmailserver.com ForwardSyncDaemon Active
    yourmailserver.com ProvisioningRps Active
    yourmailserver.com MapiProxy Active
    yourmailserver.com EdgeTransport Active
    yourmailserver.com HighAvailability Active
    yourmailserver.com SharedCache Activ
    Replace yourmailserver.com with your server host name.
    Thanks

  • The proxy server could not handle the request get /user/login in dbfw 5.1

    hi
    when i m login to oracle database firewall throuth internet explorer on the window xp client then the following error occur
    the proxy server could not handle the request get /user/login
    plz resolve issue
    Edited by: 913779 on May 15, 2012 6:29 AM

    Are you using a proxy? Check you settings.<BR><BR>
    ===============================================
    '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).
    ''(If you're using an added theme, switch to the Default theme.)''
    If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br>
    [[Image:FirefoxSafeMode|width=520]]<br><br>
    If Firefox is not running, you can start Firefox in Safe Mode as follows:
    * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut.
    * On Mac: Hold the '''option''' key while starting Firefox.
    * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
    ''Once you get the pop-up, just select "'Start in Safe Mode"''
    [[Image:Safe Mode Fx 15 - Win]]
    '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause.
    ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.''
    When you figure out what's causing your issues, please let us know. It might help others with the same problem.
    Thank you.

  • Sharing via email says the server did not recognize the username and password  combination

    I am trying to share photos in iPhoto via email (gmail) and it says the server does not recognize the username password combination. I have deleted the email account rebooted iMac and re-entered the gmail account info and I get the same message. I have confirmed the username and password are correct.

    LarryHN I guess I should have clarified that. I did try it that way and I am able to email pictures with mail set as the email client. When I change it to iPhoto as the email client is when I get this message. I have the same setup on my Macbook and it works great for emailing pictures from iPhoto. Although I can send them through email client, I prefer doing it through iPhoto.

  • This server does not have the module needed for interpreting traces

    I wan to use the Trace Control function of the Exchange Troubleshooting Assistant. I specifically want to look at the transactions of a particular user. When starting the function I get the message, "This server does not have the module needed for interpreting traces." I find nothing to tell me what the module is or where to get it.
    Specifically, I have a Macintosh user (bigwig in my organization) that insists on using Apple's 10.6 Calendar program, and constantly complains that his calendars are different between his 3 Macs and his iPhone. He claims to have put a calendar item on one machine, now it appears nowhere. And I have no way of proving what is going wrong. He hates Outlook and refuses to use it, he hates Entourage and refuses to use it. The local database for Entourage kept getting fouled up to the point that we kept having to delete this account and readding it to force the recreation of the database. The database tool never fixed the problems and of course he did a lot of customization that got destroyed every time we deleted the account settings and added them back.
    I really want to run the tool for a while and see if there is actually some transaction actually happening on the server side, so I would like to have these traces and be able to view them.
    SnoBoy

    See
    http://blogs.msdn.com/b/dvespa/archive/2011/05/27/how-to-use-extra-to-troubleshoot-rpc-client-access-issues.aspx.
    Just click on ok and proceed with set trace manually.
    Svetozar Petrović

  • The requested operation could not be performed because OLE DB provider "MSOLAP" for linked server does not support the required transaction interface.

    I am getting the following error when attempting to INSERT the results of an "EXEC(@MDXQuery) at SSAS LinkedServer":
    The requested operation could not be performed because OLE DB provider "MSOLAP" for linked server does not support the required transaction interface.
    Here is code that illustrates what I am doing:
    DECLARE @MDX varchar(max);
    SET @MDX='
    SELECT
    [Measures].[Extended Service Count]
    } ON COLUMNS,
    NON EMPTY [Organization].[By Manufacturer].[Manufacturer]
    ON ROWS
    FROM (
    SELECT
    {[Organization].[Org Tree].&[2025],[Organization].[Org Tree].&[2040]} ON 0
    FROM [MyCube]
    /* Test 1 */
    EXECUTE(@MDX) at SSASLinkedServer;
    /* Test 2 */
    DECLARE @ResultsB TABLE (
    Manufacturer varchar(255)
    , ExtendedServiceCount float
    INSERT INTO @ResultsB (Manufacturer, ExtendedServiceCount) EXECUTE(@MDX) at SSASLinkedServer;
    Test 1 succeeds, returning expected results, and Test 2 fails returning the error mentioned above.
    Other articles I've found so far don't seem to apply to my case.  I am not creating any explicit transactions in my code.   When I use OPENQUERY, I am able to do the insert just fine, but not when I use EXEC @MDX at LinkedServer.
    Unfortunately in some variations of the query, I run into the 8800 character limit on OPENQUERY, so I need to use this other approach.
    Any ideas?
    -Tab Alleman

    Hi Tab,
    In this case, SQL Server Analysis Services doesn’t support Distributed Transactions by design. Here is a similar thread about this issue for your reference, please see:
    http://social.technet.microsoft.com/Forums/en-US/8b07be45-01b6-49d4-b773-9f441c0e44c9/olaplinked-server-error-msolap-for-linked-server-olaplinked-server-does-not-support-the?forum=sqlanalysisservices
    One workaround is that use SQLCMD to execute the EXEC AT command and saved the results to a file, then import using SSIS.
    If you have any feedback on our support, please click
    here.
    Regards,
    Elvis Long
    TechNet Community Support

  • Server failed to run - Reason:Server is not in the majority cluster partition

    Hi,
    my environment is Weblogic 12.1.2.
    The deployment configuration is: cluster, 2 machines, 2 managed servers, 1 data source, and JMS (with uniform distributed queue).
    When I'm starting the admin server + managed server on the first machine (using the node manager), while on the second machine the managed server and also the node manager are not running, the server failed to run and the error reason is : "Server is not in the majority cluster partition".
    How can I enforce the server to run even if the second one is not running ? This scenario could occured because of some local problems on the second machine. My expectation is that after the second will running the whole cluster status will be good.
    Thanks,
    Yaakov

    Hi,
    Just to remember the configuration: 2 managed servers configured as cluster that should be deployed on 2 different machine.
    Following summary of the tests:
         - node manager + admin server + 1 managed server running on the first machine --> server failed to init with error "Server is not in the majority cluster partition"
         - node manager + admin server + 2 managed servers running on the one machine --> servers are running without errors
         - node manager + admin server + 1 managed server running on the first  machine / node manager runs on the second machine --> server on the first machine runs without errors without the famous error ' Server is not in the majority cluster partition'.
    Bottom line, seems that if the node manager is not running on the remote machine, the cluster is not in a stable state and so the single managed server failed to initialize.
    Is it according the documentation / expectations ?
    Thanks,
    Yaakov

  • ICloud IMAP server does not send the CAPABILITY with CRLF

    IMAP iCloud server does not send the CAPABILITY response with CRLF appended as per RFC 3501. Please find the log snippet
    11-05 10:50:52.462 29603 29988 D Email   : open :: socket openjava.io.BufferedInputStream@43a726a8 | java.io.BufferedOutputStream@43a72b68
    11-05 10:50:52.502 29603 29988 D Email   : <<< #null# ["OK", ["CAPABILITY", "st11p00mm-iscream023", "1S", "XAPPLEPUSHSERVICE", "IMAP4", "IMAP4rev1", "SASL-IR", "AUTH=ATOKEN", "AUTH=PLAIN"], "iSCREAM ready to rumble (1S:1092) st11p00mm-iscream023 [42:4469:15:50:53:39]"]
    11-05 10:50:52.502 29603 29988 D Email   : >>> 1 CAPABILITY
    11-05 10:50:52.552 29603 29988 D Email   : <<< #null# ["CAPABILITY", "st11p00mm-iscream023", "1S", "XAPPLEPUSHSERVICE", "IMAP4", "IMAP4rev1", "SASL-IR", "AUTH=ATOKEN", "AUTH=PLAIN"]
    11-05 10:50:52.562 29603 29988 D Email   : <<< #1# ["OK", "!!"]
    11-05 10:50:52.582 29603 29988 D Email   : >>> [IMAP command redacted]
    11-05 10:50:52.682 29603 29988 D Email   : <<< #2# ["OK", ["CAPABILITY", "XAPPLEPUSHSERVICE", "IMAP4", "IMAP4rev1", "ACL", "QUOTA", "LITERAL+", "NAMESPACE", "UIDPLUS", "CHILDREN", "BINARY", "UNSELECT", "SORT", "CATENATE", "URLAUTH", "LANGUAGE", "ESEARCH", "ESORT", "THREAD=ORDEREDSUBJECT", "THREAD=REFERENCES", "CONDSTORE", "ENABLE", "CONTEXT=SEARCH", "CONTEXT=SORT", "WITHIN", "SASL-IR", "SEARCHRES", "XSENDER", "X-NETSCAPE", "XSERVERINFO", "X-SUN-SORT", "ANNOTATE-EXPERIMENT-1", "X-UNAUTHENTICATE", "X-SUN-IMAP", "X-ANNOTATEMORE", "XUM1", "ID", "IDLE"], "User test logged in"]
    11-05 10:50:52.682 29603 29988 D Email   : >>> 3 CAPABILITY
    11-05 10:50:52.742 29603 29988 W Email   : Exception detected: Expected 000a (
    )1-05 10:50:52.742 29603 29988 W Email   : ) but got 000d (
    This is happening only when CAPABILITY command is sent follwed by LOGIN command. Please check this issue.

    If you want your mail delivered properly the Official Host Name of the sending server should match the PTR (reverse DNS) of the sending IP Address, and there should be an "A" record that matches the OHN as well.
    Example:
    mail.yourdomain.com (Official Host Name) on 123.123.123.123
    PTR for 123.123.123.123 should match mail.yourdomain.com
    There should be an A record in yourdomain.com pointing to 123.123.123.123
    Kostas

  • Receiver SOAP Adapter Problem-soap fault: Server did not recognize the valu

    I have a scenario for service orders using async call : IDOC-XI-SOAP.
    I used the XML Spy tool to test the Service order's web services and it works fine. I imported the same WSDL file in XI. When I send a SOAP message from XI, I get a following error in the adapter engine.
    <i>MP: exception caught with cause com.sap.aii.af.ra.ms.api.RecoverableException: SOAP: response message contains an error XIAdapter/PARSING/ADAPTER.SOAP_EXCEPTION - soap fault: Server did not recognize the value of HTTP Header SOAPAction: AddUpdateCostObjectLevel1.</i>
    Can someone please help me...
    Thanks in advance!
    Mrudula

    This problem is resolved by me by passing the "http://company's URL/AddUpdateCostObjectLevel1" in the SOAP action.
    Thanks to all for your input.
    Mrudula

Maybe you are looking for

  • ERROR ORA-00942: table or view does not exist

    Hi: I created a .sql file and a loader file. Running the .sql file with sql * plus Worksheet: declare gr sdo_georaster; begin select image into gr from gis.RasterImages where geoid=1 for update; sdo_geor.generatePyramid(gr,'resampling=NN'); update gi

  • How do I download the trial version of Photoshop Extend?

    I am trying to download the trial version of Photoshop Extend but I am having problems doing so.   My computer meets all the system requirements, I have cleared out my temp files and tried switching web browsers from Windows Explorer to Mozilla Firef

  • Finding "Zero Sales Products"

    Hi All I am New To Oracle And Need Some Help In Writing A Query In SQL. I Have The Below Tables SQL> desc sales_invoice; Name Null? Type INVOICE_NO NUMBER(3) INVOICE_DATE DATE PRODUCT_CODE VARCHAR2(2) QUANTITY NUMBER(6,3) RATE NUMBER(6,2) VALUE NUMBE

  • Why applications do not they include features consistent with Siri?

    I asked Siri how many miles I ran last week and he could not answer me. Siri can become smarter provided that each application integrates functions to Siri. each application should bring a branch to Siri.

  • Can image be shrunk to fit on CVS Monitor

    I have a Point Gray Scorpion camera with a resolution of 1600x1200 pixels. Is there a way to shrink the image so the entire image is shown on the CVS monitor without being cropped. I am using VBAI 2.0.2