Need ACL Assistance for SMTP Inbound

All,
First thanks for any help given.
I am trying to configure my ASA5505 to allow SMTP relay and the ACL\Static I created is not working.
Here is the config:
ASA Version 8.2(2)
names
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.2 255.255.255.0
interface Vlan2
nameif outside
security-level 0
ip address 12.12.12.1 255.255.255.248 --> Suppressed
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
speed 100
duplex full
interface Ethernet0/4
interface Ethernet0/5
switchport access vlan 3
interface Ethernet0/6
interface Ethernet0/7
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list 101 extended permit tcp any host 12.12.12.1 eq smtp
access-list inside_access_in extended permit ip any any
access-list nonat extended permit ip any 10.10.10.0 255.255.255.0
pager lines 24
logging enable
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.5 smtp netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 12.12.12.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global-policy
class inspection_default
  inspect icmp
class class-default
prompt hostname context
Please help me :-(
Many thanks!

Jim,
I do see acl applied -
access-group outside_in in interface outside
but same time i do not see any statement matching this access-group.
access-list 101 extended permit tcp any host 12.12.12.1 eq smtp
access-list inside_access_in extended permit ip any any
access-list nonat extended permit ip any 10.10.10.0 255.255.255.0
So either create this statement -
access-list outside_in extended permit tcp any host 12.12.12.1 eq smtp
or change the access group-
access-group 101 in interface outside
Thanks
Ajay

Similar Messages

  • Need ACL Assistance for SMTP

    All,
    First thanks for any help given.
    I am trying to configure my ASA5505 to allow SMTP relay and the ACL\Static I created is not working.
    Here is the config:
    ASA Version 8.2(2)
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.2 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 12.12.12.1 255.255.255.248 --> Suppressed
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    speed 100
    duplex full
    interface Ethernet0/4
    interface Ethernet0/5
    switchport access vlan 3
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    access-list 101 extended permit tcp any host 12.12.12.1 eq smtp
    access-list inside_access_in extended permit ip any any
    access-list nonat extended permit ip any 10.10.10.0 255.255.255.0
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nonat
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface smtp 192.168.1.5 smtp netmask 255.255.255.255
    access-group inside_access_in in interface inside
    access-group outside_in in interface outside
    route outside 0.0.0.0 0.0.0.0 12.12.12.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global-policy
    class inspection_default
      inspect icmp
    class class-default
    prompt hostname context
    Please help me :-(
    Many thanks!

    Hi Jim,
    The configuration guide will provide some basic examples for configuring object-groups:
    http://www.cisco.com/en/US/docs/security/asa/asa82/configuration/guide/objectgroups.html
    Single network objects are only available in 8.3 and higher. However, an object-group in 8.2 can certainly contain a single member.
    -Mike

  • Need ACL Assistance on Switch/Router

    Hello all,
    I  am learning how to write ACLs, and one of the exercises is that I have  to write an ACL to restrict PING, HTTP, FTP, and allow POP3 and SMTP  between a pc and server.  Below is my ACL.  The thing that does not work  is the POP3\SMTP access.  It continues to fail.  I do not want to just  add a "permit ip any any" to make it work.  Can someone help?  Thanks!
    PC1:  192.168.6.65
    PC2:  192.168.6.66
    Svr1:  209.1.5.14
        10 deny icmp host 192.168.6.65 host 209.1.5.14 echo
        20 deny icmp host 192.168.6.65 host 209.1.5.14 echo-reply
        30 deny icmp host 192.168.6.66 host 209.1.5.14 echo
        40 deny icmp host 192.168.6.66 host 209.1.5.14 echo-reply
        50 deny tcp host 192.168.6.65 host 209.1.5.14 eq www
        60 deny tcp host 192.168.6.66 host 209.1.5.14 eq www
        70 deny tcp host 192.168.6.65 host 209.1.5.14 eq ftp
        80 deny tcp host 192.168.6.65 host 209.1.5.14 eq ftp-data
        90 deny tcp host 192.168.6.66 host 209.1.5.14 eq ftp
        100 deny tcp host 192.168.6.66 host 209.1.5.14 eq ftp-data
        190 permit tcp host 192.168.6.65 host 209.1.5.14 eq smtp
        200 permit tcp host 192.168.6.66 host 209.1.5.14 eq smtp
        210 permit tcp host 192.168.6.65 host 209.1.5.14 eq pop3
        220 permit tcp host 192.168.6.66 host 209.1.5.14 eq pop3

    Hi Techinneed,
    Perhaps you try this.
        10 permit tcp host 192.168.6.65 host 209.1.5.14 eq smtp
        20 permit tcp host 192.168.6.66 host 209.1.5.14 eq smtp
        30 permit tcp host 192.168.6.65 host 209.1.5.14 eq pop3
        40 permit tcp host 192.168.6.66 host 209.1.5.14 eq pop3
        50 deny ip any any.

  • ACL Applied in Inbound direction and another ACL exist for in outbound direction - will return traffic allow

    interface gix/y
    ip address A.B.C.D 255.255.255.192
    ip access-group ACL-Inbound in
    ip access-group ACL-Outbound out
    exit
    In ACL-Inbound I have allowed SMTP traffic 6 source address to 4 destination server. One sample output among 24 acl is given below.
    permit tcp host E.F.G.H host I.J.K.L eq 25
    I haven't applied any specific rule for SMTP traffic on outbound direction. My understanding is destinations will be able to reply to the request. Does that need to be specified in the ACL

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    As Fahad has already noted, if you're going to use both an in and out ACL, you'll need to account for the traffic allowed in both direction.  Normally, the in and out ACE are just mirror entries, so for your example of:
    in
    permit tcp host E.F.G.H host I.J.K.L eq 25
    out would be:
    permit tcp host I.J.K.L eq 25 host E.F.G.H
    Fahad also mentioned using a Reflexive ACL.  These will generate a stateful mirror ACE for the reverse traffic.  The reverse ACE will stay active for a short duration after seeing traffic that creates it and the it will time out and remove itself.  Normally you would only use one on a trusted side of the device for generated flows.  When used with a trusted side, the ACE often are made more generic, for example, any inside to outside HTTP flow will allow and ACE for the return traffic.

  • How do i install mySQL on my macbook air,please i need the assistance urgently,because i need to use the program for my course.

    how do i install mySQL on my macbook air.please i need urgent assistance,as it would help me do my course work.
    regarde garabella.

    Call AppleCare and ask them to send you a replacement set. They will charge you a nominal fee for shipping and handling.
    Allan

  • Need sample programs for inbound & outbound interfaces in abap hr?

    hi friends
    i need sample programs for inbound & outbound interface programs in hr abap . any one send me pls
    thanks & regards
    deepurd

    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    *& Report ZPROG65_11 *
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    REPORT zprog65_11 .
    TABLES : lfa1.
    TYPES : BEGIN OF ven ,
    lifnr LIKE rf02k-lifnr,
    bukrs LIKE rf02k-bukrs ,
    ekorg LIKE rf02k-ekorg,
    ktokk LIKE rf02k-ktokk,
    name1 LIKE lfa1-name1,
    sortl LIKE lfa1-sortl,
    land1 LIKE lfa1-land1,
    spars LIKE lfa1-spras,
    akont LIKE lfb1-akont,
    fdgrv LIKE lfb1-fdgrv,
    waers LIKE lfm1-waers,
    anred LIKE lfa1-anred ,
    END OF ven .
    DATA : t_ven TYPE TABLE OF ven WITH HEADER LINE ,
    t_bdc LIKE TABLE OF bdcdata WITH HEADER LINE .
    DATA : v_file TYPE string ,
    v_temp TYPE i ,
    v_lifnr(10) TYPE n,
    v_hdate LIKE sy-datum.
    DATA : c_tcode LIKE sy-tcode .u201Dvalue u2018XK01u2032.
    PARAMETERS : p_file(30) DEFAULT u2018c:\vendor1_11.txtu2019,
    p_group LIKE apqi-groupid.
    START-OF-SELECTION .
    MOVE p_file TO v_file .
    PERFORM file_upload TABLES t_ven USING v_file .
    v_hdate = sy-datum - 1.
    CALL FUNCTION u2018BDC_OPEN_GROUPu2019
    EXPORTING
    client = sy-mandt
    DEST = FILLER8
    group = p_group
    holddate = v_hdate
    keep = u2018Xu2019
    user = sy-uname
    IMPORTING
    QID =
    EXCEPTIONS
    client_invalid = 1
    destination_invalid = 2
    group_invalid = 3
    OTHERS = 11
    IF sy-subrc 0.
    MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    ENDIF.
    LOOP AT t_ven .
    clear lfa1.
    v_temp = 0.
    MOVE t_ven-lifnr TO v_lifnr.
    SELECT SINGLE * FROM lfa1 INTO lfa1 WHERE lifnr =
    v_lifnr.
    IF sy-subrc = 0.
    WRITE :/ u2018foundu2019.
    v_temp = 1.
    else.
    write: / u2018not foundu2019.
    ENDIF.
    IF v_temp = 0.
    c_tcode = u2018xk01u2032.
    PERFORM fill_ddc_table .
    ELSEIF v_temp = 1.
    c_tcode = u2018xk02u2032.
    PERFORM fill_bdc_table .
    ENDIF.
    CALL FUNCTION u2018BDC_INSERTu2019
    EXPORTING
    tcode = c_tcode
    TABLES
    dynprotab = t_bdc
    EXCEPTIONS
    internal_error = 1
    OTHERS = 7.
    REFRESH t_bdc .
    ENDLOOP .
    CALL FUNCTION u2018BDC_CLOSE_GROUPu2019
    EXCEPTIONS
    not_open = 1
    queue_error = 2
    OTHERS = 3.
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    *& Form file_upload
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    text
    u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014-
    u2013>P_T_VEN text
    u2013>P_V_FILE text
    u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014-
    FORM file_upload TABLES p_tven STRUCTURE t_ven
    USING p_vfile.
    CALL FUNCTION u2018GUI_UPLOADu2019
    EXPORTING
    filename = p_vfile
    filetype = u2018ASCu2019
    has_field_separator = u2018Xu2019
    IMPORTING
    FILELENGTH =
    HEADER =
    TABLES
    data_tab = p_tven
    EXCEPTIONS
    file_open_error = 1
    file_read_error = 2
    OTHERS = 17
    IF sy-subrc 0.
    MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    ENDIF.
    ENDFORM. u201D file_upload
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    *& Form FILL_DDC_TABLE
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    text
    u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014-
    u2013> p1 text
    <u2013 p2 text
    u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014-
    FORM fill_ddc_table .
    SCREN 100
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180100u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-LIFNRu2019.
    t_bdc-fval = t_ven-lifnr .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-BUKRSu2019.
    t_bdc-fval = t_ven-bukrs.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-EKORGu2019.
    t_bdc-fval = t_ven-ekorg.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-KTOKKu2019.
    t_bdc-fval = t_ven-ktokk.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    110
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180110u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-NAME1u2032.
    t_bdc-fval = t_ven-name1 .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-SORTLu2019.
    t_bdc-fval = t_ven-sortl.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-LAND1u2032.
    t_bdc-fval = t_ven-land1.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-SPRASu2019.
    t_bdc-fval = t_ven-spars.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    120
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180120u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    130
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180130u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018=ENTRu2019.
    APPEND t_bdc. CLEAR t_bdc.
    210
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180210u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFB1-AKONTu2019.
    t_bdc-fval = t_ven-akont .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFB1-FDGRVu2019.
    t_bdc-fval = t_ven-fdgrv.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    215
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180215u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    220
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180220u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    310
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180310u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFM1-WAERSu2019.
    t_bdc-fval = t_ven-waers .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    320
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180320u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018=UPDAu2019.
    APPEND t_bdc. CLEAR t_bdc.
    ENDFORM. u201CFILL_DDC_TABLE
    u201D FILL_DDC_TABLE
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    *& Form FILL_BDC_TABLE
    &u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014
    text
    u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014-
    u2013> p1 text
    <u2013 p2 text
    u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014u2014-
    FORM fill_bdc_table .
    SCREN 101
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180101u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-LIFNRu2019.
    t_bdc-fval = t_ven-lifnr .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-BUKRSu2019.
    t_bdc-fval = t_ven-bukrs.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018RF02K-EKORGu2019.
    t_bdc-fval = t_ven-ekorg.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    110
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180110u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018lfa1-anredu2019.
    t_bdc-fval = t_ven-anred .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-NAME1u2032.
    t_bdc-fval = t_ven-name1 .
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-SORTLu2019.
    t_bdc-fval = t_ven-sortl.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-LAND1u2032.
    t_bdc-fval = t_ven-land1.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018LFA1-SPRASu2019.
    t_bdc-fval = t_ven-spars.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018/00u2032.
    APPEND t_bdc. CLEAR t_bdc.
    300
    t_bdc-program = u2018SAPMF02Ku2019.
    t_bdc-dynpro = u20180300u2032.
    t_bdc-dynbegin = u2018Xu2019.
    APPEND t_bdc. CLEAR t_bdc.
    t_bdc-fnam = u2018BDC_OKCODEu2019.
    t_bdc-fval = u2018=YESu2019.
    APPEND t_bdc. CLEAR t_bdc.
    ENDFORM. u201D FILL_BDC_TABLE
    Best Regards

  • Need Authentication for SMTP Access

    I have this Java program (SendMail.java) for sending email; however, my ISP requires authentication for SMTP server access, i.e. I receive a 550 Authentication Required error. Does anyone know how to go about coding authentication into a program like SendMail so that the userID and password can be sent back to the server?
    * SendMail.java
    * Created on July 13, 2005, 8:09 PM
    * To change this template, choose Tools | Options and locate the template under
    * the Source Creation and Management node. Right-click the template and choose
    * Open. You can then make changes to the template in the Source Editor.
    * @author Owner
    // SendMail by Tony Swain.
    // Send mail via SMTP
    // To do Appletisize it.
    import java.io.BufferedReader;
    import java.io.FileInputStream;
    import java.io.InputStreamReader;
    import java.io.PrintStream;
    import java.net.Socket;
    import java.util.StringTokenizer;
    import java.net.Authenticator;
    import java.net.*;
    // To do. Finish multiThreading &| write que Thread.
    // this programs sends mail Via SMTP as defined in RFC 821.
    // ftp://ftp.isi.edu/in-notes/rfc821.txt
    public class SendMail   
    Object mailLock              = null;  //In case we want a multi-threaded mailer
    public String mailServerHost = "";
    public String from           = "";
    public String to             = "";
    public String replyTo        = "";
    public String subject        = "Java is Fun";
    public String mailData       =
       "HyperSendMail";
    public String errorMsg = "";
    public Socket mailSendSock = null;
    public  BufferedReader inputStream = null;
    public PrintStream outputStream    =  null;
    public String serverReply          = "";
    SendMail()
       // Doesn't do anything but we need this for extension purposes.
    // Server, from,to,subject, data
    SendMail(String server,String tFrom,String tTo,String sub,String sendData)
       mailServerHost = server;
       mailLock=this; // Thread Monitor passed constructor later. Default this Monitor.
       from = tFrom;
       to   = tTo;
       if(sendData != null)
          mailData = sendData; 
    /*  Just a note to remind myself to add this for cross app./Applet & Runnable.
       & Threadsafe readLine()  I'm too lazy ATM
    SendMail()
       if(mailLock != null)
          if(mailLock instanceof Applet)
             Applet app = (Applet)
    public void send()
       if(!open())          //Yikes! get out of here.
          return;    
       try
          outputStream.println("HELO sendMail");
          serverReply = inputStream.readLine(); 
       catch(Exception e0)
          e0.printStackTrace();
       try
          outputStream.println("MAIL FROM: "+from);
          serverReply = inputStream.readLine();
            // I cheat and don't look for the whole 550
            // we know 5 is an error anyway. Add it in if you want.
          if(serverReply.startsWith("5"))
             close("FROM: Server error :"+serverReply);
             return;
       // Note the switch here. we could get mail from somewhere and by
       // pre setting replyTo reply somewhere else :)
          if(replyTo == null)
             replyTo = from;
          outputStream.println("RCPT TO: <"+to+">");
           // Ya got me! I didn't look for any  250 OK messages. Add it in if you really want.
           // A real programmer will spend 30 hours writing self modifying code in order
           // to save 90 nano seconds ;)  we assume if it did't give an error it must be OK.
          serverReply = inputStream.readLine();
          if(serverReply.startsWith("5"))
             close("Reply error:"+serverReply);
             return;
          outputStream.println("DATA");
          serverReply = inputStream.readLine();
          if(serverReply.startsWith("5"))
             close("DATA Server error : "+serverReply);
             return;
          outputStream.println("From: "+from);
          outputStream.println("To: "+to);
          if(subject != null)
             outputStream.println("Subject: "+subject);
          if(replyTo != null)
             outputStream.println("Reply-to: "+replyTo);
          outputStream.println("");
          outputStream.println(mailData);
          outputStream.print("\r\n.\r\n");
          outputStream.flush();
          serverReply = inputStream.readLine();
          if(serverReply.startsWith("5"))
             close("DATA finish server error: "+serverReply);
             return;
          outputStream.println("quit");
          serverReply = inputStream.readLine();
          if(serverReply.startsWith("5"))
             close("Server error on QUIT: "+serverReply);
             return;
          inputStream.close();
          outputStream.close();
          mailSendSock.close();
       catch(Exception any)
          any.printStackTrace();
          close("send() Exception");
       close("Mail sent");
    public boolean open()
       synchronized(mailLock)
          try
             mailSendSock = new Socket(mailServerHost, 25);
             outputStream = new PrintStream(mailSendSock.getOutputStream());
             inputStream = new BufferedReader(new InputStreamReader(
              mailSendSock.getInputStream()));
             serverReply = inputStream.readLine();
             if(serverReply.startsWith("4"))
                errorMsg = "Server refused the connect message : "+serverReply;
                return false;
          catch(Exception openError) 
             openError.printStackTrace();
             close("Mail Socket Error");
             return false;
          System.out.println("Connected to "+mailServerHost);
          return true;
    public void close(String msg)
              //try to close the sockets
       System.out.println("Close("+msg+")");
       try
          outputStream.println("quit");
          inputStream.close();
          outputStream.close();
          mailSendSock.close();
       catch(Exception e)
          System.out.println("Close() Exception");
         // We are closing so see ya later anyway
    public static void main(String Args[])
    SendMail sm = new
    // * NOTE:
    // Erase these values right away! Just to show you how it is done.
    // Whatever you do don' release it with my mail server hardcoded.
    // last thing I need is 10 million Java mail test spams :)
    SendMail(
              "outgoing.myISP.net",         //Mail Server
              "[email protected]",       // sender
              "[email protected]",       // Recipient
              "Java mail test",               // Subject
              "test test test!");             // Message Data
              sm.send();                      // Send it!
    }

    There is no one in the forum who can shed some light on my problem?

  • I have been on hold for 40 mins 16 sec Need tech assistance!

    I have been on hold for 40 mins 16 sec Need tech assistance!

    One Horse wrote:
     …Photoshop CS4 will not install on a new MacPro…
    Did you happen to remove a previously installed trial or regular copy of CS4 or a CS3 installation improperly?
    "Improperly" means by any other means other than using the respective Adobe Uninstallers in Applications/ Utilities/ Adobe/ ….
    For instance, if you dragged anything to the trash.  That would have been improper starting with CS3.  Previous versions could be trashed, but no more.
    If that was the case you need to look for the CS3Clean and CS4Clean scripts on the Adobe site, download them and run them.

  • Apparently the default country for an account is US. I want it changed to Netherlands without having to call customer service. In need of assistance please.

    Hi,
    Apparently the default country for an account is US. I want it changed to Netherlands without having to call customer service. In need of assistance please, is there someone from Adobe on this forum who can help me? Or does someone know an email address?
    thanks!
    Arjan de Jong

    Change/Verify Account https://forums.adobe.com/thread/1465499 may help
    -http://helpx.adobe.com/x-productkb/policy-pricing/change-country-associated-with-adobe-id. html

  • Need Users and ACL permission for KM Reports

    Hello Experts,
    Need you help for one requirement , in which i need to provide a list of users with ACL permission of each report from KM. There is huge amount of reports so it is quite time consuming to get each report open & to check the ACL and user from KM.
    It there is any thing , so that i can get the list of user with the ACL permission for each reports?
    Any help will be appreciated with points.
    Regards
    AK

    Hi AK,
        I misunderstood your query,if you just want to check the permission of all reports then you can use the default permission report available in the content Administration->KM Content->toolbox->reports->permission report.
    http://help.sap.com/saphelp_nw04/helpdata/en/fe/5290412facac5fe10000000a1550b0/frameset.htm
    If you could not find the report contact basis team to do the configuration
    http://help.sap.com/saphelp_nw04/helpdata/en/07/dad131443b314988eeece94506f861/frameset.htm
    Naga

  • Migration Assistant says it needs 221978913 gb for one user folder

    I am attempting to migrate a colleague of mine from a PowerMac G5 2.0 DP running 10.4.8 to a Mac Pro 2x2.66 machine running 10.4.8 as well.
    I have the old machine hooked up via a firewire cable and idling in target disk mode. On the new machine I login as an user with administrative rights, start up the migration assistant and let it calculate (takes about 5 minutes). Then it says that it needs 221978913 gb for one of the user folders (the one basically being used and needing to migrate). Obviously this isn't correct. The user folder is pretty big (about 110gb) but definitely not 221978913 gb. Everything else such as Applications or the guest user account is the correct size.
    What do I need to do to make this work? I have a feeling its an alias pointing to itself or something like that, but the guy has thousands of files and projects in his folder... there's gotta be a quick and dirty way to find something like that (perhaps a find command or applescript).
    Thanks guys,
    Yvo

    Hi Yvo:
    I've seen outlandish size estimates like that when the directory is messed up; the computer basically doesn't know where the files begin and end, and it comes up with some huge number for the size of the folder.
    Try using Disk Utility to Repair Disk on the G5. If it makes any repairs, try again until it finds no errors. Then try running the migration assistant again and see what it says.
    Good luck,
    Andrew Penner

  • Need differentiated support for "deny" vs "permit" in NX-OS QoS ACLs

    Does anyone know if a later version of NX-OS will be able to differentiate between "deny" vs "permit" in NX-OS QoS ACLs? The NX-OS QoS  documentation states that the permit and deny keywords are ignored for the purposes of matching in QoS class-maps.
    Here is the recent Cisco references.
    http://www.cisco.com/en/US/docs/switches/datacenter/sw/6_x/nx-os/qos/configuration/guide/classification.html#wp1124010
    and
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/qos/513_n2_1/b_Cisco_Nexus_5000_QoS_Config_Guide_513_N2_1_chapter_010.html#task_1135158
    I tested the N7K, and it does indeed ignore the
    permit and deny keywords. (DIscussion here, if you are interested...Deny Equals Permit in NX-OS QoS ACLs
    The impact - for QoS class-maps, both the deny and permit statements in the example below are matched:
    ip access-list test
      permit any 10.0.1.0 0.0.0.255
      deny ip any any
    This behavior does not follow what happens on 6500s and other IOS devices.

    Jerry -
    Any idea why? This breaks the ability to use moderately complex ACLs. For example - how would you configure scavenger class traffic to ignore some traffic, and mark other?
    Carole

  • Need to define multiple smtp servers for all accounts (1 for WIFI and MOBILE network)

    Hi.   I just bought a BB10 and so far, loving it.   My phone service provider is Telus but I do not use their email.   So when I am on the Telus network, my smtp server setting needs to be smtp.telus.net and when I am on WIFI, I need to point to smtp.cogeco.ca.   Home can I set this up?

    If I would have know this I would have bought an iPhone instead.  Actually, I will return the Z10 Monday and get the iPhone 5.   Enough is enough.

  • Using a different port for SMTP

    Where can I change my preference of port number for SMTP? I would like to use 366 since I think my ISP is blocking port 25.

    Your ISP blocks inbound and/or outbound 25?
    Port 25 is used for server-server communication and can't be changed.
    If your ISP blocks port 25 inbound, then your server can't receive mail from other servers, even if you change it's port.
    If your ISP blocks 25 outbound, you still need to send to a destination port 25. For outbound, the only thing you can do is relay through your ISP (either from client, or configure postfix to relay through ISP).
    When people add alternate ports for SMTP, it's for the mail client to submit mail to the server. From there, server-server is always going to have a dest port of 25.
    If you wish to add an alternate port (you said you wanted 366) for mail submission, edit /etc/postfix/master.cf
    Find this line:
    smtp inet n - n - - smtpd
    add another below it (location doesn't really matter) like this:
    366 inet n - n - - smtpd
    Then stop/start mail server and port 366 will accept smtp connections.
    FYI- the standard port for smtp submission is 587. Doesn't matter if you want to use another port (366), just make sure you're not trampling on another service which may use that port.
    Jeff

  • I NEED ADOBE SERVICE FOR A REFUND -- TONIGHT

    I'm ready to scream -- I was supposed to be transferred to the department for a refund and instead it timed out and ended my chat:
    The chat line is: (EMPHASIS ON THE RED FONT AREAS -- I NEED TO CANCEL DREAMWEAVER CS6 (AS I WAS ASSURED I WOULD HAVE NO PROBLEM DOING) AND GET A REFUND -- I JUST PURCHASED DREAMWEAVER CC.
    One moment please while we route your chat to a representative.
    All representatives are currently assisting others. Thanks for your patience. A representative will be with you shortly.
    Thank you for contacting Adobe Sales. My name is Gavin. How may I help you today?
    Gavin: Hi, may I have your first name please?
    you: Hi, my name is Barry.  I spoke with your chat line the other night, the night I purchased CS6.  I was on the fence, do I want CS6 (for about $400) or CC (with the ongoing $20 a month fee).  I was told that if I wanted to cancel CS6 and move to CC, it would be OK, since I had only installed CS6 and had not used it yet.  And that I could get the refund for CS6 and install CC at the same time.  At the moment, my purchase from Best Buys had not registered in your system, but I'm sure it has now.  SO THE QUESTION AGAIN -- could you discuss with me the pros and cons of CS6 vs. CC -- I have heard that I will not be able to update/upgrade CS6, that it is close-ended, and that CC will be a constant addition of latest features.  PLEASE ELUCIDATE ME ON WHICH PROGRAM I (A NEOPHYTE WHO JUST PAID SOMEONE TO BUILD ME A WEBSITE) MIGHT WANT TO USE.
    Gavin: Hello Barry
    Gavin: Let me explain that for you.
    you: Hi, -- can you read my lengthy question and provide me your insights, CS6 or CS CC?  Thanks, Gavin - I might have spoken with you the other night even.
    Gavin: No, its with other representative.
    Gavin: Adobe Creative Cloud is our newest option for you, That will give you everything , plus the ability to sync and store your files
    Gavin: If you purchase the software outright at once then you'll be paying the upgrade cost when new version releases but that is not the case when subscribed to Creative Cloud membership since you get free upgrades to future version and will remain current with the latest software tools.
    you: Is there some comparison sheet which would lay out the features and benefits of the two programs, side by side, for an educated decision?  I was told that CS6 if purchased outright is NOT UPGRADABLE -- wouldn't that lean me toward DW CC instead, to stay current as features are added and tools too?  IF THAT IS THE CASE, PLEASE REFUND ME THE CS6 COST AND SIGN ME UP FOR THE DW CC PROGRAM INSTEAD.  I was told you could transfer me to the folks in your place who could make this happen -- but I NEED IT DONE TONIGHT!  My website developer is coming tomorrow and needs an installed program to train me on.
    Gavin: We are connected, right?
    you: sorry, it took time to frame my question
    Gavin: That's okay.
    Gavin: Barry, I see that going forward all new versions will be through creative cloud membership.
    Gavin: I'll help you with the cancellation for your CS6 purchase made once you complete the sign up for Dreamweaver CC, Okay
    you: SO, HELP ME TO A DECISION, GAVIN.  What do I do?  Get the monthly fee program and turn in the CS6 for a refund?  HELP
    you: Lead the way -- BUT.... AND IT'S A BIG "BUT" -- will it be installed and functioning TONIGHT so my guy can train me tomorrow?  PLEASE ANSWER THEN let's get this new sign up & cancellation into action.
    Gavin: I see that there is no option to equalize the CS6 purchase for the CC subscription plan however you need to subscribe first and then will refund the CS6 purchase made.
    Gavin: After subscribing to Dreamweaver CC you can download/ install the software immediately
    Gavin: Sounds great, right?
    you: So you cannot help me -- what do I do?  How do I subscribe first, and how do I get the refund for CS6?  Please advise.  I'm ready to do it NOW! 
    Gavin: I'll help you now with the link to subscribe Dreamweaver CC and then help you to get the refund for CS6, Okay
    you: fantastic -- I'm at your disposal
    you: what do you need from me?
    Gavin: Please click here to subscribe
    Gavin: I'll stand by please let me know once your done.
    you: one last question -- as I said, I'm new to this -- can I later upgrade to Creative Cloud's whole family by just increasing my monthly payment by the difference?  please advise.
    Gavin: Yes, that's possible.
    Gavin: You can later switch or upgrade to complete creative cloud membership when you require other products.
    you: great - I'm purchasing now and will let you know when it goes through
    Gavin: Sure
    you: do I have to un-install CS6 first? PLEASE ADVISE - I'M STARTING TO DOWNLOAD AND DIDN'T THINK OF IT!!!!
    Gavin: Excellent!
    Gavin: You can uninstall CS6 version once you complete the download for CC.
    Gavin: Barry, please stay online while I transfer this chat to our Customer Service Team for more help on cancellation for your CS6 purchase made, Okay
    you: I am online, and DW CC has extracted and is half-way through the next step
    you: by the way, here's my proof of purchase--should I proceed through the entire installation and checking for upgrades.  Need I check for upgrades, or is this the latest version?
    you:   We received your payment - thank you! Here are the details about that order for your records:   Order Details:    Creative Cloud single-app membership for Dreamweaver (one-year) $19.99 per month Order # AD010920985  
    Gavin: Excellent!
    Gavin: Please run the download to install, mean while you cancel the order for CS6 purchase made, Okay.
    you: Ok - how do I cancel it?  Will you turn me over to that department to effect the cancellation?
    Gavin: Yes, please stay online while I transfer this chat.
    you: Dreamweaver CC is now installed.  Thanks for your help, Gavin.  I'm so nervous about this because I can't afford to screw it up and have my website guy come tomorrow and not be able to train me.
    Gavin: Not to worry!
    Please wait while I transfer you to an operator at Adobe Service.
    We are still assisting other customers, thank you for your patience. You can also try our community forums, where experts are online 24/7.
    We are still assisting other customers, thank you for your patience. You can also try our community forums, where experts are online 24/7.
    You are not currently connected to a chat representative.
    Your chat transcript will be sent to [email protected] at the end of your chat.
    We are still assisting other customers, thank you for your patience. You can also try our community forums, where experts are online 24/7.
    You are not currently connected to a chat representative.
    We are still assisting other customers, thank you for your patience. You can also try our community forums, where experts are online 24/7.
    You are not currently connected to a chat representative.

    Hello Barry,
    as one of these DW fans here, I'm very surprised and disappointed how your chat passed off. And I can fully understand your immeasurable disappointment. So I/we won't give up this quickly. Maybe you would succeed by using the written form. The employees have time to reflect your problem in an optional way. Please try it once more and use this form for "Sales Inquiries" (Contact us online):
    http://www.adobe.com/products/request-consultation/marketing-cloud.html?promoid=KAWSG
    Good luck!
    Hans-Günter

Maybe you are looking for

  • How do you delete a MegaRAID logical volume?

    I have a G5 Xserve with the MegaRAID card and three 250gb disks.  When it was installed years ago we created several Raid 5 logical volumes that used up all the space on the disks.  We're repurposing the system and I would like to simplify things by

  • Automatic Routing

    Hello All, We are using CRM 2005. We use rule modeler (context =order routing) when an agent clicks on Escalate Button, In automatic routing a set of predefined rules are defined where based on the conditions the routing takes place to the respective

  • Photoshop CS5.5 Save For Web UI extra border Bug

    I have observed on two different Win7 32bit workstations with Photoshop 12.1 x32 from Adobe Design Premium CS 5.5 that save for web seems to add an extra pixel of workspace background grey to the inside black border of the image display on the right

  • Data guard - recreate primary

    hi all! I have following question: We have development database which is frequently deleted and recreated from production base. Now we will implement logical standby for this development base, where we will create some additional objects. What will h

  • My new Macbook Pro 13 keeps minimizing full screen applications and sending me back to the desktop. Any Help?

    I can't stay in full screen applications without being returned to the desktop within 30 seconds. Is anyone else experiencing this problem or can assist I am testing it without running any applications other than safari in full screen. It act like it