Need help identifying why my fonts look horrible

I reinstalled Arch on my desktop, but forgot to backup my font configuration files.  I had Monaco set up very nicely before, but now it looks horrible on my new install, and I can't really see what I'm doing wrong. As far as I know, I was just using the ttf-monaco, freetype2-infinality and fontconfig-infinality (w/ osx2 style) packages, and then modified the infinality.conf file (with emboldened Monaco) and Xresources.
This is what it looked like before:
http://i.imgur.com/dFJRKbt.png
This is what it looks like now:
http://i.imgur.com/QHsLTF3.png
~/.Xresources
Xft.antialias: true
Xft.hinting: false
Xft.rgba: rgb
Xft.dpi: 96
/etc/fonts/infinality/infinality.conf
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
<selectfont>
<rejectfont>
<pattern>
<patelt name="fontformat" >
<string>Type 1</string>
</patelt>
</pattern>
</rejectfont>
</selectfont>
<match target="font" >
<edit name="embeddedbitmap" mode="assign">
<bool>false</bool>
</edit>
</match>
<match target="pattern" >
<edit name="prefer_outline" mode="assign">
<bool>true</bool>
</edit>
</match>
<match target="pattern" >
<edit name="do_substitutions" mode="assign">
<bool>true</bool>
</edit>
</match>
<match target="pattern" >
<edit name="bitmap_monospace" mode="assign">
<bool>false</bool>
</edit>
</match>
<match target="font">
<edit name="force_autohint" mode="assign">
<bool>false</bool>
</edit>
</match>
<match target="pattern">
<edit name="dpi" mode="assign">
<double>96</double>
</edit>
</match>
<match target="pattern" >
<edit name="qt_use_subpixel_positioning" mode="assign">
<bool>false</bool>
</edit>
</match>
<match target="font">
<test name="family">
<string>Monaco</string>
</test>
<edit name="embolden" mode="assign">
<bool>true</bool>
</edit>
</match>
<include>infinality/conf.d</include>
</fontconfig>
Also, bold isn't showing up in termite but does in gvim? Not sure why that's happening.
Last edited by mpeebles (2014-01-06 11:51:11)

grepping for "font" in the termite git log, I stumbled upon this:
commit a05fdcd4d15316f258175e9a526058bad2c8e7ea
Author: Simon Gomizelj <[email protected]>
Date:   Sat Nov 23 20:37:18 2013 -0500
    better warning for no browser
...skipping...
    Config option to enable/disable bold font
which suggests that a feature to do exactly that (disable bold fonts) has been introduced to the termite codebase. I haven't used termite myself, but either reverting to an older revision than a05fdcd4d15316f258175e9a526058bad2c8e7ea or just enabling bold faces through the said config option could be a solution to your problem.
Last edited by elipp (2014-01-07 19:46:22)

Similar Messages

  • Hello everyone I need help! Why i cant Update to Mountain Lion if Im gonna try to update my Macbook Pro with Mac OS X 2.3 GHz Intel Core i5. It always says "Your Software is up to date" which is only Mac Os X ver. 10.7.5

    Hello everyone I need help! Why i cant Update to Mountain Lion if Im gonna try to update my Macbook Pro with Mac OS X 2.3 GHz Intel Core i5. It always says "Your Software is up to date" which is only Mac Os X ver. 10.7.5

    Not sure what exactly you did (or not), but it looks as if you should attempt doing it all again, only this time all right and by the book. Many millions have done so, and sure it'll work for you as well.
    If you've indeed purchased ML already, you'll find it exactly there in the App Store: under Purchases.

  • On Windows 7, CS6 all products, but especially need help with ID.  Fonts that are showing in other applications are not showing in ID.

    on Windows 7, CS6 all products, but especially need help with ID.  Fonts that are showing in other applications are not showing in ID.

    The ID Program folder will be relevant to your OS...
    I took a shot and right clicked on my Scripts Samples, choose reveal in Explorer and opened up the ID Program folder.
    As shown, there is a Fonts folder.
    Drag/Copy/Paste fonts to this folder.

  • I need help identifying an old Macintosh game: it was a painting game where you rode a roller coaster to an art museum and you got to pick what kind of art work you were going to make. This was the early 90's and I've been trying to hunt it down

    I need help identifying an old Macintosh game: it was a painting game where you rode a roller coaster to an art museum and you got to pick what kind of art work you were going to make. It was animated, 2D i believe. This was the early 90's and I've been trying to hunt it down. I think there was some kind of animal in it, a giraffe maybe?

    Could you be thinking of Microsoft Home's "Fine Artist" for Macintosh, as shown in this Amazon.com listing?  This program was bundled with the Performa series of Macs during the mid-90s.

  • I need help identifying which Magsafe Power Adapter I need for my Macbook Pro Model A1398, EMC 2673?

    I need help identifying which Magsafe Power Adapter I need for my Macbook Pro Model A1398, EMC 2673?

    Provided the computer-end fits, you are free to use one with a HIGHER Wattage rating. No damage whatsoever will be done to any component, but it will likely run cooler (but may be slightly heavier).
    If you use one with too LOW a Wattage rating, you will not be able to charge and run at the same time, and your computer's top speed (for its most intensive computations) will be limited.

  • My email address is ***********, Apple ID I forgot my password, why not send links that Reset Pass on my email, I need help than why? Contact Us By Email me back with ***********, Thanks

    My email address is ***********, Apple ID I forgot my password, why not send links that Reset Pass on my email, I need help than why? Contact Us By Email me back with ***********, Thanks
    <E-mails Edited by Host>

    You are not addressing Apple here. This is a user-supported technical support forum. If you have tried to restore your Apple ID using iForgot, then try contacting iTunes Customer Service.

  • MSI P67A-G43 (B3) - Need help identifying this postcode

    Need help identifying this postcode:
    CPU:i7-2600k
    Mobo:MSI P67A-G43 (B3)
    PSU: Corsair 750w
    GPU isn't the problem since I replaced it and still get this postcode. RAM isn't the problem since I've tried four different sticks one at a time in each slot and still get the postcode. Getting no live video from the GTX580 and no onboard video. I think either the mobo or the CPU is the problem, don't want to have to send both in for RMA so if anyone can help me identify the postcode that'd be great.

    Hey Ctrl
    Well I happen to have the same beep code on my motherboard (P67A-C43 B3), after trying different suggestions from the MSI forum users and MSI technical support I ended up RMA(ing) my motherboard.
    You can try resetting the CMOS, by flipping the battery and leaving it like that for 5 minutes and putting it back to its original side. I highly doubt it is your cpu. Like anybody in the forum might suggest, try different components which appears you already did. I doubt your corsair is faulty. CPU and motherboard are your best bet that are faulty, and i highly doubt that it is the CPU because for there to find another person (you) that had the same problem as me since last friday (RMA board yesterday, wednesday) I find it highly unlikely.

  • Need help in finding a font for a logo

    I was looking for help in finding a font for my logo. I'm not a designer at all, so I'm calling on all the fine designers and folks on the Adobe site to help me out. All replies are, of course, appreciated and any suggestions/comments/ideas will be welcome.
    I'm designing a logo for my film company. I wanted to keep it simple but not boring either. I put together the first draft of the logo using Photoshop CS3 and used Trajan Pro for the film company words (Panthera Films) and used Futura for the slogan ("Inspiration through Imagination"). While I don't mind the fonts, it's simple but, alas, too boring. I love the panther image but need a dynamic font for "Panthera Films" and a complimenting font for the slogan. 
    Can anyone recommend a good combination of fonts to replace the Trajan Pro and Futura? As well, I want to give the logo a nice presence without it being too loud, bold or jumping off the page. As well, should the font for "Films" be the same as "Panthera" or can they be different?
    The image I attached is something I was thinking to use as a banner on a website.
    Any help would be appreciated too with this
    TIA,
    Dale

    Dale,
    As I said, I like it too.
    You may consider making it a bit heavier, maybe bold, for readability at small sizes.
    It is hard to recommend a specific font because it should represent your company and what it stands for. Have you tried typing the name in a word processing application (Worst or something better) and then running through all the font you have? If not, that might give you a few new thoughts about the overall kind of font you feel is the right one. And then it is much easier to recommend something.

  • Need help determining why my nothing is showing up after setting up site to site vpn

    Ok, so I'm am trying to figure out why I can't get nothing to show up when I do sh crypto isakmp sa or sh crypto ipsec sa. I did the basic setup for a site to site vpn and I can ping across both networks just fine no problem. So when I ping from a pc in the 172.16.0.0 network to 192.168.0.0 network there is no problem at all because the pings are recieved just fine. But when I go to sh crypto isakmp sa, there is just nothing there and I can't for the life of me figure out why. I looked at my sh run for both routers and everything looks fine, but I guess I may be overlooking something. If someone could help me diagnose this problem I would truely appreciate.   I have attached my packet tracer file and both routers are using the password binary. I put the password on there for the sake of it and to have a more real feel.

    Here are the show runs for both routers
    Router Main A
    hostname RmainA
    ip dhcp pool ITS
    network 172.16.150.0 255.255.255.0
    default-router 172.16.150.1
    option 150 ip 172.16.150.1
    username ciscosdm privilege 15 password 0 ciscosdm
    crypto isakmp policy 2
    encr aes 128
    authentication pre-share
    group 2
    crypto isakmp key binary address 192.0.2.27
    crypto ipsec transform-set yasser esp-aes 128 esp-sha-hmac
    crypto map vader 100 ipsec-isakmp
    set peer 192.0.2.27
    set pfs group2
    set transform-set yasser
    match address S2S-VPN-TRAFFIC
    no ip domain-lookup
    spanning-tree mode pvst
    interface Loopback0
    ip address 172.16.95.100 255.255.255.255
    interface FastEthernet0/0
    ip address 192.0.2.25 255.255.255.248
    duplex auto
    speed auto
    crypto map vader
    interface FastEthernet0/0.1
    no ip address
    interface FastEthernet0/1
    description TRUNK TO MAIN SWITCH A
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/1.10
    encapsulation dot1Q 10
    ip address 172.16.10.1 255.255.255.240
    interface FastEthernet0/1.20
    encapsulation dot1Q 20
    ip address 172.16.20.1 255.255.255.0
    interface FastEthernet0/1.30
    encapsulation dot1Q 30
    ip address 172.16.30.1 255.255.255.0
    interface FastEthernet0/1.40
    encapsulation dot1Q 40
    ip address 172.16.40.1 255.255.255.0
    interface FastEthernet0/1.70
    encapsulation dot1Q 70
    ip address 172.16.70.1 255.255.255.0
    interface FastEthernet0/1.95
    encapsulation dot1Q 95
    ip address 172.16.95.1 255.255.255.240
    interface FastEthernet0/1.100
    encapsulation dot1Q 100
    ip address 172.16.100.1 255.255.255.0
    shutdown
    interface FastEthernet0/1.150
    encapsulation dot1Q 150
    ip address 172.16.150.1 255.255.255.0
    interface Serial0/0/0
    description TO BRANCH
    ip address 10.0.0.1 255.255.255.252
    clock rate 64000
    shutdown
    interface Serial0/0/1
    no ip address
    clock rate 125000
    shutdown
    interface Serial0/1/0
    no ip address
    clock rate 2000000
    shutdown
    interface Serial0/1/1
    no ip address
    clock rate 2000000
    shutdown
    interface FastEthernet1/0
    switchport mode access
    shutdown
    interface FastEthernet1/1
    switchport mode access
    shutdown
    interface FastEthernet1/2
    switchport mode access
    shutdown
    interface FastEthernet1/3
    switchport mode access
    shutdown
    interface FastEthernet1/4
    switchport mode access
    shutdown
    interface FastEthernet1/5
    switchport mode access
    shutdown
    interface FastEthernet1/6
    switchport mode access
    shutdown
    interface FastEthernet1/7
    switchport mode access
    shutdown
    interface FastEthernet1/8
    switchport mode access
    shutdown
    interface FastEthernet1/9
    switchport mode access
    shutdown
    interface FastEthernet1/10
    switchport mode access
    shutdown
    interface FastEthernet1/11
    switchport mode access
    shutdown
    interface FastEthernet1/12
    switchport mode access
    shutdown
    interface FastEthernet1/13
    switchport mode access
    shutdown
    interface FastEthernet1/14
    switchport mode access
    shutdown
    interface FastEthernet1/15
    switchport mode access
    shutdown
    interface Vlan1
    no ip address
    shutdown
    router ospf 1
    log-adjacency-changes
    network 10.0.0.0 0.0.0.3 area 0
    network 192.0.2.24 0.0.0.7 area 0
    network 172.16.0.0 0.0.0.255 area 1
    network 172.16.1.0 0.0.0.255 area 1
    network 172.16.10.0 0.0.0.255 area 1
    network 172.16.20.0 0.0.0.255 area 1
    network 172.16.30.0 0.0.0.255 area 1
    network 172.16.70.0 0.0.0.255 area 1
    network 172.16.95.1 0.0.0.0 area 1
    network 172.16.95.0 0.0.0.15 area 1
    network 172.16.100.0 0.0.0.3 area 1
    network 172.16.150.0 0.0.0.255 area 1
    network 0.0.0.0 255.255.255.255 area 1
    default-information originate
    ip classless
    ip default-network 10.0.0.0
    ip access-list extended S2S-VPN-TRAFFIC
    permit ip 172.16.0.0 0.0.0.255 192.168.0.0 0.0.0.255
    dial-peer voice 150 voip
    destination-pattern 20..
    session target ipv4:192.168.150.1
    telephony-service
    max-ephones 30
    max-dn 30
    ip source-address 172.16.150.1 port 2000
    auto assign 1 to 30
    ephone 1
    device-security-mode none
    mac-address 0014.6AAC.2355
    type 7960
    ephone 2
    device-security-mode none
    ephone 3
    device-security-mode none
    ephone 4
    device-security-mode none
    ephone 5
    device-security-mode none
    ephone 6
    device-security-mode none
    ephone 7
    device-security-mode none
    ephone 8
    device-security-mode none
    ephone 9
    device-security-mode none
    ephone 10
    device-security-mode none
    ephone 11
    device-security-mode none
    ephone 12
    device-security-mode none
    ephone 13
    device-security-mode none
    ephone 14
    device-security-mode none
    ephone 15
    device-security-mode none
    ephone 16
    device-security-mode none
    ephone 17
    device-security-mode none
    ephone 18
    device-security-mode none
    ephone 19
    device-security-mode none
    ephone 20
    device-security-mode none
    ephone 21
    device-security-mode none
    ephone 22
    device-security-mode none
    ephone 23
    device-security-mode none
    ephone 24
    device-security-mode none
    ephone 25
    device-security-mode none
    ephone 26
    device-security-mode none
    ephone 27
    device-security-mode none
    ephone 28
    device-security-mode none
    ephone 29
    device-security-mode none
    ephone 30
    device-security-mode none
    line con 0
    exec-timeout 90 0
    password binary
    logging synchronous
    login
    line vty 0 4
    password binary
    login local
    end

  • Help with exporting. Video looks horrible after export, but great when in premiere pro

    Hey guys, looking for some advice on exporting.
    When I finish a video, the color and everything looks great while in premiere pro, but after exporting it, the color ends up looking dull and the whole video looks blurry.  I'm filming with a canon vixia hf200 at 60i. It imports as a AVCHD file, I deinterlace it, and then export at the Vimeo HD settings. What can be causing the video to look horrible after exporting? What settings should I be exporting under? Any help would be appreciated!

    It looks like you're coming up against some of the colorspace handling issues that the Premiere pipeline has.
    Since your source is 60i AVCHD it's HD and thus rec709 colorspace. If it gets encoded with the standard rec601 colorspace (SD sizes are this) then all the colors get crushed. Look for a "709" and "601" radio button in your export settings. If it's not there you're out of luck.
    The "blurry" is probably a poor quality de-interlacer. If Vimeo permits interlaced vs progressive do that instead. it's always cleaner to stay in the same video format all the way through.
    TECHNICAL ASIDE:
    rec709 is a triangle of possible colors that can be expressed by mixing of ratios of 3 emitters (the R G B corners of the triangle). (they are the RGB phosphors of a CRT and now LCD pixel elements)
    rec709 is a bigger triangle than rec601 so it's capable of more colors. but if you accidently map that triangle's corners to the coordinates of rec601 it gets crushed.
    In photography the "sRGB" uses the rec709 triangle. A bigger triangle that that is "Adobe RGB". So if you work in Adobe RGB and export to sRGB without conversion the colors get crushed because sRGB in inside the triangle of "Adobe RGB".
    http://en.wikipedia.org/wiki/Srgb
    http://en.wikipedia.org/wiki/Rec._709
    http://upload.wikimedia.org/wikipedia/commons/8/8f/CIExy1931_sRGB.svg

  • JDeveloper11g - code editor font looks horrible

    Why is it that my preferred coding font (Consolas - fixed-Width font) looks like sh.t in JDeveloper 11g? And is there any way to improve that?
    I'm using Java6
    -J.

    Frank,
    It would be nice if JDeveloper team can add support for additional nice looking fonts in the next release. The default fonts in Micorsoft Visual Studio in Vista looks really great. If the above is not possible, I would appreciate if you can add support for "courier" font (not courier new) since that is one of the fonts that I think will be used by a lot.
    Thanks
    Bala.

  • Need help identifying controller information in hyperdraw

    Hello,
    Sorry if this is a dumb questions, but I'm in the middle of a project and need help ASAP. In one of my tracks (Real Guitar) there is some form of controller information present at the start of the track and I have no clue what it is! Is there a preference/key command that shows all data in hyperdraw, and then lets you select it (similar to the way the matrix editor works if you double click in the background, and then click on a specific note?)
    Thanks in advance for any help you can provide!

    Jonathan,
    I use the method that Jim suggested. I have the "H" key programmed for autodefine. (I've also got another two keys programmed to simply turn hyperdraw on and off for the selected region(s)). Autodefine is very cool. If there are, say, 4 different controllers in the track, hitting H the first time will show you the lowest-numbered controller; hit it again and it shows you the next higher number controller, and so on. The controller number is displayed in the lower LH area of the hyperdraw display for each region.
    If a track contains controller information for multiple channels, you'll see two numeric values in the lower LH corner -- the controller number and MIDI channel for that controller, separated by a comma.

  • I need help diagnosing why my Macbook pro is crashing my internet?

    Hi, I need help diagnosing a problem with my macbook pro early 2011.  For the past two weeks all of a sudden my internet was crashing and really slow. Finally I was getting so fed up I called my internet provider and we ruled out that it isnt the cable modem or router.  When I turned my macbook off everything was working fine and all my tablets and apple TV was streaming fine with the speeds I pay for.  I've already went to the genius bar and they did a clean install of maverick.  After the clean install the internet worked for one day and the next day when I got home at night it stopped working. Went to the genius bar once more and took my router and the problem was encountering the same at the store we reseted the router and everything worked fine again.  When I got home I reseted the router setup up with new ssisd and same problem internet crashing. Finally I decided to make another account and the internet was working fine again. Before going to my second trip to the genius bar I made a second account which was working good with good internet speeds, but I still decided to go in cause I don't want to have to have multiple accounts since I'm the only user.  Right now the only way the internet isn't crashing is using another account rather than the administer account. Please help cause I've already went to the apple store twice and feel like I'm at the end of the road and never going to fix the problem

    When you next have the problem, note the exact time: hour, minute, second.
    If you have more than one user account, these instructions must be carried out as an administrator.
    Launch the Console application in any of the following ways:
    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.
    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select
    View ▹ Show Log List
    from the menu bar.
    Scroll back in the log to the time you noted above. Select any messages timestamped from then until the end of the episode, or until they start to repeat, whichever comes first. Copy the messages to the Clipboard by pressing the key combination command-C. Paste into a reply to this message (command-V).
    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.
    Please do not indiscriminately dump thousands of lines from the log into this discussion.
    Important: Some private information, such as your name, may appear in the log. Anonymize before posting.

  • Need help identifying a font

    I've been asked to finalize this web site
    http://www.ru308.com/
    I want to make a clean version of the logo, without the
    grainy background.
    Can anyone help me identify the font used for the company
    name?
    RUSSELL INDUSTRIES, INC.
    Or suggest a good resource that can help me identify the
    font?
    Thanks in advance
    Steve
    Adobe Community Expert: Authorware, Flash Mobile and Devices
    http://www.magnoliamultimedia.com
    You need to go to MAX -
    http://adobemax2007.com/na/

    My Fonts - What the Font? A great resource!
    http://www.myfonts.com/WhatTheFont/
    --Nancy O.
    Alt-Web Design & Publishing
    www.alt-web.com
    "Steve Howard" <[email protected]> wrote in
    message
    news:f95ijg$7ra$[email protected]..
    > I've been asked to finalize this web site
    >
    >
    http://www.ru308.com/
    >
    > I want to make a clean version of the logo, without the
    grainy background.
    > Can anyone help me identify the font used for the
    company name?
    >
    > RUSSELL INDUSTRIES, INC.
    >
    >
    > Or suggest a good resource that can help me identify the
    font?
    >
    > Thanks in advance
    >
    > Steve
    >
    > --
    > Adobe Community Expert: Authorware, Flash Mobile and
    Devices
    >
    http://www.magnoliamultimedia.com
    >
    > You need to go to MAX -
    http://adobemax2007.com/na/
    >

  • Need help on setting large fonts on iphone 3g s

    I have looked at the new iphone 3g s, and think I would like it very muuch. However, since I am somewhat visually impaired, I need large fonts on ALL categories on the phone, e-mail, contacts, notes, etc.
    I have looked at the phone at my local Apple store, but cannot find a way for the fonts to become larger. I go to settings, set the font to GIANT, but then NOTHING changes when I then go back to contacts.
    I have tried the Zoom program, but that seems too complicated. I currently own a Kindle, and I love it because I merely hit one button, and I have the availability of 6 DIFFERENT FONT SIZES. Why isn't this type of software available for the iphone?
    I want to buy the iphone, but cannot unless I can read all data on the phone easily. ANY HELP OUT THERE IS APPRECIATED.
    Dan

    Copied from this link regarding the Zoom option.
    http://www.apple.com/iphone/how-to/#accessibility.zoom
    Many iPhone applications let you zoom in and out specific elements. For example, you can double-tap or use the pinch gesture to expand webpage columns in Safari. Zoom is a special accessibility feature that lets you magnify the entire screen of any application you’re using to help you see what’s on the display.
    If the Zoom feature seems to complicated for you, then you don't have any other option with the iPhone. More than likely it would not seem so complicated to you after using it for several days or for a week or two. The iPhone can be returned for payment credit within 30 days after the purchased date, less a 10% restocking fee. And the AT&T contract can be cancelled within the same 30 days with no penalty.

Maybe you are looking for

  • RESTfull java Web Services....the best framework?

    Hi, I am currently working on Spring framework, ant build tool and Tomcat. I am planning to implement RESTful web services in my application. Any idea which framework is best to use and Can any one suggest me few good books? Your help is greatly appr

  • OK post all your 2.0 problems here!

    Here are the list of my problems:- 1) App store is good but crashes all so often. 2) Youtube app cannot connect to net when my safari app is browsing with breeze. 3) Music app does not have recently played to recently added playlists. 4) When syncing

  • ITunes 8 crashes while watching video

    Since I upgraded to iTunes 8.0 last night iTunes crashes while watching video content downloaded from the iTunes store. This happens after about 8 minutes of video and then begins to degrade in quality (sound and video fall out of sync) until finally

  • TS3694 Tried to update to ios 6 please help

    Tried to update to ios 6 and the download got to 99% before error code 3194 displayed and I cannot reload any software now, please help

  • Firmeware issues with Creative Zen Vision:M

    My creative Zen vision m 30g had started playing up, songs were being played super fast, or not being played at all, it would also go to FM radio randomly. The first step I took was to format the player and put my music back on, but the problem persi