Need help with gallery showing .jpg AND .swf

Hi all,
I have an image gallery that loads images and swf-files from an XML-file. The .jpg's load and display just fine, but the .swf files won't show. The data is loaded though. Any help is greatly appreciated!
Thanks so much in advance,
Dirk
My XML file looks like this:
<?xml version="1.0" encoding="UTF-8" ?>
- <slideshow>
<image src="photo1.jpg" time="1" title="test" desc="test" artist="sabre" link="" target="_self" />
<image src="photo2.jpg" time="3" title="test2" desc="test2desc" artist="sabre" link="" target="_self" />
<image src="flash1.swf" time="2" title="test3" desc="test3desc" artist="sabre" link="" target="_self" />
</slideshow>
And the AS3:
// import tweener
import caurina.transitions.Tweener;
// delay between slides
const TIMER_DELAY:int = 5000;
// fade time between slides
const FADE_TIME:Number = 1;
// flag for knowing if slideshow is playing
var bolPlaying:Boolean = true;
// reference to the current slider container
var currentContainer:Sprite;
// index of the current slide
var intCurrentSlide:int = -1;
// total slides
var intSlideCount:int;
// timer for switching slides
var slideTimer:Timer;
// slides holder
var sprContainer1:Sprite;
var sprContainer2:Sprite;
// slides loader
var slideLoader:Loader;
// current slide link
var strLink:String = "";
// current slide link target
var strTarget:String = "";
// url to slideshow xml
var strXMLPath:String = "xml.xml";
// slideshow xml loader
var xmlLoader:URLLoader;
// slideshow xml
var xmlSlideshow:XML;
function initSlideshow():void {
// hide buttons, labels and link
mcInfo.visible = false;
btnLink.visible = false;
var request:URLRequest = new URLRequest (strXMLPath);
request.method = URLRequestMethod.POST;
var variables:URLVariables = new URLVariables();
variables.memberID = root.loaderInfo.parameters.memberID;
request.data = variables;
var loader:URLLoader = new URLLoader (request);
loader.addEventListener(Event.COMPLETE, onXMLLoadComplete);
loader.dataFormat = URLLoaderDataFormat.VARIABLES;
loader.load(request);
// create new timer with delay from constant
slideTimer = new Timer(TIMER_DELAY);
// add event listener for timer event
slideTimer.addEventListener(TimerEvent.TIMER, nextSlide);
// create 2 container sprite which will hold the slides and
// add them to the masked movieclip
sprContainer1 = new Sprite();
sprContainer2 = new Sprite();
mcSlideHolder.addChild(sprContainer1);
mcSlideHolder.addChild(sprContainer2);
// keep a reference of the container which is currently
// in the front
currentContainer = sprContainer2;
// add event listeners for buttons
btnLink.addEventListener(MouseEvent.CLICK, goToWebsite);
btnLink.addEventListener(MouseEvent.ROLL_OVER, showDescription);
btnLink.addEventListener(MouseEvent.ROLL_OUT, hideDescription);
mcInfo.btnPlay.addEventListener(MouseEvent.CLICK, togglePause);
mcInfo.btnPause.addEventListener(MouseEvent.CLICK, togglePause);
mcInfo.btnNext.addEventListener(MouseEvent.CLICK, nextSlide);
mcInfo.btnPrevious.addEventListener(MouseEvent.CLICK, previousSlide);
// hide play button
mcInfo.btnPlay.visible = false;
function onXMLLoadComplete(e:Event):void {
// show buttons, labels and link
mcInfo.visible = true;
btnLink.visible = true;
// create new xml with the received data
xmlSlideshow = new XML(e.target.data);
var  unesc_xmlSlideshow:XML = new XML(unescape(xmlSlideshow));
// get total slide count
intSlideCount = unesc_xmlSlideshow..image.length();
// switch the first slide without a delay
switchSlide(0);
function fadeSlideIn(e:Event):void {
var  unesc_xmlSlideshow:XML = new XML(unescape(xmlSlideshow));
// add loaded slide from slide loader to the
// current container
addSlideContent();
// clear preloader text
mcInfo.lbl_loading.text = "";
// check if the slideshow is currently playing
// if so, show time to the next slide. If not, show
// a status message
if(bolPlaying) {
  mcInfo.lbl_loading.text = "Next slide in " + unesc_xmlSlideshow..image[intCurrentSlide].@time + " sec.";
} else {
  mcInfo.lbl_loading.text = "Slideshow paused";
// fade the current container in and start the slide timer
// when the tween is finished
Tweener.addTween(currentContainer, {alpha:1, time:FADE_TIME, onComplete:onSlideFadeIn});
function onSlideFadeIn():void {
// check, if the slideshow is currently playing
// if so, start the timer again
if(bolPlaying && !slideTimer.running)
  slideTimer.start();
function togglePause(e:MouseEvent):void {
var  unesc_xmlSlideshow:XML = new XML(unescape(xmlSlideshow));
// check if the slideshow is currently playing
if(bolPlaying) {
  // show play button
  mcInfo.btnPlay.visible = true;
  mcInfo.btnPause.visible = false;
  // set playing flag to false
  bolPlaying = false;
  // set status message
  mcInfo.lbl_loading.text = "Slideshow paused";
  // stop the timer
  slideTimer.stop();
} else {
  // show pause button
  mcInfo.btnPlay.visible = false;
  mcInfo.btnPause.visible = true;
  // set playing flag to true
  bolPlaying = true;
  // show time to next slide
  mcInfo.lbl_loading.text = "Next slide in " + unesc_xmlSlideshow..image[intCurrentSlide].@time + " sec.";
  // reset and start timer
  slideTimer.reset();
  slideTimer.start();
function switchSlide(intSlide:int):void {
// check if the last slide is still fading in
if(!Tweener.isTweening(currentContainer)) {
  // check, if the timer is running (needed for the
  // very first switch of the slide)
  if(slideTimer.running)
   slideTimer.stop();
  // change slide index
  intCurrentSlide = intSlide;
  // check which container is currently in the front and
  // assign currentContainer to the one that's in the back with
  // the old slide
  if(currentContainer == sprContainer2)
   currentContainer = sprContainer1;
  else
   currentContainer = sprContainer2;
  // hide the old slide
  currentContainer.alpha = 0;
  // bring the old slide to the front
  mcSlideHolder.swapChildren(sprContainer2, sprContainer1);
  // delete loaded content
  clearLoader();
  // create a new loader for the slide
  slideLoader = new Loader();
  // add event listener when slide is loaded
  slideLoader.contentLoaderInfo.addEventListener(Event.COMPLETE, fadeSlideIn);
  // add event listener for the progress
  slideLoader.contentLoaderInfo.addEventListener(ProgressEvent.PROGRESS, showProgress);
  var  unesc_xmlSlideshow:XML = new XML(unescape(xmlSlideshow));
  // load the next slide, seems to f*ck up here...
  slideLoader.load(new URLRequest(unesc_xmlSlideshow..image[intCurrentSlide].@src));
  // show description of the next slide
  mcInfo.lbl_description.text = unesc_xmlSlideshow..image[intCurrentSlide].@title;
  // show artist's name of the next slide
  mcInfo.lbl_artist.text = unesc_xmlSlideshow..image[intCurrentSlide].@artist;
  // set link and link target variable of the slide
  strLink           = unesc_xmlSlideshow..image[intCurrentSlide].@link;
  strTarget          = unesc_xmlSlideshow..image[intCurrentSlide].@target;
  mcInfo.mcDescription.lbl_description.htmlText = unesc_xmlSlideshow..image[intCurrentSlide].@desc;
  // show current slide and total slides
  //mcInfo.lbl_count.text = (intCurrentSlide + 1) + " / " + intSlideCount + " Slides";
  mcInfo.lbl_count.text = " Slide " + (intCurrentSlide + 1) + " / " + intSlideCount;
function showProgress(e:ProgressEvent):void {
// show percentage of the bytes loaded from the current slide
mcInfo.lbl_loading.text = "Loading..." + Math.ceil(e.bytesLoaded * 100 / e.bytesTotal) + "%";
function goToWebsite(e:MouseEvent):void {
// check if the strLink is not empty and open the link in the
// defined target window
if(strLink != "" && strLink != null) {
  navigateToURL(new URLRequest(strLink), strTarget);
function nextSlide(e:Event = null):void {
// check, if there are any slides left, if so, increment slide
// index
if(intCurrentSlide + 1 < intSlideCount)
  switchSlide(intCurrentSlide + 1);
// if not, start slideshow from beginning
else
  switchSlide(0);
function previousSlide(e:Event = null):void {
// check, if there are any slides left, if so, decrement slide
// index
if(intCurrentSlide - 1 >= 0)
  switchSlide(intCurrentSlide - 1);
// if not, start slideshow from the last slide
else
  switchSlide(intSlideCount - 1);
function showDescription(e:MouseEvent):void {
// remove tweens
Tweener.removeTweens(mcInfo.mcDescription);
// fade in the description
Tweener.addTween(mcInfo.mcDescription, {alpha:1, time:0.5, y: -1});
function hideDescription(e:MouseEvent):void {
// remove tweens
Tweener.removeTweens(mcInfo.mcDescription);
// fade out the description
Tweener.addTween(mcInfo.mcDescription, {alpha:0, alpha:1, time:0.5, y: 30});
function clearLoader():void {
try {
  // get loader info object
  var li:LoaderInfo = slideLoader.contentLoaderInfo;
  // check if content is bitmap and delete it
  if(li.childAllowsParent && li.content is Bitmap){
   (li.content as Bitmap).bitmapData.dispose();
} catch(e:*) {}
function addSlideContent():void {
// empty current slide and delete previous bitmap
while(currentContainer.numChildren){Bitmap(currentContainer.getChildAt(0)).bitmapData.disp ose(); currentContainer.removeChildAt(0);}
// create a new bitmap with the slider content, clone it and add it to the slider container
var bitMp:Bitmap =  new Bitmap(Bitmap(slideLoader.contentLoaderInfo.content).bitmapData.clone());
currentContainer.addChild(bitMp);
// init slideshow
initSlideshow();

I'm sorry, you're right! Didn't intend to be lazy...
This line loads the image in the loader 'slideLoader'. This seems to work fine with image files (.jpg), but .swf files are ignored. Is it possible to load both .jpg AND .swf files in a loader, or do I have to use some other method for this?
slideLoader.load(new URLRequest(unesc_xmlSlideshow..image[intCurrentSlide].@src));
Thanks again,
Dirk

Similar Messages

  • Need help with my iPhone 5 and my Macbook Pro.

    Need help with my iPhone 5 and my Macbook Pro.  I was purchased some music on itunes at my mac. Some reason I deleted those music from both on Mac and iPhone 5.  Today, I went to my iPhone iTunes store inside of iCloud to redownload my puchased. But those song won't able to sync back to my iTunes library on my Mac.  Can anyone help me with that ??....
    iPhone 5, iOS 6.0.1

    You've posted to the iTunes Match forum, which your question does not appear to be related to. You'll get better support responses by posting to either the iTunes for Mac or iTunes for Windows forum. Which ever is more appropriate for your situation.

  • I need help with my text tone and I have ring tone. no text tone for the 4s.

    I need help with my text tone. I have ring tone no text tone. I have a 4s.

        Hi Sarar2333!  Let's get your text tones working again!
    Here's a link with instructions how to enable and change your alert sounds for your text/notification settings on your iPhone 4S: http://vz.to/1stiF8a.  You can ensure text tones are enabled by selecting a tone in the "Text Tone" setting.  Let me know how that works out for you.  Thanks!
    AnthonyTa_VZW
    Follow us on Twitter @VZWSupport

  • Need help with buying graphics card and ram for MSI 865PE NEO 2-V

    Hi,
    I want to buy 1GB of ram for motherboard MSI 865PE NEO 2-V I need help with finding correct parts.
    I also want to buy 512Mb or 1GB graphics card.
    as i said before i need help with finding correct ones so they match motherboard, I would appreciate if any one would post link to cheap and fitting parts.
    I found graphics card allready, i just need to know if it will fit.
    the card is
    NVIDIA GeForce 7600 GS (512 MB) AGP Graphics Card
    Thanks for help.

    here you can see test reports for your mobo:
    http://www.msi.com/product/mb/865PE-Neo2-V.html#?div=TestReport

  • Need help with clickbios ii terminolgy and values. Z77A-GD65 / 3770k

    Hello All 
    I recently purchased a Z77A-GD65 board and after searching I've found the differences in terminology between this and my previous Asus board but still have a couple of settings I cant find any info on.
    System Specs:
    motherboard: msi z77a-gd65
    cpu: intel 3770k
    ram: corsair vengeance 2133mhz 1.5v
    psu: corsair 850w
    First things first is I believe I am running in turbo oc mode. I've selected the oc genie tab on the center right of the bios screen and proceeded to change settings there. With cpu voltage on auto and vdroop set to 50% at 4.6ghz. (I'll try and get screenshots of bios settings soon)
    The following are the terms I need help with:
    In the my oc genie section;
     1. Long duration power limit
     2. Long duration maintained
     3. Short duration power limit
    In the main overclocking section;
     4. Digital Compensation level (not in owners manual, options auto/high)
     5. Cpu core ocp expander (enabled for overclock 4.5ghz+?)
    In the CPU Features section;
     6. long duration power limit w (does "w" stand for watts?)
     7. long duration maintained s   (does "s" stand for seconds?)
     8. short duration power limit
     9. primary plane current limit a  (does "a" stand for amps?)
    10. secondary plane current limit
    11. primary plane turbo power limit
    12. secondary plane turbo power
    I know those are a lot of settings, but would appreciate any simple definitions as to what they do and recommended values for mild overclocking (4.5-4.80)
    Also on my previous board (Asus P8P67 Pro) my 3770k was stable in prime95 for 18 hrs at 4.5ghz fixed 1.155v with only ram timings put in manually and LLC set to extreme.(or whatever max is called in asus bios) Voltage was fixed and everything else was defailts.

    Well I'm back.  Been digging around for a few days and found some answers to my questions.
    First things first s that for some reason I could not adjust voltage values with the + or - symbols. Clearing cmos did not help this. I had to reflash the bios to get this functionality back as well as clearing cmos before and after the flash.
    So I figured out the values in the oc genie section are the same as the normal section but only used when your using the oc genie. (numbers 1-3)
    Digital compensation level and ocp expander should be set to high and enabled respectively when going for higher overclocks. (4 and 5)
    Now for the rest of my questions ( 6 through 12) I have found suggested settings and some info after hours and hours of searching but still have a couple of questions about them.
    Long/short duration power limit, and primary/secondary plane turbo limit. I see suggestion settings of 250 or 255. I take it this is simply max supplied watts to the chip? If so why the 250/255 values? Is that the highest the board will give? Is plane turbo limit related to the enhanced turbo stated and how much wattage can be drawn there while the other limit is for any non turbo frequencies?
    Long duration maintained, I've seen 60 suggested a lot. Why is this?
    There's not an over abundance of info on these boards as compared to asus so it seems info is a little less documented and video tutorials explaining things are next to none.
    Any help would be appreciated. Thanks 

  • HT4528 I need help with my I phone and I can get verizon to let me on there to talk and I will have to have my phone so that I can do what you tell me to do

    I need help with my phone it is not ringing and I cant figure where in here to make it so it will something has been pushed so I cant hear any calls or texts

    Not when you insist on being so impatient.
    These are user to user support forums.  No one here is paid to read or respond to messages.
    Try explaining the issue instead of the jumbled, rambling mess of a title and we will be happy to assist.

  • Need help with Olympus E-M1 and ACR 8.3 Results

    Hi:
    1.  I'm fairly familiar with photoshop and ACR, but definitely not an expert.   I'm also very familiar with the Olympus RAW files since the E-5 (I've owned the E-5, E-M5 and several Pens);  I now recently purchased the E-M1 and I've been having problems getting decent images out of the RAW files (compared to the prior Olympus RAW files).
    2.  Problem:  it just "feels" that the overall tone curve is more abrupt, especially in the highlights.    With the prior Olympus RAW files, the transition from moving the exposure slider to the right and then getting blown out highlights was more gradual;   there just seems to be an overt decrease in "headroom" when dealing with highlights in the E-M1 RAW files.   I know this makes no sense in that the dynamic range is supposed to be greater with this camera compared to the prior ones.  
    3.  Problem:  In relation to the above issue, it also seems that the highlight slider is not as specific as it used to be in that when I move it to the left, more of the histogram seems to be affected as opposed to the bright / highlight region.   It now seems to  basically counteract any adjustments made to the exposure.   Again, this may be my imagination but it just feels this way.
    4.  Problem: In relation to the above issue, the other strange observation I've had is that although the histogram of the image shows no clipping, the image may have very bright areas with almost imperceptible detail;   when I click on it and view that data point within curves, it shows it to be well below 255.    In my lame flower shot example (it's not a good example but I couldn't find anything else right now), I would have guessed that in the brighest petal area, that it would be something like 250, but it's only 220.   But when I zoom in, there's really no texure or detail or data.  
    5.  The above issue in re: highlight rendering and control may or may not be related but it's the first time, I've been having issues and I've never had such problems with either ACR or prior Olympus cameras and thus I'm wondering if this is some issue with how ACR interprets the E-M1 file.  I did do some comparison with Capture One 7 and that does a definitely better job of highlight recovery in that it seems to more preferentially target just the highlights and definitely does a better job with color rendition.   I have Olympus Viewer 3, but it's so slow and lame, that I haven't done much testing with it.   Any thoughts and advice much much appreciated.

    Also, you might want to upload your raw file, a full-size JPG of what you posted, above, and an example from C1 to www.dropbox.com and post a public link, here, for others to experiment with.

  • Need Help with External Hard drives and too much music

    I am not terribly tech-savvy, and I need your help. I have a G5 PPC dual processor with an internal 250GB drive. I have two seagate firewire/USB2 external hard drives. One is 250GB and one is 350GB. I want to know how to use them to get my Mac to run faster and better.
    My original hard drive is 7GB shy of being full. Almost half of this is my itunes library which is over 100GB. The older (250GB) hard drive has about 150GB of photos/videos.
    My Mac is running slow as molasses and when I power up the external hard drives it slows down to what I recall my original Mac Plus ran like.
    I use the G5 primarily to work with photos, illustrations and creating the occasional DVD with video and photos. the apps I use most often are Photoshop, Illustrator and Painter. I always listen to music while work.
    I hope all of this information is helpful! Here is my question:
    What is the best way for me to set up and use these external hard drives to return my G5 to its original blazing (to me) fast speed?
    PPC G5 Mac OS X (10.4.9)

    I think you should look at adding two 500GB internal drives. I'd say Maxtor MaxLine Pro for cost, but they also run much warmer (43ºC even when nearly doing zilch) so I'd go with WD RE2 500GB for $40 ea. more.
    dump whatever you don't need, trash anything that is hogging space and is just temp file or useless cache. Web browsers can leave behind a ton of small files eating up tens of MBs.
    Use SuperDuper to backup/clone your drive.
    Disk Warrior 4 to repair (after it gets to 15% free, or just forget for now).
    A 250GB drive formats to 240GB and you have ~3% free it looks like.
    For every data drive plan to have two backup drives.
    Keep your boot drive to 40% used.
    And your data drive to 60%.
    Backups can go a little higher.
    Drives are cheap and inexpensive, especially for the space and performance. And they have improved SATA over the years it has been out.
    By doing a backup followed by erasing your drive, and then restoring it, using SuperDuper, which optimizes the organization, skips copying temp files that aren't needed, it also defragments your files. I would do backup daily to different sets that you "rotate." And before any OS update. And do the erase and restore probably every 2 months.
    Make sure you keep one drive partition somewhere that is just your disk utility emergency boot drive that is not a copy of working system, used for doing repairs like running Disk Warrior and Disk Utility.
    You may need to repair; backup; even erase and restore your external drives. Rather than spend on vendor made case, just pick up a good FireWire case either with drive, or bare (and add your own). I think it'd add 500GB FW drive though.
    Why?
    To begin backup of your current drive. To leave your other FW drives "as is" for now.
    Then install a new internal 500GB drive as well so you now have a good current backup, and you have moved your data off 250GB to 500GB. If anything happens, you have one off line FW backup.
    Then begin to clean up, organize, and get your FW drives working. It sure sounds like they have had some directory or file problems.
    You can find a lot of Firewire and SATA drive choices over at OWC:
    http://www.macsales.com/firewire/

  • Need help with configuring web root and root url URL

    Hello Folks,
    I have been trying for a while to the flex 4 tutorial which asks you to connect to a mysql database. I have been able to configure the DB but cannot figure out what my web root and root url should be. Is there a web service that needs to be deployed or started. Would it be the IP address of the database that I created ( I tried that ) . I get the idea that an apache service must be started somehow on my flex environment and then I must find the root of the apache server. I dont see an apache directory anywhere. I am finding this difficult to know where to begin.

    Hi,
    First you need to be running a web server on your computer something like wamp/mamp is usually the better choice as most people have had the best success with this server setup(and it has all the current services like php and myssql)
    When you use the wizard the path to your webroot is usually whre you located the wamp/mamp install, for windows it maybe something like c:\wamp\www not 100% sure about macs but I think the 'www' folder on a mac is 'htdocs'.
    your url is either http://localhost or http://127.0.0.1.
    David.

  • Need help with hp photosmart c8180 and wep code

    Hello,
    I am somewhat new with computers. The printer I have is an old one. HP Photosmart c8180 . When i followed the wizzard set up
    options I entered the wep that is on my lap top(also an HP) and that code was accepted by the printer, however, it will not print from the lap top everything says it is offline and in que. I cannot find a trouble shoot option or anything. Printer still reads "connected". Can anyone give me some ideas?
    Thanks...
    LR

    hello nurselulu67, I don't know why you were not able to print. Could you run the Print Diagnostic Utility in the link below?
    http://www.hp.com/go/tools
    edit: change the link. easier to remember
    Though I work for HP, I'm speaking for myself and not HP. I'm just trying to help with my limited knowledge
    **Make it easier for other people to find solutions, by marking my answer with "Accept as Solution" if it solves your issue.**

  • Need help with gallery plugin

    Hola
    I need your help (again) to figure it out
    why the lightbox plugin is not working in this site.
    http://mydsigner.com/claudia/gallery_manteca.html
    So you people know, this is the site that I asked before in this link;
    What's up with the new Adobe wants to use your confidential information thing
    Here is the original site;
    http://www.lascasuelasmexicanrestaurant.com/gallery/details.php?gallery=Manteca_4
    As you see here, ALL PAGES ARE PHP (?)
    Well, I managed to get the html pages, change some things,
    all working well, but the gallery doesn't work, and I don't have any idea why.
    You see, the page has a link to a lightbox css that for a strange reason,
    I cannot find on the server
    ;href="/css/bootstrap-lightbox.min.css
    When I looked for that file, it's just not there, so
    I got a file from bootstrap and put it in there, but the lightbox still don't want to work.
    Need your wizard help here.
    Thanks a lot
    Saludos from California

    Hola Osgood
    Thats what's wrong - it should NOT be <script src="css/prettyPhoto.css"></script>
    It should be linking to the js file NOT the css file:
    <script src="http://mydsigner.com/claudia//js/jquery.prettyPhoto.js"></script>"
    How many 'likes" can I give you?
    This is the right answer !!!
    I knew something was wrong there, but cannot figure it out.
    Definitely I need to keep studying my everything about this stuff.
    Again, thanks a Lot !!!
    Saludos from California :-)

  • I need help with a flash nav and switching pages!!!

    is there anyway to point the browser to play a swf file from
    a specific point (labeled frame) in the movie after switching
    (html) pages?
    basically it's a nav bar that needs to be played from the end
    of the movie after the first opening (html)page.
    I know i can do this with frames, but i would love to avoid
    that if possible. and the only other option i know would be to have
    2 swf files. there has to be a "on(load) /gotoandplay() or some
    combination to make this work, it seems to be too close to not be
    possible.
    thanks for all the help.

    SHouldn't be too involved. Just set a variable with JS (or
    whatever
    language you can use, I used JS simply b/c you stated HTML
    pages, not PHP or
    ASP), then in your flash movie, have your first frame do a
    basic if/then or
    do a switch (if it's available in AS).
    if ($var==1){
    gotoAndPlay (1,1);
    elseif ($var--2){
    gotoAndPlay(1,2);
    etc.
    Alternately, you could set a session variable, but you would
    have to have
    dynamic pages to do that.
    "Dminadeo" <[email protected]> wrote in
    message
    news:elkjne$gei$[email protected]..
    >
    quote:
    Originally posted by:
    Newsgroup User
    > You could have your pages set a value on them, and read
    that value into
    > flash.
    >
    > Ie, say your value is set via javascript. I would
    imagine you could then
    > pass that to yoru flash movie, which would reference the
    place to start
    > before actually starting the movie.
    >
    > HTH,
    >
    > Jon
    >
    >
    > that sounds a little more involved than i thought it
    would be, but i'm
    > willing
    > to give it a shot. any other pointers?
    > thanks again
    >
    >
    >

  • 1941w - Need help with IP address assigning, and relay wireless to a DHCP server.

    Hope someone can point me in the right direction -
    Basically have a Win08 R2 DHCP server, and a 1941w router.
    I've got the internet, got the lan clients getting DHCP ok (with ip helper-address set on the 0/0 internal interface).
    Also have the SSID, and wireless clients can connect - but no IPs are being handed out, also not sure if I understand or did the bridging correctly or assigned IPs to the vlan or bvi1 correctly.
    for ex:
    DHCP server IP:
    10.10.2.4
    Router Ethernet internal interface 0/0 IP:
    10.10.2.1
    with helper-address 10.10.2.4 (lan clients are resolving IPs correctly from the DHCP server)
    Vlan1 IP address:
    10.10.3.1
    Does this interface need the helper-address as well? (10.10.2.4)?
    wlan-ap 0 IP address:
    unnumbered
    interface BVI1 IP address (static):
    10.10.2.2
    am i totally off? not even sure if i have the vlan bridged to the 0/0 adapter or not correctly - but as I said, i can get a wireless client to connect with the SSID.
    would appreciate any advice/pointers, thanks

    of course - here is the router config:
    =======================================================
    Using 5591 out of 262136 bytes
    version 15.1
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    hostname router
    boot-start-marker
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200
    logging console critical
    enable secret 5 $1$JWwK$.04.NFg7tQ82UTy68/hyv.
    no aaa new-model
    service-module wlan-ap 0 bootimage autonomous
    no ipv6 cef
    no ip source-route
    ip cef
    no ip bootp server
    ip name-server 10.10.2.4
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-975501586
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-975501586
    revocation-check none
    rsakeypair TP-self-signed-975501586
    crypto pki certificate chain TP-self-signed-975501586
    certificate self-signed 01 nvram:IOS-Self-Sig#3.cer
    license udi pid CISCO1941W-A/K9 sn FTX155085QG
    hw-module ism 0
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh authentication-retries 2
    interface Embedded-Service-Engine0/0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    shutdown
    interface GigabitEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$$ES_LAN$$FW_INSIDE$
    ip address 10.10.2.1 255.255.255.0
    ip helper-address 10.10.2.4
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    no mop enabled
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered GigabitEthernet0/0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    arp timeout 0
    no mop enabled
    no mop sysid
    interface GigabitEthernet0/1
    description $ES_WAN$$FW_OUTSIDE$
    ip address dhcp client-id GigabitEthernet0/1
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    no mop enabled
    interface Wlan-GigabitEthernet0/0
    description Internal switch interface connecting to the embedded AP
    no ip address
    interface Vlan1
    ip address 10.10.3.1 255.255.255.0
    ip helper-address 10.10.2.4
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list 1 interface GigabitEthernet0/1 overload
    logging trap debugging
    access-list 1 remark INSIDE_IF=GigabitEthernet0/0
    access-list 1 remark CCP_ACL Category=2
    access-list 1 permit 10.10.2.0 0.0.0.255
    no cdp run
    control-plane
    line con 0
    login local
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    line vty 5 15
    privilege level 15
    login local
    transport input telnet ssh
    scheduler allocate 20000 1000
    end
    =======================================================
    and the ap config:
    =======================================================
    Using 2067 out of 32768 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$xKDT$GdLGeA6h.H9LKL9l3dPmj.
    no aaa new-model
    dot11 syslog
    dot11 ssid WIFI1
       vlan 1
       authentication open
       authentication key-management wpa
       mbssid guest-mode
       wpa-psk ascii 7 044B1E030D2D43632A
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 1 mode ciphers aes-ccm
    broadcast-key vlan 1 change 30
    ssid WIFI1
    antenna gain 0
    station-role root
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    bridge-group 2 spanning-disabled
    interface Dot11Radio1
    no ip address
    no ip route-cache
    encryption vlan 1 mode ciphers aes-ccm
    broadcast-key vlan 1 change 30
    ssid WIFI1
    antenna gain 0
    dfs band 3 block
    channel dfs
    station-role root
    interface Dot11Radio1.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    bridge-group 2 spanning-disabled
    interface GigabitEthernet0
    description  the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache
    interface GigabitEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface BVI1
    ip address 10.10.2.2 255.255.255.0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    no activation-character
    line vty 0 4
    login local
    end
    ============================================

  • Desperately need help with a networked printer and SMB sharing for windows

    Complete xServ newbie here. I'm a windows/novell admin, with limited experience in Unix and Linux.
    Against my advice, a client of mine that owns a small office of 20 people bought an XServG5 to act as a server for 20 mixed Windows PCs. File sharing services are working fine. I've created the users, set up groups and rights - that's all good.
    I cannot get an SMB shared printer to work from the windows machines. They run through the network printer install just fine, it shows up online, etc. However, when print jobs are submitted they DO show up in the printer queue on the server, sit there for a while, and then get moved to the completed box.
    They never print. There's not any indication that the job is even submitted to the printer. I can print to the printer just fine from the server itself, but the windows clients don't work, but they don't return an error message.
    Print services are running on the server, I've configured the printer name to be less than 12 characters for the share, and indeed it does pop right up during the "add network printer" routine.
    Ideas? I'm not even sure what questions I'm supposed to be asking, such is my ignorance of the OS. I do know that I followed the documentation to a T, and according to Apple this should work.
    Thanks in advance for the help. I'm extremely frustrated.

    We have the same problem. Our printer worked for about 2 years but failed similar to yours after a system update.
    Can you go into the Windows service, Logs, Printer Service. Copy and paste the log here. What I am looking for is a line like lpr: CANNOTCONNECTCLIENT or something similar to this.
    What I expect is that you have a problem where the cups defined printer is not usable. We can't get our problem fixed either - but am just curious if you have the same thing. We reloaded our server, applied all of the update and still cannot get it to work.
    Again, I think it stems from the update.

  • Hard drive crash need help with new iTunes load and backup files

    I have looked through the posts and not found my situation.
    I had my iPhone synced to a PC computer and the hard drive crashed. I had an extensive library in iTunes, but none of the music was purchased online so I can't simply download it again. It was all from CD's, many of which belonged to friends. I now have an iMac. The music I like is still on my iPhone, but not on my new iMac. When I try to sync the iPhone with my iMac it wants to delete all the music on my iPhone. Is there any way to copy the music off my iPhone first - so I can add it back into my iTunes library?

    Yes, luckily I have been in this situation.
    You can download a free application that will take your music from your iPhone and place it onto your Macintosh HD.
    One of these should suit your needs:
    http://www.macupdate.com/app/mac/19890/ipoddisk
    http://www.wideanglesoftware.com/touchcopy/index.php?gclid=CPjvvOiyr6gCFaNl7Aodm h6QIQ
    http://www.headlightsoft.com/detune/
    I hope this helped.

Maybe you are looking for

  • Printing from InDesign - black lines

    Good afternoon all, I've started using InDesign CS6 at work to produce advertising catalogues. I've hit a bit of a wall when I print it and would like a bit of help to try and solve my issue(s). I have a booklet set up to print 4 pages of A4 on to do

  • Dlink Network Card Help Please

    At my school in the radio and tv classes we use the network to tranfer video files and such. One of the G4s built in ethernet card has broken pins. My teacher bought a Dlink DFE-530tx+ and I'm in charge of getting it working. I've installed the PCI a

  • Recommend design pattern books

    Hi I work at a university and I am looking for some books on design patterns in LabVIEW, preferably for 2009. I am interested in state machine and master/slave design and perhaps also producer/consumer design pattern. Can you recommend some books on

  • Should we do a streamline refi or wait?

    Hello, I haven't seen this question asked so here it goes: My partner and I were financed for a home last July.  Only she is currently on the loan as I had a recent job change and some spotty marks on my credit when we closed.  So know we are thinkin

  • Crystal Report looks the design time xml at run time

    Hi, I have a question about crystal report. I am using VS 2008. My PC is Windows XP SP2. The reporst was using xml datasource. At design time, I specifiy the datasource as a xml file (D:\Report\myReport.xml). At run time, on a different pc where the