Nexus 5k QoS Classifcation

Hello,
  From what I have gathered from documentation the Nexus is able to mark any DSCP value between 0-63. I would assume it would be able to classify based on any DSCP value as well.  The documentation however leads me to believe otherwise. The language for marking suggest valid values are from 0 to 63. For classification the language suggests classification can only match standard DSCP values. I would test but do not have a Nexus at my disposal. Can someone with experience please confirm?
Classification
http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/command/reference/qos/n5k-qos_cmds_m.html#wp1079436
Marking
http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/command/reference/qos/n5k-qos_cmds_s.html#wp1159955
regards,
ryan

Hi Ryan,
As you can see from my 5010 lab switch:
24.09.5010B.1(config)# policy-map type qos my_policy
24.09.5010B.1(config-pmap-qos)# class type qos my_class
24.09.5010B.1(config-pmap-c-qos)# set dscp ?
  <0-63>   DSCP value
  af11     AF11 dscp (001010)
  af12     AF12 dscp (001100)
  af13     AF13 dscp (001110)
  af21     AF21 dscp (010010)
  af22     AF22 dscp (010100)
  af23     AF23 dscp (010110)
  af31     AF31 dscp (011010)
  af32     AF32 dscp (011100)
  af33     AF33 dscp (011110)
  af41     AF41 dscp (100010)
  af42     AF42 dscp (100100)
  af43     AF43 dscp (100110)
  cs1      CS1(precedence 1) dscp (001000)
  cs2      CS2(precedence 2) dscp (010000)
  cs3      CS3(precedence 3) dscp (011000)
  cs4      CS4(precedence 4) dscp (100000)
  cs5      CS5(precedence 5) dscp (101000)
  cs6      CS6(precedence 6) dscp (110000)
  cs7      CS7(precedence 7) dscp (111000)
  default  Default dscp (000000)
  ef       EF dscp (101110)
The only DSCP values you can set are 0-63, as you suspected.
However, these are the only DSCP values you are supposed to be able to match as well:
24.09.5010B.1(config-cmap-qos)# match dscp ?
<0-63>   List of DSCP values
  af11     AF11 dscp (001010)
  af12     AF12 dscp (001100)
  af13     AF13 dscp (001110)
  af21     AF21 dscp (010010)
  af22     AF22 dscp (010100)
  af23     AF23 dscp (010110)
  af31     AF31 dscp (011010)
  af32     AF32 dscp (011100)
  af33     AF33 dscp (011110)
  af41     AF41 dscp (100010)
  af42     AF42 dscp (100100)
  af43     AF43 dscp (100110)
  cs1      CS1(precedence 1) dscp (001000)
  cs2      CS2(precedence 2) dscp (010000)
  cs3      CS3(precedence 3) dscp (011000)
  cs4      CS4(precedence 4) dscp (100000)
  cs5      CS5(precedence 5) dscp (101000)
  cs6      CS6(precedence 6) dscp (110000)
  cs7      CS7(precedence 7) dscp (111000)
  default  Default dscp (000000)
  ef       EF dscp (101110)
This output was taken on our latest version of code, and the 5500 series is the same.
- Amanda

Similar Messages

  • Nexus 5600 QoS

    Hi
    I want to apply QoS scheduling using 8 classes per interface in the nexus 5672
    As far as I know , Nexus 5600 have 8 queues per port
    So in the ingress port, I want to apply  COS mark using 8 class-maps and policy-map type qos
    but I don't understand why I must apply "set qos-group" in the policy-map
    and then in the egress port, to schedule the bandwidth for each class-map 
    I applied class-map and policy-map type queueing
    but in the class-map, there is only "match qos-group", qos-group has only1~5 value
    so how to apply bandwidth percent for 8 each class-map in the policy-map per port?
    is it impossible?
    please let me know that reason and how to do that
    Thank you

    Duplicate posts.  
    Go here:  http://supportforums.cisco.com/discussion/12142791/nexus-7000-qos

  • Nexus 5500 qos drop priority

    Hi
    If I have two COS values within the same queue on a 5500 port can I set drop priority for them ? I am looking at setting in contract and out of contract data rates for some VMs, setting the COS value dependant on this and then getting the 5K to be more likely to drop out of contact data.
    Its whjat I would do on a 6k or 7k with assigning different tail drop thresholds to different COS values in the same queue.

    Thats what I kind of figured after reading all the docs. Makes it a bit of a pain as there really arent quite enough queues for what I want to do.
    Viideo & Voice
    Call SIgnnaling
    Critical Data
    Network Ctrl (ssh, VMware vmotion and ctrl etc)
    Bulk Data
    Best Efforts
    Thats six and since we are using FCoE tehre are only 5 qos groups we can use ......
    I am going to have to combine two of the above.

  • How to change default FCoE QoS class - Nexus 5020

    I see that on a Nexus 5020, the default FCoE QoS class is 50%. I am not using FCoE so I would like to adjust this value to 0%. I switch complains and says I can't change default values. How should I go about getting around this to eliminate the FCoE queue and give 100% BW to default? Thanks.

    No. The default classloader is a builtin classloader in
    the JRE. You can use other classloaders.
    The java.net.URLClassLoader is provided in
    the JDK. That's the only one. Otherwise you
    should subclass ClassLoader and implement
    the loadClass method (f.i.
    loadClass("my.program") {
    String file="my.program".replace('.','/') + ".class";
    // find the file in classpath
    // read the class file in a byte[]
    return defineClass(byte[]);
    although this is not the advised way to do it. Search the web for how to implement a classloader directly.

  • DCBX Between Linux and Nexus QOS

    Hi Guys
    i have a server with 2 physical links only.
    over this link im passing 2 vlans in trunk ( can be Portchannel to VPC or bond active passive , doesnt matter to me ) .
    vlan 302 is for data
    vlan 303 is for backup
    server on vlan 303 is pushing traffic on that link and would take as much
    bandwidth as we would give it , and would therefore cause communication issues to vlan 302 . ( congestion ) .
    I would like to talk about my options here , to avoid congestions .
    thought about enabling dcbx on clients ( linux ) and pfc ( priority flow
    control ) to be able to negotiate qos and bw allocation according to COS IEEE 802.1p .
    the idea is to have either the traffic prioritized/limit/shaped before/when its ingressing the nexus port .
    the dcbx looks very cool like i said , it's kind of like what the nexus has with the CNA Card .
    when it can send the linux nic through dcbx the qos parameters to apply ! ( ah ok , i see now its exactly the same )
    ps linux dcbx link : http://manpages.ubuntu.com/manpages/precise/man8/dcbtool.8.html
    Ingress Queuing Policies
    You can associate an ingress policy map with an Ethernet interface to guarantee bandwidth for the specified traffic class or to specify a priority queue.
    The ingress policy is applied in the adapter to all outgoing traffic that matches the specified CoS value.
    When you configure an ingress policy for an interface, the switch sends the configuration data to the adapter. If the adapter does not support the DCBX protocol or the ingress policy type-length-value (TLV), the ingress policy configuration is ignored.
    did anyone here tried it or implemented dcbx before ?
    anyway id be happy to hear your wise and helpfull suggestions please
    Thanks Thanks !!!

    Found the answer.
    Anatomy of RX packet counters on a Cisco Nexus 5548:
    Nexus5548# show int eth1/29 
      RX      
        6387682660 unicast packets  1495485 multicast packets  164 broadcast packets 
        6389178309 input packets  589693485138 bytes
        5146969 jumbo packets  0 storm suppression bytes
      * "input" = unicast + multicast + broadcast (all non-jumbo)
      * "jumbo" = frames sized 1519 bytes to the MTU bytes defined on the interface
      * "jumbo" frames are counted separately from non-jumbo ("input")
      * (unicast, multicast and broadcast "jumbo" frames appear to be rolled into the 
            one "jumbo" counter)
    This can be seen another way with the 'count detail' command, correlated to "show int" output:
    Nexus5548# show int eth1/29 count detailed
    Ethernet1/29
      Rx Packets:                                  6389178309 <-- input
      Rx Unicast Packets:                          6387682660 <-- unicast
      Rx Multicast Packets:                           1495485 <-- multicast
      Rx Broadcast Packets:                               164 <-- broadcast
      Rx Jumbo Packets:                               5146969 <-- jumbo
      Rx Bytes:                                  589693485138
      Rx Packets from 0 to 64 bytes:                  1059418 <-- non-jumbo start
      Rx Packets from 65 to 127 bytes:             6072007478       +
      Rx Packets from 128 to 255 bytes:              11055520       +
      Rx Packets from 256 to 511 bytes:             287107435       +
      Rx Packets from 512 to 1023 bytes:             12801466       +
      Rx Packets from 1024 to 1518 bytes:                  23 <-- non-jumbo end
      Rx Trunk Packets:                            6387682823 <-- unicast + broadcast
    fyi.

  • QoS Priority in Nexus 55xx

    Hi Everyone, just a little doubt
    Which traffic has more priority in a Nexus 5500 Platform. FCoE in class-fcoe (CoS=3) or CoS =5 in a strict-priority queue ?
    Thanks in Advanced
    My Best Regards,
    Andre Lomonaco

    yeah you probably want to set this up a bit differently.
    you would want to use the bandwidth command in these shaped classes.
    the shape command (setting PIR) operate a bit differently then the classes that have the bandwidth command  set (setting cIR).
    the CIR of a shape policy is 64k, so after the 64k is served, it moves over to the other classes, gets
    the bw remaining assigned and then what is left is divided over the hsaped classes to the max of their PIR.
    If you set the bandwidth on all classes you "reserve" that bandwidth on that class when that bw is needed.
    may wanna pull cisco live form years 2013 and 2014 (orlando/sanfran) session ID 2904 for more details on QOS you may like.
    regards
    xander

  • Nexus QoS Defaults on F cards

    I fond the below chart and I want to make sure I understand it correctly. Accoding to that chart my nexus 7k with F cards trust Cos by default and not DSCP. Is that correct? 
    our Access switches have mls qos trust dscp and our voip devices are making traffic as dscp.
    Thanks
    6500
    N7K
    ENABLE QOS      
    mls qos
    Enabled by default
    TRUST
    mls qos trust [cos|dscp|ip-precedence]
    DSCP (on M1 modules) and CoS (on F1 modules) trusted by default
    INTERNAL QOS
    QoS Label is used internally
    CoS and/or DSCP passed through, though QoS-Groups can be used
    COS TO DSCP MAPPING
    Default of CoS to 3 most significant bits of DSCP (CoS 1 to DSCP 8 )
    Same
    DSCP to COS MAPPING
    Default 3 most significant bits of DSCP to CoS (DSCP 10 to CoS 1)
    Same
    CHANGE COS/DSCP MAPPING
    Modify cos-dscp or dscp-cos maps
    Create and apply qos policy-map(s) ingress and/or egress

    I fond the below chart and I want to make sure I understand it correctly. Accoding to that chart my nexus 7k with F cards trust Cos by default and not DSCP. Is that correct? 
    our Access switches have mls qos trust dscp and our voip devices are making traffic as dscp.
    Thanks
    6500
    N7K
    ENABLE QOS      
    mls qos
    Enabled by default
    TRUST
    mls qos trust [cos|dscp|ip-precedence]
    DSCP (on M1 modules) and CoS (on F1 modules) trusted by default
    INTERNAL QOS
    QoS Label is used internally
    CoS and/or DSCP passed through, though QoS-Groups can be used
    COS TO DSCP MAPPING
    Default of CoS to 3 most significant bits of DSCP (CoS 1 to DSCP 8 )
    Same
    DSCP to COS MAPPING
    Default 3 most significant bits of DSCP to CoS (DSCP 10 to CoS 1)
    Same
    CHANGE COS/DSCP MAPPING
    Modify cos-dscp or dscp-cos maps
    Create and apply qos policy-map(s) ingress and/or egress

  • Nexus 5596 and QOS config guide

    Hi,
    I need to implement qos on a nexus device for a client
    Basically what I am trying to implement is this but on the nexus
    Policy Map Enhanced_QoS_Customer_Out
          Description: Enhanced QoS customers outbound Percentages
        Class Cust_VoIP_Out
          priority 30 (%)
        Class Cust_Gold_Out
          bandwidth 30 (%)
        Class Cust_Silver_Out
          bandwidth 13 (%)
        Class Cust_Bronze_Out
          bandwidth 2 (%)
    Policy Map Ethernet_QoS_Customer_Out_200Mb
        Class class-default
          Average Rate Traffic Shaping
          cir 200000000 (bps)
          service-policy Enhanced_QoS_Customer_Out
    Is this possible on the nexus 5596?
    I havent found much information around shaping.. Please advise if the above policy is achelievable on the nexus and if not what does the nexus support?
    regards,

    Hi,
    I don't think the 5500 support shaping since it is mostly a layer-2 device.  Here is the config guide for QOS.
    http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/CLIConfigurationGuide/QoS.html
    HTH

  • Nexus and 3850 QoS

    Dear all,
    I am having a problem with implementing QoS for a 3rd Party application. The vendor requests that some of this traffic needs special markings with specific cos/dscp values. Also we need to have QoS for our Cisco IP Phones.
    The devices ( phones and the 3rd Party devices) are hooked up at the 3850 (running IP Base) switches which are connected via port channel to 2 Nexus 5596UP which are connected via vPC.
    If i execute the 
    show policy-map int t1/1/4 or show policy-map int e1/1 on the switches, I can see that there are match packets ( matched by any) but 0 by the UDP ports.
    Also the the 3rdParty Clocks are not synchron which is an indicator that the QoS is not working. If the two clocks are hooked up at the same 3850 switch they sync. 
    I am sure I miss something, but I really do not know what. The goal is to have QoS for the Cisco IP phones and also the 3rd Party devices.
     Any help would be much appreciated.
    Here the 3rd Party requests and configurations I did on the switches:
    Protocol: PTP
    Destination: 224.0.1.129
    Dest.Port: UDP319,320
    DSCP: CS7
    CoS: 56
    Protocol: Unicast Streaming
    Dest.Port: UDP 14336-14600
    DSCP: EF
    CoS: 46
    Protocol: Broadcast Streaming
    Dest. Port UDP 4321
    DSCP: EF
    CoS: 46
    I created the following Class Maps, ACLs and Policy Maps on the Nexus Switches for 3rd Party and Voice:
    ip access-list ACL-Dante-Audio
      10 permit udp any any eq 4321
      20 permit udp any any range 14336 14600
      30 permit ip any any
    ip access-list ACL-Dante-PTP
      10 permit udp any any eq 319
      20 permit udp any any eq 320
      30 permit ip any any
    class-map type qos match-any VOICE
      match dscp 46
      match cos 5
    class-map type qos match-any Dante-PTP
      match access-group name ACL-Dante-PTP
    class-map type qos match-any Dante-Audio-PTP
      match access-group name ACL-Dante-Audio
    policy-map type qos Global-QoS-IN
      class Dante-PTP
        set dscp 56
      class Dante-Audio-PTP
        set dscp 46
      class VOICE
        set qos-group 5
    system qos
      service-policy type qos input Global-QoS-IN
    The following settings are configured on the 3850's:
    ip access-list extended ACL-Dante-Audio
     permit udp any any eq 4321
     permit udp any any range 14336 14600
     permit ip any any
    ip access-list extended ACL-Dante-PTP
     permit udp any any eq 319
     permit udp any any eq 320
     permit ip any any
    class-map match-any Dante-PTP
    match access-group name ACL-Dante-PTP
    class-map match-any Dante-Audio-PTP
     match access-group name ACL-Dante-Audio
    class-map match-any VOICE
     match dscp ef 
     match cos  5 
    policy-map Output-Qos-Policy
     class Dante-PTP
      set dscp cs7
     class Dante-Audio-PTP
      set dscp ef
     class VOICE
    interface TenGigabitEthernet1/1/4
     description Uplink_Core1_e1/1
     switchport mode trunk
     switchport nonegotiate
     auto qos trust dscp
     channel-group 1 mode passive
     service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
     service-policy output Output-Qos-Policy
     ip dhcp snooping trust
    interface TenGigabitEthernet2/1/4
     description Uplink_Core2_e1/1
     switchport mode trunk
     switchport nonegotiate
     auto qos trust dscp
     channel-group 1 mode passive
     service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
     service-policy output Output-Qos-Policy
     ip dhcp snooping trust
    Thanks in advance
    Thorsten

    After a few tries we found solution.
    Solution is customizing cisco av pair, it must looks like:
    cisco-av-pair=shell:roles*"network-admin admin"

  • QOS on Nexus 5500

    Hi:
    Can someone give me a QOS example config for my scenario below:
    I have read the config guide and is confused.
    Let's say I have a router leg on e1/1 of N5K1.
    I want to limit on the outbound( N5K1 to router) http 25%, icmp 10K  and remaining goes to default.
    Any sample configurations welcome. I have already checked the ones in thc config guide.
    thanks

    Hello Ben,
    Since you have not received a reply, I am moving this post to our data center community for greater visibility.
    Thank you,
    Fabienne

  • Vlan base Qos on Cisco Nexus 5K

    Is Cisco Nexus 5596UP support vlan base Policing and traffic shaping on code NX OS version: 5.1(3)N1(1)
    where i couldn't see any police command under the policy map 

    Hi,
    Please find the below link for configuration guide for Nexus 5K.
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/sm_snmp.html
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/system_management/513_n1_1/b_Cisco_n5k_system_mgmt_cg_rel_513_n1_1_chapter_01110.pdf
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/sm_snmp.pdf
    Regards,
    Gaurav

  • Nexus 7K rate-limiting QoS

    All
    I have 2 sets of server that replicate over a WAN link.  I would like to limit the bandwidth to 10mbs for these servers only. 
    The servers reside on the 10.1.6.0/24 and 10.4.6.0/24 subnets
    The N7K and the Cisco 6500 both connect directly to the WAN link.  I’m not sure how I should accomplish this on the N7K.
    Please advise.

    More info
    It looks like I need to create a CUSTOM QUEUE and then apply that custom queue to a specific interface. I still don't get how define a subnet for this queue. The xample given does not make sense at the moment.
    example given
    Create a Custom Queuing Policy
    In order to create a custom queuing policy, complete these steps:
    1. Create a custom queuing policy with the desired queue limit and bandwidth allocation.
    2. Modify the global queuing class−maps to create the needed CoS to queue mapping.
    3. Apply the new queuing policy to the appropriate interfaces.
    Consider an example for M132 modules that have a 1p7q4t queuing architecture where all 8 CoS values are
    mapped to a separate queue. The output shows the custom queuing policy along with the changes to the global
    queuing class−maps:
    policy−map type queuing 10G_POLICY
    class type queuing 1p7q4t−out−pq1
    priority level 1
    queue−limit percent 10
    class type queuing 1p7q4t−out−q2
    queue−limit percent 10
    bandwidth remaining percent 10
    class type queuing 1p7q4t−out−q3
    queue−limit percent 5
    bandwidth remaining percent 5
    class type queuing 1p7q4t−out−q4
    queue−limit percent 5
    bandwidth remaining percent 5
    class type queuing 1p7q4t−out−q5
    queue−limit percent 10
    bandwidth remaining percent 20
    class type queuing 1p7q4t−out−q6
    queue−limit percent 5
    bandwidth remaining percent 10
    class type queuing 1p7q4t−out−q7
    queue−limit percent 5
    bandwidth remaining percent 10
    class type queuing 1p7q4t−out−q−default
    queue−limit percent 50
    bandwidth remaining percent 40
    ! voice
    class−map type queuing match−any 1p7q4t−out−pq1
    match cos 5
    ! scavenger
    class−map type queuing match−any 1p7q4t−out−q2
    match cos 1
    ! transactional
    class−map type queuing match−any 1p7q4t−out−q3
    match cos 2
    ! call signaling
    class−map type queuing match−any 1p7q4t−out−q4
    match cos 3
    ! video
    class−map type queuing match−any 1p7q4t−out−q5
    match cos 4
    ! routing
    class−map type queuing match−any 1p7q4t−out−q6
    match cos 6
    ! management
    class−map type queuing match−any 1p7q4t−out−q7
    match cos 7
    ! best effort
    class−map type queuing match−any 1p7q4t−out−q−default
    match cos 0
    The final step is to apply the custom queuing policy to each 1p7q4t interface:
        interface Ethernet8/1
        service−policy type queuing output 10G_POLICY

  • Problem on the QoS trust boundary on FEX

    HI: all
         During a test, we found the N5K attached FEX will override all the DSCP marking to 0  for the class-default traffic. Based on my understanding, the N5K will enable the qos trust on all access port by defual. But how about I configure a policy-map on the interface for DSCP marking, and want to leave the unclassified traffic as the original DSCP tag, is that possible?
        Thanks!
    BR
    LIBING

    Hi There,
    Take a look at the QoS config guide, it has some of the answers you are after.
    You should refer to the guide relevant to your OS version.
    http://www.cisco.com/en/US/partner/docs/switches/datacenter/nexus5500/sw/qos/602_N1_1/b_5500_QoS_Config_602N11_chapter_0110.html
    Any incoming packet not tagged with an 802.1p CoS value is assigned the default untagged CoS value of zero (which maps to the default Ethernet drop system class). You can override the default untagged CoS value for an Ethernet or EtherChannel interface.
    On a Cisco Nexus device, you can configure a type qos policy map and untagged CoS on the same interface.
    Trust Boundaries
    The trust boundary is enforced by the incoming interface as follows:
    All Fibre Channel and virtual Fibre Channel interfaces are automatically classified into the FCoE system class.
    By default, all Ethernet interfaces are trusted interfaces.The 802.1p CoS and DSCP are preserved unless the marking is configured. There is no default CoS to queue and DSCP to queue mapping. You can define and apply a policy to create these mappings. By default, without a user defined policy, all traffic is assigned to the default queue.
    Any packet that is not tagged with an 802.1p CoS value is classified into the default drop system class. If the untagged packet is sent over a trunk, it is tagged with the default untagged CoS value, which is zero.
    You can override the default untagged CoS value for an Ethernet interface or port channel.
    You can override the default untagged CoS value for an Ethernet interface or a port channel interface using the untagged cos cos-value command.
    You can override the default untagged Cos value for an Ethernet or a Layer 3 interface or a port channel interface using the untagged cos cos-value command.
    After the system applies the untagged CoS value, QoS functions the same as for a packet that entered the system tagged with the CoS value.
    Hope that helps.

  • Nexus 4000i in blade center H to 5548UP - no Flogi login

    I have a fully integrated network in 2 separate data centers built solely on Nexus 5500UP switches that I just got finished designing and implementing.  It connects FCoE to all hosts, FCoE from server access 5596UP to a pair of 5596 that act as "SAN" swtiches where I have native FC SFP that connect to XIV storage.  In that environement all works great, multi-hop FCoE, NPIV, etc.  All zoning and SAN administration is done fully on the N5K 5500 platform.  (I even have MDS 9222i sole used for FCIP tunneling on the A and B fabric and that works like a champ too, DCNM sees both data centers as one large A and B fabric with the FCIP tunnels linking them)
    The issue is when I introduced a pair of blade centers with N4K switches and a pair of 5548UP switches as their upstream FCF.  The documentation isn't rocket science and yet I can't get a FLOGI login.  The N7K sees the server MAC in the FIP snooping, it also sees the 5548 as it's FCF.  But the 5548 vfc is stuck in "initializing".  QoS is there, NXOS is upgraded, etc...I'm stumped and annoyed at this point.  DCNM sees the 5548 as part of the fabric and it is a subordinated switch in the fcdomain and once I brought the switch up, all zoning, aliasing, etc was received on the switch...so I know the 5548 can see the fabric. Below are some configs (I cut out what isn't relevant)
    5548UP:
    Software
      BIOS:      version 3.5.0
      loader:    version N/A
      kickstart: version 5.1(3)N1(1)
      system:    version 5.1(3)N1(1)
    feature npiv
    feature telnet
    no feature http-server
    feature tacacs+
    cfs eth distribute
    feature interface-vlan
    feature lacp
    feature vpc
    feature lldp
    class-map type qos class-fcoe
    class-map type queuing class-fcoe
      match qos-group 1
    class-map type queuing class-all-flood
      match qos-group 2
    class-map type queuing class-ip-multicast
      match qos-group 2
    class-map type network-qos class-fcoe
      match qos-group 1
    class-map type network-qos class-all-flood
      match qos-group 2
    class-map type network-qos class-ip-multicast
      match qos-group 2
    system qos
      service-policy type qos input fcoe-default-in-policy
      service-policy type queuing input fcoe-default-in-policy
      service-policy type queuing output fcoe-default-out-policy
      service-policy type network-qos fcoe-default-nq-policy
    interface port-channel10
      description 20Gbps Trunk to CLT-BC1-4001-PD-01 port e1/15 and 16
      switchport mode trunk
      switchport trunk allowed vlan 310
      spanning-tree port type network
    interface vfc141
      bind mac-address 00:c0:dd:20:50:41
      switchport description CLT-BC1 Blade #1
      no shutdown
    vsan database
      vsan 310 interface vfc55
      vsan 310 interface vfc141
    interface Ethernet1/7
      description Trunk to CLT-BC1-4001-PD-01 port e1/15
      switchport mode trunk
      switchport trunk allowed vlan 310
      channel-group 10 mode active
    interface Ethernet1/8
      description Trunk to CLT-BC1-4001-PD-01 port e1/16
      switchport mode trunk
      switchport trunk allowed vlan 310
      channel-group 10 mode active
    CLT-SAC-5548-PD-05# show int vfc 141
    vfc141 is trunking
        Bound MAC is 00:c0:dd:20:50:41
        Port description is CLT-BC1 Blade #1
        Hardware is Ethernet
        Port WWN is 20:8c:54:7f:ee:5a:d2:bf
        Admin port mode is F, trunk mode is on
        snmp link state traps are enabled
        Port mode is TF
        Port vsan is 310
        Trunk vsans (admin allowed and active) (310)
        Trunk vsans (up)                       ()
        Trunk vsans (isolated)                 ()
        Trunk vsans (initializing)             (310)
        1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
        1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
          0 frames input, 0 bytes
            0 discards, 0 errors
          0 frames output, 0 bytes
            0 discards, 0 errors
        last clearing of "show interface" counters never
        Interface last changed at Mon Mar 12 21:26:47 2012
    CLT-SAC-5548-PD-05# show flogi database
    No flogi sessions found.
    CLT-SAC-5548-PD-05#show fcdomain
    VSAN 310
    The local switch is a Subordinated Switch.
    Local switch run time information:
            State: Stable
            Local switch WWN:    21:36:54:7f:ee:5a:d2:81
            Running fabric name: 21:36:54:7f:ee:1c:d0:81
            Running priority: 128
            Current domain ID: 0xec(236)
    Local switch configuration information:
            State: Enabled
            FCID persistence: Enabled
            Auto-reconfiguration: Disabled
            Contiguous-allocation: Disabled
            Configured fabric name: 20:01:00:05:30:00:28:df
            Optimize Mode: Disabled
            Configured priority: 128
            Configured domain ID: 0x00(0) (preferred)
    Principal switch run time information:
            Running priority: 2
    Interface                 Role          RCF-reject
    vfc55                 Upstream         Disabled
    Nexus 4000i switch
    Software
      BIOS:      version 1.0.37
      loader:    version N/A
      kickstart: version 4.1(2)E1(1h)
      system:    version 4.1(2)E1(1h)
    feature telnet
    feature tacacs+
    feature interface-vlan
    feature lacp
    feature fip-snooping
    policy-map type queuing policy-fcoe-bandwidth
      class type queuing 1p7q4t-out-q-default
        bandwidth percent 50
      class type queuing 1p7q4t-out-pq1
        bandwidth percent 7
      class type queuing 1p7q4t-out-q2
        bandwidth percent 7
      class type queuing 1p7q4t-out-q3
        bandwidth percent 7
      class type queuing 1p7q4t-out-q4
        bandwidth percent 7
      class type queuing 1p7q4t-out-q5
        bandwidth percent 7
      class type queuing 1p7q4t-out-q6
        bandwidth percent 7
      class type queuing 1p7q4t-out-q7
        bandwidth percent 7
    class-map type network-qos class-fcoe
      match cos 3
    class-map type network-qos class-non-fcoe
      match cos 0-2,4-7
    policy-map type network-qos policy-fcoe
      class type network-qos class-fcoe
        pause no-drop
        mtu 2500
      class type network-qos class-non-fcoe
    system qos
      service-policy type network-qos policy-fcoe
      service-policy type queuing output policy-fcoe-bandwidth
    vlan 310
      fip-snooping enable
    interface port-channel10
      description 20Gbps Trunk to CLT-SAC-5548-PD-05 port e1/7 and 8
      switchport mode trunk
      switchport trunk allowed vlan 310
      fip-snooping port-mode fcf
      spanning-tree port type network
      speed 10000
    interface Ethernet1/1                 <----the server is in slot 1    
      switchport mode trunk
      spanning-tree port type edge trunk
      speed auto
    interface Ethernet1/15
      description Trunk to CLT-SAC-5548-PD-05 port e1/7
      switchport mode trunk
      switchport trunk allowed vlan 310
      speed 10000
      channel-group 10 mode active
    interface Ethernet1/16
      description Trunk to CLT-SAC-5548-PD-05 port e1/8
      switchport mode trunk
      switchport trunk allowed vlan 310
      speed 10000
      channel-group 10 mode active
    CLT-BC1-4001-PD-01# show fip-snooping fcf
      Legend:
    Interface VLAN Active FPMA/ FCMAP      FCF-MAC   Pri   Switch WWN  Fabric Name
                   Enodes SPMA
    por10     310  0      FPMA 0x0efc00 54:7f:ee:5a  128  21:36:54:7f: 21:36:54:7f:
                                        :d2:8a            ee:5a:d2:81  ee:1c:d0:81
    CLT-BC1-4001-PD-01# show fip-snooping vlan-discovery
      Legend:
          Interface      VLAN          FIP MAC
           Eth1/1         1         00:c0:dd:20:50:41
    Any suggestions because I'm stumped!!  I'm also attaching a PDF copy of my Visio that shows port by port mapping and configuration for this blade chassis and port-channel 10.
    Thanks for the help.
    Chris

    In the inital post where I put "
    The N7K sees the server MAC in the FIP snooping, it also sees the 5548  as it's FCF.  But the 5548 vfc is stuck in "initializing".
    I meant to put N4K...not N7K...sorry about that.

  • Ask the Expert: Configuration, Design, and Troubleshooting of Cisco Nexus 1000

    With Louis Watta
    Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to learn and ask questions about design, configuration, and troubleshooting of Cisco Nexus 1000V Series Switches operating inside VMware ESXi and Hyper-V with Cisco expert Louis Watta. Cisco Nexus 1000V Series Switches deliver highly secure, multitenant services by adding virtualization intelligence to the data center network. With Cisco Nexus 1000V Series Switches, you can have a consistent networking feature set and provisioning process all the way from the virtual machine access layer to the core of the data center network infrastructure.
    This is a continuation of the live Webcast.
    Louis Watta is a technical leader in the services organization for Cisco. Watta's primary background is in data center technologies: servers (UNIX, Windows, Linux), switches (MDS, Brocade), storage arrays (EMC, NetApp, HP), network switches (Cisco Catalyst and Cisco Nexus), and enterprise service hypervisors (VMware ESX, Hyper-V, KVM, XEN). As a Technical Leader in Technical Services, Louis currently supports beta and early field trials (EFTs) on new Cisco software and hardware. He has more than 15 years of experience in a wide variety of data center applications and is interested in data center technologies oriented toward data center virtualization and orchestration. Prior to Cisco, Louis was a system administrator for GTE Government Systems. He has a bachelor of science degree in computer science from North Carolina State University. .
    Remember to use the rating system to let Louis know if you have received an adequate response.
    Louis might not be able to answer each question because of the volume expected during this event. Remember that you can continue the conversation on the Data Center community Unified Computing shortly after the event.
    This event lasts through Friday, JUne 14, 2013. Visit this forum often to view responses to your questions and the questions of other Cisco Support Community members.
    Webcast related links:
    Slides
    FAQ
    Webcast Video Recording

    Right now there is only a few features that are not supported on N1Kv on Hyper-V
    They are VXLAN and QOS Fair Weighted Queuing. We are currently demoing VXLAN functionality at Microsoft TechEd Conference this week in New Orleans. So VXLAN support should be coming soon. I can't give you a specific timeline.
    For Fair Weighted Queuing I'm not sure. In the VMware world we take advantage of NETIOC infrastructure. In the MS world they do not have a NETIOC infrastructure that we can use to create a similar feature.
    Code base parity (as in VMware and Hyper-V VSMs running NXOS 5.x) will happen with the next major N1KV release for ESX.
    Let me know if that doesn't answer your question.
    thanks
    louis

Maybe you are looking for

  • IPod Transfer.

    Hi guys, I'm wondering if anyone can shed some light on this issue! I'm having a problem transferring files from my computer to my iPod, and I'm not sure if it's my computer or my iPod that is giving me the problems. My computer is a 1.25 Powerbook G

  • HT6114 Kernel Panic in OS X 10.9.2 copying a file to a file server

    Hi, i've made the update to OS X 10.9.2 3 days ago and it looked like we had all our problems with this OS X solved. Today, I deleted from a share in a NAS (file server) a small file and tried to copy another one with the same name, but the moment th

  • How to get initial value of Child View from Parent View in ADF?

    Hi, I am typically from a Oracle forms background and new to ADF. In ADF,how can I populate the initial value for a new record in child view from the parent view? For example.. using standard Departments and Employees tables which has parent child re

  • Quick Time Player 10 vs 7

    I can play an MPEG movie on the Tiger iMac, Quick Time Player 7.6.4, but cannot play this on Snow Leopard, Quick Time 10.0. The message says I need to download a different format, but does not say what. In reading about Quick Time, there is a downloa

  • TV Guide - Is it possible to view the freeview lis...

    Hi Is is possible to view the freeview listings by 'programme type', e.g to filter the listings so they show only Films, Sports, Drama, etc I know it is possible to do this when viewing the BT Vision Freeview listings on the BT website, but I can't s