Non-standard keys

Hi,
How can I respond to input from non-standard keys, like the forward and back keys on some keyboards? I've tried using the KeyEventDemo, but it doesn't record any events. Any ideas?
Thanks.

Try this:
KeyboardFocusManager.getCurrentKeyboardFocusManager().addKeyEventDispatcher(
        new KeyEventDispatcher() {
            public boolean dispatchKeyEvent(KeyEvent e) {
                System.out.println(e.getKeyCode());
                return false;
});It will detect all keyevents and print the correpsonding keycode. If this code does not react when you press those arrow keys, then you cannot detect them using pure java.

Similar Messages

  • More Non-standard keys

    Hi
    I've noticed that many Windows programs responds to a "menu"-key located next to the right <ctrl>key. (When you press this key, a popup menu shows up as if you would have pressed the right mouse button).
    I would like to respond to this key in my program. A KeyEvent is produced in java and sent to the processKeyEvent method. The keycode is 0. And KeyEvent.getKeyText(e.getKeyCode()) returns "Unknown keyCode".
    This is unfortunately not the only key on my keyboard which is unknown to java. (Also the "Windows"-key next to the left <ctrl>key, and the Back- and forward keys mentioned in the "Non-standard keys" posting last month return keyCode 0) Is it possible somehow to tell which unknown key has been pressed? I've tried to find any difference in the KeyEvents when pressing different "unknown" keys, but the events seem to be equal.
    Does anyone know if java offers another way to tell which key has been pressed??

    Hi again
    Hmmm, that's an interesting thought. Aside from inserting a
    kabillion Click Box objects on the slide (one for each key allowed)
    there really isn't a way inside Captivate. Personally, I think it
    would make for a wonderful enhancement request.
    Click
    here to view the WishForm/Bug Reporting Form
    Aside from that, you might contract with fellow Adobe
    Community Expert Paul Dewhurst to create a small widget similar to
    what is found at the link below, but accepts any keypress as the
    trigger:
    Click
    here to visit Paul's site
    Paul's contact information is on his site.
    Cheers... Rick

  • Using non-standard sshd port after 10.8 upgrade

    After spending hours tracking down this solution as a result of losing my ssh settings after the upgrade to Mountain Lion, I thought it might be useful to post the steps taken to restore the configuration I used with Snow Leopard.
    Changing the sshd default listening port
    Disclaimer: This tutorial is specific to Mountain Lion (OS X 10.8). I was able to accomplish this using Snow Leopard (OS X 10.6) in fewer steps, but upgrading required this more involved solution. 
    Steps:
    1.) You must first enable the root user account in order to change the relevant files. This can be done from the terminal, or by going to System Preferences --> Users & Groups. Once there, click on 'Login Options' at the bottom of the Current User list, and 'Join' where it says 'Network Account Server'.
    This will bring up a smaller window. Click on 'Open Directory Utility' at the bottom. You will be prompted for your admin password. Now go to the 'Edit' tab at the top of the screen and toggle down to 'Enable Root User'.  You will be prompted to enter your admin password twice.
    2.) Log out of your regular user account. At the log in screen you will now see an additional entry for 'other'. Click on that and log in with the username 'root' and your admin password. If are inexperienced as a root-level user, be careful as you can cause problems to your system can be difficult to undo.
    Once in your root account, the first step is to create a new 'service definition' in the etc/services file. Open the file with text editor of choice and scroll to the current entry for sshd listening port, which will look like this:
    ssh    22/udp    # SSH Remote Login Protocol
    ssh    22/tcp     # SSH Remote Login Protocol
    Overwrite the '22' with the port number you would like sshd to listen on:
    ssh    12345/udp   # SSH Remote Login Protocol
    ssh    12345/tcp    # SSH Remote Login Protocol
    *12345 being our hypothetical, non-standard port.
    It is important to note that the new port number will not take by simply adding a new uncommented line to the file (I tried), unless of course you comment the original ssh entries. Easiest way is just to overwrite what is there already. Save changes.
    3.) You now need to edit the ssh.plist file, which is located at /System/Library/LaunchDaemons/ssh.plist. A word to those familiar with Linux/BSD environments: changing the default port in the sshd_config file, which exists in OS X, does NOT change the listening port. Simply changing the default port, saving the config file, and restarting the server (the sensible way) won't work. The OS X sshd server (openssh) is configured to get launch instructions from the ssh.plist file, as opposed to sshd_config. If you are more interested in this aspect of OS X, read up on LaunchDaemons (e.g. launchd).
    Before altering the ssh.plist file, you should save a backup copy in case of mistakes, or if you need to revert back to it in the future. Name your backup file something like original.ssh.plist, etc.
    In the ssh.plist file, locate the SocksServiceName entry and change it from the default:
    <key>SockServiceName</key>
    <string>ssh</string>
    To the following:
    <key>SockServiceName</key>
    <string>$alternate port number</string>
    In our example from above this value would be 12345.
    4.) Save your changes, and exit ssh.plist. You now need to move the backup file you created (original.ssh.plist) out of the System/Library/LaunchDaemons path.
    The updated sshd port will not take until you have only one ssh.plist file in the LaunchDaemons directory - this has to do with how launchd is configured to load files which is outside the scope of the current discussion.  (*If you've found a way around this, please share.) 
    5.) Restart the sshd server. Easiest way to accomplish this is going to System Preferences --> Sharing and clicking off 'Remote Login', then clicking back on it. 
    6.) Test the configuration by logging into the machine running the sshd server from another host using:
    ssh username@ipaddress -p 12345
    There are a few good tutorials out there that capture some of these steps, but many are dated and/or incomplete. If you are running a standard setup of OS X 10.8, this should work for you.
    Of course, don't be fooled into thinking that changing the default listening port from the ubiquitously-probed 22 equates to actual security. At best, it will cut down on the number of dubious connection attempts and probing.

    Hi all, above helped me change the sshd port number, thank you very much.
    Just upgraded to OS X 10.9.3 on my macbook pro.
    My findings were:
    Step 1(become a root user or sudo)
    Step 2 (/etc/services)
    This may not be required unless you want ssh to work without the "-p XXXX" option to connect to other ssh hosts.  I favor such as "ssh -p 2222 user@hostname" just to be sure I know what I am doing and also to leave ssh known port as its default "22".
    Step 3 (/System/Library/LaunchDaemons/ssh.plist)
    This is required if you want to change the sshd port number, I changed both "ssh" to "2222" in this file.
    Step 4 (launchctl)
    Below is a must as I understood:
    launchctl unload /System/Library/LaunchDaemons/ssh.plist
    launchctl load /System/Library/LaunchDaemons/ssh.plist
    it should be already working with the new port number.
    You can "ssh -p 2222 user@localhost" in the console terminal and see if its working.
    Since I am no expert on MacOS X, and it is a macbook pro that I am using, I also rebooted the system and changes were reflected permanantly.
    Thank you guys!

  • Non cumulative key figures

    Hi
    I understand that there are 3 types of non cumulative key figues with these optiones.
    1) cumulative KF with exception aggregation
    2) with associated single delta(cumulative)
    3)with associated IN and Outflow(cumulative)
    I know that we use type 3 in inventory. Has any one used option 2 with Non cumulative KF with associated single Delta?
    Please let me know the scenario where it is useful?
    Thanks
    Vennela

    Vennela,
    It all boils down to the definition of what cumulation is ...
    cumulation refers to straightforward addition of key figures along given filter conditions in the query. This is similar to the sum() operator in an SQL query.
    However people will need different kind of aggregation at different points in time other than the standard aggregation / cumulation that is used regularly.
    Coming to non cumulation :
    1) cumulative KF with exception aggregation
    This refers to predominantly formulae - for instance - count of all customers whose sales > 0 - but the report is does not have customer in it and the result is expected. This would mean that the calculation essentially happens at a different level as opposed to the actual query and the key figure cannot be simply summed up.
    2) with associated single delta(cumulative)
    This is somewhat at a higher level of granularity as opposed to case 3 where you look at all movements. An example here would be You have opening stock and then you get only the debits and credits for the day as opposed to getting stock for all movement types.
    Somethign like
    opening Stock for the day = 100
    Outgoing stock = 30
    incoming stock = 10
    Here movment type information is omitted and instead is consolidated in the source system itself.
    3)with associated IN and Outflow(cumulative)
    This has been discussed many a time and can be found by searching the forums...

  • Isakmp peers using non-standard port 4500

    Hello,
    I have a remote site using the Internet to access corporate networks over IPSEC. Set-up is as below:
    Remote Router uses public IP across internet --> hits corporate untrusted nework FW --> NAT'ed to private 10.x.x.x IP --> reaches trusted network router.
    The problem is that the peer keeps hanging and the only way to reset it is to issue 'clear crypto session' on the central trusted router. I have added isakmp keepalives with the aim of forcing some keepalive traffic:
    crypto isakmp keepalive 90 30 periodic
    ...and this works to some degree (with DPD are u there keepalives). However I have noticed that the far end router uses non-standard ports when trying to set up phase-1 tunnel:
    BEVRLY_D_CR184_01#sh crypto isa pee
    Peer: 161.x.x.x Port: 4500 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10456 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10554 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10557 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10580 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10589 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10596 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10600 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    These ports (non-4500) will be blocked by our firewalls. Why does it use these, and is there a way of stopping the router using anything other than port 4500?
    Thanks
    Phil

    Hello,
    Yes - there's NAT at the trusted central router end our side of the firewall... the config used is below:
    Remote Router end:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description BEVRLY_CC296_01 F0/8 (10.30.45.29)
    ip address x.x.x.x 255.255.255.252
    ip helper-address 10.91.6.30
    ip helper-address 10.4.162.92
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source Dialer1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    Central Router:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description link to Beverley via internet (BEVERLY_CR184_01 Tun1)
    ip address x.x.x.x 255.255.255.252
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source FastEthernet0/1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    I believe the DPD keepalives ensure NAT is known and compatible (crypto isakmp keepalive 90 30 periodic) between the peers....
    Any help gladly appreciated....
    thanks
    Phil

  • Number of button slots for (non-standard) PhoneTemplate

    Hi,
    Once I create a new non-standard phone button template in the CUCM (Device > Device Settings > Phoe Button Template), the number of the buttons on the newly created seems "unpredictable" for me. Sometimes the number of the buttons are the same as on the original template, but sometimes much more.
    For example, 'Standard 7965 SIP' has 6 buttons. If I create based on this template, my 'Standard 7965 SIP MyTemplate' will have 54 slots in it.
    Similar: 'Standard 8961 SIP' has 5 buttons, 'Standard 8961 SIP MyTemplate' has 45.
    Why? Where is this coming from?
    Additional info:
    I have checked the DatabaseDictionary documentation, which states :
    "Before insert into PhoneTemplate, if NEW.usermodifiable = false, thenusing the NEW.tkModel, get the numButton value from TypeModel. It will contain comma-separated min, max values. Take the max value and assign to NEW.numOfButtons."
    But I cannot find this 'numButton' value in the typemodel table?!

    Hi,
    even this small code fails:
            SortedMap index = new TreeMap(new LatvianStringComparator());
            index.put("baa", "baa");
            index.put("aaa", "aaa");
            index.put("aqa", "aqa");
            index.put("caa", "caa");
            Iterator it = index.keySet().iterator();
            while (it.hasNext()) {
                String key = (String)it.next();
                System.out.println(key);
            }because you assume '...first string is "less than" the second one'
    but you did not test it.
    Just add a 'less test' like:
    if (str2Rank > str1Rank) {
    //First string is "less than" the second one.
    signum = -1;
    break;
    }after
    if (str2Rank > str1Rank) {}and your code will work.
    even better: use Collator API
    Franco

  • How to create Object Links For non standard SAP Objects?

    Hi all,
             I need to create an object link in cvo1n for a non standard SAP object (inspection characteristics) . we have two ways to do this
    1. Create a screen for the rquirement by taking the standard screens as reference.
    2. Implement badi document_obj.
    I need a step by step process to perform both the steps. Sample codes will be helpful.
    One more thing is that i need a link in the standard screens of inspection characteristics also. How to get a two way link both in cv01n and in the standard inspection char screen.

    hi
    Customizing for the Do cument Management , you must maintain the key fields for the SAP objects that you want to link to document info records, by choosing Control Data ® Maintain key fields.
    Process
    Program two screens for the following module pools for the SAP object that is to be linked additionally:
    u2013 SAPLCV00
    u2013 SAPLCVIN
    The process logic must be according to that of screen 0204 in program SAPLCV00 and must not be changed.
    Create the function module OBJECT_CHECK_XXXX (XXXX = name of the SAP object).
    If this object can be classified, this function module already exists in the standard system. Otherwise, copy the existing function module OBJECT_CHECK_EQUI (linking of equipment) and change it to suit the new object.
    also you can attach the document to PRT also. but it will not show you in dms. This type of attachment is only from otherside.
    thanks
    nitin
    award point if useful

  • I thought FCP X 10.1.1 could handle non-standard frame sizes?

    Yesterday I was demonstrating FCP X 10.1.1 to a friend.
    As time was limited I imported the nearest piece of video I could find, which happened to be part of an H.264  video tutorial with a frame size of  960 x 600 and a frame rate of 30fps.
    I hit the E key to send it to the timeline only to receive the old "not recognised" error message as shown below.
    I thought I may have created the project incorrectly but when I repeated with a new project I double-checked that I had selected "Set based on first video clip".
    I thought that FCP X 10.1.1 would automatically recognise a non-standard frame size and simply create an appropriate project.
    I was too busy doing the demo to investigate at the time but later I discovered that there was no problem creating a 960 x 600 custom project manually.
    It's a pity FCPX is not clever enough to do it automatically  ............  or can it?

    Thanks Tom, you clarified it .......  or at least something clicked in my brain.
    I was trying to set "Custom" when I created the new project.
    I didn't know, or had forgotten, that in the "error" window I could select "Custom".
    All is now well and FCP X 10.1.1 is pretty clever after all!
    There is one weird thing I'd like to mention.
    When I clicked on "Custom" the 960 x 600  frame dimensions appeared but the  frame rate was listed as 23.98p as shown in the screenshot below.
    So what's wrong with that?
    Well the clip is 30p  and I naturally thought I was going to end up with a project with an incorrect frame rate.
    Now here's the funny thing  .........  when I selected the project and viewed it in the Inspector it was the correct 30p
    So why was I given that worrying piece of misinformation.

  • Add Non-Standard Web Link in Mac Mail

    Does anyone know how to add a non-standard web link? The add link dialog box does not like my url.
    I need to add a link like this: http://someserver100/index.html.
    It disables the "OK" button as soon as I add the "100" after "someserver".
    Prior to the Leopard upgrade I never had a problem doing this. Now it seems that Mail is trying to be too clever. Please help, this is an important business need for me to be able to send links like this.

    I didn't originally go deep into detail as not to bore, but maybe the details will make the difference.
    I am a web developer. I have a client that I vpn into to make web updates. The server that I work on is a testing / development server, not the outside world facing production server. The server is not viewable via a domain name. So I can not get to it by typing www.domainname.com. Instead, the client's IT guys have a host name set up for the server that I need to use due to some of the back end technology that serves the pages.
    The server name is "development100".
    In order for me to view pages on this server, I had to make an entry in my host file so my browser would know what ip address "development100" is associated with. That way whenever I type "http://develoment100" into my browser's url bar to proof my web work it would resolve me to the testing / development server.
    Now, once my changes are done and posted, I need to send a notification email to the IT staff that servers two purposes. First, it gives them an exact url laundry list of what files have have updated. Second, it gives them a link to click for each item that will allow them to proof that html, jpeg, etc.
    A typical item in this list would like like this: http://development100/index.html
    That link should send them directly to the index page on the server for example. I have be using this system of building the notification emails with these links for over five years and prior to upgrading to Leopard, it always worked.
    Now, if I try to "Add Link" and type "http://development100/index.html" in the dialog box. The "OK" button will become disabled as soon as I key in the first number in that link.
    If I don't "Add Link" and just key "http://development100/index.html" into the body of the email the link will cut off at the first number as well. So the link will look like this: "http://development"
    Sorry for the long explanation, but I think that it is necessary. The answer may just be that Apple is trying to verify / qualify links automatically and wont let numbers go in the link name without a .com / suffix. Thanks for the help.

  • Non Standard warning when activating structure

    Hello,
    I am getting a non standard warning when i was activating my Structure and it said , "Exactly one field TXTSP of type LANG: Selection as text language possible", what does it mean.Please assist me and tell me what needs to be done.
    I am activating this structure with refrence quantity fields to create a generic datasource.
    I have my LTXA1 and  TXTSP fields in there.
    Thanks.

    Hi Sam ,
    thanks for answering,
    How does this impact my structure or view.
    At this time for my LTXA1(Confirmation Text)  i have CO_RTEXT as my data element.
    For my TXTSP (Language key) I have SPRAS as my data elemnt.
    And under my Entry/Help for  TXTSP (Lang Key) i have  T002 as my check table.
    Please tell me what happens i wouldnt change this as its just a non standard warning.
    thanks

  • Keyboard shipped with Pavilion non-standard number keypad

    Hello, I advised a friend to buy an HP Pavilion 550 desktop for use at her office. She is a bookkeeper and relies heavily on the number pad on the right side of the keyboard. The keyboard that shipped has a non-standard numeric keypad where the "0" key has a right facing arrow instead of the "0" key. Financial people cannot function with this type of keyboard. I had never seen a keyboard like this before and cannot imaging why HP shipped something that is not standard. I asked her to contact HP support, since there must have been a mistake. HP support offered to SELL her a new keyboard, but would not replace the keyboard shipped with the PC. The PC is brand new and just came out of the box! This is an embarrassing display of our support for our products.  Please help.

    i suppose you could do that - but that seems like a royal pain, and certainly not the graceful experience that apple is known for.
    Alternatively - i have found you can just type CHA CHA in text with the keyboard and it translates it into numbers accordingly.
    Still - a jarring experience, i prefer the other way. Oh well.

  • Kvirc from SVN {NON-Standard-Install-Method} and Overcoming 2 Problems

    Hello, everyone.  Firefishe here.
    There are certain programs I like to compile from source code, outside of the normal arch hierarchy of PKGBUILD's.  One such program is the Internet Relay Chat client, "KVIRC".
    I've been using kvirc for years, and I like to keep it as up-to-date as possible, just like Arch!
    This is why I like to use the svn version, so I can update it quickly and uniformly.  I like--as a user--to contribute back to the project.  (I had one of my bug reports translated into an instant commit by the main project author, himself, once.  That made me feel quite good, so it really does help to do a few things like this now and again.
    Okay, on to the main topic.
    I'm writing this to alleviate a nagging problem that had been plaguing me for months in 2013.  Qt5 just wasn't compiling kvirc very well back then.  The fact is, the echoing strains of "qt5 is broken in kvirc" from the #kvirc channel on Freenode, resounded soundly throughout that entire year.  Qt5 was still a bit buggy, and not all the libraries (32bit or 64bit) were quite finished.
    Move forward to (now) July, 2014!  I have now compiled kvirc successfully on my 64bit (with 32bit multilib installation) laptop, and kvirc is purring away with a current svn build of kvirc.
    However, I ran into some issues, which I would like to share with you, below:
    I usually go about compiling kvirc from svn like this: (I usually start from my /home/userNameHere directory.)
    {arch@homedir}$ svn co https://svn.kvirc.de/svn/trunk/kvirc
    {arch@homedir}$ cd kvirc
    {arch@homedir}$ mkdir release
    {arch@homedir}$ cd release
    {arch@homedir}$ ccmake ..
    [At this point, the 'ccmake ..' command invokes cmake-gui, an ncurses-like graphical user interface, with a list of menu items pertaining to various libraries and flags that can be set.  cmake-gui makes selecting these flags and libraries quite easy, and also gives a clear indication of what directories may not have been found (which will be discussed a bit later.) ]
    Press the 'C' Letter Key -- (This runs the Configure Routine.  I sometimes do this twice, just to be sure it configured properly. I've had it miss a few times for unknown reasons.)
    Press the 'G' Letter Key -- This 'Generates' Cmake files.
    After the 'G' command, the system takes you back to the command prompt.
    {arch@homedir}$ make ***WAIT A WHILE, COULD TAKE A BIT LONGER ON SLOWER SYSTEMS!***
    {arch@homedir}$ sudo make install  (Or 'su -' to root, then do 'make install'; your preference.  I prefer using sudo.)
    {arch@homedir}$ sudo ldconfig  (Or 'ldconfig' if still at root prompt #)
    {arch@homedir}$ kvirc (or 'kvirc &' if you don't want the terminal window to hold onto the process.)
    Kvirc should run at this point, but I ran into a couple of problems.  Once during the ccmake configuration (which prevented ccmake from configuring), and at the end, which prevented kvirc from running.)
    The first had to do with two (2) packages that were not installed.  The were, as follows:
    qt5-webkit
    qt5-multimedia
    I installed those files, then did the  'ccmake ..' portion.   That ran fine, as well as the 'make' and 'sudo make install' and 'sudo ldconfig' parts.
    What didn't work was when I tried to run kvirc.  I got the following error:
    {arch@homedirc}$ kvirc
    kvirc: error while loading shared libraries: libkvilib.so.4: cannot open shared object file: No such file or directory
    I remember, back when kvirc was wanting Qt4, and not Qt5, that if I didn't do the first 'sudo ldconfig' command before trying to run kvirc, it would give something similar.  However, since this compile run was wanting Qt5, and not qt4, I was puzzled.
    Well, it turned out to be something quite simple.  This is a non-standard process of software installation on a new(er) arch system.  The 'uname -r' command on my system yields the following:  3.15.4-1-ARCH .  It is no surprise, then, that at this late date, Qt5 is complete (or at least more complete) than back in 2013 when I had the original problems, and had to select the 'WANTS-QT4' section during the 'ccmake ..' command.
    **** Building kvirc this way places the kvirc binary in /usr/local/bin, and a certain 'libkvilib.so.4' library in /usr/local/lib ****.
    This is to be expected from a standard source compile on most gnu/linux systems; and this *is* a standard compile, even though we're using the 'ccmake ..' command to do the preliminary configuration and cmakefile generation.)
    The problem is, is that Arch is looking for libkvilib.so.4 in /usr/lib, and not /usr/local/lib.  So the following was, for me, the solution that got everything squared away:
    I made a symlink in /usr/lib to /usr/local/lib/libkvilib.so.4, like this:
    {arch@homedir}$ cd /usr/lib
    {arch@homedir}$ sudo ln -s /usr/local/lib/libkvilib.so.4 libkvilib.so.4
    After doing this, I did:
    {arch@homedir}$ kvirc (or kvirc &)
    And It Ran Beautifully! :-)
    I hope you've enjoyed this HOWTO.  I know most people may just want to use the 4.2.x version of kvirc, currently residing safely in the standard repositories.  However, if you're like me, and want a bit of bleeding edge, Qt5 goodness with kvirc, I might suggest doing the above!
    I can be reached at firefishe At gmail DOT com if anyone has any questions.
    Last edited by Firefishe (2014-07-11 09:23:20)

    Hi Dareen,
    Looking at the information shared and also the error message ( Update Failed,Updates could not be applied.Please contact your Administrator if you wish to apply updates on your machine. Updates have been suppressed by the Administrator.If the problems persist, contact customer support for further assistance" ),
    It suggests that the updates were to be managed by the Admin only. Lets try the following step and suggest if this was able to resolve the concern that you have or not.
    1) Navigate to C:\Program Files (x86)\Common Files\Adobe\AAMUpdaterInventory\1.0 and you will find a .dat file ( AdobeUpdaterAdminPrefs.dat).
    2) Please open the file in question and you will find a line item : <Suppressed>1</Suppressed> .
    3) Please change the Value from 1 to 0 and save the file back in the same location.
    post the above step, try the installation once again and share the end result please.
    Cheers,
    Kartikay Sharma

  • TT5121 error - Non standard type mapping?

    Hi all,
    I'm creating cache groups on the TT database, but for some tables I'm getting the following error:
    TT5121: Non standard type mapping for column [Schema].[Table].[Column], cache operations are restricted.
    I'm creating the tables on TT using the Oracle tables DDL, so I quite don't understand where's the problem. I found another thread here on OTN with a similar problem, but it didn't help me. Both TT and Oracle have the UTF8 Character Set.
    Can anyone help?
    Thanks,
    André

    Hi Chris,
    The DDL for the 11g source table:
    CREATE TABLE DMTCMT_AT.DIM_ADDRESS
      ADDRESS_ID                      NUMBER(19)    NOT NULL,
      ADDRESS_CODE                    VARCHAR2(40 CHAR),
      ADDRESS_TYPE                    VARCHAR2(32 CHAR),
      STREETNAME                      VARCHAR2(64 CHAR),
      HOUSE_NUMBER                    VARCHAR2(16 CHAR),
      HOUSE_NUMBER_EXTENSION          VARCHAR2(8 CHAR),
      HOUSE_NAME                      VARCHAR2(64 CHAR),
      FLAT_NUMBER                     VARCHAR2(16 CHAR),
      FLOOR_NUMBER                    VARCHAR2(16 CHAR),
      STAIR_CASE                      VARCHAR2(16 CHAR),
      ZIP_CODE                        VARCHAR2(8 CHAR),
      ZIP_CODE_WITHOUT_EXTENSION      VARCHAR2(8 CHAR),
      ZIP_CODE_EXTENSION              VARCHAR2(8 CHAR),
      DISTRICT_NAME                   VARCHAR2(64 CHAR),
      CITY_NAME                       VARCHAR2(64 CHAR),
      COMMUNITY_NAME                  VARCHAR2(64 CHAR),
      REGION_NAME                     VARCHAR2(64 CHAR),
      COUNTRY_NAME                    VARCHAR2(64 CHAR),
      PO_BOX_NUMBER                   VARCHAR2(16 CHAR),
      PO_BOX_TYPE                     VARCHAR2(16 CHAR),
      X_COORDINATE                    VARCHAR2(16 CHAR),
      Y_COORDINATE                    VARCHAR2(16 CHAR),
      IS_COMPLETE                     VARCHAR2(1 CHAR),
      DSL_FRANCHISE_ID                NUMBER(19),
      CABLE_FRANCHISE_ID              NUMBER(19),
      OBJECT_SCD1_WID                 NUMBER(19),
      OBJECT_WID                      NUMBER,
      EXTERNAL_ID                     VARCHAR2(255 BYTE),
      VALID_FOR_START_DATE_TIME       DATE,
      VALID_FOR_END_DATE_TIME         DATE,
      META_VALID_FOR_START_DATE_TIME  DATE,
      META_VALID_FOR_END_DATE_TIME    DATE,
      META_DATASOURCE_ID              NUMBER(19),
      META_CREATION_DATE              DATE,
      META_IS_CURRENT                 VARCHAR2(1 BYTE),
      META_IS_VALID                   VARCHAR2(1 BYTE),
      META_IS_ACTIVE                  VARCHAR2(1 BYTE),
      META_BUSINESS_UNIT_ID           NUMBER(19),
      META_COUNTRY_CODE               VARCHAR2(3 BYTE) NOT NULL,
      META_PROCESS_ID                 NUMBER(19),
      META_MODIFICATION_DATE          DATE,
      MD5_CRC                         VARCHAR2(32 BYTE),
      IS_SELF_INSTALL                 VARCHAR2(1 BYTE),
      SELF_INSTALL_DATE               DATE,
      BUSINESS_FRANCHISE_ID           NUMBER(20)
    TABLESPACE CDMDWHPE
    PCTUSED    0
    PCTFREE    10
    INITRANS   1
    MAXTRANS   255
    STORAGE    (
                INITIAL          64K
                NEXT             1M
                MINEXTENTS       1
                MAXEXTENTS       UNLIMITED
                PCTINCREASE      0
                BUFFER_POOL      DEFAULT
    LOGGING
    NOCOMPRESS
    NOCACHE
    NOPARALLEL
    MONITORING
    ENABLE ROW MOVEMENT;
    The DDL for the TT cache group:
    CREATE READONLY CACHE GROUP DIM_ADDRESS_AT FROM DMTCMT_AT.DIM_ADDRESS
    ( ADDRESS_ID                      NUMBER(19)    NOT NULL,
      ADDRESS_CODE                    VARCHAR2(40 CHAR),
      ADDRESS_TYPE                    VARCHAR2(32 CHAR),
      STREETNAME                      VARCHAR2(64 CHAR),
      HOUSE_NUMBER                    VARCHAR2(16 CHAR),
      HOUSE_NUMBER_EXTENSION          VARCHAR2(8 CHAR),
      HOUSE_NAME                      VARCHAR2(64 CHAR),
      FLAT_NUMBER                     VARCHAR2(16 CHAR),
      FLOOR_NUMBER                    VARCHAR2(16 CHAR),
      STAIR_CASE                      VARCHAR2(16 CHAR),
      ZIP_CODE                        VARCHAR2(8 CHAR),
      ZIP_CODE_WITHOUT_EXTENSION      VARCHAR2(8 CHAR),
      ZIP_CODE_EXTENSION              VARCHAR2(8 CHAR),
      DISTRICT_NAME                   VARCHAR2(64 CHAR),
      CITY_NAME                       VARCHAR2(64 CHAR),
      COMMUNITY_NAME                  VARCHAR2(64 CHAR),
      REGION_NAME                     VARCHAR2(64 CHAR),
      COUNTRY_NAME                    VARCHAR2(64 CHAR),
      PO_BOX_NUMBER                   VARCHAR2(16 CHAR),
      PO_BOX_TYPE                     VARCHAR2(16 CHAR),
      X_COORDINATE                    VARCHAR2(16 CHAR),
      Y_COORDINATE                    VARCHAR2(16 CHAR),
      IS_COMPLETE                     VARCHAR2(1 CHAR),
      DSL_FRANCHISE_ID                NUMBER(19),
      CABLE_FRANCHISE_ID              NUMBER(19),
      OBJECT_SCD1_WID                 NUMBER(19),
      OBJECT_WID                      NUMBER,
      EXTERNAL_ID                     VARCHAR2(255 BYTE),
      VALID_FOR_START_DATE_TIME       DATE,
      VALID_FOR_END_DATE_TIME         DATE,
      META_VALID_FOR_START_DATE_TIME  DATE,
      META_VALID_FOR_END_DATE_TIME    DATE,
      META_DATASOURCE_ID              NUMBER(19),
      META_CREATION_DATE              DATE,
      META_IS_CURRENT                 VARCHAR2(1 BYTE),
      META_IS_VALID                   VARCHAR2(1 BYTE),
      META_IS_ACTIVE                  VARCHAR2(1 BYTE),
      META_BUSINESS_UNIT_ID           NUMBER(19),
      META_COUNTRY_CODE               VARCHAR2(3 BYTE) NOT NULL,
      META_PROCESS_ID                 NUMBER(19),
      META_MODIFICATION_DATE          DATE,
      MD5_CRC                         VARCHAR2(32 BYTE),
      IS_SELF_INSTALL                 VARCHAR2(1 BYTE),
      SELF_INSTALL_DATE               DATE,
      BUSINESS_FRANCHISE_ID           NUMBER(20)
      PRIMARY KEY ("OBJECT_WID"));
    Thanks,
    André

  • G5 Second Display using the GeForce FX 5200 - Non-Standard

    I have a Dual 1.8 GHz PowerPC G5 Macintosh.
    The display adapter installed is as follows:
    GeForce FX 5200:
    Chipset Model: GeForce FX 5200
    Type: Display
    Bus: AGP
    Slot: SLOT-1
    VRAM (Total): 64 MB
    Vendor: nVIDIA (0x10de)
    Device ID: 0x0321
    Revision ID: 0x00a2
    ROM Revision: 2060
    Displays:
    VX2235wm-3:
    Resolution: 1680 x 1050 @ 60 Hz
    Depth: 32-bit Color
    Core Image: Supported
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Quartz Extreme: Supported
    Display:
    Status: No display connected
    I want to attach a second display to my machine, but the second plug on the card is a non-standard DVI-type connector. It looks like this:
    x x x x x x x x x x X X
    x x x x x x x x x x -----
    x x x x x x x x x x X X
    ...with 10 rows of 3 as opposed to 8.
    I have had trouble finding an adapter to use to convert this to VGA (which is what I meed to connect my second monitor). I've searched the Apple Store online to no avail, as well as Google. Perhaps I've had no luck because I don't know the name of this part.
    Any help is much appreciated!
    ~Rob Blaze

    Hello! Does the port look like the one below? If so you'll need an adapter. Tom
    Actually, HERE is the page i was looking for that shows and describes all dvi connections.
    Apple ADC Connector
    [IMG]http://img300.imageshack.us/img300/9497/appleadcconnectorve2.jpg[/IMG]
    Message was edited by: Thomas Bryant

  • How To: Use FCPX to create iPhone Portrait Movies (and other non-standard formats)

    Goal: Use Final Cut Pro X 10.0.7 to produce a 640x1136 video (iPhone 5 Portrait). You can use these same steps to produce virtually any dimensions you want. My example is for the iPhone 5, in Portrait mode.
    This information is available in various places, but you have to realy work to find it, so I thought I'd post a step-by-step guide here.
    By the way, you might think you could just create a FCPX Project with your desired dimensions, but you can't (at least with 10.0.7). Projects only support certainly dimensions. But there are other ways, as the rest of this post describes:
    1) Create an initial movie with the desired dimensions, to serve as a template. We'll call it "Template.mov". The only thing that matters is the dimensions. It can be in any codec FCPX understands, and virtually any length.
    I'm using a 2 second video shot on my iPhone for the template. You could also create a blank image (.png, whatever) with the proper dimensions, copy and paste it into a new Quick Time Pro 7 window, and Export it using custom settings. There's lots of different ways to do this.
    2) Drop Template.mov into a FCPX event.
    3) Select Template.mov in the Event browser, and select File->Duplicate (or command-D). You probably could just edit "Template.mov", but it's a good idea to save it for reuse.
    3) Change the name of the copied video. I'm using "iPhone Video".
    4) Right-click "iPhone Video" and select "Open in Timeline".
    5) If you made the Template video from a still image, you may need to change the duration (ctrl+D). You don't have to make it very long, but it needs to be longer than 1 frame. A few seconds should be enough.
    6) Use this timeline like you'd use a project's timeline. Drop in new content, trim, transition, etc. There may be things you can't do in it, but I haven't found any yet. I'm guessing Chapters may not work, but I haven't tried them.
    7) Note that when you drop new content into the timeline, it may size funny. That's because the default setting for "Spacial Conform" is "Fit". Simply select the newly-dropped content, and in the Video settings inspector, scroll down to "Spacial Conform" and change it. You could use "Fill", which fills the frame vertically, or "None", which uses the source's original height. Then crop/transform/whatever to get what you want.
    8) When you're ready to render, select "iPhone Video" in the Event browser, then use the "Share" button. You want to use the "Export File" destination, which you may have to add. Pick your codec, and let 'er rip.
    9) When the rendering is done, you should have a video in your desired dimensions.
    That's all there is to it. Hope this helps someone.
    Dan
    PS: Don't ask why someone would want to create an iPod video using FCPX. The point is that you may need to create a video with non-standard  dimensions at some point in time, and this is how to do it.
    PPS: Most of this information came from http://library.creativecow.net/articles/payton_t/FCPX_Custom-Resolution-Timeline s/video-tutorial. I just wrote it down, while I tried to do what the video suggested.

    Instructions for using QuickTime Pro 7 to create a template video with unusual dimensions.
    I suspect that anyone savy enough to be using FCPX has probably already figured out how to do this, either using my technique or another, so there probably isn't a real need for me to post this. For that matter, I may be the only person who cares about this at all. However, while I was trying to learn how to do all of this, I would have really appreciated having all the information in one place, so here goes.
    If you want to create a video with unusual dimensions (like 640x1136) using my steps above, you'll need a "template" video first. Here's an easy way to create one, using any image editor, and QuickTime Pro 7.
    1) Open QuickTime Pro 7 (QTP for short).
    2) From the menu, select File->New Player. You'll get a window with just the bottom portion of the player, i.e. the playback controls.
    3) Using an image editor, create a still image in the desired dimensions. You can use any image editor. It doesn't matter what the image contains (although it will end up showing as a thumbnail in FCPX).
    4) Copy the image to the clipboard.
    5) Switch back to QTP, and paste the image into the new player. Don't worry that there isn't a video window showing - just paste it into the window that has only playback controls. As soon as you do, the video window appears.
    6) Advance to the end of the movie (the short, 1-frame movie), then hold down Command+V (paste) and keep holding it down to paste multiple images in. Watch the time advance. You could, if you want, just hold down Command+V until you get the length you want. But if you want a long video, there's an easier way:
    7) When you reach a few seconds (or whatever duration your patience allows), select all (Command+A) and copy (Command+C). Then hold down Command+V to keep pasting in the longer clips. Wait until you reach a longer duration, then repeat the process. So, for example, 1 second, then 10 seconds, then 1 minute, then 10 minutes, then 1 hour. Or whatever you want.
    8) Save the video however you want. I usually use File->Export with H.264, with Quality set to "Least". Just make sure you don't let it change the dimensions. If you resized the player window, depending on which "save" or "export" method you've chosen, it might default to the resized dimensions, so double check that to make sure.
    That's it. You now have a template video you can use with my previous post(s).
    Dan

Maybe you are looking for