Php code limit a user based on access level

building site where users post items for sale
different levels of access
want to limit basic access level to 10 postings
use php/mysql and dreamweaver CS4
thanks for your help,
jim balthrop

sounds phenominal
Like Craigslist but you have to pay... sign me up!
If the activation method of the registration being sent to your email is this method then, as mentioned, it can be circumvented. And the IP address is an absolute fool-proof way to prevent multiple registration. That is of course without the consideration that the user may use a proxy server or otherwise cloak their IP address.
Think of it this way: what if you were only allowed to post 10 threads in the Adobe forums and after that you had to pay to get "many benefits besides unlimited posting" What do you think DWFAQ would do?

Similar Messages

  • Limit member selection based on access in running Hyperion Financial Report

    Hi there
    I am wondering, is it possible to limit the member selection in a prompt box based on what access they have when running a Hyperion Financial Report?
    I know its possible to limit the user POV based on the members they have access to (in Preferences) but we have a reporting requirement on the page dimension to prompt the user for what cost centres they want to run the report for. When I used a prompt function the user gets to select any cost centre in the "choices" range regardless of whether they have access or not. We just want it to show what cost centres they have access to.
    Thanks

    If the datasource is ready only and not writeable for the users, then you can use MetaRead filters for cost centre, which will only show the hierarchies the users have access to.
    (You cannot mix Write and MetaRead filters in the same filter, it would be Write and Read).
    Let me know if that's an option.
    Cheers, Iain

  • Hyperion FR , Planning Details, Limit member selection based on access.

    Hi There
    I am working on a project
    Version 11.1.2.2, FR connected with "Planning Details""
    I want to limit POV "Entity" member selection based on access right and I don't want to set User POV one by one.
    For ex:
    US users don't need to see Canada users' entity.
    I am looking for a solution or workaround that can be easy to manage and save time.
    Highly appreciate and Thanks

    You can actually set the default values in jconsole. jconsole can be started with FRConfig.cmd (normally under C:\Oracle\Middleware\EPMSystem11R1\products\biplus\bin).
    Change the value of "com.hyperion.reporting.HRPrefs.filter_by_security" to true, this way, the the default values will be true for all users who haven't set it in user preference yet.
    This will list only the members which the users has access.
    I believe this is what you are looking for.
    Edited by: Krishna Kumar K P on Sep 14, 2012 9:50 AM

  • Action page based on Access Level

    I put this together using a couple of different sources. It
    worked until I put in the switch statement and commented out
    <cfset MM_redirectLoginSuccess="DRIVERS.CFM">
    Now, I am getting this error when the login is successful:
    Variable MM_REDIRECTLOGINSUCCESS is undefined.
    I'm just trying to let the user access level control which
    page they are routed to upon a successful login.
    Can anyone tell me what I can do to make this work?
    <cfif IsDefined("FORM.USERNAME")>
    <!-- <cfset MM_redirectLoginSuccess="DRIVERS.cfm">
    -->
    <cfset MM_redirectLoginFailed="INDEX.cfm">
    <cfquery name="MM_rsUser" datasource="vol" username=""
    password="">
    SELECT USERNAME,PSWD,ACCESS_LVL FROM dbo.USERS WHERE
    USERNAME='#FORM.USERNAME#' AND PSWD='#FORM.PASSWORD#'
    </cfquery>
    <cfif MM_rsUser.RecordCount NEQ 0>
    <cftry>
    <cflock scope="Session" timeout="30" type="Exclusive">
    <cfset Session.MM_Username=FORM.USERNAME>
    <cfset Session.MM_UserAuthorization= MM_rsUser.ACCESS_LVL
    >
    </cflock>
    <cfif IsDefined("URL.accessdenied") AND false>
    <cfset MM_redirectLoginSuccess=URL.accessdenied>
    </cfif>
    <cfswitch expression="#MM_rsUser.ACCESS_LVL#">
    <cfcase value="A">
    <cfset MM_redirectLoginSuccess="DRIVERs.cfm">
    </cfcase>
    <cfcase value="B" >
    <cfset MM_redirectLoginSuccess="VOL_GRID.cfm">
    </cfcase>
    </cfswitch>
    <cflocation url="#MM_redirectLoginSuccess#"
    addtoken="no">
    <cfcatch type="Lock">
    <!--- code for handling timeout of cflock --->
    </cfcatch>
    </cftry>
    <cfelse>
    <cflocation url="#MM_redirectLoginFailed#"
    addtoken="no">
    <cfset MM_LoginAction=CGI.SCRIPT_NAME>
    <cfif CGI.QUERY_STRING NEQ "">
    <cfset MM_LoginAction=MM_LoginAction & "?" &
    XMLFormat(CGI.QUERY_STRING)>
    </cfif>
    </cfif>
    </CFIF>
    <cfset MM_LoginAction=CGI.SCRIPT_NAME>
    <cfif CGI.QUERY_STRING NEQ "">
    <cfset MM_LoginAction=MM_LoginAction & "?" &
    XMLFormat(CGI.QUERY_STRING)>
    </cfif>
    <head>
    </head>
    <html>
    <body>
    <form
    action="<cfoutput>#MM_loginAction#</cfoutput>"
    method="POST" name="index">
    <input type="text" name="USERNAME" accesskey="1"
    tabindex="1" id="USERNAME" />
    <label for="USERNAME">USERNAME</label>
    <p>
    <input type="text" name="PASSWORD" accesskey="2"
    tabindex="2" id="PASSWORD" />
    <label for="PASSWORD">PASSWORD</label>
    </p>
    <p>
    <input type="submit" name="Submit" value="Submit"
    accesskey="3" tabindex="3" id="Submit" />
    <label for="Submit">SUBMIT</label>
    </p>
    </form>
    </body>
    </html>

    You somehow have a case where the variable
    MM_REDIRECTLOGINSUCCESS is not defined. The best practice is to
    cfparam or set a default to the variable, even if it's to an error
    page so you don't get these undefined errors. Also, indenting helps
    code readabilitly a lot.

  • Restrict certain function based on access level

    I'm working through an approval process with Office 365 SharePoint Lists and Infopath, and I want certain people to be able to submit items in a Sharepoint list on behalf of someone else. So, the boss might have her assistant post news for her,
    but her name will be on it. I only want certain people with a higher access level to be able to do this. Most people will just be able to submit news on their own behalf. I'm not sure how to do this other than to actually have a separate list that only certain
    people can access to support this one function.
    Currently I have lists for...
    Draft Items
    Submitted Items
    Published Items
    and I might create a fourth one for "Drafts Items on behalf of." Can you think of a better way than to actually create a fourth list?

    Hi  ,
    According to your description, my understanding is that you want to three permission level for a list: unable submit and unable approval, able submit and unable approval, able submit and able approval.
    If you just want to restrict  for a list, you can try to stop inheriting permissions for the list.
    For the above permission level, it can be reflected to the SharePoint default permission level: read, edit, approve. So for achieving your demand, you can add the users  into  suitable permission
    group (Site Visitors, Site Members, Approvers).
    Then you can go to the list ->List Settings ->Versioning Settings, select “Yes” for Require content approval for submitted items.
    Best Regards,
    Eric
    Eric Tao
    TechNet Community Support

  • How can I restrict the user to run the report based the access level at access table backend?

    I have a report which pulls data of servicetickets. Now I have to work on security part which should retrict the people to look for specif sales team tickets based on their access at backend. They should access the tickets of the sales teams which they have
    access. Can anyone help on this.
    Thanks,
    Swapna

    Getting error as
    Msg 536, Level 16, State 2, Line 7
    Invalid length parameter passed to the RIGHT function.
    and
    (Tut.AdloginID
    = RIGHT(@ReportUser,
    PATINDEX('%\%',
    REVERSE(@ReportUser))
    -1)
    OR
    EXISTS (
    SELECT *
    FROM dbo.TicketingUserTeams Tut
    WHERE Tut.Team
    = 'Ticketing Admin'
    AND Tut.AdloginID
    = RIGHT(@ReportUser,
    PATINDEX('%\%',
    REVERSE(@ReportUser))
    -1)
    Swapna

  • How do I limit a user's FTP access?

    I would like to be able to allow someone to log on via FTP, but only be able to see their home directory -- not what other users have in their home directories, the files in the root directory, etc. I have read that this is possible with OS X Server, but can you do it with plain old Tiger?

    If the person is already logged on to wireless and you change the password or key, they will probably be able to stay online until they disconnect from the wireless network. The next time they try to log on, they will receive an error message stating that they have entered an incorrect password.
    Ideally, you would find a way to turn off the other computer for a few minutes, then change the password. Then the other computer would not be able to log onto the wireless unless they had the correct password.
    I would suggest that you go with the change password / network key route. Things get a bit tricky with the other method outlined below.
    "Also, how do you take a computer off the allow list? That might be the easiest way to do it."
    The "allow" list is made up of computers that you DO want to be able to connect. If you leave the computer that you DON'T want to connect off the "allow" list, they will not be able to connect.
    You will need to enter the MAC address of every computer that you DO want to allow to connect. Any computer that is not on this list will not be able to connect.
    Open AirPort Utility, Click Manual Setup
    Click the Access tab just below the row of icons
    On the MAC Access Control setting, select Timed Access and follow the prompts
    See pages 47-48 in the AirPort Network Guide for details
    http://manuals.info.apple.com/enUS/Apple_AirPort_NetworksEarly2009.pdf

  • How to change lookup code  with Access Level as 'System'

    Hi,
    I need to append new lookup codes in a lookup type having access level as 'SYSTEM'. Is there any standard way to do the same or just updating the customization level column will do ? Please let me know if you have any solution for this.
    Regards
    Girish

    You can also change the meaning on that value to something like "*** DO NOT USE***". This will make it obvious to the user that he/she should not choose it.
    You can try to add a when-validate-record personalization to show error if someone selected a disabled value.
    You can also try to modify the list of values associated with the field using personalizations.
    If nothing else works, you can use a SQL to uncheck the enabled flag. The risks involved in this are well known.
    Hope this answers your question
    Sandeep Gandhi
    Independent Consultant
    513-325-9026

  • Non-SysAdmins get error 18456 Severity 14 State 11 Login Failed for user _ Reason Token-based server access validation failed with an infrastructure error.

    I have a SQL 2008 R2 system (10.50.4000) where I'm having problems connecting any user that is not a SysAdmin.  Example: I setup a new SQL Login to use Windows Authentication and grant that user db_datareader on the target database.  The user attempts
    to connect using Excel client or Access or SQL Management Studio and receives Error 18456.  The SQL Server Logs shows Error 18456 Severity 14 State 11 Login Failed for user _ Reason Token-based server access validation failed with an infrastructure error.
    The strange part is that if I temporarily grant the user the sysadmin server role then the user can connect successfully and retrieve data.  But, if I take away that sysadmin server role then the user can no longer connect but again receives the Error
    18456 Severity 14 State 11 Login Failed for user _ Reason Token-based server access validation failed with an infrastructure error.
    We've turned off UAC on the client machine to see if that was the problem, but no change.
    I have dropped and re-added the user's SQL Login (and the related database user login info).  No success.
    The Ring Buffers output shows:
    The Calling API Name: LookupAccountSidInternal
    API Name: LookupAccountSid
    Error Code: 0x534
    Thanks for any help.
    -Walt

    Yes, you understand correctly.  The user is logging onto a workstation (not the server) with a Windows Authenticated id.  The user is using either Excel or Access or SSMS and connecting to the server using a Windows Authenticated SQL Login account.
     If the account has sysadmin role (which is only for testing) then the connection is successful.  If I take away sysadmin role from the account then the connection is unsuccessful and the SQL Server Log shows Error
    18456 Severity 14 State 11 Login Failed for user _ Reason Token-based server access validation failed with an infrastructure error.
    (SQL Authentication is not an option here.  I must use Windows Authentication).
    Any other troubleshooting assistance you can offer would be appreciated.  Thanks.
    -Walt 

  • Restrict Access to certain users based on if a variable in the SQL database is set to 1

    Hey guys,
    I am quite new to PHP and MySQL and I have a question concerning access  restriction. For a website project I am experimenting with Dreamweaver's  login and restrict access behavior, which works fine. However, on the  website I would like to restrict access for users that only have a 1 set  in the corresponding MySQL database (which means that e.g. each page has a different variable in the database that can be set to 1, which would allow me to personify access beyond the level of the out-of-the box option, where each user can only have one access level). So it is quite similiar to the  out-of-the-box restrict access to page based on user group, but just  depending on another variable in the database.
    I guess it can be done with an if condition that checks in the database if the logged in user has a 1 in this variable, and if yes give her/him access if not redirect to another page. However, I could not figure out  how to implement that.
    Your help is highly appreciated!
    Thanks in advance!

    Hello guys,
    I spend quite some time on the internet reseaching my wish and redefined my need: I would basically like to have the possibility to assign a user multiple access levels. There would be e.g. 10 pages for each I create an access level. Then a user with e.g. access to pages 2 and 8 can only access these two pages. So my basic question is if and if yes how I can assign a user muliple access levels at a time and store these values in the MySQL database.
    Thanks a lot for your help!!

  • Database design for Role/User based access to the application..

    We want to implement Role/User based access to the application.
    Can anyone tell me whats the optimized way of storing the data {User, Role, Access_Type etc} in the database.. The Roles might get added in the future so i dont want to maintain a single table to map User-Access_Type..
    Access_Type -->
    AT_1 | AT_2 |AT_N |
    ------- |------- |------- -|------|
    User_1 | | | |
    ------- |------- |--------|------ |
    User_2 | | | |
    ------- |------ -|--------|------ |
    I want to maintain a table which will map user with the Access_Type, which should be mainatained in a different table..
    Any help would be highly appreciated..
    Thanks in Advacnce,
    Shridhar..

    You find your answer here:
    http://jakarta.apache.org/tomcat/tomcat-5.0-doc/realm-howto.html

  • In BD87  T /c  is it possible to control user based in Comp code...?

    In BD87  T /c  is it possible to control user based in Comp code...?
    Thanks
    Mahi

    BD87 is a transaction to work with IDOCs.
    one IDOC e.g. for vendor master can have several segments with different company codes.
    But you cannot post an IDOC only partially, that is technically not possible and does not make much sense.
    Further the IDOC segment in the table is just one huge field, It does not have single fields like company code.It is a generic field that can keep the segments of any IDOC.
    In my opinion there is no way to control it at company code level.
    In any case you posted it in the wrong forum. BD87 is not a MM transaction.
    Hence, moving it to the Abap Connectivity forum

  • Get all sap users based on company code

    Hi,
    In my workflow i need an activity which will popup all sap users based on the company code. can anyone guide me by giving the table which is having relationship between sap user and company code. Any direct relation or indirect relation?
    Thanks
    sheron

    Hi Arghadip,
    Actually the tables u were mentioning were HR Tables right.
    But these tables are not maintained in this project. This is an SAP-ISU project.
    regards
    sheron

  • User based rate limit

    Hi,
    Iam looking for a way to Rate Limit - Vlan interfaces,
    Somting like this .. or do I need to change the service-policy to rate-limit for it to work
    Interface Vlan2
    Description Customer-A
    service-policy input police-customerA-traffic
    service-policy output police-customerA-traffic
    ip address 10.10.10.1 255.255.255.252
    Interface Vlan3
    Description Customer-B
    service-policy input police-customerB-traffic
    service-policy output police-customerB-traffic
    ip address 10.10.11.1 255.255.255.252
    Interface Vlan4
    Description Customer-C
    service-policy input police-customerC-traffic
    service-policy output police-customerC-traffic
    ip address 10.10.12.1 255.255.255.252
    Interface GigabitEthernet3/1
    Description Trunk - Customer-A - Customer-C
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 2,4
    switchport mode trunk
    Interface GigabitEthernet3/1
    Description Trunk - Customer-B
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 3
    switchport mode trunk
    Is that posible ??, or do i need to make user based rate limit based on Source / destination adresses, and move the service policy to the physical interface ??
    Hardware in this case Cisco 7609 running MPLS
    Thanks in advance.
    /Peter

    Can you explain your network topology a little?. This would help me to understand your network setup and help you in this issue accordingly.

  • Can you limit the amount of data accessed per user on an AirPort Extreme?

    Can you limit the amount of data accessed per user on an AirPort Extreme?

    Your question was whether the AirPort Extreme is able to establish data limits per user.
    If you add another router that has this type of capability or install software on another router, then you will be able to establish data limits for each user. The AirPort Extreme will have no control over this.

Maybe you are looking for