Pkg-config help

I searched the forums but I'm still a little lost. Trying to build xarchiver.
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for pkg-config... no
checking for PACKAGE... configure: error: The pkg-config script could not be found or is too old. Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.
Now, the search on the forums told me I need to make sure the .pc file is in my package config path. However, I don't know what .pc file I'm looking for. Thanks for the help.

[root@workstation64 andyrtr]# pacman -Qo /usr/bin/pkg-config
/usr/bin/pkg-config is owned by pkgconfig 0.19-1
So "pacman -Sy pkgconfig" should solve it.

Similar Messages

  • Pkg-config doesn't find libmfx

    Hi,
    I'm trying to build ffmpeg with h264_qsv (QuickSync) support. In order to do that, I need libmfx. But pkg-config doesn't find the libmfx files, although they are present:
    PKG_CONFIG_PATH is filled with the correct path:
    [root@nuc FFmpeg]# echo $PKG_CONFIG_PATH
    /usr/lib/pkgconfig/
    The libmfx files are there:
    [root@nuc FFmpeg]# ls -l /usr/lib/pkgconfig/libmfx.*
    -rw-r--r-- 1 root root 120284 Jun 20 19:25 /usr/lib/pkgconfig/libmfx.a
    -rwxr-xr-x 1 root root 893 Jun 20 19:25 /usr/lib/pkgconfig/libmfx.la
    -rw-r--r-- 1 root root 339 Jun 20 20:05 /usr/lib/pkgconfig/libmfx.pc
    The libmfx.pc contents seems ok?
    [root@nuc FFmpeg]# cat /usr/lib/pkgconfig/libmfx.pc
    prefix=/usr/local
    exec_prefix=${prefix}
    libdir=${prefix}/lib
    includedir=${prefix}/include
    Name: libmfx
    Description: Intel Media SDK Dispatched static library
    Version: 2013
    Requires:
    Requires.private:
    Conflicts:
    Libs: -L${libdir} -lsupc++ ${libdir}/libmfx.a
    Libs.private:
    Cflags: -I${includedir} -I/media/downloads/opensource/SDK/include/
    The header files are at the included in the SDK dir:
    [root@nuc FFmpeg]# ls -l /media/downloads/opensource/SDK/include/
    total 168
    -rw-r--r-- 1 zao zao 4835 Jun 3 09:58 mfxastructures.h
    -rw-r--r-- 1 zao zao 5479 Jun 3 09:58 mfxaudio++.h
    -rw-r--r-- 1 zao zao 3493 Jun 3 10:02 mfxaudio.h
    -rw-r--r-- 1 zao zao 4767 Jun 3 10:00 mfxcommon.h
    -rw-r--r-- 1 zao zao 6306 Jun 3 09:58 mfxdefs.h
    -rw-r--r-- 1 zao zao 2865 Jun 3 10:00 mfxenc.h
    -rw-r--r-- 1 zao zao 2976 Jun 3 09:58 mfxjpeg.h
    -rw-r--r-- 1 zao zao 2900 Jun 3 10:00 mfxla.h
    -rw-r--r-- 1 zao zao 3048 Jun 3 09:58 mfxmvc.h
    -rw-r--r-- 1 zao zao 2881 Jun 3 09:58 mfxpak.h
    -rw-r--r-- 1 zao zao 28117 Jun 3 09:58 mfxplugin++.h
    -rw-r--r-- 1 zao zao 11066 Jun 3 10:00 mfxplugin.h
    -rw-r--r-- 1 zao zao 2647 Jun 3 09:58 mfxsession.h
    -rw-r--r-- 1 zao zao 38541 Jun 3 10:00 mfxstructures.h
    -rw-r--r-- 1 zao zao 10411 Jun 3 10:00 mfxvideo++.h
    -rw-r--r-- 1 zao zao 6257 Jun 3 10:00 mfxvideo.h
    -rw-r--r-- 1 zao zao 2690 Jun 3 09:58 mfxvp8.h
    -rw-r--r-- 1 zao zao 1662 Jun 3 09:58 mfxvstructures.h
    But configure cant't find the files:
    [root@nuc FFmpeg]# git pull
    Already up-to-date.
    [root@nuc FFmpeg]# ./configure --enable-libmfx --enable-nonfree --enable-iconv --arch=x86 --disable-debug --disable-shared --disable-doc --disable-w32threads --enable-gpl --enable-version3 --enable-runtime-cpudetect --enable-avfilter --enable-bzlib --enable-zlib --enable-librtmp --enable-gnutls --enable-avisynth --enable-frei0r --enable-filter=frei0r --enable-libbluray --enable-libcaca --enable-libopenjpeg --enable-fontconfig --enable-libfreetype --enable-libass --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-libschroedinger --enable-libsoxr --enable-libtwolame --enable-libspeex --enable-libtheora --enable-libutvideo --enable-libvorbis --enable-libvo-aacenc --enable-libopus --enable-libvidstab --enable-libvpx --enable-libwavpack --enable-libxavs --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzvbi
    ERROR: libmfx not found using pkg-config
    If you think configure made a mistake, make sure you are using the latest
    version from Git. If the latest version fails, report the problem to the
    [email protected] mailing list or IRC #ffmpeg on irc.freenode.net.
    Include the log file "config.log" produced by configure as this will help
    solve the problem.
    Sorry for being new at this, but I really want to learn
    Thanks in advance, zAo

    Did a restart from scratch: removed all *mfx* files from /usr/*, removed all build files and downloaded them again. Apart from make install, everything is run as my desktop user.
    [zao@nuc mfx_dispatch]$ mkdir build && cd build
    [zao@nuc build]$ cmake .. -DCMAKE_INSTALL_PREFIX=/usr/local
    -- The C compiler identification is GNU 5.1.0
    -- The CXX compiler identification is GNU 5.1.0
    -- Check for working C compiler: /usr/bin/cc
    -- Check for working C compiler: /usr/bin/cc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    -- Intel Media SDK is here: /media/downloads/git/mfx_dispatch
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /media/downloads/git/mfx_dispatch/build
    Start build
    [zao@nuc build]$ make -j
    Scanning dependencies of target mfx
    [ 8%] [ 16%] [ 25%] [ 50%] [ 41%] [100%] [ 41%] [ 66%] [ 66%] [ 75%] [ 83%] [ 91%] Building CXX object CMakeFiles/mfx.dir/src/mfx_dxva2_device.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/main.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_library_iterator.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_library_iterator_linux.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_critical_section.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_load_dll.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_dispatcher_log.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_function_table.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_critical_section_linux.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_load_dll_linux.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_dispatcher.cpp.o
    Building CXX object CMakeFiles/mfx.dir/src/mfx_win_reg_key.cpp.o
    Linking CXX static library libmfx.a
    [100%] Built target mfx
    Install
    [zao@nuc build]$ sudo make install
    [100%] Built target mfx
    Install the project...
    -- Install configuration: ""
    -- Installing: /usr/local/include/mfxjpeg.h
    -- Installing: /usr/local/include/mfxplugin++.h
    -- Installing: /usr/local/include/mfxastructures.h
    -- Installing: /usr/local/include/mfxla.h
    -- Installing: /usr/local/include/mfxenc.h
    -- Installing: /usr/local/include/mfxcommon.h
    -- Installing: /usr/local/include/mfxplugin.h
    -- Installing: /usr/local/include/mfxvp8.h
    -- Installing: /usr/local/include/mfxdefs.h
    -- Installing: /usr/local/include/mfxmvc.h
    -- Installing: /usr/local/include/mfxstructures.h
    -- Installing: /usr/local/include/mfxvideo.h
    -- Installing: /usr/local/include/mfxvstructures.h
    -- Installing: /usr/local/include/mfxaudio++.h
    -- Installing: /usr/local/include/mfxpak.h
    -- Installing: /usr/local/include/mfxvideo++.h
    -- Installing: /usr/local/include/mfxaudio.h
    -- Installing: /usr/local/include/mfxsession.h
    -- Installing: /usr/local/lib/pkgconfig/libmfx.pc
    -- Installing: /usr/local/lib/libmfx.a
    pkg-config doesn’t find the right files:
    [zao@nuc build]$ pkg-config --list-all| grep mfx
    [zao@nuc build]$ echo $?
    1
    I know that building via PKGBUILD is much cleaner, but -for me- it add additional levels of complexity.
    Any tips or ideas? Thanks for your patience

  • Pkg-config is missing x11.pc

    Hello list,
    I tried to compile 'cairo' from source.
    When running configure, pkg-config is checking for Package x11.
    checking for xlib... Package x11 was not found in the pkg-config search
    path.
    Perhaps you should add the directory containing `x11.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'x11' found
    Can anyone tell me which package/s provide this file and/or if this is part of any SUN Package?
    I'm using gcc 3.4.6 from SunFreware
    Any help would be appreciated,
    Thanks
    Wolfgang

    The missing x11.pc is a known issue
    http://bugs.opensolaris.org/view_bug.do?bug_id=6571762
    Workaround: Create /usr/lib/pkgconfig/x11.pc:
    prefix=/usr/openwin
    exec_prefix=${prefix}
    libdir=${exec_prefix}/lib
    includedir=${prefix}/include
    xthreadlib=
    Name: X11
    Description: X Library
    Version: 0.0
    Requires: xproto kbproto inputproto
    Requires.private: xau xdmcp
    Cflags: -I${includedir} -I/usr/X11/share/include -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DXTHREADS -DXUSE_MTSAFE_API
    Libs: -L${libdir} -R${libdir} -lX11
    Libs.private:

  • [ SOLVED ] pkg-config package and yaourt fails

    hi,
    I am using yaourt to install packages from the AUR.
    Everytime i try to install a package that requires pkgconfig as a dependancy yaourt downloads pkg-config and installs it even though I already have this package installed.
    After installing pkg-config, yaourt outputs the message:
    Install or build missing dependencies for <packagename>:
    were packagename is the name of the package i was trying to install. It then goes back to the prompt
    I am running arch64. How can i fix this?
    This is an example of the entire process. I am trying to install gnome-globalmenu.
    [abes@Archlinux ~]$ yaourt -S gnome-globalmenu
    ==> Resuming previous build
    ==> Downloading gnome-globalmenu PKGBUILD from AUR...
    --2010-11-18 20:18:46-- http://aur.archlinux.org/packages/gnome-globalmenu/gnome-globalmenu.tar.gz
    Resolving aur.archlinux.org... 208.92.232.29
    Connecting to aur.archlinux.org|208.92.232.29|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1408 (1.4K) [application/x-tgz]
    Saving to: "gnome-globalmenu.tar.gz"
    100%[======================================>] 1,408 --.-K/s in 0s
    2010-11-18 20:18:47 (58.0 MB/s) - "gnome-globalmenu.tar.gz" saved [1408/1408]
    bsdtar: Removing leading '/' from member names
    x gnome-globalmenu.install
    x PKGBUILD
    Comment by: dottorblaster on Fri, 23 Apr 2010 17:34:53 +0000
    looks like this project is dead :(
    Comment by: gartz on Tue, 11 May 2010 12:56:13 +0000
    xfce4 supported. Just edit in the PKGBUILD (configure line): from '--with-gnome-panel' to '--without-gnome-panel --with-xfce4-panel'.
    Will work fine! :) Tkx dottorblaster!
    Comment by: dottorblaster on Tue, 11 May 2010 13:39:58 +0000
    Yeah, there is the XFCE package for this.
    Comment by: JPEC on Sun, 12 Sep 2010 16:23:30 +0000
    gartz, for xfce, after installing the PKG and adding the applet in the panel, is it something more to do?
    Comment by: scorpfa on Thu, 07 Oct 2010 18:04:59 +0000
    Dependency 'gnome-panel-bonobo' missing
    First Submitted: Tue, 10 Feb 2009 00:06:36 +0000
    gnome-globalmenu 0.7.10-1 : Global Menu Bar for GNOME
    ( Unsupported package: Potentally dangerous ! )
    ==> Edit PKGBUILD ? [Y/n] ("A" to abort)
    ==> ----------------------------------------------
    ==>n
    ==> gnome-globalmenu dependencies:
    - gnome-panel (already installed)
    - libnotify (already installed)
    - gnome-panel-bonobo (already installed)
    - vala (already installed)
    - libtool (already installed)
    - pkgconfig (building from AUR)
    - intltool (already installed)
    ==> Edit gnome-globalmenu.install ? [Y/n] ("A" to abort)
    ==> ----------------------------------------------
    ==>n
    ==> Continue the building of gnome-globalmenu ? [Y/n]
    ==> ----------------------------------------------
    ==>y
    ==> Building missing dependencies from AUR:
    Password:
    warning: provider package was selected (pkg-config provides pkgconfig)
    warning: pkg-config-0.25-2 is up to date -- reinstalling
    resolving dependencies...
    looking for inter-conflicts...
    Targets (1): pkg-config-0.25-2
    Total Download Size: 0.00 MB
    Total Installed Size: 0.18 MB
    Proceed with installation? [Y/n] y
    checking package integrity...
    (1/1) checking for file conflicts [######################] 100%
    (1/1) upgrading pkg-config [######################] 100%
    ==> Install or build missing dependencies for gnome-globalmenu:
    [abss@Archlinux ~]$
    Last edited by Abraham Salloum (2011-06-11 23:32:18)

    Updating yaourt fixed it. What happened was that before i knew what the AUR was - i had installed a lot of community supported repos. After installing youart i removed the community supported repos because i thought i didn't need them.
    I didn't realise that yaourt was not in the official repositories, so the package was never able to upgrade.
    yaourt should be in the official repos.
    Thanks a lot for your help.

  • Having trouble getting waf to create a pc file for pkg-config

    Hello Arch Linux forums!
    After successfully building and installing some monome tools on my debian machine, I thought I'd migrate over to developing things on arch linux.
    However, I'm having trouble building my project because pkg-config cannot find libmonome after a fresh build.  It complains that there's no libmonome.pc in my $PKG_CONFIG_PATH.  Sure enough, libmonome.pc does not exist, while it does on my debian machine.
    I suspect it's some sort of permissions / path issue that I need to account for, but I'm unaware as to where to start looking.  Has anyone else used waf and encountered similar issues?
    Thanks in advance!

    Well the configuration file you chose does not allow users created in NetWeaver to be created in the LDAP.  That's why it's a "readonly" configuration.  I would guess that you need a custom configuration file specifically for open ldap.
    This should help get you started on a custom configuration file:
    http://help.sap.com/saphelp_nw2004s/helpdata/en/b7/14d43f2dd44821e10000000a1550b0/frameset.htm
    Then again, if the only problem with the .XML file you chose is that you can't write to the LDAP, give the dataSourceConfiguration_ads_writeable_db.xml configuration file a shot.

  • Libpng and pkg-config

    Hi all,
    I'm working on compiling a couple components on my mac. I've hand compiled libpng for use with the cairo library. I'm finding that, for some odd reason, pkg-config doesn't have libpng in its search path.
    Any ideas on getting this working?
    Thank you for your help in advance!
    Sincerely,
    Jason
    Message was edited by: Jason Saumur

    I'm not sure what you might be missing when building this by hand, but I just use the fink package manager, and it will install stuff like cairo with all the required supporting libraries like libpng, etc.
    http://www.finkproject.org/
    there are some other options, like MacPorts or DarwinPorts also.

  • Gtkmm pkg config entry missing

    Hello I'm missing the pkg-config entry for gtkmm on arch x86-64. I'm wondering why it wasn't installed automatically. Can you help me out?

    $ pacman -Ql gtkmm | grep pc
    gtkmm /usr/lib/pkgconfig/atkmm-1.6.pc
    gtkmm /usr/lib/pkgconfig/gdkmm-2.4.pc
    gtkmm /usr/lib/pkgconfig/gtkmm-2.4.pc
    is there.

  • I keep getting "pkg-config: could not find or read package"

    trying to install firefox-branded using yaourt
    [anthony@arch yaourt]$ yaourt -S firefox-branded
    ==> Downloading firefox-branded PKGBUILD from AUR...
    bsdtar: Removing leading '/' from member names
    x firefox-safe.desktop
    x browser-defaulturls.patch
    x PKGBUILD
    x firefox.install
    x mozilla-firefox-1.0-lang.patch
    x firefox.desktop
    x firefox-version.patch
    x firefox-agent.patch
    x mozconfig
    Comment by: wantilles on Wed, 21 Jul 2010 12:34:35 +0000
    Upstrem update to 3.6.7.
    Comment by: geo on Wed, 21 Jul 2010 12:46:53 +0000
    As reliable as ever, thanks wantilles :)
    Comment by: wantilles on Wed, 21 Jul 2010 16:27:56 +0000
    @ ropez fzerorubigd tschertel
    I won't answer the same questions twice.
    See my comment on Mon, 28 Jun 2010 15:51:20 +0000.
    Comment by: fzerorubigd on Wed, 21 Jul 2010 18:18:22 +0000
    :) I just want to report this is out of date and why I flag this as out of date. nothing else.
    Comment by: wantilles on Sat, 24 Jul 2010 11:36:22 +0000
    Upstream update to 3.6.8.
    Comment by: fzerorubigd on Wed, 11 Aug 2010 17:56:44 +0000
    Its a good work, but can you add default dictionary to this too? I mean just add a dictionaries folder inside installation folder and copy to en-US.dic and en-US.aff from mozilla-1.9.2/extensions/spellcheck/locales/en-US/hunspell folder?
    Thanks for your great work.
    First Submitted: Wed, 25 Jun 2008 06:41:54 +0000
    firefox-branded 3.6.8-1 : Standalone web browser from mozilla.org
    ( Unsupported package: Potentially dangerous ! )
    ==> Edit PKGBUILD ? [Y/n] ("A" to abort)
    ==> ------------------------------------
    ==> n
    ==> firefox-branded dependencies:
    - desktop-file-utils (already installed)
    - zip (already installed)
    - diffutils (already installed)
    - libgnomeui>=2.24.1 (already installed)
    - python (already installed)
    - wireless_tools (already installed)
    - xulrunner=1.9.2.8 (building from AUR)
    - pkg-config (building from AUR)
    ==> Edit firefox.install ? [Y/n] ("A" to abort)
    ==> -------------------------------------------
    ==> n
    ==> Continue building firefox-branded ? [Y/n]
    ==> -----------------------------------------
    ==>
    ==> Building and installing package
    ==> Install or build missing dependencies for firefox-branded:
    Password:
    error: 'pkg-config': could not find or read package
    ==> WARNING: Dependencies have been installed before the failure
    ==> Restart building firefox-branded ? [y/N]
    ==> ----------------------------------------
    ==>
    ==> WARNING: Following packages have not been installed:
    firefox-branded
    I have pkg-config installed (pacman -S base-devel) and ran pacman -Syyu after.

    ==> Making package: firefox-branded 3.6.8-1 (Tue Aug 24 03:59:02 PDT 2010)
    ==> Checking Runtime Dependencies...
    ==> Missing Dependencies:
    -> xulrunner=1.9.2.8
    ==> Checking Buildtime Dependencies...
    ==> Missing Dependencies:
    -> pkg-config
    ==> ERROR: Could not resolve all dependencies.
    thats what I get with makepkg -i

  • Pkg-config troubles

    I need to install Mono, but I can't without pkg-config.  The problem is, I can't install pkg-config.  It configures well, but the 'make' is messy with all sorts of warnings about null pointers, and 'make install' doesn't do a thing.
    What might be the problem?

    ac3raven wrote:I need to install Mono, but I can't without pkg-config.
    I guess you're trying to build it manually, but why?  You can just use pacman -S mono to get mono.
    ac3raven wrote:The problem is, I can't install pkg-config.  It configures well, but the 'make' is messy with all sorts of warnings about null pointers, and 'make install' doesn't do a thing.
    You don't even need it if you just use pacman to install mono, but you just use pacman -S pkgconfig or pacman -S base-devel if you plan to build things manually.
    Last edited by tdy (2009-09-28 01:45:09)

  • [Solved] pkg-config too old

    I was just trying to install the isight-firmware-tools (http://aur.archlinux.org/packages.php?ID=23525) from the aur with yaourt (yaourt -S isight-firmware-tools), but I get the following error while installing:
    checking for unistd.h... yes
    checking gcrypt.h usability... yes
    checking gcrypt.h presence... yes
    checking for gcrypt.h... yes
    checking for makeinfo... ${SHELL} /tmp/yaourt-tmp-jan/aur-isight-firmware-tools/isight-firmware-tools/src/isight-firmware-tools-1.4.1/missing --run makeinfo
    checking for pkg-config... no
    checking for IFT... configure: error: The pkg-config script could not be found or is too old. Make sure it
    is in your PATH or set the PKG_CONFIG environment variable to the full
    path to pkg-config.
    Alternatively, you may set the environment variables IFT_CFLAGS
    and IFT_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    To get pkg-config, see <http://pkg-config.freedesktop.org/>.
    See `config.log' for more details.
    make: *** No targets specified and no makefile found. Stop.
    ==> ERROR: Build Failed.
    Aborting...
    Error: Makepkg was unable to build isight-firmware-tools package.
    Does anyone know what to do? I have a 64-bit system, extra and community enabled.
    pkgtools 13-1 from community is installed already...
    Last edited by rggjan (2009-09-11 10:11:54)

    Of course ... not
    I somehow thought, this was included in the pkgtools package when a package "pkg-config" didn't exist, but there is a package "pkgconfig" (without "-").
    Installing that solved the problem, thanks!

  • Upstream pkg-config Depend and Installed Version Descrepancies

    Hi,
    I'm attempting to update the AUR package for gnome-gmail-notifier to agree to the latest release upstream. The problem is, that the upstream configure script checks for the dependancy libsoup-2.2 using pkg-config. In an up to date Arch install however, there does not exist a libsoup-2.2.pc file. Instead, we have libsoup-2.4.pc.
    In this case, the dependancy is technically met, but the configure script fails anyways. In the Arch Linux world, how is this discrepancy properly handled? Upstream? Is there something to handle this in the context of the PKGBUILD file?
    I know how to fix this for myself, on this machine. I'm more curious how the folks of Arch that want to make a proper package would handle this.
    Cheers,
    ~djc

    Just to not leave this thread hanging, I decided to use sed to edit the configure.ac file in the PKGBUILD build() function. Does the trick, but I'm not sure it's the proper way. I do see sed being used for many modifications in other packages, however, so I'll run with this solution for now

  • [SOLVED] pkg-config gtkmm3?

    Hi!
    I'm surprised I don't see a pkg-config for the library gtkmm 3.
    I don't know how to know if a package has it's pkg-config or not.
    Do you know?
    Thanks.
    Last edited by Creak (2013-10-27 13:06:00)

    @Tribly: I don't know really well what pkgfile can do... Apparently it'd be a good idea to learn a bit more about it
    What's the difference between pkgfile and pacman -Q ??
    Last edited by Creak (2013-10-27 13:08:37)

  • Does pkg-config come with 10.6 or its dev tools (10.6.4 + 3.2.3 w/iOS SDK)?

    I had pkg-config installed from MacPorts (in /opt/local/bin). I removed it today and realized I had another copy of pkg-config in /usr/bin.
    I don't remember installing pkg-config without MacPorts, but two people I know don't have pkg-config in /usr/bin (they claim to have a "vanilla" Xcode 3.2.3 install, with only a few other things installed -- yasm, git, but not pkg-config).
    Can someone with 10.6.4, Xcode 3.2.3 and no third-party pkg-config installation tell me whether they have pkg-config in /usr/bin?

    Indeed.
    FWIW, you can remove them using the script provided there: http://www.mono-project.com/Mono:OSX#UninstallingMono_on_Mac_OSX

  • Airport General Config Help Required

    I've got a wireless Thomson broadband router hooked up downstairs running DHCP server, and upstairs I've got an airport extreme configured in bridge mode. I've got a MAC Mini directly ethernet cabled to the AE.
    I can connect to the internet from the Mac, but cannot see a couple of ethernet devices connected to the remaining two AE ethernet ports (Windows Home Server and Buffalo Linkstation).
    I can change the config so that the AE acts as the DHCP server, am then able to use WHS and the Linkstation, but not internet.
    Can anyone give me any pointers as to how to configure it up (if at all possible). Does the AE need to be hard wired to the router?
    Thanks

    Hello Sai Narayana,
    Our client wants to implement whole travel management in ESS, I am new to SAP travel management, Could you please help me in starting the configuration of create travel request, which node the master cost center is configured. I looked under financial accounting->travel management->Travel Planning and Travel Expenses but couldnt figure out where the travel request will be configured. We are using ECC 6.0. Your help is very much appreciated as I am doing configuration alone i dont have any other help.
    I have question regading Travel Planning if we want to implement travel planning do we have to use AMADEUS or can we integrate the clients present used travel link to R/3 using RFCs.
    Regards,
    Latha

  • Autonomous 1231/1242 Radius Config Help. What is this not working?

    Hey Guys,
    I can't seem to get the SSID RadiusTest to work properly.
    Windows PC's show "Windows was unable to find a certificate to log you into the network". Macs don't authenticate either. Radius server isn't seeing any requests at all. Radius server is working because we are authenticating other things to it.
    On my test 1231, IOS is 12.3(8) JEB1.
    And all help is appreciated.
    Thanks,
    Scott
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname TKS-AP1231-ICTServices
    enable secret 5 $1$Izyg$qXSRYpFDI9ZX6F50vDrku0
    clock timezone K 10
    clock summer-time K recurring
    ip subnet-zero
    ip domain lookup source-interface BVI1
    ip domain name domain.com.au
    ip name-server 172.16.###.###
    ip name-server 172.16.###.###
    aaa new-model
    aaa group server radius rad_eap
    server 172.16.###.### auth-port 1812 acct-port 1813
    ip radius source-interface BVI1
    aaa group server tacacs+ tac_admin
    aaa group server radius infrastructure
    aaa group server radius clients
    aaa group server radius central_auth
    aaa group server radius rad_mac
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa group server radius rad_eap1
    server-private 172.16.###.### auth-port 1812 acct-port 1813 key 7 060D062F4B5D1B18045GHW1E0718
    server 172.16.###.### auth-port 1812 acct-port 1813
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authentication login method_infrastructure group infrastructure
    aaa authentication login method_clients group clients
    aaa authentication login method_Central group central_auth local
    aaa authentication login eap_methods1 group rad_eap1
    aaa authorization exec default local
    aaa authorization exec method_Central group central_auth local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    dot11 mbssid
    dot11 vlan-name Conference vlan 150
    dot11 ssid RadiusTest
       vlan 18
       authentication open eap eap_methods
       authentication network-eap eap_methods
       authentication key-management wpa
       mbssid guest-mode
    dot11 ssid Staff
       vlan 17
       authentication open
       authentication key-management wpa optional
       wpa-psk ascii 7 055E5F5E0555401B161003171928013C22272D6B6370
    dot11 ssid Student
       vlan 16
       authentication open
       authentication key-management wpa
       guest-mode
       mbssid guest-mode
       wpa-psk ascii 7 02575102282A2323434F1B1D0C1915595A5C
    dot11 network-map
    dot11 arp-cache optional
    username ########## privilege 15 password 7 ###################
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 17 mode ciphers tkip wep40
    encryption vlan 16 mode ciphers tkip
    encryption vlan 18 mode ciphers aes-ccm tkip
    ssid RadiusTest
    ssid Staff
    ssid Student
    speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
    no power client local
    power client 50
    power local cck 50
    power local ofdm 20
    channel 2437
    station-role root
    interface Dot11Radio0.6
    encapsulation dot1Q 6 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.16
    encapsulation dot1Q 16
    no ip route-cache
    bridge-group 16
    bridge-group 16 subscriber-loop-control
    bridge-group 16 port-protected
    bridge-group 16 block-unknown-source
    no bridge-group 16 source-learning
    no bridge-group 16 unicast-flooding
    bridge-group 16 spanning-disabled
    interface Dot11Radio0.17
    encapsulation dot1Q 17
    no ip route-cache
    bridge-group 17
    bridge-group 17 subscriber-loop-control
    bridge-group 17 port-protected
    bridge-group 17 block-unknown-source
    no bridge-group 17 source-learning
    no bridge-group 17 unicast-flooding
    bridge-group 17 spanning-disabled
    interface Dot11Radio0.18
    encapsulation dot1Q 18
    no ip route-cache
    bridge-group 18
    bridge-group 18 subscriber-loop-control
    bridge-group 18 block-unknown-source
    no bridge-group 18 source-learning
    no bridge-group 18 unicast-flooding
    bridge-group 18 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    interface FastEthernet0.6
    encapsulation dot1Q 6 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface FastEthernet0.16
    encapsulation dot1Q 16
    no ip route-cache
    bridge-group 16
    no bridge-group 16 source-learning
    bridge-group 16 spanning-disabled
    interface FastEthernet0.17
    encapsulation dot1Q 17
    no ip route-cache
    bridge-group 17
    no bridge-group 170 source-learning
    bridge-group 17 spanning-disabled
    interface FastEthernet0.18
    encapsulation dot1Q 18
    no ip route-cache
    bridge-group 18
    no bridge-group 18 source-learning
    bridge-group 18 spanning-disabled
    interface BVI1
    ip address 172.16.#.### 255.255.255.192
    no ip route-cache
    ip default-gateway 172.16.#.###
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    logging history debugging
    snmp-server view iso iso included
    snmp-server community KingsRO RO
    snmp-server community KingsWr1t3 RW
    snmp-server trap-source BVI1
    snmp-server location ###
    snmp-server contact ############################################
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps tty
    snmp-server enable traps entity
    snmp-server enable traps disassociate
    snmp-server enable traps deauthenticate
    snmp-server enable traps authenticate-fail
    snmp-server enable traps dot11-qos
    snmp-server enable traps switch-over
    snmp-server enable traps rogue-ap
    snmp-server enable traps wlan-wep
    snmp-server enable traps config
    snmp-server enable traps syslog
    snmp-server enable traps cpu threshold
    snmp-server enable traps aaa_server
    snmp-server host 172.16.###.## version 2c cisco udp-port 1620
    radius-server host 172.16.###.### auth-port 1812 acct-port 1813 key ##########################
    bridge 1 route ip
    wlccp ap username wds password #################
    wlccp authentication-server infrastructure method_infrastructure
    wlccp authentication-server client any method_clients
    banner login ^C
    ^C
    line con 0
    line vty 0 4
    sntp server 172.16.###.###
    sntp server 172.16.###.###
    sntp server 172.16.###.###
    sntp broadcast client
    end

    You configured your WDS to use empty radius methods. There's no much point to this apart from breaking your setup.
    Remove all 3 "wlccp" commands. I suggest to have your normal radius working before you try and do WDS.
    If behavior is still the same, then it means that the radius server has to get a request if the clients are proposed EAP-TLS and they are looking for a certificate to authenticate with ...
    Did you pre-configure a profile on the client ? Did you configure them for PEAP ? EAP-TLS ? Which method do you allow on your radius server.
    Nicolas

Maybe you are looking for