PPTP VPN Routing

Hi,
I'd like to request an update for an issue raised in another topic re vpn in osx (10.4).
ref: http://discussions.apple.com/thread.jspa?messageID=722699
Specifically, the apple PPTP VPN needs to provide a way to specify which IPv4 subnets should be routed along the vpn tunnel.
For example, my company vpn connects using a 172.16... ip address, however while I need to access some other subnets (administration/fileservers etc) via the vpn tunnel, I don't want to send ALL my internet traffic to the vpn.
I could probably fix this by messing with the system scripts from the unix commandline, but would much rather have an eta for an apple provided/supported fix.
Can anyone help.
Graeme
Powerbook G4 1.25Ghz Mac OS X (10.4.6)

I understand wanting a nice Apple solution.
Seems like it would be pretty easy to do, but
writing a small script isn't too hard either.
Here is my /etc/ppp/ip-up which routes traffic to
10.46.0.0/16 over the PPTP VPN.
Cheers,
Steve
#!/bin/sh
NET=`echo $5 | cut -d. -f1,2,3`.0
case $NET in
10.46.129.0) /sbin/route add -net 10.46.0.0 $5 255.255.0.0;;
esac
MacBook   Mac OS X (10.4.6)  

Similar Messages

  • Pptp VPN route : Leopard does not set correct netmask

    Hello
    Today I switched from a MacOSX 10.4.11 (Tiger) PowerBook to a MacOS 10.5.5 (Leopard) MacBook Pro. I configured my pptp VPN settings with the "Internet Connection Tool" and Network-Settings-panel on Leopard identically as on my Tiger PowerBook (option route all traffic over VPN on both systems disabled).
    As far I could connect on the Leopard system to the destination VPN server without any problem, but could only establish a traffic-connection to the VPN server it self. As on my Tiger system the VPN connection worked seamless over several years now I supposed some routing problem.
    In fact on the Tiger system the routing table showed me, that the destination network has a 255.255.0.0 network mask and was correctly received and set on the Tiger routing table, but that the Leopard systems assumes a 255.255.255.0 network mask and set this assumption to the its routing table: (destination LAN has address space 10.50.0.0 - 10.50.255.255 / netmask 255.255.0.0)
    Tiger 10.4.11 :
    10.50/16 ppp0 USc 0 0 ppp0
    Leopard 10.5.5 :
    10.50/24 ppp0 USc 0 0 ppp0
    In the Leopard vpn setting panel, there is also the possibility to set manually the destination ip-address and netmask, but I found it has no effect on the real setting on Leopard. The only way to set the correct route with the correct netmask is under Leopard to do it by the command shell - first deleting the route set by Leopard and setting a new route with a the correct netmask :
    route delete -net 10.50. -interface ppp0
    route add -net 10.50. -interface ppp0 -netmask 255.255.0.0
    I do not understand, why under Tiger (and also on MacOSX 10.3.X) the pptp VPN worked always correct and set the correct netmask, and now Leopard (MacOSX 10.5.X) does some kind of assumption and is not able to set the correct netmask.
    Any Ideas ?

    How did you determine that partial traffic is sent through the VPN?
    Basic principles of VPN is to avoid using a common subnet for your client ip pool. Having an uncommon subnet will solve your #2 issue below. Simply change the 3rd octet on your home network from .1 to something else, .11
    I have a working pptp server configuration on ubuntu 10 with iphone 3g iOS 4.1 connected, invested hours of research, but only a short time configuring the server and iphone vpn client. passing internet traffic through local gateway/router from work wi-fi and accessing local desktop using windows remote desktop lite app.

  • NETWORKING: PPTP vpn routing issue.

    I tried this on many MACs since 10.4 till my actual 10.8.2.
    PPTP connection against atipical subnet 192.168.0.0/23.
    The RAS server has a 192.168.1.71 wich is the gateway for the destination 192.168.1.0/24 in my routing table.
    The Apple client can only connect to 192.168.1.0/24 subnet, while in the remote 192.168.0.0/23 includes 192.168.0.1-192.168.1.254.
    If i manually add the route 192.168.0.0/24 192.168.1.71 it works like a charm.
    No matter to say it is a Windows PPTP RAS and that no Windows client of any version (XP-8) has this networking issue.
    By now, i'm using a little bash script i send to ppl using MAC that need to connect to the vpn, that adds the route.
    Thanks in advance, any help will be highly appreciated!

    Just hold comments on this one for the moment. I have stripped the config completely (including not having a Management Interface) and it is working now. Need to test further and get the config back to what it should be.

  • How to configure Multiple PPTP VPN Clients on cisco 3g supported Router

    I want the router to be a PPTP VPN client to 2 independent PPTP servers, both are in different cities in Cisco routers. I have tested with one on cisco 1841 aqnd its working fine; but when I add the 2nd, its using vpdn-group 1 and therefore connecting to the wrong PPTP server:
    here is the config for the one that works:
    vpdn-group 1
    request-dialin
    protocol pptp
    rotary-group 0
    initiate-to ip xxx.xxx.xxx.xxx
    interface Dialer0
    mtu 1450
    ip address negotiated
    ip pim dense-mode
    ip nat outside
    ip virtual-reassembly
    zone-member security private
    encapsulation ppp
    ip igmp query-interval 125
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 1
    no peer neighbor-route
    no cdp enable
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp authentication ms-chap-v2 ms-chap eap chap pap callin
    ppp eap refuse
    ppp chap hostname xxx@xxx
    ppp chap password 7 xxxpassword
    But if I create a vpdn-group 2 and a Dialer1 interface, with dialer-group 2, its still attempting to connect to the IP in vpdn-group 1 - how do I get it to use the 2nd vpdn-group, or how do I make this work? and which cisco 3G Router you prefer because these are remote sites and only 3G Internet service is available.

    I want the router to be a PPTP VPN client to 2 independent PPTP servers, both are in different cities in Cisco routers. I have tested with one on cisco 1841 aqnd its working fine; but when I add the 2nd, its using vpdn-group 1 and therefore connecting to the wrong PPTP server:
    here is the config for the one that works:
    vpdn-group 1
    request-dialin
    protocol pptp
    rotary-group 0
    initiate-to ip xxx.xxx.xxx.xxx
    interface Dialer0
    mtu 1450
    ip address negotiated
    ip pim dense-mode
    ip nat outside
    ip virtual-reassembly
    zone-member security private
    encapsulation ppp
    ip igmp query-interval 125
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 1
    no peer neighbor-route
    no cdp enable
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp authentication ms-chap-v2 ms-chap eap chap pap callin
    ppp eap refuse
    ppp chap hostname xxx@xxx
    ppp chap password 7 xxxpassword
    But if I create a vpdn-group 2 and a Dialer1 interface, with dialer-group 2, its still attempting to connect to the IP in vpdn-group 1 - how do I get it to use the 2nd vpdn-group, or how do I make this work? and which cisco 3G Router you prefer because these are remote sites and only 3G Internet service is available.

  • Internet stops with PPTP VPN connections to ASUS RT-N66U VPN Router

    I have a client with a small office network that has a few people working remotely from Windows 7 and 8 PCs. As an inexpensive solution the client opted to use a VPN router (ASUS RT-N66U) that supports PPTP so remote users could access the shared
    files and SQL DB server. 
    The VPN connectivity for one client was working fine and then stopped working altogether so when the VPN connection is established all Internet and VPN access is stopped. This was especially troubling for me since I work remotely and cannot test or debug after
    the VPN session has been connected. I checked the error logs and found nothing. Also there had been no new programs installed. And finally, I ran a full system antivirus scan with no issues found.
    In case you are facing a similar issue, before trying something remotely that may not work, use the shutdown with reboot command in a COMMAND window and set a timer for something like 3 minutes to reboot in case you get stuck. (e.g. shutdown -r -t 180). 
    Problem: The two symptoms of the VPN connection failure are:
    1) All Internet browsing stops working locally 
    2) No data can pass through the VPN tunnel
    I created a virtual machine on my local network and replicated the client's environment. I experimented with nearly every setting in the VPN dialogue until and came to the final solution. 
    Solution: For the VPN adapter on the remote machines I configured DNS settings and used the remote as the default gateway.
    * VPN adapter Networking IPV4 Properties for:
    - DNS server 1: Main Office VPN Router IP Address
    - DNS server 2: A public DNS server (Google is 8.8.8.8)
    - I also checked the box to "register this connection addresses in DNS"
    Note: Perhaps the local router would also have worked and DNS2 but I didn't test it.
    I have documented this because after reading and searching among many Technical articles and the Microsoft support website, I was unable to find the solution that I came up with so I hope to help someone else. 
    Question1: - Can anyone tell me why the connectivity only works when 'use default gateway on remote network' is checked?
    - I have disabled this option with some business class VPN routers and the connectivity still worked to the remote network but it does not work to the Asus router.
    Question2: From the information provided can I determine where the problem lies?
    Is it the:
    1) Remote client PC
    2) Remote client router
    3) Home office VPN router (Asus RT-N66U)
    If the true culprit cannot be determined yet, what steps do you recommend so I can isolate the true cause of the failure.
    I appreciate any help so that I can be sure my solution is valid and pass along the findings to ASUS if it is their issue.

    Thank you for the suggestion. I have successfully connected through the VPN router when the one client was unable to get VPN throughput working.
    I looked at the routing tables with and without the VPN connection established. The differences are that:
    1) when VPN is NOT active, there is a route from the local NIC IP to the Internet IP address of the local gateway
    destination 68.109.82.xx
    mask 255.255.255.0
    gateway 192.168.0.1
    interface 192.168.0.11
    metric 21
    2) when VPN IS active, the route to the Internet IP address of the local gateway is deleted and a persistent route to the VPN router local network has been added
    Persistent route:
    destination 192.168.21.0
    mask 255.255.255.0
    gateway 192.168.0.1
    interface 192.168.0.11
    metric 1

  • [Solved] NetworkManager-pptp VPN not working after update to 0.9.10

    Hello,
    I have a PPTP VPN set up and it's been working for a long time.  However, after I updated last night to networkmanager-0.9.10, it is no longer able to connect to the remote network.  I can activate the VPN connection, enter my password, but after a short period of time, the connection reports:  "Error: Connection activation failed: the VPN service returned invalid configuration."  As I mentioned before, this VPN was working right before the update and I didn't change the configuration on either my computer or the destination network so I'm pretty sure that this is something to do with the update.  I'm wondering if anybody else has run into this problem and if they've been able to find a solution.  I've been searching all over these forums and the internet for some hours now and I haven't found anything yet.  I'm hoping that somebody might be able to point me in the right direction or maybe know of something that might have changed with the new update.
    Here is my VPN configuration (using NetworkManager-PPTP.  I've also obscured the public IP address):
    [connection]
    id=MyVPN
    uuid=fe6e6265-1a79-4a69-b6d1-8b47e9d4c948
    type=vpn
    permissions=user:greyseal96:;
    autoconnect=false
    timestamp=1408950986
    [vpn]
    service-type=org.freedesktop.NetworkManager.pptp
    gateway=192.168.146.114
    require-mppe=yes
    user=greyseal96
    password-flags=3
    [ipv6]
    method=auto
    [ipv4]
    method=auto
    route1=10.17.0.0/16,10.17.1.1,1
    never-default=true
    Here are my logs during the time that I tried to connect:
    Aug 24 23:44:15 MyArchBox NetworkManager[578]: <info> Starting VPN service 'pptp'...
    Aug 24 23:44:15 MyArchBox NetworkManager[578]: <info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 1938
    Aug 24 23:44:15 MyArchBox NetworkManager[578]: <info> VPN service 'pptp' appeared; activating connections
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: <info> VPN connection 'MyVPN' (ConnectInteractive) reply received.
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: <info> VPN plugin state changed: starting (3)
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: ** Message: pppd started with pid 1945
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: <info> VPN connection 'MyVPN' (Connect) reply received.
    Aug 24 23:44:21 MyArchBox pppd[1945]: Plugin /usr/lib/pppd/2.4.6/nm-pptp-pppd-plugin.so loaded.
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: Plugin /usr/lib/pppd/2.4.6/nm-pptp-pppd-plugin.so loaded.
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (plugin_init): initializing
    Aug 24 23:44:21 MyArchBox pppd[1945]: pppd 2.4.6 started by root, uid 0
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
    Aug 24 23:44:21 MyArchBox pppd[1945]: Using interface ppp0
    Aug 24 23:44:21 MyArchBox pppd[1945]: Connect: ppp0 <--> /dev/pts/2
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: Using interface ppp0
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: Connect: ppp0 <--> /dev/pts/2
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: <info> (ppp0): new Generic device (driver: 'unknown' ifindex: 10)
    Aug 24 23:44:21 MyArchBox NetworkManager[578]: <info> (ppp0): exported as /org/freedesktop/NetworkManager/Devices/9
    Aug 24 23:44:21 MyArchBox pptp[1947]: nm-pptp-service-1938 log[main:pptp.c:333]: The synchronous pptp option is NOT activated
    Aug 24 23:44:21 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 1 'Start-Control-Connection-Request'
    Aug 24 23:44:21 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_disp:pptp_ctrl.c:758]: Received Start Control Connection Reply
    Aug 24 23:44:21 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_disp:pptp_ctrl.c:792]: Client connection established.
    Aug 24 23:44:22 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 7 'Outgoing-Call-Request'
    Aug 24 23:44:22 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_disp:pptp_ctrl.c:877]: Received Outgoing Call Reply.
    Aug 24 23:44:22 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_disp:pptp_ctrl.c:916]: Outgoing call established (call ID 0, peer's call ID 50048).
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 6 / phase 'authenticate'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (get_credentials): passwd-hook, requesting credentials...
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (get_credentials): got credentials from NetworkManager-pptp
    Aug 24 23:44:25 MyArchBox pppd[1945]: CHAP authentication succeeded
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: CHAP authentication succeeded
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 8 / phase 'network'
    Aug 24 23:44:25 MyArchBox pppd[1945]: MPPE 128-bit stateless compression enabled
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: MPPE 128-bit stateless compression enabled
    Aug 24 23:44:25 MyArchBox pppd[1945]: Cannot determine ethernet address for proxy ARP
    Aug 24 23:44:25 MyArchBox pppd[1945]: local  IP address 10.17.10.3
    Aug 24 23:44:25 MyArchBox pppd[1945]: remote IP address 10.17.10.1
    Aug 24 23:44:25 MyArchBox pppd[1945]: primary   DNS address 10.17.2.22
    Aug 24 23:44:25 MyArchBox pppd[1945]: secondary DNS address 10.17.2.23
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info> VPN connection 'MyVPN' (IP4 Config Get) reply received from old-style plugin.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info> VPN Gateway: 192.168.146.114
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info> Tunnel Device: ppp0
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info> IPv4 configuration:
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Internal Address: 10.17.10.3
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Internal Prefix: 32
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Internal Point-to-Point Address: 10.17.10.1
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Maximum Segment Size (MSS): 0
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Static Route: 10.17.0.0/16   Next Hop: 10.17.1.1
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Forbid Default Route: yes
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Internal DNS: 10.17.2.22
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   Internal DNS: 10.17.2.23
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info>   DNS Domain: '(none)'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <info> No IPv6 configuration
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <error> [1408949065.481618] [platform/nm-linux-platform.c:1716] add_object(): Netlink error adding 10.17.0.0/16 via 10.17.1.1 dev ppp0 metric 1 mss 0 src user: Unspecific failure
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <warn> VPN connection 'MyVPN' did not receive valid IP config information.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: Cannot determine ethernet address for proxy ARP
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: local  IP address 10.17.10.3
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: remote IP address 10.17.10.1
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: primary   DNS address 10.17.2.22
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: secondary DNS address 10.17.2.23
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 9 / phase 'running'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_ip_up): ip-up event
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_ip_up): sending Ip4Config to NetworkManager-pptp...
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: PPTP service (IP Config Get) reply received.
    Aug 24 23:44:25 MyArchBox pppd[1945]: Terminating on signal 15
    Aug 24 23:44:25 MyArchBox pppd[1945]: Modem hangup
    Aug 24 23:44:25 MyArchBox pptp[1954]: nm-pptp-service-1938 log[callmgr_main:pptp_callmgr.c:245]: Closing connection (unhandled)
    Aug 24 23:44:25 MyArchBox pptp[1954]: nm-pptp-service-1938 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 12 'Call-Clear-Request'
    Aug 24 23:44:25 MyArchBox pptp[1954]: nm-pptp-service-1938 log[call_callback:pptp_callmgr.c:84]: Closing connection (call state)
    Aug 24 23:44:25 MyArchBox pppd[1945]: Connect time 0.0 minutes.
    Aug 24 23:44:25 MyArchBox pppd[1945]: Sent 0 bytes, received 0 bytes.
    Aug 24 23:44:25 MyArchBox pppd[1945]: MPPE disabled
    Aug 24 23:44:25 MyArchBox pppd[1945]: Connection terminated.
    Aug 24 23:44:25 MyArchBox dbus[579]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.51" (uid=0 pid=1938 comm="/usr/lib/networkmanager/nm-pptp-service ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.52" (uid=0 pid=1945 comm="/sbin/pppd pty /sbin/pptp 192.168.146.114 --nolaunc")
    Aug 24 23:44:25 MyArchBox dbus[579]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.51" (uid=0 pid=1938 comm="/usr/lib/networkmanager/nm-pptp-service ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.52" (uid=0 pid=1945 comm="/sbin/pppd pty /sbin/pptp 192.168.146.114 --nolaunc")
    Aug 24 23:44:25 MyArchBox dbus[579]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.51" (uid=0 pid=1938 comm="/usr/lib/networkmanager/nm-pptp-service ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.52" (uid=0 pid=1945 comm="/sbin/pppd pty /sbin/pptp 192.168.146.114 --nolaunc")
    Aug 24 23:44:25 MyArchBox dbus[579]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.51" (uid=0 pid=1938 comm="/usr/lib/networkmanager/nm-pptp-service ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.52" (uid=0 pid=1945 comm="/sbin/pppd pty /sbin/pptp 192.168.146.114 --nolaunc")
    Aug 24 23:44:25 MyArchBox dbus[579]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.51" (uid=0 pid=1938 comm="/usr/lib/networkmanager/nm-pptp-service ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.52" (uid=0 pid=1945 comm="/sbin/pppd pty /sbin/pptp 192.168.146.114 --nolaunc")
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: inet 10.17.0.0/16 table main
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: priority 0x1 protocol static
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: nexthop via 10.17.1.1 dev 10
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <error> [1408949065.487073] [platform/nm-linux-platform.c:2252] link_change(): Netlink error changing link 10:  <DOWN> mtu 0 (1) driver 'unknown' udi '/sys/devices/virtual/net/ppp0': No such device
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: <error> [1408949065.487153] [platform/nm-linux-platform.c:1777] delete_object(): Netlink error deleting 10.17.10.3/32 lft forever pref forever lifetime 1862-0[4294967295,4294967295] dev ppp0 src kernel: No such device (-31)
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: Terminated ppp daemon with PID 1945.
    Aug 24 23:44:25 MyArchBox kernel: Loading kernel module for a network device with CAP_SYS_MODULE (deprecated).  Use CAP_NET_ADMIN and alias netdev- instead.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: Terminating on signal 15
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: Modem hangup
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 8 / phase 'network'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: Connect time 0.0 minutes.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: Sent 0 bytes, received 0 bytes.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: MPPE disabled
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 10 / phase 'terminate'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 11 / phase 'disconnect'
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: Connection terminated.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 1 / phase 'dead'
    Aug 24 23:44:25 MyArchBox dbus[579]: [system] Rejected send message, 10 matched rules; type="error", sender=":1.51" (uid=0 pid=1938 comm="/usr/lib/networkmanager/nm-pptp-service ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.52" (uid=0 pid=1945 comm="/sbin/pppd pty /sbin/pptp 192.168.146.114 --nolaunc")
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** Message: nm-pptp-ppp-plugin: (nm_exit_notify): cleaning up
    Aug 24 23:44:25 MyArchBox pppd[1945]: Exit.
    Aug 24 23:44:25 MyArchBox NetworkManager[578]: ** (nm-pptp-service:1938): WARNING **: pppd exited with error code 16
    Aug 24 23:44:45 MyArchBox NetworkManager[578]: <info> VPN service 'pptp' disappeared
    If you've gotten this far, thank you for taking the time to read through all this!  Any help that you can give would be much appreciated.
    Last edited by greyseal96 (2014-08-27 15:20:02)

    Hmm, not sure about the 3.16 series kernel, but I found that when I upgraded to kernel 3.18 the PPTP VPN also stopped working.  This time, though, it was because, for some reason, there was a change in kernel 3.18 where the firewall kernel modules necessary for the VPN don't get loaded so the firewall won't allow some of the PPTP traffic from the remote side back in.  Since the firewall is stateful, these modules need to be loaded so that the firewall can know that the incoming PPTP traffic from the remote side is part of an existing connection.  Here's what my network manager logs looked like:
    NetworkManager[619]: <info> Starting VPN service 'pptp'...
    NetworkManager[619]: <info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 31139
    NetworkManager[619]: <info> VPN service 'pptp' appeared; activating connections
    NetworkManager[619]: <info> VPN connection 'MyVPN' (ConnectInteractive) reply received.
    NetworkManager[619]: <info> VPN plugin state changed: starting (3)
    NetworkManager[619]: ** Message: pppd started with pid 31148
    NetworkManager[619]: <info> VPN connection 'MyVPN' (Connect) reply received.
    pppd[31148]: Plugin /usr/lib/pppd/2.4.7/nm-pptp-pppd-plugin.so loaded.
    NetworkManager[619]: Plugin /usr/lib/pppd/2.4.7/nm-pptp-pppd-plugin.so loaded.
    NetworkManager[619]: ** Message: nm-pptp-ppp-plugin: (plugin_init): initializing
    pppd[31148]: pppd 2.4.7 started by root, uid 0
    NetworkManager[619]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
    pppd[31148]: Using interface ppp0
    pppd[31148]: Connect: ppp0 <--> /dev/pts/5
    NetworkManager[619]: Using interface ppp0
    NetworkManager[619]: Connect: ppp0 <--> /dev/pts/5
    NetworkManager[619]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
    NetworkManager[619]: <info> (ppp0): new Generic device (driver: 'unknown' ifindex: 7)
    NetworkManager[619]: <info> (ppp0): exported as /org/freedesktop/NetworkManager/Devices/6
    pptp[31150]: nm-pptp-service-31139 log[main:pptp.c:333]: The synchronous pptp option is NOT activated
    pptp[31157]: nm-pptp-service-31139 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 1 'Start-Control-Connection-Request'
    pptp[31157]: nm-pptp-service-31139 log[ctrlp_disp:pptp_ctrl.c:758]: Received Start Control Connection Reply
    pptp[31157]: nm-pptp-service-31139 log[ctrlp_disp:pptp_ctrl.c:792]: Client connection established.
    pptp[31157]: nm-pptp-service-31139 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 7 'Outgoing-Call-Request'
    pptp[31157]: nm-pptp-service-31139 log[ctrlp_disp:pptp_ctrl.c:877]: Received Outgoing Call Reply.
    pptp[31157]: nm-pptp-service-31139 log[ctrlp_disp:pptp_ctrl.c:916]: Outgoing call established (call ID 0, peer's call ID 25344).
    pppd[31148]: LCP: timeout sending Config-Requests <===HERE IS WHERE THE CONNECTION FAILS BECAUSE THE MODULES AREN'T LOADED.
    pppd[31148]: Connection terminated.
    NetworkManager[619]: LCP: timeout sending Config-Requests
    NetworkManager[619]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 11 / phase 'disconnect'
    NetworkManager[619]: Connection terminated.
    NetworkManager[619]: <warn> VPN plugin failed: connect-failed (1)
    NetworkManager[619]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 1 / phase 'dead'
    pppd[31148]: Modem hangup
    pppd[31148]: Exit.
    NetworkManager[619]: <warn> VPN plugin failed: connect-failed (1)
    NetworkManager[619]: Modem hangup
    NetworkManager[619]: ** Message: nm-pptp-ppp-plugin: (nm_exit_notify): cleaning up
    NetworkManager[619]: <warn> VPN plugin failed: connect-failed (1)
    NetworkManager[619]: <info> VPN plugin state changed: stopped (6)
    NetworkManager[619]: <info> VPN plugin state change reason: unknown (0)
    NetworkManager[619]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
    NetworkManager[619]: ** (nm-pptp-service:31139): WARNING **: pppd exited with error code 16
    NetworkManager[619]: <info> VPN service 'pptp' disappeared
    To fix this, I had to add a file to the /etc/modules-load.d directory to have the modules loaded into the kernel at boot.  I just created a file called netfilter.conf and put the following in it:
    nf_nat_pptp
    nf_conntrack_pptp
    nf_conntrack_proto_gre
    Not sure if this addresses your problem or not, but maybe it's worth a look.

  • Help needed to connect to remote PPTP VPN via PIX 515e

    Hello,
    A user in our office needs to connect to a client's remote PPTP VPN but can't connect.  The user is running Windows 7.  We have a Cisco PIX 515e firewall that is running PIX Version 6.3(3) - this is what our user is having to go through to try and make the connection to the client's remote VPN.
    The client's network guys have come back and said the issue is at our side.  They say that they can see some of our traffic but not all of it. The standard error is shown below, and they say it's symptomatic of the client-side firewall not allowing PPTP traffic:
    "A connection between the VPN server and the VPN client XXX.XXX.XXX.XXX has been established, but the VPN connection cannot be completed. The most common cause for this is that a firewall or router between the VPN server and the VPN client is not configured to allow Generic Routing Encapsulation (GRE) packets (protocol 47). Verify that the firewalls and routers between your VPN server and the Internet allow GRE packets. Make sure the firewalls and routers on the user's network are also configured to allow GRE packets. If the problem persists, have the user contact the Internet service provider (ISP) to determine whether the ISP might be blocking GRE packets."
    I have very little firewall experience and absolutely no Cisco experience I'm afraid.  From looking at the PIX config I can see the following line:
    fixup protocol pptp 1723.
    Does this mean that the PPTP protcol is enabled on our firewall?  Is this for both incoming and outgoing traffic?
    I can see no reference to GRE 47 in the PIX config.  Can anyone advise me what I should look for to see if this has been enabled or not?
    I apologise again for my lack of knowledge.  Any help or advice would be very gratefully received.
    Ros

    Hi Eugene,
    Thank you for taking the time to reply to me.  Please see our full PIX config below.  I've XX'd out names and IP addresses as I'm never comfortable posting those type of details in a public forum.  I hope that the information below is still sufficient for you.
    Thanks again for your help,
    Ros
    PIX(config)# en
    Not enough arguments.
    Usage:  enable password [] [level ] [encrypted]
            no enable password level
            show enable
    PIX(config)# show config
    : Saved
    : Written by enable_15 at 10:30:31.976 GMT/BDT Mon Apr 4 2011
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 DMZ security10
    enable password XXX encrypted
    passwd XXX encrypted
    hostname PIX
    domain-name XXX.com
    clock timezone GMT/BST 0
    clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol pptp 1723
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name XX.XX.XX.XX Secondary
    access-list outside_access_in permit tcp XX.XX.XX.XX 255.255.255.240 host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp host XX.XX.XX.XX host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp host XX.XX.XX.XX host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 8082
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq www
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.0.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl deny udp any any eq 135
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_40 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_60 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER1 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_10 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_20 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_30 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_50 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_70 permit ip any XX.XX.XX.XX 255.255.0.0
    access-list USER2 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER3 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER4 permit ip any XX.XX.XX.XX 255.255.0.0
    pager lines 24
    logging on
    logging host inside XX.XX.XX.XX
    icmp permit any outside
    icmp permit any inside
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    ip address outside XX.XX.XX.XX 255.255.255.248
    ip address inside XX.XX.XX.XX 255.255.255.0
    no ip address DMZ
    ip audit info action alarm
    ip audit attack action alarm
    pdm location XX.XX.XX.XX 255.255.255.255 inside
    pdm location XX.XX.XX.XX 255.255.0.0 outside
    pdm location XX.XX.XX.XX 255.255.255.0 outside
    pdm logging debugging 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) XX.XX.XX.XX XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX. XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX. XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX XX.XX.XX.XX netmask 255.255.255.255 0 0
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 XX.XX.XX.XX 1
    route inside XX.XX.XX.XX 255.255.0.0 XX.XX.XX.XX 1
    timeout xlate 3:00:00
    timeout conn 2:00:00 half-closed 0:30:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    ntp authenticate
    ntp server XX.XX.XX.XX source outside prefer
    http server enable
    http XX.XX.XX.XX 255.255.0.0 outside
    http XX.XX.XX.XX 255.255.255.0 outside
    http XX.XX.XX.XX 255.255.255.255 inside
    snmp-server host inside XX.XX.XX.XX
    no snmp-server location
    no snmp-server contact
    snmp-server community XXX
    snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map cola 20 set transform-set ESP-3DES-MD5
    crypto dynamic-map dod 10 set transform-set ESP-3DES-MD5
    crypto map outside_map 10 ipsec-isakmp dynamic cola
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer XX.XX.XX.XX
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 25 ipsec-isakmp
    crypto map outside_map 25 match address USER1
    crypto map outside_map 25 set peer XX.XX.XX.XX
    crypto map outside_map 25 set transform-set ESP-3DES-MD5
    crypto map outside_map 30 ipsec-isakmp
    crypto map outside_map 30 match address outside_cryptomap_30
    crypto map outside_map 30 set peer XX.XX.XX.XX
    crypto map outside_map 30 set transform-set ESP-3DES-MD5
    crypto map outside_map 40 ipsec-isakmp
    crypto map outside_map 40 match address outside_cryptomap_40
    crypto map outside_map 40 set peer XX.XX.XX.XX
    crypto map outside_map 40 set transform-set ESP-3DES-MD5
    crypto map outside_map 50 ipsec-isakmp
    crypto map outside_map 50 match address outside_cryptomap_50
    crypto map outside_map 50 set peer XX.XX.XX.XX
    crypto map outside_map 50 set transform-set ESP-3DES-MD5
    crypto map outside_map 60 ipsec-isakmp
    crypto map outside_map 60 match address outside_cryptomap_60
    crypto map outside_map 60 set peer XX.XX.XX.XX
    crypto map outside_map 60 set transform-set ESP-3DES-MD5
    crypto map outside_map 70 ipsec-isakmp
    crypto map outside_map 70 match address outside_cryptomap_70
    crypto map outside_map 70 set peer XX.XX.XX.XX
    crypto map outside_map 70 set transform-set ESP-3DES-MD5
    crypto map outside_map 75 ipsec-isakmp
    crypto map outside_map 75 match address USER4
    crypto map outside_map 75 set peer XX.XX.XX.XX
    crypto map outside_map 75 set transform-set ESP-3DES-MD5
    crypto map outside_map 80 ipsec-isakmp
    crypto map outside_map 80 match address USER2
    crypto map outside_map 80 set peer XX.XX.XX.XX
    crypto map outside_map 80 set transform-set ESP-3DES-MD5
    crypto map outside_map 90 ipsec-isakmp
    crypto map outside_map 90 match address USER3
    crypto map outside_map 90 set peer XX.XX.XX.XX
    crypto map outside_map 90 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet XX.XX.XX.XX 255.255.0.0 outside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet timeout 30
    ssh XX.XX.XX.XX 255.255.255.248 outside
    ssh XX.XX.XX.XX 255.255.255.248 outside
    ssh timeout 30
    management-access inside
    console timeout 0
    terminal width 80
    Cryptochecksum:XXX
    PIX(config)#

  • PPTP VPN on Server 2008R2 dropping users but acting like it is still connected

    Hello,
    I'm having a weird problem and I'm at a loss.  We have a couple of cloud servers that form our remote office system.  Basically, their is 1 DC, 1 Remote Desktop server, and 2 member servers being used as workstations.  The users access these
    server and resources via a PPTP VPN setup on the DC using RRAS.  Everything has worked fairly well for the last year, but recently, my users have complained that they get disconnected at random times over the last couple of weeks.  I was able
    to observe the behavior yesterday and it goes something like this:
    -The user is working fine
    -The user tries to access a share, open a web page, tries to open a remote desktop session or notices that their Outlook client is disconnected and finds that nothing can be reached outside of the local machine.  I tried pinging the DC address,
    www.google.com, and the RDP server without success. From the server, I tried pinging the errant workstation without success. The server shows the connection to be active and the workstation does not disconnect the connection. On
    one occasion, the problem just rectified itself and everything started working again. On all other occasions, the VPN had to be disconnected and reconnected. Note that some workstations are not reporting this problem.
    -The user disconnects the VPN
    -The user reconnects the VPN and usually everything is okay again for awhile, but sometimes they are disconnected within minutes.
    This is new behavior, and no changes have been made by me and the Cloud support people tell me they haven't done anything.  At this point, I'm not even sure how to go about troubleshooting it. The next time it happened, I was going to pull an ARP table
    to see if anything looks amiss, but the only other avenue I have going is a call into the cloud services support to see if they can look for dropped or filtered information between our main office and our cloud server.
    The only part of this setup that is a little bit different for me is the IPv4 settings in the RRAS console under properties of the server. Normally in the IPv4 settings, I select DHCP and allow the users to pull from the existing DHCP server. However, the
    cloud support recommended against having a DHCP server, so instead of DHCP, I selected "use static IP address pool." I put 10.216.8.197 to 10.216.8.22 and the subnet mask is picking up from the server as 255.255.255.224 and the default gateway is
    picking up from the server as 10.216.8.193.
    Does anyone have any advice on how to troubleshoot this problem?  What to try next if the cloud services support doesn't find anything, etc?
    Thanks,
    Jeffery Smith

    Hi Jeffery,
    According to your description, the VPN clients can connect the server at the beginning, but when we reconnected after going wrong, they were disconnected within minutes. Maybe the next time it happened, we could follow steps below to troubleshoot this issue.
    Use ipconfig /all command in the VPN client when we set up VPN connection, to view which IP address the VPN client obtain.
    Pull an ARP table from the VPN client to view the IP Address-Physical Address mappings as you said will help to troubleshoot this issue. The assigned IP address maybe used by other computers.
    If the static IP address pool range from 10.216.8.197 to 10.216.8.22, due to the subnet is 255.255.255.224, there are 8 subnet in the 10.216.8.0/27 network. If the static IP address pool consists of ranges of IP addresses that are for a separate subnet,
    then we need to either enable an IP routing protocol on the remote access server computer or add static IP routes consisting of the {IP Address, Mask} of each range to the routers of the intranet. If the routes are not added, then remote access clients can’t
    receive traffic from resources on the intranet.
    Best Regards,
    Tina

  • 2 questions about PPTP VPN on 878

    Hello,
    I've configured my 878 router as a PPTP VPN server. It works very fine and very quickly. Using the XP VPN client from a remote site, I can "see" all servers in my network.
    2 questions
    1) When doing telnet on the 878 through the VPN, it is very slow.
    2) I would have to get access to the internet through the VPN. But this does not work.
    What should I change in this config :
    Thanks in advance,
    Guy
    version 12.3
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    service linenumber
    service sequence-numbers
    hostname ineo-21029
    boot-start-marker
    boot-end-marker
    no logging buffered
    enable secret 5 .....
    username ...
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    ip subnet-zero
    no ip cef
    no ip dhcp use class
    ip name-server 212.100.160.51
    ip name-server 212.100.160.52
    ip port-map ms-sql port 1433
    vpdn enable
    vpdn-group 1
    ! Default PPTP VPDN group
    accept-dialin
    protocol pptp
    virtual-template 1
    no ftp-server write-enable
    isdn switch-type basic-net3
    controller DSL 0
    mode atm
    line-term cpe
    line-mode 2-wire line-zero
    dsl-mode shdsl symmetric annex B
    line-rate auto
    interface BRI0
    no ip address
    shutdown
    isdn switch-type basic-net3
    interface ATM0
    description === to PE/Router ====
    no ip address
    ip accounting output-packets
    load-interval 30
    no atm ilmi-keepalive
    interface ATM0.1 point-to-point
    description $ES_WAN$
    pvc 8/35
    oam-pvc manage 5
    oam-pvc manage cc end direction both
    oam retry 3 3 1
    oam retry cc end 3 3 30
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    interface FastEthernet0
    no ip address
    interface FastEthernet1
    no ip address
    interface FastEthernet2
    no ip address
    interface FastEthernet3
    no ip address
    interface Virtual-Template1
    ip unnumbered Vlan1
    peer default ip address pool test
    no keepalive
    ppp encrypt mppe auto
    ppp authentication pap chap ms-chap ms-chap-v2
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.2.2 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface Dialer1
    description $FW_OUTSIDE$
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp chap hostname ....
    ppp chap password ....
    ppp pap sent-username ....
    ip local pool test 192.168.2.240 192.168.2.250
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    no ip http secure-server
    ip nat inside source list 101 interface Dialer1 overload
    access-list 101 permit ip 192.168.2.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    control-plane
    line con 0
    exec-timeout 120 0
    no modem enable
    transport preferred all
    transport output all
    stopbits 1
    line aux 0
    transport preferred all
    transport output all
    line vty 0 4
    access-class 113 in
    exec-timeout 0 0
    transport preferred all
    transport input all
    transport output all
    scheduler max-task-time 5000

    Thanks for this message.
    Finding no solution to my problem, i've switched to other tools : Easy VPN server in the router + Cisco VPN client. My 2 questions have now received a positive answer.
    I was very important for me to get Internet acess through the VPN. Because we rent a dedicated server, located somewhere, and the access to this server is firewall-protected on our public IP address. Thus, when i'm outside and want to manage this serveur, i've to connect via VPN at our central office first.
    Best regards,
    Guy

  • Remote Desktop/Access shared files over PPTP VPN

    Hello,
    I just bought the RV180W so I can connect to my office computer from anywhere as a VPN client. The two things I need to do while I am connected as a VPN client is to be able to access my files on my office desktop and be able to remote desktop to it as well. I have Win7 on all of my computers. Ideally, I would like to do that over PPTP VPN connection but if that is not possible I can try Cisco QuickVPN software.
    I enabled PPTP on my router and created a user account. I was also able to successfully establish the connection remotely. While I was connected as a PPTP VPN client, I was able to access the Internet and my router setup page which is telling me that the connection is good. However, I was not able to either discover my office PC under my network tab in Win7 nor I was able to remote desktop. I keep my office PC on all the time and it never go to sleep. I did not create any connection policy but maybe this is the problem. Please let me know if you know of a solution.
    Thanks!

    Hi David,
    Thank you for the response.
    I was able to access the router configuration using the local IP address (in my case 192.168.1.1). I don't think I would have been able to access it using the public IP address since I have the router remote management feature disabled.
    Now after reading your email, I was finally able to remote desktop and access shared files through a PPTP VPN connection. Here is what I did:
    1- I separted the PPTP VPN IP address range from my DHCP range (in my case, PPTP VPN range is 192.168.1.200 to 210 and my DHCP range is from 192.168.1.100 to 199)
    2- I assigned my office desktop PC that I am trying to remote desktop to a fixed IP address (192.168.1.20)
    3- For remote desktop, I had to type the IP address (192.168.1.20). Typing the PC name (officepc) or searching for was not working.
    4- For shared files, I had to map a network drive as //192.168.1.20/My Pictures for example. I couldn't find my PC when searched for it under Network.
    After doing all that, I was able to do kinda what I wanted. Ideally, I would have liked to avoid using fixed IP addresses and be able to access computers by their name and see them under the Network tab. Is their a way to do this? I noticed that RV220W offers SSL VPN, would that help me?
    I would appreciate it if you could answer my last two questions.
    Thanks!
    Mustafa

  • Accessing device attached to VPN router

    Hi.  We have a VPN router, RV180, that was installed to allow us to access data on a PLC which is physically attached to the router via ethernet cable. We are able to establish a VPN connection from a remote laptop using QuickVPN. However, we cannot figure out how to browse to the PLC using Internet Explorer. The IP address we have for the PLC is identical to an external IP address and our browser simply loads the page from the Internet. How do we browse to the PLC using the VPN connection?
    Thanks
    Mike

    Hello.  If I may reactivate an old string I have a bit of an ironic question.  The Mac connection which seemed so difficult is now the only one that works.  To be clear, The Windows folks can still create a VPN connection.  However, they cannot access the PLC on the other side.  This wasn't obvious when I last posted because we didn't have the correct login info for the PLC so none of us could get in.  Now, my VPN connection allows me to log in to the PLC.  The Windows VPN connection cannot see the PLC log in page.  Can anyone suggest some areas to check in the administration pages of the router to find the difference between the PPTP protocol which works and the QuickVPN protocol which doesn't?
    Mike

  • Deploy PPTP VPN Settings for remote workers

    Hi All,
    I need to use applescript, so that we can email / copy the script to our remote users and they can execute it to setup PPTP VPN to our work vpn server.
    I have never used applescript and google led me to a apple forum post with the following, the problem I am facing is, that I can’t seem to name the VPN connection, neither i can give it a pptp vpn server address, dns, default gateway and any custom routes.
    How can I add those fields / enteries in ?
    http://discussions.apple.com/thread.jspa?messageID=10368307
    tell application “System Preferences”
    reveal pane “Network”
    activate
    tell application “System Events”
    tell process “System Preferences”
    tell window 1
    click button “Add Service”
    tell sheet 1
    click pop up button 1
    click menu item “VPN” of menu 1 of pop up button 1
    delay 1
    click pop up button 2
    click menu item “PPTP” of menu 1 of pop up button 2
    click button “Create”
    end tell
    click button “Apply”
    end tell
    end tell
    delay 1 — optional (just for visual feedback)
    keystroke “w” using {command down}
    end tell
    end tell
    will be grateful for your help on this
    Thanks

    I came across the same problem, I posted a solution here in case anyone else comes across it: http://blog.affirmix.com/2011/01/12/how-to-configure-a-vpn-in-mac-os-x-usingappl escript/

  • IVPN starts, but "the pptp-vpn server did not respond. Try reconnecting."

    Hi. I am new to VPN, and I just got the software iVPN from Macserve, and the server starts successfully, using either PPTP or L2TP:
    But the connections from my network do not connect. Every time I click on "connect" for either network connection, I get the error "the pptp-vpn server did not respond. Try reconnecting."
    I set up both connections in my Network Preferences according to the support page (http://macserve.org.uk/support/ivpn/):
    My Airport Express configurations have never given me any problems with my home network:
    And I think that I forwarded the ports properly (even though my firewall is not activated):
    What am I doing wrong?

    The Apple routers can be a problem on vpn passthrough.
    Ports that are required for vpn are more complicated ..
    See earlier post.. eg How do I set up L2TP VPN?
    Ports for PPTP which you have opened manually.. are not valid for L2TP.. so you need several more ports opened.
    The problematic ones are GRE and ESP which are protocols not ports.
    I think you can pretty well assume the apple router running anything that has BTMM in it won't work.. since it will need the port 500 for itself.
    On the old express try going back to 7.6.1 firmware.. I have to say I don't use the express.. lots of extreme and TC.. so their firmware issues are slightly different so firmware versions for the express are somewhat different.
    Try not to use both port forwards (mapping if you must).. and DMZ.. they can fight each other.. if DMZ doesn't work it is better to turn it right off and forward all the required ports.
    Let me recommend a test.
    Plug your cable modem directly into the computer running the VPN.. so you have no NAT router in front of it.
    Pay attention to the local firewall that apple runs and what ports you will need to open on it to get vpn to work.. this is your best chance to get remote vpn running. If you fail with the public IP on the computer it will certainly fail through NAT.. and generally local firewall will be an issue.
    You should of course test that a client in the local lan can connect by the vpn.. it is always worth testing from the easiest configuration to the most complex.
    So local lan just as you have now..
    Then direct cable connection to the computer.
    Then NAT router.. but you can pretty well assume apple routers are going to be problematic because apple want to dally at BTMM using same ports as IPSEC uses for L2TP.
    My email is live.. roll your mouse over it and talk to me direct..

  • PIX 501 and Linksys VPN Router (WRV200)

    I have inherited a job where we have a Cisco PIX 501 firewall at one site, and Linksys WRV200 VPN Router on two other
    sites. I have been asked to connect these Linksys routers to the PIX firewall via VPN.
    I believe the Linksys vpn routers can only connect via IPSec VPN, so i am looking for help on configuring the PIX 501 to allow the linksys to connect with the following parameters, if possible.
    Key Exchange Method: Auto (IKE)
    Encryption: Auto, 3DES, AES128, AES192, AES256
    Authentication: MD5
    Pre-Shared Key: xxx
    PFS: Enabled/Disabled
    ISAKMP Key Lifetime: 28800
    IPSec Key Lifetime: 3600
    On the PIX i have the PDM installed and i have tried using the VPN Wizard to no avail.
    I chose the following settings when doing the VPN Wizard:
    Type of VPN: Remote Access VPN
    Interface: Outside
    Type of VPN Client Device used: Cisco VPN Client
    (can choose Cisco VPN 3000 Client, MS Windows Client using PPTP, MS Windows client using L2TP)
    VPN Client Group
    Group Name: RabyEstates
    Pre Shared Key: rabytest
    Extended Client Authentication: Disabled
    Address Pool
    Pool Name: VPN-LAN
    Range Start: 192.168.2.200
    Range End: 192.168.2.250
    DNS/WINS/Default Domain: None
    IKE Policy
    Encryption: 3DES
    Authentication: MD5
    DH Group: Group 2 (1024-bit)
    Transform Set
    Encryption: 3DES
    Authentication: MD5
    I have attached the VPN log from the Linksys VPN Router.
    This is the first time i've ever worked with PIX so i'm still trying to figure the thing out, but i'm confident with CCNA level networking.
    Thanks for your help!

    Hi again,
    I believe the pix has a 3des license because of the following parts of the "show version"
    Licensed Features:
    Failover: Disabled
    VPN-DES: Enabled
    VPN-3DES-AES: Enabled
    This PIX has a Restricted (R) license.
    I've tried reconnecting the VPN tunnel with debugging on the PIX and get the output as shown in the attached file "vpndebug.txt"
    As for the other show commands they give:
    pixfirewall# show crypto isakmp sa
    Total : 0
    Embryonic : 0
    dst src state pending created
    pixfirewall# show crypto ipsec sa
    interface: outside
    Crypto map tag: transam, local addr. 10.0.0.1
    local ident (addr/mask/prot/port): (192.168.1.0/255.255.255.0/0/0)
    remote ident (addr/mask/prot/port): (192.168.101.0/255.255.255.0/0/0)
    current_peer: 10.0.0.2:0
    PERMIT, flags={origin_is_acl,}
    #pkts encaps: 0, #pkts encrypt: 0, #pkts digest 0
    #pkts decaps: 0, #pkts decrypt: 0, #pkts verify 0
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts compr. failed: 0, #pkts decompress failed: 0
    #send errors 0, #recv errors 0
    local crypto endpt.: 10.0.0.1, remote crypto endpt.: 10.0.0.2
    path mtu 1500, ipsec overhead 0, media mtu 1500
    current outbound spi: 0
    inbound esp sas:
    inbound ah sas:
    inbound pcp sas:
    outbound esp sas:
    outbound ah sas:
    outbound pcp sas:
    pixfirewall#
    Thanks again Daniel, i really appreciate your help on this matter.

  • Systemd and a PPTP VPN

    Hello Arch Community!
    I'm trying to set up a PPTP VPN that automatically connects and routes all traffic on startup. The Wiki page still has instructions for rc.d. I've tried the following, but it doesn't seem to work
    /etc/systemd/system/multi-user.target.wants/pia.service
    [Unit]
    Description=Starts PIA_CALI.
    [Service]
    Type=Simple
    ExecStart=/usr/bin/pon PIA_CALI
    [Install]
    WantedBy=multi-user.target
    When I run systemctl start pia it acts like it works, but the ppp0 device is never created. It works fine when i simply run sudo pon PIA_CALI.
    Any help would be greatly appreciated!
    Thanks
    drsn0w

    Hi slreno, 
    Based on this link: http://support.microsoft.com/kb/314076, the following ports and protocol must be enabled for PPTP on all firewalls and routers that are between the VPN client and the VPN server: 
    Client ports                        Server port               Protocol
    1024-65535/TCP              1723/TCP                 PPTP
    But as what you've posted, you have a modem/router from timewarner, then you might also need to open those ports on that device.
    If everyone needs to believe in something, I believe I'll have another beer..

Maybe you are looking for

  • NVIDIA GeForce 8600M GT graphics processors issue

    Hello. i have this problem: http://support.apple.com/kb/ts2377 Just wondering how much would it cost to fix it? would it be worth it? or should i just get a new computer.. thnks!

  • How can I send an email to a group from my iPhone?

    I want to send an email to a group in my contacts, but when I select the group, the individuals display for selection.  How can I send an email by addressing it to the group? 

  • How to do business area adjustment

    hi Hi     I have posted different business areas for line items in some document. Exp.  Dr  B.A1  - 1000 Cash  Cr  B.A2  - 1000 Like that Here in the business area wise balance sheet and trail balance report, balances not tallied. How to do this. tha

  • Need to put help document on home page.

    Hi All..... in my project several users are not trained on oracle HRMS as to how to use the selfservice due to being on leave. I have prepared a document with screenshots on how to use the functions. I want to put this document in home page. So when

  • Only records of less than one day allowed for attendance/absence type 1002

    Hi All, I am getting an error while maintaining my sick leave absence type "Only records of less than one day allowed for attendance/absence type 1002" how to resolve this SD