Problem accessing an object in a VBox

Hi!
I have a problem accessing an object which is in a VBox.
I made an example so you can see my problem. I am trying to
access pnlChat.
If you load the swf you won't see the Alert because there is
something wrong (and I don't know what)
If you try to remove the <mx:VBox> tags that wrap the
pnlChat Panel, it will work.
Why can't I access this object when it is in a VBox?
Thanks

"Jimmy Jeeves" <[email protected]> wrote in
message
news:g8jv84$5ib$[email protected]..
> Hi!
>
> I have a problem accessing an object which is in a VBox.
> I made an example so you can see my problem. I am trying
to access
> pnlChat.
> If you load the swf you won't see the Alert because
there is something
> wrong
> (and I don't know what)
> If you try to remove the <mx:VBox> tags that wrap
the pnlChat Panel, it
> will
> work.
>
> Why can't I access this object when it is in a VBox?
From the FAQ I'm compiling:
Q: I need to set a property or add an event listener on a
component
that is in a ViewStack/TabNavigator/Accordion. When the
component is not
the first child of the Navigator Container, I get a null
object error
(#1009). What causes this, and how can I fix it?
A: By default, the Navigator containers only create the
children of
each pane as that pane is viewed. The easy way to fix this is
to set the
creationPolicy on the Navigator to "all." However, this will
cause your
application to take longer to load. A better way to fix this
is to wait for
a later event, such as creationComplete on the component you
want to access,
or to use binding to "pull" the data into the component.
The way I handle it is to call invalidateProperties() on
change of the
ViewStack. I then override commitProperties() and call an
"initializer" for
each pane. In the body of each initializer function, I check
to see if the
selectedItem for the viewStack is the one my initalizer cares
about. If
not, I return from the function immediately. Inside that
initializer
function, I set properties and add listeners as appropriate.

Similar Messages

  • Problem accessing child object and changing its appearance (color)

    For a program, I need to be able to access a child object (in this case a box) after adding it to a transform group and change its appearance, for example the color of its top face. I have included a small code example to show my problem. The box is the only child I have added to the TransformGroup, but when I call getChild(), it returns a node, and thus I can't then call getShape() to get the top face and change its appearance. What am I doing wrong?
    public BranchGroup createSceneGraph() {
         BranchGroup objRoot = new BranchGroup();
         Transform3D rotate = new Transform3D();
         Transform3D tempRotate = new Transform3D();
    rotate.rotX(Math.PI/4.0d);
         tempRotate.rotY(Math.PI/4.0d);
    rotate.mul(tempRotate);
         TransformGroup objRotate = new TransformGroup(rotate);
         objRoot.addChild(objRotate);
         Appearance ap = new Appearance();
         Appearance app = new Appearance();
         Appearance apr = new Appearance();
         ColoringAttributes colr = new ColoringAttributes();
         ColoringAttributes colg = new ColoringAttributes();
         colr.setColor((float)1, (float)0, (float)0);
         ap.setColoringAttributes(colr);
    colg.setColor((float)0,(float)1, 0);
         apr.setColoringAttributes(colg);
         Box box = new Box((float)0.4, (float)0.4, (float)0.4, app);
         box.getShape(4).setAppearance(ap);
         objRotate.addChild(box);
         objRotate.getChild(0).getShape(4).setAppearance(ap);
    objRoot.compile();
         return objRoot;
    }

    It would help if you gave us the following System information:
    Operating System/version
    Photoshop version number
    Amount of RAM installed
    Hard drive(s) capacity
    Make and model number of video card
    Also try resetting your preferences as described in the FAQ.
    http://forums.adobe.com/thread/375776?tstart=0
    You either have to physically delete (or rename) the preference files or, if using the Alt, Ctrl, and Shift method, be sure that you get a confirmation dialog.
    This resets all settings in Photoshop to factory defaults.
    A complete uninstall/re-install will not affect the preferences and a corrupt file there may be causing the problem.

  • Problem Accessing Instantiated Objects

    I'm sorry for the long code that follows. Am hoping that someone can point out some ideas for how to structure this properly. Following my instructor's cookie requirements, the first panel two user inputed balances and an interest rate. Two objects are instantiated, one for each balance, in a seperate class. The results of 12 months of savings are then displayed in the 2nd panel. There is then the required option to change the interest rate. When modified, it should show the new interests and balances for the original balances instead.
    I successfully got the first set of interests and new balances, and thought, "sweet! I'm home free now!"
    Because God himself hates me, this is of course not the case. It's not recognizing the objects in the second event, which is modifying the interest rate.
    I'm not sure how I can restructure this so that the objects which are instantiated using user input can be accessible by both events. If anybody can suffer through looking at all this junk and has some ideas (or even just some general advice on how to manipulate objects), I'd appreciate it.
    import javax.swing.*;
    import java.awt.*;
    import java.awt.event.*;
    import java.text.DecimalFormat;
    public class SavingsTest extends JFrame
        private JLabel balanceLabel, dollaSign, balanceLabel2, dollaSign2, percentSign, rateLabel;
        private JTextField balanceField, balanceField2, rateField;
        private JTextArea displayArea;
        private JButton submitButton, modifyButton;
        private String cBalance1S, cBalance2S, intRateS;
        private double cBalance1, cBalance2, intRate, oldBalance1, oldBalance2;
        // Constructor creates frame
        public SavingsTest ()
            super( "Savings Calculator" );
            Container container = getContentPane();
            JPanel mainPanel = new JPanel();
            mainPanel.setLayout(new FlowLayout());
            mainPanel.setBorder(BorderFactory.createEmptyBorder(5,5,5,5));   
    *          INPUT PANEL        *
            JPanel inputPanel = new JPanel();
            inputPanel.setLayout(null);        
            inputPanel.setPreferredSize(new Dimension(500,250));         
      //      inputPanel.setBackground(Color.white);       
            inputPanel.setBorder(BorderFactory.createCompoundBorder(
                          BorderFactory.createTitledBorder("Enter Data"),
                          BorderFactory.createEmptyBorder(5,5,5,5)));
            // Consumer 1 Balance Components
            balanceLabel = new JLabel ("Enter Customer 1 balance:"); 
            balanceLabel.setBounds(85,25,168,24);
            inputPanel.add(balanceLabel);
            dollaSign = new JLabel ("$ "); 
            dollaSign.setBounds(125,55,168,24);
            inputPanel.add(dollaSign);       
            balanceField = new JTextField(10);
            balanceField.setBounds(145,55,50,24);
            inputPanel.add(balanceField);
            // Consumer 2 Balance Components
            balanceLabel2 = new JLabel ("Enter Customer 2 balance:"); 
            balanceLabel2.setBounds(265,25,168,24);
            inputPanel.add(balanceLabel2);
            dollaSign2 = new JLabel ("$ "); 
            dollaSign2.setBounds(305,55,168,24);
            inputPanel.add(dollaSign2);       
            balanceField2 = new JTextField(10);
            balanceField2.setBounds(325,55,50,24);
            inputPanel.add(balanceField2);        
        // Interest Rate Components      
            rateLabel = new JLabel ("Enter annual rate :"); 
            rateLabel.setBounds(215,105,168,24);
            inputPanel.add(rateLabel);
            percentSign = new JLabel ("% "); 
            percentSign.setBounds(215,145,168,24);
            inputPanel.add(percentSign);       
            rateField = new JTextField(10);
            rateField.setBounds(235,145,50,24);
            inputPanel.add(rateField); 
         // Submit Button Component
            submitButton = new JButton("SUBMIT");
            submitButton.setBounds(215, 185, 80, 30);
            inputPanel.add(submitButton);
            mainPanel.add(inputPanel);             
    *          DISPLAY PANEL      *
            JPanel displayPanel = new JPanel();
            displayPanel.setLayout(null);        
            displayPanel.setPreferredSize(new Dimension(500,375));        
            displayPanel.setBorder(BorderFactory.createCompoundBorder(
                          BorderFactory.createTitledBorder("Monthly Interest & Balances"),
                          BorderFactory.createEmptyBorder(5,5,5,5)));
            // Modify Interest Rate Button Component
            modifyButton = new JButton("Modify Rate");
            modifyButton.setEnabled( false );       
            modifyButton.setBounds(215, 25, 80, 30);
            displayPanel.add(modifyButton);    
            // Display Area Component
            displayArea = new JTextArea(); 
            displayArea.setEditable(false);
            displayArea.setBounds(25,85,445,275);
            displayPanel.add(displayArea);          
            mainPanel.add(displayPanel);    
    *         MAIN PANEL           *
            container.add( mainPanel);      
            setSize(630, 700);
            setVisible( true );  
    *     SUBMIT BUTTON EVENT               *
    submitButton.addActionListener(
              new ActionListener()
         { // Open ActionListener
              public void actionPerformed (ActionEvent e)
                        getInput();
         } // Close ActionListener
    *          MODIFY BUTTON EVENT          *
    modifyButton.addActionListener(
              new ActionListener()
         { // Open ActionListener
              public void actionPerformed (ActionEvent e)
                        modifyInput();
         } // Close ActionListener
        }  // End Constructor
    public static void main ( String args[] )
          SavingsTest initiate = new SavingsTest();
          initiate.setDefaultCloseOperation( JFrame.EXIT_ON_CLOSE );
       private void getInput()
                // Get values from fields and assign to Strings
                cBalance1S = balanceField.getText();
                balanceField.setText("");
                cBalance2S = balanceField2.getText();
                balanceField2.setText("");
                intRateS = rateField.getText();
                rateField.setText("");
                // Parse Strings to doubles, etc
                cBalance1 = Double.parseDouble(cBalance1S);           
                cBalance2 = Double.parseDouble(cBalance2S);
                intRate = Double.parseDouble(intRateS);           
                intRate = intRate * .01;
                oldBalance1 = cBalance1;
                oldBalance2 = cBalance2;
                submitButton.setEnabled( false );
                modifyButton.setEnabled( true );
                SavingsAccount account1 = new SavingsAccount(cBalance1, intRate);
                SavingsAccount account2 = new SavingsAccount(cBalance2, intRate);              
                displayArea.append("\t         Account 1\t\t         Account 2\n");
                displayArea.append("\tInterest\tBalance\tInterest\tBalance\n");
                DecimalFormat twoDigits = new DecimalFormat( "0.00");
                // Calculate Interests & Balances, then display
                for (int i = 1; i <13; i++)
                    double interest1 = account1.calculateMonthlyInterest ();
                    double interest2 = account2.calculateMonthlyInterest ();
                    double newBalance1 = account1.calculateNewBalance(interest1);
                    double newBalance2 = account2.calculateNewBalance(interest2);
                    displayArea.append("Month " + i + ":\t" + twoDigits.format(interest1)
                    + "\t" + twoDigits.format(newBalance1) + "\t" +
                    twoDigits.format(interest2) + "\t" + twoDigits.format(newBalance2)
                    + "\n");
       private void modifyInput()
         intRateS = JOptionPane.showInputDialog(" Enter new annual rate: ");       
            intRate = Double.parseDouble(intRateS);
            SavingsAccount.modifyInterestRate(intRate);
            displayArea.setText("");
                displayArea.append("\t         Account 1\t\t         Account 2\n");
                displayArea.append("\tInterest\tBalance\tInterest\tBalance\n");
                DecimalFormat twoDigits = new DecimalFormat( "0.00");
                // Calculate Interests & Balances, then display
                for (int i = 1; i <13; i++)
                    // ERROR IS HERE WHERE IT DOES NOT RECOGNIZE THE OBJECTS
                    double interest1 = account1.calculateMonthlyInterest ();
                    double interest2 = account2.calculateMonthlyInterest ();
                    double newBalance1 = account1.calculateNewBalance(interest1);
                    double newBalance2 = account2.calculateNewBalance(interest2);
                    displayArea.append("Month " + i + ":\t" + twoDigits.format(interest1)
                    + "\t" + twoDigits.format(newBalance1) + "\t" +
                    twoDigits.format(interest2) + "\t" + twoDigits.format(newBalance2)
                    + "\n");
     

    I believe I did indeed state was not being recognized.I didn't see it. But then, I didn't read all your code either. That's not me (or paul) being an asshole--it's just too much code.
    Besides in the content of my post, if I were a
    gambling woman, I'd wager it's probably within that
    code which you went through so much trouble to make
    sure everybody knows you aren't reading. He wasn't doing that for anybody's benefit but your own. That is a lot of code to read. Pasting in the exact error message the compiler gave you would have made it a lot easier for someone to help you. Yawmark waas very kind, but in general, if you want help here, you should post details about what the problem is. "Not recognizing objects" means next to nothing, but the actual error message tells us a lot. In fact, you should take a stab at reading it yourself. Error messages are your friends. They tell you pretty precisely what was wrong and where.
    It says
    exactly where the objects are unrecognizable. It's
    even in big, red, pretty letters.The compiler gave you a lot more detail than that. You didn't indicate which objects.
    But why make posts which make coherent sense when you
    could just make an ass of yourself without all that
    silly reading.Paul's comments were intended to goad you into posting something that would make it easier for people to help you.
    >
    For example, complaining that there's too much code
    (having seen only half the code at that), It doesn't matter if that was only 0.001% of your code. It's too much to post here for that problem. It's understandable that you wouldn't know that, as you're new here, but copping an attitude instead of accepting the constructive criticism doesn't really accomplish anything.
    The only thing lending itself to the idea that God
    hates me is the fact that he let some idiot such as
    yourself wonder into this thread. There are some
    brilliant, wonderful, kind, and very helpful people on
    these forums to which I am eternally grateful. Then I
    guess there's also you.Actually, paulcw helps a lot of people here. Like most of us, he gets annoyed sometimes at poorly constructed questions.
    I hope that you won't take the above as a personal attack. It's not intended that way. It's intended to be constructive criticism.

  • Problem accessing exception object in jsp error page - Apache Tomcat 5.0.25

    Hi all,
    I'm thoroughly confused and need some help. I've deployed a very simple web application in Apache Tomcat 5.0.25 to test exception handling - errortest.jsp and error.jsp. errortest.jsp throws a divide by zero exception if executed with default values in text fields.
    When I put the directive IsErrorPage="true" in error.jsp i get a HTTP 500 error when error.jsp is accessed. If I remove it error.jsp is displayed but I cant access the exception object - if I try to I get an exception below:
    org.apache.jasper.JasperException: Unable to compile class for JSP
    An error occurred at line: 5 in the jsp file: /error.jsp
    Generated servlet error:
    [javac] Compiling 1 source file
    E:\Apache Software Foundation\Tomcat 5.0\work\Catalina\localhost\mywebapp\org\apache\jsp\error_jsp.java:46: cannot resolve symbol
    symbol : variable exception
    location: class org.apache.jsp.error_jsp
    out.print(exception.getMessage());
    ^
    1 error
    Below is the code for the two jsp pages:
    errortest.jsp:
    <%@ page errorPage="error.jsp" %>
    <html>
    <head><title>Error test</title></head>
    <body>     
         <form action="errortest.jsp" method="post">
         Enter first number:<input type="text" name="first" value="5"/><br>
         Enter second number:<input type="text" name="second" value="0"/><br>
         <input type="submit"/>
         </form>
         <%
         if (request.getMethod().equals("POST")) {
              int first = Integer.parseInt( request.getParameter( "first" ) );
              int second = Integer.parseInt( request.getParameter( "second" ) );
              int answer = first/second;
         %>
    </body>
    </html>
    NB: I am able to catch and display the exception if I use a try/catch block around the division as shown below.
    try {
    int answer = first/second;
    } catch( Exception e) {
    e.printStackTrace( new PrintWriter(out) );
    error.jsp (first draft)
    NB: HTTP 500 error occurs when directive "isErrorPage" is added:
    <%@ page isErrorPage="true" %>
    <html>
    <head><title>Error Page</title></head>
    <body>
    </body>
    </html>
    error.jsp (second draft)
    NB: directive is removed but exception thrown when implicit exception object is accessed. error.jsp displays if exception object is not accessed:
    <%@ page %>
    <html>
    <head><title>Error Page</title></head>
    <body>
    <%=exception.getMessage()%>
    </body>
    </html>
    Web server specs:
    Apache Tomcat 5.0.25
    Machine specs:
    Windows XP Pro
    Java environments:
    j2sdk1.4.2_03
    J2EE 1.4

    This works for me:
    throwError.jsp
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
         "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <%@ page language="java" errorPage="/error.jsp"
    contentType="text/html; charset=utf-8" %>
    <html>
    <head>
         <title>Throw Exception</title>
    </head>
    <body>
    Throwing exception....
    <%
    // throw ArithmeticException
    int badInt = 12/0;
    %>
    </body>
    </html>
    error.jsp
    <%@ page language="java" isErrorPage="true" %>
    <head><title>Doh!</title></head>
    An Error has occurred in this application.
    <% if (exception != null) { %>
    <pre><% exception.printStackTrace(new java.io.PrintWriter(out)); %></pre>
    <% } else { %>
    Please check your log files for further information.
    <% } %>

  • Problem accessing Document object UDF

    Hey All,
    I am trying to build a custom application for a company that us using SBO patch level 21. Unfortunately they cannot upgrade to a newer patch level at this time.
    I use the following code to check the existence of a  UDF field:
    if(myDocument.Lines.UserFields.Fields.Item(udfField) != null)
    {                                   myDocument.Lines.UserFields.Fields.Item(udfField).Value = udfVal;
    For some reason the DI API throws an exception to say it cannot find the UDF. Even though it exists in the database. I have tried a number of UDFs all of which exist and they all throw the exception.
    Any ideas?

    Lita,
    I wasn't lucky as you!
    I even tried to access to the user field by index but I always get a COM exception: FFFFFBAF
    Here's the code still not working properly:
    SAPbobsCOM.Documents d = (SAPbobsCOM.Documents) B1Company.GetBusinessObject(SAPbobsCOM.BoObjectTypes.oPurchaseOrders); // Same problem on other documents...
                        SAPbobsCOM.Document_Lines dl = d.Lines;
                        dl.SetCurrentLine(0);
                        try
                            int n = d.UserFields.Fields.Count;
                            string fld = dl.UserFields.Fields.Item(0).Description;
                            //int j = dl.UserFields.Fields.Count;
                        catch (System.Exception e)
                            B1App.MessageBox(e.Message, 0, "OK", "", "");
    This problem is a nightmare because we have severals customer add-ons based on document lines user fields!!!

  • Problem accessing a objects in a public class

    Hello I am have written a program where I am using 2 classes. I have created a JFrame class in one of my classes and I have created a JFormattedtextfield in my other class. How do I place the JFormattedtextfields on the the JFrame which I have created in another class?

    This is what I sort of what I mean. Since I am new to java I don't know how to mount the panels onto f here. Also the reason why I did'nt post it on the swing forum is that I got the swing part of the code figured out I just need help with the general programming bit.
    public class test {
        public static void main(String[] args) {
       public test() {
              JFrame f = new JFrame("Test Program");  // f is created here
              f.setSize(400,400);
              f.setVisible(true);         
    class Layout {
              //Fields for data entry
               JFormattedTextField test = new JFormattedTextField ();
               //Panels
               JPanel secondaryPanel = new JPanel();
               public Layout(){
               test.setForeground(Color.black);     
               f.add(secondaryPanel); // How do I mount this panel onto f here           
      }

  • Add ABAP program: validating package - error accessing shared objects-area

    When adding a new program or browsing the packages in eclipse i get an "error accessing shared objects-area".
    I can edit, save and run existing ABAP reports, however.
    There was a similar problem here, regarding database procedure proxies but the solution doesn't apply to my problem, i guess. The solution was about creating the shared memory area CL_RIS_SHM_AREA. I can't access the memory area and start the constructor, as it doesn't show up on the monitor.
    ADT 2.28
    Eclipse 4.3
    Netweaver 7.31 SP4 -> is this really compatible with ADT 2.28?
    Thanks in advance for helpful hints,
    Julian

    HI Julian,
    if the area doesn't show up in the monitor, please try to start the constructor in transaction SHMM on your own by selecting the icon 'Start Constructor' as shown in the screenshot.
    Choose CL_RIS_SHM_AREA as area, select 'Default Instance' and 'Dialog' as execution mode. Then press 'Create'. Either this works or the system will tell you the issue with the instance creation (e.g. insufficient shared objects memory - see the other solution description).
    Best regards, Sebastian

  • Exchange setup error: "There was a problem accessing the registry on this computer"

     Hi,
    i am trying to install Exchange 2007 SP1 in a Windows 2003 Server standard 32 bits version.
    During the "Readiness checks" i received the next error in "Hub transport role prerequisites":
    Error:
    There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.
    Remote Registry service is running. I've searched for the error in google and in some topics appears that the error is due to the "Client for Microsoft Networks" and "File and Printer Sharing" is not installed in the LAN properties. The server has 2 network cards and in both of them is checked. One of the connections is disabled.
    I dont know what more to do, any help will be appreciated.
    Thanks

    No, firewall is disabled.
    Setup Logs says:
    10:50:04.890: Starting Collecting Data phase.
    10:50:04.921: No mapping between account names and security IDs was done
    10:50:04.984: Error (Unexpected error [0x674CBB7E] while executing command '[Microsoft.Win32.RegistryKey]:penRemoteBaseKey([Microsoft.Win32.RegistryHive]::LocalMachine, [System.Net.Dns]::GetHostEntry([System.Net.Dns]::GetHostName()).HostName)'.) trying to process object [Microsoft.Win32.RegistryKey]:penRemoteBaseKey([Microsoft.Win32.RegistryHive]::LocalMachine, [System.Net.Dns]::GetHostEntry([System.Net.Dns]::GetHostName()).HostName), skipping object.
    10:50:06.093: Completed Collecting Data phase.
    10:50:06.125: Error (Rule name 'PreReq_fPassiveUninstallNoCMSPresentKey' referenced by rule 'PreReq_fPassiveUninstallNoCMSPresent' in input file is not defined) in format of rules in configuration file.
    10:50:06.171: Starting Postprocessing Rules phase.
    10:50:06.187: Completed Postprocessing Rules phase.
    Thanks for your help!

  • Unable to access the objects with out schema as prefix.. can any body help

    Hi,
    i am using 10g.I have one problem like i unable to get the table access with out mention prefix for that table.
    but i created public synonym and gave all grants to all users also. but still i need to mention schema name as prefix otherwise it give the error..
    can any body tell me reason and give me solution.
    ex: owner:eiis table:eiis_wipstock
    connect to: egps schema
    in this position if i try with eiis.wipstock it gives error but if i mention like eiis.wiis_wipstock then its working fine.

    Pl do not spam the forums with duplicate posts - Unable to access the objects with out schema as prefix.. can any body help

  • Problem accessing another public ip in same subnet

    Hi,
    I have searched around for a previous post regarding this but can't find an issue similar to mine (or I'm just too stupid to understand that it is )
    I have a Cisco 5505 at a small business that I help. The problem is that the ISP are providing public IPs to multiple customers in a /24 subnet. The ASA has a single public IP configured 8.8.8.8 (not really, just for the examples sake) with a subnet mask of 255.255.255.0.
    The webserver I have to access is not managed by me and is located in a different location (same town though) has 8.8.8.115, it is located in the same subnet as the ASA.
    How would I make this work? I have tried to configure a static arp entry for the web server but it just won't work. If i place a computer directly on the outside interface I have no problem accessing the web server.
    I am running ASA version 8.2, but I could upgrade if it would help me solve the problem.
    Any help with this issue is much appreciated.

    The ISP only specify one gateway in that range and that is 8.8.8.1 so any other would not let me access internet.
    Once again thank you for your time.
    : Saved
    ASA Version 8.2(1)
    hostname ciscoasa
    domain-name XXXXXXX
    enable password XXXXXXX encrypted
    passwd XXXXXXX encrypted
    names
    name 8.8.8.8 Outside_IP
    name 192.168.20.2 Server
    name 192.168.20.11 rav-dc01
    name 192.168.20.12 rav-ms01
    name 192.168.20.13 rav-rds01
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.20.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address Outside_IP 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa821-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name XXXXXXX
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list inside_nat0_outbound extended permit ip any 192.168.25.0 255.255.255.0
    access-list RemoteVPNSplittunnel standard permit 192.168.20.0 255.255.255.0
    access-list outside_access_in extended permit tcp host 100.100.100.228 interface outside eq 3389
    access-list outside_access_in extended permit tcp any interface outside eq smtp
    access-list outside_access_in extended permit udp any interface outside eq 4125
    access-list outside_access_in extended permit tcp any interface outside eq 4125
    access-list outside_access_in extended permit tcp any interface outside eq https
    access-list outside_access_in extended permit tcp any interface outside eq pptp
    access-list outside_access_in extended permit tcp any interface outside eq 444
    access-list outside_access_in extended permit gre any interface outside
    access-list outside_access_in extended permit udp any interface outside eq 444
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list inside_access_in extended permit tcp host rav-ms01 any eq smtp
    access-list inside_access_in extended deny tcp any any eq smtp
    access-list inside_access_in extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool RemoteVPNPool 192.168.25.100-192.168.25.200 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) udp interface 4125 Server 4125 netmask 255.255.255.255
    static (inside,outside) tcp interface 4125 Server 4125 netmask 255.255.255.255
    static (inside,outside) tcp interface https rav-ms01 https netmask 255.255.255.255  dns
    static (inside,outside) tcp interface pptp Server pptp netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 rav-rds01 3389 netmask 255.255.255.255  dns
    static (inside,outside) tcp interface smtp rav-ms01 smtp netmask 255.255.255.255
    static (inside,outside) udp interface 444 Server 444 netmask 255.255.255.255
    static (inside,outside) tcp interface 444 Server 444 netmask 255.255.255.255
    static (inside,outside) tcp interface www Server www netmask 255.255.255.255  dns
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 8.8.8.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server rav_Intern protocol radius
    aaa-server rav_Intern (inside) host rav-dc01
    key CiscoAsa5505RAV2012
    radius-common-pw CiscoAsa5505RAV2012
    http server enable 8080
    http 192.168.20.0 255.255.255.0 inside
    http 192.168.25.0 255.255.255.0 inside
    http 100.100.101.128 255.255.255.192 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt connection timewait
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map outside_dyn_map 20 set pfs
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.20.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.20.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    dhcpd address 192.168.20.190-192.168.20.200 inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server rav-dc01 source inside
    webvpn
    group-policy RemoteVPN internal
    group-policy RemoteVPN attributes
    wins-server value 192.168.20.11
    dns-server value 192.168.20.11
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value RemoteVPNSplittunnel
    default-domain value rav.nu
    split-dns value rav.nu
    username SupportVPN password XXXXXXX encrypted privilege 0
    username SupportVPN attributes
    vpn-group-policy RemoteVPN
    tunnel-group RemoteVPN type remote-access
    tunnel-group RemoteVPN general-attributes
    address-pool RemoteVPNPool
    authentication-server-group rav_Intern
    accounting-server-group rav_Intern
    default-group-policy RemoteVPN
    tunnel-group RemoteVPN ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect pptp
      inspect icmp
      inspect icmp error
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:8481ab3aa01b23bad17bacb2aca7197a
    : end
    asdm image disk0:/asdm-621.bin
    no asdm history enable

  • ListCellFactory - how to access an object's data associated with list cell?

    I am new to javafx and building a sample app to learn the basics. The app has a list view control and used listcellfactory to create listcells. Each list cell is composed of few labels and image. I populated list view with listViewItems function, where in it sends object[]; I have my own object with data that needs to be populated in the list cell. I have hard coded the object[] and that size is reflected in list view items size. However, I am not able to populate the object data in individual labels.
    In the following code, I can only get the string representation of the object and I am unable to figure out how to individually access the object's data. Please help me with this.
    function listCellFactory(): javafx.scene.control.ListCell {
    var listCell: javafx.scene.control.ListCell;
    def offerLbl: javafx.scene.control.Label = javafx.scene.control.Label {
    text: bind "{listCell.item}"
    def descriptionLbl: javafx.scene.control.Label = javafx.scene.control.Label {
    text: bind "{listCell.item}"
    def friendLbl: javafx.scene.control.Label = javafx.scene.control.Label {
    text: bind "{listCell.item}"
    def offerImgView: javafx.scene.image.ImageView = javafx.scene.image.ImageView {
    image: imagetrial
    fitWidth: 300.0
    fitHeight: 250.0
    def offerVerticalBox: javafx.scene.layout.VBox = javafx.scene.layout.VBox {
    content: [ offerLbl, descriptionLbl, friendLbl, offerImgView, ]
    spacing: 6.0
    listCell = javafx.scene.control.ListCell {
    node: offerVerticalBox
    return listCell
    }

    If I understand you question, it should be (listCell.data as YourClassName)
    Edited by: AigarsP on Oct 21, 2010 2:10 PM

  • Access to object list of type "BusinessSystem" using the InternalEOAService BusinessSystemAccessor failed

    Hi All,
    We are facing an issue in PI configuration when, we are unable to view business systems in the Integration Builder.
    ERROR : Access to object list of type "BusinessSystem" using the InternalEOAService BusinessSystemAccessor failed
    Our Landscape is as follows:
    PI : Based on NW7.4
    Connected to Central SLD on Solman 7.1
    OS : Windows 2008
    DB : MSSQL 2008
    We checked OSS note 1117249 - Incomplete Registration of PI components in SLD
    The problem seems to be with incomplete registration of PI components on the central SLD.
    In the Central SLD which we have configured, under the Process Integration tab we are unable to see entries for Integration Server, Adapter Engine, Directory, Repository and Runtime Workbench (RWB).
    Can you please help me with registering these components on the Central SLD so that these are visible during the PI configuration.
    Also, any idea if this issue is related to the different versions of PI and Central SLD system.
    Regards,
    Nilesh

    Hi Nilesh,
    Please check SAP Note 764176 - Manual correction of XI content in SLD.
    also check the below discussion
    Problem to register Intergration Server in SLD
    regards,
    Harish

  • "Site System Status Summarizer still cannot access storage object" after DB Move

    After our SCCM server was up and running, the DBAs moved the SQL Site Database to a new drive which is a supported SQL Operation according to this Support document:
    https://support.microsoft.com/en-us/kb/2709082
    Using the methods described by the above document we were able to restore functionality to SCCM but I am still seeing Informational messages in the SMS_SITE_SYSTEM_STATUS_SUMMARIZER component.
    Site System Status Summarizer still cannot access storage object "\\<SQLServer>\S$\SMS_<SQLServer>" on site system "\\<SQLServer>". The operating system reported error 67: The network name cannot be found.
    Possible cause: The site system is turned off, not connected to the network, or not functioning properly.
    Solution: Verify that the site system is turned on, connected to the network, and functioning properly.
    Possible cause: Site System Status Summarizer does not have sufficient access rights to connect to the site system and access the storage object.
    Solution: Verify that the accounts are properly configured to allow the site to connect to the site system and access the storage object.
    Possible cause: Network problems are preventing Site System Status Summarizer from connecting to the site system.
    Solution: Investigate and correct any problems on your network.
    Possible cause: You took the site system out of service and do not intend on using it as a site system any more.
    Solution: Remove the site system from the list of site systems used by this site; this list appears under Site Systems in the Configuration Manager Console.
    Possible cause: You accidentally deleted the storage object or took the storage object out of service.
    Solution: The components will eventually detect that the storage object no longer exists on the site system and will either recreate it or choose a new storage object. Monitor the status messages reported by other site components to verify that this
    occurs properly.
    The storage object has been inaccessible since "14/03/2015 1:23:20 AM". When you correct the problem and Site System Status Summarizer successfully accesses the storage object, Site System Status Summarizer will set the storage object's status
    to OK, providing that the storage object has sufficient free space.
    I have run a site reset to try and fix this but the site server still seems to be trying to access files on the old drive. Is there a method to get SCCM to start looking for these files on the NEW DB drive (H$) in my case?

    Was a site reset performed at all yet? This has to be done. 
    Torsten Meringer | http://www.mssccmfaq.de
    Yes, I tried a site reset prior to making this post. I was sure I had read that this should resolve the issue but unfortunately it seems a site reset did not resolve the issue.
    Since we are running a virtualized environment, is it possible the old drive has to still exist prior to running the site reset? If we add a small "S" drive back to the server and run the site reset again, might that help?

  • Thread safety bug in XPS Serializer or FixedDocument sequence? "calling thread cannot access this object..."

    Every once in a while (500 iterations or more) I'm getting an exception in the static method below stating "calling thread cannot access this object because a different thread owns it".  Thing is, this method references no external objects
    and performs no special threading operations.  All of the WPF objects are created and consumed in this method.  The only aspect that is multi-threaded is that this method can get called concurrently on different threads in the same app domain (the
    project is a Windows service). That said the fileToDecollate parameter will be unique every time, so there is no "collision" as far as that goes.
    Any ideas?   This is maddening and in theory it should not be possible to blow this error.
    Exception Information------------------------------------------
    System.InvalidOperationException: The calling thread cannot access this object because a different thread owns it.
       at System.Windows.Threading.Dispatcher.VerifyAccess()
       at System.Windows.DependencyObject.GetLocalValueEnumerator()
       at System.Windows.Xps.Serialization.SerializersCacheManager.GetTypeDependencyPropertiesCacheItem(Object serializableObject)
       at System.Windows.Xps.Serialization.SerializersCacheManager.GetSerializableDependencyProperties(Object serializableObject)
       at System.Windows.Xps.Serialization.SerializablePropertyCollection.InitializeSerializableDependencyProperties()
       at System.Windows.Xps.Serialization.SerializablePropertyCollection.Initialize(PackageSerializationManager serializationManager, Object targetObject)
       at System.Windows.Xps.Serialization.SerializableObjectContext.CreateContext(PackageSerializationManager serializationManager, Object serializableObject, SerializableObjectContext serializableObjectParentContext, SerializablePropertyContext serializablePropertyContext)
       at System.Windows.Xps.Serialization.ReachSerializer.DiscoverObjectData(Object serializedObject, SerializablePropertyContext serializedProperty)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeObject(Object serializedObject)
       at System.Windows.Xps.Serialization.FixedDocumentSerializer.SerializeObject(Object serializedObject)
       at System.Windows.Xps.Serialization.ReachDocumentReferenceSerializer.PersistObjectData(SerializableObjectContext serializableObjectContext)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeObject(Object serializedObject)
       at System.Windows.Xps.Serialization.ReachDocumentReferenceCollectionSerializer.SerializeDocumentReference(Object documentReference)
       at System.Windows.Xps.Serialization.ReachDocumentReferenceCollectionSerializer.SerializeDocumentReferences(SerializableObjectContext serializableObjectContext)
       at System.Windows.Xps.Serialization.ReachDocumentReferenceCollectionSerializer.PersistObjectData(SerializableObjectContext serializableObjectContext)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeObject(SerializablePropertyContext serializedProperty)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeProperty(SerializablePropertyContext serializablePropertyContext)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeProperties(SerializableObjectContext serializableObjectContext)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeObjectCore(SerializableObjectContext serializableObjectContext)
       at System.Windows.Xps.Serialization.DocumentSequenceSerializer.PersistObjectData(SerializableObjectContext serializableObjectContext)
       at System.Windows.Xps.Serialization.ReachSerializer.SerializeObject(Object serializedObject)
       at System.Windows.Xps.Serialization.XpsSerializationManager.SaveAsXaml(Object serializedObject)
       at System.Windows.Xps.XpsDocumentWriter.SaveAsXaml(Object serializedObject, Boolean isSync)
       at System.Windows.Xps.XpsDocumentWriter.Write(FixedDocumentSequence fixedDocumentSequence)
       at MyCompany.Utilities.Document.XPSDocument.Decollate(String fileToDecollate, String outputPath) in E:\Projects\MyCompany\Utilities\MyCompany.Utilities.Document\XPSDocument.cs:line 358
       at MyCompany.Services.ERM.XPSCapture.Decollate(String fileToDecollate, String outputPath) in E:\Projects\MyCompany\Services\MyCompany.Services.ERM\XPSCapture.cs:line 210
       at MyCompany.Services.ERM.ERMFileProcessor.decollateERMFile(String tempERMFile, IFileCapture fileCapture) in E:\Projects\MyCompany\Services\MyCompany.Services.ERM\ERMFileProcessor.cs:line 1257
       at MyCompany.Services.ERM.ERMFileProcessor.process() in E:\Projects\doc-link\MyCompany\Services\Altec.Services.ERM\ERMFileProcessor.cs:line 354
       at MyCompany.Services.ERM.ERMFileProcessor.Process(ProcessingCompleteCallback callback) in E:\Projects\MyCompany\Services\MyCompany.Services.ERM\ERMFileProcessor.cs:line 90
    Additonal Info------------------------------------------
    ExceptionManager.MachineName: BTP-30-DEV
    ExceptionManager.WindowsIdentity: XXXXX-WA\Bradley
    ExceptionManager.FullName: WindowsBase, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    ExceptionManager.AppDomainName: MyCompany.XXXXXXServiceHost.exe
    ExceptionManager.ProcessInfo: PID=7392, ThreadID=7816, Managed ThreadID=36, Name=MyCompany.XXXXXXServiceHost, Uptime=00:02:12.2548416
    ExceptionManager.ProcessResourceUsage: Working Set=265188 KB, Peak Working Set=525940 KB, Virtual Memory Size=530264 KB, Peak VM Size=809832 KB, Handles=631
    ExceptionManager.SystemMemory: Load=81%, Total Physical=3168748 KB, Free Physical=586736 KB, Total PageFile=5213700
    publicstaticList<string>
    Decollate(stringfileToDecollate,
    stringoutputPath)
      // iterate fixed documents and fixed pages, create new XPS files
    List<string>
    xpsDecFiles = newList<string>();
      using(XpsDocumentxpsSourceDocument
    = newXpsDocument(fileToDecollate,
    FileAccess.Read))
        FixedDocumentSequencefixedDocSeq
    = xpsSourceDocument.GetFixedDocumentSequence();
        intpageNumber = 0;
        foreach(DocumentReferencedocReference
    infixedDocSeq.References)
          FixedDocumentsourceFixedDoc
    = docReference.GetDocument(false);
          foreach(PageContentpage
    insourceFixedDoc.Pages)
            pageNumber++;
            // prepare new fixed doc sequence
    FixedDocumentSequencenewFixedDocSeq
    = new
    FixedDocumentSequence();
    DocumentReferencenewDocReference
    = new
    DocumentReference();
    FixedDocumentnewFdoc
    = new
    FixedDocument();
    newDocReference.SetDocument(newFdoc);
    // copy the page
    PageContentnewPage =
    new
    PageContent();
    newPage.Source = page.Source;
    (newPage asIUriContext).BaseUri
    = ((IUriContext)page).BaseUri;
    // tickle this method... presumably just to load the FixedPage data.
    FixedPagenewFixedPage
    = newPage.GetPageRoot(false);
    // Add page to fixed doc sequence.
    newFdoc.Pages.Add(newPage);
    // Always do this last: add document reference to fixed doc sequence. 
    newFixedDocSeq.References.Add(newDocReference);
    // create and save new XPS doc                   
    stringdecFileName =
    Path.Combine(outputPath,
    Path.GetFileNameWithoutExtension(fileToDecollate)
    + "~"+ (pageNumber).ToString()
    + FileExtensions.XPS);
    if(File.Exists(decFileName))
    File.Delete(decFileName);
    XpsDocumentnewXPSDoc
    = new
    XpsDocument(decFileName,
    FileAccess.ReadWrite);
    // testing.  thread IDs should be the same.
    //Debug.Assert(System.Windows.Threading.Dispatcher.CurrentDispatcher.Thread.ManagedThreadId == newFixedDocSeq.Dispatcher.Thread.ManagedThreadId);
    XpsDocument.CreateXpsDocumentWriter(newXPSDoc).Write(newFixedDocSeq);
    newXPSDoc.Close();
    // add file to list
    xpsDecFiles.Add(decFileName);
      returnxpsDecFiles;

    I have opened a support case with Microsoft through my employer.  I'm convinced there is some .NET framework code that is not thread safe.  I did put together a test harness app that demonstrates the problem (within 30 seconds or so after
    you start it) and I sent that to MS support.  They're looking into it. Anyone else who is curious can download the sample project here:
    https://skydrive.live.com/redir?resid=5CBB4B55BCCB2D67!443&authkey=!AGEnR3CKrXUU6E0
    Bradley
    Bradley P.

  • Access to object that call me?

    Any can help me with this problem.
    I got:
    ClassA
    ClassB
    ClassC
    They all mine. and derived from Object.
    I create "objectA" of ClassA,
    then call method of "objectA", which call method of "objectB" (ClassB)
    which call method of "objectC"..
    At end of this in "objectC", i want to have access to "objectA"
    What i should use?
    Sorry about my English.

    public ClassB (ClassA obja) {
    ClassC c = new ClassC(a)
    public ClassC (ClassA obja) {
    obja.whatever

Maybe you are looking for

  • Linking Cost Centre to Hierarchy via ALE

    When sending new Cost Centres from our FMS Server to HR/Payroll Server via ALE & IDOCS, the Cost Centres are created, but there is no link to the Hierarchy. (ie) when going into transaction OKEN, they do not appear under the relevant group. However i

  • How to remove cfauth ("cf authentification") prompt?

    Each time i browse, the prompt called "cfauth" asking my user name and password

  • Where is the Nagios add on toolbar ?

    Hello, I used to have my Nagios add on toolbar on the bottom of Firefox. Since the version 29, Nagios toolbar has disappeared. Looked at the FAQ, and none of the answers helped me. When I try to customize my menu, or try to "display/undisplay" toolba

  • DW 8.02 Crashing  Help!!

    Hi Everybody, I'm running DW 8.02 on a Windows xpsp2 setup. Dreamweaver launches fine but when I launch the site manager Dreamweaver hangs up and then crashes after about 30 seconds or so. I tried all the suggested fixes including uninstalling/ reins

  • HELP HUGE OS X PROBLEM!!!!!

    Ok HUGE problem, I just installed OS X Tiger on my g3 lombard, it ran perfectly, that later on in the day I restarted and when I did the gray screen with the dark grey apple in the middle, and the botton cricle-lines that keeps spinnign appears and i