Problem Accessing Instantiated Objects

I'm sorry for the long code that follows. Am hoping that someone can point out some ideas for how to structure this properly. Following my instructor's cookie requirements, the first panel two user inputed balances and an interest rate. Two objects are instantiated, one for each balance, in a seperate class. The results of 12 months of savings are then displayed in the 2nd panel. There is then the required option to change the interest rate. When modified, it should show the new interests and balances for the original balances instead.
I successfully got the first set of interests and new balances, and thought, "sweet! I'm home free now!"
Because God himself hates me, this is of course not the case. It's not recognizing the objects in the second event, which is modifying the interest rate.
I'm not sure how I can restructure this so that the objects which are instantiated using user input can be accessible by both events. If anybody can suffer through looking at all this junk and has some ideas (or even just some general advice on how to manipulate objects), I'd appreciate it.
import javax.swing.*;
import java.awt.*;
import java.awt.event.*;
import java.text.DecimalFormat;
public class SavingsTest extends JFrame
    private JLabel balanceLabel, dollaSign, balanceLabel2, dollaSign2, percentSign, rateLabel;
    private JTextField balanceField, balanceField2, rateField;
    private JTextArea displayArea;
    private JButton submitButton, modifyButton;
    private String cBalance1S, cBalance2S, intRateS;
    private double cBalance1, cBalance2, intRate, oldBalance1, oldBalance2;
    // Constructor creates frame
    public SavingsTest ()
        super( "Savings Calculator" );
        Container container = getContentPane();
        JPanel mainPanel = new JPanel();
        mainPanel.setLayout(new FlowLayout());
        mainPanel.setBorder(BorderFactory.createEmptyBorder(5,5,5,5));   
*          INPUT PANEL        *
        JPanel inputPanel = new JPanel();
        inputPanel.setLayout(null);        
        inputPanel.setPreferredSize(new Dimension(500,250));         
  //      inputPanel.setBackground(Color.white);       
        inputPanel.setBorder(BorderFactory.createCompoundBorder(
                      BorderFactory.createTitledBorder("Enter Data"),
                      BorderFactory.createEmptyBorder(5,5,5,5)));
        // Consumer 1 Balance Components
        balanceLabel = new JLabel ("Enter Customer 1 balance:"); 
        balanceLabel.setBounds(85,25,168,24);
        inputPanel.add(balanceLabel);
        dollaSign = new JLabel ("$ "); 
        dollaSign.setBounds(125,55,168,24);
        inputPanel.add(dollaSign);       
        balanceField = new JTextField(10);
        balanceField.setBounds(145,55,50,24);
        inputPanel.add(balanceField);
        // Consumer 2 Balance Components
        balanceLabel2 = new JLabel ("Enter Customer 2 balance:"); 
        balanceLabel2.setBounds(265,25,168,24);
        inputPanel.add(balanceLabel2);
        dollaSign2 = new JLabel ("$ "); 
        dollaSign2.setBounds(305,55,168,24);
        inputPanel.add(dollaSign2);       
        balanceField2 = new JTextField(10);
        balanceField2.setBounds(325,55,50,24);
        inputPanel.add(balanceField2);        
    // Interest Rate Components      
        rateLabel = new JLabel ("Enter annual rate :"); 
        rateLabel.setBounds(215,105,168,24);
        inputPanel.add(rateLabel);
        percentSign = new JLabel ("% "); 
        percentSign.setBounds(215,145,168,24);
        inputPanel.add(percentSign);       
        rateField = new JTextField(10);
        rateField.setBounds(235,145,50,24);
        inputPanel.add(rateField); 
     // Submit Button Component
        submitButton = new JButton("SUBMIT");
        submitButton.setBounds(215, 185, 80, 30);
        inputPanel.add(submitButton);
        mainPanel.add(inputPanel);             
*          DISPLAY PANEL      *
        JPanel displayPanel = new JPanel();
        displayPanel.setLayout(null);        
        displayPanel.setPreferredSize(new Dimension(500,375));        
        displayPanel.setBorder(BorderFactory.createCompoundBorder(
                      BorderFactory.createTitledBorder("Monthly Interest & Balances"),
                      BorderFactory.createEmptyBorder(5,5,5,5)));
        // Modify Interest Rate Button Component
        modifyButton = new JButton("Modify Rate");
        modifyButton.setEnabled( false );       
        modifyButton.setBounds(215, 25, 80, 30);
        displayPanel.add(modifyButton);    
        // Display Area Component
        displayArea = new JTextArea(); 
        displayArea.setEditable(false);
        displayArea.setBounds(25,85,445,275);
        displayPanel.add(displayArea);          
        mainPanel.add(displayPanel);    
*         MAIN PANEL           *
        container.add( mainPanel);      
        setSize(630, 700);
        setVisible( true );  
*     SUBMIT BUTTON EVENT               *
submitButton.addActionListener(
          new ActionListener()
     { // Open ActionListener
          public void actionPerformed (ActionEvent e)
                    getInput();
     } // Close ActionListener
*          MODIFY BUTTON EVENT          *
modifyButton.addActionListener(
          new ActionListener()
     { // Open ActionListener
          public void actionPerformed (ActionEvent e)
                    modifyInput();
     } // Close ActionListener
    }  // End Constructor
public static void main ( String args[] )
      SavingsTest initiate = new SavingsTest();
      initiate.setDefaultCloseOperation( JFrame.EXIT_ON_CLOSE );
   private void getInput()
            // Get values from fields and assign to Strings
            cBalance1S = balanceField.getText();
            balanceField.setText("");
            cBalance2S = balanceField2.getText();
            balanceField2.setText("");
            intRateS = rateField.getText();
            rateField.setText("");
            // Parse Strings to doubles, etc
            cBalance1 = Double.parseDouble(cBalance1S);           
            cBalance2 = Double.parseDouble(cBalance2S);
            intRate = Double.parseDouble(intRateS);           
            intRate = intRate * .01;
            oldBalance1 = cBalance1;
            oldBalance2 = cBalance2;
            submitButton.setEnabled( false );
            modifyButton.setEnabled( true );
            SavingsAccount account1 = new SavingsAccount(cBalance1, intRate);
            SavingsAccount account2 = new SavingsAccount(cBalance2, intRate);              
            displayArea.append("\t         Account 1\t\t         Account 2\n");
            displayArea.append("\tInterest\tBalance\tInterest\tBalance\n");
            DecimalFormat twoDigits = new DecimalFormat( "0.00");
            // Calculate Interests & Balances, then display
            for (int i = 1; i <13; i++)
                double interest1 = account1.calculateMonthlyInterest ();
                double interest2 = account2.calculateMonthlyInterest ();
                double newBalance1 = account1.calculateNewBalance(interest1);
                double newBalance2 = account2.calculateNewBalance(interest2);
                displayArea.append("Month " + i + ":\t" + twoDigits.format(interest1)
                + "\t" + twoDigits.format(newBalance1) + "\t" +
                twoDigits.format(interest2) + "\t" + twoDigits.format(newBalance2)
                + "\n");
   private void modifyInput()
     intRateS = JOptionPane.showInputDialog(" Enter new annual rate: ");       
        intRate = Double.parseDouble(intRateS);
        SavingsAccount.modifyInterestRate(intRate);
        displayArea.setText("");
            displayArea.append("\t         Account 1\t\t         Account 2\n");
            displayArea.append("\tInterest\tBalance\tInterest\tBalance\n");
            DecimalFormat twoDigits = new DecimalFormat( "0.00");
            // Calculate Interests & Balances, then display
            for (int i = 1; i <13; i++)
                // ERROR IS HERE WHERE IT DOES NOT RECOGNIZE THE OBJECTS
                double interest1 = account1.calculateMonthlyInterest ();
                double interest2 = account2.calculateMonthlyInterest ();
                double newBalance1 = account1.calculateNewBalance(interest1);
                double newBalance2 = account2.calculateNewBalance(interest2);
                displayArea.append("Month " + i + ":\t" + twoDigits.format(interest1)
                + "\t" + twoDigits.format(newBalance1) + "\t" +
                twoDigits.format(interest2) + "\t" + twoDigits.format(newBalance2)
                + "\n");
 

I believe I did indeed state was not being recognized.I didn't see it. But then, I didn't read all your code either. That's not me (or paul) being an asshole--it's just too much code.
Besides in the content of my post, if I were a
gambling woman, I'd wager it's probably within that
code which you went through so much trouble to make
sure everybody knows you aren't reading. He wasn't doing that for anybody's benefit but your own. That is a lot of code to read. Pasting in the exact error message the compiler gave you would have made it a lot easier for someone to help you. Yawmark waas very kind, but in general, if you want help here, you should post details about what the problem is. "Not recognizing objects" means next to nothing, but the actual error message tells us a lot. In fact, you should take a stab at reading it yourself. Error messages are your friends. They tell you pretty precisely what was wrong and where.
It says
exactly where the objects are unrecognizable. It's
even in big, red, pretty letters.The compiler gave you a lot more detail than that. You didn't indicate which objects.
But why make posts which make coherent sense when you
could just make an ass of yourself without all that
silly reading.Paul's comments were intended to goad you into posting something that would make it easier for people to help you.
>
For example, complaining that there's too much code
(having seen only half the code at that), It doesn't matter if that was only 0.001% of your code. It's too much to post here for that problem. It's understandable that you wouldn't know that, as you're new here, but copping an attitude instead of accepting the constructive criticism doesn't really accomplish anything.
The only thing lending itself to the idea that God
hates me is the fact that he let some idiot such as
yourself wonder into this thread. There are some
brilliant, wonderful, kind, and very helpful people on
these forums to which I am eternally grateful. Then I
guess there's also you.Actually, paulcw helps a lot of people here. Like most of us, he gets annoyed sometimes at poorly constructed questions.
I hope that you won't take the above as a personal attack. It's not intended that way. It's intended to be constructive criticism.

Similar Messages

  • Problem accessing an object in a VBox

    Hi!
    I have a problem accessing an object which is in a VBox.
    I made an example so you can see my problem. I am trying to
    access pnlChat.
    If you load the swf you won't see the Alert because there is
    something wrong (and I don't know what)
    If you try to remove the <mx:VBox> tags that wrap the
    pnlChat Panel, it will work.
    Why can't I access this object when it is in a VBox?
    Thanks

    "Jimmy Jeeves" <[email protected]> wrote in
    message
    news:g8jv84$5ib$[email protected]..
    > Hi!
    >
    > I have a problem accessing an object which is in a VBox.
    > I made an example so you can see my problem. I am trying
    to access
    > pnlChat.
    > If you load the swf you won't see the Alert because
    there is something
    > wrong
    > (and I don't know what)
    > If you try to remove the <mx:VBox> tags that wrap
    the pnlChat Panel, it
    > will
    > work.
    >
    > Why can't I access this object when it is in a VBox?
    From the FAQ I'm compiling:
    Q: I need to set a property or add an event listener on a
    component
    that is in a ViewStack/TabNavigator/Accordion. When the
    component is not
    the first child of the Navigator Container, I get a null
    object error
    (#1009). What causes this, and how can I fix it?
    A: By default, the Navigator containers only create the
    children of
    each pane as that pane is viewed. The easy way to fix this is
    to set the
    creationPolicy on the Navigator to "all." However, this will
    cause your
    application to take longer to load. A better way to fix this
    is to wait for
    a later event, such as creationComplete on the component you
    want to access,
    or to use binding to "pull" the data into the component.
    The way I handle it is to call invalidateProperties() on
    change of the
    ViewStack. I then override commitProperties() and call an
    "initializer" for
    each pane. In the body of each initializer function, I check
    to see if the
    selectedItem for the viewStack is the one my initalizer cares
    about. If
    not, I return from the function immediately. Inside that
    initializer
    function, I set properties and add listeners as appropriate.

  • Problem accessing child object and changing its appearance (color)

    For a program, I need to be able to access a child object (in this case a box) after adding it to a transform group and change its appearance, for example the color of its top face. I have included a small code example to show my problem. The box is the only child I have added to the TransformGroup, but when I call getChild(), it returns a node, and thus I can't then call getShape() to get the top face and change its appearance. What am I doing wrong?
    public BranchGroup createSceneGraph() {
         BranchGroup objRoot = new BranchGroup();
         Transform3D rotate = new Transform3D();
         Transform3D tempRotate = new Transform3D();
    rotate.rotX(Math.PI/4.0d);
         tempRotate.rotY(Math.PI/4.0d);
    rotate.mul(tempRotate);
         TransformGroup objRotate = new TransformGroup(rotate);
         objRoot.addChild(objRotate);
         Appearance ap = new Appearance();
         Appearance app = new Appearance();
         Appearance apr = new Appearance();
         ColoringAttributes colr = new ColoringAttributes();
         ColoringAttributes colg = new ColoringAttributes();
         colr.setColor((float)1, (float)0, (float)0);
         ap.setColoringAttributes(colr);
    colg.setColor((float)0,(float)1, 0);
         apr.setColoringAttributes(colg);
         Box box = new Box((float)0.4, (float)0.4, (float)0.4, app);
         box.getShape(4).setAppearance(ap);
         objRotate.addChild(box);
         objRotate.getChild(0).getShape(4).setAppearance(ap);
    objRoot.compile();
         return objRoot;
    }

    It would help if you gave us the following System information:
    Operating System/version
    Photoshop version number
    Amount of RAM installed
    Hard drive(s) capacity
    Make and model number of video card
    Also try resetting your preferences as described in the FAQ.
    http://forums.adobe.com/thread/375776?tstart=0
    You either have to physically delete (or rename) the preference files or, if using the Alt, Ctrl, and Shift method, be sure that you get a confirmation dialog.
    This resets all settings in Photoshop to factory defaults.
    A complete uninstall/re-install will not affect the preferences and a corrupt file there may be causing the problem.

  • Problem accessing exception object in jsp error page - Apache Tomcat 5.0.25

    Hi all,
    I'm thoroughly confused and need some help. I've deployed a very simple web application in Apache Tomcat 5.0.25 to test exception handling - errortest.jsp and error.jsp. errortest.jsp throws a divide by zero exception if executed with default values in text fields.
    When I put the directive IsErrorPage="true" in error.jsp i get a HTTP 500 error when error.jsp is accessed. If I remove it error.jsp is displayed but I cant access the exception object - if I try to I get an exception below:
    org.apache.jasper.JasperException: Unable to compile class for JSP
    An error occurred at line: 5 in the jsp file: /error.jsp
    Generated servlet error:
    [javac] Compiling 1 source file
    E:\Apache Software Foundation\Tomcat 5.0\work\Catalina\localhost\mywebapp\org\apache\jsp\error_jsp.java:46: cannot resolve symbol
    symbol : variable exception
    location: class org.apache.jsp.error_jsp
    out.print(exception.getMessage());
    ^
    1 error
    Below is the code for the two jsp pages:
    errortest.jsp:
    <%@ page errorPage="error.jsp" %>
    <html>
    <head><title>Error test</title></head>
    <body>     
         <form action="errortest.jsp" method="post">
         Enter first number:<input type="text" name="first" value="5"/><br>
         Enter second number:<input type="text" name="second" value="0"/><br>
         <input type="submit"/>
         </form>
         <%
         if (request.getMethod().equals("POST")) {
              int first = Integer.parseInt( request.getParameter( "first" ) );
              int second = Integer.parseInt( request.getParameter( "second" ) );
              int answer = first/second;
         %>
    </body>
    </html>
    NB: I am able to catch and display the exception if I use a try/catch block around the division as shown below.
    try {
    int answer = first/second;
    } catch( Exception e) {
    e.printStackTrace( new PrintWriter(out) );
    error.jsp (first draft)
    NB: HTTP 500 error occurs when directive "isErrorPage" is added:
    <%@ page isErrorPage="true" %>
    <html>
    <head><title>Error Page</title></head>
    <body>
    </body>
    </html>
    error.jsp (second draft)
    NB: directive is removed but exception thrown when implicit exception object is accessed. error.jsp displays if exception object is not accessed:
    <%@ page %>
    <html>
    <head><title>Error Page</title></head>
    <body>
    <%=exception.getMessage()%>
    </body>
    </html>
    Web server specs:
    Apache Tomcat 5.0.25
    Machine specs:
    Windows XP Pro
    Java environments:
    j2sdk1.4.2_03
    J2EE 1.4

    This works for me:
    throwError.jsp
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
         "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <%@ page language="java" errorPage="/error.jsp"
    contentType="text/html; charset=utf-8" %>
    <html>
    <head>
         <title>Throw Exception</title>
    </head>
    <body>
    Throwing exception....
    <%
    // throw ArithmeticException
    int badInt = 12/0;
    %>
    </body>
    </html>
    error.jsp
    <%@ page language="java" isErrorPage="true" %>
    <head><title>Doh!</title></head>
    An Error has occurred in this application.
    <% if (exception != null) { %>
    <pre><% exception.printStackTrace(new java.io.PrintWriter(out)); %></pre>
    <% } else { %>
    Please check your log files for further information.
    <% } %>

  • Problem accessing Document object UDF

    Hey All,
    I am trying to build a custom application for a company that us using SBO patch level 21. Unfortunately they cannot upgrade to a newer patch level at this time.
    I use the following code to check the existence of a  UDF field:
    if(myDocument.Lines.UserFields.Fields.Item(udfField) != null)
    {                                   myDocument.Lines.UserFields.Fields.Item(udfField).Value = udfVal;
    For some reason the DI API throws an exception to say it cannot find the UDF. Even though it exists in the database. I have tried a number of UDFs all of which exist and they all throw the exception.
    Any ideas?

    Lita,
    I wasn't lucky as you!
    I even tried to access to the user field by index but I always get a COM exception: FFFFFBAF
    Here's the code still not working properly:
    SAPbobsCOM.Documents d = (SAPbobsCOM.Documents) B1Company.GetBusinessObject(SAPbobsCOM.BoObjectTypes.oPurchaseOrders); // Same problem on other documents...
                        SAPbobsCOM.Document_Lines dl = d.Lines;
                        dl.SetCurrentLine(0);
                        try
                            int n = d.UserFields.Fields.Count;
                            string fld = dl.UserFields.Fields.Item(0).Description;
                            //int j = dl.UserFields.Fields.Count;
                        catch (System.Exception e)
                            B1App.MessageBox(e.Message, 0, "OK", "", "");
    This problem is a nightmare because we have severals customer add-ons based on document lines user fields!!!

  • Problem accessing a objects in a public class

    Hello I am have written a program where I am using 2 classes. I have created a JFrame class in one of my classes and I have created a JFormattedtextfield in my other class. How do I place the JFormattedtextfields on the the JFrame which I have created in another class?

    This is what I sort of what I mean. Since I am new to java I don't know how to mount the panels onto f here. Also the reason why I did'nt post it on the swing forum is that I got the swing part of the code figured out I just need help with the general programming bit.
    public class test {
        public static void main(String[] args) {
       public test() {
              JFrame f = new JFrame("Test Program");  // f is created here
              f.setSize(400,400);
              f.setVisible(true);         
    class Layout {
              //Fields for data entry
               JFormattedTextField test = new JFormattedTextField ();
               //Panels
               JPanel secondaryPanel = new JPanel();
               public Layout(){
               test.setForeground(Color.black);     
               f.add(secondaryPanel); // How do I mount this panel onto f here           
      }

  • Problem with instantiating

    I'm having a bit of a problem understanding instantiating objects. The way I understand it, an object needs to be declared, instantiated and initialised befoore it can be used.
    For example, I have a class Point.
    So I can have a statement like :
    Point P1 = new Point(0,0);
    The way I understand it, Point P1+ is the declaration, new+ is the instantiation and Point(0,0)+ is the initialisation.
    If my understanding is correct, there are two cases that confuse me.
    Case 1:_
    I already have a previously declared, instantiated and initialised object PArg of class Point.
    then I can state:
    Point p0 = PArg;
    Now in this case I dont use the new +keyword. I can see where I decare the Object p0 and where I initialise it, but I don't see any instantiation. But the program still works. I don't understand how.
    Case 2:+
    Point PIn[] = new Point[5];
    In this case I am declaring the array of objects and instantiating then with the new +keyword. But I still cannot initialse any elements of my array without intantiating them again. I need to have something like:
    PIn[i] = new Point(x,y);
    where it is instantiated again with the new +keyword and initialised. I on't understand why it is required or even possible to instantiate the objects in the array twice.
    I hope my questions are appropriate for this forum. I would greatly appreciate any answers or links to answers.
    Thanks.
    Edited by: JulianPatel on Aug 29, 2008 1:13 PM

    I have a follow-up question to the ones that have been answered here.
    In your example, you assign the value of variable PArg (i.e. the value of the reference) to p0. After the assignment, p0 has the same value as PArg, meaning it refers to the same object as PArg (or both are null).
    So if I'm understanding correctly, both p0 and PArg now point to the same physical object, that is to say the same memory location correct? Does that mean if I now change the value of some element in p0, it will also be changed in PArg? What about the other way around?
    Eg In my class Point, store two integer values x and y. So suppose I decalre and initialise:
    Point PArg = new Point(3,4);This will set PArg.x = 3 and PArg.y =4
    Now if I have:
    Point p0 = PArg;and then I change the value of p0.x and p0.y using :
    p0.reset(1,2);This will change p0.x from 3 to 1. But will PArg.x also change from 3 to 1?
    Similarly if it set :
    PArg.reset(1,2);will this change the values of p0.x and p0.y?
    The relevant potions of code for my class is:
    class Point
    int x,y;
    Point(int xIn, int yIn)
    x = xIn;
    y = yIn;
    void reset(int xIn, int yIn)
    x = xIn;
    y = yIn;
    }And what if the object is created from a method ? Suppose I have a class Geometry containing methods like:
    static double sqr(double d)
    //Returns the square of the argument
    return(d*d);
    static double distance(Point p1, Point p2)
    //Returns the distance between two Points and/or Floating Points
    double d,x1,x2,y1,y2;
    x1 = p1.x; x2 = p2.x;
    y1 = p1.y; y2 = p2.y;
    d = sqrt(sqr(x1-x2) + sqr(y1-y2));
    return (d);
    static Point integerAltitudeFoot(Point p0,Point pLine1,Point pLine2)
    //Returns the Point of intersection of a perpendicular from p0 onto the line passing through pLine1 and pLine2
    double d01,d02,d12,d1,d2;
    int midX,midY;
    d01 = distance(p0,pLine1);
    d02 = distance(p0,pLine2);
    d12 = distance(pLine2,pLine1);
    d1 = (sqr(d12) + sqr(d01) - sqr(d02))/(2*d12);
    d2 = (sqr(d12) + sqr(d02) - sqr(d01))/(2*d12);
    midX = (int)((pLine1.x*d2 + pLine2.x*d1)/d12);
    midY = (int)((pLine1.y*d2 + pLine2.y*d1)/d12);
    Point footPrint = new Point(midX,midY);
    return(footPrint);
    }and then I have:
    Point p = Geometry.altitudeFoot(p0,pLine1,pLine2);In this case the object is created by the line:
    Point footPrint = new Point(midX,midY);within the altitude function, and then its reference is passed outside through the line:
    return(footPrint);and passed onto p by
    Point p = Geometry.altitudeFoot(p0,pLine1,pLine2);correct?
    But wouldn't the life cycle of Point footPrint be terminated as soon as the method execution is complete? But Point p persists beyond the life cycle of footPrint.
    I hope I have expressed my questions properly. As always, thanks in advance for the answers.
    Edited by: JulianPatel on Aug 31, 2008 6:10 PM

  • Add ABAP program: validating package - error accessing shared objects-area

    When adding a new program or browsing the packages in eclipse i get an "error accessing shared objects-area".
    I can edit, save and run existing ABAP reports, however.
    There was a similar problem here, regarding database procedure proxies but the solution doesn't apply to my problem, i guess. The solution was about creating the shared memory area CL_RIS_SHM_AREA. I can't access the memory area and start the constructor, as it doesn't show up on the monitor.
    ADT 2.28
    Eclipse 4.3
    Netweaver 7.31 SP4 -> is this really compatible with ADT 2.28?
    Thanks in advance for helpful hints,
    Julian

    HI Julian,
    if the area doesn't show up in the monitor, please try to start the constructor in transaction SHMM on your own by selecting the icon 'Start Constructor' as shown in the screenshot.
    Choose CL_RIS_SHM_AREA as area, select 'Default Instance' and 'Dialog' as execution mode. Then press 'Create'. Either this works or the system will tell you the issue with the instance creation (e.g. insufficient shared objects memory - see the other solution description).
    Best regards, Sebastian

  • Problem With Business Object and printing job

    Hello,
    We are encountering a problem with the application "Business Objects FINANCE", and we would need your help quickly.
    In the application , itu2019s impossible to print Consolidated Subsidiaries nor the Securities Held. If we try so, the application freezes and we can't do anything but killing the application via the task manager.
    Though, other states can be printed without problem.
    We tried on several different PCs, and the problem occured equally on each one.
    The version installed is 10.5, and we can do any tests that you think would be useful to diagnose problem.
    Our society is AUBAY SA, and our credential to enter in your support website are : S0005386617
    In attachment youu2019ll find a screenshot of the event viewer from the server where the application is install.
    Thanks in advance for your answer,
    best regards.

    check the export parameters of the event triggering workflow.
    If there is a problem, try instantiating the object in your wf based on the key.
    Also check if the wf is able to import the data.
    regards,
    Sandeep Josyula

  • Exchange setup error: "There was a problem accessing the registry on this computer"

     Hi,
    i am trying to install Exchange 2007 SP1 in a Windows 2003 Server standard 32 bits version.
    During the "Readiness checks" i received the next error in "Hub transport role prerequisites":
    Error:
    There was a problem accessing the registry on this computer. This may happen if the Remote Registry service is not running; it may also indicate a network problem.
    Remote Registry service is running. I've searched for the error in google and in some topics appears that the error is due to the "Client for Microsoft Networks" and "File and Printer Sharing" is not installed in the LAN properties. The server has 2 network cards and in both of them is checked. One of the connections is disabled.
    I dont know what more to do, any help will be appreciated.
    Thanks

    No, firewall is disabled.
    Setup Logs says:
    10:50:04.890: Starting Collecting Data phase.
    10:50:04.921: No mapping between account names and security IDs was done
    10:50:04.984: Error (Unexpected error [0x674CBB7E] while executing command '[Microsoft.Win32.RegistryKey]:penRemoteBaseKey([Microsoft.Win32.RegistryHive]::LocalMachine, [System.Net.Dns]::GetHostEntry([System.Net.Dns]::GetHostName()).HostName)'.) trying to process object [Microsoft.Win32.RegistryKey]:penRemoteBaseKey([Microsoft.Win32.RegistryHive]::LocalMachine, [System.Net.Dns]::GetHostEntry([System.Net.Dns]::GetHostName()).HostName), skipping object.
    10:50:06.093: Completed Collecting Data phase.
    10:50:06.125: Error (Rule name 'PreReq_fPassiveUninstallNoCMSPresentKey' referenced by rule 'PreReq_fPassiveUninstallNoCMSPresent' in input file is not defined) in format of rules in configuration file.
    10:50:06.171: Starting Postprocessing Rules phase.
    10:50:06.187: Completed Postprocessing Rules phase.
    Thanks for your help!

  • Unable to access the objects with out schema as prefix.. can any body help

    Hi,
    i am using 10g.I have one problem like i unable to get the table access with out mention prefix for that table.
    but i created public synonym and gave all grants to all users also. but still i need to mention schema name as prefix otherwise it give the error..
    can any body tell me reason and give me solution.
    ex: owner:eiis table:eiis_wipstock
    connect to: egps schema
    in this position if i try with eiis.wipstock it gives error but if i mention like eiis.wiis_wipstock then its working fine.

    Pl do not spam the forums with duplicate posts - Unable to access the objects with out schema as prefix.. can any body help

  • Problem accessing another public ip in same subnet

    Hi,
    I have searched around for a previous post regarding this but can't find an issue similar to mine (or I'm just too stupid to understand that it is )
    I have a Cisco 5505 at a small business that I help. The problem is that the ISP are providing public IPs to multiple customers in a /24 subnet. The ASA has a single public IP configured 8.8.8.8 (not really, just for the examples sake) with a subnet mask of 255.255.255.0.
    The webserver I have to access is not managed by me and is located in a different location (same town though) has 8.8.8.115, it is located in the same subnet as the ASA.
    How would I make this work? I have tried to configure a static arp entry for the web server but it just won't work. If i place a computer directly on the outside interface I have no problem accessing the web server.
    I am running ASA version 8.2, but I could upgrade if it would help me solve the problem.
    Any help with this issue is much appreciated.

    The ISP only specify one gateway in that range and that is 8.8.8.1 so any other would not let me access internet.
    Once again thank you for your time.
    : Saved
    ASA Version 8.2(1)
    hostname ciscoasa
    domain-name XXXXXXX
    enable password XXXXXXX encrypted
    passwd XXXXXXX encrypted
    names
    name 8.8.8.8 Outside_IP
    name 192.168.20.2 Server
    name 192.168.20.11 rav-dc01
    name 192.168.20.12 rav-ms01
    name 192.168.20.13 rav-rds01
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.20.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address Outside_IP 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa821-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name XXXXXXX
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list inside_nat0_outbound extended permit ip any 192.168.25.0 255.255.255.0
    access-list RemoteVPNSplittunnel standard permit 192.168.20.0 255.255.255.0
    access-list outside_access_in extended permit tcp host 100.100.100.228 interface outside eq 3389
    access-list outside_access_in extended permit tcp any interface outside eq smtp
    access-list outside_access_in extended permit udp any interface outside eq 4125
    access-list outside_access_in extended permit tcp any interface outside eq 4125
    access-list outside_access_in extended permit tcp any interface outside eq https
    access-list outside_access_in extended permit tcp any interface outside eq pptp
    access-list outside_access_in extended permit tcp any interface outside eq 444
    access-list outside_access_in extended permit gre any interface outside
    access-list outside_access_in extended permit udp any interface outside eq 444
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list inside_access_in extended permit tcp host rav-ms01 any eq smtp
    access-list inside_access_in extended deny tcp any any eq smtp
    access-list inside_access_in extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool RemoteVPNPool 192.168.25.100-192.168.25.200 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) udp interface 4125 Server 4125 netmask 255.255.255.255
    static (inside,outside) tcp interface 4125 Server 4125 netmask 255.255.255.255
    static (inside,outside) tcp interface https rav-ms01 https netmask 255.255.255.255  dns
    static (inside,outside) tcp interface pptp Server pptp netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 rav-rds01 3389 netmask 255.255.255.255  dns
    static (inside,outside) tcp interface smtp rav-ms01 smtp netmask 255.255.255.255
    static (inside,outside) udp interface 444 Server 444 netmask 255.255.255.255
    static (inside,outside) tcp interface 444 Server 444 netmask 255.255.255.255
    static (inside,outside) tcp interface www Server www netmask 255.255.255.255  dns
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 8.8.8.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server rav_Intern protocol radius
    aaa-server rav_Intern (inside) host rav-dc01
    key CiscoAsa5505RAV2012
    radius-common-pw CiscoAsa5505RAV2012
    http server enable 8080
    http 192.168.20.0 255.255.255.0 inside
    http 192.168.25.0 255.255.255.0 inside
    http 100.100.101.128 255.255.255.192 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt connection timewait
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map outside_dyn_map 20 set pfs
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.20.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.20.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    dhcpd address 192.168.20.190-192.168.20.200 inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server rav-dc01 source inside
    webvpn
    group-policy RemoteVPN internal
    group-policy RemoteVPN attributes
    wins-server value 192.168.20.11
    dns-server value 192.168.20.11
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value RemoteVPNSplittunnel
    default-domain value rav.nu
    split-dns value rav.nu
    username SupportVPN password XXXXXXX encrypted privilege 0
    username SupportVPN attributes
    vpn-group-policy RemoteVPN
    tunnel-group RemoteVPN type remote-access
    tunnel-group RemoteVPN general-attributes
    address-pool RemoteVPNPool
    authentication-server-group rav_Intern
    accounting-server-group rav_Intern
    default-group-policy RemoteVPN
    tunnel-group RemoteVPN ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect pptp
      inspect icmp
      inspect icmp error
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:8481ab3aa01b23bad17bacb2aca7197a
    : end
    asdm image disk0:/asdm-621.bin
    no asdm history enable

  • Memory leak problem while passing Object to stored procedure from C++ code

    Hi,
    I am facing memory leak problem while passing object to oracle stored procedure from C++ code.Here I am writing brief description of the code :
    1) created objects in oracle with the help of "create or replace type as objects"
    2) generated C++ classes corresponding to oracle objects with the help of OTT utility.
    3) Instantiating classes in C++ code and assigning values.
    4) calling oracle stored procedure and setting object in statement with the help of setObject function.
    5) deleted objects.
    this is all I am doing ,and getting memory leak , if you need the sample code then please write your e-mail id , so that I can attach files in reply.
    TIA
    Jagendra

    just to correct my previous reply , adding delete statement
    Hi,
    I am using oracle 10.2.0.1 and compiling the code with Sun Studio 11, following is the brief dicription of my code :
    1) create oracle object :
    create or replace type TEST_OBJECT as object
    ( field1 number(10),
    field2 number(10),
    field3 number(10) )
    2) create table :
    create table TEST_TABLE (
    f1 number(10),f2 number (10),f3 number (10))
    3) create procedure :
    CREATE OR REPLACE PROCEDURE testProc
    data IN test_object)
    IS
    BEGIN
    insert into TEST_TABLE( f1,f2,f3) values ( data.field1,data.field2,data.field3);
    commit;
    end;
    4) generate C++ classes along with map file for database object TEST_OBJECT by using Oracle OTT Utility
    5) C++ code :
    // include OTT generate files here and other required header files
    int main()
    int x = 0;
    int y = 0;
    int z =0;
    Environment *env = Environment::createEnvironment(Environment::DEFAULT);
    Connection* const pConn =
    env->createConnection"stmprf","stmprf","spwtrgt3nms");
    const string sqlStmt("BEGIN testProc(:1) END;");
    Statement * pStmt = pConn->createStatement(sqlStmt);
    while(1)
    TEST_OBJECT* pObj = new TEST_OBJECT();
    pObj->field1 = x++;
    pObj->field2 = y++;
    pObj->field3 = z++;
    pStmt->setObject(1,pObj);
    pStmt->executeUpdate();
    pConn->commit();
    delete pObj;
    }

  • Problem accessing variables from java file to JSP page

    Hello Everyone,
    I have small problem accessing my method variables from my java bean file to a JSP page. can some please take a look and tell me why I can't populate my JSP page, I've been trying all day to get this done!!!
    This is my Java file
    package dev;
    import java.io.*;
    import java.util.*;
    public class RoundDetail2
    public String string_gameID;
    public int string_card1;
    public String readDetail_topLayer;
    public static final String SUITS[] = {" ", "Clubs", "Hearts", "Spades", "Diamonds", "Joker", "FaceDown"};
    public static final String VALUES[] = {"Joker ","Ace", "Two", "Three", "Four", "Five", "Six", "Seven", "Eight", "Nine", "Ten", "Jack", "Queen", "King"};
    public static final String SuitVALUES[] = {" ","1","2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14"};
    public RoundDetail2() throws FileNotFoundException
    DataInputStream inFile=
                 new DataInputStream(
                    new BufferedInputStream(
                   new FileInputStream("C:/apps/jakarta-tomcat-4.0.6/webapps/ROOT/WEB-INF/classes/dev/Data_452SY2.txt")));
    try { 
                 while((readDetail_topLayer = inFile.readLine()) != null)
              StringTokenizer tokenizer_topLayer = new StringTokenizer(readDetail_topLayer,"\t", true);
                   while  (tokenizer_topLayer.hasMoreTokens())
                        string_gameID = tokenizer_topLayer.nextToken();
         catch(IOException e)
                    System.out.println(e.getMessage());
         Thanks KT

    ......How are you declaring the class in your JSP? ... are you instantiating it as a bean using the useBean tag, or just instantiating it in your code like normal.
    Maybe you could post the relevant JSP code too?
    Hello again,
    Only the last string is populating after the file has be tokenized. What I'll like to accomplish is passing the very first string in the file. I did not get too far in the JSP file setup because the code is still in it's testing stage, but any help will be highly appreciated.
    Here is the JSP code
    <%@page import="dev.*" %>
    <%@page session="true" language="java" import="java.io.*" %>
    <jsp:useBean id="wagerhist" scope="request" class="dev.RoundDetail2" />
    <html>
    <head>
    <title>Round Detail</title>
    <body>
      <table width="530" bordercolor="#000000" valign="top">
        <tr>
              <td align="left"  width="19%">Game ID<%=wagerhist.string_gameID%></td>
              <td align="left"  width="30%">  </td>
              <td align="left"  width="20%">card1</td>
              <td align="left"  width="31%">  </td>
            </tr>
      </table>
    </body>
    </html>

  • Access to object list of type "BusinessSystem" using the InternalEOAService BusinessSystemAccessor failed

    Hi All,
    We are facing an issue in PI configuration when, we are unable to view business systems in the Integration Builder.
    ERROR : Access to object list of type "BusinessSystem" using the InternalEOAService BusinessSystemAccessor failed
    Our Landscape is as follows:
    PI : Based on NW7.4
    Connected to Central SLD on Solman 7.1
    OS : Windows 2008
    DB : MSSQL 2008
    We checked OSS note 1117249 - Incomplete Registration of PI components in SLD
    The problem seems to be with incomplete registration of PI components on the central SLD.
    In the Central SLD which we have configured, under the Process Integration tab we are unable to see entries for Integration Server, Adapter Engine, Directory, Repository and Runtime Workbench (RWB).
    Can you please help me with registering these components on the Central SLD so that these are visible during the PI configuration.
    Also, any idea if this issue is related to the different versions of PI and Central SLD system.
    Regards,
    Nilesh

    Hi Nilesh,
    Please check SAP Note 764176 - Manual correction of XI content in SLD.
    also check the below discussion
    Problem to register Intergration Server in SLD
    regards,
    Harish

Maybe you are looking for