Problem Expanding certain paths in a JTree

I am working with a JTree and trying to do the following:
My JTree is initially defined using the following code:
rootNode = new DefaultMutableTreeNode();
DefaultTreeModel treeModel = new DefaultTreeModel(rootNode);
tree = new JTree(treeModel);
//treeListener = new TreeSelectionListener();
tree.addTreeSelectionListener(treeListener);
DefaultTreeCellRenderer renderer = new DefaultTreeCellRenderer();
renderer.setLeafIcon(null);
tree.setCellRenderer(renderer);
tree.getSelectionModel().setSelectionMode(TreeSelectionModel.SINGLE_TREE_SELECTION);
tree.setShowsRootHandles(true);
tree.setAutoscrolls(true);
tree.setExpandsSelectedPaths(true);
When a user selects a node, and presses some button, I get and save the current path (of the selected component) like this:
TreePath currentPath = tree.getSelectionPath();
Then I do some action on it, then repopulate the JTree
I have the following code at the bottom of the JTree populating method in an effort to expand the path in the tree which was last selected:
tree.expandPath(currentPath);
tree.setVisible(true);
tree.updateUI();
The problem is that when the tree repopulates, it stays completely collapsed, and I can't seem to figure out how automatically make it viewable in an expanded state (I don't want the user to have to go expand each expandable node by clicking beside it)
Does anyone know how to either expand the whole tree from the very beginning, or expand just the selected path?
Thanks in advance for your help,
Noha

To expand on path there is jtree.expandPath(treepath);
To expand the whole tree, I wrote a recursive method.

Similar Messages

  • Problem with file path in linux

    hi,
    i have problem with file path accessing in linux. my java class is accessing a abc.cvs file and and getting all data. it is working fine in windows xp. but i run this same file in linux it does not access the abc.cvs file and does not get any data.
    my project structure
    Search
    abc.cvs
    search.SearchMain
    i am sccessing this cvs file in this SearchMain class by this way file name = "abc.cvs"
    It is working fine with window but problem with linux.
    when i place this abc.cvs in a folder as "./data/abc.cvs" also working fine with windows but not in linux.
    I am new for linux.
    Please give me solution.
    Thanks in advance
    Ravi

    forgot to tell,
    then you need to export that path
    export $CLASSPATH
    code}                                                                                                                                                                               

  • Problems with certain websites

    I have BB  8830 worldphone.  I am having problems accessing certain websites.   Have Verizon wireless as carrier.  Using opera mini i cant log into a lot of credit card accounts or the verizon log on screens.  What settings should I be using on my phone?   Please help.

    How to determine which emulation mode to be used and when?
    tanzim                                                                                  
    If your query is resolved then please click on “Accept as Solution”
    Click on the LIKE on the bottom right if the post deserves credit

  • Problem deploying certain mappings using OMBPlus

    We've got a problem deploying certain mapings using OMBPLus. This applies to all mappings that use a function to lookup the effective date of a SCD (type 2) from a lookup table. We use that function in the dimension operator properties as the "Default Effective Time of Open Record". Though the validation of those mappings fails they can nevertheless be deployed using the Control Center Manager. And, best of all, they work fine.
    Now we have to deploy those mappings using OMBPlus because we're not allowed to work with tools on the preproduction and production systems. Deploying those mappings with OMBPlus doesn't seem to work. It works fine for all other mappings but not for those mentioned above. Has anybody a solution?
    Regards,
    Jörg

    Hi Dave,
    this is the error message I get whe I run my OMBPLus script:
    OMB05602: An unknown Deployment error has occured for Object Type PUB03205 : Validation Error: MAP_DIM_FAHRZEUGKLASSE : VLD-5010: The Default Effective Date of open records for dimension DIM_FAHRZEUGKLASSE should be an expression of type DATE. Value "FCT_GET_AKT_LL_vmon()" is not a valid date: PLS-00201: identifier 'FCT_GET_AKT_LL_VMON' must be declared
    I'm not quite sure about what you mean with creating a stub function. As you can see from the error message above I use a function called FCT_GET_AKT_LL_vmon that returns the actual date od the load from a lookup table. This function is of course present in the target schema.
    Regards,
    Jörg

  • I am having problems saving certain images

    I am having problems saving certain images. For example, on Ebay while viewing an auction item, when you click on the image to view the larger picture it opens in a new window. With Internet Explorer, you can "right-click" and "save picture as". With Firefox 3.6.9 the "save picture as" option is not availabale. Other options such as save "save page as" are available, but not "save as," or "save picture as." Any ideas? Thanks

    I have found a solution to the problem. Apparently there is an addon to fix this. Had no idea a specific google search for "trouble saving images on ebay" would turn up anything.
    https://addons.mozilla.org/en-US/firefox/addon/13802/

  • I am having problems with certain websites that require adobe flash player because of the restrictions that apple has put in place. Is there a way to get to sites that require flash player?

    I am having problems with certain websits that require adobe flash player

    Please don't start the 1 millionth thread on this subject, which has been answered over and over and over and over and over and over and over.........Use the search bar and type flash and you'll see thousands of posts on this.

  • Problem parsing the path data

    I am trying to open a PSD doc in Photoshop CS3 and I am getting an error: problem parsing the path data. Is there any way around this?

    Is the icon really an alias? Aliases have a hard-to-see arrow in the lower left corner. If you click once on the icon and do a Get Info, you'll be told if it's an alias, and if so, where the original is, or once was if the original is gone.
    Following Ramon and Buko's advice, I got rid of Norton products and several minor irritations at the same time.
    --Gene

  • Having problems loading certain sites

    hi i am having problems with certain web pages. i can load up any web page but have problems when clicking on something with in the page that opens a new window. the window is displayed but loads up no images or text and says done in the bottom left hand corner. this means i can not use online banking or any of my other accounts online. any help would be greatly appreciated. as i cant think of what is coursing the problem. i have avg protection on my laptop and windows firewall.

    "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
    "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"
    Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).
    See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]]
    If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.
    You can use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions.
    You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

  • Problem parsing the path data - error on jpgs

    Photoshop CS2 v9.0.2 Windows XP SP2
    Received the following error message in CS2: "Could not complete your request because of a problem parsing the path data"
    I began getting the message above after adding ITPC data to three .jpg files. The message appears when I try to open the files from either Bridge or Windows Explorer. Other files are not affected. The .psd master file with the same metadata opens ok. I tried clearing the ITPC data, but this had no affect. I also tried moving the file to a different folder and renamed the file with no success. The files open ok in Windows Paint and appear ok in Bridge.
    I created the ITPC data on one file in Photoshop and saved a metadata template. Then, in Bridge 1.0.4.6 I used the "replace metadata" command on the other two files.
    I searched the knowledge base and this forum. I found only one hit in the forum from 2007, but there were no responses.
    Can anyone describe what triggers this message, and how to avoid it or fix it?
    Thanks

    Foward / backward slashes should not cause issues, as they are part of the standard character set on any system for obvious reasons, but I would more assume that this is an issue in how Windows translates the file info to native paths and tries to access those paths for verification. I seem to recall having read something along those lines recently in relation to some security issues, but I'm not really sure. anyway, does "escaping" the characters improve the matter (\\ or \/)?
    Mylenium

  • Problem creating fillable paths

    I'm having a problem making fillable paths in a project. I have an outer ring path and an inner ring path that has a guitar headstock shape cut out of it. I want to fill the ring and guitar headstock shape with a color, and then fill the inside ring and surrounding area around the headstock with another color. I cannot seem to figure it out no matter what I try. I'm attaching images so you can see what I am talking about. I have been trying to figure this out for awhile, and I am quite frustrated at this point. It seems as though there would be a quick and simple way to do this, but I have not been able to find it. I've tried grouping, live paint bucket, and I've tried using multiple options in the pathfinder panel to combine the shapes, but no luck so far. Any help on this matter would be greatly appreciated. Thanks.

    Thanks Jacob.
    I don't think that was the problem, though.
    Ok, so I'm not sure what I did, but I can now fill both parts, but something strange is happening. When I fill the outer ring, it fills everything, Like this:
    So after I got that fill working, I can still see the other path when I hover over it with the mouse:
    So I filled that path with black, but the black fills in the parts where the guitar tuning machines are too. There is no path separating the tuners from the headstock, but it still fills there:
    I am now thoroughly confused.
    Man this is getting crazy. It seems like it would just work as if I were filling any path, but apparently I have mucked this thing up pretty good.

  • I have new Ipad...MacBook Pro with Mountain Lion:  I have problems with certain applicaitons not sync'ing (like email, cal, notes)...need help

    I have problems with certain applicaitons not sync'ing (like email, cal, notes)...need help

    There are a few twists here. This is my opinion of a quick and easy way to do what you want to do.
    Get a 2.5" sata enclosure like this one - this is just a sample:
    http://www.amazon.ca/eForCity-2-5-inch-SATA-Enclosure-Blue/dp/B0083OOV9G/ref=sr_ 1_1?ie=UTF8&qid=1360012807&sr=8-1
    Put the new ssd in the enclosure, connect it to the Mac using the included USB cable. It is now an external drive.
    Format the drive using Disk Utility.
    Download and run Carbon Copy cloner, and clone your drive to the new external.
    Shutdown. Open the MBP and remove the SSD drive from the enclosure and put it in the place of the old drive.
    Boot the MBP. Once you know the new drive is up and running, you can get to the process of installing the old one in the optical bay.
    http://mac.tutsplus.com/tutorials/hardware/how-to-upgrade-your-macbook-pro-to-an -ssd/

  • Expand a path in JTree

    Hi all. Please help, I am trying to programmatically expand JTree with JTree.expandPath(path), but it only works one level downwards from the last physically selected node. Is this a bug, or am I doing something wrong?

    If you are using DefaultMutableTreeNode for your nodes, thenTreePath tp = new TreePath(theNode.getPath());gets you a path from the root to theNode. If you want that to be the selection, thentheTree.setSelectionPath(tp);and if you want it to be expanded and viewable thentheTree.expandPath(tp);If you aren't using DefaultMutableTreeNode, you will have to build the TreeNode[] that contains the nodes from the root down to theNode by some kind of loop; the rest of the code still works.

  • Get a certain node of a JTree

    Hi to all!
    I' m using JTree combined with DefaultMutableTreeNode and DefaultTreeModel.
    My problem is that I have the path of a certain node and I just want to get a certain node of this path in order to edit (or better to update) its "userObject".
    Maybe it's a silly question but I'm new to JTree and I feel a little lost with all these methods provided.
    Thank you in advance.

    For starters: excellent photography, and great lighting knowledge and skills. With great photography and lighting, you really don't need to do major alterations other than some minor improvements. i would say instead of looking for lightroom to make it better, instead improve the quality of your photos. lightroom is a tool, not a result to good photos. 
    with that said, reference these links:
    http://thelightroomlab.com/2009/10/camera-raw-profiles-in-adobe-photoshop-lightroom/
    http://layersmagazine.com/photographic-workflow-from-lightroom-to-photoshop.html
    http://tv.adobe.com/watch/getting-started-with-adobe-photoshop-lightroom-4/lightroom-4-cre ate-stunning-images/
    janelle

  • Expand a TreePath in a JTree

    hi
    i face a really strange problem at the moment.
    from my main tree, i want to copy the selected TreePath to my tree in a dialog.
    so i pass the TreePath to the dialog and call the following method:
    tree.expandPath(path);in the tree-initialization i set setExpandsSelectedPaths to true, so the path should be expanded.
    nothing happens.
    either no effect if i call directly expandPath().
    does anybody have an idea why this happen like this?
    thx & greetz
    swissManu

    Hi,
    if I cought your problem, this method should help you. I use it to expand the tree.
    private void expand(JTree tree, DefaultMutableTreeNode node) {
              if (!node.getAllowsChildren()) {
                   return;
              tree.expandPath(new TreePath(node.getPath()));
              for (int step = 0; step < node.getChildCount(); step++) {
                   expand(tree, (DefaultMutableTreeNode)node.getChildAt(step));
         }you can call the method like this:
    expand(tree, (DefaultMutableTreeNode)tree.getModel().getRoot());, tree is an instance of JTree class :-)
    LP

  • MTU Size Problem Loading Certain Webpages

    Hello Colleagues,
    I'm having a strange problem dealing with MTU sizes and loading certain webpages. I am aware of the default Microsoft MTU of 1500 and also using GRE IPSEC Tunnels recommended at MTU size 1400. I have since manually set some users PC's to MTU of 1400 and most of those users are experiencing no issues. However, there are a few users who still experience website loading issues even though I have manually changed their MTU size to 1400.
    These are domain accounts will the same image loads on their machines, so all have the same permissions, rights, firewall settings, etc. They all use the same LAN, switches, and routers.
    Here are the router configs, router 1 and router 2
    Router 1
    Current configuration : 9006 bytes
    version 15.3
    no service pad
    service timestamps debug datetime msec localtime
    service timestamps log datetime msec localtime
    service password-encryption
    hostname R-US-RS-WVPN1
    boot-start-marker
    boot system flash:c1900-universalk9-mz.SPA.153-1.T1.bin
    boot system flash:c1900-universalk9-mz.SPA.151-3.T1.bin
    boot-end-marker
    logging buffered 64000
    enable secret 5 *removed*
    no aaa new-model
    clock timezone CET 1 0
    clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00
    errdisable recovery cause udld
    errdisable recovery cause bpduguard
    errdisable recovery cause rootguard
    errdisable recovery cause pagp-flap
    errdisable recovery cause dtp-flap
    errdisable recovery cause link-flap
    errdisable recovery interval 303
    ip cef
    ip domain name corp.com
    ip name-server 10.###.8.21
    ip name-server 10.###.8.96
    ip inspect dns-timeout 90
    ip inspect tcp idle-time 60
    ip inspect name fw smtp timeout 120
    ip inspect name fw ftp timeout 120
    ip inspect name fw realaudio
    ip inspect name fw tftp timeout 30
    ip inspect name fw udp timeout 30
    ip inspect name fw tcp timeout 60
    no ipv6 cef
    multilink bundle-name authenticated
    crypto pki trustpoint TP-self-signed-316595902
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-316595902
    revocation-check none
    rsakeypair TP-self-signed-316595902
    crypto pki certificate chain TP-self-signed-316595902
    certificate self-signed 01
      *removed*
            quit
    license udi pid CISCO1921/K9 sn FTX153182M8
    spanning-tree vlan 229 priority 8192
    redundancy
    ip ssh version 2
    crypto isakmp policy 10
    hash md5
    authentication pre-share
    lifetime 3600
    crypto isakmp key *removed* address 70.###.172.142
    crypto isakmp key *removed* address 184.###.###.254
    crypto isakmp keepalive 35 11
    crypto ipsec transform-set FY-WVPN-Tunnel esp-aes esp-md5-hmac
    mode tunnel
    crypto map vpn 10 ipsec-isakmp
    set peer 70.###.172.142
    set peer 184.###.###.254
    set transform-set FY-WVPN-Tunnel
    match address gre-tunnel-list
    interface Loopback0
    ip address 10.###.0.10 255.255.255.255
    interface Tunnel2291
    description Primary-TimewarnerTelecom-Ral-FayWVPN1
    ip address 10.###.99.26 255.255.255.252
    no ip redirects
    cdp enable
    tunnel source 66.###.161.126
    tunnel destination 184.###.###.254
    crypto map vpn
    interface Tunnel2293
    description Primary-TimewarnerTelecom-Ral-FayWVPN2
    ip address 10.###.99.154 255.255.255.252
    no ip redirects
    cdp enable
    tunnel source 66.###.161.126
    tunnel destination 70.###.172.142
    crypto map vpn
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description TW Telecom/DMVPN1
    ip address 66.###.161.126 255.255.255.252
    ip access-group Block-Internet in
    ip access-group Block-Internet out
    duplex auto
    speed auto
    no cdp enable
    crypto map vpn
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/0/0
    switchport access vlan 229
    no ip address
    interface GigabitEthernet0/0/1
    switchport access vlan 229
    no ip address
    interface GigabitEthernet0/0/2
    switchport access vlan 229
    no ip address
    interface GigabitEthernet0/0/3
    description PBX Eth1
    switchport access vlan 229
    no ip address
    interface Vlan1
    no ip address
    shutdown
    interface Vlan229
    ip address 10.###.229.253 255.255.255.0
    ip helper-address 10.###.231.201
    standby 229 ip 10.###.229.254
    standby 229 priority 105
    standby 229 preempt
    router eigrp 100
    network 10.0.0.0
    ip forward-protocol nd
    no ip http server
    ip http secure-server
    ip route 70.###.172.142 255.255.255.255 66.###.161.125
    ip route 184.###.###.254 255.255.255.255 66.###.161.125
    ip route 205.###.96.180 255.255.255.252 66.###.161.125
    ip access-list extended Block-Internet
    permit esp host 66.###.161.126 host 184.###.###.254
    permit esp host 184.###.###.254 host 66.###.161.126
    permit udp host 66.###.161.126 host 184.###.###.254 eq isakmp
    permit udp host 184.###.###.254 host 66.###.161.126 eq isakmp
    permit esp host 66.###.161.126 host 70.###.172.142
    permit esp host 70.###.172.142 host 66.###.161.126
    permit udp host 66.###.161.126 host 70.###.172.142 eq isakmp
    permit udp host 70.###.172.142 host 66.###.161.126 eq isakmp
    permit icmp host 66.###.161.126 host 184.###.###.254
    permit icmp host 184.###.###.254 host 66.###.161.126
    permit icmp host 66.###.161.126 host 70.###.172.142
    permit icmp host 70.###.172.142 host 66.###.161.126
    permit icmp any any echo-reply
    permit icmp any any time-exceeded
    permit icmp any any packet-too-big
    permit icmp any any traceroute
    permit icmp any any unreachable
    deny   ip any any
    deny   icmp any any
    ip access-list extended gre-tunnel-list
    permit gre host 66.###.161.126 host 184.###.###.254
    permit gre host 66.###.161.126 host 70.###.172.142
    logging host 10.100.###.254
    logging host 10.100.###.246
    snmp-server community a RW 20
    snmp-server community r RO 20
    snmp-server community a RW 20
    snmp-server community r RO 20
    snmp-server community P_RW RW
    snmp-server community P_RO RO
    snmp-server enable traps entity-sensor threshold
    snmp-server host 10.100.###.246 public
    snmp-server host 10.100.###.254 public
    access-list 20 permit 10.###.9.3
    access-list 20 permit 10.###.8.16
    access-list 20 permit 10.100.###.249
    access-list 20 permit 10.100.###.254
    access-list 20 permit 10.100.###.246
    control-plane
    banner motd ^CCCCCCC
    ****************** Warning! Warning! Warning! ********************
    This system is restricted to authorized users for business
    purposes.  Unauthorized access is a violation of the law.  This
    service may be monitored for administrative and security reasons.
    By proceeding, you consent to this monitoring
    ****************** Warning! Warning! Warning! ********************
    ^C
    line con 0
    login local
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    exec-timeout 60 0
    password 7 *removed*
    login local
    transport input ssh
    line vty 5 15
    exec-timeout 60 0
    password 7 *removed*
    login local
    transport input ssh
    scheduler allocate 20000 1000
    ntp server 10.###.8.8 prefer
    ntp server 10.###.231.200 prefer
    ntp server 10.###.8.69
    ntp server 10.###.1.6 prefer
    end
    Router 2
    Current configuration : 9013 bytes
    version 15.3
    no service pad
    service timestamps debug datetime msec localtime
    service timestamps log datetime msec localtime
    service password-encryption
    hostname R-US-RS-WVPN2
    boot-start-marker
    boot system flash:c1900-universalk9-mz.SPA.153-1.T1.bin
    boot system flash:c1900-universalk9-mz.SPA.151-3.T1.bin
    boot-end-marker
    logging buffered 64000
    logging console critical
    enable secret 5 *removed*
    no aaa new-model
    clock timezone CET 1 0
    clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00
    errdisable recovery cause udld
    errdisable recovery cause bpduguard
    errdisable recovery cause rootguard
    errdisable recovery cause pagp-flap
    errdisable recovery cause dtp-flap
    errdisable recovery cause link-flap
    errdisable recovery interval 303
    ip cef
    ip domain name corp.mann-hummel.com
    ip name-server 10.###.8.21
    ip name-server 10.###.8.96
    ip inspect dns-timeout 90
    ip inspect tcp idle-time 60
    ip inspect name fw smtp timeout 120
    ip inspect name fw ftp timeout 120
    ip inspect name fw realaudio
    ip inspect name fw tftp timeout 30
    ip inspect name fw udp timeout 30
    ip inspect name fw tcp timeout 60
    ipv6 multicast rpf use-bgp
    no ipv6 cef
    multilink bundle-name authenticated
    crypto pki trustpoint TP-self-signed-3179596086
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3179596086
    revocation-check none
    rsakeypair TP-self-signed-3179596086
    crypto pki certificate chain TP-self-signed-3179596086
    certificate self-signed 01
      *removed*
            quit
    license udi pid CISCO1921/K9 sn FTX153182M2
    spanning-tree vlan 229 priority 1###84
    redundancy
    ip ssh version 2
    crypto isakmp policy 10
    hash md5
    authentication pre-share
    lifetime 3600
    crypto isakmp key *removed* address 70.###.172.142
    crypto isakmp key *removed* address 184.###.###.254
    crypto isakmp keepalive 35 11
    crypto ipsec transform-set Fay-Ral-WVPN-Tunnel esp-aes esp-md5-hmac
    mode tunnel
    crypto map vpn 10 ipsec-isakmp
    set peer 184.###.###.254
    set peer 70.###.172.142
    set transform-set Fay-Ral-WVPN-Tunnel
    match address gre-tunnel-list
    interface Loopback0
    ip address 10.###.0.12 255.255.255.255
    interface Tunnel2292
    description Failover-TimewarnerCable-Ral-Fay-WVPN2
    ip address 10.###.99.30 255.255.255.252
    no ip redirects
    cdp enable
    tunnel source 96.###.25.226
    tunnel destination 184.###.###.254
    crypto map vpn
    interface Tunnel2294
    description Failover-TimewarnerCable-Ral-Fay-WVPN2
    ip address 10.###.99.158 255.255.255.252
    no ip redirects
    cdp enable
    tunnel source 96.###.25.226
    tunnel destination 70.###.172.142
    crypto map vpn
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description Fay-Ral WVPN
    ip address 96.###.25.226 255.255.255.252
    ip access-group Block-Internet in
    ip access-group Block-Internet out
    duplex auto
    speed auto
    no cdp enable
    crypto map vpn
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    interface GigabitEthernet0/0/0
    switchport access vlan 229
    no ip address
    interface GigabitEthernet0/0/1
    switchport access vlan 229
    no ip address
    interface GigabitEthernet0/0/2
    switchport access vlan 229
    no ip address
    interface GigabitEthernet0/0/3
    description PBX Eth2
    switchport access vlan 229
    no ip address
    interface Vlan1
    no ip address
    shutdown
    interface Vlan229
    ip address 10.###.229.252 255.255.255.0
    ip helper-address 10.###.231.201
    standby 229 ip 10.###.229.254
    standby 229 preempt
    router eigrp 100
    network 10.0.0.0
    ip forward-protocol nd
    no ip http server
    ip http secure-server
    ip route 70.###.172.142 255.255.255.255 96.###.25.225
    ip route 184.###.###.254 255.255.255.255 96.###.25.225
    ip route 205.###.96.180 255.255.255.252 66.###.161.125
    ip access-list extended Block-Internet
    permit esp host 96.###.25.226 host 184.###.###.254
    permit esp host 184.###.###.254 host 96.###.25.226
    permit udp host 96.###.25.226 host 184.###.###.254 eq isakmp
    permit udp host 184.###.###.254 host 96.###.25.226 eq isakmp
    permit esp host 96.###.25.226 host 70.###.172.142
    permit esp host 70.###.172.142 host 96.###.25.226
    permit udp host 96.###.25.226 host 70.###.172.142 eq isakmp
    permit udp host 70.###.172.142 host 96.###.25.226 eq isakmp
    permit icmp host 96.###.25.226 host 184.###.###.254
    permit icmp host 184.###.###.254 host 96.###.25.226
    permit icmp host 96.###.25.226 host 70.###.172.142
    permit icmp host 70.###.172.142 host 96.###.25.226
    permit icmp any any echo-reply
    permit icmp any any time-exceeded
    permit icmp any any packet-too-big
    permit icmp any any traceroute
    permit icmp any any unreachable
    deny   ip any any
    deny   icmp any any
    ip access-list extended gre-tunnel-list
    permit gre host 96.###.25.226 host 184.###.###.254
    permit gre host 96.###.25.226 host 70.###.172.142
    logging host 10.100.###.254
    logging host 10.100.###.246
    snmp-server community P_RW RW
    snmp-server community P_RO RO
    snmp-server community a RW 20
    snmp-server community r RO 20
    snmp-server community a RW 20
    snmp-server community r RO 20
    snmp-server enable traps entity-sensor threshold
    snmp-server host 10.100.###.246 public
    snmp-server host 10.100.###.254 public
    access-list 20 permit 10.###.9.3
    access-list 20 permit 10.###.8.16
    access-list 20 permit 10.100.###.249
    access-list 20 permit 10.100.###.254
    access-list 20 permit 10.100.###.246
    control-plane
    banner motd ^CCCCCC
    ****************** Warning! Warning! Warning! ********************
    This system is restricted to authorized users for business
    purposes.  Unauthorized access is a violation of the law.  This
    service may be monitored for administrative and security reasons.
    By proceeding, you consent to this monitoring
    ****************** Warning! Warning! Warning! ********************
    ^C
    line con 0
    login local
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    exec-timeout 60 0
    password 7 *removed*
    login local
    transport input ssh
    line vty 5 15
    exec-timeout 60 0
    password 7 *removed*
    login local
    transport input ssh
    scheduler allocate 20000 1000
    ntp server 10.###.8.8 prefer
    ntp server 10.###.231.200 prefer
    ntp server 10.###.8.69
    ntp server 10.###.1.6 prefer
    end

    UPDATE
    I have since applied the following config to the tunnel interfaces:
    ip mtu 1400
    ip tcp adjust-mss 1400
    tunnel path-mtu-discovery
    This worked and I was able to reset each users PC to default MTU size of 1500, but only until just now. I got a call from a user who explained that he wasn't able to reach some websites, again.
    Sure enough, I've just confirmed that all of the users are unable to access the websites any longer.
    This is crazy, does anyone have any ideas?

Maybe you are looking for

  • Webservice call from a button

    Hi Everyone, I'm new in web service, I need som assistsance,please. I know I will have to add a new data connection and choose a WSDL file, I think I know that part...Do I have to do this??? 1. How do I call my web service using  code (javascript) an

  • RP-IMP-C2-B2 macro in HR ABAP?

    Hi Experts, I am new to HR ABAP programming.I got a requirement  to modify existing  customized program.In that customized program ,RP-IMP-C2-B2 macro is called ,and this one is returning ZES internal table.This intenal table is used in the program.K

  • Agent cannot recieve call

    Hi, I have an agent configured in UCCX on a remote site. All of the CRS config should be correct and the agent can log on to the agent desktop. When a call is routed to the agent the status goes into reserved, then straight back to Not Ready (or Read

  • Using Eclipse plug-in

    Dear. When using eclipse with javafx 1.2 plugin , there are many errors in the Problems Views in Eclipse IDE. After create the javafx script, there is an error message as below. "cannot access com.sun.javafx.runtime.FXBase class file for com.sun.java

  • TS1717 Unable to launch Itunes

    When I try to launch itunes, I get a blank window with "OK" in but no other message, I can click on the OK, but nothing happens and itunes doesn't launch!  I have tried checking for updates, and I have also shut down and re-started.  To no avail.  La