Problem in taking the control of my application in the test class

Hi,
I am calling an application(Login) from the test class. This test class tests for blank fields entered for the login application.
Once i get the login screen, my program is getting hanged, i mean its not executing the test case unless i press the cancel button in that login screen. Only when i press the cancel button,my test case is executing in the background & is successful.
Can anyone tell me why is this happening & is there a better way to handle this situation.
Thanks & Regards,
Vishal

Well here is the Test class that i have written,
* LoginScreenTest1
* Created on Mar 9, 2007 by vishal
package unittest.com.erp;
import junit.extensions.TestSetup;
import junit.extensions.jfcunit.*;
import junit.extensions.jfcunit.finder.*;
import junit.extensions.jfcunit.eventdata.*;
import junit.framework.Test;
import junit.framework.TestSuite;
import junit.textui.TestRunner;
import com.erp.client.swing.ClientLoginDialog;
import com.erp.client.swing.workspace.ClientWorkspaceFrame;
import com.erp.client.swing.workspace.data.LoginResults;
import javax.swing.*;
import junit.extensions.jfcunit.finder.Finder;
import java.awt.Window;
import java.awt.Robot;
import java.awt.event.ActionEvent;
import java.awt.event.ActionListener;
import java.awt.event.InputEvent;
import java.util.List;
import java.util.ArrayList;
* MISSING_JAVADOC Vishal Class LoginScreenTest1 description.
* @author Vishal
public class LoginScreenTest1
    extends JFCTestCase {
  private  ClientLoginDialog loginScreen ;
  private static JFCTestHelper s_helper = null;
  private LoginResults lr;
  public LoginScreenTest1(String name) {
    super(name);
    s_helper = new JFCTestHelper();
    System.out.println("Calling Login dialog");
    loginScreen = ClientLoginDialog.login(new JFrame(),true);  // Returns the login dialog
    loginScreen.setVisible(true); // Its getting hanged here,only when i press the cancel button my test case gets executed
  public static Test suite() {
    System.out.println("I am in Suite");
    TestSuite suite = new TestSuite(LoginScreenTest1.class);
    return suite;
  public void testUserAndPasswordEmpty() {
    JDialog dialog;
    System.out.println("In Test case ");
    JTextField userNameField = (JTextField)s_helper.findNamedComponent("LoginTextField",loginScreen, 0);
    JTextField passwordField = (JTextField)s_helper.findNamedComponent("PasswordField",loginScreen, 0);
    JButton CancelButton = (JButton)s_helper.findNamedComponent("Cancelbutton",loginScreen, 0);
    userNameField.setText("");
    passwordField.setText("");
    JButton LoginButton = (JButton)s_helper.findNamedComponent("Loginbutton",loginScreen, 0);
    System.out.println("Clicking Login button");
    LoginButton.doClick();
    System.out.println("Login button clicked");
  public static final void main(String[] args)
    junit.textui.TestRunner.run(suite());
     try
        Thread.sleep(1000000);
     catch (Exception e)
}Message was edited by:
vishal_vj

Similar Messages

  • Coded UI : Window '' is blocking the control 2015. Please move the window '' or make the control 2015 visible and retry the action. Additional Details:

    Hi ,
    I'm trying to do a test automation using codedUI. This is a Windows application based on WPF.
    I recorded the events and when playback I get a error.
    There are two datetime pickers in the same form and when doing a playback one is picking up the date correctly where as the other datetimepicker is throwing the error as below.
    Window '' is blocking the control 2015. Please move the window '' or make the control 2015 visible and retry the action. I tried even manually selecting some offset points but still the calendarfield shows empty.
    Thanks,
    Jayashree

    Hi Jayashree,
    Thank you for posting in the MSDN forum.
    >> Window '' is blocking the control 2015. Please move the window '' or make the control 2015 visible and retry the action.
    Please debug it with steps in this blog:
    http://blogs.msdn.com/b/visualstudioalm/archive/2012/03/04/handling-playback-failures-in-coded-ui-test-due-to-stale-ui-controls.aspx
    Please make sure that the target control is well truly visible on the screen, and then troubleshoot action you need to take is to check if the search has actually hit the correct target element. You can make use
    of the
    DrawHighlight method in your test code to validate this.
    Best Regards,
    Jack 
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • HT5858 In the control center I can change the mute or the rotation but not both.  How do I fix this.  In settings I can not uncheck both the mute and rotation lock.

    In the control center I can change the mute or the rotation but not both.  In the settings area therefore I can't uncheck the mute and rotation settings at the same time.

    Check your settings. The iPads have a small switch on the right edge. It can be used as a rotation lock to keep the screen from automatically reorienting itself as you move around, but you need to have the tablet’s settings configured properly. That same switch, right above the volume buttons, can also be set to function instead as a mute button to silence certain types of audio.
    If the switch is set to work as a mute button, you can change its purpose to “screen-rotation lock” by tapping the Settings icon on the home screen. On the Settings screen, tap General on the left side, and on the right side of the screen flick down to “Use Side Switch to.” Tap to select Lock Rotation or Mute to set the button’s function. Even if you set the side switch for your preferred use, you can still mute the Mini or lock the screen. Just double-click the Home button, and when the panel of apps appears along the bottom edge of the screen, flick the row from left to right with your finger. Tap the icon on the far left side of the row to either lock the iPad’s screen or mute the iPad’s alerts, notifications and sound effects. Music, podcasts and video are not muted unless you turn the volume all the way down.
     Cheers, Tom

  • C4780, The Control Panel Display Freezes on the HP Logo when Connecting to a Wireless Network

    this is my second c4780 i have tried to connect wirelessly to my imac, every time i get to the wireless part of the set up process my network is the strongest in the list but it cant seem to connect and when i go to retry it then it tells me the device cannot be found and that i need to connect it via usb when it already is connected and then the Control Panel Display Freezes on the HP Logo, and i cant get it unfrozen. I would really like this printer to work wirelessly so i don't have to go back to the apple store again and return it. Any help is greatly appreciated, thanks

    Worked great!!!!!!!!!!!!!!!!!!!! thank you so much i was about ready to throw it out the window

  • Since upgrade to Windows 8, cannot save .rdp files under the Remote Desktop Connection application on the Desktop

    Since I upgraded to Windows 8, I am no longer able to save individual Remote Desktop Connection files as .rdp files. I am talking about the traditional Remote Desktop Connection application on the Desktop that was in previous Windows versions, not the
    Remote Desktop App from the Windows 8 store.
    When I try to click on the Save button I get "An error occurred while saving to file"
    When I try to click on the Save As button I get "Unable to open connection file" with the file address being where I tried to save it with the file name at the end.
    Also when I upgraded to Windows 8, my .rdp files disappeared from my Documents folder.
     I need to create different .rdp files for different programs that my employees get into on my server. Now I have to hand type all the info each time into the Programs tap on the Remote Desktop Connection window, because I can't save to an
    .rdp file.
     I like the Remote Desktop App from the Windows store but it won't let me designate specific programs to use using standard dos notation (ie c:\program files\ etc..). It just goes to my server desktop.
     I want to promote Windows 8 to my employees but I need either .rdp files for the traditional Remote Desktop Connection or the ability to open specific programs using dos notation in the Windows Store Remote Desktop App.

    I know this is an old post but others might still be having the problem. Here's what I did.
    Create a new text file and open it in notepad. Copy the below into it and edit for your environment. (IP, screen size).
    screen mode id:i:2
    desktopwidth:i:1920
    desktopheight:i:1080
    session bpp:i:24
    auto connect:i:0
    full address:s:192.168.x.x
    compression:i:0
    keyboardhook:i:2
    audiomode:i:2
    redirectdrives:i:1
    redirectprinters:i:1
    redirectcomports:i:1
    redirectsmartcards:i:1
    displayconnectionbar:i:1
    username:s:USERNAME
    domain:s:DOMAIN
    alternate shell:s:
    shell working directory:s:
    disable wallpaper:i:1
    disable full window drag:i:1
    disable menu anims:i:1
    disable themes:i:1
    bitmapcachepersistenable:i:1
    use multimon:i:0
    winposstr:s:0,3,0,0,800,600
    audiocapturemode:i:1
    videoplaybackmode:i:1
    connection type:i:7
    networkautodetect:i:1
    bandwidthautodetect:i:1
    enableworkspacereconnect:i:0
    allow font smoothing:i:0
    allow desktop com:0
    disable cursor setting:i:0
    redirectclipboard:i:1
    redirectposdevices:i:0
    drivestoredirect:s:*
    autoreconnection enabled:i:1
    authentication level:i:2
    prompt for credentials:i:0
    negotiate security layer:i:1
    remoteapplicationmode:i:0
    gatewayhostname:s:
    gatewayusagemethod:i:4
    gatewaycredentialssource:i:4
    gatewayprofileusagemethod:i:0
    promptcredentialonce:i:0
    gatewaybrokeringtype:i:0
    use redirection server name:i:0
    rdgiskdcproxy:i:0
    kdcproxyname:s:
    You don't need to worry too much about what's in here. Save the text file as
    filename.rdp then rightclick on the file and select edit. The familiar GUI rdp session editor will open. You can make changes in the GUI and
    save or save as a different session.
     Hope this helps.

  • HI friends i am facing issue regarding the hosting of an application on the firewall .

    Dear friends i configure public ip on firewall interface ,and i have one more public ip for hosting of the sqp application publicly,so please how can i do this can any one let me know configuration is below.
    THE BELOW ARE THE IP ADD FOR THE SERVER HOSTING ,AND CONFIGURATION OF THE FIREWALL AND ROUTER FOLLLOW BELOW.
    PC IP : 72.93.232.66
    Subnet Mask: 255.255.255.252
    Gate Way ( Router IP ) : 72.93.232.65
    Domain Name : www.hrmstadrees.com
    Server Local IP for Application: http://10.10.10.4/MenaITech/Mename/
    ASA-CONFIG
    ASA Version 8.2(5)
    domain-name RAQ.com
    enable password lpW.MGeEHg0ISQZq encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    description Connected to TAD-Router G0/1
    nameif outside
    security-level 0
    ip address 72.93.19.174 255.255.255.252
    interface Ethernet0/1
    description Connected to Cisco SMB Switch G1
    nameif inside
    security-level 100
    ip address 10.15.1.1 255.255.255.248
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    no ip address
    management-only
    banner login ********  RAQ FIREWALL ********
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 8.8.8.8
    name-server 84.22.224.11
    name-server 84.22.224.12
    domain-name tadrees.com
    access-list split-tunnel standard permit 10.10.0.0 255.255.0.0
    access-list nonat extended permit ip 10.1.1.0 255.255.255.0 10.10.0.0 255.255.0.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.1.1.0 255.255.255.0
    access-list Mename-Access extended permit tcp any host 72.93.19.174 eq www
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm debugging
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool sslvpnpool 10.1.1.1-10.1.1.254 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-702.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nonat
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www 10.10.10.4 www netmask 255.255.255.255
    access-group Mename-Access in interface outside
    router rip
    network 10.0.0.0
    version 2
    route outside 0.0.0.0 0.0.0.0 72.93.19.173 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server TAD-AD protocol nt
    aaa-server TAD-AD (inside) host 10.10.10.1
    aaa authentication ssh console LOCAL
    http server enable 444
    http 192.168.1.0 255.255.255.0 management
    http 0.0.0.0 0.0.0.0 outside
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 2
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 20
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    enable outside
    no anyconnect-essentials
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    svc enable
    tunnel-group-list enable
    internal-password enable
    group-policy sslvpn internal
    group-policy sslvpn attributes
    wins-server none
    dns-server none
    vpn-tunnel-protocol svc webvpn
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value split-tunnel
    default-domain value tadrees.com
    group-policy DfltGrpPolicy attributes
    webvpn
      svc ask enable default webvpn timeout 30
    username admin password s8Vngsgpp8NmOJP7 encrypted privilege 15
    username cisco password HWFflA1bzYiq7Uut encrypted privilege 15
    tunnel-group TAD-SSLV type remote-access
    tunnel-group TAD-SSLV general-attributes
    address-pool sslvpnpool
    authentication-server-group TAD-AD LOCAL
    default-group-policy sslvpn
    tunnel-group TAD-SSLV webvpn-attributes
    group-alias ssl enable
    group-url https://72.93.19.174/ssl enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:c23556bcb54d60cbd598593f6429d106
    : end
    ROUTER CONFIGURATION
    RAQ-Router#sho run
    Building configuration...
    Current configuration : 5623 bytes
    ! Last configuration change at 13:59:42 UTC Sat Sep 21 2013 by cisco
    ! NVRAM config last updated at 13:44:13 UTC Sat Sep 21 2013 by cisco
    ! NVRAM config last updated at 13:44:13 UTC Sat Sep 21 2013 by cisco
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname TAD-Router
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
    no aaa new-model
    no ipv6 cef
    ip source-route
    no ip cef
    ip domain name yourdomain.com
    ip name-server 8.8.8.8
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1513054491
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1513054491
    revocation-check none
    rsakeypair TP-self-signed-1513054491
    crypto pki certificate chain TP-self-signed-1513054491
    certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31353133 30353434 3931301E 170D3132 30393236 31363239
      33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35313330
      35343439 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100AADE 6F39CF31 6832A80B DBCC6E4D 82AA4F8A B71E7118 50B53E0E FD94E7E9
      A6557FD6 30A099C0 D44E36BA 92CBE1EB 1C2789B6 A1260D38 B24637A5 255F18D7
      0B6F2B70 44CF0583 DADB7687 E4102B24 4FA18CDA 36A7CA2A 96F78C1C B92214D8
      087DC6D5 240F7449 DBC4AD01 17FBDC0A 9ECC24DF C7D57E33 9C9CF327 27F2A905
      78470203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14D06F56 4B82A937 E11730CB BDEECF51 BDAE337F 98301D06
      03551D0E 04160414 D06F564B 82A937E1 1730CBBD EECF51BD AE337F98 300D0609
      2A864886 F70D0101 05050003 8181005A 297C5954 817B8D56 1443D1D5 B21DBA42
      F7EC486D B82CBA55 C2953C0E 756FAC1F B04C48C3 D208E4AF DE412F1C C4A97B38
      856AC4F2 A664C6CB 3E241FB6 4AD2DC4B BE5B4809 DE6269CC 0826E822 33F853B3
      3FE1E0E9 AA125902 C632B6E6 BE2EC625 0F7F2259 F408844B 9813429F 422EDBE0
      ADE0EA0D A2138291 D806C4F1 72C4A9
            quit
    license udi pid CISCO2911/K9 sn FCZ1633771T
    username bciscoadmin password 0 tadreesadmin
    username cisco privilege 15 password 0 c1sc0
    ip ssh version 1
    track 1 interface Dialer0 ip routing
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description Connected to Internet Temp
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    ip address 72.93.19.173 255.255.255.252
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    pvc 0/35
      pppoe-client dial-pool-number 1
    pvc 0/99
      pppoe-client dial-pool-number 1
    interface Dialer0
    no ip address
    interface Dialer1
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1492
    ip flow ingress
    ip nat outside
    ip nat enable
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 0 123456
    ppp pap sent-username [email protected] password 0 123456
    no cdp enable
    ip forward-protocol nd
    no ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip route 0.0.0.0 0.0.0.0 Dialer1
    access-list 23 permit 10.10.10.0 0.0.0.7
    no cdp run
    control-plane
    banner login ^CC
    **    TADREES PRIVATE NETWORK ..... AUTHORIZED USERS ONLY    **
    ***************************************************************^C
    banner motd ^CC
                                                      ==================
                                                           WARNING
                                                      ==================
    If you are an unauthorized user LOG OFF NOW, all unauthorized access will be prosecuted to the full extent of the law
    This is a Private Network Device. This resource including all related equipment, networks and network devices, are provided for authorized Private use. Private systems are monitored for all lawful purposes, including ensuring authorized use, for manageme
    The monitoring on this system may include audits by authorized personnel to test or verify the validity, security and survivability of this system. During monitoring information may be examined, recorded, copied and used for authorized purposes. All
    Use of this system, constitutes consent to this policy and the policies and procedures set forth by the company
    Evidence of unauthorized use collected during monitoring will be used for criminal prosecution by  staff, legal counsel and law enforcement agencies.^C
    line con 0
    login local
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    login local
    transport input telnet ssh
    line vty 5 15
    login local
    transport input telnet ssh
    scheduler allocate 20000 1000
    end

    Let me get this correctly, you want to access the server over the public IP?

  • MyMac won't let me update Firefox. The error message says I don't have the authority to do that. I am the administrator of the computer. I check the controls and I am still the administrator. I prevent kids from downloading anything.

    When I drag it per the installation window the popup error says
    "The operation cannot be completed because you do not have sufficient privileges for some of the items."
    I have a macbook pro (unibody) running OX 10.5.8.
    I AM the administrator. It just let me update microsoft office so it looks like the failure to update is targeted at Firefox.
    I ran Avast for Mac (Beta and free) last night and it found 14 infected files mostly connected with Java (so much for the virus fee Mac theory). I deleted them all via the program. Then rebooted and redownloaded the new Firefox. Still got the same error message.
    I'd appreciate any suggestions, help... magic wands LOL

    If there are problems with updating or with the permissions then easiest is to download the full version and trash the currently installed version to do a clean install of the new version.
    Download a new copy of the Firefox program and save the disk image (dmg) file to the desktop
    *Firefox 8.0.x: http://www.mozilla.com/en-US/firefox/all.html
    *Trash the current Firefox application to do a clean (re-)install
    *Install the new version that you have downloaded
    Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data if you uninstall and (re)install Firefox.
    *http://kb.mozillazine.org/Profile_folder_-_Firefox

  • HT1923 I am using Windows 8 and need to uninstall itunes.  When I go to the Control panel I cannot see the itunes program?  Where is it?

    Hello.  I have a corrupted itunes after a recent update on a Windows 8 machine.  I have been instructed to remove the Itunes and reinstall it.  When I go to the Control panel I do not see the itunes installed.  Can someone please tell me where I go to uninstall the itunes on Windows 8.  Thanks

    I am haveing same problem canot find itunes.msi

  • Is it possible to create run and stop button on the control pannel instead fo using the ones on the tool bar?

    I have created a program which runs to all my specifications. The final thing I'd like to do is to be able to run it from the contrl panel.
    Can i create a run and stop button on the control panel or am i limited to using the little white arrow button on the toolbar?

    When you say Control Panel are you referring to the Front Panel of your VI?  If so then yes you can have the program start automatically upon being opened and close with a button push on the Front Panel.  Let me know if this is what you were looking for.
    CLA, CLED, CTD,CPI, LabVIEW Champion
    Platinum Alliance Partner
    Senior Engineer
    Using LV 2013, 2012
    Don't forget Kudos for Good Answers, and Mark a solution if your problem is solved.

  • How to use user id of the logged user (in Application) in the Valueset

    Hi All,
    I want to Create a Table Value Set.
    i want to Filter the values in value set based on the User id by which user has logged in Application.
    How to get user id and how it can be used in Table Value set Query.
    Please guide me...
    Waiting 4 ur response.
    Thanks
    Sheetal

    Hi Sheetal,
    You can call the function fnd_global.user_id to get the current user identifier of the logged in user.
    Regards,
    J.
    SELECT fnd_global.user_id
    FROM   dual

  • How to contact the author of an application on the iPhone AppStore?

    Is there a link on the iPhone AppStore to send questions or suggestions to the developer of an application?
    (If not, why isn't there one? )

    Thank you Varjak!
    So it's as I supposed...
    Unfortunately I don't have iTunes installed on this PC, so that's why I searched on the iTunes webpage...
    And indeed I don't understand why they don't provide the same link on the iTunes webpage. (maybe to "encourage" you to open the iTunes application, or maybe in order not to provide links between the iTunes page and the developer page, links which would be processed by the search engine bots and the page ranking algorithms...)

  • OS X on the SSD, yes - but Applications on the same SSD or HDD?

    Hi,
    I'v just ordered one of the new iMacs custom built with both a HDD and a SSD - for maximum speed in Photoshop and video editing.
    However, I'm not sure whether I should install OS X & all Applications on the very same SSD - and then all documents on the HDD?
    Or - should I install OS X solo on the SSD - and then all Applications and documents on the HDD?
    I'm not an expert, so I'm not quite sure how the digital logic works here....
    Thank you kindly!
    Regards
    Dr. Wishbone

    SSD drives have a limited number of writes. I say store the OS and applications on the SSD for speed.
    I think the easiest way to accomplish this is to install everything onto the SSD first. Then, adjust your /etc/fstab file to have /Users be on the hard disk. Do the same for /private/tmp and /private/var.

  • Authorize the computer to transfer applications to the iPhone by iTunes

    Please help me to authorize the computer where that after doing software for the computer did not do cancel the authorization and I now have only two computers authorized one MacBook Pro and the other Dell desktop and when I do authorize any other device message appears to achieving the maximum devices authorized, although I did not authorized only two devices only I hope help me .
    Thank you
    Note: Excuse me I'm not good in English, this translation Google

    Delete and redownload the remaining songs if doing so is free in your country.
    (90752)

  • Does the two installations rule follow the suite or individual applications within the suite?

    I would like my web tools on my mac and windows laptops but I want my video/audio editing tools on my desktop tower. So no individual apps would be installed more than twice. Premiere, After-effects and Audtion would all be installed only once but on a 3rd machine - is that possible or would that require deactiving the entire Suite on one of the laptops? - thanks

    It's not possible. The activation is per suite, not per product.
    Mylenium

  • Multiple versions of the same Web Dynpro application on the same SAP Portal

    I have a single application (local development) and deploy directly to a SAP Portal(NW 7.0) from NWDS Version: 7.0.15
    No problems there, works like a charm.
    But I want to have multiple versions of the same application on one portal. Eg. ill build a version 1.0 for test and deploy this. Then continue to work on version 1.1 deploying this directly on the portal. The two versions should now co-existing under different names and/or packages.
    Please help.

    Hi Kim,
    May be you can try this and see if this works for you. I am not 100% sure if it will work for you, but worth a try I guess. Create a Test WebDynpro project and try the following steps on this project. If they work  out correctly and serve the purpose for you only then try them on your actual Web Dynpro project.
    1. Create a test Web Dynpro project  say "TestWDProject" with Component say "Comp1" and the default views and windows etc.
    Also create some working application our of this component and Windows using the Context.
    2. Right click the "Comp1" and select Copy.
    3. Right click 'Components" node in the project structure and select "Paste"
    4.This step will try to paste the copy of Comp1 as a new Component.
    5. You can change the Name and Package of the Component.
    6.Similarly you'll get the prompts for views,windows etc.
    7.Once you have copied everything, Just check if everything looks good.
    8.Now you can create a new Application using this new component and the Component Interface View and Deploy it.
    9.Test whether the Application created out of this copy works same as the original component.
    You can also try to create another Web Dynpro project and paste the Comp1 in the Components node of that new project and perform the same steps.
    Again, try with these Test Projects and see if this serves your purpose before applying the steps on actual projects.
    Regards,
    Ajay

Maybe you are looking for