PUBLIC.ORDdoc

Hi Folks -
I have installed Oracle 11g and made a table like so:
CREATE TABLE files ...
"IMAGE_THUMB" "ORDIMAGE" ,
"VIDEO_THUMB" BLOB,
"CONTENT" "ORDDOC" ,
then do a DESC of the table and see this:
IMAGE_THUMB PUBLIC.ORDIMAGE
VIDEO_THUMB BLOB
CONTENT PUBLIC.ORDDOC
Usually it says "ORDSYS.ORDIMAGE" instead of PUBLIC.ORDIMAGE
What gives? I tried unlocking the ORDSYS account, and recreating the table using this:
"IMAGE_THUMB" "ORDSYS.ORDIMAGE" ,
ERROR at line 20:
ORA-00902: invalid datatype
How can I use the ORDSYS schema in 11g? I don't want this datatype owned by PUBLIC?

The PUBLIC owner appears because the column was created using the ORDIMAGE synonym for the ORDSYS.ORDIMAGE type.
There's nothing wrong here, and no need to unlock or otherwise change the ORDSYS account. The ORDIMAGE type belongs to the ORDSYS schema
Try using "ORDSYS"."ORDIMAGE" if you want to see the ORDSYS schema when you do a describe.

Similar Messages

  • Exception again but not previous

    Hi
    now the given example is running well
    my code is creating this error or exception
    Exception:
    java.sql.SQLException: ORA-00917: missing comma
         at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:180)
         at oracle.jdbc.oci8.OCIDBAccess.check_error(OCIDBAccess.java, Compiled Code)
         at oracle.jdbc.oci8.OCIDBAccess.executeFetch(OCIDBAccess.java, Compiled Code)
         at oracle.jdbc.oci8.OCIDBAccess.parseExecuteFetch(OCIDBAccess.java, Compiled Code)
         at oracle.jdbc.driver.OracleStatement.executeNonQuery(OracleStatement.java, Compiled Code)
         at oracle.jdbc.driver.OracleStatement.doExecuteOther(OracleStatement.java, Compiled Code)
         at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java, Compiled Code)
         at oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java, Compiled Code)
         at fileSave.insertNewPhoto(filesave.java:69)
         at demo.jsp._docInsert._jspService(_docInsert.java:154)
         at oracle.jsp.runtime.HttpJsp.service(HttpJsp.java, Compiled Code)
         at oracle.jsp.app.JspApplication.dispatchRequest(JspApplication.java, Compiled Code)
         at oracle.jsp.JspServlet.doDispatch(JspServlet.java, Compiled Code)
         at oracle.jsp.JspServlet.internalService(JspServlet.java, Compiled Code)
         at oracle.jsp.JspServlet.service(JspServlet.java, Compiled Code)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:588)
         at org.apache.jserv.JServConnection.processRequest(JServConnection.java, Compiled Code)
         at org.apache.jserv.JServConnection.run(JServConnection.java, Compiled Code)
         at java.lang.Thread.run(Thread.java:479)

    <%@ page language="java" %>
    <%@ page import="fileSave" %>
    <%@ page import="oracle.ord.im.OrdHttpJspResponseHandler" %>
    <%@ page import="oracle.ord.im.OrdHttpUploadFormData" %>
    <%@ page import="oracle.ord.im.OrdHttpUploadFile" %>
    <jsp:useBean id = "docb" scope = "page" class = "fileSave"/>
    <jsp:useBean id = "handler" scope = "page" class = "oracle.ord.im.OrdHttpJspResponseHandler"/>
    <jsp:useBean id = "formData" scope = "page"
    class = "oracle.ord.im.OrdHttpUploadFormData"/>
    <%
    String doc_id;
    String to;
    String from;
    String sub;
    String desc;
    OrdHttpUploadFile uploaddoc = null;
    try
    formData.setServletRequest(request);
    if (!formData.isUploadRequest())
    %>
    <jsp:forward page = "docload.jsp"/>
    <%
    return ;
    formData.parseFormData();
    to = formData.getParameter("to");
    from = formData.getParameter("from");
    sub = formData.getParameter("sub");
    desc = formData.getParameter("desc");
    uploaddoc = formData.getFileParameter("doc");
    if (uploaddoc == null ||
    uploaddoc.getOriginalFileName() == null ||
    uploaddoc.getOriginalFileName().length() == 0)
    %>
    <jsp:forward page = "docload.jsp?error = Please + give + doc + name."/>
    <%
    return;
    if (uploaddoc.getContentLength() == 0)
    %>
    <jsp:forward page = "loaddoc.jsp?error = Please + give + File. "/>
    <%
    return ;
    //docb.setDoc_id(doc_id);
    docb.setTo(to);
    docb.setFrom(from);
    docb.setSub(sub);
    docb.setDesc(desc);
    docb.insertNewPhoto(uploaddoc);
    finally
    //docb.release();
    // formData.release();
    %>
    <html>
    <head>
    <title>File Insertion jsp page</title>
    </head>
    <body>
    <h3>Document load page</h3>
    </body>
    </html>
    fileSave code is here
    import java.util.*;
    import java.io.*;
    import java.sql.*;
    import javax.servlet.ServletException;
    import oracle.jdbc.driver.*;
    import oracle.ord.im.OrdDoc;
    import oracle.ord.im.OrdHttpUploadFile;
    import oracle.ord.im.OrdMediaUtil;
    public class fileSave
         private final static String EMPTY_DOC = "ordsys.ordDoc.init()";
         private OracleConnection conn;
         private OraclePreparedStatement stmt;
         private OracleResultSet rset;
         private static Stack connStack = new Stack();
         private static boolean driverLoaded = false;
         String doc_id;
         String to;
         String from;
         String sub;
         String desc;
         OrdDoc doc;
         public void selectTable() throws SQLException
              if (conn == null)
                   getConnection();
                   stmt = (OraclePreparedStatement)conn.prepareStatement(
                                  "select * from doc_table");
                   rset =(OracleResultSet)stmt.executeQuery();
         public void selectRowByDoc_id(String doc_id) throws SQLException
                   if (conn == null)
                             getConnection();
                   stmt = (OraclePreparedStatement)conn.prepareStatement(
                                                                     "select * from doc_table where doc_number = ?");
                        stmt.setString(1, doc_id);
                        rset = (OracleResultSet)stmt.executeQuery();
         public boolean fetch() throws SQLException
                   if (rset.next())
                        doc_id = rset.getString(1);
                        to = rset.getString(2);
                        from = rset.getString(3);
                        sub = rset.getString(4);
                        desc = rset.getString(5);
                        doc = (OrdDoc)rset.getCustomDatum(6,OrdDoc.getFactory() );
                             return true;
                             else
                             rset.close();
                             stmt.close();
                             return false;
    public void insertNewPhoto(OrdHttpUploadFile uploaddoc)
    throws SQLException, ServletException, IOException
    if (conn == null)
         getConnection();
                             conn.setAutoCommit(false);
              OraclePreparedStatement stmt =     
                                            (OraclePreparedStatement)conn.prepareStatement(          
         "select doc_sequence.nextval from dual" );
    OracleResultSet rset = (OracleResultSet)stmt.executeQuery();
         if (!rset.next() )     {
         throw new ServletException( "new ID not found" );
              String doc_id = rset.getString( 1 );     
    rset.close();
    stmt.close();
    stmt = (OraclePreparedStatement)conn.prepareStatement(
    "insert into doc_table(doc_number, to_user, from_user,subject, description, doc)" +
                                       "values(?,?,?,?,?,ORDSYS.ORDDoc.init())");
                             stmt.setString(1,doc_id);
                             stmt.setString(2,to);
                             stmt.setString(3,from);
                             stmt.setString(4,sub);
                             stmt.setString(5,desc);
                             stmt.executeUpdate();
                             stmt.close();
                             stmt = (OraclePreparedStatement)conn.prepareStatement(
                        "select doc from doc_table where doc_number = ? for update");
                             stmt.setString(1, doc_id);
                             rset = (OracleResultSet)stmt.executeQuery();
                             if (!rset.next())
         throw new ServletException("new row not found in table");
    doc = (OrdDoc)rset.getCustomDatum(1,OrdDoc.getFactory());
    rset.close();
    stmt.close();
    uploaddoc.loadDoc(doc);
    stmt = (OraclePreparedStatement)conn.prepareStatement(
    "update doc_table set doc = ? where doc_number = ? ");
    stmt.setCustomDatum(1,doc);
    stmt.setString(2,doc_id);
    stmt.execute();
    stmt.close();
    conn.commit();
    public void release() throws SQLException
    if (rset != null)
    rset.close();
    rset = null;
    if (stmt != null)
    stmt.close();
    rset = null;
    if (conn != null)
    freeConnection(conn);
    conn = null;
    public String getDoc_id()
    return doc_id;
    public void setDoc_id(String doc_id)
    this.doc_id = doc_id;
    public String getTo()
    return to;
    public void setTo(String to)
    this.to = to;
    public String getFrom()
    return from;
    public void setFrom(String from)
    this.from = from;
    public String getSub()
    return sub;
    public void setSub(String sub)
    this.sub = sub;
    public String getDesc()
    return desc;
    public void setDesc(String desc)
    this.desc = desc;
    public OrdDoc getDoc()
    return doc;
    public void setDoc(OrdDoc doc)
    this.doc = doc;
    private Connection getConnection()
    throws SQLException
    //Connection conn = null;
    synchronized(connStack)
    if(!driverLoaded)
    DriverManager.registerDriver(new oracle.jdbc.driver.OracleDriver());
    driverLoaded = true;
    if (connStack.empty())
                                       conn =(OracleConnection)DriverManager.getConnection
                   ("jdbc:oracle:oci8:@", "kashif", "raojee");
                                            try
                                            OrdMediaUtil.imCompatibilityInit(conn);
                                            catch (Exception e)
                                            throw new SQLException(e.toString());
                                                 else
    conn = (OracleConnection)connStack.pop();
    conn.setAutoCommit(true);
    return conn;
    private void freeConnection(Connection conn)
    if(conn != null)
    synchronized(connStack)
    connStack.push(conn);

  • Problem using writeToSource from ORDDoc

    Hi
    I have some problem using writeToSource
    it works it writs on the source but not at the end
    it writes at 1st starting position
    how i can handle that problem
    tanx

    Hi larry
    Thanx for cooperation
    i am using some way to use lob data but
    not pointer execption is really great problem for me
    i am giving code an exception too read an give me some suggestions
    public void append(String sid)
    throws SQLException, ServletException, IOException
    String comm1="";
    if (conn == null)
         getConnection();
         conn.setAutoCommit(false);
    stmt =(OraclePreparedStatement)conn.prepareStatement(
    "select doc from doc_table where doc_number = ? for update");
    stmt.setString(1,sid);
    if (rset.next())
    doc1 = (OrdDoc)rset.getCustomDatum(1,OrdDoc.getFactory() );
         }else
                             rset.close();
                             stmt.close();
    stmt.close();
    stmt =(OraclePreparedStatement)conn.prepareStatement(
    "select comm from doc_table where doc_number = ?");
    stmt.setString(1,sid);
    if (rset.next())
              comm1 = rset.getString(1);
    else
         rset.close();
              stmt.close();
    stmt.close();
    byte [][]ctx = new byte[1][64];
    byte[] buf = new byte[comm1.length()];
    buf = comm1.getBytes();
    BLOB doc2 = doc1.getContent();
    OracleCallableStatement open_st =
    (OracleCallableStatement) conn.prepareCall(
    "BEGIN " +          
    " DBMS_LOB.CREATETEMPORARY(doc2,TRUE,DBMS_LOB.SESSION); "+
    " DBMS_LOB.OPEN(doc2,DBMS_LOB.LOBREADWRITE);"+
    " DBMS_LOB.WRITEAPPEND(doc2,comm1.length(),comm1);" +
    " END;");
    //open_st.registerOutParameter(1,doc2);
    //open_st.registerOutParameter(2,comm1.length());
    // open_st.registerOutParameter(3,comm1);
    open_st.execute();
    close_st =(OracleCallableStatement)conn.prepareCall(
    "BEGIN DBMS_LOB.CLOSE(?); END;");
    BLOB temp = open_st.getBLOB(1);
    InputStream in = temp.getBinaryStream();
    doc1.loadDataFromInputStream(in);
    in.close();
    //close_st.setBLOB(1,temp);
    stmt = (OraclePreparedStatement)conn.prepareStatement(
    "update doc_table set doc = ? where doc_number = ? ");
    stmt.setCustomDatum(1,doc1);
    stmt.setString(2,sid);
    stmt.execute();
    rset.close();
    stmt.close();
    conn.commit();                     
    java.lang.NullPointerException
    at SQLObject.append(SQLObject.java:64)
    at demo.sample._comments._jspService(_comments.java:136)

  • How do I use Sun Web Server 7.0u1 reverse proxy to change public URLs?

    Some of our installations use the Sun Web Server 7.0 (update 1, usually)
    for hosting some of the public resource and reverse-proxying other parts
    of the URI namespace from other backend servers (content, application
    and other types of servers).
    So far every type of backend server served a unique part of the namespace
    and there was no collision of names, and the backend resources were
    published in a one-to-one manner. That is, a backend resource like, say,
    http://appserver:8080/content/page.html would be published in the internet
    as http://www.publicsite.com/content/page.html
    I was recently asked to research whether we can rename some parts of
    the public URI namespace, to publish some or all resources as, say,
    http://www.publicsite.com/data/page.html while using the same backend
    resources.
    Another quest, possibly related in solution, was to make a tidy url for the
    first page the user opens of the site. That is, in the current solution when
    a visitor types the url "www.publicsite.com" in his or her browser, our web
    server returns an HTTP-302 redirect to the actual first page URL, so the
    browser sends a second request (and changes the URL in its location bar).
    One customer said that it is not "tidy". They don't want the URL to change
    right upon first rendering the page. They want the root page to be rendered
    instantly i the first HTTP request.
    So far I found that I can't solve these problems. I believe these problems
    share a solution because it relies on ability to control the actual URI strings
    requested by Sun Web Server from backend servers.
    Some details follow, now:
    It seems that the reverse proxy (Service fn="service-passthrough") takes
    only the $uri value which was originally requested by the browser. I didn't
    yet manage to override this value while processing a request, not even if
    I "restart" a request. Turning the error log up to "finest" I see that even
    when making the "service-passthrough" operation, the Sun Web Server
    still remembers that the request was for "/test" (in my test case below);
    it does indeed ask the backend server for an URI "/test" and that fails.
    [04/Mar/2009:21:45:34] finest (25095) www.publicsite.com: for host xx.xx.xx.83
    trying to GET /content/MainPage.html while trying to GET /test, func_exec reports:
    fn="service-passthrough" rewrite-host="true" rewrite-location="true"
    servers="http://10.16.2.127:8080" Directive="Service" DaemonPool="2b1348"
    returned 0 (REQ_PROCEED)My obj.conf file currently has simple clauses like this:
    # this causes /content/* to be taken from another (backend) server
    NameTrans fn="assign-name" from="/content" name="content-test" nostat="/content"
    # this causes requests to site root to be HTTP-redirected to a certain page URI
    <If $uri =~ '^/$'>
        NameTrans fn="redirect"
            url="http://www.publicsite.com/content/MainPage.html"
    </If>
    <Object name="content-test">
    ### This maps http://public/content/* to http://10.16.2.127:8080/content/*
    ### Somehow the desired solution should instead map http://public/data/* to http://10.16.2.127:8080/content/*
        Service fn="service-passthrough" rewrite-host="true" rewrite-location="true" servers="http://10.16.2.127:8080"
        Service fn="set-variable" set-srvhdrs="host=www.publicsite.com:80"
    </Object>
    I have also tried "restart"ing the request like this:
        NameTrans fn="restart" uri="/data"or desperately trying to set the new request uri like this:
        Service fn="set-variable"  uri="/magnoliaPublic/Main.html"Thanks for any ideas (including a statement whether this can be done at all
    in some version of Sun Web Server 7.0 or its opensourced siblings) ;)
    //Jim

    Some of our installations use the Sun Web Server 7.0 (update 1, usually)please plan on installing the latest service pack - 7.0 Update 4. these updates addresses potentially critical bug fixes.
    I was recently asked to research whether we can rename some parts of
    the public URI namespace, to publish some or all resources as, say,
    http://www.publicsite.com/data/page.html while using the same backend
    resources.> now, if all the resources are under say /data, then how will you know which pages need to be sent to which back end resources. i guess, you probably meant to check for /data/page.html should go to <back-end>/content/page.html
    yes, you could do something like
    - edit your corresponding obj.conf (<hostname>-obj.conf or obj.conf depending on your configuration)
    <Object name=¨default¨>
    <If $uri = ¨/page/¨>
    #move this nametrans SAF (for map directive - which is for reverse proxy within <if> clause)
    NameTrans.. fn=map
    </If
    </Object>
    and you could do https-<hostname>/bin/reconfig (dynamic reconfiguration) to check out if this is what you wanted. also, you might want to move config/server.xml <log-level> to finest and do your configuration . this way, you would get enough information on what is going on within your server logs.
    finally,when you are satisfied, you might have to run the following command to make your manual change into admin config repository.
    <install-root>/bin/wadm pull-config user=admin config=<hostname> <hostname>
    <install-root>/bin/wadm deploy-config --user=admin <hostname>
    you might want to check out this for more info on how you could use <if> else condition to handle your requirement.
    http://docs.sun.com/app/docs/doc/820-6599/gdaer?a=view
    finally, you might want to refer to this doc - which explains on ws7 request processing overview. this should provide you with some pointers as to what these different directives mean
    http://docs.sun.com/app/docs/doc/820-6599/gbysz?a=view
    >
    One customer said that it is not "tidy". They don't want the URL to change
    right upon first rendering the page. They want the root page to be rendered
    instantly i the first HTTP request.
    please check out the rewrite / restart SAF. this should help you.
    http://docs.sun.com/app/docs/doc/820-6599/gdada?a=view
    pl. understand that - like with more web servers - ordering of directives is very important within obj.conf. so, you might want to make sure that you verify the obj.conf directive ordering is what you want it to do..
    It seems that the reverse proxy (Service fn="service-passthrough") takes
    only the $uri value which was originally requested by the browser. I didn't
    yet manage to override this value while processing a request, not even if
    I "restart" a request. Turning the error log up to "finest" I see that even
    when making the "service-passthrough" operation, the Sun Web Server
    still remembers that the request was for "/test" (in my test case below);
    it does indeed ask the backend server for an URI "/test" and that fails.
    now, you are in the totally wrong direction. web server 7 includes a highly integrated reverse proxy solution compared to 6.1. unlike 6.1, you don´t have to download a separate plugin . however, you will need to manually migrate your 6.1 based reverse proxy settings into 7.0. please check out this blog link on how to set up a reverse proxy
    http://blogs.sun.com/amit/entry/setting_up_a_reverse_proxy
    feel free to post to us if you need any futher help
    you are probably better off - starting fresh
    - install ws7u4
    - use gui or CLI to create a reverse proxy and map one on one - say content
    http://docs.sun.com/app/docs/doc/820-6601/create-reverse-proxy-1?a=view
    if you don´t plan on using ws7 integrated web container (ability to process jsp/servlet), then you could disable java support as well. this should reduce your server memory footprint
    <install-root>/bin/wadm disable-java user=admin config=<hostname>
    <install-root>/bin/wadm create-reverse-proxy user=admin uri-prefix=/content server=<http://your back end server/ config=<hostname> --vs=<hostname>
    <install-root>/bin/wadm deploy-config --user=admin <hostname>
    now, you can check out the regular express processing and <if> syntax from our docs and try it out within <https-<hostname>/config/<hostname>-obj.conf> file and restart the server. pl. note that once you disable java, ws7 admin server creates <vs>-obj.conf and you need to edit this file and not default obj.conf for your changes to be read by server.
    >
    I have also tried "restart"ing the request like this:
    NameTrans fn="restart" uri="/data"
    ordering is very important here... you need to do this some thing like
    <Object name=default>
    <If not $restarted>
    NameTrans fn=restart uri from=/¨ uri=/foo.
    </If>

  • Create a public Internet facing site with SharePoint Foundation

    Hi,
    Would I be able to use SharePoint Foundation to create a public Internet facing site? In addition, where can I find tutorial on how to create public Internet facing sites?
    Thanks a lot!
    Eduardo

    Hi Eduardo,
    You can create public Internet facing site using SharePoint Foundation, e.g. www.wssdemo.com
    Regards,
    Vladimir
    MCTS, SharePoint tips blog: http://buyevich.blogspot.com

  • How to Configure Cisco ASA 5512 for multiple public IP interfaces

    Hi
    I have a new ASA 5512 that I would like to configure for multiple public IP support.  My problem may be basic but I am an occasional router admin and don't touch this stuff enough to retain everything I have learned.
    Here is my concept.    We have a very basic network setup using three different ISPs that are currently running with cheap routers for internet access.  We use these networks to open up access for Sales to demo different products that use a lot of bandwidth (why we have three)
    I wanted to use the 5512 to consolidate the ISPs so we are using one router to manage the connections.  I have installed an add on license that allows multiple outside interfaces along with a number of other features.
    Outside Networks (I've changed the IPs for security purposes)
    Outside1 E 0/0 : 74.55.55.210  255.255.255.240 gateway 74.55.55.222
    Outside2 E 0/2: 50.241.134.220 255.255.248 gateway 50.241.134.222
    Inside1 : E 0/1 192.168.255.1 255.255.248.0
    Inside2 : E 0/3 172.16.255.1 255.255.248.0
    My goal is to have Inside 1 route all internet traffic using Outside1 and Inside 2 to use Outside2.    The problem is I can't seem to do this. I can get inside 1 to use outside 1 but Inside2 uses Outside 1 as well.
    I tried adding static routes on Outside2 to have all 172.16.248.0/21 traffic use gateway 50.241.134.222 but that doesn't seem to work.   
    I can post my config up as needed.  I am not well versed in Cisco CLI, I've been using the ASDM 7.1 app.  My ASA 5512 is at 9.1.   
    Thanks in advance for the suggestions/help

    I have been away for a while and am just getting caught up on some posts. so my apology for a delayed response.
    I find the response very puzzling. It begins by proclaiming that to achieve the objective we must use Policy Based Routing. But then in the suggested configuration there is no PBR. What it gives us is two OSPF processes using one process for each of the public address ranges and with some strange distribute list which uses a route map. I am not clear what exactly it is that this should accomplish and do not see how it contributes to having one group of users use one specific ISP and the other group of users use the other ISP>
    To the original poster
    It seems to me that you have chosen the wrong device to implement the edge function of your network. The ASA is a good firewall and it does some routing things. But fundamentally it is not a router. And to achieve what you want were a group of users will use a specified ISP and the other group of users will use the other ISP you really need a router. You want to control outbound traffic based on the source of the traffic, and that is a classic situation where PBR is the ideal solution. But the ASA does not do PBR.
    HTH
    Rick

  • How can I set OWA to use Public by default and hide that section from OWA?

    I have an Exchange 2013 deployment that needs a customized OWA page.  I've already run Set-OwaVirtualDirectory "ex1\owa*" -LogonPagePublicPrivateSelectionEnabled $True to show the Public option.  I've also edited the logon.aspx
    file to set the checkbox to be unchecked by default.  My problem is I need to hide that entire line, I don't want users to see that section at all as if I never ran the above command.  When I was testing hiding it with <!-- --> it hid it but
    caused that piece to stop working as it went back to private.  Has anyone been able to accomplish this or can clue me in on how to do this?  Thank you in advance.

    Hi,
    I suggest we ask the question on Exchange Development Forum:
    http://social.technet.microsoft.com/Forums/en-US/home?forum=exchangesvrdevelopment&filter=alltypes&sort=lastpostdesc
    Regards,
    Simon Wu
    TechNet Community Support

  • How can another user on my system share their document if they cannot access a public drop box, do not have an email account setup on the system and we don't want to use iwork?

    Please help. My DS created a document under his login on my PowerBook and now, I cannot seem to access it. He doesn't have an email account of his own, I can't seem to save it as a public document in a drop box like I can from my own login and we do not want to use iwork. Is there a way to save it so that I can access it from my login to email to his teacher. I don't want to have to retype it into Pages under my login.

    Save the document from his account to an external drive or thumb drive.
    Set the permissions (using Finder > Get Info) for "Everyone" to Read and Write.
    Your DS will likely be the owner of the file, so you may need his login password to change the permissions.
    Regards,
    Barry

  • Error while calling a super class public method in the subclass constructor

    Hi ,
    I have code like this:
    CLASS gacl_applog DEFINITION ABSTRACT.
      PUBLIC SECTION.
        METHODS:
                create_new_a
                   IMPORTING  pf_obj       TYPE balobj_d
                              pf_subobj    TYPE balsubobj
                              pf_extnumber TYPE string
                   EXPORTING  pfx_log_hndl TYPE balloghndl
                   EXCEPTIONS error
    ENDCLASS.
    CLASS gacl_applog IMPLEMENTATION.
      METHOD create_new_a.
        DATA: ls_log TYPE bal_s_log.
      Header aufsetzen
        MOVE pf_extnumber TO ls_log-extnumber.
        ls_log-object     = pf_obj.
        ls_log-subobject  = pf_subobj.
        ls_log-aluser     = sy-uname.
        ls_log-alprog     = sy-repid.
        ls_log-aldate     = sy-datum.
        ls_log-altime     = sy-uzeit.
        ls_log-aldate_del = ls_log-aldate + 1.
        CALL FUNCTION 'BAL_LOG_CREATE'
             EXPORTING
                  i_s_log      = ls_log
             IMPORTING
                  e_log_handle = pfx_log_hndl
             EXCEPTIONS
                  OTHERS       = 1.
        IF ( sy-subrc NE 0 ).
          MESSAGE ID      sy-msgid TYPE sy-msgty NUMBER sy-msgno
                  WITH    sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4
                  RAISING error.
        ENDIF.
      ENDMETHOD.
    CLASS gcl_applog_temp DEFINITION INHERITING FROM gacl_applog.
      PUBLIC SECTION.
        DATA: log_hndl   TYPE balloghndl READ-ONLY
            , t_log_hndl TYPE bal_t_logh READ-ONLY
        METHODS: constructor
                   IMPORTING  pf_obj       TYPE balobj_d
                              pf_subobj    TYPE balsubobj
                              pf_extnumber TYPE string
                   EXCEPTIONS error
               , msg_add      REDEFINITION
               , display      REDEFINITION
    ENDCLASS.
    CLASS gcl_applog_temp IMPLEMENTATION.
      METHOD constructor.
        CALL METHOD create_new_a
               EXPORTING  pf_obj       = pf_obj
                          pf_subobj    = pf_subobj
                          pf_extnumber = pf_extnumber
               IMPORTING  pfx_log_hndl = log_hndl.
        IF ( sy-subrc NE 0 ).
          MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno
                  WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4
                  RAISING error.
        ENDIF.
      ENDMETHOD.
    A public method of Super class has been called from the constructor of the sub class. we are getting the syntax error :
    ' In the constructor method, you can only access instance attributes, instance methods, or "ME" after calling the constructor of the superclass…'
    Can you please suggest how to change the code with out affecting the functioanlity.
    Thank you ,
    Lakshmi.

    Hi,
    Call that method by instance of Subclass.   OR
    SUPER-->method.
    Read very useful document
    Constructors
    Constructors are special methods that cannot be called using CALL METHOD. Instead, they are called automatically by the system to set the starting state of a new object or class. There are two types of constructors - instance constructors and static constructors. Constructors are methods with a predefined name. To use them, you must declare them explicitly in the class.
    The instance constructor of a class is the predefined instance method CONSTRUCTOR. You declare it in the public section as follows:
    METHODS CONSTRUCTOR
            IMPORTING.. [VALUE(]<ii>[)] TYPE type [OPTIONAL]..
            EXCEPTIONS.. <ei>.
    and implement it in the implementation section like any other method. The system calls the instance constructor once for each instance of the class, directly after the object has been created in the CREATE OBJECT statement. You can pass the input parameters of the instance constructor and handle its exceptions using the EXPORTING and EXCEPTIONS additions in the CREATE OBJECT statement.
    The static constructor of a class is the predefined static method CLASS_CONSTRUCTOR. You declare it in the public section as follows:
    CLASS-METHODS CLASS_CONSTRUCTOR.
    and implement it in the implementation section like any other method. The static constructor has no parameters. The system calls the static constructor once for each class, before the class is accessed for the first time. The static constructor cannot therefore access the components of its own class.
    Pls. reward if useful....

  • Error while invoking a public PL/SQL API in EBIZ from Sync BPEL process

    Hi,
    SOA Suite: 11.1.1.3
    I am getting the following error when I am invoking a public API in EBIZ from Oracle via a BPEL process. I am supplying the username/password via binding properties (as mentioned in other posts). Can someone point out that is the exact cause for this error please?
    SEVERE: AbstractWebServiceBindingComponent.dispatchRequest Unable to dispatch request to http://<myserver>:8006/webservices/SOAProvider/plsql/hz_party_v2pub/ due to exceptionjavax.xml.ws.soap.SOAPF
    aultException: Error occured while service was processing.
    at oracle.j2ee.ws.client.jaxws.DispatchImpl.throwJAXWSSoapFaultException(DispatchImpl.java:874)
    at oracle.j2ee.ws.client.jaxws.DispatchImpl.invoke(DispatchImpl.java:707)
    at oracle.j2ee.ws.client.jaxws.OracleDispatchImpl.synchronousInvocationWithRetry(OracleDispatchImpl.java:226)
    at oracle.j2ee.ws.client.jaxws.OracleDispatchImpl.invoke(OracleDispatchImpl.java:97)
    at oracle.integration.platform.blocks.soap.AbstractWebServiceBindingComponent.dispatchRequest(AbstractWebServiceBindingComponent.java:449)
    at oracle.integration.platform.blocks.soap.WebServiceExternalBindingComponent.processOutboundMessage(WebServiceExternalBindingComponent.java:184)
    at oracle.integration.platform.blocks.soap.WebServiceExternalBindingComponent.sendSOAPMessage(WebServiceExternalBindingComponent.java:634)
    at oracle.integration.platform.blocks.soap.WebServiceExternalBindingComponent.request(WebServiceExternalBindingComponent.java:520)
    at oracle.integration.platform.blocks.mesh.SynchronousMessageHandler.doRequest(SynchronousMessageHandler.java:139)
    at oracle.integration.platform.blocks.mesh.MessageRouter.request(MessageRouter.java:179)
    at oracle.integration.platform.blocks.mesh.MeshImpl.request(MeshImpl.java:144)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:296)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:177)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:144)
    at oracle.integration.platform.metrics.PhaseEventAspect.invoke(PhaseEventAspect.java:71)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:166)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
    at $Proxy204.request(Unknown Source)
    at oracle.fabric.CubeServiceEngine.requestToMesh(CubeServiceEngine.java:704)
    at com.collaxa.cube.ws.WSInvocationManager.invoke(WSInvocationManager.java:246)
    at com.collaxa.cube.engine.ext.bpel.common.wmp.BPELInvokeWMP.__invoke(BPELInvokeWMP.java:935)
    at com.collaxa.cube.engine.ext.bpel.common.wmp.BPELInvokeWMP.handleNormalInvoke(BPELInvokeWMP.java:440)
    at com.collaxa.cube.engine.ext.bpel.common.wmp.BPELInvokeWMP.__executeStatements(BPELInvokeWMP.java:182)
    at com.collaxa.cube.engine.ext.bpel.common.wmp.BaseBPELActivityWMP.perform(BaseBPELActivityWMP.java:140)
    at com.collaxa.cube.engine.CubeEngine._performActivity(CubeEngine.java:2675)
    at com.collaxa.cube.engine.CubeEngine.performActivity(CubeEngine.java:2558)
    at com.collaxa.cube.engine.CubeEngine.handleWorkItem(CubeEngine.java:1256)
    at com.collaxa.cube.engine.dispatch.message.instance.PerformMessageHandler.handleLocal(PerformMessageHandler.java:73)
    at com.collaxa.cube.engine.dispatch.DispatchHelper.handleLocalMessage(DispatchHelper.java:188)
    at com.collaxa.cube.engine.dispatch.DispatchHelper.sendMemory(DispatchHelper.java:285)
    at com.collaxa.cube.engine.CubeEngine.endRequest(CubeEngine.java:4607)
    at com.collaxa.cube.engine.CubeEngine.createAndInvoke(CubeEngine.java:828)
    at com.collaxa.cube.engine.ejb.impl.CubeEngineBean.createAndInvoke(CubeEngineBean.java:111)
    at com.collaxa.cube.engine.ejb.impl.CubeEngineBean.syncCreateAndInvoke(CubeEngineBean.java:147)
    at com.collaxa.cube.engine.ejb.impl.bpel.BPELEngineBean.syncCreateAndInvoke(BPELEngineBean.java:103)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.bea.core.repackaged.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:310)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:182)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.jee.spi.MethodInvocationVisitorImpl.visit(MethodInvocationVisitorImpl.java:37)
    at weblogic.ejb.container.injection.EnvironmentInterceptorCallbackImpl.callback(EnvironmentInterceptorCallbackImpl.java:54)
    at com.bea.core.repackaged.springframework.jee.spi.EnvironmentInterceptor.invoke(EnvironmentInterceptor.java:50)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:89)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
    at $Proxy193.syncCreateAndInvoke(Unknown Source)
    at com.collaxa.cube.engine.ejb.impl.bpel.BPELEngineBean_51369e_ICubeEngineLocalBeanImpl.syncCreateAndInvoke(BPELEngineBean_51369e_ICubeEngineLocalBeanImpl.java:575)
    at com.collaxa.cube.engine.delivery.DeliveryHandler.initialRequestAnyType(DeliveryHandler.java:528)
    at com.collaxa.cube.engine.delivery.DeliveryHandler.initialRequest(DeliveryHandler.java:482)
    at com.collaxa.cube.engine.delivery.DeliveryHandler.request(DeliveryHandler.java:156)
    at com.collaxa.cube.engine.ejb.impl.CubeDeliveryBean.request(CubeDeliveryBean.java:600)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.bea.core.repackaged.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:310)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:182)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.jee.spi.MethodInvocationVisitorImpl.visit(MethodInvocationVisitorImpl.java:37)
    at weblogic.ejb.container.injection.EnvironmentInterceptorCallbackImpl.callback(EnvironmentInterceptorCallbackImpl.java:54)
    at com.bea.core.repackaged.springframework.jee.spi.EnvironmentInterceptor.invoke(EnvironmentInterceptor.java:50)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:89)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
    at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
    at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
    at com.bea.core.repackaged.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
    at $Proxy190.request(Unknown Source)
    at com.collaxa.cube.engine.ejb.impl.bpel.BPELDeliveryBean_5k948i_ICubeDeliveryLocalBeanImpl.request(BPELDeliveryBean_5k948i_ICubeDeliveryLocalBeanImpl.java:325)
    at oracle.fabric.CubeServiceEngine.request(CubeServiceEngine.java:290)
    at oracle.integration.platform.blocks.mesh.SynchronousMessageHandler.doRequest(SynchronousMessageHandler.java:139)
    at oracle.integration.platform.blocks.mesh.MessageRouter.request(MessageRouter.java:179)
    at oracle.integration.platform.blocks.mesh.MeshImpl.request(MeshImpl.java:144)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:296)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:177)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:144)
    at oracle.integration.platform.metrics.PhaseEventAspect.invoke(PhaseEventAspect.java:59)
    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:166)
    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
    at $Proxy204.request(Unknown Source)
    at oracle.integration.platform.blocks.soap.WebServiceEntryBindingComponent.doMessageProcessing(WebServiceEntryBindingComponent.java:1155)
    at oracle.integration.platform.blocks.soap.WebServiceEntryBindingComponent.processIncomingMessage(WebServiceEntryBindingComponent.java:767)
    at oracle.integration.platform.blocks.soap.FabricProvider.processMessage(FabricProvider.java:113)
    at oracle.j2ee.ws.server.provider.ProviderProcessor.doEndpointProcessing(ProviderProcessor.java:1119)
    at oracle.j2ee.ws.server.WebServiceProcessor.invokeEndpointImplementation(WebServiceProcessor.java:873)
    at oracle.j2ee.ws.server.provider.ProviderProcessor.doRequestProcessing(ProviderProcessor.java:553)
    at oracle.j2ee.ws.server.WebServiceProcessor.processRequest(WebServiceProcessor.java:202)
    at oracle.j2ee.ws.server.WebServiceProcessor.doService(WebServiceProcessor.java:166)
    at oracle.j2ee.ws.server.WebServiceServlet.doPost(WebServiceServlet.java:384)
    at oracle.integration.platform.blocks.soap.FabricProviderServlet.doPost(FabricProviderServlet.java:444)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
    at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
    at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
    at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:292)
    at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
    at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
    at oracle.dms.wls.DMSServletFilter.doFilter(DMSServletFilter.java:202)
    at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:56)
    at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3588)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
    at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2200)
    at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2106)
    at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1428)
    at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
    Nov 3, 2010 2:32:08 PM com.collaxa.cube.CubeLogger error
    SEVERE: <WSInvocationManager::invoke> got FabricInvocationException
    oracle.fabric.common.FabricInvocationException: javax.xml.ws.soap.SOAPFaultException: Error occured while service was processing.
    Thanks,
    Dinesh

    Hi James,
    Thanks for the quick reply.
    We've tried to call that web service from an HTML designed in Visual Studios with the same username and password and its working fine.
    But on the BPEL console, we are getting the error as mentioned.
    Also if you can tell me how to set the user name and password in the header of the parter link.I could not find how to do it.
    Thanks,
    Saurabh

  • Error while accessing a public method of applet from javascript.

    Hi,
    I am getting "Object doesn't support this property or method" error
    when accessing a public method of applet from javascript in IE 6 using
    document.applets[0].myMethod();
    The same is working in IE 7.
    Thanks in advance.
    Regards,
    Phanikanth

    I don't know why it happens, but this works for me in both versions:
    <applet ..... name="MyApplet">
    </applet>and in javascript use
    document.MyApplet.myMethod()

  • CU8 Update - Public Folder Calendar and Contacts show up in OWA that no longer exist and I cannot access when selecting.

    We recently updated to CU8. I went to test out the new Public Folder access to calendars and contacts.  I first go to Calendars in OWA and I see a list of several calendars.  I see one that is listed twice, one I can open and the other states "Couldn't
    open calendar - A connection couldn't be made with the shared calendar. Remove the calendar and try to add it again, or ask the owner to share it again." I also see other calendar's that we used in the past but no longer reside under public folders.
    I get the same error on them.
    For People, I can go there and I see a section called "Public Folder" and there is a contact list called "IT Team Contacts".  When I click on it, it states in the middle pane "Your request can't be completed right now. 
    Please try again later."  This contact list is not on our public folders. 
    Any ideas on why we I'm seeing these issues?
    Thanks,
    Jeff Dailey

    Seems like some orphaned PF favorites. You should be able to remove them from Outlook, or via MFCMAPI

  • Can not access server's on public ip's

    Guys,
    We have a core switch with two fibre lines connecting us through two different ISP's to the internet. These ISP's have provided us with a range of public ip's each. We have a few routers on some of these ip's and they are working fine and we can access them externally (telnet and ssh).
    I am now busy setting up two servers, one on each ISP with their respective public ip's. I can ping the core switch and the isp gateways from the servers and from the core. I have triple checked that there are no active firewalls and I can see that the http ports are open and accessible (TcpView). But for the life of me I can not access those servers externally. I am now completely stumped. I do suspect though that it is a routing problem through the core.
    And herewith the relevant parts from my Core switch's config:
    version 12.2
    service tcp-keepalives-in
    service tcp-keepalives-out
    hostname SMS-CORE
    no aaa new-model
    clock timezone ZAR 2
    no ip source-route
    mls netflow interface
    mls cef error action reset
    spanning-tree mode pvst
    spanning-tree portfast edge default
    vlan internal allocation policy ascending
    interface FastEthernet3/25
     switchport
     switchport access vlan 153
     switchport mode access
    interface FastEthernet3/31
     switchport
     switchport access vlan 153
     switchport mode access
    interface FastEthernet3/35
     switchport
     switchport access vlan 153
     switchport mode access
    interface FastEthernet3/37
     switchport
     switchport access vlan 20
     switchport mode access
    interface FastEthernet3/47
     switchport
     switchport access vlan 20
     switchport mode access
    interface FastEthernet3/48
     ip address 192.168.2.2 255.255.255.252
    interface Vlan1
     no ip address
    interface Vlan20
     ip address PUBLIC_IP1 255.255.255.240
    interface Vlan153
     ip address PUBLIC_IP2 255.255.255.248
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.2.1
    ip local policy route-map PUBLIC
    access-list 100 permit ip ISP2_NETWORK 0.0.0.7 any
    access-list 101 permit ip ISP1_NETWORK 0.0.0.15 any
    route-map PUBLIC permit 10
     match ip address 100
     set ip default next-hop PUBLIC_GW2
    route-map PUBLIC permit 20
     match ip address 101
     set ip default next-hop 192.168.2.1
    Any  ideas guys, I am at my wits end here ....
    Thanks as always !

    Hi Oliver , 
           Have you got IP Address assigned to your server from the same segment ?? like for server 1 
    ip address PUBLIC_IP1 255.255.255.240
    and for server 2 
    ip address PUBLIC_IP2 255.255.255.248
    What is the gateway IP address assigned for both servers .
    HTH
    Sandy

  • Unable to access public ip from branch vpn (Cisco ASA 5510 Firewall)

                       Hi,
    As per the above diagram
    in Head office -  able to access public ips
    In Branch office - unable to access public ips only accessing head office servers and internet is shared from head office.
    please see the below configuration in Branch office router:
    access-list 1 permit any
    access-list 100 remark ****** Link to Firewall-HO1 ******
    access-list 100 permit ip 10.21.211.0 0.0.0.255 172.16.35.0 0.0.0.255
    access-list 100 permit ip 10.21.211.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 100 permit ip 10.21.211.0 0.0.0.255 10.11.0.0 0.0.255.255
    access-list 100 permit ip 10.21.211.0 0.0.0.255 10.12.0.0 0.0.255.255
    access-list 100 permit ip 10.21.111.0 0.0.0.255 172.16.35.0 0.0.0.255
    access-list 100 permit ip 10.21.111.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 100 permit ip 10.21.111.0 0.0.0.255 10.11.0.0 0.0.255.255
    access-list 100 permit ip 10.21.111.0 0.0.0.255 10.12.0.0 0.0.255.255
    access-list 100 permit ip 10.21.10.0 0.0.0.255 172.16.35.0 0.0.0.255
    access-list 100 permit ip 10.21.10.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 100 permit ip 10.21.10.0 0.0.0.255 10.11.0.0 0.0.255.255
    access-list 100 permit ip 10.21.10.0 0.0.0.255 10.12.0.0 0.0.255.255
    access-list 100 permit ip 10.21.211.0 0.0.0.255 host 78.93.190.226
    access-list 100 permit ip 10.21.111.0 0.0.0.255 host 78.93.190.226
    access-list 100 permit ip any any
    access-list 101 deny   ip 10.21.211.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.211.0 0.0.0.255 10.11.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.211.0 0.0.0.255 10.12.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.211.0 0.0.0.255 172.0.0.0 0.255.255.255
    access-list 101 deny   ip 10.21.111.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.111.0 0.0.0.255 10.11.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.111.0 0.0.0.255 10.12.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.111.0 0.0.0.255 172.0.0.0 0.255.255.255
    access-list 101 deny   ip 10.21.10.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.10.0 0.0.0.255 10.11.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.10.0 0.0.0.255 10.12.0.0 0.0.255.255
    access-list 101 deny   ip 10.21.10.0 0.0.0.255 172.0.0.0 0.255.255.255
    access-list 101 permit ip host 10.21.211.51 any
    access-list 101 permit tcp 10.21.211.0 0.0.0.255 host 66.147.240.160 eq pop3
    access-list 101 permit tcp 10.21.211.0 0.0.0.255 host 66.147.240.160 eq smtp
    access-list 101 permit tcp 10.21.211.0 0.0.0.255 host 78.93.56.10 eq pop3
    access-list 101 permit tcp 10.21.211.0 0.0.0.255 host 78.93.56.10 eq smtp
    access-list 102 permit ip 10.21.211.0 0.0.0.255 any
    route-map nonat permit 10
    match ip address 101
    Thanks for your valuable time and cosiderations

    any1 can help me ?

  • Can too much memory lead to a kernel panic on a MacBook Pro? specs 2.4GHz intel core i7 16GB DDR3 RAM   late2011..My laptop began suffering from kernel panics 3 mos ago first noticed using public wifi. Gone thru apple support all the way to engineers

    Can too much RAM memory in a late 2011 model macbook pro lead to kernel panic? That is what I was told by a senior supervisor from apple support who troubleshot this issue.First noticed this problem in Dec 2014 while using a private wifi at a relative's home. Did not occur again until Feb1 using a public wifi at a hotel. Never happened on my private wifi network until last night  attempting to use airplay. ( have used airplay before without issue). Late 2011 MacBook Pro running 10.9.5; 2.4 GHz Intel core i7, 16 GB DDR3,AMD Radeon HD 6770m 1024 MB graphic card.  The laptop came with 8GB RAM and I installed 8 GB about 2 years ago for some reason I cannot remember... probably because I thought the system was slowing down a little. I know that sounds silly. I do not run multiple programs at a time except I leave 6-8 website tabs open simultaneously. I don't photo or video edit.  I would describe my use as "light"  based on reading these blogs.I had purchased apple support and spent hours on the phone with them in early Feb moving up through support  and senior support to sending logs to the "engineers." Of course lots of things were done some of which I am sorry to report I cannot recall their technical definitions. Deleted  3rd party apps/programs; re-worked start up menu; re-installed operating system; reset " this, that and the other" using acrobatic simultaneous key strokes both in and out of safe mode..Anyway the results from the engineers came back and they suggested that if it happened again I was to remove the 8GB of RAM I had installed as the system was getting confused as to which chip to use.( that is my interpretation of what was said..prob dumbed down for me)...Anyway 1 day after these pronouncements came down I read that Apple had agreed to fix  graphics cards in some late model 2011 MBPs. I felt this was unlikely to be the issue  given all that had been done including an extended hardware test but called the Senior Support Supervisor I was working with to ask him to make sure. He never phoned me back. Should I go to the trouble of removing 8GB of RAM from my laptop? Of course I will try it as the alternative is a new computer.Blogs read that this model can support 16GB but Apple didn't test for it. Senior Supervisor claims this is my trouble.  Does that make sense?  Not to me....but it is clear to all my level of knowledge.  Can a malfunctioning graphics card be missed by an extended hardware test? I appreciate comments.

    The RAM needs specs as shown below.
    Maximum Memory
    16 GB (Actual) 8 GB (Apple)
    Memory Slots
    2 - 204-pin PC-10600 (1333 MHz) DDR3 SO-DIMM

Maybe you are looking for

  • Camera RAW image support for Pentax K100D

    Hi, Firstly, let me just say I have a MacBook Pro which came preloaded with Tiger. A month or so ago I upgraded to Leopard and I have applied all the available Apple software update. I recently got a Pentax K100D digital SLR camera capable of taking

  • Part 2: Flat files and Business Contents: Any issues with this scenario?

    I will appreciate some clarification on the some points made in response to my previous post "Flat files and Business Contents: Any issues with this scenario?" 1. " ...you’d better analyze those cubes for data redundancy and presence of data you’ll n

  • How does one connect to an Oracle Database using OO4O as sysdba using VB 6?

    Hi, Can any one give suggestion to connect an Oracle Database using OO4O as sysdba using VB 6.0. Generally it supports only database, userid/password only. For Eg: Option Explicit Dim m_oraSession As Object Dim m_oraDatabase As Object Private Sub Com

  • 11g Declarative Components

    I have developed a Declarative component. Imported it into another project. I am now able to drag this component onto a jspx UIX page. One of the attributes I exposed was a datacontrol for binding to a tree component of the Declarative component. How

  • Copa - Value feild amount Adjustment

    Hello All, we have created some value feilds based on some Cost Elements groups in CO-PA now we have to change the Cost elements  in that group and need to check the past data with the changed values of current cost elements. Is there any T.Code by w