Ray-Trace not working on a 3D object

I created a model in Google Sketchup, mapping photo textures to some surfaces to create certain textures. When I imported it into Photoshop (in DAE format), Photoshop shows the mapped photo textures no problem, but when I go to ray-trace the model, it starts and then stops right away without ray-tracing. I've rendered lots of 3D models from Sketchup before and never had this issue, although, I haven't tried importing a model that already had photo textures mapped before, which is why I made mention of that.
I'm using Photoshop CS5 Extended. (Not 5.5)
Does anyone know why it would be doing this? Are there settings I need to change, or just a glitch with the particular model file?
Here's the model:
The dashboard (made up of a group of floating flat surfaces made to look like holographic controls) is all photo-textures. This is a screenshot taken directly from Photoshop, so you can see they're appearing fine in Interactive quality.

I do that dmennenoh, on contentLoaderInfo COMPLETE EVENT i smooth the bitmap in the same way, it even says trace(bitmap.smoothing) true.
I kind've nailed down the problem. It comes from the good old AS3 3D API. You know how when an object has 3d propertis applied to it it creates a matrix3D for it. Well on a picture like this one, that has small 1pixel patterns on it, when the matrix3D != null the image looks like hell even with smoothing = true.
I returned the image's rotationY to 0 and still look fuzzy. Than i also made matrix3D = null. And now the image look fine. So the problem is from the matrix3D or the 3D API itself. There's not much of a solution to this problem.
The image is also scaled down from a big image. You know that if you scale down an image that has patterns on it without smoothing applied to it, it look much like my image. Thus when it's a 3D object the smoothing property isn't taken into account. So every time you use an image with patterns and rotate it or move it on Z it will look much like my image.
I found a solution though. If the image is almost or the size of the desired dimension it will not look fuzzy. My image is a 1680x1050 reduced down to 610x380. And it looks fuzzy even with smoothing=true if it's a 3d object. After I resized my image to 610x380 in Irfanview it looks cool.
Hope I didn't bored you to death with my long explanation.
Cheers.

Similar Messages

  • Blue ray disc not working in HP laptop

    Hi,
    I recently bought a HP laptop with HD and Blue ray.
    It was working fine till last month.
    I bought a new LCD TV and i tired to connect it with my laptop.
    And i tried to play my blue ray disc.
    It was not working.I don know wat the problem could be.
    Please anyone help me..
    Iam stuck up with this thing.
    I tried the following things:
    1. I updated the Media smart stuff..
    2. I reinstalled and installed the Media smart itself.
    But still the system says " please insert disc"
    It cant read the disc.but when i played normal DVD's its working fine.
    Only blue ray its not working.
    So please some one help me
    Thanks,
    DJ

    Since this is a desktop computer, I would recommend posting this in the desktop forums for better coverage since this is the notebook forums.
    -------------How do I give Kudos? | How do I mark a post as Solved? --------------------------------------------------------

  • Dynamic NAT ASA 8.4 Packet Tracer not working

    Hi guys,
    I've tried to ping and go to a site from 192.168.1.6 to 10.10.10.12, but it's not working. I've followed a couple dynamic NAT tutorials, but I can't figure out what I'm missing. The config is below, and I'd appreciate any help.
    Thanks!
    ASA Version 8.4(2)
    hostname ciscoasa
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.2 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 10.10.10.2 255.0.0.0
    object network inside-subnet
    subnet 192.168.1.0 255.255.255.0
    object network inside-subnet
    nat (inside,outside) dynamic interface
    telnet timeout 5
    ssh timeout 5
    dhcpd address 192.168.1.5-192.168.1.35 inside
    dhcpd auto_config outside

    Thanks guys. I'm one step closer. I can ping from 192.168.1.0 to 10.0.0.0, but I can't open a webpage. I try visiting 10.0.0.6/index.html in packet tracer and get a "Request time out" message. I tried to mirror the ACL for www, but it's not working. 
    Does anyone have a suggestion? My updated config is below.
    Thanks!
    ASA Version 8.4(2)
    hostname ciscoasa
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 10.0.0.1 255.0.0.0
    object network inside-subnet
    subnet 192.168.1.0 255.255.255.0
    object network outside-subnet
    subnet 10.0.0.0 255.0.0.0
    access-list TEST extended permit icmp any any echo-reply
    access-list TEST extended permit tcp any any eq www
    access-list http extended permit tcp any any eq www
    access-list http2 extended permit udp any any eq www
    access-group TEST in interface outside
    object network inside-subnet
    nat (inside,outside) dynamic interface
    telnet timeout 5
    ssh timeout 5
    dhcpd auto_config outside
    dhcpd address 192.168.1.5-192.168.1.35 inside
    dhcpd enable inside

  • Ray tracing not working

    I get the 'Out of paged mapped memory' when I try to make 3D titles.
    IMac 2011 - the 6970 graphics card - 16Gb RAM
    Could this be yet another incompatibility between CS6 and the 2011 Imac (ie. the 6970 card which Adobe refuse to support)?
    Thanks in anticipation of a fix!!

    Hi Todd,,
    When I try to change the Renderer pull down top right of the composition window to Ray-Traced 3D, the composition settings window opens on the Advanced tab and when I change the Renderer pull down to Ray-Traced I get the following error message in a window headed (5070::0):
    After Effects error: Ray-traced 3D: Out of paged mapped memory for ray tracer. (5070::0)
    Screen shot attached.
    To answer those questions:
    version: 11.0.1.12
    OSX 10.7.5
    ProRes 422(HQ) 1920 x 1080 23.98fps
    I am trying to make a title that I have applied via 'Track Camera' into a 3D one. This has never worked.
    Other software running is Premiere CS6
    No 3rd party effects
    2011 Imac 3.4GHz i7, 16Gb RAM, 6970 Graphics card, 4 core. One 6Tb Thunderbolt hard drive connected (although working of internal drives at this time)
    No 3rd party I/O stuff
    Not using Render Multiple frames ......

  • Trace not working when create air app in flash cs6

    hi
    when i compile air app in flash cs6 , trace function dont workk and flash cs6 dispatch error with this title: test movie lunch failed, please help me

    yeah, that happened to me, is not a compilation error is a popup that says "test lunch movie failed". I usually happened when the machine is saturated memory, and does not work well until after restart 

  • Encore cs 5.1 blu ray chapter not working.....

    I've a tone of problems with this version.  Encore showing error codes 14, 25.....Some of the chapters working fine but others not. I've tried several ways to solve the issues but no hope. It seems you need full knowledge of blu ray theories to burn a blu ray!!!!  

    HDV&S wrote:
    I'm using windows 7 on laptop with i7 processor and nvidia GTS 360M display, External 1 TB HDD through SATA cable.
    Original shot was on HDV 60i with multiple Sony cameras and did the multicam edit. Converted to H264 with PCM audio with premiere CS 5.5, used VBR 2 pass everthing else left as defaut settings. Rendering took almost 21 hrs to generate  2:18 hr. video .m4v and .wav files (file size 17.7 gb).
    When I bring these videos as timeline(took ~20min to load files.) into the Encore with all the menus(created in photoshop with buttons and res. 1440 X 1080 to match with other assets ), some of the chapters not working on the preview window and Encore transcoded the whole files took another ~10 hrs!
    Is there any better and faster workflow to complete the project ?
    note: I used the cineform avi for multicam editing in premiere pro with the same settings (HDV 29.97).
    Okay, we are starting to make progress, but why are you shooting in HDV? That is a lossy system using non-sqyuare pixels so the whole thing is effectively getting converted. No wonder it took 21 hours and it looks to me as if you exported to the wrong settings - .m4v is regular .264, not BluRay. See Stan's suggestion.
    We still need to see the exact error messages - it looks likely you are out of HDD space. Remember that Premiere & Encore use 32-bit float audio temp files, and the media cache databases will be enormous.....how much HDD free is remaining?

  • Trace() not working in component

    How do you get trace() to work from within a component
    script?

    Not sure what you mean.. Perhaps you could adapt the code
    below for an
    example?
    #initclip
    trace("HELLO");
    #endinitclip
    Thanks
    On 10/7/06 21:26, in article
    e8ud6g$6on$[email protected], "Andreq85"
    <[email protected]> wrote:
    > ...it work well for me..
    >
    >
    > If you try to do a trace for the livepreview (when
    authoring) ...it will never
    > fire...
    >
    > but if you do a trace in the constructor function it
    work...

  • Trace not working flex

    I have come to a point where I need to use trace. Well, it is not working. I enter "Debug" mode/perspective and have the following, but nothing gets traced. First time I ever use trace in flex, have used it in Flash plenty of times.
    <s:View xmlns:fx="http://ns.adobe.com/mxml/2009"
            xmlns:s="library://ns.adobe.com/flex/spark" title="TestView"
            creationComplete="init()">
    private function init():void{
              trace("working");
    Thanks

    I have gotten this working. Had to a a .cfg file.

  • ICI trace not working

    Hi Guys
    We are working on CRM 4.0 SP11. Currently we are integrating with third party CTI vendor called Interactive Intelligence.
    Currently SAP is sending the messages and Interactive Intelligence is receiving them. The Interactive Intelligence guys are saying that the format of messages is wrong. So they are sending an exception to SAP system.
    To check these messages, we have switched on the ICI trace. But the ICI trace is not working. We have switched the CRM tracing ON. User Parameter CRM_ICI_TRACELEVEL has been set to XXX However when viewing the trace files from transaction code CRM_ICI_TRACE no values are returned.
    Any help would be highly appreciated.
    Regards
    Hari

    We need to use SOAP setting for ICI trace to be updated.

  • Trace not working in air / as3

    Hi, this may be something obvious but after installing adobe
    air, trace no longer works to my output window.
    I've checked the publish settings and 'omit traces' is
    unchecked.
    thanks

    Hi Trigon_15
    Same thing happend to me, suddenly trace stopt working, some sort of bug i believe
    how it occured i don't know, if added a new SDK, all worked perfect, 2 days later, it just
    stopped tracing.
    How i solved it?
    i've added the compiler argument (-compiler.debug=true) to the Compiler options of the project.
    In my case it's tracing again
    Hopes it will help you to!
    Regards,
    Marc
    ps. i'm using Flash Builder 4 with Flex SDK 4.1

  • Blue ray drive not working all of a sudden and not reading any discs

    I am using hp hdx 18 laptop which is a few years old and it was working fine until recently i found that the drive doesn't read discs anymore but the device manager shows it's fine and it tries to read by spinning and making noise and then stop
    I tried to boot the machine from dvd in setup but it will just go straight to HDD bootup.   
    is it busted?  just wondering what I can do to see if there's anything I can do before getting an external drive
    thanks
    donald

    It could have failed as suppected.  When you tried to boot to a DVD or Restore disk, did you remember to change the boot order to DVD/CD first device?
    The drive is normally a replaceable device but an external device should work OK, too.
    {---------- Please click the "Thumbs Up" to say thanks for helping.
    Please click "Accept As Solution" if my help has solved your problem. ----------}
    This is a user supported forum. I am a volunteer and I do not work for HP.

  • Air.trace() not working

    Hi all,
    Someone had a similar problem here: http://forums.adobe.com/thread/750219?tstart=0  They managed to solve it, I started adding to post but thought it best to start a brand new post.
    I've tried what they've suggested and made a file called mm.cfg in my %HomeDrive%%HomePath% directory (c:\users\james) the contents of which are:
         ErrorReportingEnable=1
         TraceOutputFileEnable=1
         TraceOutputFileName=c:\logs\flashlogs.txt
         MaxWarnings=50
    but I still don't get a log file from air.trace().  Though in C:\Users\James\AppData\Roaming\Macromedia\Flash Player  there's a file flashlog.txt with:
         Warning: Not a known player download type, app:/HelloWorld.html
    I'm running Vista and I'm using AIRSDK 2.5.  I call my hello world  application from the command prompt with " adl HelloWorld-app.xml "  I  get a window of correct dimensions with " Hello World! " as expected, but  no console message.  What am I doing wrong please?  I've been looking  for about a day now at how to get the air.trace messages but neither  those nor the introspector statements work.
    Thank you!!
    James
    The  4 files are in:
    C:\AIRHelloWorld
    The 4 files are:
    HelloWorld-app.xml
    HelloWorld.html
    AIRAliases.js
    AIRIntrospector.js
    My  code for HelloWorld-app.xml and HelloWorld.html is below.   AIRAliases.js and AIRIntrospector.js  are copied straight from AIRSDK
    HelloWorld-app.xml
    <!-- Tutorial at: http://help.adobe.com/en_US/air/build/WS5b3ccc516d4fbf351e63e3d118666ade46-7ecc.html -->
    <application xmlns="http://ns.adobe.com/air/application/2.5">
        <id>examples.html.HelloWorld</id>   
        <versionNumber>0.1</versionNumber>   
        <filename>HelloWorld</filename>
        <initialWindow>
            <content>HelloWorld.html</content>
            <visible>true</visible>
            <width>240</width>
            <height>320</height>
        </initialWindow>
    </application>
    <!-- To RUN AND TEST the application get a console window (type cmd into search box of Windows vista)
    type:
    cd c:\AIRHelloWorld
    When you have it in the directory of "c:\AIRHelloWorld" then type:
    adl HelloWorld-app.xml
    You'll get a window showing the app and also apparently the console window displays the
    message resulting from the air.trace() call in the html, but I never see this -->
    HelloWorld.html
    <html>
    <head>
        <title>Hello World</title>
        <!-- In the <head> section of the HTML, import the AIRAliases.js file: -->
        <script src="AIRAliases.js" type="text/javascript"></script>
        <script type="text/javascript" src="AIRIntrospector.js"></script>
        <!-- JavaScript function to handle the onLoad event:  -->
        <script type="text/javascript">
        function appLoad(){
            air.trace("Hello World - debug comment");  /*The appLoad() function simply calls
               the air.trace() function. The trace message print to the command
               console when you run the application using ADL. Trace statements
               can be very useful for debugging.*/
            air.Introspector.Console.log("Hello World - Introspector debug comment");
        </script>
    </head>
    <body on load="appLoad()">
        <h1>Hello World!</h1>
    </body>
    </html>

    Hi Chris, on sdk 2.5, actually, also the Introspector doesn't seem to work. Tried:
    <html>
        <head>
            <title>Source Viewer Sample</title>
            <script type="text/javascript" src="js/AIRAliases.js"></script>
            <script type="text/javascript" src="js/AIRIntrospector.js"></script>
            <script type="text/javascript">
                function logBtn()
                    var button1 = document.getElementById("btn1");
                    air.Introspector.Console.log(button1);
            </script>
        </head>
        <body>
            <p>Click to view the button object in the Console.</p>
            <input type="button" id="btn1"
                onclick="logBtn()"
                value="Log" />
        </body>
    </html>
    UPDATE: I didn't realize it was a different window that appears behind. It works then!

  • Getfilebyserverrelativeurl not working in Javascript client object model

    Hi,
    I am using the "getfilebyserverrelativeurl" to verify if the file exists. But it does not seem to work.
    I am using Javascript client object model.
    Below is the code used:
    //ImageName = "test1.jpg" . This file does not exist in the below location
    var url = oweb.get_url() + "/Lists/LibraryName/folder1/" + ImageName;
    try {
    var fileUrl = oweb.get_serverRelativeUrl() + "/Lists/LibraryName/folder1/" + ImageName;
    oweb.getFileByServerRelativeUrl(fileUrl);
    window.location = url;
    catch (e) {
    alert("File does not exist.");
    I am not getting any errors in javascript, but the alert is not showing up.
    The file does not exist in the folder, so I am expecting the alert, but in-turn it redirects to "Page not found" OOB page.
    How to fix this?
    Thanks

    Hello,
    I see a few odd things with that code.
    Try it with the following changes and see if it makes a difference:
    // declared globally
    var fileName= "";
    var fileurl = "";
    function downloadImage(){
    fileName = "image1.zip";
    fileurl = SP.ClientContext.get_current().get_url() + "/LibraryName/foldername/" + fileName;
    var clientcontext = new SP.ClientContext.get_current()
    var oweb = clientcontext.get_web();
    var ofile = oweb.getFileByServerRelativeUrl(fileurl);
    clientcontext.load(ofile);
    clientcontext.executeQueryAsync(Function.createDelegate(this, this.RenderDownloadfilesOnSuccess), Function.createDelegate(this, this.RenderDownloadfilesOnFailure));
    function RenderDownloadfilesOnSuccess() {
    window.location = fileurl;
    function RenderDownloadfilesOnFailure(sender, args) {
    alert(fileName + " does not exist.");
    Which version of Internet Explorer are you using for debugging? The F12 developer tools will allow you to debug JavaScript and "step out" of executing JavaScript code so you can trace the problem back to where it originates in your own code
    instead of debugging the resulting errors that crop up in the built-in stuff (like MicrosoftAjax.js)

  • OBN not working in portal 'missing Object ID' error

    Hi,
    We have implemented MSS though the portal, and am having problems with the org profile and position profile firing up via OBN from employee profile.
    It works fine though NWBC, but for some reason not in the portal.
    I get an ‘missing Object ID’ error.
    Anyone got any ideas?
    Thanks

    Please don't doublepost the question over all places. Stick to one topic. Continue there: [http://forum.java.sun.com/thread.jspa?threadID=5301671]

  • Search spec not working for Multiple Business Object in Siebel

    Hi,
    In Siebel Applicaiton Specified Search spec in Administration - BI Reports->Standard Templates-> integtion Object. the Specified Search spec is not returning particular record. It's seems returning all records. below we are using search spec as [Row Id] = [Quote.BillingaccountId].
    for testing purpose specified how code value : [Row Id]='1-wXR8'(some BillingaccountId in our application from Quote Object).
    Does anybody worked on Searchspec for MultipleBusienssObjects and is the search spec syntax is correct.
    Thanks
    -Chakri

    Hi Ravi..
    thanks for replay. with SR you provided getting no search results. If you have already can you please email me at [email protected]
    And also mention format as IO1.Field1=IO2.Field2. Need to give IO.fieldname i.e Integration Object Name .Field name or IC.Fieldname.. Can you please correct.
    Thanks
    -Chakri

Maybe you are looking for

  • Setup E-mail to yourself

    Hi Guys: How to setup a printer and How to setup en e-mail option in SAP , Example I Saved a Purchase order and I want to E-mail the Purchase order to myself Thanks Sweth

  • Load-balancing in the same IP subnet

    Can I use load-balancing in the same IP subnet? I have the servers and client in the same IP subnet. I'd like to load-balance client traffic to server traffic. I also need to load balance traffic between servers. Is possible to configure it only in o

  • Call  Transaction of CO11N

    Hi Gurus,   I am doing back ground job of call transaction for CO11N transaction when i am passing the values the yield value is getting updated but when i try to go to Goods Movements , based on yield value ( 1row qty) automaticallu 2nd qty & 3rd qt

  • Contact Form positioning, cells mis-aligned?

    I built a contact form and put it up at http://www.newood.com/catreq.htm For some reason, a couple of the cells that hold form fields are not aligned correctly, both in IE and in Firefox. Is there someone here that could check the code for me and mig

  • Hotsync trying to connect and eventually shutting my phone down

    In less than a year, I have had a Palm Centro and a Palm 680. Both phones suddenly started Hotsyncing without me prompting them to do so. My wife liked her centro so well that we decided to just replace it with the 680, and within two months the same