Dynamic NAT ASA 8.4 Packet Tracer not working

Hi guys,
I've tried to ping and go to a site from 192.168.1.6 to 10.10.10.12, but it's not working. I've followed a couple dynamic NAT tutorials, but I can't figure out what I'm missing. The config is below, and I'd appreciate any help.
Thanks!
ASA Version 8.4(2)
hostname ciscoasa
names
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.2 255.255.255.0
interface Vlan2
nameif outside
security-level 0
ip address 10.10.10.2 255.0.0.0
object network inside-subnet
subnet 192.168.1.0 255.255.255.0
object network inside-subnet
nat (inside,outside) dynamic interface
telnet timeout 5
ssh timeout 5
dhcpd address 192.168.1.5-192.168.1.35 inside
dhcpd auto_config outside

Thanks guys. I'm one step closer. I can ping from 192.168.1.0 to 10.0.0.0, but I can't open a webpage. I try visiting 10.0.0.6/index.html in packet tracer and get a "Request time out" message. I tried to mirror the ACL for www, but it's not working. 
Does anyone have a suggestion? My updated config is below.
Thanks!
ASA Version 8.4(2)
hostname ciscoasa
names
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
interface Vlan2
nameif outside
security-level 0
ip address 10.0.0.1 255.0.0.0
object network inside-subnet
subnet 192.168.1.0 255.255.255.0
object network outside-subnet
subnet 10.0.0.0 255.0.0.0
access-list TEST extended permit icmp any any echo-reply
access-list TEST extended permit tcp any any eq www
access-list http extended permit tcp any any eq www
access-list http2 extended permit udp any any eq www
access-group TEST in interface outside
object network inside-subnet
nat (inside,outside) dynamic interface
telnet timeout 5
ssh timeout 5
dhcpd auto_config outside
dhcpd address 192.168.1.5-192.168.1.35 inside
dhcpd enable inside

Similar Messages

  • ASA-5505 Site-to-Site Not Working

    I am somewhat new to Cisco but to do have some experience. I am trying to connect two ASA 5505's together via site-to-site VPN. They are configured with public IPs and all other services are working. I have used the VPN wizard on both boxes successfully but the tunnels are not working. The two devices are on the Comcast network. Any help would be appreacited.
    Site A: ASA 5505 w/50 User license
    Site B: ASA 5505 w/10 User license
    Site A Config:
    ASA Version 8.2(5)
    hostname *********************
    enable password 6.De4e7UzES9wBPg encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.100.10 Web_Server
    name 10.0.6.0 Ghost_Flower_Inside
    name 10.0.5.0 San_Mateo_Inside
    name 10.0.5.100 Any_Connect_100
    name 10.0.5.101 Any_Connect_101
    name 10.0.5.102 Any_Connect_102
    name 10.0.5.103 Any_Connect_103
    name 10.0.5.104 Any_Connect_104
    name 10.0.5.105 Any_Connect_105
    name 10.0.5.106 Any_Connect_106
    name 10.0.5.107 Any_Connect_107
    name 10.0.5.108 Any_Connect_108
    name 10.0.5.109 Any_Connect_109
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    switchport access vlan 12
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.5.201 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 173.10.XXX.XXX 255.255.255.252
    interface Vlan12
    no forward interface Vlan1
    nameif dmz
    security-level 50
    ip address 192.168.100.1 255.255.255.0
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 75.75.75.75
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group network Any_Connect_DHCP
    network-object host Any_Connect_100
    network-object host Any_Connect_101
    network-object host Any_Connect_102
    network-object host Any_Connect_103
    network-object host Any_Connect_104
    network-object host Any_Connect_105
    network-object host Any_Connect_106
    network-object host Any_Connect_107
    network-object host Any_Connect_108
    network-object host Any_Connect_109
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list outside_access_in extended permit tcp any interface outside eq ssh
    access-list outside_1_cryptomap extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip object-group Any_Connect_DHCP any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    ip local pool AnyConnectDHCPPool Any_Connect_100-10.0.5.110 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (dmz) 1 192.168.100.2 netmask 255.255.255.255
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (dmz,outside) tcp interface www Web_Server www netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 173.10.XXX.XXX 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 10.0.1.0 255.255.255.0 inside
    http 10.1.10.0 255.255.255.0 outside
    http San_Mateo_Inside 255.255.255.255 inside
    http San_Mateo_Inside 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 173.12.XXX.XXX
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    vpn-sessiondb max-webvpn-session-limit 10
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh 10.0.1.0 255.255.255.0 inside
    ssh San_Mateo_Inside 255.255.255.0 inside
    ssh 10.1.10.0 255.255.255.0 outside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 10.0.5.10-10.0.5.30 inside
    dhcpd dns 75.75.75.75 75.75.76.76 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    anyconnect-essentials
    svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 1 regex "Intel Mac OS X"
    svc profiles CATS disk0:/cats.xml
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    dns-server value 75.75.75.75
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    webvpn
      svc profiles value CATS
    username user1 password tTq7bIZ.C4x0j.qv encrypted privilege 15
    username ********* password sPxon1E6hTszm7Ko encrypted privilege 15
    tunnel-group 173.12.XXX.XXX type ipsec-l2l
    tunnel-group 173.12.XXX.XXX ipsec-attributes
    pre-shared-key *****
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:1751532c3624a6c2eec3c1ae0c31fe03
    : end
    Site B:
    ASA Version 8.2(5)
    hostname ***************
    enable password 6.De4e7UzES9wBPg encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.100.10 Web_Server
    name 10.0.6.0 Ghost_Flower_Inside
    name 10.0.5.0 San_Mateo_Inside
    name 10.0.5.100 Any_Connect_100
    name 10.0.5.101 Any_Connect_101
    name 10.0.5.102 Any_Connect_102
    name 10.0.5.103 Any_Connect_103
    name 10.0.5.104 Any_Connect_104
    name 10.0.5.105 Any_Connect_105
    name 10.0.5.106 Any_Connect_106
    name 10.0.5.107 Any_Connect_107
    name 10.0.5.108 Any_Connect_108
    name 10.0.5.109 Any_Connect_109
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    switchport access vlan 12
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.5.201 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 173.10.XXX.XXX 255.255.255.252
    interface Vlan12
    no forward interface Vlan1
    nameif dmz
    security-level 50
    ip address 192.168.100.1 255.255.255.0
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 75.75.75.75
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group network Any_Connect_DHCP
    network-object host Any_Connect_100
    network-object host Any_Connect_101
    network-object host Any_Connect_102
    network-object host Any_Connect_103
    network-object host Any_Connect_104
    network-object host Any_Connect_105
    network-object host Any_Connect_106
    network-object host Any_Connect_107
    network-object host Any_Connect_108
    network-object host Any_Connect_109
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list outside_access_in extended permit tcp any interface outside eq ssh
    access-list outside_1_cryptomap extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    access-list inside_nat0_outbound extended permit ip object-group Any_Connect_DHCP any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    ip local pool AnyConnectDHCPPool Any_Connect_100-10.0.5.110 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (dmz) 1 192.168.100.2 netmask 255.255.255.255
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (dmz,outside) tcp interface www Web_Server www netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 173.10.242.182 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    http 10.0.1.0 255.255.255.0 inside
    http 10.1.10.0 255.255.255.0 outside
    http San_Mateo_Inside 255.255.255.255 inside
    http San_Mateo_Inside 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 173.12.XXX.XXX
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    vpn-sessiondb max-webvpn-session-limit 10
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh 10.0.1.0 255.255.255.0 inside
    ssh San_Mateo_Inside 255.255.255.0 inside
    ssh 10.1.10.0 255.255.255.0 outside
    ssh 0.0.0.0 0.0.0.0 outside
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 10.0.5.10-10.0.5.30 inside
    dhcpd dns 75.75.75.75 75.75.76.76 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    anyconnect-essentials
    svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 1 regex "Intel Mac OS X"
    svc profiles CATS disk0:/cats.xml
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    dns-server value 75.75.75.75
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    webvpn
      svc profiles value CATS
    username ************** password sPxon1E6hTszm7Ko encrypted privilege 15
    tunnel-group 173.12.XXX.XXX type ipsec-l2l
    tunnel-group 173.12.XXX.XXX ipsec-attributes
    pre-shared-key *****
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:1751532c3624a6c2eec3c1ae0c31fe03
    : end

    Hi Kevin,
    Both the sides have IP address of 173.10.XXX.XXX  on the respective Outside interfaces and you have configured the peers for 173.12.X.X.
    Please ensure the correct IP addresses for VPN peers are configured , via the following command:
    crypto map outside_map 1 set peer X.X.X.X
    e.g. If you have 173.10.X.X on Site X and 173.12.X.X on Site Y , then
    On Site X, peer would be
    crypto map outside_map 1 set peer 173.12.X.X
    and the tunnel-group will be
    tunnel-group 173.12.XXX.XXX type ipsec-l2l
    tunnel-group 173.12.XXX.XXX ipsec-attributes
    pre-shared-key *****
    On Site Y, peer would be
    crypto map outside_map 1 set peer 173.10.X.X
    and the tunnel-group will be
    tunnel-group 173.10.XXX.XXX type ipsec-l2l
    tunnel-group 173.10.XXX.XXX ipsec-attributes
    pre-shared-key *****
    Also , the nat exempt would be complimentary on each other i.e.
    On Site X,
    access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0
    On Site Y,
    access-list inside_nat0_outbound extended permit ip Ghost_Flower_Inside 255.255.255.0 San_Mateo_Inside 255.255.255.0
    Hope that helps.
    Regards,
    Dinesh Moudgil

  • Dynamic port configured for FILE adapter is not working

    Hi,
    I have a simple dynamic port in an orchestration that writes a file to a file location. Here is the configuration
    ================
    FilePort(Microsoft.XLANGs.BaseTypes.Address) = "FILE://c:\\TestFolder\\Out";
    FilePort(Microsoft.XLANGs.BaseTypes.TransportType) = "FILE";
    ================
    When I run this orchestration, the dynamic port does not write the file to the folder, however I does not show any error either. It is always in "Ready to Run" state where the message is "Queued Awaiting".
    I tried all sorts of combinations like FILE:// FILE:\\ File: file:// file:\\ etc... and also without the moniker, just c:\.... I get the same problem.
    when I use a static port(subscribed to the same message) it works fine. When I use a static port ALONGWITH this dynamic port then both works fine !!! I receive 2 files.
    but when I use only dynamic port it does not work!!
    Anybody knows how to solve it.
    THANKS IN AVANCE
    PLEASE HELP
    Surya

    It could be becasue you 're not passing in the file name, Try something like this..
    SndPort_Dynamic(Microsoft.XLANGs.BaseTypes.Address)=@"file://C:\Test\Try\Out\Test1.xml";
    But even when you don't pass the file name, i was expecting the erro to be like:
    The FILE send adapter cannot open file C:\TestFolder\Out\ for writing.
    Details: The system cannot find the path specified.
    But try with File Name and restart the host instance after the change.
    Or use somehting like this:
    FilePort(Microsoft.XLANGs.BaseTypes.Address)=@"file://C:\Test\Try\Out\\%MessageID%.xml";
    FilePort(Microsoft.XLANGs.BaseTypes.TransportType) = "File";
    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

  • Trace not working when create air app in flash cs6

    hi
    when i compile air app in flash cs6 , trace function dont workk and flash cs6 dispatch error with this title: test movie lunch failed, please help me

    yeah, that happened to me, is not a compilation error is a popup that says "test lunch movie failed". I usually happened when the machine is saturated memory, and does not work well until after restart 

  • Trace() not working in component

    How do you get trace() to work from within a component
    script?

    Not sure what you mean.. Perhaps you could adapt the code
    below for an
    example?
    #initclip
    trace("HELLO");
    #endinitclip
    Thanks
    On 10/7/06 21:26, in article
    e8ud6g$6on$[email protected], "Andreq85"
    <[email protected]> wrote:
    > ...it work well for me..
    >
    >
    > If you try to do a trace for the livepreview (when
    authoring) ...it will never
    > fire...
    >
    > but if you do a trace in the constructor function it
    work...

  • Trace not working flex

    I have come to a point where I need to use trace. Well, it is not working. I enter "Debug" mode/perspective and have the following, but nothing gets traced. First time I ever use trace in flex, have used it in Flash plenty of times.
    <s:View xmlns:fx="http://ns.adobe.com/mxml/2009"
            xmlns:s="library://ns.adobe.com/flex/spark" title="TestView"
            creationComplete="init()">
    private function init():void{
              trace("working");
    Thanks

    I have gotten this working. Had to a a .cfg file.

  • ICI trace not working

    Hi Guys
    We are working on CRM 4.0 SP11. Currently we are integrating with third party CTI vendor called Interactive Intelligence.
    Currently SAP is sending the messages and Interactive Intelligence is receiving them. The Interactive Intelligence guys are saying that the format of messages is wrong. So they are sending an exception to SAP system.
    To check these messages, we have switched on the ICI trace. But the ICI trace is not working. We have switched the CRM tracing ON. User Parameter CRM_ICI_TRACELEVEL has been set to XXX However when viewing the trace files from transaction code CRM_ICI_TRACE no values are returned.
    Any help would be highly appreciated.
    Regards
    Hari

    We need to use SOAP setting for ICI trace to be updated.

  • Trace not working in air / as3

    Hi, this may be something obvious but after installing adobe
    air, trace no longer works to my output window.
    I've checked the publish settings and 'omit traces' is
    unchecked.
    thanks

    Hi Trigon_15
    Same thing happend to me, suddenly trace stopt working, some sort of bug i believe
    how it occured i don't know, if added a new SDK, all worked perfect, 2 days later, it just
    stopped tracing.
    How i solved it?
    i've added the compiler argument (-compiler.debug=true) to the Compiler options of the project.
    In my case it's tracing again
    Hopes it will help you to!
    Regards,
    Marc
    ps. i'm using Flash Builder 4 with Flex SDK 4.1

  • Dynamic action on text box change does not working

    i have a page with following components.
    a report that has and edit link.
    a text box to catch the primary key from report link when it is clicked
    a number of elements (text boxes, check boxes and LOVs) which are used as data entry form.
    Now my design is that user enter values save them and no sooner did they save, the report depicts new
    values. if user want to edit any record, they click on edit link and the data entry form elements
    should now bring all those values from DB on page. i m successful to pick primary key and bring
    it in a hidden text box and wrote a dynamic action on its change event that will bring values from
    DB and set all page elements. but but but.........the change event doesnt work. it only work
    when focus is lost from the text box...!! offcourse user wont want to click in that "hiddent" text
    box and then click some where else to bring values in page data entry form......
    help is humbly requested from forum or if any other solution approach is to be used easier than
    one i m using, would be appreciated.
    thanks in advance for reading my bore question :)

    bundles of thanks for reply. i m going to elaborate.
    1. My page no is 3.
    2. Hidden Item name is P3_EDIT_ACTIVITY_ID
    3. Data entry form, hidden item and the report are on the same page.
    4. on the edit link of report, i have used following settings.
        Target: Page in this application
         Page: 3
         and i set hidden item as follows......
         Item 1   P3_EDIT_ACTIVITY_ID         Value #ACTIVITY_ID#
       well, when i click the link on report it does bring Activity_Id in the hidden box (which is not yet hidden for debugging purpose)
    Next i wrote Dynamic action which fires on the change event of P3_EDIT_ACTIVITY_ID and run PL/SQL code with in it which is as follows
      declare
      Dept varchar(50);
    begin
       select my_dept into Dept from activity_main ACTIVITY_ID = :P3_EDIT_ACTIVITY_ID;
       :P3_Dept := :Dept;          (i did use :P3_Dept := Dept also but this wont work)
      insert into testdynamic (stamp) values (Dept);  (I did this to check whether correct value is brought from DB, yes it works correctly, correct Dept is being inserted in stamp column)
    end;
      i have created another true action to check when the dynamic action is fired. its very simple alert. and the problem is, it only fires when focus is lost from the P3_EDIT_ACTIVITY_ID. i mean, when u keep changing value inside the text box, nothing happens, when u go outside, the alert is fired and so the pl/sql procedure. but the line
        :P3_Dept := :Dept;       OR      :P3_Dept  := Dept;         arent working which is the actual requirement.
      I m not using set value here as i have to set a lot of values on page not one. further. plz let me get rid of this lost focus thing as i want the form to be populated with correct values related to P3_EDIT_ACTIVITY_ID as the user click on any edit_link in the report.
    Thanks for persistence. i hope i have provided all the details.
    looking forward.

  • Air.trace() not working

    Hi all,
    Someone had a similar problem here: http://forums.adobe.com/thread/750219?tstart=0  They managed to solve it, I started adding to post but thought it best to start a brand new post.
    I've tried what they've suggested and made a file called mm.cfg in my %HomeDrive%%HomePath% directory (c:\users\james) the contents of which are:
         ErrorReportingEnable=1
         TraceOutputFileEnable=1
         TraceOutputFileName=c:\logs\flashlogs.txt
         MaxWarnings=50
    but I still don't get a log file from air.trace().  Though in C:\Users\James\AppData\Roaming\Macromedia\Flash Player  there's a file flashlog.txt with:
         Warning: Not a known player download type, app:/HelloWorld.html
    I'm running Vista and I'm using AIRSDK 2.5.  I call my hello world  application from the command prompt with " adl HelloWorld-app.xml "  I  get a window of correct dimensions with " Hello World! " as expected, but  no console message.  What am I doing wrong please?  I've been looking  for about a day now at how to get the air.trace messages but neither  those nor the introspector statements work.
    Thank you!!
    James
    The  4 files are in:
    C:\AIRHelloWorld
    The 4 files are:
    HelloWorld-app.xml
    HelloWorld.html
    AIRAliases.js
    AIRIntrospector.js
    My  code for HelloWorld-app.xml and HelloWorld.html is below.   AIRAliases.js and AIRIntrospector.js  are copied straight from AIRSDK
    HelloWorld-app.xml
    <!-- Tutorial at: http://help.adobe.com/en_US/air/build/WS5b3ccc516d4fbf351e63e3d118666ade46-7ecc.html -->
    <application xmlns="http://ns.adobe.com/air/application/2.5">
        <id>examples.html.HelloWorld</id>   
        <versionNumber>0.1</versionNumber>   
        <filename>HelloWorld</filename>
        <initialWindow>
            <content>HelloWorld.html</content>
            <visible>true</visible>
            <width>240</width>
            <height>320</height>
        </initialWindow>
    </application>
    <!-- To RUN AND TEST the application get a console window (type cmd into search box of Windows vista)
    type:
    cd c:\AIRHelloWorld
    When you have it in the directory of "c:\AIRHelloWorld" then type:
    adl HelloWorld-app.xml
    You'll get a window showing the app and also apparently the console window displays the
    message resulting from the air.trace() call in the html, but I never see this -->
    HelloWorld.html
    <html>
    <head>
        <title>Hello World</title>
        <!-- In the <head> section of the HTML, import the AIRAliases.js file: -->
        <script src="AIRAliases.js" type="text/javascript"></script>
        <script type="text/javascript" src="AIRIntrospector.js"></script>
        <!-- JavaScript function to handle the onLoad event:  -->
        <script type="text/javascript">
        function appLoad(){
            air.trace("Hello World - debug comment");  /*The appLoad() function simply calls
               the air.trace() function. The trace message print to the command
               console when you run the application using ADL. Trace statements
               can be very useful for debugging.*/
            air.Introspector.Console.log("Hello World - Introspector debug comment");
        </script>
    </head>
    <body on load="appLoad()">
        <h1>Hello World!</h1>
    </body>
    </html>

    Hi Chris, on sdk 2.5, actually, also the Introspector doesn't seem to work. Tried:
    <html>
        <head>
            <title>Source Viewer Sample</title>
            <script type="text/javascript" src="js/AIRAliases.js"></script>
            <script type="text/javascript" src="js/AIRIntrospector.js"></script>
            <script type="text/javascript">
                function logBtn()
                    var button1 = document.getElementById("btn1");
                    air.Introspector.Console.log(button1);
            </script>
        </head>
        <body>
            <p>Click to view the button object in the Console.</p>
            <input type="button" id="btn1"
                onclick="logBtn()"
                value="Log" />
        </body>
    </html>
    UPDATE: I didn't realize it was a different window that appears behind. It works then!

  • Ray-Trace not working on a 3D object

    I created a model in Google Sketchup, mapping photo textures to some surfaces to create certain textures. When I imported it into Photoshop (in DAE format), Photoshop shows the mapped photo textures no problem, but when I go to ray-trace the model, it starts and then stops right away without ray-tracing. I've rendered lots of 3D models from Sketchup before and never had this issue, although, I haven't tried importing a model that already had photo textures mapped before, which is why I made mention of that.
    I'm using Photoshop CS5 Extended. (Not 5.5)
    Does anyone know why it would be doing this? Are there settings I need to change, or just a glitch with the particular model file?
    Here's the model:
    The dashboard (made up of a group of floating flat surfaces made to look like holographic controls) is all photo-textures. This is a screenshot taken directly from Photoshop, so you can see they're appearing fine in Interactive quality.

    I do that dmennenoh, on contentLoaderInfo COMPLETE EVENT i smooth the bitmap in the same way, it even says trace(bitmap.smoothing) true.
    I kind've nailed down the problem. It comes from the good old AS3 3D API. You know how when an object has 3d propertis applied to it it creates a matrix3D for it. Well on a picture like this one, that has small 1pixel patterns on it, when the matrix3D != null the image looks like hell even with smoothing = true.
    I returned the image's rotationY to 0 and still look fuzzy. Than i also made matrix3D = null. And now the image look fine. So the problem is from the matrix3D or the 3D API itself. There's not much of a solution to this problem.
    The image is also scaled down from a big image. You know that if you scale down an image that has patterns on it without smoothing applied to it, it look much like my image. Thus when it's a 3D object the smoothing property isn't taken into account. So every time you use an image with patterns and rotate it or move it on Z it will look much like my image.
    I found a solution though. If the image is almost or the size of the desired dimension it will not look fuzzy. My image is a 1680x1050 reduced down to 610x380. And it looks fuzzy even with smoothing=true if it's a 3d object. After I resized my image to 610x380 in Irfanview it looks cool.
    Hope I didn't bored you to death with my long explanation.
    Cheers.

  • Trace not working

    Hi ,
    I am using Adobe flash cs5. I used to create Air application on the publish settings.
    While i run the air application in side the Adobe flash cs5 it update the "Application Data\Macromedia\Flash Player\Logs\flashlog.txt"
    but once i compile them as .air packge, it didnt update the flashlog.txt.I want to see the trace when the .air application starts.Please guide me to debug the air application.
    Tool               : flash CS5
    Air version     : 2
    OS                 : Windows 7
    Note:
    When i google about it I got something like ADL to get the trace.Then i download the latest air sdk. But i am not aware how to link the "AdobeAIRSDK" with the flash cs5.

    Trace statements and debugging using the release app is not officially supported.  However, you can launch your app using ADL from a command prompt and the trace statements will appear.  Alterntativly, users have worked around this limitation using steps as described in this blog:
    http://backroom.bostonproductions.com/?p=902

  • Trace() not working with embedded SWFs created with Flash Builder

    I have just migrated to Flash Builder 4.5 with the 4.5.1 SDK.
    I have an application that loads a lot of child SWFs into it - some of which are created with Flash, some are created with Flash Builder.
    I am noticing now that my trace() statements that are called from within SWFs produced with Flash Builder that are loading as child SWFs into my main SWF are NOT appearing.  However, trace() statements called from within SWFs produced with Flash that are loading as child SWFs into my main SWF ARE appearing.
    This is an extremely major problem and has short-circuited my debugging/development.
    Any recommendations, workarounds, or suggestions?

    If the child SWFs were created by performing an "Export Release Build", then trace() statements would be omitted.
    You can control this by setting the -omit-trace-statements compiler argument (in Project properties -> Flex Compiler -> Additional Compiler Arguments).
    -Anirudh

  • Dynamic link from Premier to AE CS6 not working well

    Just downloaded CS6 2 days ago and today I tried converting a HDV video sequence with two titles on tracks 2 & 3 into an After Effects comp.
    So AE launched and all copied over but my two titles came over as black solids! So I deleted them then I right clicked on the 1440x1080 HDV video layer in the HDV comp and choose Track Camera, it spent some time anlayzing the video and then said "Layer size must match Composition"
    So seems to be some bugs in the whole dynamic link transfer system between premier pro and AE in CS6 ???

    Dynamic Link is designed to bring over footage items, but titles are created dynamically inside Premiere and do not exist as footage first.  As a result, I am not surprised they do not come into AE through the dynamic link.
    The best workflow is to start with the superior text manipulation inside After Effects.  You can get much more control and power from within AE.  If you aren't sure how to start working on text there, there are many, many excellent free tutorials at CreativeCow.net or paid instructional videos with Lynda.com or Video2Brain.com.
    Otherwise, do not bring the titles into AE - make any adjustments you want to make to your footage, and keep the titles separate.

  • Dynamic Link between Premire Pro and AE not working

    I've been having this issue where dynamic link is grayed out in the Premiere Pro menu, when i try to link a clip to AE. It's the same the other way round (i.e. AE to Premiere), and also the "Replace with After Effects Comp" is grayed out as well. Im using the CC version (Not CC 2014), so it should work?
    Thanks for your help!

    Hi Kevin,
    Thanks for your reply. I'm using CS6 (if that's what you mean by version - otherwise I think it's 7.0). I've never come across verifying the programs, how do I go about it?
    Thanks

Maybe you are looking for

  • Quotation Marks in Mail

    Just installed Lion and I'm getting some mail replies with my original note attached and something is wrong.  This is what quotation marks look like around the work Name.  What's up with this? \'Name\"

  • How to program a new tv into the remote control

    We just bought a new tv and need to change the remote control to the new tv.  How do I do that?

  • [solved] How to install Linux on the Fujitsu Scaleo Home Server 2205

    Hello! I am currently thinking about buying a Fujitsu Scaleo Home Server 2205. The according datasheet can be found here. The default installation includes Windows Home Server, which is why I have to find a way to install Linux on it (still thinking

  • Where is the 'hand' pan tool in preview

    Still can't find it! I'm also missing the 'zoom selection' tool. I hoped Mavericks would catch up on this- Seems like OSX devs think the only content of PDF might be text and over-size drawings and images are just not allowed. This is a pain in the a

  • Help! I just got it, is it broke

    I just got mine today and plugged it in for its first charge. I want to import music from other folders, but when I click on any of the folders in the import wizard, nothing happens. I cant "ADD" anything!!! What is going on? Can you not do this whil