Redirect port 80 to 8080

Hey I have created a simple http server, so when i type
> curl http://localhost:8080/
I give me the respons:
> Hello World
now i want the same to happen when I type:
> curl http://localhost:80/
I could do that by changen the port that the http server is lisining on but it will require that i run it as a super user and i don't want that.
I have tryed to use the ipfw command (I have vey limited knowleged about it):
> ipfw add 100 fwd 127.0.0.1,8800 tcp from any to any 80 in
it then says:
> 00100 fwd 127.0.0.1,8800 tcp from any to any dst-port 80 in
I look at the list:
> ipfw -d -e -t -a list
it says:
> 00100   1     64 Thu Aug  4 14:47:51 2011 fwd 127.0.0.1,8800 tcp from any to any dst-port 80 in
> 65535 188 33853 Thu Aug  4 14:45:39 2011 allow ip from any to any
But when i try to get a respons from my http server:
> curl http://localhost:80/
It says:
> curl: (7) couldn't connect to host
I try to restart my computer and check the list again:
> ipfw -d -e -t -a list
It says:
> 65535 464 111936 Thu Aug  4 14:48:39 2011 allow ip from any to any
So somehow the rule has been removed.
What can i do to redirect port 80 to 8080,

I should have writen
sudo ipfw add 100 fwd 127.0.0.1,8080 tcp from any to me 80
I belive the important diffrent is the change from any to me in the last part.
And rules applyed to ipfw will be rested after restarting,

Similar Messages

  • Redirecting Port 80 to 8080

    Hello,
    Below is my configuration for redirecting http://apps.domain.local to http://apps.domain.local:8080. Please let me know if I am on the right track.
    Thanks,
    rserver redirect REDIRECT_TO_8080
    description SAP BO Redirect RServer from 80 to 8080
    webhost-redirection http://%h%p:8080 301
    inservice
    serverfarm redirect SF_REDIRECT_8080
    description SAP BO Redirect RServer from 80 to 8080
    rserver REDIRECT_TO_8080
    inservice
    class-map match-all VIP_SAP_BO_8080
    2 match virtual-address 10.1.0.99 tcp eq 8080
    class-map match-all VIP_SAP_BO_80
    2 match virtual-address 10.1.0.99 tcp eq 80
    policy-map type loadbalance first-match PM_REDIRECT_8080
    class class-default
    serverfarm SF_REDIRECT_8080
    policy-map type loadbalance first-match PM_LB_SAP_BO
    description Load Balance Policy for SAP Business Objects
    class class-default
    sticky-serverfarm IP_STICKY_SAP_BO
    policy-map multi-match PM_MULTI_MATCH_LB
    description Load Balancing Service Policy 1
    class VIP_VIP_SAP_BO_80
    loadbalance vip inservice
    loadbalance policy PM_REDIRECT_8080
    loadbalance vip icmp-reply active
    class VIP_SAP_BO_8080
    loadbalance vip inservice
    loadbalance policy PM_LB_SAP_BO
    loadbalance vip icmp-reply active

    Hello,
    I have the similar requirement and i have tried unsuccessfully to achieve it, will appreciate your help on it. Below is the scenario, ace loadbalances request recieved on port 8080 but when ace receives the request on port 80, iam unable to redirect to port 8080. Please let me know mistake in this configuration as it doesnt seems to work.
    And the configuration is as follows:
    access-list permitany line 8 extended permit ip any any
    access-list permitany line 9 extended permit icmp any any
    access-list permitany line 10 extended permit tcp any any
    probe tcp CONTENT-PROBE-SERVERS-8080
      port 8080
      interval 30
      passdetect interval 10
      open 1
    rserver host CONTENT-SERVER-1
      ip address 192.168.3.130
      inservice
    rserver host CONTENT-SERVER-2
      ip address 192.168.3.140
      inservice
    serverfarm host CONTENT-SERVERS-8080
      probe CONTENT-PROBE-SERVERS-8080
      rserver CONTENT-SERVER-1 8080
        inservice
      rserver CONTENT-SERVER-2 8080
        inservice
    sticky ip-netmask 255.255.255.255 address source STICKY-CONTENT-SERVERS-8080
      timeout 120
      replicate sticky
      serverfarm CONTENT-SERVERS-8080
    class-map match-any CMAP-CONTENT-SERVERS-8080
      2 match virtual-address 192.168.3.145 tcp eq 8080
    class-map match-any CMAP-WEB-SERVERS-80
      2 match virtual-address 192.168.3.145 tcp eq www
    class-map type management match-any remote_access
      2 match protocol xml-https any
      3 match protocol icmp any
      4 match protocol telnet any
      5 match protocol ssh any
      6 match protocol http any
      7 match protocol https any
      8 match protocol snmp any
    policy-map type management first-match MANAGEMENT-ACCESS
      class remote_access
        permit
    policy-map type loadbalance first-match PMAP-CONTENT-SERVERS-8080
      class class-default
        sticky-serverfarm STICKY-CONTENT-SERVERS-8080
    policy-map type loadbalance first-match PMAP-WEB-SERVERS-80
      class class-default
        sticky-serverfarm STICKY-CONTENT-SERVERS-8080
    policy-map multi-match NLB-SERVERS
      class CMAP-WEB-SERVERS-80
        loadbalance vip inservice
        loadbalance policy PMAP-WEB-SERVERS-80
        loadbalance vip icmp-reply
      class CMAP-CONTENT-SERVERS-8080
        loadbalance vip inservice
        loadbalance policy PMAP-CONTENT-SERVERS-8080
        loadbalance vip icmp-reply
        nat dynamic 1000 vlan 113
    interface vlan 113
      description **** CLIENT VLAN ****
      bridge-group 1
      mac-sticky enable
      no icmp-guard
      access-group input NONIP
      access-group input permitany
      access-group output permitany
      nat-pool 1000 192.168.3.145 192.168.3.145 netmask 255.255.255.255 pat
      service-policy input MANAGEMENT-ACCESS
      service-policy input NLB-SERVERS
      no shutdown
    interface vlan 500
      description **** SERVER VLAN ****
      bridge-group 1
      access-group input NONIP
      access-group input permitany
      access-group output permitany
      service-policy input MANAGEMENT-ACCESS
      no shutdown
    interface bvi 1
      ip address 192.168.3.234 255.255.255.0
      alias 192.168.3.236 255.255.255.0
      peer ip address 192.168.3.235 255.255.255.0
      no shutdown

  • Two http ports - one in 8080 and the other one in 3034 - How to remove 8080

    Hi!
    I have two http ports - one in 8080 and the other one in 3034 - How to remove 8080.
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=<ip address>)(PORT=<port number>)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=<hotname>)(PORT=3034))(Presentation=HTTP)(Session=RAW))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=<hotname>)(PORT=2102))(Presentation=FTP)(Session=RAW))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=<hotname>)(PORT=8080))(Presentation=HTTP)(Session=RAW))
    Services Summary...

    You get check which is the current dedicated HTTP port by using DBMS_XDB.getHTTPPort(). There can be only HTTP port active per database (not taken into account the HTTPs one). If two or more exists than there is still a process claiming that port (in this case 8080). It will be cleaned up after one or more processes are not claiming that port again. New connections will be redirected to the new port.

  • How can I add a redirect port, or RPT port, in Windows 7?

    I'm dumbfounded.  I know in Windows XP there was an option to add a printer and select the redirection port.  Seems in Windows 7, or at least my installation, that option is missing.  I need to be able to add a redirect port to setup some
    specialized printing we do here in our office.  Hope my question makes sense and I hope I have just missed something and it's really just not that it's not possible or I'm screwed!
    Also I have tried the "Add New Port Type" options and it asks for a driver which I can't seems to find anywhere.  Any help is much appreciated as this has halted my Windows 7 roll out.

    Hi,
    Do you mean in Windows XP, we can add a new port in File-> Server Properties-> Ports-> Add Ports?
    If this is the issue, please see the information below:
    ====================================
    In Windows 7, we have no Server Properties options. But we can also achieve the same goal by using the following two methods:
    Method 1: Right click one of the local printers and select Printer Properties. Click Ports-> Add Port…
    Method 2: In Control Panel, click Administrative Tool and select Print Management. Then open Print Servers and select the local machine. Then right click Ports and
    click Add Ports…
    Hope this can have a little help.
    Best regards,
    Spencer Shi
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

  • Localhost:8080 redirects to localhost.ie:8080

    Hi All,
    I am interested in learning more about webservices and have just install Sun Java System Application Server 8.
    After starting the server, I needed to see if the server and installation went ok. This is done by typing :
    http:localhost:8080 into the browser (internet explorer 6)
    HOWEVER when I do this I get redirected to localhost.ie:8080 which yields an error as it can't find localhost.ie.
    it only works if I use http:\\127.0.0.1:8080.
    where is it getting the "localhost.ie" part from. I cannot seem to find the configuration file to edit it and replace localhost.ie with localhost.
    can anyone help me here.
    kind regards,
    Will.

    You probably just need to update your hosts file to include an entry for localhost

  • Redirect port help

    I am to try to redirect port 3500 of dialer0 for an IP 192.168.1.2 in the Lan whit the same port number. Already I moved in nat. E I created rules ACL. But I did not obtain.
    Router cisco 836
    My config:
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname cisco5000
    boot-start-marker
    boot-end-marker
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    ip subnet-zero
    ip name-server xxx.xxx.xxx.xxx
    ip name-server xxx.xxx.xxx.xxx
    ip cef
    ip ips po max-events 100
    vpdn enable
    l2tp-class PTRP-L2TP
    authentication
    hello 50
    password 7 xx
    exit
    pseudowire-class PTRP-PWC
    encapsulation l2tpv2
    protocol l2tpv2 PTRP-L2TP
    ip local interface Dialer1
    exit
    no ftp-server write-enable
    interface Ethernet0
    description == LAN =
    ip address 192.168.1.15 255.255.255.0
    ip directed-broadcast
    no ip proxy-arp
    no ip mroute-cache
    no keepalive
    no cdp enable
    exit
    interface BRI0
    no ip address
    no cdp enable
    exit
    interface ATM0
    no ip address
    load-interval 30
    no atm ilmi-keepalive
    dsl operating-mode auto
    exit
    interface ATM0.1 point-to-point
    pvc 0/35
    encapsulation aal5snap
    protocol ppp dialer
    dialer pool-member 1
    exit
    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    exit
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    exit
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    exit
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    exit
    interface Virtual-PPP1
    description == Tunel L2TP BE-BT1 ==
    ip address negotiated
    backup delay 30 30
    backup interface Virtual-PPP2
    no cdp enable
    ppp pap sent-username xx
    pseudowire xxx.xxx.xxx.xxx pw-class PTRP-PWC
    exit
    interface Virtual-PPP2
    description == Tunel L2TP BE ==
    ip address negotiated
    no cdp enable
    ppp pap sent-username xx
    pseudowire xxx.xxx.xxx.xxx 10 pw-class PTRP-PWC
    exit
    interface Dialer1
    description == ADSL ==
    ip address negotiated
    ip access-group 111 in
    no ip unreachables
    encapsulation ppp
    no ip route-cache cef
    no ip route-cache
    no ip mroute-cache
    dialer pool 1
    dialer remote-name xx
    dialer idle-timeout 0
    dialer-group 1
    ppp pap sent-username xx
    exit
    ip classless
    ip route 0.0.0.0 0.0.0.0 Virtual-PPP1 10
    ip route 0.0.0.0 0.0.0.0 Virtual-PPP2 100
    ip route xxx.xxx.xxx.xxx 255.255.255.255 Dialer1
    ip route xxx.xxx.xxx.xxx 255.255.255.255 Dialer1
    ip http server
    ip http authentication local
    ip http secure-server
    access-list 7 remark === Remote CONF ===
    access-list 7 permit xxx.xxx.xxx.xxx
    access-list 7 permit xxx.xxx.xxx.xxx
    access-list 111 remark === internet ===
    access-list 111 permit ip host xxx.xxx.xxx.xxx any
    access-list 111 permit ip host xxx.xxx.xxx.xxx any
    access-list 111 permit icmp any any echo-reply
    access-list 111 permit icmp any any time-exceeded
    access-list 111 permit ip host xxx.xxx.xxx.xxx any
    access-list 111 permit ip host xxx.xxx.xxx.xxx any
    access-list 111 deny ip any any
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    exit
    line con 0
    no modem enable
    transport preferred all
    transport output all
    stopbits 1
    exit
    line aux 0
    transport preferred all
    transport output all
    exit
    line vty 0 4
    access-class 7 in
    transport preferred all
    transport input all
    transport output all
    exit
    scheduler max-task-time 5000
    scheduler interval 500
    exit
    end

    content WEB_80
    vip address 10.1.18.11
    add service 1
    protocol tcp
    add service 2
    port 80
    advanced-balance sticky-srcip
    active
    In this example the request will come in through port 80, but for it to go out by port 3500 we can add the following command port xxxx (where xxxx is the number of the port) in a service. This will allow the CSS to redirect the request to the server on the desired port.
    This is just an example to let you see how and where to configurate it.

  • Redirect Port 80

    I know this is a very basic question but how do you redirect port 80?  I have an option to port forward or port trigger.
    What I am trying to do is use a program called Remote Administrator.  It works locally on my network but as soon as I try to connect from outside the network it fails.  I suspect port 80 is the issue and no matter what I do it still comes up as stealth on the GRC site.  So, I port forwarded 80 (both TCP & UDP) to my local ip address that I want to connect to and no go.
    Am I missing some hidden place in the router config that has redirect...
    Thanks in advance

    I agree with you but someone mislead me to believe that port 80 was the problem.  I have port forwarded 4899 to my internal IP and it still does not connect.  I have tried using a no-ip program called canyouseemee to verify if the port is open but it appears to be closed.  I can connect locally but not over the internet so I assume it's a router/firewall issue.
    Any ideas?

  • How to get Port Forwarding to 8080 working on HH2

    Hi,
    How can I get port forwarding to 8080 working on my HomeHub2?
    I have a QNAP TS219P NAS connected via wired Ethernet to my HomeHub2.
    This has a Web Administration facility that should enable me to access & manage the NAS over the Internet.
    I have set the NAS to have a fixed IP address of 198.162.1.100 and enabled a dyndns account to point to my ISP WAN IP. I then used Application Sharing on the HH to forward all traffic to 8080 to the NAS device (called "Kermit" in my case).
    However, using http://mysite.dyndns.org:8080 simply brings up the admin page of the Home Hub.
    Despite the HH telling me the port is forwarded correctly, http://www.canyouseeme.org reports the port as - "Error: I could not see your service on nn.nn.nn.nn on port (8080) ...Reason: Connection refused"
    My HH firewall is set to "Default" (Allow all outgoing connections and block all incoming traffic. Games and application sharing is allowed.), but I have tried disabling it and this made no difference at all.
    I know that dyndns and port forwarding are working in other respects, since I also set the NAS up as a Web Server with a simple home page, and forwarded port 80 on the HH through to the NAS. Requests over the Internet for the http://mysite.dyndns.org:80 home page work fine...
    There's nothing in the HH Event log that I can make sense of and I'm going mad...
    Is anyone able to talk me through some good ideas of how to progress this?

    Another thing I thought of- did you setup the port forwarding to forward to your named IP address or to the hostname?
    I would recommend setting the port forwarding to your named IP address:
    http://192.168.1.254/app_config.lp?be=1&l2=0&l0=2&l1=4
    In this menu (Application Sharing -> Configuration, select "User Defined" in Device. A textfield entry box appears below device and hardcode 192.168.1.100 in there).
    Finally, any logs on the QNAP for your external connection attempts? - Could it be passing through the HomeHub and then get rejected by the QNAP?

  • Redirect port 80 in a zone to port 8070 in a zone - IPFILTER/IPNAT

    I have a non-root user running a web server on 8070 in a zone, and he wants port 80 redirected to 8070 so his URL wont have :8070 in it.
    On Linux with iptables, I did:
    iptables -t nat -I PREROUTING -p tcp dport 80 -j REDIRECT to-ports 8070
    Works great, all traffic to port 80 is redirected to port 8070.
    How can I do the same with IP Filter? I understand IP Filter has to be run in the global zone, not a problem.

    DBSanders, I have a similar configuration on my research network.
    I wanted all web traffic coming to the bastion host (stargate) to be routed to 443 on my webserver (prometheus);
    dmfe0 is the internal adapter, and dmfe1 is the external adapter.
    So, my solution looks like this:
    stargate:/etc/ipf/ipf.conf:
    pass in quick on dmfe1 from any to any port=80 keep state
    pass in quick on dmfe1 from any to any port=8080 keep state
    pass in quick on dmfe1 from any to any port=443 keep state
    pass out quick from prometheus port=443 to any keep statestargate:/etc/ipf/ipnat.conf:
    rdr dmfe1 stargate port 80 -> prometheus port 443 tcp
    rdr dmfe1 stargate port 443 -> prometheus port 443 tcp
    rdr dmfe1 stargate port 8080 -> prometheus port 443 tcp

  • Change XML DB default HTTP port number from 8080 to ... ?

    Hi !
    I need to change the default port number of XML DB from port 8080 to something else, because the development server also hosts a web service, which is configured to listen on port 8080 for debugging reasons. This WS is provided by our partner and we have no control over the ports it uses.
    I'm not a network prof. so I'd like to ask what other port number would make sense for XML DB instead of 8080. Can I choose any port number I like, e.g. 8088?
    Besides using DBCA is there any other place I need to configure this new port number?
    TIA,
    Stefan

    I've done this on occasion using the OEM attach to the database and click XML Database then configuration, you will see it on the right window pane.

  • 1 Node/ Webcache Port 80/ Apps on Port 7778 and 8080

    I have a machine with 3 aliases.
    Is it possible to bind multiple ports to webcache running on port 80 and depending on alias have it routed to the correct application and port?
    What I want is someone that enters http://app1 to go to port 7778 and http://app2 to go to port 8080.
    app1 and app2 both resolve to the same IP address.
    I keep getting "Another site with same exists" when trying to set this up.
    Mike
    ------

    Got It.
    You need to connect to the webcache admin port on 9400 rather than through the EM Application Server management port on 1156.
    Once you get there on the left hand side under "Origin Servers, Sites and Load Balancing"
    Click on "Site definintions":
    Click on "Add Sites":
    For "Host Name" Enter app1
    For "Port" Enter 80
    Click on "Submit"
    Repeat the steps above for each application. I entered each app twice once as app1.us.oracle.com and then simply as app1
    Once all the application "Sites" are entered click on "Site to Server Mapping"
    Select each site you previously entered and click on "Edit Selected"
    In the pop-up select "Select from Site Definitions"
    Using the drop down box choose the Application/Site you want to map
    Scroll down further in the pop-up to "Select Application Web Servers"
    Choose the host and port you want associatted with this application/Site
    Then click Submit

  • SSL Redirect Port ?

    Hello All,
    Im a litle confuse, and im not getting there.
    I had this config scheme, and it works fine:
    Every SSL Traffic is ended in SSL Module, and give it back to content as port 80.
    It matchs the content HTTP-Aplj, and sends traffic to service esl0011-7777.
    It works fine, with http and https.
    Then i had tryed many unsucessefully times the following:
    I want that http traffic goes just like the actual config, ending on backend servers on port 7777, but want the https traffic to be redirected to 4443.
    I have done some trys on several parts of the configs, adding new services for 4443 port, ssl-proxy-list, and adding a new content.
    I even got this message, when was trying to active the content SSL.Aplj:
    %% Not all content VIP:Port combinations are configured in a ssl-proxy-list for sslAccel type of services
    Please give me some ideias to achieve this goal.
    The following config is the basic config for the 1st step. The working one.
    Best Regards,
    Bruno Petrónio
    ************** SSL-Proxy-List **************
    ssl-server 90 vip address 10.1.2.136
    ssl-server 90 urlrewrite 1 https:\\10.1.2.136
    ssl-server 90 rsacert xxxxcert
    ssl-server 90 rsakey xxxxkey
    ssl-server 90 cipher rsa-export-with-rc4-40-md5 10.1.2.136 80
    ************** SERVICE **************
    service MODSSL
    slot 2
    type ssl-accel
    keepalive type none
    add ssl-proxy-list ssl1
    active
    service esl0011-7777
    ip address 10.1.1.120
    port 7777
    keepalive type http
    keepalive port 7777
    keepalive uri "/"
    active
    ************** OWNER **************
    owner Test
    content HTTP-Aplj
    vip address 10.1.2.136
    port 80
    protocol tcp
    add service esl0011-7777
    redundancy-l4-stateless
    active
    content SSL-Aplj
    vip address 10.1.2.136
    add service MODSSL
    application ssl
    advanced-balance ssl
    protocol tcp
    port 443
    url "/*"
    redundancy-l4-stateless
    active

    try the following
    ssl-server 90 vip address 10.1.2.136
    ssl-server 90 urlrewrite 1 10.1.2.136
    ssl-server 90 rsacert xxxxcert
    ssl-server 90 rsakey xxxxkey
    ssl-server 90 cipher rsa-export-with-rc4-40-md5 10.1.2.136 4443
    service esl0011-4443
    ip address 10.1.1.120
    port 4443
    keepalive type http
    keepalive uri "/"
    active
    content HTTP-4443
    vip address 10.1.2.136
    port 4443
    protocol tcp
    add service esl0011-4443
    active
    BTW, I also corrected your urlrewrite command as it was incorrect. You need to specify the host. So not http or https in front.
    Gilles.

  • Redirecting ports on a CSS

    How can I redirect a tcp/udp port through a CSS ??? I have an application running on VLAN2 and it needs to connect to a server running on VLAN3. This application first go to a vip address in the CSS, and this vip is balancing the service across TCP port 1352 in a Raptor Fw. The log in the Raptor said "Non-transparent call from x.x.x.x" ... Any susggestion ???

    If you're only doing firewall loadbalancing, the CSS is not going to NAT the traffic or change any port.
    Your firewalls should be doing this.
    If you also have a VIP defined with services, each service representing a server, you can configure different port for each one of them.
    If you still need more help, please give us an example of traffic flow with traffic before and after the CSS and what you expect to see.
    Gilles.

  • Default port 8889 to 8080

    Hello all,
    where I can find the oracle webserver config file to be eable to set defoult port for forms to 8080 ?
    edo

    hello
    Please tell me what is your configuration of server?
    Which forms and listener u r used?
    Are u using webdb listener? If u r using Webdb then there is \listener\cfg directory there is wdbsvr.cfg file and SERVER_PORT = parameter u just set ur port no to that parameter.

  • Tomcat: prefix in services-config.xml must be unique?

    Hi all, I've been trying to get my flex application communicating with Tomcat and now have it working
    Just trying to confirm something that took me many hours to get right and may help others along the way..
    Originally I modified the BlazeDS webapp by updating the remoting xml and putting in my own classes and it worked without any problems
    I then removed the BlazeDS webapp directory out the tree and created a new one carefully checking each step.. but there was nothing written to catalina log file at any time when running the app or any sign of communication even in debug mode
    I then moved the sample BlazeDS webapp back and when starting Tomcat it complained of duplicate ID's (here is the message: Exception: flex.messaging.config.ConfigurationException: Can not add destination with id 'insert your remoting destination id' to service with id 'proxy-service' because another service with id 'remoting-service' already has a destination with the same id)
    Eventually I noticed in services-config.xml logging section for my new webapp that the <prefix> was still set to BlazeDS - changed this to the new webapp directory name and not only did the exceptions disappear but everything now worked
    So I'm thinking that the prefix is much more important than just a logging descriptor as the XML tag suggests
    Can anyone confirm this behaviour or shed some light?
    PS I should make clear the above problems were not when running the turnkey but on a fresh install of tomcat 6.0.29 on Centos linux using apache proxypass/reverseproxypass to redirect port 80 to 8080
    PS2 - I realise this is not a pure Flex question but it's related due to Adobe crafting a turnkey Flex/Tomcat install with Blaze and it's in the flex configuration files)
    I hope I've covered all bases in the question and look forward to knowing more... CHEERS!

    Hi all, I've been trying to get my flex application communicating with Tomcat and now have it working
    Just trying to confirm something that took me many hours to get right and may help others along the way..
    Originally I modified the BlazeDS webapp by updating the remoting xml and putting in my own classes and it worked without any problems
    I then removed the BlazeDS webapp directory out the tree and created a new one carefully checking each step.. but there was nothing written to catalina log file at any time when running the app or any sign of communication even in debug mode
    I then moved the sample BlazeDS webapp back and when starting Tomcat it complained of duplicate ID's (here is the message: Exception: flex.messaging.config.ConfigurationException: Can not add destination with id 'insert your remoting destination id' to service with id 'proxy-service' because another service with id 'remoting-service' already has a destination with the same id)
    Eventually I noticed in services-config.xml logging section for my new webapp that the <prefix> was still set to BlazeDS - changed this to the new webapp directory name and not only did the exceptions disappear but everything now worked
    So I'm thinking that the prefix is much more important than just a logging descriptor as the XML tag suggests
    Can anyone confirm this behaviour or shed some light?
    PS I should make clear the above problems were not when running the turnkey but on a fresh install of tomcat 6.0.29 on Centos linux using apache proxypass/reverseproxypass to redirect port 80 to 8080
    PS2 - I realise this is not a pure Flex question but it's related due to Adobe crafting a turnkey Flex/Tomcat install with Blaze and it's in the flex configuration files)
    I hope I've covered all bases in the question and look forward to knowing more... CHEERS!

Maybe you are looking for

  • Please Help.   Safari is Killing Me.  Thank You in Advance!

    Hi there! I have a MacBookPro 2.33GHz, Intel Core 2 Duo, 2 GB, 667 MHz, DDR2, SDRAM. I'm running OS 10.5.8 and Safari 4.0.4 (5531.21.10). I've had this computer for a couple of years now and everything has been great with it. However, lately, my Safa

  • Automatic update cs extensions

    hi, I'm trying to build in a automatic updater for my cs extension as described in this Adobe pdf, but it's not working yet. Let me describe my steps so far: I have my extension - version 1.0 - installed in the host (Illustrator and Premiere) With th

  • TOC - Receiving a "Cannot find the file named" error when pressing Ctrl+alt

    When I generate a TOC, it comes out beautifully. However, when I press control + alt to check my links, I receive a "cannot find the file named" error message. This happens for the majority of the links. All of the files are present along with the gr

  • Lightroom Support for Fuji Finepix x100

    This seems to be one of the few photo forums in which people aren't yet banging on about the Fuji X100. Time to fix that. Can anyone give advice about when Lightroom will be able to import its raw files?

  • Database back up

    hi, Now am using windows 2008 x32 bit standard version,  so am going to move or upgrate windows 2008R2 x64bit. it's possible to work well all database in this new database? i can only back up 2008 x32 bit (.mdf and .ldf) file only