Routing Engine: Transform route Response to another CRS

Hi.
We use Oracle 10gR2 routing engine for routing Europe.
We have to keep spatial data in one coordinate reference system (CRS) at the DB level and visualize it using another in our application. When it comes to routing, we would like to make the routing engine issue a transformation of linestring coordinates from one CRS, in which data is held to the other, in which the route is to be visualized. Currently, the routing engine returns a geometry in the CRS, we do not want to use for visualizing.
Is there a simple way of making the routing engine do so? Maybe by changing SQL generated within the routeserver.jar to do the transformation using Oracle packages...
Cheers
Sebastian.

Sebastian,
We will definitely consider this. We need to enhance the
route request to support this.
Unfortunately there is no simple way to generate this from the routerserver.jar.
You need to do an explicit call to the DB to transform the router geometry
to the desired CRS.
Are you using MapViewer for visualization ?
MapViewer can do CRS transformation on the fly for visualization.
siva

Similar Messages

  • Routing engine problems: partition_id AND frequent exceptions in responses

    Hi.
    I want to use Oracle routing engine with Oracle Spatial 10gR2 for Europe.
    I have tables NODE, EDGE, SIGN_POST and PARTITION populated okay with data from a data vendor.
    I have 600000 edges and 415000 nodes. 128 partitions were generated by
    using: exec SDO_ROUTER_PARTITION.partition_router('NODE_PART', 4000);
    Two issues occur to me:
    1. select num_nodes from partition where partition_id = 0; returns 390 nodes, but neither in table node nor edge are records with partition_id = 0, which is as I have learned the Highway Partition. Does that make sense?
    2. Route requests sometimes return correct results, but more frequently routing engine exceptions:
    Most popular are:
    - Route not found between destination/source node and highway network!
    - mbrAwareAStarSearch could not find a route!
    What might be wrong?
    I also experience both problems with the NAVTEQ example data for San Francisco extracted from sf_routing.zip.
    Below find requests leading to exceptions indicated using NAVTEQ example data extracted from sf_routing.zip in order to make the described reproducable:
    1. Route not found between destination/source node and highway network!:
    <?xml version="1.0" standalone="yes"?>
    <route_request id="8"
    route_preference="shortest"
    road_preference="highway"
    return_driving_directions="false"
    distance_unit="km"
    time_unit="hour"
         return_route_geometry="true"
    pre_geocoded_locations="true">
    <start_location>
    <pre_geocoded_location id="1">
    <edge_id>-37847628</edge_id>
    <percent>.5</percent>
    <side>L</side>
    </pre_geocoded_location>
    </start_location>
    <end_location>
    <pre_geocoded_location id="2">
    <edge_id>-37846969</edge_id>
    <percent>.5</percent>
    <side>R</side>
    </pre_geocoded_location>
    </end_location>
    </route_request>
    2. - mbrAwareAStarSearch could not find a route!
    <?xml version="1.0" standalone="yes"?>
    <route_request id="8"
    route_preference="shortest"
    road_preference="highway"
    return_driving_directions="false"
    distance_unit="km"
    time_unit="hour"
         return_route_geometry="true"
    pre_geocoded_locations="true">
    <start_location>
    <pre_geocoded_location id="1">
    <edge_id>-37827163</edge_id>
    <percent>.5</percent>
    <side>R</side>
    </pre_geocoded_location>
    </start_location>
    <end_location>
    <pre_geocoded_location id="2">
    <edge_id>-37847628</edge_id>
    <percent>.5</percent>
    <side>R</side>
    </pre_geocoded_location>
    </end_location>
    </route_request>

    The highway partition, partition zero, is "logical" idea. That is it only exists in the partition table. Each node and edge in the data belongs to a partition that it shares with other nodes or edges in the same physical area. This physical relationship is shown in the partition ids stored in the edge and node tables. Once these partitions are figured out each edge is looked at to see if it's a highway edge, that is, it has a func_class of 1 or 2. Once this is done these edges have their start and end nodes classified as highway nodes and those are considered to be in partition zero also.
    I've run into the MBR error you're seeing in my testing and have been looking into it. Forgive my poor analogy, but there appear to be "holes" in the highway system. If one has a major artery, say interstate 95 coming out of FL, all routes between FL and VA are going to want to use that major artery. If there was a "hole" in interstate 95, a section that was not classified as a highway section thus not in partition 0, those routes would be dropped as unusable. If all the routes get dropped in this way you get the mbrAwareAStarSearch error.
    I haven't seen the other error but I'll use your example and have a look into it.

  • Routing engine download

    Where I can download the Oracle Routing Engine?
    I've search on the following link:
    http://www.oracle.com/technology/software/products/spatial/index.html
    but there is no more reference to the Routing Engine.
    Thanks
    Renzo

    The result of the query:
    SELECT COMP_ID, COMP_NAME, version, STATUS
    FROM DBA_REGISTRY
    WHERE COMP_NAME = 'Spatial';
    is:
    COMP_ID COMP_NAME VERSION STATUS
    SDO Spatial 10.2.0.1.0 VALID
    Renzo

  • I have a hard drive for CD storage that needs to connect to the Ethernet router. sInce my router is not in this room, and in another room, I want to use my Mac as a router for the drive, and share the wifi. Ho do I do this

    I have a hard drive for CD storage that needs to connect to the Ethernet router. sInce my router is not in this room, and in another room, I want to use my Mac as a router for the drive, and share the wifi. Ho do I do this? I gace tried the System Preferences -> Sharing, shared internet to Ethernet, but can't se ethe device on Finder

    Djembe wrote:
    UEFI (unified extensible firmware interface) boot requires Global unique identifier Partition Table (GPT) as opposed to the older Master Boot Record (MBR). If your existing drive is formatted in MBR, you will need to adjust BIOS settings to enable legacy boot in order for it to work properly.
    Is there a performance difference between GPT and MBR? If GPT is better, I do not mind formatting the drive with it.
    5. No special drivers are needed.
    Thanks. What about the thunderbolt port?
    7. I think Lenovo estimates 6 hours.
    Lenovo says 6 hours with the 6-cell battery on its website.
    BrendaEM wrote:
    Hi,
    There was a serious BIOS/UEFI problem with that SSD . Perhaps this thread will save you some headaches. Someone is recomending shutting off Rapid Boot in the setup, which would probable mean little with a SSD, anyway.
    I read through this, and it looks like the problem was fixed in a BIOS update, which I plan to do. However, it also seems like Intel Rapid Start is not even worth it in the first place, as sleep consumes almost no power at all.
    W540: i7-4700mq, K2100m, 8 GB DDR3L, 512 GB SSD
    T510: i7-620m, NVS 3100m, 8 GB DDR3, 512 GB SSD

  • Error - Intialising Routing Engine

    I ve installed Oracle 10g spatial and now trying to istall the routing engine. Do u know what this Oracle Spatial Geocoder is ?? How can I check it is installed.
    I did the following steops to install the routing engine
    Made changes to the http-web-site.xml, server.xml file of OC4J.
    Started OC4J with the following command
    Java –server... . ..
    When opening the routeserver in the browser, index page of routeserver is opening with welcome note Routeserver Successfully Deployed.
    But not able to make proper changes to the file /routeserver/web/WEB-INF/web.xml for successful initialization of routeserver
    Importing sample Datafile
    Error coming while running the following command to import tablespace
    C:\pinellas-county>impdp adci DIRECTORY=adci_dump_dir DUMPFILE=tts.dmp TRANSPORT DATAFILES='C:\pinellas-county\adcidata.ora'
    Import: Release 10.1.0.2.0 - Production on Tuesday, 07 June, 2005 10:59
    Copyright (c) 2003, Oracle. All rights reserved.
    Password:
    Connected to: Oracle Database 10g Enterprise Edition Release 10.1.0.2.0 - Produc
    tion
    With the Partitioning, OLAP and Data Mining options
    Master table "ADCI"."SYS_IMPORT_TRANSPORTABLE_01" successfully loaded/unloaded
    Starting "ADCI"."SYS_IMPORT_TRANSPORTABLE_01": adci/******** DIRECTORY=adci/********dumpdir DUMPFILE=tts.dmp TRANSPORT_DATAFILES='C:\pinellas-county\adci/********_data.ora'
    Processing object type TRANSPORTABLE_EXPORT/PLUGTS_BLK
    ORA-39123: Data Pump transportable tablespace job aborted
    ORA-06550: line 2, column 2:
    PLS-00306: wrong number or types of arguments in call to 'BEGINIMPORT'
    ORA-06550: line 2, column 2:
    PL/SQL: Statement ignored
    Job "ADCI"."SYS_IMPORT_TRANSPORTABLE_01" stopped due to fatal error at 10:59
    thnx
    deepthy

    Hi,
    You can download from metalink. You will need a metalink account to do this.
    I've just downloaded the sample data from adci.
    It did install for me.
    Can you post the exact steps you ran through?
    Also, what hardware platform are you running on?
    Thanks,
    Dan
    Here are the exact steps I ran through:
    sqlplus system/pass*****
    CREATE USER ADCI PROFILE "DEFAULT"
    IDENTIFIED BY "ADCI" DEFAULT TABLESPACE "USERS"
    TEMPORARY TABLESPACE "TEMP" ACCOUNT UNLOCK;
    GRANT "CONNECT" TO "ADCI";
    GRANT imp_full_database, create table, create sequence TO ADCI;
    CREATE or replace DIRECTORY adci_dump_dir AS 'C:\oracle\oradata\ora10g';
    GRANT READ, WRITE ON DIRECTORY adci_dump_dir TO adci;
    ALTER USER adci QUOTA UNLIMITED ON USERS;
    exit;
    ---Since I am running on windows I do not need to use RMAN convert
    impdp adci DIRECTORY=adci_dump_dir DUMPFILE=tts.dmp TRANSPORT_DATAFILES='C:\oracle\oradata\ora10g\adci_data.ora'
    -- GOT OUTPUT LIKE THIS:
    --Import: Release 10.1.0.4.0 - Production on Wednesday, 15 June, 2005 14:13
    --Copyright (c) 2003, Oracle.  All rights reserved.
    --Password:
    --Connected to: Oracle Database 10g Enterprise Edition Release 10.1.0.4.0 - Production
    --With the Partitioning, OLAP and Data Mining options
    --Master table "ADCI"."SYS_IMPORT_TRANSPORTABLE_01" successfully loaded/unloaded
    --Starting "ADCI"."SYS_IMPORT_TRANSPORTABLE_01":  adci/******** DIRECTORY=adci/***
    --*****dumpdir DUMPFILE=tts.dmp TRANSPORT_DATAFILES='C:\oracle\oradata\ora10g\adci/********_data.ora'
    --Processing object type TRANSPORTABLE_EXPORT/PLUGTS_BLK
    --Processing object type TRANSPORTABLE_EXPORT/TYPE/TYPE_SPEC
    --ORA-31684: Object type TYPE:"MDSYS"."SDO_ORDINATE_ARRAY" already exists
    --ORA-39083: Object type TYPE failed to create with error:
    --ORA-02311: cannot alter with COMPILE option a valid type with type or table dependents
    --Failing sql is:
    ----ERRORS LIKE THE ABOVE CAN BE IGNORED
    sqlplus system/pass*****
    ALTER TABLESPACE ADCI_DATA READ WRITE;
    ALTER USER ADCI QUOTA UNLIMITED ON ADCI_DATA;
    connect adci/adci
    EXEC SDO_UTIL.INITIALIZE_INDEXES_FOR_TTS
    INSERT INTO USER_SDO_MAPS SELECT * FROM SDO_MAPS;
    INSERT INTO USER_SDO_THEMES SELECT * FROM SDO_THEMES;
    INSERT INTO USER_SDO_STYLES SELECT * FROM SDO_STYLES;
    COMMIT;
    exec dbms_stats.gather_schema_stats(ownname=>'ADCI',cascade=>TRUE,estimate_percent=>15);
    select SDO_gcdr.geocode('ADCI',
    SDO_keywordArray( '13359 Seminole Blvd','Largo, FL 33778'), 'US', 'DEFAULT')
    from dual ;
    SDO_GCDR.GEOCODE('ADCI',SDO_KEYWORDARRAY('13359SEMINOLEBLVD','LARGO,FL33778'),'U
    SDO_GEO_ADDR(0, SDO_KEYWORDARRAY(), NULL, 'SEMINOLE BLVD', NULL, NULL, 'LARGO',
    NULL, 'FL', 'US', '33778', NULL, '33778', NULL, '13359', 'SEMINOLE', 'BLVD', 'F'
    , 'F', NULL, NULL, 'R', .8975, 22864031, '????#ENUT?B281CP?', 1, 'DEFAULT',
    -82.78702, 27.8941784)

  • Route engine

    Hi
    Oracle Spatial Route engine document introduces that in Route Request DTD, it is possible to write a route request that <Start Location> as below:
    <start_location>
    <input_location id="1">
    <Point>
    <coordinates>
    -122, 37
    </coordinates>
    </Point>
    </input_location>
    </start_location>
    But when i press submit button, it has errors:
    <?xml version="1.0" encoding="UTF-8" ?>
    <generic_error>java.lang.NoClassDefFoundError: oracle/spatial/util/GML at oracle.spatial.geocoder.common.XMLHelper4Geocoder.fillGCAddrFromPointElement(XMLHelper4Geocoder.java:259) at oracle.spatial.geocoder.common.XMLHelper4Geocoder.createGCAddrFromLocationNode(XMLHelper4Geocoder.java:333) at oracle.spatial.router.server.XMLHelper4Router.extractInputLocation(XMLHelper4Router.java:276) at oracle.spatial.router.server.XMLHelper4Router.extractLocation(XMLHelper4Router.java:255) at oracle.spatial.router.server.XMLHelper4Router.convert(XMLHelper4Router.java:207) at oracle.spatial.router.server.RouteServerServlet.processRouteRequest(RouteServerServlet.java:448) at oracle.spatial.router.server.RouteServerServlet.takeXMLRequestAndReturnResponse(RouteServerServlet.java:411) at oracle.spatial.router.server.RouteServerServlet.doPost(RouteServerServlet.java:272) at javax.servlet.http.HttpServlet.service(HttpServlet.java:760) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:765) at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317) at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790) at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:270) at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:112) at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186) at java.lang.Thread.run(Unknown Source)</generic_error> [b]
    Can you help me to solve the errors
    Thanh a lot
    hai_va

    iva Ravada,
    Thanks your reply.
    (i) If I give a address instead of a point, route request works correctly
    (ii) I followed your instruction create spatial indexes on all the tables
    used by the geocoder (in Oracle sample data, it is gc_road_segment_us table) and write the request to work with point as below:
    <?xml version="1.0" standalone="yes"?>
    <route_request id="8"
    route_preference="shortest"
    road_preference="highway"
    return_driving_directions="true"
    distance_unit="meter"
    time_unit="second"
    return_route_geometry="true"
    xmlns:gml="http://www.opengis.net/gml">
    <start_location>
    <input_location id="1">
    <gml:Point>
    <gml:coordinates> -122.39382,37.79518</gml:coordinates>
    </gml:Point>
    </input_location>
    </start_location>
    <end_location>
    <input_location id="2">
    <gml:Point>
    <gml:coordinates> -122.40472,37.74164 </gml:coordinates>
    </gml:Point>
    </input_location>
    </end_location>
    </route_request>
    Coordinates of points are coordinates of addresses from (i)
    But have errors
    <?xml version="1.0" encoding="UTF-8" ?>
    <RouteServerException>[RSE-0206: Unexpected output format from Geocoder!!!]</RouteServerException>
    How can I use request to work with point?
    Thanks once again
    hai_va

  • Route Engine Problem, Please help

    Hi
    Oracle Spatial Route engine document introduces that in Route Request DTD, it is possible to write a route request that <Start Location> as below:
    <start_location>
    <input_location id="1">
    <Point>
    <coordinates>
    -122, 37
    </coordinates>
    </Point>
    </input_location>
    </start_location>
    But when i press submit button, it has errors:
    <?xml version="1.0" encoding="UTF-8" ?>
    <generic_error>java.lang.NoClassDefFoundError: oracle/spatial/util/GML at oracle.spatial.geocoder.common.XMLHelper4Geocoder.fillGCAddrFromPointElement(XMLHelper4Geocoder.java:259) at oracle.spatial.geocoder.common.XMLHelper4Geocoder.createGCAddrFromLocationNode(XMLHelper4Geocoder.java:333) at oracle.spatial.router.server.XMLHelper4Router.extractInputLocation(XMLHelper4Router.java:276) at oracle.spatial.router.server.XMLHelper4Router.extractLocation(XMLHelper4Router.java:255) at oracle.spatial.router.server.XMLHelper4Router.convert(XMLHelper4Router.java:207) at oracle.spatial.router.server.RouteServerServlet.processRouteRequest(RouteServerServlet.java:448) at oracle.spatial.router.server.RouteServerServlet.takeXMLRequestAndReturnResponse(RouteServerServlet.java:411) at oracle.spatial.router.server.RouteServerServlet.doPost(RouteServerServlet.java:272) at javax.servlet.http.HttpServlet.service(HttpServlet.java:760) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:765) at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317) at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790) at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:270) at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:112) at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186) at java.lang.Thread.run(Unknown Source)</generic_error>
    Can you help me to solve the errors
    Thanh a lot
    hai_va

    iva Ravada,
    Thanks your reply.
    (i) If I give a address instead of a point, route request works correctly
    (ii) I followed your instruction create spatial indexes on all the tables
    used by the geocoder (in Oracle sample data, it is gc_road_segment_us table) and write the request to work with point as below:
    <?xml version="1.0" standalone="yes"?>
    <route_request id="8"
    route_preference="shortest"
    road_preference="highway"
    return_driving_directions="true"
    distance_unit="meter"
    time_unit="second"
    return_route_geometry="true"
    xmlns:gml="http://www.opengis.net/gml">
    <start_location>
    <input_location id="1">
    <gml:Point>
    <gml:coordinates> -122.39382,37.79518</gml:coordinates>
    </gml:Point>
    </input_location>
    </start_location>
    <end_location>
    <input_location id="2">
    <gml:Point>
    <gml:coordinates> -122.40472,37.74164 </gml:coordinates>
    </gml:Point>
    </input_location>
    </end_location>
    </route_request>
    Coordinates of points are coordinates of addresses from (i)
    But have errors
    <?xml version="1.0" encoding="UTF-8" ?>
    <RouteServerException>[RSE-0206: Unexpected output format from Geocoder!!!]</RouteServerException>
    How can I use request to work with point?
    Thanks once again
    hai_va

  • How can we forward XML document from Routing Engine to Mapviwer!!!

    Does anyone try to forward XML document from routing engine to Mapviwer. Like spatial coordinate system from Routing engine. Could you help me how to accomplish this problem. Thank much much....

    Just open an HTTP connection to MapViewer's server url (ususally http://host:port/mapviewer/omserver) and send an XML map request to it using POST. You can do that from any language that supports such a connection.
    Inside the xml map request you can attach the routing result (a series of coordinates i imagine) as dynamic geo-features. You can also specify any base map/layer information in the xml map req provided you have defined such map/themes. DTD of mapviewer's map req is in the Users Guide, which is on OTN site mapviewer http://otn.oracle.com/products/mapviewer.

  • Routing Engine or SDM

    Hi I am beginning to investigate Spatial for use in generating street routing geometry and instructions.
    It appears there are two ways of going about this: Routing Engine (Java-XML) or the Spatial Data Model (SDM).
    If one wants instructions the Routing Engine is the way to go. But there does not appear to be anyway to restrict turns (I gather this from the description of the EDGE.DIVIDER field in the doc). The SDM model lacks instructions, but a past post indicates that restricting turns can be accomplished via adding an additional field to the LINK table (eg, a varray of restricted NODE id's).
    Is there a way I can get both driving instructions and turn restrictions? I assume the solution would need to come via editing around the SDM model to add instructions.
    Any thoughts? Thanks in advance.
    Glen

    David,
    Here is a description of how a road is classified as a highway:
    Roads come in 5 functional classes 1 through 5. We use functional class to decide two things in
    the Router, 1) is the edge part of a highway and need to be in the highway partition and 2) what is the
    speed classification for the edge.
    We use the speed classification along with the edges length to
    compute how long it should take to traverse the edge.
    Function class 1 and 2 are considered highway
    edges and are placed in the highway partition, the other functional classes are not.
    Functional class 1 roads have consistent, typically fast speeds with limited access.
    Functional class 2 roads also have consistent speeds and are used to get traffic to and from
    functional class 1 roads.
    Functional class 3 roads are also high volume edges used to connect functional class 2 roads.
    Functional class 4 roads move volumes of traffic from neighborhood to neighborhood. Think,
    busy main road in a city.
    Functional class 5 roads are all other roads not accounted for above.

  • Routing Engine Algorithm?

    Hi every one,
    does any one know what algorithms did Routing Engine uses. I may afraid that Routing Engine does not warranty to fine the shortest path in a complex road network.
    Any idea, regrad viravud.

    Vud,
    The algorithm is a hierarchical routing algorithm where
    all the highways are used as the higher level graph.
    And yes, there is no gauarantee of the optimal route
    in this hierarchical routing algorithm.
    If you want optimal shortest path, you should consider
    using the Spatial Netowork Data Model.
    siva

  • Routing Engine

    Hello,
    I want to use the Routing Engine but I understand that it is not include with the download of Oracle 10g Database version 10.2, which is the installation I have. I would like to download the sdo_routing.zip but there is not link to download it.
    Somebody could tell me how to find it or install it?

    Hello,
    Only the 2nd picture you put here shows up, so I can only comment on that. 
    So by default when when you are doing proxy L3 routing the F1 modules will load balance across all M1 modules to perform the route lookups.  However you can configure this and choose which modules should be doing the routing:
    http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/unicast/command/reference/l3_cmds_h.html#wp1533507
    The main reason why the situation in the 2nd picture happens is that the F1 module doesn't know which port we will need to send the traffic out after it gets routed, so it sends it to any M1 module for the lookup.  Once that M1 module performs the lookup it will send it to the correct destinaion port, so it may have two passes through the fabric.
    Chad

  • Can you route fax calls coming in to another system

    Hi all
    We have an issue whereby we have some fax numbers that come in on one of our ISDN's but these devices are on another site.
    we have call manager on the main site where the numbers come in, then these fax numbers need to route to another telephone system via a gateway.
    We ran a test and we can hear the fax coming in, but it beeps and never completes.
    can the call manager route these type of calls to another pbx ? if so do i need to check anything ?
    cheers
    Carl

    Standardize on one faxing protocol, ideally protocol based T.38 across all systems. Fax relay is Cisco proprietary and will not work well with other systems.
    Chris

  • Need a Help, Routing engine not work!

    I am to new to oracle spatial. I found that oracle have a Routing Engine, I download its install but when I test a simple Routing XML I got the following error message:
    <?xml version="1.0" encoding="UTF-8" ?>
    <generic_error>Message:Error in sending request to elocation server. Sun Oct 10 20:33:49 GMT+07:00 2004 Machine Node Name: laptop Component: Sub-Component: Server Side Severity: 0 Description: Nested exception is: java.net.ConnectException: Connection refused: connect java.net.ConnectException: Connection refused: connect at java.net.PlainSocketImpl.socketConnect(Native Method) at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:305) at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:171) at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:158) at java.net.Socket.connect(Socket.java:452) at java.net.Socket.connect(Socket.java:402) at sun.net.NetworkClient.doConnect(NetworkClient.java:139) at sun.net.www.http.HttpClient.openServer(HttpClient.java:402) at sun.net.www.http.HttpClient.openServer(HttpClient.java:618) at sun.net.www.http.HttpClient.<init>(HttpClient.java:306) at sun.net.www.http.HttpClient.<init>(HttpClient.java:267) at sun.net.www.http.HttpClient.New(HttpClient.java:339) at sun.net.www.http.HttpClient.New(HttpClient.java:320) at sun.net.www.http.HttpClient.New(HttpClient.java:315) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:521) at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:498) at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:569) at oracle.spatial.geocoder.client.HttpClientGeocoder.sendRequest(HttpClientGeocoder.java:197) at oracle.spatial.geocoder.client.HttpClientGeocoder.batchGeocode(HttpClientGeocoder.java:142) at oracle.spatial.router.server.RouteServerServlet.processRouteRequest(RouteServerServlet.java:467) at oracle.spatial.router.server.RouteServerServlet.takeXMLRequestAndReturnResponse(RouteServerServlet.java:411) at oracle.spatial.router.server.RouteServerServlet.doPost(RouteServerServlet.java:272) at javax.servlet.http.HttpServlet.service(HttpServlet.java:760) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:765) at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317) at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790) at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:270) at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:112) at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192) at java.lang.Thread.run(Thread.java:534)</generic_error>

    Hi,
    Do you want to send the notification on schedule time?
    Generally, I will schedule the job, and then set the notification to send the email to the operator when the job succeeds/fails/completes.
    For e-mail notifications, you can provide an e-mail address or multiple e-mail addresses separated by semicolons. This could also be an e-mail group defined within your e-mail system. If you wish to notify many people, it is better to
    define an e-mail group in your e-mail system.
    Thanks.
    Tracy Cai
    TechNet Community Support

  • Other languages for oracle routing engine?

    Hello,
    I'm sorry if this is not the right place to post my question, but i wasn't able to find a special forum about routing.
    In our application, we'd like to use the oracle routing engine for navigation. As people from different nations use our application, we'd like to supply appropriate languages for most of them.
    The supported languages we know of are english, french, german, italian and spanish.
    For our customer we need languages like polish, Czech, and - most important - russian.
    Does anybody know whether these languages exist or if there is a possibility of installing something like a language pack for the routing engine?
    thanks,
    JoAl

    The Router currently does not have an option for Polish, Czech or Russian. It is possible for for these languages to be included but they would be included in a later version of the Router.
    The first step is to know exactly what languages you would like included. If we have the translation services to translate the driving directions to those languages we will include them in a future version of the Router.

  • Router 2811 stop routing

    Hi all, I have a 2811 [Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(11)XJ, RELEASE SOFTWARE (fc1)] and I don´t know why, sometimes the router just stop routing. I perform a "show ip route" or "show arp" and seems to be everything ok. Interfaces are all up, and a site-to-site vpn active but no traffic between the sites.
    Does anybody know what could be happening or what command should I execute the next time?
    Best regards
    Carlos
    PD: Sorry for my english :-)

    !
    crypto isakmp policy 1
     encr aes 256
     authentication pre-share
     group 5
    crypto isakmp policy 10
     encr 3des
     authentication pre-share
     group 2
    crypto isakmp key **** address **** no-xauth
    crypto isakmp client configuration group vpn
     key voicentersdm
     pool SDM_POOL_1
     acl 100
     netmask 255.255.255.0
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set esp-aes256-sha esp-aes 256 esp-sha-hmac
    crypto dynamic-map SDM_DYNMAP_1 1
     set transform-set ESP-3DES-SHA
     reverse-route
    crypto map SDM_CMAP_1 client authentication list sdm_vpn_xauth_ml_1
    crypto map SDM_CMAP_1 isakmp authorization list sdm_vpn_group_ml_1
    crypto map SDM_CMAP_1 client configuration address respond
    crypto map SDM_CMAP_1 11 ipsec-isakmp
     description ****
     set peer ****
     set transform-set esp-aes256-sha
     match address 102
    interface FastEthernet0/0
     description Internet$ETH-WAN$
     ip address ****
     ip nat inside
     ip virtual-reassembly
     speed 100
     full-duplex
     no cdp enable
     crypto map SDM_CMAP_1
    interface FastEthernet0/1
     description ****
     ip address 172.16.156.2 2555.255.255.0
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
     no cdp enable
    interface FastEthernet0/0/0
     description LAN
    interface FastEthernet0/0/1
     description mpls
     switchport access vlan 100
    interface FastEthernet0/0/2
    interface FastEthernet0/0/3
    interface Vlan1
     description $ES_LAN$
     ip address ****
     ip nat inside
     ip virtual-reassembly
    interface Vlan100
     description mpls
     ip address ****
     ip nat inside
     ip virtual-reassembly
    ip local pool SDM_POOL_1 192.168.2.1 192.168.2.5
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 **** name default_route
    ip route 10.0.0.0 255.255.254.0 190.3.65.57 
    ip route 10.0.2.0 255.255.255.0 10.0.254.9 
    ip route 10.0.3.0 255.255.255.0 10.0.254.9 
    ip route 10.0.254.0 255.255.255.248 10.0.254.9 
    ip route 10.48.25.0 255.255.255.0 172.16.156.1 
    ip route 10.92.16.0 255.255.255.0 172.16.156.1 
    ip route 10.92.17.0 255.255.255.0 172.16.156.1 
    ip route 10.92.24.0 255.255.255.0 172.16.156.1 
    ip route 10.92.48.0 255.255.255.0 172.16.156.1 
    ip route 10.92.49.0 255.255.255.0 172.16.156.1 
    ip route 10.92.50.0 255.255.255.0 172.16.156.1 
    ip route 10.92.55.0 255.255.255.0 172.16.156.1
    ip route 170.51.242.0 255.255.255.0 172.16.156.1
    no ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat pool nat-claro 172.16.156.2 172.16.156.200 netmask 255.255.255.0
    ip nat pool nat-claro-chaco 172.16.157.2 172.16.157.200 netmask 255.255.255.0
    ip nat inside source route-map ****
    ip nat inside source route-map ****
    logging trap notifications
    logging 10.20.1.234
    access-list 100 remark SDM_ACL Category=4
    access-list 100 permit ip 10.20.0.0 0.0.255.255 any
    access-list 100 permit ip 172.16.156.0 0.0.0.255 any
    access-list 101 remark SDM_ACL Category=18
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.80
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.177
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.17.234
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.4
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.51
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.52
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.243
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.242
    access-list 101 permit ip 10.20.0.0 0.0.255.255 10.92.48.0 0.0.0.255
    access-list 101 permit ip 10.20.0.0 0.0.255.255 10.92.49.0 0.0.0.255
    access-list 101 permit ip 10.20.0.0 0.0.255.255 10.92.50.0 0.0.0.255
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.55.11
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 170.51.242.162
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.55.12
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.55.13
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.55.21
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.55.15
    access-list 101 permit ip 10.20.0.0 0.0.255.255 host 10.92.16.86
    access-list 101 permit ip 10.0.0.0 0.255.255.255 host 10.92.55.16
    access-list 102 permit ip 10.20.0.0 0.0.255.255 10.0.0.0 0.0.1.255
    access-list 102 permit ip 10.92.0.0 0.0.255.255 10.0.0.0 0.0.1.255
    access-list 102 permit ip 10.20.0.0 0.0.255.255 192.168.10.0 0.0.0.255
    access-list 102 permit ip 10.92.0.0 0.0.255.255 192.168.10.0 0.0.0.255
    access-list 102 permit ip 10.0.2.0 0.0.0.255 10.0.0.0 0.0.1.255
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.80
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.177
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.17.234
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.4
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.51
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.52
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.243
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.16.242
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.80
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.243
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.242
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.55.15
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.55.15
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.80
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.177
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.17.234
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.177
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.17.234
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.4
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.51
    access-list 103 permit ip 10.0.2.0 0.0.0.255 host 10.92.16.52
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.4
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.51
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.52
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.243
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.16.242
    access-list 103 permit ip 10.0.3.0 0.0.0.255 host 10.92.55.15
    access-list 103 permit ip 10.0.0.0 0.0.1.255 host 10.92.55.21
    access-list 104 permit ip 10.20.0.0 0.0.255.255 10.0.2.0 0.0.0.255
    access-list 104 permit ip 10.92.0.0 0.0.255.255 10.0.2.0 0.0.0.255
    no cdp run
    route-map *** permit 10
     match ip address 101
    route-map *** permit 20
     match ip address 103
    !

Maybe you are looking for