Sharing global routing table with vrf for intra-as traffic

We have a network block of 10.201.0.0/16 which is divided into two subnet 10.201.0.0/18 and 10.201.192.0/18. We are getting a internet feed for each subnet.
10.201.192.0/18 is in global routing table, and 10.201.0.0/18 is in a vrf-lite green.
I am thinking doing the following:
...........HUB
VL199/....\VL198
SPOKE1 SPOKE2
Hub and spoke are from perspective of vrf green.
For vrf green in the HUB:
ip route vrf green 10.201.0.0 255.255 255.192 vlan 199
ip route vrf green 10.201.64.0 255.255.255.192 vlan198
SPOKE1
ip route 0.0.0.0 0.0.0.0 vlan199
SPOKE2
ip route 0.0.0.0 0.0.0.0 vlan198
Suppose we already get the 2 internet feeds to HUB route with vrf green and global routing table. This should get vrf green going.
But we also have global routing table on the HUB router.
We would like to have 10.201.0.0/16 communicating with each other, and only keep internet default separated.
How should we get to 10.201.0.0/18 from global routing table and how should we get to 10.201.192.0/18 from SPOKE[12]?

In my lab, I have 2 ports configured.
int gi1/2
ip vrf forward green
ip address 10.201.192.253 255.255.255.252
int gi1/1
ip address 10.201.192.254 255.255.255.252
ip route 10.201.0.0 255.255.192.0 gi1/2
ip route vrf 10.201.192.0 255.255.192.0 gi1/1 10.201.192.254
This way, from vrf green to global has go through HUB. and vrf greens will also go through greens.
Is there any other much elegant way for this purpose?

Similar Messages

  • VRF Best Practice: LAN only VRF, Mgmt VRF, Global Routing table or VRF?

    I am setting up a routed LAN (not a WAN) environment on two 6500 switches (sup-720). My goal is to create 32 routed environments separated by logical firewalls (multi-context ASA's). So I want a “core” router in each environment, and don't want to buy 32 pairs of 6500's-sorry Cisco.
    Each of these environments are tied together by a core routing environment, running on the same pair of 6500's. No WAN MPLS is going on and I am trying to use VRF for each of the routed environments core router. The management functions of the 6500 shall run off the VRF Core router and ip range (the one that ties all the other VRF's together. Here is a simple diagram:
    VRF1
    ||
    FW1
    ||
    VRFCOR
    ||
    FW2
    ||
    VRF2
    So to go from VRF1 to VRF2, you traverse two firewalls and VRFCOR.
    Several questions related to this design:
    1) Am I nuts to use VRF's in this application?
    2) Is there a better choice than VRF's to do what I want?
    3) Should VRFCOR be the global routing table (IOW, not a VRF)? Or should be its own VRF? Another way to ask this is: Shall a router ever run entirely in VRF tables, or should there be at least one global table in use?
    4) Are there problems with any management protocols on a VRF, such as NTP, AAA, SNMP, LOGGING, TELNET? Or have all those been worked out?
    5) Any other suggestions?
    TIA, Will

    VRF is suited for such kind of an application. Refer to URL http://cisco.com/application/pdf/en/us/guest/netsol/ns171/c649/ccmigration_09186a0080851cc6.pdf to get an idea about the

  • Vrf routes into global route table

    Dear All
    I am stuck with a design I am trying to come up with for our EDGE network and looking for ideas from the community.
    It is similar to what is described here:
    http://www.cisco.com/en/US/docs/solutions/Enterprise/Network_Virtualization/ServEdge.html#wp86450http://www.cisco.com/en/US/docs/solutions/Enterprise/Network_Virtualization/ServEdge.html#wp86904
    In short we have a multi-context FWSM at 2 sites creating an EDGE network, each site operate independently. The sites are linked internally in a single routing domain using OSPF. Each of the outside networks are in seperate VRFs, single-tier model.
    I need to find a way to:
    1) link the 2 sites (currently is done with a GRE tunnel between the site vrfs, looking at replacing this with mp-bgp and l3vpn encapsulation)
    2) redistribute routes from each of the vrf into the common global route table (running ospf)
    1 is working nicely with mp-BGP peer between the sites and routes distributed between, however I am stuck on how to achieve 2.
    The only way I can see is to change the global route table to a vrf, then use rt import/export. This is commonly described as shared services. When I did that I got stuck with how to do the BGP peering as the loopback I was using for the peering is inside the new vrf.
    Basically I want dynamic routing from the global route table to learn routes from each of the sites vrf. Then if a particular site's vrf is unavailable, it can pick up the other site's route.
    Am I missing something here? The document linked makes it sound incredibly easy yet I am struggling with how to implement it.
    Any advice is much appreciated

    Hello philip,
    It is really hard to help you, if you do not provide topology where you would like to implement these changes, so just some thoughts to your points:
    2) redistribute routes from each of the vrf into the common global route table (running ospf)
    You can use PE - CE design. VRFs are terminated on PE with all routes you need in respective VRFs. On PE, MP-BGP routes are redistributed into respective VRF's OSPF process . PE is connected with CE via separate physical interface for each VRF or you can use one physical interface with dedicated sub-interface for each VRF. PE is peering with CE using OSPF. All routes end up in CE global routing table.
    Problems with this design ->
    - for each VRF you have to create separate OSPF process on PE and CE, also OSPF process ID has to be unique on PE for each VRF. Also OSPF process ID has to match to establish OSPF neighborship between PE-CE, so on CE you will have to redistribute OSPF routes from each process to your main OSPF process.
    other workarounds ->
    1) instead OSPF you will use as peering protocol BGP between PE-CE, but you still have to redistribute BGP routes to OSPF on CE
    2) you will use different PE to redistribute each VRF -> BGP routes will be redistributed from VRF into OSPF (same process ID as your main OSPF ID). Routes will be advertised via OSPF into CE global routing table.
    You will use on PE per VRF to redistribute routes into OSPF with same process ID as your main process ID. Thanks to different PEs, you can have same OSPF process ID, all these PEs will peer with same CE via OSPF.
    I hope I made my thoughts understandable, cause its quite hard to explain
    When I did that I got stuck with how to do the BGP peering as the loopback I was using for the peering is inside the new vrf.
    This should not be a problem. You can have same IP on all VRF and also global table, so peering can still be done. After BGP routes are exchanged you can leak prefixes from one vrf to another or into global table as you need.
    Best Regards
    Please rate all helpful posts and close solved questions

  • Redundant access from MPLS VPN to global routing table

    Several our customers have MPLS VPNs deployed over our infrastructure. Part of them requires access to Internet (global routing table in our case).
    As I'm not aware of any methods how to dynamicaly import/export routes between VRF/Global routing tables, at the moment there are static routes configured - one inside VRF pointing to global next hop, another one in global routing table, pointing to interface inside VRF.
    Task is to configure redundant access to Internet. By redundancy I mean using several exit points (primary and backup), what physically represents separate boxes.
    Here comes tricky part - both global static routes (on both boxes, meaning) are valid and reachable in all cases - no matter if specific prefix is reachable in VRF or not. What I'd like to achieve is that specific static route becomes valid only if specific prefix is reachable inside VRF. Yea, sounds like dynamic routing :), I know
    OK, hope U got the idea. Any solutions/recommendations ? Running all Internet routing inside VRF isn't an option, at least for now :(

    Hi Andris,
    I did not mean to have a VRF on the CE. The CE would have both PVCs in the global routing table - his ONLY routing table in fact. One PVC would be used to announce routes into the customer specific VPN (VRF configured on the PE). The other PVC would allow for internet access through the PE (global IP routing table on the PE).
    dot1q will be ok as well.
    This way the CE can be a normal BGP peer to the PE, i.e. there is no MPLS VPN involved here. This allows all options of customer-ISP connectivity.
    Example:
    PE config:
    interface Serial0/0
    encapsulation frame-relay
    interface Serial0/0.1 point-to-point
    description customer VPN access
    ip vrf customer
    ip address 10.1.1.1 255.255.255.252
    interface Serial0/0.2 point-to-point
    description customer Internet access
    ip address 192.168.1.1 255.255.255.252
    router rip
    address-family ipv4 vrf customer
    version 2
    network 10.0.0.0
    no auto-summary
    redistribute bgp 65000 metric 5
    router bgp 65000
    neighbor 192.168.1.2 remote-as 65001
    address-family ipv4 vrf customer
    redistribute rip
    CE config:
    interface Serial0/0
    encapsulation frame-relay
    interface Serial0.1 point-to-point
    description VPN access
    ip address 10.1.1.2 255.255.255.252
    interface Serial0.2 point-to-point
    description Internet access
    ip address 192.168.1.2 255.255.255.252
    router bgp 65001
    neighbor 192.168.1.1 remote-as 65000
    router rip
    version 2
    network 10.0.0.0
    no auto-summary
    Of course you can replace RIP with whatever is suitable for you. And don´t sue me when you do not apply required BGP filters for internet access... ;-)
    The other option ("mini internet") would be feasible as well. Just make sure your BGP filters are NEVER messed up and additionally apply a limit on the numbers of prefixes in your VRF mini-internet.
    Regards
    Martin

  • GLOBAL TEMPORAY TABLE  with the ability for a user to see others's entries

    I have a list of record available for many user at the same time for them to work on.
    Every one has the tendency to chosse the first record...
    I want each of the users to be able to chose a different record once the preceding record has been selected by another user.
    It would have been somthing like a GLOBAL TEMPORAY TABLE but with the ability for every user to see others records
    so I would do and anti-join...
    Does anyon have an idea on how I could implement such a behavior?

    You will not be able to use a global temporary table for such a requirement.
    It sounds like you will need a permanent table, which you will need to lock certain records (prohibiting users from taking those already in use), you can look at using the DBMS_LOCK package for this.
    That's just speculation based on what you've typed, if you provide more details you make get more specific help.

  • Global Temp table with BLOB causing session crash

    Hi,
    i have a table as follows:
    create global temporary table spg_file_import (
    name varchar2 (128) constraint sfi_nam_ck not null,
    mime_type varchar2 (128),
    doc_size number,
    dad_charset varchar2 (128),
    last_updated date,
    content_type varchar2 (128),
    content long raw,
    blob_content blob
    on commit delete rows
    this is my 9ias 'document' table thats used to receive uploaded files which i modified to be global temporary.
    what i want to do is:
    a)upload a text file (xml)
    b) convert that file to clob
    c) store that file in new permanent table as clob
    d) commit (hence delete temp table rows as they are no longer necessary)
    to test it i have:
    CREATE OR REPLACE procedure daz_html
    as
    begin
    htp.p(' <FORM enctype="multipart/form-data" action="daz_fu" method="POST">');
    htp.p(' <p>');
    htp.p(' File to upload: <INPUT type="file" name="p_file_in"><br>');
    htp.p(' <p><INPUT type="submit">');
    htp.p(' </form>');
    htp.p('</body>');
    htp.p('</html>');
    end;
    CREATE OR REPLACE procedure daz_fu (
    p_file_in varchar2
    as
    -- BLOB Stream locator
    v_raw blob;
    v_clob clob;
    v_blob_length number;
    v_length number;
    v_buffer varchar2(32767);
    v_pos number := 1;
    begin
    -- Get xml document from transient 9iAs data store.
    select blob_content
    into v_raw
    from spg_file_import
    where name = p_file_in;
    -- create temp LOB
    dbms_lob.createtemporary(v_clob, false);
    -- get BLOB length
    v_blob_length := dbms_lob.getlength(v_raw);
    loop
    -- get length to read. this is set as a max length of 32767
    v_length := least((v_blob_length - (v_pos-1)),32767);
    -- assign BLOB to a varchar2 buffer in preparation to convert to CLOB
    v_buffer := utl_raw.cast_to_varchar2(dbms_lob.substr(v_raw, v_length, v_pos));
    -- now write out to the CLOB
    dbms_lob.writeappend(v_clob, v_length, v_buffer);
    -- increment our position.
    v_pos := v_pos + v_length;
    -- exit when we are done.
    exit when v_pos >= v_blob_length;
    end loop;
    commit;
    htp.p('commit done!');
    end;
    now if i upload a small text file (about 5kb) it works with no problem.
    however if I upload a large text file (say about 1Mb) it crashes oracle with:
    Fri, 26 Jul 2002 11:49:24 GMT
    ORA-03113: end-of-file on communication channel
    DAD name: spgd1
    PROCEDURE : daz_fu
    USER : spg
    URL : http://www.bracknell.bt.co.uk/pls/spgd1/daz_fu
    PARAMETERS :
    ============
    p_file_in:
    F22210/Document.txt
    this produces a large trc file.. the trace file indicates the crash occured on the commit; line
    Current RBA:[0x4eb0.117.10]
    *** 2002-07-26 12:35:11.857
    ksedmp: internal or fatal error
    ORA-00600: internal error code, arguments: [kcblibr_user_found], [4294967295], [2], [12583564], [65], [], [], []
    Current SQL statement for this session:
    declare
    rc__ number;
    begin
    owa.init_cgi_env(:n__,:nm__,:v__);
    htp.HTBUF_LEN := 255;
    null;
    daz_fu(p_ref_in=>:p_ref_in,p_type_in=>:p_type_in,p_file_in=>:p_file_in);
    if (wpg_docload.is_file_download) then
    rc__ := 1;
    wpg_docload.get_download_file(:doc_info);
    null;
    commit;
    else
    rc__ := 0; null;
    commit;
    owa.get_page(:data__,:ndata__);
    end if;
    :rc__ := rc__;
    end;
    ----- PL/SQL Call Stack -----
    object line object
    handle number name
    812b1998 42 procedure SPG.DAZ_FU
    819dff90 7 anonymous block
    ----- Call Stack Trace -----
    If i reaplce the temporary table with a non-temp table of the same structure i get no problems what-so-ever. Am I doing something that I shouldnt be with global temporary tables?
    Thanks.

    This is on Oracle 8.1.7.2

  • How to build a table with two For Loop

    Hi,
    I have two Loop For and I want to build a table with N columm (N = a loop + b loop)
    You can see my example.
    Thank's a lot
    Attachments:
    help_table.zip ‏10 KB

    I think this is the solution that you are going for.
    -Jim
    Attachments:
    help_table.vi ‏26 KB

  • Problem with global temporary table with rows

    Scenario :
    I need to create a table for generating a report in a oracle 10g database. Data population in the table depends on the parameter passed from front end.
    I have created global temporay table to achieve this. But use of same table by another user is not possible.
    I have created the global temporary table as follows:
    ''Create global temporay table xyz (a varchar2(10),b varchar2(10)) on commit preserve rows''

    You have not posted much details.
    But yes, global temporary tables are session specific. So other session won't see anything.
    Amardeep Sidhu
    http://amardeepsidhu.com/blog
    http://oracleadmins.wordpress.com

  • EBS Tables with relation for OBIA Report columns.

    Hi Friends,
    We are trying to find the required EBS Tables for the below tables of HR module report. Please find the tables in OBI query.
    select sum(case when T91397.GROUP_ACCOUNT_NUM = 'CONT EXP' then case when T91707.OTHER_DOC_AMT is null then 0 else T91707.OTHER_DOC_AMT * T91707.GLOBAL1_EXCHANGE_RATE end else 0 end ) as c1,
    sum(case when T91397.GROUP_ACCOUNT_NUM = 'EMP SUPP' then case when T91707.OTHER_DOC_AMT is null then 0 else T91707.OTHER_DOC_AMT * T91707.GLOBAL1_EXCHANGE_RATE end else 0 end ) as c2,
    sum(case when T91397.GROUP_ACCOUNT_NUM in ('GEN PAYROLL', 'MKTG PAYROLL', 'R&D PAYROLL', 'SLS PAYROLL') then case when T91707.OTHER_DOC_AMT is null then 0 else T91707.OTHER_DOC_AMT * T91707.GLOBAL1_EXCHANGE_RATE end else 0 end ) as c3,
    sum(case when T91397.GROUP_ACCOUNT_NUM = 'EMP BENFT' then case when T91707.OTHER_DOC_AMT is null then 0 else T91707.OTHER_DOC_AMT * T91707.GLOBAL1_EXCHANGE_RATE end else 0 end ) as c4,
    sum(case when T91397.GROUP_ACCOUNT_NUM = 'COGS' then case when T91707.OTHER_DOC_AMT is null then 0 else T91707.OTHER_DOC_AMT * T91707.GLOBAL1_EXCHANGE_RATE end else 0 end ) as c5,
    sum(case when T91397.GROUP_ACCOUNT_NUM = 'REVENUE' then case when T91707.OTHER_DOC_AMT is null then 0 else T91707.OTHER_DOC_AMT * T91707.GLOBAL1_EXCHANGE_RATE end else 0 end ) as c6,
    T66755.PER_NAME_MONTH as c7
    from
    W_DAY_D T66755 /* Dim_W_DAY_D_Common */ ,
    W_GL_ACCOUNT_D T91397 /* Dim_W_GL_ACCOUNT_D */ ,
    W_GL_OTHER_F T91707 /* Fact_W_GL_OTHER_F */ ,
    W_STATUS_D T96094 /* Dim_W_STATUS_D_Generic */ ,
    W_MCAL_DAY_D T300914 /* Dim_W_MCAL_DAY_D_Ent */
    where ( T66755.ROW_WID = T300914.MCAL_DAY_DT_WID and T66755.PER_NAME_YEAR = '2009' and T91397.ROW_WID = T91707.GL_ACCOUNT_WID and T91707.DOC_STATUS_WID = T96094.ROW_WID and T91707.DELETE_FLG = 'N' and T91707.ACCT_PERIOD_END_DT_WID = T300914.ROW_WID and (T96094.W_STATUS_CODE in ('POSTED', 'REVERSED')) )
    group by T66755.PER_NAME_MONTH
    select sum(case when T299373.W_EMPLOYMENT_STAT_CODE = 'A' then T299423.HEADCOUNT else 0 end ) as c1,
    sum(T299423.HEADCOUNT) as c2,
    T100027.PER_NAME_MONTH as c3
    from
    W_MONTH_D T100027 /* Dim_W_MONTH_D */ ,
    W_EMPLOYMENT_STAT_CAT_D T299373 /* Dim_W_EMPLOYMENT_STAT_CAT_D */ ,
    W_WRKFC_BAL_A T299423 /* Fact_Agg_W_WRKFC_BAL_A */
    where ( T100027.ROW_WID = T299423.SNAPSHOT_MONTH_WID and T100027.PER_NAME_YEAR = '2009' and T299373.ROW_WID = T299423.EMPLOYMENT_STAT_CAT_WID and T299423.CAL_MONTH_START_DT <= TO_DATE('2013-05-01 00:00:00' , 'YYYY-MM-DD HH24:MI:SS') )
    group by T100027.PER_NAME_MONT
    Of course, if we can go through back track like:
    OBI <-- Infa PLP <-- Infa SILOS <-- Infa SDE <-- SDE Mappletes <-- Source Qualifier <-- Sql Query.
    We are getting no.of tables for single obi table. But, we need only required tables for the above OBI queries for single report.
    Please correct me if wrong and guide me with better approach..
    Thanks in advance.. Appreciate ur inputs here.
    Best Regards,
    Raghu Nagadasari
    Edited by: Raghava Nagadasari on May 1, 2013 5:30 AM
    Edited by: Raghava Nagadasari on May 1, 2013 5:31 AM

    I would say it is part of unit testing; writing ebs query, get results and compare with BI results and some times compare bi query to match some part of criteria.
    I would say just understand the requirements and try to write it, it might take some time but it helps a lot.
    Lineage docs might help some extend to know the source tables, check here
    http://www.cool-bi.com/Ref/Ref.php
    Edited by: Srini VEERAVALLI on May 1, 2013 9:44 AM

  • XMLGEN: Produce XML dump of a table WITH tags for null column values

    I am new to generating XML so bear with me....
    We have a customer who needs an XML extract of data, including tags for any column that is null.
    I created a simple test case below using DBMS_XMLGEN.getXML. The first row (A1) has no null values and thus tags for columns A, BEE and CEE are produced. The second row (A2) has null in column BEE and thus tags for only columns A and CEE are produced.
    Is there a way to force a tag for null column BEE in the second row?
    create table foo (A varchar2(10), BEE number, CEE date);
    insert into foo values ('A1',1,sysdate);
    insert into foo values ('A2',null,sysdate);
    SELECT DBMS_XMLGEN.getXML('SELECT * FROM foo') FROM dual;
    <ROWSET>
    <ROW>
    <A>A1</A>
    <BEE>1</BEE>
    <CEE>27-SEP-12</CEE>
    </ROW>
    <ROW>
    <A>A2</A>
    <CEE>27-SEP-12</CEE>
    </ROW>
    </ROWSET>

    What's the database version? (SELECT * FROM v$version)
    Could you use this instead :
    SQL> select xmlserialize(document
      2           xmlelement("ROWSET",
      3             xmlagg(
      4               xmlelement("ROW",
      5                 xmlelement("A", a)
      6               , xmlelement("BEE", bee)
      7               , xmlelement("CEE", cee)
      8               )
      9             )
    10           )
    11         -- for display purpose only :
    12         as clob indent
    13         )
    14  from foo
    15  ;
    XMLSERIALIZE(DOCUMENTXMLELEMEN
    <ROWSET>
      <ROW>
        <A>A1</A>
        <BEE>1</BEE>
        <CEE>2012-09-27</CEE>
      </ROW>
      <ROW>
        <A>A2</A>
        <BEE/>
        <CEE>2012-09-27</CEE>
      </ROW>
    </ROWSET>
    Or,
    SQL> select xmlserialize(document
      2           xmlquery(
      3             '(#ora:view_on_null empty #)
      4             {
      5               <ROWSET>{fn:collection("oradb:/DEV/FOO")}</ROWSET>
      6             }'
      7             returning content
      8           )
      9           as clob indent
    10         )
    11  from dual;
    XMLSERIALIZE(DOCUMENTXMLQUERY(
    <ROWSET>
      <ROW>
        <A>A1</A>
        <BEE>1</BEE>
        <CEE>2012-09-27</CEE>
      </ROW>
      <ROW>
        <A>A2</A>
        <BEE/>
        <CEE>2012-09-27</CEE>
      </ROW>
    </ROWSET>
    (where "DEV" is my test schema)
    If you want to stick with DBMS_XMLGEN, you're gonna have to use PL/SQL and setNullHandling procedure.
    Edited by: odie_63 on 27 sept. 2012 17:14

  • Table with barcode for incomming invoice

    Hello,
    i need small help. When we are storing incoming invoice we have a popup with a barcode. Where is then barcode information stored(in which table)? i was not succesfull while searching for this table....and i dont know if our customizing is done well and barcode is really stored
    thanks,
    JJ

    Try TOA01 <a href="http://help.sap.com/erp2005_ehp_02/helpdata/en/d7/e21dde408e11d1896b0000e8322d00/content.htm">More details!</a>

  • Create Table with Compress for OLTP and error ORA-14464

    Hello,
    i have a Oracle-DB 11.2 and want to use Advanced Compression.
    I want to create a table:
    CREATE TABLE TD_GE_1990
    ( "name_id" NUMBER(1,0),
    "name_txt" VARCHAR2(100 BYTE)
    ) COMPRESS FOR OLTP;
    But i get:
    SQL-Fehler: ORA-14464: Kompressionstyp nicht angegeben
    The "compatible"-Parameter is set to 11.1:
    SELECT value
    FROM gv$parameter
    WHERE name LIKE '%compatible%';
    11.1.0.0.0
    Do i have to change something in the database?
    Best regards
    Heidi

    14464, 00000, "Compression Type not specified"
    // *Cause: Compression Type was not specified in the Compression Clause.
    // *Action: specify Compression Type in the Compression Clause.                                                                                                                                                                                                                                                                                                                                                                                   

  • Table with Values for Displaying Icons in a Report

    I have found a report that displays red, green and yellow lights to help users to quickly review the results.
    Code has statements such as WRITE: AT /1 '@5B@' AS ICON. "(GREEN LIGHT)
      WRITE: AT /1 '@5C@' AS ICON. "red light
    I would like to know where I can go in SAP to see what other ICONS can be displayed and what the code would be.
    For example - I found the writing WRITE: AT /1 '@5D@' AS ICON - and using @5D@ you get a yellow warning.
    Thanks!
    Scott

    Rob,
    Code value will not be available in table ICON.
    its available in Type group ICON
    ie SE11--> select Type Group > ICON> display
    Here is sample
    CON_2 ICON_DUMMY                     '@00@'."  PlaceholderIcon
    ICON_2 ICON_CHECKED                   '@01@'."  Checked; OK
    ICON_2 ICON_INCOMPLETE                '@02@'."  Incomplete
    ICON_2 ICON_FAILURE                   '@03@'."  Failed
    ICON_2 ICON_POSITIVE                  '@04@'."  Positive

  • Create table with sqlstudio for sapdb

    Hi all,
    I try to use a created table in sapdb in my webdynpro, but when I run my application I the following error: contains the semantics error[s]: table "BE_DEPARTMENT" unknown. When I create the table by using NWDS then I the error is solved.
    In sqlstudio I used CREATE TABLE. What must I do after this statement so that I can use the created table in my NWDS
    I use a JDBC connection in my Webdynpro
    Regards,
    Richard

    Please have a look at these
    /people/kathirvel.balakrishnan2/blog/2005/04/16/how-to-manipulate-a-maxdb-database-using-jdbc--part-1
    /people/kathirvel.balakrishnan2/blog/2005/04/22/how-to-manipulate-a-maxdb-database-using-jdbc--part-2
    https://pwdf1209.dmzwdf.sap.corp/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/documents/a1-8-4/how to create tables in maxdb using sql studio.pdf
    Cheers
    Kathir

  • Route leaking from VRF to Global on same router with VLAN interface

    Hi all,
    I would like to do some route leaking from VRF to Global and Global to VRF on the same router. Here is an output of the config:
    interface FastEthernet4
    description ***Connection to WAN***
    ip vrf forwarding FVRF
    ip address 10.0.0.6 255.255.255.0
    interface Vlan100
    description ***LAN***
    ip address 192.168.227.1 255.255.255.0
    So what I want is to import 192.168.227.0 /24 into FVRF and import 10.0.0.0 /24 into the global routing table.
    I though I could do that config but it is not possible:
    (config)#ip route vrf FVRF 192.168.227.0 255.255.255.0 vlan 100
    % For VPN or topology routes, must specify a next hop IP address if not a point-to-point interface
    OR
    DK-SLVPN(config)#ip route vrf FVRF 192.168.227.0 255.255.255.0 vlan 100 192.168.227.1 global
    %Invalid next hop address (it's this router)
    Any ideas are really welcome.
    Best regards,
    Laurent

    Hi,
    I have tried the following solution:
    Add 10.0.0.0 /24 From VRFto Global:
    ip route 10.0.0.0 255.255.255.0 FastEthernet4
    Add 192.168.227.0 /24 from Global to VRF:
    router bgp 64512
    bgp log-neighbor-changes
    address-family ipv4
      no synchronization
      redistribute connected
      no auto-summary
    exit-address-family
    ip prefix-list Global-VRF seq 5 permit 192.168.227.0/24
    route-map Global permit 10
    match ip address prefix-list Global-VRF
    ip vrf FVRF
      rd 1:1
      import ipv4 unicast map Global
    So now the VRF table looks like that:
    #      sh ip route vrf FVRF
    C        10.0.0.0/24 is directly connected, FastEthernet4
    S        10.0.0.1/32 [254/0] via 10.0.0.1, FastEthernet4
    L        10.0.0.6/32 is directly connected, FastEthernet4
    B     192.168.227.0/24 is directly connected, 00:15:12, Vlan100
    The Global table looks like this:
    #sh ip route
    Gateway of last resort is 10.1.0.107 to network 0.0.0.0
    D*    0.0.0.0/0 [90/1709056] via 10.1.0.107, 3d02h, Tunnel1
           10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
    S        10.0.0.0/24 is directly connected, FastEthernet4
    C        10.1.0.0/24 is directly connected, Tunnel1
    L        10.1.0.227/32 is directly connected, Tunnel1
    C        10.2.0.0/24 is directly connected, Tunnel2
    L        10.2.0.227/32 is directly connected, Tunnel2
    C        10.10.10.227/32 is directly connected, Loopback100
           192.168.227.0/24 is variably subnetted, 2 subnets, 2 masks
    C        192.168.227.0/24 is directly connected, Vlan100
    L        192.168.227.1/32 is directly connected, Vlan100
    But When I try to ping it still doesn´t work:
    #ping vrf FVRF 192.168.227.1 source fastEthernet 4
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.227.1, timeout is 2 seconds:
    Packet sent with a source address of 10.0.0.6
    Success rate is 0 percent (0/5)
    #ping 10.0.0.1 source vlan 100
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.227.1
    Success rate is 0 percent (0/5)
    Any ideas?
    Regards,
    Laurent

Maybe you are looking for

  • Okay... i need some help.

    Im trying to link a pdf file from my computer to a project. I imported a flash Catalyst project into Builder and need step by step instruction to create a hyperlink to a pdf on my computer. If anyone can help me with this it would be greatly apriciat

  • How to pull the job with the latest effective date in PSFT?

    Hello, I am running the PSFT 9.1.1 connector workforcefullsync. I ran into a problem when the user has multiple job records. Each time that the user job is updated, a new job record is created. So, when the data comes from PSFT, for a user, we have m

  • Some component in my application is filtered by the AD Hunter,help

    the AD HUNTER filter the web page content by blocking those item with "ad" like pattern in the url,what can i do ,the javascript file and the images are all blocked. :'(

  • File Upload/Download, updating to SAP

    Hi All: Has anyone implemented the file upload functionality? Could you please share the details.... Iam successfully passing the file name from WD but get short dump with "   Termination occurred in the ABAP program "SAPLCNDP" - in      "DP_CONTROL_

  • HT204365 PDFs no longer have iBooks as an option

    Hi, since I updated my iPad, the "open in iBooks" option has disappeared from PDFs, web publications etc and so I can't put any new PDFs into iBooks.  Any suggestions? Many thanks, Jacqueline