Simple Xmonad configuration help needed.

I have no idea how haskell works at all. But I simply love xmonad!
Could someone help me out with my configuration? It is currently
import XMonad
import XMonad.Config.Xfce
main = xmonad xfceConfig
This works pretty well for me, for the most part. However, I need a few keybinding. First, I want ctrl-alt-arrow to change desktops and I found I can do this with "XMonad.Actions.CycleWS", which I have installed and the configuration of:
, ("M-<Left>", prevWS )
, ("M-<Right>", nextWS )
, ("M-S-<Left>", shiftToPrev )
, ("M-S-<Right>", shiftToNext )
However, I have no idea how to do this. Also, I would like XF86AudioRaiseVolume to execute "amixer set Master 5dB+" and XF86AudioLowerVolume to "amixer set Master 5dB-" and XF86AudioMute to "amixer set Master toggle". I know I could easily do this with xbindkeys or some other extra keybinding daemon, but I want to learn how to do this the correct way in haskell. Thanks!

Is this your whole xmonad.hs ? Anyway for the keybindings part ( for multimediakeys i use xbindkeys because i use the same xmonad.hs on my laptop plus desktop ) , but you can do it without xbindkeys wich is much nicer, less apps needed. If your keys are already reconignized as XF86AudioMute then you wouldnt have to use xmodmap. You can define keys in two various ways in XMonad with the additional keysP (Util.EZconfig ) or with keys = Mykeys
I always learn from looking into others people's configs , so here is an config from another arch user. Look for the section myKeys, and define something like :
, ("<XF86AudioLowerVolume>", spawn amixer set Master 5dB+)
if you are interested here is my config
Further reference
Last edited by jelly (2009-07-31 00:31:09)

Similar Messages

  • 1941W configuration help needed

    Our Deployment Scenario:-
    1941W Gigabit Ethernet 0/0 is connected to the PPOE connection of the ISP.
    Gigabit Ethernet 0/1 is connected to the wired LAN
    I have created 2 wireless radio Cisco_Kamran_BGN which is operating at 2.4 Ghz Devices and Cisco_Kamran_A which is operating at 5Ghz Devices.
    I have created 2 VLans for the Wireless.
    Vlan 10 for Cisco_Kamran_A        192.168.10.x
    Vlan 11 for Cisco _Kamran_BGN   192.168.11.X
    The problem is the Wireless users are not getting the IP address from the respective DHCP server which has been configured on the Router.
    Can please any from the community help me and show me where I am missing the configuration.
    Please find my router  & ap configuration below.
    Router Configuration
    Router#
    sh run
    Building configuration...
    Current configuration : 3022 bytes
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$TdQt$npYeaf/W0kRElcfMggzJ31
    no aaa new-model
    service-module wlan-ap 0 bootimage autonomous
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.50
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp excluded-address 192.168.11.1 192.168.11.10
    ip dhcp pool DHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_A
    network 192.168.11.0 255.255.255.0
    default-router 192.168.11.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_BGN
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 195.225.241.222 213.42.20.20
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    license udi pid CISCO1941W-E/K9 sn FCZ1553C1VK
    hw-module ism 0
    redundancy
    bridge irb
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered GigabitEthernet0/0
    arp timeout 0
    no mop enabled
    no mop sysid
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface Wlan-GigabitEthernet0/0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    no ip address
    interface Vlan1
    no ip address
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Vlan11
    ip address 192.168.11.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxx password 0 xxxxxx
    ppp ipcp route default
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list DSL_ACCESSLIST interface Dialer1 overload
    ip access-list extended DSL_ACCESSLIST
    permit ip 192.168.0.0 0.0.255.255 any
    control-plane
    line con 0
    password xxxxxx
    login
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    password xxxxxx
    login
    transport input all
    scheduler allocate 20000 1000
    end
    Router#
    Router#
    Router#
    Access Point Configuration
    ap#
    ap#
    ap#
    sh run
    Building configuration...
    Current configuration : 2603 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$JxdQ$a2/00bWJuhUKP9QLC94YD/
    no aaa new-model
    dot11 syslog
    dot11 ssid Cisco_Kamran_A
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 1045081417161C5A555C7A7B
    dot11 ssid Cisco_Kamran_BGN
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 020D05561907017015165949
    username Cisco password 7 14341B180F0B
    bridge irb
    interface Dot11Radio0
    description 802.11bgn radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    broadcast-key change 3600
    ssid Cisco_Kamran_BGN
    antenna gain 0
    station-role root
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface Dot11Radio1
    description 802.11a radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    ssid Cisco_Kamran_A
    antenna gain 0
    no dfs band block
    channel dfs
    station-role root
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0
    description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface GigabitEthernet0.10
    description 802.11a bridge
    encapsulation dot1Q 10
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0.11
    description 802.11bgn bridge
    encapsulation dot1Q 11
    no ip route-cache
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface BVI1
    ip address dhcp client-id GigabitEthernet0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    no activation-character
    line vty 0 4
    login local
    end
    ap#
    ap#
    ap#

    Hi Stepehen,
    Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.
    Home
    Re: 1941W configuration help needed
    created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion
    conf t
    interface     Dot11Radio0
    no ssid     Cisco_Kamran_BGN
    no encryption mode     ciphers aes-ccm
    exit
    interface     Dot11Radio1
    no encryption mode     ciphers aes-ccm
    no ssid     Cisco_Kamran_A
    exit
    dot11 ssid     Cisco_Kamran_A
    vlan 10
    dot11 ssid     Cisco_Kamran_BGN
    vlan 11
    exit
    interface     Dot11Radio0
    encryption vlan 11     mode ciphers aes
    ssid     Cisco_Kamran_BGN
    exit
    interface     dot11radio0.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio 0.11
    encapsulation     dot1q 11
    bridge-group 11
    Configuration of     subinterfaces and main interface
    within the same bridge     group is not permitted
    exit
    interface     Dot11Radio1
    encryption vlan 10     mode ciphers aes-ccm
    ssid     Cisco_Kamran_A
    interface     dot11radio1.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio1.10
    encapuslation     dot1q 10
    bridge-group 10
    Configuration of subinterfaces and main     interface
    within the same bridge     group is not permitted
    end
    wr
    Reply to this message by going to Home
    Start a new discussion in Getting Started with Wireless at Home

  • Multiple ethernet network adaptors + MySQL/php5: configuration help needed

    I would be grateful if someone could give me some advice on how to configure multiple ethernet adapters under OS X 10.5.6
    I have set up my system to work nicely with two ethernet network adapters, each with its own fixed IP. This bit works just fine. The machine supports two separate servers - a mail server and the OS X Apache2 server. I have configured the mail server to only listen to one of the IPs, and the Apache2 server to listen to the other (via httpd.conf). The system also has MySQL and php5 installed / enabled, and these services are only used by the Apache2 server.
    The problem I have is that when I start the machine, initially the php5 system cannot connect reliably to the MySQL database system. The fix I have found is to temporarily make the ethernet adapter connected to the mail server 'inactive'. While this is so, the php5/MySQL connection to Apache2 works. Curiously, once an initial connection between php5 and MySQL has been made, subsequently I can make the mail server's ethernet adapter active again without further problems.
    I initially thought this might be due to 'service order' issues - but changing the service order (e.g. putting the Apache adapter 'above' the mail adapter in the service order does not help. The fix only works by making the mail adapter inactive temporarily.
    I suspect that there is some configuration change I can make to clarify the setup I have. The MySQL and Apache installations only need to talk to the Apache server - but I am not sure how to record this configuration in the OS X system.
    Thanks in advance for any assistance that you can provide.
    Message was edited by: Gavin Lawrie

    Hi Stepehen,
    Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.
    Home
    Re: 1941W configuration help needed
    created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion
    conf t
    interface     Dot11Radio0
    no ssid     Cisco_Kamran_BGN
    no encryption mode     ciphers aes-ccm
    exit
    interface     Dot11Radio1
    no encryption mode     ciphers aes-ccm
    no ssid     Cisco_Kamran_A
    exit
    dot11 ssid     Cisco_Kamran_A
    vlan 10
    dot11 ssid     Cisco_Kamran_BGN
    vlan 11
    exit
    interface     Dot11Radio0
    encryption vlan 11     mode ciphers aes
    ssid     Cisco_Kamran_BGN
    exit
    interface     dot11radio0.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio 0.11
    encapsulation     dot1q 11
    bridge-group 11
    Configuration of     subinterfaces and main interface
    within the same bridge     group is not permitted
    exit
    interface     Dot11Radio1
    encryption vlan 10     mode ciphers aes-ccm
    ssid     Cisco_Kamran_A
    interface     dot11radio1.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio1.10
    encapuslation     dot1q 10
    bridge-group 10
    Configuration of subinterfaces and main     interface
    within the same bridge     group is not permitted
    end
    wr
    Reply to this message by going to Home
    Start a new discussion in Getting Started with Wireless at Home

  • Simple SAN configuration but need some help

    Hi,
    We have a little San configuration with 6 clients (G5) one MDC (XS G5) and 1 XSR 5.6 TB. XSan 1.2 / MDC and all machine 10.4.3 and 1 in 10.4.4
    Our clients are of two types :
    Two of them have only 1 local user account with admin privileges
    Four of them have 2 local accounts (one with admin privileges, the other normal)
    I just want that all people can access (read & write) the entire volume and folders.
    I don't want to use LDAP for that for some reasons (I want a local user on our FCP editing machines, and already have LDAP for other purposes and don't want to mix the problems).
    Here is my problem : when I copy some files from a client with admin user account, I don't have the write access to theses fils from a client with normal user account....
    but when I'm logged with admin, it works fine.
    How does XSan work for authentification and what I have to do to make my little system work ?
    Thank for your help
    Marcello
    all   Mac OS X (10.4.4)  
    all   Mac OS X (10.4.4)  
    all   Mac OS X (10.4.4)  

    The Xsan Quick-reference Guide from Peachpit Press is a good place to start. As I understand it, each computer should have the same list of users, in the same order. e.g. admin,edit1, edit3 etc. They should be entered in the same order so that their 'uid' is the same on each computer i.e. 501, 502, 503, although I think 'netinfo manager' goto 'users' lets you change the uid number.
    Once this is done, then use 'Tinkertool' application, to change 'permissions' the checked 'don't allow' to unchecked will then allow any user to read/write anything else written to the raid.

  • Simple BIP Report help needed

    Hi All ,
    I am bit new to BI Publisher,I have done plenty of Oracle reports 6i and 10g.
    Have read the BIPublisher Guide as well,but could not understand a few points.
    suppose I want to build a very very simple report like
    Sysdate Sysdate Sysdate
    16-Oct-08 16-Oct-08 16-Oct-08
    step 1) I will write the following query in the Data Model and store/save it.
    select sysdate ,sysdate,sysdate from dual.
    Step 2) In the layout model I want to use .rtf layout .So in the MS word .rdf document I create /insert
    a table with 2 rows and 3 columns,where 1st row will have Sysdate in all 3 columns as header.
    Now to fetch date 3times(the data) from the above query,WHAT is going to be my next steps ????
    I am not able to understand the link between the layout(.rtf document) and XML document.
    Please can someone reply to this question and let me know ?
    Regards
    Sunny

    I added a useless parameter just so you could see where parms should go...
    Datatemplate:
    <dataTemplate name="A_SIMPLE_REPORT">
         <properties>
              <property name="xml_tag_case" value="upper"/>
         </properties>
         <parameters>
              <parameter name="P_PARM" dataType="character"/>
         </parameters>
         <dataQuery>
              <sqlStatement name="QUERYNAME">
                   <![CDATA[
    select sysdate SYSDATE1
    , sysdate SYSDATE2
    , sysdate SYSDATE3
    from dual
    where 'XYZ' = nvl(:P_PARM, 'XYZ')
    ]]>
              </sqlStatement>
         </dataQuery>
         <dataStructure>
              <group name="G_UPPERGROUP" dataType="varchar2" source="QUERYNAME">
                   <element name="SYSDATE1" dataType="varchar2" value="SYSDATE1"/>
                   <element name="SYSDATE2" dataType="varchar2" value="SYSDATE2"/>
    <element name="SYSDATE3" dataType="varchar2" value="SYSDATE3"/>
              </group>
         </dataStructure>
         <dataTrigger name="afterReportTrigger" source="A_SIMPLE_REPORT.afterreport()"/>
    </dataTemplate>
    XML OUPUT:
    <?xml version="1.0" encoding="UTF-8" ?>
    <A_SIMPLE_REPORT>
    <LIST_G_UPPERGROUP>
    <G_UPPERGROUP>
    <SYSDATE1>2008-10-16T18:20:19.000-05:00</SYSDATE1>
    <SYSDATE2>2008-10-16T18:20:19.000-05:00</SYSDATE2>
    <SYSDATE3>2008-10-16T18:20:19.000-05:00</SYSDATE3>
    </G_UPPERGROUP>
    </LIST_G_UPPERGROUP>
    </A_SIMPLE_REPORT>
    Hope this helps,
    Scott
    PS If you have been doing reports for as long as you say you prob. know this already...but I NEVER* trust Oracle to convert my dates. I convert them all to char, pass them and convert them on "the other side" (if needed). But, you can change the data type to date if you feel brave, but don't say I didn't warn you. ;-)

  • EPM 11.1.1.3 Shared Services Configuration help needed

    Hi,
    I am currently running into issues when trying to configure Shared Services via the EPM System Configurator 11.1.1.3. I've installed Weblogic 9.3 MP3 with all of the default options (including establishing Node Manager as a service). I've also created a seperate userId in Weblogic called hyperion (with the password of hyperion) so that EPM can access the instance against the default web server.
    When I run the configurator to try and deploy to application server, the status sits there on the "Starting WebLogic 9 Admin Servers" and does nothing.
    Sometimes is does get past that but then the deployment fails because it is unable to deply the interop.war.
    Any help would be greatly appreciated as I'm 100% stuck!
    Thanks,
    Anju

    Hi,
    I am not sure what your issue is but I do know that you don't have to start creating users in weblogic. Usually you do a standard install of weblogic, if you are not going to use it you don't need the node manager set up.
    Cheers
    John
    http://john-goodwin.blogspot.com/

  • JMS Configuration Help Needed for Publish Subscribe Messaging

    Hi,
    I am new to JMS and need help to configure JMS from the sun admin console. As of now i have configured the topic and the connection factory from the JMS Resources under the Resources tab(here too i just specified the topic name and guest and password and jndi and similarly the connection factory name but have not specified any port or anything else), but i guess something is missing as i can publish but cannot subscribe nor can i view the messages on the topic..I think some sort of configuration is also need on the Java Message Service header under the Configuration tab.I have searched for this on the net but have not been able to find any sort of detailed help.If someone could give a detailed picture as too how to go about this configuration with an example it would be of great help.
    Vaishali Shah

    Sai,
    Seen this:
    http://tinyurl.com/pbshe
    Good Luck,
    Avi.

  • Simple HTML page HELP needed

    Hi all,
    Here's my dilemma:
    I've got this simple html page that I've made with
    dreamweaver CS3. On the starting page I want to put a section
    called "NEWS", under which there would be essentially a texfield
    with the news. Now, I don't want to put the news text in the html
    code. Rather, I'd like the code to somehow take this text from a
    separate text file which I could edit at will and simply overwrite
    on the host server so that changes are seen in browsers.
    I don't need a real CMS (besides, CMS is way over my head).
    Just this one text field. I've tried with the textfield/text
    area/HTML object/etc. in the 'insert' tool but none worked. Can
    this be done at all? Appreciate any help.

    macioo1 wrote:
    > Now, I don't want to put the news text in
    > the html code. Rather, I'd like the code to somehow take
    this text from a
    > separate text file which I could edit at will and simply
    overwrite on the host
    > server so that changes are seen in browsers.
    You can do this with a server-side include. The first thing
    you need to
    do is to find out whether your hosting company has enabled
    server-side
    includes, or if you have access to a server-side language
    such as ASP or
    PHP. The way that you create a server-side include is
    slightly different
    in each type of setup.
    When you have found what your remote server supports, someone
    can give
    you further instructions.
    David Powers, Adobe Community Expert
    Author, "The Essential Guide to Dreamweaver CS3" (friends of
    ED)
    Author, "PHP Solutions" (friends of ED)
    http://foundationphp.com/

  • Simple java applet help needed

    hi, im having trouble with an applet im developing for a project.
    i have developed an applet with asks the user for simple information( name,address and phone) through textfields, i wish for the applet to store this information in an array when an add button below the textfeilds is pressed.
    client array[];
    array=new client[];//needs to be an infinate array!
    I have created the client class with all the set and get methods plus constructors needed but i dont know how to take the text typed into the textfields by the user and store them in the array.
    i also need to save this info to a file and be able to load it back into the applet.
    Could some please help! Thank you for your time.

    Better maybe redefine the idea using an data structure :
    public class client{
    private char name[];
    private char address[];
    private int phone;
    public class vector_clients{
    private client vect[];
    // methods for vect[]
    What is your opinion about ???

  • Configurator help needed

    My MacBook Air was reimaged now configurator says unable to attach device to Apple Configurator, 60 devices to manage need help! I did have to download configurator again, iTunes and get all the apps from the cloud, but the devices think they are being connected to a different computer...

    Hi,
    I'm an ICT Manager at the international School of Turin - IST
    we have 350 ipad enrolled, and 60 between macbook air and iMac.
    After kill may self in a lot of different way I discover CiscoMeraki.
    Is an amazing tool for enroll all the devices, push and manage applications.
    Is completely free!!! https://account.meraki.com/secure/login/dashboard_login
    Give a look a let me know.
    Trust me before I was struggle like you!
    Alessandro

  • Hard drive configuration help needed.

    Just got the mac today and I'm starting the upgrades. This is how it will look. 3 1TB seagate drives. I am going to clone the factory drive to one. Install Vista through bootcamp on another.
    This is what The Hatter had mentioned in another post that I started. "Vista is easy to install, doesn't need any help really, doesn't run in, under, or through BootCamp. Just format a drive as Master Boot Record, setup one or more FAT partitions (you will need to delete and create NTFS when it gets to the install screen in Vista). Then once running, you install some Apple hardware services and support to allow switching, synching time, and such. And install the latest Nvidia Vista drivers."
    I can probably figure out how to get the process started, but I have no clue as to the specifics of the last sentence that starts "Then once running.....". If you see this Hatter, could you please give me the specifics? The third will be for storage.
    I noticed that there are no jumpers present on the Western Digital that came with it. So is removing the limiting jumper's from the Segate's the only settings I need to worry about?
    Lastly. When I install these drives, will Mac do the format or is there something I need to do first?
    Thanks in advance.

    You'll need to consult Seagate's configuration information for your drive model. You can locate it at Seagate's web site.
    Partitioning and formatting is done using Disk Utility in the Utilities folder. New drives that did not come installed from Apple should be prepped properly as follows:
    Extended Hard Drive Preparation
    1. Open Disk Utility in your Utilities folder. If you need to reformat your startup volume, then you must boot from your OS X Installer Disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger or Leopard.)
    2. After DU loads select your hard drive (this is the entry with the mfgr.'s ID and size) from the left side list. Note the SMART status of the drive in DU's status area. If it does not say "Verified" then the drive is failing or has failed and will need replacing. SMART info will not be reported on external drives. Otherwise, click on the Partition tab in the DU main window.
    3. Set the number of partitions from the dropdown menu (use 1 partition unless you wish to make more.) Click on the Options button, set the partition scheme to GUID (only required for Intel Macs) then click on the OK button. Set the format type to Mac OS Extended (Journaled.) Click on the Partition button and wait until the volume(s) mount on the Desktop.
    4. Select the volume you just created (this is the sub-entry under the drive entry) from the left side list. Click on the Erase tab in the DU main window.
    5. Set the format type to Mac OS Extended (Journaled.) Click on the Options button, check the button for Zero Data and click on OK to return to the Erase window.
    6. Click on the Erase button. The format process can take up to several hours depending upon the drive size.
    The exception would be if you plan to set up one entire drive for Vista. In that case when you partition the drive select MBR partition scheme rather than GUID and format the drive MSDOS. You need not use the Write Zeros option. When you install Vista it will reformat the drive NTFS.
    If you intend to use part of one drive for Vista and another partition for the Mac, then prep the drive for the Mac as outlined above. Then use Boot Camp to create the Windows partition on the drive. Boot Camp will install the MBR on the Windows partition which you cannot do from Disk Utility.

  • WLAN Controller configuration help needed

    Hi,
    I need to configure AP with WLAN controller for guest access. we have 2 vlans. vlan 1 - guess vlan (internet only access) and vlan 2 - all access.
    while configuring wlan controller. which vlan should i configure as native vlan? I have radius server which would check health of the user and would direct wlan controller to put in user in vlan 1 or 2 depending on its credentials.
    please advise how to implement it. what would be initial steps.

    Hi,
    I have couple of doubts before going further for solution to implement ?
    What model of wlan controller & AP , you are using ?
    to configure the Controller , initially you need to configure the interface ( which are virtual ) .
    You need to connect controller to your existing LAN set-up may be one of the port of your core switch ............
    below are the interface which you need to configure in controller .......
    1) Management interface with IP ( which will be used to access your controller from lan ... ) this is ip should be able to ping from the network.
    2) AP manager IP ( this is again depend on model ) if it is 5500 , this is not required ..
    3) Virtual IP : this is should the IP address which is not at all there in your lan eq.1.1.1.1
    4) dynamic interface with IP : this is the interface which will map your vlan to WLAN
    once you create the mentioned interfaces , you need to create the wlan and map the above dynamic interface with respective wlan.if required you can configure the DHCP pool as well in controller for Wlan.
    let me know , whether this information helped  you ........................

  • IPlanet/Sun ONE Directory Server 5.1 configuration help needed.

    Hi from Finland.
    We have a SunFire 420 running Solaris 8.
    It has 2 network adaptors each configured to have separate IP addresses. Eventually these cards will be on quite separate networks... one for intranet users and one for the rest.
    What I am wanting to know is how do I configure the iDS 5.1 to be listening on port 389 for both IPs
    When I installed iDS 5.1 I could only see one hostname and one domainname so the install went fine.
    Is the Directory with multiple network adaptors setup an O/S issue or an iDS issue???
    Any tips or help would be gratefully accepted!!

    All my PROD systems have dual n/w cards listenning on different IPs(subnets for that matter). Data can be accessed over LDAP on both IPs with the same port. We did not have to do anything special at the Directory or the OS level.

  • Configuration Help Needed - Layout of Public Access and Private Access Network

    HELP
         I need help in laying out the following network - herre is my first stab at it.
    1. Actiontec DSL Modem - DHCP On     ----- Model GT701-WG
       WAN IP Address 12.17.66.203
       WAN SubNet Mask 255.255.255.255
       Lan IP Address 192.168.0.1
       Lan SubNet Mask 255.255.255.0
    2. WRT54G - DHCP On ----------------  Open to Public Access to the Internet
       Local IP Address 192.168.1.1
       Subnet Mask 255.255.255.0
    3. DellPowerConnect 2708 Switch ---  Open to Public Access to the Internet
    4. MS Windows SBS2003 Server   --- Closed to Public Access
        Connecting to the #2 WRT54G thru a Linsys network card
    5. WRT54G - DHCP Off - ??? --------- Closed to Public Access
        Connecting to another Linksys network card in the SBS2003 Server
       Local IP Address 192.168.1.2     ???
       Subnet Mask 255.255.255.0
    6. Linksys SD216 Switch                 --- Closed to Public Access
    Any help would be greatly appreciated

    I got the network setup, but did not get what you are trying to do. Do you have 2 WRT54Gs there? Are you trying to turn off DHCP server of second WRT54G? A detailed information would be appreciated.

  • Simple Sound Recording - Help needed

    Hi there
    Im wondering if this is possible and if so , does anbody know offhand where I can find a basic implementation of this typea thing...
    I simply need to be able to read in a wav file, then record it and give it a different name. I am just trying to get this basic functionality sorted, because I will be progressing on to reading in a file, runninig some DSP algorithm on it, and then needing to save it back out, so I elieve that I need to write it in chunks much the same as the SourceDataLine buffers the sound...err am i making sense?
    I have been trying to do this with TargetDataLine, and its just getting the better of me at the moment, I am able to read in the file and play it as normal, its just the recording it to an output file where I am failing.
    thanks a million
    conaill

    Do I get you right that you want to read a sound file into memory and then store it back to the hard disk? If this is the case, try this:
    int frameSizeInBytes;
    int bufferLengthInFrames = 32;
    int bufferLengthInBytes;
    byte[] data;
    int numBytesRead;
    BufferedReader mIn;
    AudioFormat format;
    ByteArrayInputStream bIn;
    AudioInputStream outStream;
    File o;
    int soundLength;
    soundLength = 1000;
    f = new File("infile.wav");
    inStream = AudioSystem.getAudioInputStream(f);
    format = inStream.getFormat();
    frameSizeInBytes = format.getFrameSize();
    bufferLengthInBytes = bufferLengthInFrames * frameSizeInBytes;
    data = new byte[soundLength];
    o = new File("outfile.wav");
    // read the sound data
    numBytesRead = inStream.read(data, 0, soundLength);
    inStream.close();
    // now write it back
    bIn = new ByteArrayInputStream(data);
    outStream = new AudioInputStream(bIn, format, soundLength);
    AudioSystem.write(outStream, AudioFileFormat.Type.WAVE, o);This reads only a portion of a file, you'll have to modifiy it.
    Hope this helps,
    S

Maybe you are looking for

  • Problem with Access Policy

    Hi All! OIM 11g: 1. I have installed DBUM 9.1.0.4 2. I have configured IT Resurce, and RO for granting user MS SQL User and database role (for example in HRData db) 3. I have created Role named: "HRData DB User" and Access Policy named: "HR Data DB U

  • IBM WebSphere App.Server 3.5 StdEd + Oracle 8i for repository ?

    I want to install IBM WebSphere Application Server (WAS) 3.5 Std but I don't have a DB to hold the repository. One of the possible DB mentionned in the install doc is ORACLE 8i but I have no experience whatsoever with this line of products. I would l

  • Error when linking payment on account with Invoice

    Hi When i tried to link/reconcile the payment recd on account through income payment menu, its showing an error message " Confirmation Amount greater than Zero".  Pymt on Account showing as JE and open invoice amt are same only.  Anybody help me on t

  • Error Code 150:30 when opening up CS4

    When opening up CS4 I receive Error Code 150:30, what is this??

  • Excise Value change during Part 1 and 2

    Dear SAP Gurus, 1.)Requirement is that material store person should not interfere in the excise transaction not even in part-1, but the doubt is  as per my knowledge part -1 can only be done before the GR or during the GR (along with GR). and client