Snapshot with update on both sides

Hi,
I've created a snapshot with the for update clause, but when I
use the dbms_snapshot.refresh procedure, the server looses
everything made in the point B.
Point A -> master
Point B -> snapshot
Sequence:
1) Create a simple table in the master an populate it
2) create snapshot log on master
3) create database link on B to A
4) create snapshot on B
5) update the table on A
6) dbms_snapshot.refresh on B =====> ok!!!
7) update the table on A and on B
8) commit on A and B
9) dbms_snapshot.refresh on B ===> the server just applies the
changes made in A, it looses the changes in B
I need help.
Best regards,
Ari
null

Ari Arantes (guest) wrote:
: Hi,
: I've created a snapshot with the for update clause, but when I
: use the dbms_snapshot.refresh procedure, the server looses
: everything made in the point B.
: Point A -> master
: Point B -> snapshot
: Sequence:
: 1) Create a simple table in the master an populate it
: 2) create snapshot log on master
: 3) create database link on B to A
: 4) create snapshot on B
: 5) update the table on A
: 6) dbms_snapshot.refresh on B =====> ok!!!
: 7) update the table on A and on B
: 8) commit on A and B
: 9) dbms_snapshot.refresh on B ===> the server just applies the
: changes made in A, it looses the changes in B
: I need help.
: Best regards,
: Ari
Ari,
You need to generate replication support for the updatable
snapshot using the dbms_repcat.create_snapshot_repobject
procedure.
2 way replication is pretty complex to set up. You will need
correctly configured database links, snapshot logs at the master
site and replication support for all your updatable snapshots at
the snapshot site.
There are quite a few ways of setting up updatable snapshot
replication. My best advice is to get hold of the "replication
bible" from Oracle Documentation.
Oracle7 Server Distributed Systems Replicated Data or equivalent
for 8. This is essential.
good luck,
Dave.
null

Similar Messages

  • Transparent design with router on both sides?

    I am looking to solve a design which has to work in two scenarios. Preferably with an in-line solution.
    1. Transparent design with VRF on both sides:
    FW-VRF (Subnet A)
          |
          | (VLAN 11)      | ACE (Subnet A)
          |
          | (VLAN 12)
          |
    LAN-VRF
          |
          |  (VLAN 13)
          |
    Real servers (Subnet B)
    2. Transparent design in plain bridge mode
    FW-VRF (Subnet A)
          |
          | (VLAN 11)      |
       ACE (Subnet A)
          |
          | (VLAN 12)
          |
    Real servers (Subnet A)
    As mentioned, I am aiming for a single design for both scenarios. A routed design will not pass in the first scenario and a one-arm solution will be inefficient in the second scenario. (both due to existing infrastructure) Is it possible to solve this with a transparent solution in both scenarios? I can't seem to get it to work.
    Thanks in advance for any help!

    I'm gonna expand my question a bit as I can not seem to get a working config in scenario 1. From the ACE I can ping the VRFs on both side of the ACE. I can on the other hand not ping neither the bvi-address of the ACE nor one VRF from the other. Can anyone notice any immediate errors in my config? Thanks in advance for any help!
    Addresses:
    10.3.66.1 - FW_VRF on client side
    10.3.66.6 - LAN_VRF on server side
    10.3.66.7 - BVI if on ACE
    ===Admin===
    resource-class TEST_res
    limit-resource all minimum 10.00 maximum unlimited
    boot system image:c4710ace-mz.A3_2_0.bin
    hostname 4710Appl
    interface gigabitEthernet 1/1
    description Management port
    switchport access vlan 752
    no shutdown
    interface gigabitEthernet 1/2
    description Client side LAN
    switchport trunk allowed vlan 2522
    no shutdown
    interface gigabitEthernet 1/3
    description Server side LAN
    switchport trunk allowed vlan 2524
    no shutdown
    interface gigabitEthernet 1/4
    shutdown
    access-list BPDU ethertype permit bpdu
    access-list ALL line 8 extended permit ip any any
    access-list everyone line 8 extended permit ip any any
    access-list everyone line 16 extended permit icmp any any
    class-map type management match-any REMOTE_ACCESS
    description Remote access traffic match
    2 match protocol ssh any
    3 match protocol icmp any
    4 match protocol snmp any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class REMOTE_ACCESS
    permit
    interface vlan 752
    description Management VLAN
    ip address 10.7.52.63 255.255.255.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.3.66.1
    context TEST_context
    allocate-interface vlan 752
    allocate-interface vlan 2522
    allocate-interface vlan 2524
    member TEST_res
    context TEST_context_routed
    username admin password 5 $1$bale5EiS$bEdquz.bbcW3wRcfeSzbu/  role Admin domain
    default-domain
    username www password 5 $1$bsOdgxav$1uywtkwFEj3QalKaOTrkZ1  role Admin domain de
    fault-domain
    ssh key rsa 1024 force
    ===Application context===
    access-list ALL line 8 extended permit ip any any
    access-list ALL line 16 extended permit icmp any any
    class-map type management match-any REMOTE_ACCESS
    description Remote access traffic match
    2 match protocol ssh any
    3 match protocol icmp any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class REMOTE_ACCESS
    permit
    interface vlan 752
    ip address 10.7.52.64 255.255.255.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    interface vlan 2522
    description Client side VLAN
    bridge-group 1
    access-group input ALL
    access-group output ALL
    no shutdown
    interface vlan 2524
    description Server side VLAN
    bridge-group 1
    access-group input ALL
    access-group output ALL
    no shutdown
    interface bvi 1
    ip address 10.3.66.7 255.255.255.240
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.3.66.1

  • GR/IR behaviour in PSM (FM) with update in both GR/IR

    Hello Gurus,
    I'd like to ask which is the correct behaviour in PSM when Updating in both GR/IR (in OFUP transaction).
    I'm getting the following behaviour from the system:
    Goods receipt:
    FI document:............... =>......PSM Document:
    Expense acct E  100...............Funds ctr AAA /Comm Item AAA   100  (from expense acct E)
    Clearing acct     -100
    Invoice Receipt:
    FI document................ =>.....PSM Document:
    Clearing acct        100................Funds ctr AAA/ Comm Item AAA   -100 (inheriting expense acct E)
    Supplier acct       -100................Funds ctr AAA /Comm Item AAA    100 (from clearing account)
    If you analyze this from PSM perspective its correct, because the impact in Funds ctr AAA/ Comm item AAA is 100, but when comparing it to controlling real items, there is a difference due to the fact that the expense account E would have a balance of 100 in controlling and 0 in PSM.
    Is this correct anyway?
    Thanx a lot!!

    Hello Mariano,
    The mapping should be:
    Expense account (say, the gl code is 3999999) -> cost element 3999999 -> CI 3999999 30/3 (derived through any desired method)
    Clearing account (say, the gl code is 1999999) -> CI 1999999 40/3
    Vendor reconciliation accout (say, the gl code is 2999999) -> CI 2999999 60/3
    When a PO is created the system derives the FM account assignment for the PO line item. In the above case CI 3999999 will be derived through cost element and a funds center will be derived through a CO object (cost center, internal order, etc).
    During IR process, the system bypasses the derivation mechanism. Instead, the account assignment is inherited from the PO line. So, you should get DR 3999999 and CR 3999999 in FM for the LIV postings.
    Hope this clarifies the matter.
    Regards,
    Ming

  • JSpinner with arrows on both sides

    Hello.
    I would like to make a JSpinner that would have one arrow on the left and one arrow on the right side,
    like this
    |<|______|>|
            I tried to look at native JSpinner class from javax.swing package, but I can't find anything that I could change easily (like a button or so..).
    I am completely lost and the class is also so huge (almost 2000 lines).
    Could you please explain to me how the arrows in the JSpinner are represented, or simply how I should go about it ?
    Thank you for any help !

    You won't find the buttons in the JSpinner, they are part of the UI. Look in BasicSpinnerUI or MetalSpinnerUI.
    I guess you have a choice between writing a UI delegate for a JSpinner or creating a custom component that uses a SpinnerModel and nests two JButtons and a JTextField in a JPanel.
    And don't expect it to be easy ;-)
    btw, why do you have two accounts?
    db

  • Logical Standby Database with 10g+ASM on both sides??

    Hi out there,
    is there a known way to establish a logical standby database on 10g, if both
    sides are running with an ASM setup?
    I've tried to create one out of a physical standby database (which is set up
    and running w/o any problems), like a book suggested me to do.
    The procedure was:
    1. switch on supplemental logging
    2. prepare initiation parameters (for archive logging etc.) on both sides for
    logical stb.
    3. shut down the phyiscal standby
    4. alter database create logical standby controlfile as '<path>'; on the
    primary, transfer the controlfile to the standby db. Here I had to use RMAN
    to copy the controlfile into the ASM System, and modify the initfile/spfile
    in order to use the controlfile. No problem so far.
    5. mount the standby database, alter database recover managed standby database
    disconnect; -> At this point, the alert log complained about non-available
    datafiles.
    6. alter database activate standby database; --> fails ("needs recovery") due
    to last point.
    The trouble is, the controlfile created at point 4 cointains wrong paths to
    the datafiles. Since I can not have the same disk group name on the standby
    system, and since ASM renames the stored datafiles by its own, the complaints
    of point 5 are comprehensible, but nevertheless annoying.
    I tried to backup a controlfile to trace and change the paths, but at after
    mounting the standby with this controlfile and proceeding at point 5, the
    system says "<path> is not a standby controlfile"
    Is there a different way of creating a "Logical Standby Database with 10g+ASM
    on both sides"? Metalink said nothing about LogStby and ASM.
    Best regards and thanks in advance,
    Martin

    I'm not sure if this will work but try:
    1. create trace control file (you did it)
    2. change paths (you did it)
    3. recrate control file (you did it)
    ... there was error occured during mount before
    so mount database (not as standby)
    4. create standby control file (from recreated control file)
    5. shutdown instance, replace control file with new standby control file or replace the control filename in parameter file.
    6. mount as standby
    What happend?
    Update: Tested on my side and it has worked fine... How about you?
    Message was edited by:
    Ivan Kartik

  • Photosmart 7520 options issue: How to print black ink, on both sides, with borderless.

    I am checking to see if anyone has ever found a solution to the issue involved with borderless printing when the options "print on both sides" and "black ink only" are chosen.
    I used to be able to print on both sides, flip on long edge, and choose black ink only, and I was able to print borderless.  There was never an issue until last year, when out of the blue a yellow warning triangle appeared next to borderless printing.   I do not know why this happened, and I was never able to solve the issue, even with two hour-long conversations with polite and tireless HP phone reps.  One HP rep even helped me download a driver for a newer printer to see if that helped, and it did not.
    Now in order to print without the extra border, I have to do the following in order to receive the regular output:
    1.  After saving, I make a custom border that is .75 inches all the way around instead of one inch.
    2.  I increase the font size of every block of print by .5 in size.
    3.  Then I print, but I do not save;  when I close, it saves as it was before the changes I made to ameliorate the HP options mishap.
    If any HP technician our here can tell me when this issue will be addressed and solved, I would appreciate it. 
    Oh, I run an Acer laptop with Windows 7, the 64-bit version.  I use the wireless printing option.  This issue occurs with my Word Program (2013), and my up-to-date Adobe .pdf files. 
    Thank you very much.

    Hey there PrincessCupcake!
    Thanks for the detailed post back to me.
    If this was at one time an option for you and now is not, it would make sense to me that an update of some sort had made the option null and void for you, especially if you have completely uninstalled the printer driver and software and then reinstalled it. If the option was going to be available, doing the uninstall and reinstall would have fixed it in a jiffy.
    I am out of ideas as to any other cause besides an update, as you mentioned. If you have installed the printer on another computer, see if the options are there, if not, they aren't available.
    Happy Monday to you
    R a i n b o w 7000I work on behalf of HP
    Click the “Kudos Thumbs Up" at the bottom of this post to say
    “Thanks” for helping!
    Click “Accept as Solution” if you feel my post solved your issue, it will help others find the solution!

  • How can i make a coppy both side with my hp 6500a plus all in one?

    how can i make a both sides coppy with my hp 6500A plus all-in-one?

    For windows:
    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c02773085&cc=us&dlc=en&lc=en&product=4083977&tmp...
    For MAC:
    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01935823&cc=us&dlc=en&lc=en&product=4083977&tmp...
    Although I am working on behalf of HP, I am speaking for myself and not for HP.
    Love Kudos! If you feel my post has helped you please click the White Kudos! Star just below my name : )
    If you feel my answer has fixed your problem please click 'Mark As Solution' and make it easier for others to find help quickly : )
    Happy Troubleshooting : )

  • What is wrong with my headphone jack? i have an ipod touch 4th generation ipod touch every pair of headphones and earbuds i plug in it has the same sound going to both sides.

    what is wrong with my headphone jack? i have an ipod touch 4th generation ipod touch every pair of headphones and earbuds i plug in it has the same sound going to both sides.

    - Try cleaning out/blowing out the headphone jack. Try inserting/removing the plug a dozen times or so.
    Try the following to rule out a software problem
    - Reset the iPod. Nothing will be lost
    Reset iPod touch: Hold down the On/Off button and the Home button at the same time for at
    least ten seconds, until the Apple logo appears.
    - Reset all settings
    Go to Settings > General > Reset and tap Reset All Settings.
    All your preferences and settings are reset. Information (such as contacts and calendars) and media (such as songs and videos) aren’t affected.
    - Restore from backup
    - Restore to factory settings/new iPod.
    - Make an appointment at the Genius Bar of an Apple store. Seems you have a bad headphone jack.
    Apple Retail Store - Genius Bar
    Apple will exchange your iPod for a refurbished one for this price. They do not fix yours.
    Apple - iPod Repair price                  
    A third-party place like the following will replace the jack for less. Google for more.
    iPhone Repair, Service & Parts: iPod Touch, iPad, MacBook Pro Screens
    Replace the jack yourself
    iPod Touch Repair – iFixit

  • Can't print both sides (manually) with Windows 7 but can with XP

    My OfficeJet 5510 has "Print Both Sides" as an option on the "Finishing" tab, when I use it from the desktop running XP, which it's connected to with USB. That option doesn't appear anywhere when I try to print from my laptop running Windows 7, over a wireless network. This issue seems to be mentioned in many posts, but never seems to be answered. Is 2-sided printing (manually reinserting the pages) an option with Windows 7, or just with XP?

    Hi  - The difference is that with XP, you're using the HP print driver and with Win7, you're using the Microsoft driver, since it doesn't look like HP made a "Full-featured" driver for the OJ5510, since Win7 came out well after the OJ5510 released.  Unfortunately, it doesn't look like you'll be able to manually print on both sides of the page unless the software app you're printing from offers a feature.  If the app doesn't have an option specifically for manual duplexing, you might be able to specify printing only odd numbered pages, then re-loading those pages and printing the even numbered pages.  Not a great workaround, but at least an option.
    Hope that helps.
    Say Thanks by clicking the Kudos thumbs up. Please mark the post that solves your problem as an Accepted Solution so other forum users can utilize the solution.
    I am an HP employee.

  • My Macbook Pro has a black screen when running in Bootcamp Windows 7. Since I updated the mac side my windows side now starts up with completely black screen - no prompt, nothing, Cap keys still light up as does mouse and DVD drive seems to run.

    My Macbook Pro has a black screen when running in Bootcamp Windows 7. Since I updated the mac side my windows side now starts up with completely black screen - no prompt, nothing, Cap keys still light up as does mouse and DVD drive seems to run.
    Will not show up in safe mode, will not show when started from Windows 7 DVD.
    I suspect the Mac update wiped out my PC video drivers but can not think of a way to re-install?
    Can see the PC volume from Mac side with files.
    I've looked at all the online solutions so far and have tried most of them without success. Please help!
    Specs:
    2009 Macbook Pro, 3.06 GHz Intel 2 core, Max 10.6.8.
      Model Name:          MacBook Pro
      Model Identifier:          MacBookPro5,2
      Processor Name:          Intel Core 2 Duo
      Processor Speed:          3.06 GHz
      Number Of Processors:          1
      Total Number Of Cores:          2
      L2 Cache:          6 MB
      Memory:          4 GB
      Bus Speed:          1.07 GHz
      Boot ROM Version:          MBP52.008E.B05
      SMC Version (system):          1.42f4
      Serial Number (system):          7302300GANE
      Hardware UUID:          B2D4B4B4-CD92-5C7A-BDC2-527D30DD8DF3
      Sudden Motion Sensor:
      State:          Enabled

    EDIT: RESOLVED
    For anyone else who finds their way here like I did, this link did it for me: https://forums.geforce.com/default/topic/527599/windows-8-issues-solved-please-r ead-if-you-39-re-having-black-screen-and-or-flickering-/
    Specifically, the posts by Dunsany and valkyr did the trick.  I booted in safe mode, uninstalled and deleted the Nvidia driver, disabled automatic driver installation, and restarted normally.  I then manually downloaded and installed the previous Nvidia driver for my graphics card (which at the time of this writing was 335.23, rather than the latest which was 337.88), and everything is now bueno!
    Two hiccoughs along the way: First, when I tried to uninstall the Nvidia driver the first time, when I restarted I got the login screen (which was a good sign), but it quickly went black again.  I powered down, restarted in safe mode again, and repeated the uninstallation process, and it worked the second time.  Second, when I started the manual install of the 335.23 driver, the computer played a sound similar to the one for disconnecting a USB device, and the screen went black.  I'd seen a lot about trying to increase the brightness (though it hadn't worked up to this point; but if you haven't tried it yet, might as well); I tried it, and it worked! So far I'm back up and running. [/fingers crossed]
    Hope this helps someone else!

  • Both side chatting with simple GUI ,,helps pls?

    guys I'm Java application programmer i don't have well knowledge in network programing ,,my question ,,,from where should i start to design a simple GUI client*s* server chat program ,i mean some thing like simple yahoo messenger the program should include also adding contact and make that contact appears ON if he login or OFF if he sign out like red color for ON-line contact and and white color for off-line contact ...........
    another thing that chat system should include shared folder all the contact can enter it and upload file or download file ...
    please guys i run to you to help me i have 2 weeks only to do that thing please don't let me down i need your help ....TIPS,code,any thing full code :) ,,any thing will be really appreciated .
    guys for more information the program includes only the chat of course its both sides chat between the clients and these is no conference room
    or audio or video nothing ,,just text only nothing else except the folder shearing service and the colors of the contacts for login or not .
    guys once more help me give me codes or any thing useful i count on you guys.
    thx a lot in advance
    RSPCPro
    Edited by: RSPCPRO on Oct 3, 2008 6:25 PM

    RSPCPRO wrote:
    Dude , u r right ,,,but still its simple GUI issueI'm not sure why you are getting this impression. It's not a simple "GUI issue." Yes, you can simply create the GUI for this, but will it be functional? No. Furthermore, if it was so simple, why are you posting asking for help?
    For an instant message chat program, in addition to GUI programming, you need to know how client / server systems work and you need to implement one. A server should be running on one system and the client(s) will connect to it. The server usually maintains the buddy list and passes the messages to/from different clients. This presents several problems that you will need to solve:
    1. How will you develop a protocol between the client / server for communication?
    2. How will you authenticate users?
    3. How will you maintain the buddy list on the server (data structure, database, file)?
    4. How will you pass messages from one client to another (simple string message, serialized data object, etc.)?
    5. etc.
    Now, I'm not saying this is "impossible" so please don't take it that way. I'm simply trying to help you realize that there are a lot of factors to consider when developing this type of application.
    RSPCPRO wrote:
    and for the "FTP?" ,,,its folder shearing as i said earlier every one of your friends can access it not FTP .....Talking about "folder sharing" is a whole other issue. What I meant by saying "FTP?" is, how do you plan on implementing "folder sharing" remotely? One option is FTP. How would you do it?
    RSPCPRO wrote:
    and one thing please don't assume any thing u don't knowIf you ask a very broad question and ask for code, I can only assume one thing.
    RSPCPRO wrote:
    be cooler with others and u will get what u want.I agree. You should take your own advice. I'm not the one looking for help, you are.
    RSPCPRO wrote:
    thx dude for ur advice and for the link have a good day.You're welcome, and good luck.

  • How do i set text in a object so that object expands with text and has even space on both sides of the object in illustrator cc?

    how do i set text in a object so that object expands with text and has even space on both sides of the object in illustrator cc?

    if you see all the different panel. I past the info in and have to manually expand the width of every panel. Is there a way of pasting the text in and the panel moves to the right with so that there is an even space on both sides of the blue panel?

  • How to scan both sides of document in color to pdf with the dr-m160?

    how to scan both sides of document in color to pdf with the dr-m160?

    Hi healthynhappy1.
    To scan a 2-sided document, you will need to change the scanner settings in the software. 
    If you are using Capture On Touch:
    You will need to turn off the "Scan in Full Auto" option. 
    Next, you will open [Scanner Settings] and change the "Scanning Side" to Duplex. 
    Verify that the [Color Mode] shows "24-bit Color" and when you get the option to save the file, verify the [File Type] shows as "PDF".
    If you are using CapturePerfect:
    Click [Scan].
    Click [Scanner Settings].
    Change the [Scan Side] to "Duplex".
    Verify that [Color Mode] is set for "Color" and then save the file as "PDF".
    I hope that this information is helpful to you.  Should you need further assistance, please contact us at 1-800-OK-CANON (1-800-652-2666).  Have a great day!
    Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

  • Is it/shouldn't it be possible to order postcards with full image on both sides?

    Is it/shouldn't it be possible to order postcards with full image on both sides?

    Yes, you can create such a card.  This example is the folded Holiday Colors theme.  Just choose the layout for the inside that includes a full page photo on top and text on the bottom.
    OT

  • Photosmart C6280 not printing color/both sides with Mac

    Hello HP Community,
    I have a Macbook Pro running iOS X 10.9.2 and a AIO Photosmart C6280. I am have downloaded the printing/scanning software and drivers. Everything installed without problem. I have also scanned with no problem. However, no matter what program I am trying to print from on my Macbook, the printer will not print in color and also will not print on both sides - even when the double sided feature is checked off. 
    I have been to all the discussion forums of relevance and can't find anyone with my same problem. Those that have similar problems, are running different versions of iOS and the steps suggested they take are not possible with this version. Please Help!

    Hello HP_USER,
    Welcome to the HP Forums.
    I see that you're unable to print in color from you Mac 10.9.2. I will try to help you with this.
    Have you tried making a color copy from the printer? If not please do so, this is to see if the printer is having the issue stand alone.
    I would also recommend looking at these documents:
    Missing, Faded, or Dull Colors
    Wrong Colors
    As for it not duplexing, according to the User's Guide, this printer doesn't duplex as in it doesn't have a duplexer. If you are manual duplexing that would be slightly different, as it requires you to be flipping the page after the first side has come out. This document can assist you with that: Print on Both Sides of the Paper (Manual Duplexing)
    I hope this helps you out, thank you for posting on the HP Forums.
    I worked on behalf of HP.

Maybe you are looking for