[SOLVED] Trouble with atlas-lapack static library linking to our .so

I'm trying to compile a massive hunk of software, one small piece of which is libgraphics.so.   The build system, based on cmake,  is trying to link a static library from lapack to make the libgraphics.so but failing with this:
Linking CXX shared library libgraphics.so                                                                                     
/usr/bin/ld: /usr/local/lib/liblapack.a(dgetrf.o): relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/liblapack.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[2]: *** [graphics/libgraphics.so.3.1.0] Error 1
Thinking lapack.a somehow wasn't built right, after some fussing I ended up removing  the blas, lapack, and atlas libraries and reinstalling them from the AUR atlas-lapack (ver 3.8.3)  package.  This is where they had come from originally just a few months ago, when I first tried to compile this massive app.    Maybe now something in atlas-lapack got fixed?  No.   Apparently it builds static libraries without -fPIC, or something else is going on to result in this error.  I didn't see anything obvious in the PKGBUILD file to change. 
Now I'm stuck, out of further ideas to try...
Last edited by darenw (2010-10-06 20:48:40)

Problem solved.  CMake was finding a stray old .a file (w/o any .so files with it)  in /usr/local/lib while the good new .a and .so files were in /usr/lib.     Deleted the old .a, reran cmake.  Now make runs fine.   -fPIC had nothing to do with the solution.

Similar Messages

  • IOCTL's from a static library linked to KMDF driver

    Hi,
    Im trying to build a static library that can be used across multiple KMDF drivers. The library needs to send IOCTL's to another driver to access required functionality. 
    The library does not have access to the Wdf device object/objects of the KMDF drivers it is being linked to. 
    To send IOCTLs from the library, i thought i would use WdfIoTragetCreate/open and then use WdfIoTargetSendIoctlSynchronously. However, to create the IO target, i require a device object. 
    I thought i could call WdfGetDriver to get the driver object and create a dummy device object with no callbacks. However, all the examples and documentation seems to indicate that you only call WdfDeviceCreate inside EvtDeviceAdd or  EvtChildListCreateDevice callback,
    or from a call to WdfPdoInitAllocate. 
    Is it incorrect to call WdfDeviceCreate from a library which will be used way after the KMDF driver has come up ? 
    What options do i have to be able to send IOCTL's to other drivers from this static library?
    -R___K

    You need to pass in the actual device object, one of the many things that WDF does for you is cleanup things like reference counts etc, so you don't want to be using a dummy device object, since you will be entering the area of having to worry about when
    to clean it up.
    Since it is a static library you can use WDF calls unlike a DLL. 
    Don Burn Windows Filesystem and Driver Consulting Website: http://www.windrvr.com

  • Trouble with iPhoto and iPhoto library manager.

    I had trouble with my iPhoto constantly crashing, so I downloaded and used iPhoto Library Manager. Now when I am trying to get back to using iPhoto by re-importing my pictures, I keep getting a notification saying there is not enough space on my harddrive. I have spent a long time deleting large and unneccessary files all over my computer, but I am still unable to import my images to the iPhoto library.
    Does anyone have an idea of what I can do? I am starting to get worried that I will never be able to reach my pictures again
    + I have deleted all iPhoto iPod caches or whatever they're called based on recommendation from many sites.

    OS X needs about 10 gigs of hard drive space for normal OS operations - things like virtual memory, temporary files and so on.
    Without this space your Mac will slow down as the OS hunts for space on the disk, files will be fragmented, also slowing things down, apps will crash and the risk of data corruption - that is damage to your files, photos, music - increases exponentially.
    Your first priority is to make more space on that HD. Nothing else can be done until you do.
    Purchase an external HD and move your Photos and Music to it. Both iPhoto and iTunes can run perfectly well with the Library on an external disk.

  • Trouble with rebuilding the iPhoto library

    Hi, I'd need help for a problem I have found on my dad's Imac. It's a late 2009, 21.5" with Core 2 Duo and 8 GB ram running Snow Leopard and the preinstalled iPhoto (I'm not sure about the version)
    He told me about some issues with photos in his library, so I thought that maybe rebuilding the iPhoto library would fix them. Unfortunately I can't access the "rebuild" dialog and holding down Command and Option keys when opening iPhoto does nothing.
    I've been trying with the iPhoto icon in Applications folder, not through the dock, keeping them pressed before doubleclicking, pressing them at the same time, pressing also shift or control or both... I've tried all combinations without any luck, as iPhoto starts normally without showing the dialog.
    What could be the problem? Any solution?
    Thanks!

    Yep! I know it doens't make any sense... I've tried repairing permissions and checking the file system, I've also deleted the content of "caches" folder but without any luck.
    I've moved the library to the desktop and started iPhoto, created a new library and then tried with that one. It doesn't work.

  • Trouble with restoring an iPhoto library from a time machine backup.

    I'm having trouble restoring my iPhoto library from a time machine backup.
    I have created a new library in my pictures file.
    When I try to restore the library the restore process is trying to copy it to an external drive that no longer exists - it failed and I had to have it recovered and all the recovery (including backups) data is now on a different external hard drive.
    iPhoto had been using that old external drive location to start. iPhoto is now pointed to the newly created iPhoto library in my pictures file on my MacBook Air.
    Is there a way to have the restoration process point to that new iPhoto library that is now empty and not to the old external drive?

    You might try this with the restored library:
    Starting over from scratch with new library
    Start over with a new library and import the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from your original library as follows:
    1. Open the library package like this.
    2. Launch iPhoto with the Option key held down and, when asked, select the option to create a new library.
    3. Drag the subfolders of the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from the open iPhoto Library package into the open iPhoto window a few at a time.
    This will create a new library with the same Events (but not necessarily the same Event names) as the original library but will not keep the metadata, albums, books slideshows and other projects.
    Note:  your current library will be left untouched for further attempts at a fix if so desired.

  • [SOLVED] Trouble with PipeLight

    So I read through everything I could find on this and have no answers. I read the wiki and project FAQ before installing and realized I needed to make sure XATTR was enabled prior to compiling:
    [xaero@archtop ~]$ xattr_test="$HOME/.wine-pipelight"; setfattr -n 'user.testAttr' -v 'attribute value' $xattr_test &> /dev/null; getfattr $xattr_test 2>&1 | grep -q user.testAttr && echo 'It works!' || echo 'No workie!'
    It works!
    I then compiled, and installed the package, as well as chromium (fresh install) and fired it up... instantly, chromium installed the pipelight plugin, and then continued business as usual. I then installed the UA Switcher plugin linked on the project page, and went to Netflix and tried to watch something. No dice; Netflix Error Code N8156-6205. What gives? Maybe that chromium bug applies to me as well; so I went ahead and forced the UA string from the command line:
    [xaero@archtop ~]$ chromium --user-agent="Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120427 Firefox/15.0a1"
    [4759:10:1231/185916:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
    [4694:4720:1231/185916:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
    [4810:15:1231/185920:ERROR:base_feature_provider.cc(122)] manifestTypes: Allowing web_page contexts requires supplying a value for matches.
    [PIPELIGHT:LIN:unknown] attached to process.
    [PIPELIGHT:LIN:unknown] checking environment variable PIPELIGHT_SILVERLIGHT5_1_CONFIG.
    [PIPELIGHT:LIN:unknown] searching for config file pipelight-silverlight5.1.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/home/xaero/.config/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/etc/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/usr/share/pipelight/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:silverlight5.1] sandbox not found / not installed!
    [PIPELIGHT:LIN:silverlight5.1] GPU driver check - Your driver is supported, hardware acceleration enabled.
    [PIPELIGHT:LIN:silverlight5.1] using wine prefix directory /home/xaero/.wine-pipelight/.
    [PIPELIGHT:LIN:silverlight5.1] checking plugin installation - this might take some time.
    [install-dependency] wine-silverlight5.1-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [install-dependency] wine-mpg2splt-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [install-dependency] wine-wininet-installer is already installed in '/home/xaero/.wine-pipelight/'.
    wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
    err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
    [PIPELIGHT:WIN:silverlight5.1] windowless mode is off.
    [PIPELIGHT:WIN:silverlight5.1] embedded mode is on.
    [PIPELIGHT:WIN:silverlight5.1] unity hacks is off.
    [PIPELIGHT:WIN:silverlight5.1] window class hook is on.
    [PIPELIGHT:WIN:silverlight5.1] render toplevelwindow is off.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExA.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExW.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenuEx.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenu.
    fixme:advapi:RegisterTraceGuidsW (0x2b1f87, 0x350118, {aa087e0e-0b35-4e28-8f3a-440c3f51eef1}, 1, 0x65f678, (null), (null), 0x350118): stub
    [PIPELIGHT:WIN:silverlight5.1] init successful!
    fixme:advapi:UnregisterTraceGuids 0: stub
    [PIPELIGHT:LIN:unknown] attached to process.
    [PIPELIGHT:LIN:unknown] checking environment variable PIPELIGHT_SILVERLIGHT5_1_CONFIG.
    [PIPELIGHT:LIN:unknown] searching for config file pipelight-silverlight5.1.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/home/xaero/.config/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/etc/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/usr/share/pipelight/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:silverlight5.1] sandbox not found / not installed!
    [PIPELIGHT:LIN:silverlight5.1] GPU driver check - Your driver is supported, hardware acceleration enabled.
    [PIPELIGHT:LIN:silverlight5.1] using wine prefix directory /home/xaero/.wine-pipelight/.
    [PIPELIGHT:LIN:silverlight5.1] checking plugin installation - this might take some time.
    [install-dependency] wine-silverlight5.1-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [install-dependency] wine-mpg2splt-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [install-dependency] wine-wininet-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [PIPELIGHT:WIN:silverlight5.1] windowless mode is off.
    [PIPELIGHT:WIN:silverlight5.1] embedded mode is on.
    [PIPELIGHT:WIN:silverlight5.1] unity hacks is off.
    [PIPELIGHT:WIN:silverlight5.1] window class hook is on.
    [PIPELIGHT:WIN:silverlight5.1] render toplevelwindow is off.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExA.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExW.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenuEx.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenu.
    fixme:advapi:RegisterTraceGuidsW (0x2b1f87, 0x350118, {aa087e0e-0b35-4e28-8f3a-440c3f51eef1}, 1, 0x65f678, (null), (null), 0x350118): stub
    [PIPELIGHT:WIN:silverlight5.1] init successful!
    fixme:advapi:UnregisterTraceGuids 0: stub
    [PIPELIGHT:LIN:unknown] attached to process.
    [PIPELIGHT:LIN:unknown] checking environment variable PIPELIGHT_SILVERLIGHT5_1_CONFIG.
    [PIPELIGHT:LIN:unknown] searching for config file pipelight-silverlight5.1.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/home/xaero/.config/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/etc/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:unknown] trying to load config file from '/usr/share/pipelight/pipelight-silverlight5.1'.
    [PIPELIGHT:LIN:silverlight5.1] sandbox not found / not installed!
    [PIPELIGHT:LIN:silverlight5.1] GPU driver check - Your driver is supported, hardware acceleration enabled.
    [PIPELIGHT:LIN:silverlight5.1] using wine prefix directory /home/xaero/.wine-pipelight/.
    [PIPELIGHT:LIN:silverlight5.1] checking plugin installation - this might take some time.
    [install-dependency] wine-silverlight5.1-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [install-dependency] wine-mpg2splt-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [install-dependency] wine-wininet-installer is already installed in '/home/xaero/.wine-pipelight/'.
    [PIPELIGHT:WIN:silverlight5.1] windowless mode is off.
    [PIPELIGHT:WIN:silverlight5.1] embedded mode is on.
    [PIPELIGHT:WIN:silverlight5.1] unity hacks is off.
    [PIPELIGHT:WIN:silverlight5.1] window class hook is on.
    [PIPELIGHT:WIN:silverlight5.1] render toplevelwindow is off.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExA.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExW.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenuEx.
    [PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenu.
    fixme:advapi:RegisterTraceGuidsW (0x2b1f87, 0x350118, {aa087e0e-0b35-4e28-8f3a-440c3f51eef1}, 1, 0x65f678, (null), (null), 0x350118): stub
    [PIPELIGHT:WIN:silverlight5.1] init successful!
    [PIPELIGHT:LIN:silverlight5.1] using timer based event handling.
    fixme:win:EnumDisplayDevicesW ((null),0,0x65f1c8,0x00000000), stub!
    fixme:advapi:CreateProcessAsUserW 0x148 L"C:\\Program Files\\Silverlight\\5.1.20913.0\\agcp.exe" L"agcp.exe 37 320" (nil) (nil) 1 0x00004000 (nil) (null) 0x65f228 0x65f218 - semi- stub
    fixme:heap:HeapSetInformation (nil) 1 (nil) 0
    fixme:file:K32GetMappedFileNameW (0xffffffff, 0x4015f4, 0x50e1d4, 520): stub
    fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
    fixme:urlmon:Uri_GetPropertyBSTR (0x10467a0)->(6 0x65e004 4)
    fixme:process:GetNumaHighestNodeNumber (0x65eaa0): stub
    fixme:thread:SetThreadStackGuarantee (0x65ea90): stub
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e6b0, (nil) 0x65e6a8
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e6b0, (nil) 0x65e6a8
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e880, (nil) 0x65e878
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e880, (nil) 0x65e878
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e540, (nil) 0x65e538
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65d488, (nil) 0x65d480
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65d488, (nil) 0x65d480
    fixme:process:FlushProcessWriteBuffers : stub
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e470, (nil) 0x65e468
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e470, (nil) 0x65e468
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65ea00, (nil) 0x65e9f8
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e9c0, (nil) 0x65e9b8
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e8ac, (nil) 0x65e8a4
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e840, (nil) 0x65e838
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e818, (nil) 0x65e810
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65ecf0, (nil) 0x65ece8
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65ecb0, (nil) 0x65eca8
    0
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e65c, (nil) 0x65e654
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e65c, (nil) 0x65e654
    fixme:advapi:RegisterTraceGuidsW (0x10015fbb, 0x1008c460, {00000000-7ac4-430a-94e4-b0dfd254650f}, 1, 0xa9ae028, (null), (null), 0x1008c468): stub
    fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
    fixme:advapi:RegisterTraceGuidsW (0xac83c2f, 0xae63a20, {00000000-7ac4-430a-94e4-b0dfd254650f}, 1, 0xa9ae338, (null), (null), 0xae63a28): stub
    fixme:mountmgr:harddisk_ioctl returning zero-filled buffer for IOCTL_VOLUME_GET_VOLUME_DISK_EXTENTS
    fixme:advapi:GetCurrentHwProfileW (0xa9ae290)
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65e81c, (nil) 0x65e814
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65ecb0, (nil) 0x65eca8
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65ec44, (nil) 0x65ec3c
    fixme:thread:GetThreadPreferredUILanguages 48, 0x65ec1c, (nil) 0x65ec14
    fixme:thread:NtQueryInformationThread info class 16 not supported yet
    Still no dice. Any ideas on what to try next?
    Last edited by Xaero252 (2014-01-01 21:43:21)

    Hi Xaero252,
    error N8156-6205 is DRM related, and could mean that either your DRM files are somehow corrupted
    just delete them with (as a regular user):
    rm -rf ~/.wine-pipelight
    or that your Wine version is still compiled without XATTR support or missing some patches. Which package and/or patches did you use for Wine? When you're compiling it manually make sure that the patches apply cleanly, and that you run "autoreconf" before the compilation. You can find some more detailed instructions here, how to manually compile it.
    Please note that the compilation of Wine is often a bit auto-magic, and its possible that XATTR support is not included, even if you did everything right (the problem occured mainly on ArchLinux so far). In this case a recompilation should help to fix the problem. We had a user with a similar problem in our channel #pipelight a few days ago, where the problem was also just solved by recompiling the package.
    You can also take a look at this bug report some time ago, which was also caused by the fact that XATTR wasn't included somehow.
    https://bugs.launchpad.net/pipelight/+bug/1216332
    Sebastian

  • [SOLVED] Trouble with Install that I've never seen before (Gnucash)

    Hello all! I am rather new to Arch. I came over from Windows (disgruntled up to Win 7). When I first came over to Linux I did so via Ubuntu (12.04 and 13.10) and Mint (16). Seeing that Ubuntu would love to eventually sell us all out I decided to give Arch a try and LOVED IT! The install went smoothly and almost every program that I have needed has installed flawlessly..That is with the exception of Gnucash. I do a lot of freelance bookkeeping work and Gnucash is most definitely the best program I have found out there (even when I was using Windows). I have tried to install from BOTH the official repository and the AUR with no luck. I am using a 64 bit install of Arch on a Dell Inspiron 1440. All of my packages and repositories have been updated through pacman -Syu and -Syy. Below is the results message that I receive when trying to install from EITHER repository (AUR version is what I have posted). It shows that there appear to be two corrupt packages. If any of you can guide me in the right direction as to how to possibly rectify my trouble I would be most appreciative. (Also: if I am posting this in the wrong area please let me know where the better place would be.)
    [rick@rick_inspiron1440 builds]$ tar -xf gnucash-latest.tar.gz
    [rick@rick_inspiron1440 builds]$ cd gnucash-latest
    [rick@rick_inspiron1440 gnucash-latest]$ makepkg -sci
    ==> Making package: gnucash-latest 2.6.1-1 (Sun Feb 16 14:27:20 EST 2014)
    ==> Checking runtime dependencies...
    ==> Installing missing dependencies...
    [sudo] password for rick:
    resolving dependencies...
    looking for inter-conflicts...
    Packages (25): gconf-3.2.6-3 gnome-mime-data-2.18.0-6 gnome-vfs-2.24.4-8
    guile1.8-1.8.8-3 gwenhywfar-4.3.3-4 ktoblzcheck-1.43-1
    libart-lgpl-2.3.21-3 libbonobo-2.32.1-4 libbonoboui-2.24.5-2
    libdbi-0.9.0-2 libglade-2.6.4-5 libgnome-2.32.1-4
    libgnome-data-2.32.1-4 libgnomecanvas-2.30.3-2
    libidl2-0.8.14-3 libofx-0.9.9-1 libxml++-2.36.0-1
    opensp-1.5.2-4 orbit2-2.14.19-2 aqbanking-5.0.25-2
    goffice0.8-0.8.17-2 gtkhtml-3.32.2-3 libdbi-drivers-0.9.0-2
    libgnomeui-2.24.5-1 slib-3b3-3
    Total Download Size: 1.28 MiB
    Total Installed Size: 88.49 MiB
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages ...
    gtkhtml-3.32.2-3-x86_64 628.7 KiB 724K/s 00:01 [######################] 100%
    libdbi-0.9.0-2-x86_64 642.2 KiB 415K/s 00:02 [######################] 100%
    libdbi-drivers-0.9.... 35.4 KiB 668K/s 00:00 [######################] 100%
    (25/25) checking keys in keyring [######################] 100%
    (25/25) checking package integrity [######################] 100%
    error: libdbi: signature from "Thorsten Töpper <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/libdbi-0.9.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: libdbi-drivers: signature from "Thorsten Töpper <[email protected]>" is unknown trust
    :: File /var/cache/pacman/pkg/libdbi-drivers-0.9.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n]
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.
    ==> ERROR: 'pacman' failed to install missing dependencies.
    Last edited by rightwingrb (2014-02-19 00:28:41)

    rightwingrb wrote:Also...I have no idea what "code" tags are but hopefully the above is acceptable ;-)
    When posting configs, code or command output, please use [ code ] tags https://bbs.archlinux.org/help.php#bbcode
    like this
    It makes the code more readable and - in case of longer listings - more convenient to scroll through.
    Please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309
    Last edited by karol (2014-02-18 22:23:24)

  • Migration to Photos: Trouble with import from iPhoto Library

    I have just upgraded to OS X Yosemite (10.10.3). When I first opened Photos, it wanted to convert my iPhoto Library to Photos. After some hours of working with the 165.2 GB iPhoto Library, it told me that I don't have enough disk space. I believed that if I free my MacBook Pro from those 165.2 GB, I might solve the problem. So yesterday, I stored it on an external USB drive (a solid state drive of OWC with USB 3.0 connection to my MacBook), deleted the iPhoto Library on my harddisk, and opened Photos. In Photos, I chose Menu > File >Import , and navigated to the external drive. However, clicking the file icon and name does not release into any import. What shall I do to import data from my iPhotos Libray?
    Suggestions will be most appreciated and rewarded with a virtual box of Mozart Kugeln.
    Erik Thau-Knudsen

    You don't import it, you simply open it:
    Hold down the option (or alt) key key and launch Photos. From the resulting menu select 'Choose Library'

  • [Solved] Trouble with WPA/WPA2 and wireless connections (ath9k)

    Hi, I'm having some issues with my Arch install. Right now I'm posting this from Windows so I don't have precise logs, but I mostly remember the issue so bare with me.
    I'm using ath9k with my Bigfoot Killer 1202 card (not sure what the exact model is), and I can't connect to my university's WPA/WPA2 access point. Using wpa_supplicant I get the error "4-way handshake failed - pre-shared key may be incorrect".
    So after some digging I found that I can get it to authenticate with nohwcrypt=1, but when I rmmod ath9k && modprobe ath9k nohwcrypt=1 it enumerates itself as wlan0 (instead of wlp3s0, which is what I get from booting up).
    Then I made the file /etc/modprobe.d/ath9k with the contents "options ath9k nohwcrypt=1" but it seems to still not want to connect until I rmmod && modprobe manually.
    Can someone point me in the right direction on how to fix this issue? I haven't used Arch in a few years and a lot of things have changed, and so far it seems nothing works as I expect it to. Also, how do I get my wifi card to enumerate as the same device no matter when I load ath9k? I don't care if it's called wlan0 or wlp3s0, I just want it to stay the same.
    Edit: Additional Info
    lspci
    03:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
    cat /sys/module/ath9k/parameters/nohwcrypt
    [root@huxley pobegam]# cat /sys/module/ath9k/parameters/nohwcrypt
    0
    (so I guess it isn't loading from ath9k.conf on boot after all?)
    wpa_supplicant output
    <3>CTRL-EVENT-SCAN-RESULTS
    <3>WPS-AP-AVAILABLE
    <3>CTRL-EVENT-SCAN-RESULTS
    <3>WPS-AP-AVAILABLE
    <3>CTRL-EVENT-SSID-REENABLED id=0 ssid="Student"
    <3>Trying to associate with 00:19:30:6b:1b:a2 (SSID='Student' freq=2412 MHz)
    <3>Association request to the driver failed
    <3>Associated with 00:19:30:6b:1b:a2
    <4>WPA: Failed to set PTK to the driver (alg=2 keylen=32 bssid=00:19:30:6b:1b:a2)
    <3>CTRL-EVENT-DISCONNECTED bssid=00:19:30:6b:1b:a2 reason=1 locally_generated=1
    <3>WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    <3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Student" auth_failures=2 duration=20
    <3>CTRL-EVENT-SCAN-RESULTS
    <3>WPS-AP-AVAILABLE
    wpa_supplicant configuration file
    [root@huxley wpa_supplicant]# cat sunyit.conf
    ctrl_interface=/var/run/wpa_supplicant
    update_config=1
    network={
    scan_ssid=1
    ssid="Student"
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP
    priority=1
    psk="Wireless@SUNYIT"
    Last edited by Pobega (2013-10-02 03:55:51)

    Update: It seems to work ONLY when I rmmod && modprobe; if I force nohwcrypt=1 at boot it doesn't seem to work. Seems kind of odd... Wonder if this is a kernel issue?
    Edit: Also updated with dmesg (because I'm an idiot and forgot to include it)
    [ 2.802118] hub 3-1:1.0: USB hub found
    [ 2.802210] hub 3-1:1.0: 6 ports detected
    [ 2.876377] e1000e 0000:00:19.0 eth0: registered PHC clock
    [ 2.876380] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 00:90:f5:ea:54:ff
    [ 2.876382] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
    [ 2.876418] e1000e 0000:00:19.0 eth0: MAC: 11, PHY: 12, PBA No: FFFFFF-0FF
    [ 2.876688] ACPI Warning: 0x000000000000f040-0x000000000000f05f SystemIO conflicts with Region \_SB_.PCI0.SBUS.SMBI 1 (20130517/utaddress-251)
    [ 2.876697] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    [ 2.908262] usb 4-1: new high-speed USB device number 2 using ehci-pci
    [ 2.913682] [drm] Memory usable by graphics device = 2048M
    [ 2.913687] checking generic (e0000000 7f0000) vs hw (e0000000 10000000)
    [ 2.913688] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
    [ 2.913702] Console: switching to colour dummy device 80x25
    [ 2.913836] i915 0000:00:02.0: setting latency timer to 64
    [ 2.948473] i915 0000:00:02.0: irq 47 for MSI/MSI-X
    [ 2.948482] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [ 2.948483] [drm] Driver supports precise vblank timestamp query.
    [ 2.948547] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
    [ 3.032964] hub 4-1:1.0: USB hub found
    [ 3.033016] hub 4-1:1.0: 8 ports detected
    [ 3.038244] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 3.169633] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
    [ 3.221450] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
    [ 3.237256] fbcon: inteldrmfb (fb0) is primary device
    [ 3.271526] e1000e 0000:00:19.0: irq 46 for MSI/MSI-X
    [ 3.271623] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 3.491212] Switched to clocksource tsc
    [ 4.027317] psmouse serio2: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00123/0x840300/0x126c00, board id: 2439, fw id: 1215751
    [ 4.066270] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio2/input/input7
    [ 4.477837] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
    [ 4.967580] Console: switching to colour frame buffer device 240x67
    [ 4.977758] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
    [ 4.977761] i915 0000:00:02.0: registered panic notifier
    [ 4.978457] acpi device:45: registered as cooling_device8
    [ 4.978479] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
    [ 4.978579] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input8
    [ 4.978690] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
    [ 4.978877] snd_hda_intel 0000:00:1b.0: irq 48 for MSI/MSI-X
    [ 4.979210] snd_hda_intel 0000:00:03.0: irq 49 for MSI/MSI-X
    [ 4.989927] hda_codec: invalid CONNECT_LIST verb 5[1]:0
    [ 4.989974] hda_codec: invalid CONNECT_LIST verb 6[1]:0
    [ 4.990029] hda_codec: invalid CONNECT_LIST verb 7[1]:0
    [ 4.991935] input: HDA Intel MID HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input9
    [ 4.992031] input: HDA Intel MID HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input10
    [ 4.992087] input: HDA Intel MID HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input11
    [ 4.994100] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input12
    [ 4.994171] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input13
    [ 6.977361] wlan0: authenticate with 00:1d:45:cd:c1:c2
    [ 6.987213] wlan0: send auth to 00:1d:45:cd:c1:c2 (try 1/3)
    [ 6.988904] wlan0: authenticated
    [ 6.989040] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 6.989044] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 6.989046] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 6.990123] wlan0: associate with 00:1d:45:cd:c1:c2 (try 1/3)
    [ 6.993437] wlan0: RX AssocResp from 00:1d:45:cd:c1:c2 (capab=0x431 status=0 aid=9)
    [ 6.993577] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 6.993624] wlan0: associated
    [ 6.998736] wlan0: deauthenticating from 00:1d:45:cd:c1:c2 by local choice (reason=1)
    [ 7.002835] cfg80211: Calling CRDA for country: US
    [ 24.197672] wlan0: authenticate with 00:1d:45:cd:c1:c2
    [ 24.207666] wlan0: send auth to 00:1d:45:cd:c1:c2 (try 1/3)
    [ 24.209338] wlan0: authenticated
    [ 24.209468] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 24.209472] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 24.209474] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 24.210593] wlan0: associate with 00:1d:45:cd:c1:c2 (try 1/3)
    [ 24.213338] wlan0: RX AssocResp from 00:1d:45:cd:c1:c2 (capab=0x31 status=0 aid=9)
    [ 24.213481] wlan0: associated
    [ 24.221396] wlan0: deauthenticating from 00:1d:45:cd:c1:c2 by local choice (reason=1)
    [ 24.225880] cfg80211: Calling CRDA to update world regulatory domain
    [ 50.045002] wlan0: authenticate with 00:19:30:6b:1b:a2
    [ 50.054957] wlan0: send auth to 00:19:30:6b:1b:a2 (try 1/3)
    [ 50.056639] wlan0: authenticated
    [ 50.056775] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 50.056779] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 50.056781] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 50.057899] wlan0: associate with 00:19:30:6b:1b:a2 (try 1/3)
    [ 50.061270] wlan0: RX AssocResp from 00:19:30:6b:1b:a2 (capab=0x431 status=0 aid=89)
    [ 50.061426] wlan0: associated
    [ 50.073874] wlan0: deauthenticating from 00:19:30:6b:1b:a2 by local choice (reason=1)
    [ 50.078661] cfg80211: Calling CRDA to update world regulatory domain
    [ 75.892318] wlan0: authenticate with 00:1d:45:cd:c1:c2
    [ 75.902267] wlan0: send auth to 00:1d:45:cd:c1:c2 (try 1/3)
    [ 75.904108] wlan0: authenticated
    [ 75.904254] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 75.904256] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 75.904257] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 75.905145] wlan0: associate with 00:1d:45:cd:c1:c2 (try 1/3)
    [ 75.908344] wlan0: RX AssocResp from 00:1d:45:cd:c1:c2 (capab=0x401 status=17 aid=0)
    [ 75.908348] wlan0: 00:1d:45:cd:c1:c2 denied association (code=17)
    [ 75.918844] wlan0: deauthenticating from 00:1d:45:cd:c1:c2 by local choice (reason=3)
    [ 86.045293] wlan0: authenticate with 00:19:30:6b:1b:52
    [ 86.059226] wlan0: send auth to 00:19:30:6b:1b:52 (try 1/3)
    [ 86.061328] wlan0: authenticated
    [ 86.061475] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 86.061477] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 86.061478] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 86.064853] wlan0: associate with 00:19:30:6b:1b:52 (try 1/3)
    [ 86.169949] wlan0: associate with 00:19:30:6b:1b:52 (try 2/3)
    [ 86.179194] wlan0: RX AssocResp from 00:19:30:6b:1b:52 (capab=0x431 status=0 aid=22)
    [ 86.179323] wlan0: associated
    [ 89.123073] wlan0: deauthenticated from 00:19:30:6b:1b:52 (Reason: 4)
    [ 89.147287] cfg80211: Calling CRDA for country: US
    [ 105.770381] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
    [ 105.770386] e1000e 0000:00:19.0 eth0: 10/100 speed: disabling TSO
    [ 105.770418] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 114.898216] wlan0: authenticate with 00:19:30:6b:1b:a2
    [ 114.912130] wlan0: send auth to 00:19:30:6b:1b:a2 (try 1/3)
    [ 114.914102] wlan0: authenticated
    [ 114.914235] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 114.914239] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 114.914241] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 114.914348] wlan0: associate with 00:19:30:6b:1b:a2 (try 1/3)
    [ 114.916916] wlan0: RX AssocResp from 00:19:30:6b:1b:a2 (capab=0x401 status=17 aid=0)
    [ 114.916920] wlan0: 00:19:30:6b:1b:a2 denied association (code=17)
    [ 114.937999] wlan0: deauthenticating from 00:19:30:6b:1b:a2 by local choice (reason=3)
    [ 125.064495] wlan0: authenticate with 00:19:30:6b:1b:52
    [ 125.078431] wlan0: send auth to 00:19:30:6b:1b:52 (try 1/3)
    [ 125.081945] wlan0: authenticated
    [ 125.082083] ath9k 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
    [ 125.082094] ath9k 0000:03:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
    [ 125.082095] ath9k 0000:03:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
    [ 125.084061] wlan0: associate with 00:19:30:6b:1b:52 (try 1/3)
    [ 125.098558] wlan0: RX AssocResp from 00:19:30:6b:1b:52 (capab=0x431 status=0 aid=22)
    [ 125.098683] wlan0: associated
    [ 127.937457] wlan0: deauthenticated from 00:19:30:6b:1b:52 (Reason: 4)
    [ 127.959914] cfg80211: Calling CRDA to update world regulatory domain
    Edit: I ended up solving my problem -- the issue I was running into was that ath9k was baked into my initrd without nohwcrypt=1. I opted to `mkinitcpio` again without MODULES='ath9k' -- alternatively, you could add a modprobe.d file to FILES= to get it to work, but I just figured this is simpler.
    Last edited by Pobega (2013-10-02 03:57:27)

  • [SOLVED] Trouble with running systemd user service on login

    I'm trying to get emacs to run as a systemd/user service so that it will start up faster, as suggested in the wiki article, but I'm having some problems.
    I can't get the service to run as soon as I log in. I can run the service with
    systemctl --user start emacs
    and it will run for the rest of my session, but if I try to run
    systemctl --user enable emacs
    I get the following error:
    The unit files have no [Install] section. They are not meant to be enabled
    using systemctl.
    Possible reasons for having this kind of units are:
    1) A unit may be statically enabled by being symlinked from another unit's
    .wants/ or .requires/ directory.
    2) A unit's purpose may be to act as a helper for some other unit which has
    a requirement dependency on it.
    3) A unit may be started when needed via activation (socket, path, timer,
    D-Bus, udev, scripted systemctl call, ...).
    I ran
    systemctl --user is-enabled emacs
    and that returned
    static
    but I'm not sure what that means. Any help would be greatly appreciated.
    Last edited by whitebrice (2014-06-28 17:20:13)

    Are you sure there isn't a typo in your unit file? The example you linked to in the wiki does have an [Install] section.
    Post your ~/.config/systemd/user/emacs.service file here so we can take a look.

  • Having trouble with Dynamic-to-static

    Having an issue with traffic passing over a dynamic-to-static VPN.  Phase 1 and Phase 2 both complete.  sh cry ips sa on the ASA shows 0 #pkts encaps.  From the 861 it shows 0 #pkts decaps
    I know its a lot to look at but hopefully someone will see something obvious that I messed up. 
    The second tunnel is working.  It is coming from a CradlePoint MBR1400 so I am unable to apply the config from that.
    ciscoasa# sh crypto isakmp sa
       Active SA: 2
        Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
    Total IKE SA: 2
    1   IKE Peer: 107.46.57.189
        Type    : L2L             Role    : responder
        Rekey   : no              State   : MM_ACTIVE
    2   IKE Peer: xxx.xxx.xxx.xxx
        Type    : L2L             Role    : responder
        Rekey   : no              State   : MM_ACTIVE
    ciscoasa# sh crypto ipsec sa
    interface: outside
        Crypto map tag: SYSTEM_DEFAULT_CRYPTO_MAP, seq num: 65535, local addr:
          local ident (addr/mask/prot/port): (10.10.0.0/255.255.0.0/0/0)
          remote ident (addr/mask/prot/port): (192.168.101.0/255.255.255.0/0/0)
          current_peer: 107.46.57.189
          #pkts encaps: 3166, #pkts encrypt: 3166, #pkts digest: 3166
          #pkts decaps: 2828, #pkts decrypt: 2828, #pkts verify: 2828
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 3166, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: xxx.xxx.xxx.98, remote crypto endpt.: 107.46.57.189
          path mtu 1500, ipsec overhead 74, media mtu 1500
          current outbound spi: 0D67A97D
          current inbound spi : B59B6F50
        inbound esp sas:
          spi: 0xB59B6F50 (3046862672)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 5472256, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 3020
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0xFFFFFFFF 0xFFF7FFFF
        outbound esp sas:
          spi: 0x0D67A97D (224897405)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 5472256, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 3020
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
        Crypto map tag: SYSTEM_DEFAULT_CRYPTO_MAP, seq num: 65535, local addr: xxx.xxx.xxx.98
          local ident (addr/mask/prot/port): (10.10.0.0/255.255.0.0/0/0)
          remote ident (addr/mask/prot/port): (10.10.10.0/255.255.255.0/0/0)
          current_peer: xxx.xxx.xxx.xxx
         #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
          #pkts decaps: 1041, #pkts decrypt: 1044, #pkts verify: 1044
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: xxx.xxx.xxx.xxx/4500, remote crypto endpt.: xxx.xxx.xxx.xxx/2944
          path mtu 1500, ipsec overhead 82, media mtu 1500
          current outbound spi: 9613FEAC
          current inbound spi : 186C9E40
        inbound esp sas:
          spi: 0x186C9E40 (409771584)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel,  NAT-T-Encaps, }
             slot: 0, conn_id: 5476352, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (kB/sec): (3914991/3199)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0xFFFFFFFF 0xFFFFFFFF
        outbound esp sas:
          spi: 0x9613FEAC (2517892780)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel,  NAT-T-Encaps, }
             slot: 0, conn_id: 5476352, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (kB/sec): (3915000/3198)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
    REMOTE Config  Cisco 861
    Current configuration : 3112 bytes
    ! Last configuration change at 13:07:07 UTC Mon Jan 2 2006 by jwright
    ! NVRAM config last updated at 12:10:49 UTC Mon Jan 2 2006 by jwright
    version 15.0
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service sequence-numbers
    hostname Corvid
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    logging console critical
    no aaa new-model
    memory-size iomem 10
    crypto pki trustpoint TP-self-signed-3769564853
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3769564853
    revocation-check none
    rsakeypair TP-self-signed-3769564853
    crypto pki certificate chain TP-self-signed-3769564853
    certificate self-signed 02
    ip source-route
    ip dhcp excluded-address 10.10.10.1
    ip dhcp pool ccp-pool
       import all
       network 10.10.10.0 255.255.255.248
       default-router 10.10.10.1
       lease 0 2
    ip cef
    no ip bootp server
    no ip domain lookup
    ip domain name yourdomain.com
    license udi pid CISCO861-K9 sn
    username xxxxx privilege 15 secret 5 $1$SI.
    username xxxxx privilege 15 secret 5 $1$y1
    ip tcp synwait-time 10
    crypto isakmp policy 1
    encr 3des
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key ************ address xxx.xxx.xxx.xxx
    crypto ipsec transform-set RTPSET esp-aes esp-sha-hmac
    crypto map RTP 1 ipsec-isakmp
    set peer xxx.xxx.xxx.xxx
    set transform-set RTPSET
    match address 100
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    ip address dhcp
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    crypto map RTP
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source route-map nonat interface FastEthernet4 overload
    ip route 0.0.0.0 0.0.0.0 dhcp
    logging trap debugging
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 24 permit 192.168.0.0 0.0.0.255
    access-list 100 permit ip 10.10.10.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 100 deny   ip 10.10.10.0 0.0.0.255 any
    access-list 120 deny   ip 10.10.10.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 120 permit ip 10.10.10.0 0.0.0.255 any
    no cdp run
    route-map nonat permit 10
    match ip address 120
    control-plane
    line con 0
    logging synchronous
    login local
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end
    ASA5510
    ciscoasa# sh run
    : Saved
    ASA Version 8.2(1)11
    hostname ciscoasa
    domain-name pme.local
    enable password xxx encrypted
    passwd xxx encrypted
    names
    interface Ethernet0/0
    nameif backup
    security-level 1
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    interface Ethernet0/1
    nameif inside
    security-level 100
    ip address 10.10.1.1 255.255.0.0
    interface Ethernet0/2
    shutdown
    nameif outside2
    security-level 0
    no ip address
    interface Ethernet0/3
    nameif outside
    security-level 0
    ip address xxx.xxx.xxx.xxx 255.255.255.224
    interface Management0/0
    nameif management
    security-level 100
    ip address 172.17.0.199 255.255.255.0
    management-only
    banner motd       **************************** NOTICE ******************************
    banner motd       *    Unauthorized access to this network device is FORBIDDEN!    *
    banner motd       *  All connection attempts and sessions are logged and AUDITED!  *
    banner motd       ******************************************************************
    banner motd       **************************** NOTICE ******************************
    banner motd       *    Unauthorized access to this network device is FORBIDDEN!    *
    banner motd       *  All connection attempts and sessions are logged and AUDITED!  *
    banner motd       ******************************************************************
    boot system disk0:/asa821-11-k8.bin
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns domain-lookup inside
    dns domain-lookup outside2
    dns domain-lookup outside
    dns domain-lookup management
    dns server-group DefaultDNS
    name-server HOMESTEAD-INT
    name-server SEBRING-INT
    domain-name pme.local
    object-group service SQLTEST udp
    description SQLTEST for VES
    port-object eq 1434
    object-group service SQLTEST_TCP tcp
    description SQLTEST For VES
    port-object eq 1433
    object-group service DM_INLINE_TCP_1 tcp
    port-object eq ftp
    port-object eq ftp-data
    access-list nonat extended permit ip any 10.10.11.0 255.255.255.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.10.11.0 255.255.255.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 192.168.101.0 255.255.255.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.10.10.0 255.255.255.248
    access-list outside_access_in extended permit tcp any host DAYTONA-EXT-BAK eq smtp
    access-list outside_access_in extended permit tcp any host DAYTONA-EXT-BAK eq https
    access-list outside_access_in extended permit tcp any host DAYTONA-EXT-BAK eq www
    access-list outside_access_in extended permit tcp any host SonomaBullsEye eq https inactive
    access-list outside_access_in extended permit tcp any host AUTHENTICA-EXT-BAK eq www
    access-list outside_access_in extended permit tcp any host AUTHENTICA-EXT-BAK eq https
    access-list outside_access_in extended permit udp any host xxx.xxx.xxx.xxx eq 1434
    access-list outside_access_in extended permit tcp any host xxx.xxx.xxx.xxx eq 1433 inactive
    access-list outside_access_in extended permit tcp any host FILETRANSFER-EXT-BAK eq www
    access-list outside_access_in extended permit tcp any host FILETRANSFER-EXT-BAK eq https
    access-list outside_access_in remark HTTP for TeamWeb
    access-list outside_access_in extended permit tcp any host ALEXSYS-EXT-BAK eq www
    access-list outside_access_in remark HTTPS for TeamWeb
    access-list outside_access_in extended permit tcp any host ALEXSYS-EXT-BAK eq https
    access-list outside_access_in extended deny icmp any any
    access-list Split_Tunnel_List standard permit 10.10.0.0 255.255.0.0
    access-list outside_access_in_1 extended permit tcp any host DAYTONA-EXT-OUT eq smtp
    access-list outside_access_in_1 extended permit tcp any host DAYTONA-EXT-OUT eq https
    access-list outside_access_in_1 extended permit tcp any host DAYTONA-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host Sonoma eq https inactive
    access-list outside_access_in_1 extended permit tcp any host PMEUPDATE-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host FILETRANSFER-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host FILETRANSFER-EXT-OUT eq ssh inactive
    access-list outside_access_in_1 extended permit tcp any host FILETRANSFER-EXT-OUT eq https
    access-list outside_access_in_1 remark FTPS
    access-list outside_access_in_1 extended permit tcp any host FTP-EXT-OUT object-group DM_INLINE_TCP_1
    access-list outside_access_in_1 extended permit tcp any host FTP-EXT-OUT range 60200 60400
    access-list outside_access_in_1 extended permit tcp any host AUTHENTICA-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host AUTHENTICA-EXT-OUT eq https
    access-list outside_access_in_1 extended permit tcp any host OSCODA-EXT-OUT object-group SQLTEST_TCP inactive
    access-list outside_access_in_1 extended permit udp any host OSCODA-EXT-OUT object-group SQLTEST inactive
    access-list outside_access_in_1 extended permit tcp any host ALEXSYS123-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host ALEXSYS123-EXT-OUT eq https
    access-list outside_access_in_1 extended deny icmp any any
    access-list inside_access_out extended permit ip any any log
    pager lines 24
    logging enable
    logging timestamp
    logging trap notifications
    logging asdm notifications
    logging from-address [email protected]
    logging recipient-address [email protected] level errors
    logging host inside 10.10.2.12
    logging permit-hostdown
    no logging message 302015
    no logging message 302014
    no logging message 302013
    no logging message 302012
    no logging message 302017
    no logging message 302016
    mtu backup 1500
    mtu inside 1500
    mtu outside2 1500
    mtu outside 1500
    mtu management 1500
    ip local pool IPSECVPN2 10.10.11.76-10.10.11.100
    ip local pool SSLVPN 10.10.11.101-10.10.11.200 mask 255.255.0.0
    ip local pool IPSECVPN 10.10.11.25-10.10.11.75
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-623.bin
    no asdm history enable
    arp timeout 14400
    global (backup) 1 xxx.xxx.xxx.xxx
    global (outside) 1 xxx.xxx.xxx.xxx netmask 255.255.255.224
    nat (inside) 0 access-list nonat
    nat (inside) 1 10.10.0.0 255.255.0.0
    static (inside,outside) DAYTONA-EXT-OUT DAYTONA-INT netmask 255.255.255.255
    static (inside,outside) AUTHENTICA-EXT-OUT AUTHENTICA-INT netmask 255.255.255.255
    static (inside,outside) ALEXSYS123-EXT-OUT MIDOHIO-INT netmask 255.255.255.255
    static (inside,outside) PMEUPDATE-EXT-OUT PMEUPDATE-INT netmask 255.255.255.255
    static (inside,outside) FILETRANSFER-EXT-OUT FILETRANSFER-INT netmask 255.255.255.255
    static (inside,outside) FTP-EXT-OUT FTP-INT netmask 255.255.255.255
    static (inside,backup) FILETRANSFER-EXT-BAK FILETRANSFER-INT netmask 255.255.255.255
    static (inside,backup) DAYTONA-EXT-BAK DAYTONA-INT netmask 255.255.255.255
    static (inside,backup) AUTHENTICA-EXT-BAK AUTHENTICA-INT netmask 255.255.255.255
    static (inside,backup) ALEXSYS-EXT-BAK MIDOHIO-INT netmask 255.255.255.255
    access-group outside_access_in in interface backup
    access-group inside_access_out in interface inside
    access-group outside_access_in_1 in interface outside
    route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1 track 1
    route backup 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 254
    route backup 62.109.192.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    route backup 64.68.96.0 255.255.224.0 xxx.xxx.xxx.xxx 1
    route backup 66.114.160.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    route backup 66.163.32.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    route backup 209.197.192.0 255.255.224.0 xxx.xxx.xxx.xxx 1
    route backup 210.4.192.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    timeout xlate 3:00:00
    timeout conn 24:00:00 half-closed 0:05:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    webvpn
      http-proxy enable
    aaa-server PMERADIUS protocol radius
    aaa-server PMERADIUS (inside) host HOMESTEAD-INT
    key ******
    radius-common-pw ******
    aaa authentication ssh console LOCAL
    http server enable
    http 10.10.0.0 255.255.0.0 inside
    http 172.17.0.0 255.255.255.0 management
    http redirect backup 80
    http redirect outside 80
    snmp-server location Server Room
    snmp-server contact Jay
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sla monitor 100
    type echo protocol ipIcmpEcho xxx.xxx.xxx.xxx interface outside
    timeout 3000
    frequency 10
    sla monitor schedule 100 life forever start-time now
    crypto ipsec transform-set PM1 esp-3des esp-md5-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map dyn1 1 set pfs group1
    crypto dynamic-map dyn1 1 set transform-set PM1
    crypto dynamic-map dyn1 1 set security-association lifetime seconds 28800
    crypto dynamic-map dyn1 1 set security-association lifetime kilobytes 4608000
    crypto dynamic-map dyn1 1 set reverse-route
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map cryptomap1 1 ipsec-isakmp dynamic dyn1
    crypto map cryptomap1 interface backup
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint xxx.xxx.xxx.xxx
    enrollment terminal
    fqdn xxx.xxx.xxx.xxx
    subject-name CN= xxx.xxx.xxx.xxx, O=xxxx, C=US, St=MI, L=xxxx
    keypair xxx.xxx.xxx.xxx
    crl configure
    crypto ca certificate chain xxx.xxx.xxx.xxx
    certificate 041200616c79f4
        30820577 3082045f a0030201 02020704 1200616c 79f4300d 06092a86 4886f70d
      quit
    crypto isakmp identity address
    crypto isakmp enable backup
    crypto isakmp enable outside
    crypto isakmp policy 1
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 5
    lifetime 86400
    crypto isakmp policy 50
    authentication pre-share
    encryption aes-256
    hash md5
    group 5
    lifetime 86400
    crypto isakmp nat-traversal 33
    track 1 rtr 100 reachability
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 15
    ssh version 2
    console timeout 0
    management-access inside
    threat-detection basic-threat
    threat-detection statistics port
    threat-detection statistics protocol
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 64.22.86.210 source backup prefer
    ssl trust-point vpn.prattmiller.com outside
    ssl trust-point vpn.prattmiller.com backup
    ssl trust-point vpn.prattmiller.com outside2
    webvpn
    enable backup
    enable outside2
    enable outside
    svc image disk0:/anyconnect-win-2.5.3055-k9.pkg 2
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 3
    svc profiles AllowRemoteUsers disk0:/AnyConnectProfile.xml
    svc enable
    internal-password enable
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    dns-server value 10.10.2.1
    vpn-tunnel-protocol IPSec l2tp-ipsec
    default-domain none
    group-policy DfltGrpPolicy attributes
    dns-server value 10.10.2.1 10.10.2.62
    vpn-idle-timeout 600
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value Split_Tunnel_List
    default-domain value pme.local
    webvpn
      url-list value Book1
      svc profiles value AllowRemoteUsers
      svc ask enable default webvpn timeout 10
    group-policy AnyConnect internal
    group-policy AnyConnect attributes
    vpn-tunnel-protocol webvpn
    webvpn
      svc ask enable default webvpn timeout 15
    username xxxx password RrjDgdg5BBLrGPnn encrypted privilege 15
    username xxxx password qDxllXruMJHEVZji encrypted privilege 15
    username xxxx password dGOqWbOOjP0FVxtl encrypted privilege 15
    tunnel-group DefaultL2LGroup ipsec-attributes
    pre-shared-key *
    tunnel-group DefaultRAGroup general-attributes
    default-group-policy DefaultRAGroup
    tunnel-group DefaultRAGroup ipsec-attributes
    pre-shared-key *
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group DefaultWEBVPNGroup general-attributes
    address-pool (backup) IPSECVPN2
    address-pool (outside2) IPSECVPN2
    address-pool (outside) SSLVPN
    address-pool SSLVPN
    authentication-server-group PMERADIUS
    tunnel-group pm_ipsec type remote-access
    tunnel-group pm_ipsec general-attributes
    address-pool IPSECVPN2
    tunnel-group pm_ipsec ipsec-attributes
    pre-shared-key *
    tunnel-group prattmiller type remote-access
    tunnel-group prattmiller general-attributes
    address-pool IPSECVPN
    tunnel-group prattmiller ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 1024
    policy-map global_policy
    class inspection_default
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect pptp
    class class-default
    service-policy global_policy global
    smtp-server 10.10.2.6
    prompt hostname context
    Cryptochecksum:8316029502f6698d4015f5e1b3d40a08
    : end
    [code] TEST   [/code]

    My question about this is the other Dynamic VPN that is working has no static route.
    I added:
    route outside 10.10.10.0 255.255.255.248 xxx.xxx.xxx.xxx (where xxx.xxx.xxx.xxx is the IP of the non working remote IKE Peer)
    This had no effect.
    Looking at the two tunnels.  The working tunnel is using IKE IPSEC and the nonworking tunnel is using IKE IPsecOverNatT.  What have I entered that tells the VPN to use IPsecOverNatT?

  • [solved]Trouble with Grub

    Hi,
    I just installed Arch a few hours back. The only problem I had was the grub wouldnt install. My old grub(from ubuntu) is intact though it has no arch in the menu and it has a old Windows option(I deleted windows partition while installing arch, will install it later again).
    I even edited the menu.lst from grub in ubuntu, but it still shows the old chart/list of OS. I'll post it here.
    # menu.lst - See: grub(8), info grub, update-grub(8)
    # grub-install(8), grub-floppy(8),
    # grub-md5-crypt, /usr/share/doc/grub
    # and /usr/share/doc/grub-legacy-doc/.
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not use 'savedefault' or your
    # array will desync and will not let you boot your system.
    default 0
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout 3
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    hiddenmenu
    # Pretty colours
    #color cyan/blue white/blue
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line) and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    # password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    # examples
    title Windows 95/98/NT/2000
    root (hd0,4)
    makeactive
    chainloader +1
    ###Boot Windows - test 1 ###
    Title Windows on partition 1
    rootnoverify (hd0,0)
    makeactive
    chainloader +1
    ###Boot Windows - test 2 ###
    Title Windows on partition 2
    rootnoverify (hd0,1)
    makeactive
    chainloader +1
    ###Boot Windows - test 3 ###
    Title Windows on partition 3
    rootnoverify (hd0,2)
    makeactive
    chainloader +1
    ###Boot Windows - test 4 ###
    Title Windows on partition 4
    rootnoverify (hd0,3)
    makeactive
    chainloader +1
    # title Linux
    # root (hd0,1)
    # kernel /vmlinuz root=/dev/hda2 ro
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ## kopt_2_6_8=root=/dev/hdc1 ro
    ## kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=9f847f23-7716-4b30-9b65-176789e688de
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ## alternative=false
    # alternative=true
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ## lockalternative=false
    # lockalternative=false
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash
    ## should update-grub lock old automagic boot options
    ## e.g. lockold=false
    ## lockold=true
    # lockold=false
    ## Xen hypervisor options to use with the default Xen boot option
    # xenhopt=
    ## Xen Linux kernel options to use with the default Xen boot option
    # xenkopt=console=tty0
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ## altoptions=(recovery) single
    # altoptions=(recovery mode) single
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ## howmany=7
    # howmany=all
    ## specify if running in Xen domU or have grub detect automatically
    ## update-grub will ignore non-xen kernels when running in domU and vice versa
    ## e.g. indomU=detect
    ## indomU=true
    ## indomU=false
    # indomU=detect
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ## memtest86=false
    # memtest86=true
    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false
    ## should update-grub add savedefault to the default options
    ## can be true or false
    # savedefault=false
    ## ## End Default Options ##
    title Ubuntu 10.04.2 LTS, kernel 2.6.32-27-generic
    uuid 9f847f23-7716-4b30-9b65-176789e688de
    kernel /boot/vmlinuz-2.6.32-27-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro quiet splash
    initrd /boot/initrd.img-2.6.32-27-generic
    title Ubuntu 10.04.2 LTS, kernel 2.6.32-27-generic (recovery mode)
    uuid 9f847f23-7716-4b30-9b65-176789e688de
    kernel /boot/vmlinuz-2.6.32-27-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro single
    initrd /boot/initrd.img-2.6.32-27-generic
    title Chainload into GRUB 2
    root 9f847f23-7716-4b30-9b65-176789e688de
    kernel /boot/grub/core.img
    title Ubuntu 10.04.2 LTS, memtest86+
    uuid 9f847f23-7716-4b30-9b65-176789e688de
    kernel /boot/memtest86+.bin
    # (0) Arch Linux
    title Arch Linux
    root (hd0,2)
    kernel /boot/vmlinuz26 root=/dev/sda3
    /dev/sda4 ro
    initrd /boot/kernel26.img
    # (1) Arch Linux
    title Arch Linux Fallback
    root (hd0,2)
    kernel /boot/vmlinuz26 root=/dev/sda3
    /dev/sda4 ro
    initrd /boot/kernel26-fallback.img
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    What am I doing wrong? How do I add arch to the grub menu?
    Last edited by death__machine (2011-03-04 13:23:21)

    Ok I saw that the /boot/grub/ doesnt have a grub.cfg, only menu.lst. Am really getting confused on what am supposed to edit, am guessing the grub.cfg from ubuntu but compared to menu.lst , grub.cfg is more complicated.
    # DO NOT EDIT THIS FILE
    # It is automatically generated by /usr/sbin/grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
    load_env
    fi
    set default="0"
    if [ ${prev_saved_entry} ]; then
    set saved_entry=${prev_saved_entry}
    save_env saved_entry
    set prev_saved_entry=
    save_env prev_saved_entry
    set boot_once=true
    fi
    function savedefault {
    if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
    fi
    function recordfail {
    set recordfail=1
    if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    if loadfont /usr/share/grub/unicode.pf2 ; then
    set gfxmode=640x480
    insmod gfxterm
    insmod vbe
    if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
    fi
    fi
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    set locale_dir=($root)/boot/grub/locale
    set lang=en
    insmod gettext
    if [ ${recordfail} = 1 ]; then
    set timeout=-1
    else
    set timeout=10
    fi
    ### END /etc/grub.d/00_header ###
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    ### END /etc/grub.d/05_debian_theme ###
    ### BEGIN /etc/grub.d/10_linux ###
    menuentry 'Ubuntu, with Linux 2.6.35-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    linux /boot/vmlinuz-2.6.35-22-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro quiet splash
    initrd /boot/initrd.img-2.6.35-22-generic
    menuentry 'Ubuntu, with Linux 2.6.35-22-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    echo 'Loading Linux 2.6.35-22-generic ...'
    linux /boot/vmlinuz-2.6.35-22-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro single
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-2.6.35-22-generic
    menuentry 'Ubuntu, with Linux 2.6.32-27-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    linux /boot/vmlinuz-2.6.32-27-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro quiet splash
    initrd /boot/initrd.img-2.6.32-27-generic
    menuentry 'Ubuntu, with Linux 2.6.32-27-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    echo 'Loading Linux 2.6.32-27-generic ...'
    linux /boot/vmlinuz-2.6.32-27-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro single
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-2.6.32-27-generic
    menuentry 'Ubuntu, with Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    linux /boot/vmlinuz-2.6.32-24-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro quiet splash
    initrd /boot/initrd.img-2.6.32-24-generic
    menuentry 'Ubuntu, with Linux 2.6.32-24-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    echo 'Loading Linux 2.6.32-24-generic ...'
    linux /boot/vmlinuz-2.6.32-24-generic root=UUID=9f847f23-7716-4b30-9b65-176789e688de ro single
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-2.6.32-24-generic
    ### END /etc/grub.d/10_linux ###
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    linux16 /boot/memtest86+.bin
    menuentry "Memory test (memtest86+, serial console 115200)" {
    insmod ext2
    set root='(hd0,3)'
    search --no-floppy --fs-uuid --set 9f847f23-7716-4b30-9b65-176789e688de
    linux16 /boot/memtest86+.bin console=ttyS0,115200n8
    ### END /etc/grub.d/20_memtest86+ ###
    ### BEGIN /etc/grub.d/30_os-prober ###
    menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
    insmod ntfs
    set root='(hd0,1)'
    search --no-floppy --fs-uuid --set 9810e0fb10e0e0ec
    drivemap -s (hd0) ${root}
    chainloader +1
    ### END /etc/grub.d/30_os-prober ###
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries. Simply type the
    # menu entries you want to add after this comment. Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    Ok on the top of the .cfg it says to not edit it :\
    Last edited by death__machine (2011-03-04 10:16:31)

  • [Likely SOLVED]Trouble with /etc/ip-up.d

    I've setup a pptp connection. I wanna add some routing in /etc/ip-up.d/01-tralala.sh and do it:
    [cat@cat-arch ppp]$ cat ip-up.d/01-tralala.sh
    #!/bin/sh
    route del default
    route add default gw 195.26.175.10
    #and so on
    But after that ip-up starts returning 0x7f:
    Script /etc/ppp/ip-up finished (pid 30555), status = 0x7f
    And those "route ..." don't have any effect. But if I run the script myself after the connection is brought up - it works fine.
    What am I doing wrong?
    EDIT: Same issue solved here: http://bbs.archlinux.org/viewtopic.php?id=79588
    Last edited by Mr.Cat (2010-02-01 13:51:06)

    Here is the script:
    $ cat /etc/ppp/ip-up.d/setupiptables.sh
    #!/bin/sh
    modprobe ipt_MASQUERADE
    iptables -F; iptables -t nat -F; iptables -t mangle -F
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
    iptables -A INPUT -m state --state NEW -i ! ppp0 -j ACCEPT
    As you see, I have renamed it and now will reboot to test if it works.
    BTW, is something wrong with the script? When running it iptables issues a warning which I don't understand:
    Using intrapositioned negation (`--option ! this`) is deprecated in favor of extrapositioned (`! --option this`).
    I made the script using a how-to and don't understand everything in it...

  • Trouble with Z10 backing up using link

    I have never been able to back up my Z10 using Link. I've just updated the software to the latest version of link and it still gets to about 2% (which is more than it's ever been able to do before) and then fails.
    Media synchronisation seems to work fine, it just won't backup.
    I have president's choice recipe box app, but it wouldn't back up before this either.

    Hey rcgnrcp,
    Welcome to the BlackBerry Support Community Forums.
    Thanks for the question.
    I would suggest trying a backup without including the application data.  Follow these steps:
    In BlackBerry Link click on the BlackBerry at the bottom and click on Settings at the top.  Put a checkmark for select data to include in your backup files and add checkmarks to all except Application data.  Then click on Back up now.
    Let me know if you have any more questions.
    Cheers.
    -ViciousFerret
    Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp
    Be sure to click Like! for those who have helped you.
    Click  Accept as Solution for posts that have solved your issue(s)!

  • [SOLVED] Trouble With Age of Empires 2 / Conquerors in Wine

    As the title indicates I'm trying to install and run Age of Empires 2 and the expansion Conquerors, with Wine. Looks like it should work: http://appdb.winehq.org/objectManager.p … n&iId=4184
    So first I installed wine and the video driver like this...
    pacman -Sy wine wine_gecko lib32-intel-dri
    Then, for each iso I mounted it to a new folder and ran the install file on the image with wine. Here's how I mounted each iso...
    mount -o loop aoe.iso /mnt/mydisk
    Installation of both AOE2 and the Conquerors seemed to work fine. But then when I attempted to play the game from the installation menu, popping up a "Program Error" that "the program age2_x1.exe has encountered a serious problem and needs to close." If I run AOCSETUP.EXE from the mounted iso right now, the main menu (with options "Play", "Add/Remove", "Web Connection", and "Register online") shows up but clicking "play" results in the same error. I've tried removing the dpwsockx.dll file that WineHQ mentions but it makes no difference.
    I also tried loading wine with the option for Intel graphics, but had the same error as well as the following error in the console...
    [karam@nikolai mydisk]$ env LIBGL_DRIVERS_PATH=/usr/lib32/xorg/modules/dri wine AOCSETUP.EXE
    err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": libmpg123.so.0: cannot open shared object file: No such file or directory
    err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": libmpg123.so.0: cannot open shared object file: No such file or directory
    [karam@nikolai mydisk]$ fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
    fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
    fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
    fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
    fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
    fixme:alsa:AudioClient_GetMixFormat Don't know what to do with 10000 channels, pretending there's only 2 channels
    wine: Unhandled page fault on write access to 0xcf8672fe at address 0x40d774 (thread 003b), starting debugger...
    [karam@nikolai mydisk]$
    Does anyone have any ideas?...
    Last edited by tony5429 (2011-11-09 04:43:40)

    Are you on x86_64? Might wanna run WINEARCH=win32 winecfg (wiki entry for winearch). WINE works with the video drivers that you use for xorg not sure if you really need to specify that intel-dri driver.
    Another thing that works quite well for me is make sure the current working directory is the game directory, then use wine to run the .exe. I recently installed Anachronox and if I try to launch it from outside the game directory i get missing dll errors also, even though the dlls are present in the game directory.
    Also did you follow the following How-To steps on the WINE game page?
        The game must be set to Windows 2000 compatibility. (seems to play equally well with XP mode too, though.)
        This game requires a NoCD patch to run. (you can play using aocsetup.exe from the cd, if you can’t afford to NoCD)
        If the game wont start (and wine hasn’t hang up(pkill wine && pkill exe)), either remove dpwsockx.dll from your system32 folder or follow the steps for multi-player below. ¹
    Last edited by KingX (2011-11-01 08:25:10)

Maybe you are looking for