Stuck... Pease need help passing variable

Hi all....
I have an event listener added and it calls a function.
Adding the event listener passes the event to the function
automatically but what if i want to pass additional information to
it?
So this:
addEventListener(Event.ENTER_FRAME, doEveryFrame);
Becomes this
addEventListener(Event.ENTER_FRAME,
doEveryFrame(extra_var_passed));
function doEveryFrame(event:Event,
extra_var_passed:Number):void {
//code here
It seems because I am trying to pass a new variable it no
longer passes the event for me auto-magically.... how I go about
passing that event myself?
Is it possible to even pass another variable like
this??

This is AS3, correct?
You need to create your own event object that has the
properties you need to pass.
Take a look at the tutorial on custom events here:
http://www.8bitrocket.com/newsdisplay.aspx?newspage=5776

Similar Messages

  • Need help passing variables to another jsp page

    I am working in a shopping cart with multiple lines and I am wanting to pass 2 variables to another page which is accessed from a link.
    What I have so far is the following:
    This is on the shopping cart JSP page with the link
    <input type="hidden" name="shopCartReqDate1<%=i%>" id="shopCartReqDate1<%=i%>" value="<%= retVals[9] %>">
    <input type="hidden" name="shopCartExpDate1<%=i%>" id="shopCartExpDate1<%=i%>" value="<%= retVals[10] %>">
    Need it Earlier?
    I am wanting to pass it to the HAC_Help_Text_Need_it_Earlier.jsp page
    Right now on the HAC_Help_Text_Need_it_Earlier.jsp page I have the following code:
    String shopCartReqDate1 = IBEUtil.nonNull(request.getParameter("shopCartReqDate1"));
    String shopCartExpDate1 = IBEUtil.nonNull(request.getParameter("shopCartExpDate1"));
    Do I need to create a function and do a document.getElementById?
    Thanks for the help!

    As far as I understand your question You don't have to use document.getElementById. Just submit the form and then on the next page You'll just pull the variables out from the request object.

  • I am an ASP programmer and need help passing variable in JSP

    When I pass a value using a variable string that grabs the user name of a current windows session it adds spaces after each character. it should pass jdt3 and it passes j d t 3. It is grabbing the correct info. It writes the value to a web page correctly though. I really appreciate the assistance.
    <%@ page import="sun.misc.BASE64Encoder" %>
    <p><h1>Network Windows USERNAME without any login (ie)</h1></p>
    <%
    String auth = request.getHeader("Authorization");
    if (auth == null) {
    response.setStatus(response.SC_UNAUTHORIZED);
    response.setHeader("WWW-Authenticate", "NTLM");
    return;
    if (auth.startsWith("NTLM ")) {
    byte[] msg =
    new sun.misc.BASE64Decoder().decodeBuffer(auth.substring(5));
    int off = 0, length, offset;
    String s;
    if (msg[8] == 1) {
    off = 18;
    byte z = 0;
    byte[] msg1 =
    {(byte)'N', (byte)'T', (byte)'L', (byte)'M', (byte)'S',
    (byte)'S', (byte)'P', z,
    (byte)2, z, z, z, z, z, z, z,
    (byte)40, z, z, z, (byte)1, (byte)130, z, z,
    z, (byte)2, (byte)2, (byte)2, z, z, z, z, //
    z, z, z, z, z, z, z, z};
    response.setStatus(response.SC_UNAUTHORIZED);
    response.setHeader("WWW-Authenticate", "NTLM "
    + new sun.misc.BASE64Encoder().encodeBuffer(msg1).trim());
    return;
    else if (msg[8] == 3) {
    off = 30;
    length = msg[off+17]*256 + msg[off+16];
    offset = msg[off+19]*256 + msg[off+18];
    s = new String(msg, offset, length);
    //out.println(s + " ");
    else
    return;
    length = msg[off]*5 + msg[off];
    offset = msg[off+3]*5 + msg[off+2];
    s = new String(msg, offset, length);
    //out.println(s);
    length = msg[off+9]*5 + msg[off+8];
    offset = msg[off+11]*5 + msg[off+10];
    s = new String(msg, offset, length);
    out.println(s + "</SPAN>");
    String redirectURL = "http:www.intranet.com?UName="+s;
    response.sendRedirect(redirectURL);
    %>
    </BODY>

    Open AirPort Utility on the PC, select the Airport Extreme and click Manual Setup
    Click the Advanced icon
    Click the Port Mapping tab
    Click the + (plus) button at the bottom of the connection list to set things up
    Reference pages 49-51 in the Apple AirPort Networks guide for more info
    IF.....you do not see a Port Mapping tab when you click the Advanced icon, then that would mean that the AirPort Extreme is in Bridge Mode and the main routing functions for the network are being provided by another device.
    You will need to set up the port mapping on that device, which is likely your modem/router or gateway.

  • I cant transfer purchase apps to my itunes. I go to file and click transfer but nothing happens. I am trying to update my iphone but it says you need to transfer purchase apps. So i am now stuck i need help!!!

    I go to file and click transfer but nothing happens. I am trying to update my iphone but it says you need to transfer purchase apps. So i am now stuck. i need help!!!

    Click here, follow the instructions, and choose Transfer Purchases in the File menu.
    (79456)

  • Need Help in Variable calculation

    Hi,
    I am using BO XI 3.0 with Oracle as reporting database.
    I need help or suggestion in one of my cross-tab webi report. I designed the report as below.
    Date1----
    Date2
    Dim1---Dim2-Dim3-Meas1(Sum)-Meas2(Sum) |Meas3(Sum)-Meas4-Meas3---Meas4 
    111 -
    ABC---xyz   - 14 - 12 -13 - 1121--
    12
    222 -
    LMP---asd   - 22 -  32 -  01 0511--
    56
    In above crosstab report dates are one of the dimension with other dimensions.
    Now In my scenarion for date1 and date2 i have same dim1, dim2 and dim 3 so it showing me dingle row instead of 2 rows due to that Meas1 and Meas2 are sum up and as 14 and 12 but i need to display Meas1 as (Meas1 where Date=date2) and Meas2 as (Meas2 where date=date2) so instead of summing of 2 rows it should display only data for that date.
    If i move meas1 and 2 along with meas3 and 4 it fine but if remove from their and place on left side or dimension it sum up.
    If anyone has any idea please help me on this.
    Thanks for the help.
    Thanks,
    Nimesh.
    Edited by: Nimesh Panchal on Apr 13, 2009 11:39 PM

    Hi,
    Please make changes like below
    if(empRow.getLinenum().toString()!=null)
    String updateStmt = "BEGIN TEST_PKG.MAIN_PROCEDURE( " +":1)" + "; END;";
    CallableStatement cstmt = getDBTransaction().createCallableStatement(updateStmt,1);
    cstmt.setString(1,empRow.getLinenum().toString());
    Also, refer link Dilip'S Oracle Application Framework Blogs: Prepared Statement - Controller
    Thanks,
    Dilip

  • I am Stuck! Need Help With Multicast Streaming Using VLC Player

    I have a Multicast network topology shown below
    and my configs
    HUB ROUTER
    no ip domain lookup
    ip domain name primestarhotel.com
    ip multicast-routing
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip pim sparse-dense-mode
    interface FastEthernet0/0
    ip address 200.0.0.2 255.255.255.240
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.65
    description "Server Vlan"
    encapsulation dot1Q 65
    ip address 10.1.65.1 255.255.255.0
    ip pim sparse-dense-mode
    ip virtual-reassembly
    router ospf 200
    log-adjacency-changes
    network 5.5.5.5 0.0.0.0 area 0
    network 10.1.65.0 0.0.0.255 area 0
    network 200.0.0.0 0.0.0.15 area 0
    ip route 200.1.1.0 255.255.255.252 200.0.0.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    no ip http server
    no ip http secure-server
    ip pim send-rp-announce Loopback0 scope 6
    ip pim send-rp-discovery Loopback0 scope 6
    ISP ROUTER
    interface FastEthernet1/0
    interface FastEthernet1/1
    no switchport
    ip address 200.0.0.1 255.255.255.240
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/2
    no switchport
    ip address 200.1.1.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/3
    no switchport
    ip address 200.2.2.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    router ospf 200
    log-adjacency-changes
    network 200.0.0.0 0.0.0.15 area 0
    network 200.1.1.0 0.0.0.3 area 0
    network 200.2.2.0 0.0.0.3 area 0
    SPOKE 1 Router
    interface FastEthernet0/0
    ip address 200.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    no ip address
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.12
    description "Workstation pc"
    encapsulation dot1Q 12
    ip address 10.1.12.1 255.255.255.0
    ip pim sparse-dense-mode
    router ospf 200
    log-adjacency-changes
    network 10.1.12.0 0.0.0.255 area 0
    network 200.1.1.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.1.1.1
    SPOKE 2
    interface FastEthernet0/0
    ip address 200.2.2.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    ip address 10.2.22.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    router ospf 200
    log-adjacency-changes
    network 10.2.22.0 0.0.0.255 area 0
    network 200.2.2.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.2.2.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    I have implemented multicast on the network in a hub and spoke topology. i have set up ospf routing protocol and broadcast all network and can successfully ping.
    I am currently using VLC player as my media streaming server and client. i have set up rtp streaming from the HUb router using multicast ip 224.2.2.2 and unable to broadcast the multicast traffic across the spokes 1 and 2 PC's
    I have never used vlc player  never set up multicast network before and i am struggling with this and need help.
    these are my router configs below
    http://dl.dropbox.com/u/20145606/ip%20video%20config.txt
    Message was edited by: Louis Ojuwu

    I have edited the message and the configs and topology are visible above now. instead of the links i provided

  • Need HELP passing raw SOAP to JAX-RPC Web Service

    Ive recently downloaded the web services development kit from the SUN site and have got all the examples to work fine.
    What I am now trying to do is pass RAW SOAP to the HelloWorld JAX-RPC example,
    Ive managed to get the service to call the sayHello function with no params which returns 'Hello NULL'.
    I can't however get any parameters to be passed to the sayHello function,
    Below is the existing SOAP ive got calling the function with no params.
    <?xml version="1.0"?>
    <soap:Envelope soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><sayHello xmlns="http://hello.org/wsdl">????????????</sayHello></soap:Body></soap:Envelope>
    If anybody could tell me what I need to replace ???????????? with then I would be more than gratefull.
    P.s If I changed the webservice to accept multiple arguments what would I need to put in my SOAP?
    Yours,
    Cris.

    Thanks for your help on this one. However there is still one thing I don`t understand.
    In the example SOAP I posted on the orignal message I have added the namespace ns1 pointing to
    http://hello.org/wsdl
    The example you posted goes to http://caller.org/wsdl
    below is SOAP you posted for me.
    <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
    xmlns:ns0="http://caller.org/wsdl"
    env:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
    <env:Body>
    <ns0:sayHello>
    <String_1 xsi:type="xsd:string">some text</String_1>
    </ns0:sayHello>
    </env:Body>
    </env:Envelope>
    This returns me an error! However If I change ns0 to point to http://hello.org/wsdl it all works perfectly.....
    If you open a browser and go to http://hello.org/wsdl OR http://caller.org/wsdl neither URL points to anything!!!!!!! All the other namespaces used point to valid XML Schemas, which makes sense.
    So how can this SOAP message work if the namespace ns0 is nothing???????????
    Yours,
    Cris.

  • I need help passing a value to a method.

    Im fairly new to java.
    I have this JSP that i would like to ultimately write it as a servlet. So if any one can help out with this as well, that would be great.
    There's a code snippet at the bottom of my code that looks like this
            String operation = request.getParameter("actionMethod");
         String areaId = request.getParameter("areaId");
         List list = listOrders();I was wondering how i could pass the areaId value to the listOrders. That way i could use that to modify my sql depending on what areaid was selected.
    here's a copy of my code.
    <%@ page language="java" contentType="text/html; charset=UTF-8" pageEncoding="UTF-8"%>
    <%@ page import="java.sql.*,java.util.*"%>
    <%@ page import="com.fins.gt.server.*"%>
    <%@ page import="com.fins.gt.util.*"%>
    <%!
         // Eventually needs re-written as a servlet
         Connection getConnection(){
              String url="jdbc:as400://bigblue";
              Connection conn= null;
              try{
                   Class.forName("com.ibm.as400.access.AS400JDBCDriver").newInstance();
                   conn = DriverManager.getConnection(url,"prodtasv","prodtasv");
              }catch(Exception e){
              return conn;
         void closeConnection(Connection conn){
              try{
                   conn.close();
              }catch(Exception e){
         List listOrders(){
            Connection conn = getConnection();
            if(conn==null)
                    return new ArrayList();
            Statement stmt = null;
            ResultSet rs = null;
            List list = new ArrayList();
            try{
                 stmt = conn.createStatement();
                 rs = stmt.executeQuery("SELECT * FROM AIMDATA.DVCR_AREA_LOOKUP");
                 while(rs.next()){
                        Map map = new HashMap();
                        map.put("AREAID",new Long(rs.getLong("AREAID")));                    
                        map.put("SICD",rs.getString("SICD"));
                        map.put("SKCD",rs.getString("SKCD"));
                        map.put("DESCRIPTION",rs.getString("DESCRIPTION"));
                        list.add(map);
                 rs.close();
                 stmt.close();
            }catch(Exception e){
            closeConnection(conn);
            return list;
    %>
    <%
         // GridServerHandler is server side wrapper, you can get all the info posted to server in your Java way instead of JavaScript
         GridServerHandler gridServerHandler=new GridServerHandler(request,response);
         String operation = request.getParameter("actionMethod");
         if("save".equals(operation)){
         }else { //client is retrieving data
              List list = listOrders();
             //get how many records we are sending
              int totalRowNum= list.size();
              gridServerHandler.setTotalRowNum(totalRowNum);
              //if you would like paginal output on server side, you may interested in the following 4 methods
              // gridServerHandler.getStartRowNum() first record no of current page
              // gridServerHandler.getEndRowNum() last record no of current page
              // gridServerHandler.getPageSize() how many records per page holds
              // gridServerHandler.getTotalRowNum() how many records in total
              // we take map as this sample, you need to use gridServerHelp.setData(list,BeanClass.class); to deal with bean
              gridServerHandler.setData(list);
                // gridServerHandler.setException("your exception message");
              //print out JSON string to client
              out.print(gridServerHandler.getLoadResponseText());          
              //you could get the posted data by calling gridServerHandler.getLoadResponseText() and obtain more flexibility, such as chaning contentType or encoding of response.
    %>

    Sorry i uploaded the wrong code and the edit wasn't working for me.
    <%@ page language="java" contentType="text/html; charset=UTF-8"
         pageEncoding="UTF-8"%>
    <%@ page import="java.sql.*,java.util.*"%>
    <%@ page import="com.fins.gt.server.*"%>
    <%@ page import="com.fins.gt.util.*"%>
    <%!Connection getConnection() {
              String url = "jdbc:as400://bigblue";
              Connection conn = null;
              try {
                   Class.forName("com.ibm.as400.access.AS400JDBCDriver").newInstance();
                   conn = DriverManager.getConnection(url, "prodtasv", "prodtasv");
              } catch (Exception e) {
              return conn;
         void closeConnection(Connection conn) {
              try {
                   conn.close();
              } catch (Exception e) {
         List listOrders() {
              Connection conn = getConnection();
              if (conn == null)
                   return new ArrayList();
              Statement stmt = null;
              ResultSet rs = null;
              List list = new ArrayList();
              try {
                   stmt = conn.createStatement();
                   rs = stmt
                             .executeQuery("SELECT * FROM AIMDATA.DVCR_DETAIL WHERE AREAID = 1");
                   while (rs.next()) {
                        Map map = new HashMap();
                        map.put("DETAILID", new Long(rs.getLong("DETAILID")));
                        map.put("AREAID", new Long(rs.getLong("AREAID")));
                        map.put("DVCRID", new Long(rs.getLong("DVCRID")));
                        map.put("DEFECTID", new Long(rs.getLong("DEFECTID")));
                        map.put("DESCRIPTION", rs.getString("DESCRIPTION"));
                        map.put("WRNO", new Long(rs.getLong("WRNO")));
                        map.put("WRLINENO", new Long(rs.getLong("WRLINENO")));
                        list.add(map);
                   rs.close();
                   stmt.close();
              } catch (Exception e) {
              closeConnection(conn);
              return list;
         }%>
    <%
         // GridServerHandler is server side wrapper, you can get all the info posted to server in your Java way instead of JavaScript
         GridServerHandler gridServerHandler = new GridServerHandler(
                   request, response);
         String operation = request.getParameter("actionMethod");
         String areaId = request.getParameter("areaId");
         List list = listOrders();
         //get how many records we are sending
         int totalRowNum = list.size();
         gridServerHandler.setTotalRowNum(totalRowNum);
         // we take map as this sample, you need to use gridServerHelp.setData(list,BeanClass.class); to deal with bean
         gridServerHandler.setData(list);
         // gridServerHandler.setException("your exception message");
         //print out JSON string to client
         out.print(gridServerHandler.getLoadResponseText());
         //you could get the posted data by calling gridServerHandler.getLoadResponseText() and obtain more flexibility, such as chaning contentType or encoding of response.
    %>

  • Need help sending variables from HTML to SWF...

    I have a header with tab buttons--- When you are on a certain
    page the coorisponding tab is a different color(as a locator).
    Right now I have like, 7 or 8 different headers that are the
    same thing minus the colored tab of the current page.
    Is there a way to code the flash so that I only need one
    header, but still keep the off-colored buttons when on the
    coorisponding page?
    Apparently, from what I have gathered I need to Send a
    variable to the SWF from the embedding HTML using FlashVars or
    SWFObjects' 'addVariable' method etc so the SWF knows which
    tab/color to use.
    But, I have no ideal where to start...uugggggg.
    Any Suggestions????
    I really, really need to figure this out.
    Thanks in advance,
    hutch

    the easiest way to pass vars to the flash is by appending
    them to the url of the flash:
    e.g your swiff is called "mymovie.swf" and you want a
    parameter "color" to be available on the _root level of your movie,
    so all you have to do is embed the flash with the following url
    into your html page:
    "mymovie.swf?color=black"
    now back in flash you can get the value of "color" like this:
    in _root timeline:
    color
    in any other timeline:
    _root.color
    the value will be filled once the movie is called from within
    the HTML as explained above

  • Need help pass in date parameter into bat file.

    Is it possible to schedule sql job to execute bat files and pass in date below.
    I want to take a system date and pass into the bat file below.  A Schedule Job will run on Monday at 9 P.M.
    I want to automate this process instead manually enter into the bat file.  Is that possible?
    Any suggestions is appreciate.  SQL 2012
    Thank you so much in advance.
    SQL Schedule job
    DECLARE @sMonday VARCHAR(25) = REPLACE(CONVERT(VARCHAR(10), GETDATE(), 1), '/', '')
    SET @sMonday = @sMonday + '_qa48_Clonedb'
    SELECT @sMonday
    --021315_qa48_Clonedb
    DECLARE @sPrevMonday VARCHAR(25) = CAST(REPLACE(CONVERT(CHAR(10), DATEADD(DAY, - (DATEPART(dw, GETDATE() ) - 1), GETDATE() ),1), '/', '') AS CHAR(6))
    SET @sPrevMonday= @sPrevMonday + '_qa48_Clonedb'
    SELECT @sPrevMonday
    --020815_qa48_Clonedb
    Result want:
    -- Testbatfile.bat
    REM 021615_qa48_Clonedb
    SET sToday = @sMonday        
    SET sPreviousWeek = @sPrevMonday
    SET sNumOfDay=07
    DiskMirror -l snapsrvcfdba n4brec01a -i privkey.ppk "snap rename sql32oltp_repl_dataf sqlsnap__brpRMSDVS050a__recent %sToday% "
    DiskMirror -l snapsrvcfdba n4brec01a -i privkey.ppk "snap rename sql32oltp_repl_logf  sqlsnap__brpRMSDVS050a__recent %sToday% "
    DiskMirror -l snapsrvcfdba l9ABC01d -i privkey.ppk "snap rename sql100oltp_repl_dataf %sPreviousWeek% sqlsnap__ABCPWSCVR050a__%sNumOfDay% "

    See
    https://sharminjahan625.wordpress.com/2013/08/30/384/
    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

  • Need help passing Sales Order header text to PO header texts

    I would really appreciate if someone can help me with this. I am able to pass the line item texts using configuration (text linkage) but SAP does not provide a way to pass header level texts to PO.  Any help is appreciated.

    Message was edited by: B P
    Message was edited by: B P
    Message was edited by: B P

  • Need help generating variable name for timeout object

    Below is a function I am using to scale an object down and
    then hide it. It works fine on just one object, but if I try to run
    it on multiple objects at the same time, only the last object gets
    scaled down. I believe this is because the timeout list only ever
    has a single item in it, “ShrinkTimeOut”.
    Does each entity in the timeout list need a distinct name?
    And if so, how would I dynamically generate a name and save it so I
    can kill the timeout object once the object has scaled down fully?

    > Does it look like I am getting rid of the timeout object
    properly in my code?
    Now that you mention it, and I have a look, no - it doesn't:
    //not sure of the order of parameters here:
    function fShrinkLoop(mModel, aTimeout) {
    //Creates a variable that contains the vector value of the
    model's
    scale (vector( 1.0000, 1.0000, 1.0000 )).
    nScaleVector = mModel.getPropRef("transform").scale;
    //Checks to see if the model is 1% or less than its original
    size.
    if (nScaleVector[1]<=0.01) {
    //Makes the model invisible.
    mModel.visibility = symbol("none");
    //Kills the timeout object.
    aTimeout.forget();
    } else {
    //If it is not, we scale the model down further and allow
    the loop to
    repeat.
    mModel.scale(0.9);

  • [Help]Need help with variables php,Sql

    I have a table users contain fiedls "old,new & total"
    when submit , update users SET total = $total
    where $total = $old+$new
    I did this , I used echo to make sure it is ok , but it is not :
    /* Variable to Count Total  */
    $old=$row_rs_users['old'];
    $new=$row_rs_users['new'];
    $total=$old+ $new;
    echo $total;
    if ((isset($_POST["MM_update"])) && ($_POST["MM_update"] == "doit_form")) {
      $updateSQL = sprintf("UPDATE users SET total=%s WHERE id=%s",
                           $total,
                           GetSQLValueString($_POST['id'], "int"));
    Thanks,

    Seeing only part of your code, it's impossible to debug.
    However, your approach is wrong anyway. All you need to do is to add the new value to the old one in the SQL query.
    $updateSQL = sprintf("UPDATE users SET total=(total+%s) WHERE id=%s",
                           GetSQLValueString($_POST['fieldName'], "double"),
                           GetSQLValueString($_POST['id'], "int"));
    $_POST['fieldName'] is the new value being added. Use "double" if the value contains a decimal point. If it's an integer, change "double" to "int".

  • Need help on variables in webapplication

    Hello Community,
    I have a problem within a query.
    0) I am using only 1 keyfigure Z_WEIGHT
    1) I am using 2 variables on 0CALYEAR which are filled with a date range of start year and end year.
    e.g. 2005 - 2008
    2) The period for 2005 starts from: 12/2004 - 12/2005
    How can I solve this scenario?
    Any help is highly appreciated.
    Andreas

    Hi thanks for your reply.
    But I dont want a variable screen - i want a pull down menu for selecting in the query.
    Any ideas about that?
    Thanks,
    Andreas

  • I need help with Variable Manipulation

    I've been searching on google for over an hour and a half to find Variable manipulation. It seems either you know how to do it or you don't. I'm trying to do 3 things:
    I want a text box in which I enter text and it manipulates a variable so that when I press enter, the variable becomes that text.
    I want to be able to at the click of a button either assign a variable or add to that variable, whether it be incrementing or adding larger numbers.
    Finally, I want to be able to reveal those variable either at the click of a button or when the frame of the scene I'm making starts.
    Could someone please explain to me either how to do it or where to look so I can teach myself?

    Ok...after creating what you are looking for I think your confusion may be in global variables initialization with Director vs other languages.   Within Director it is necessary to reintialize the global variable within each script you need to access it in.
    So what I have done is create a two slide movie...for lack of better names slide 1 and slide 2.
    Step 1:  create the PrepareMovie Script - this script preloads the field (text box) with  "type your name".  In this case I just assigned "type your name" to the playerName global varialble.
    On prepareMovie
      global playerName
      playerName="type your name"
      member("fName").text=playerName
    end
    Step 2:
    Place cast members into slide 1
    your name - text cast member
    fname - field cast member
    continue - sprite button
    Step 3:
    Place cast members into slide 2
    verify - text cast member
    recall - sprite button
    reveal - text cast member
    Result should look something like this in the score:
    Step 4:  Scripts
    Script 6 is nothing more than a "go to the frame" script to keep the play head in place.
    on exitFrame me
      go to the frame
    end
    Script 7 just under the Slider 2 Marker
    on prepareframe me
      global playerName
      member("verify").text="Just to be certain your name is " & playerName
    end
    The Continue Button Script - attach this to the button as button script
    on mouseUp
      global playerName
      ---stuff within the field box
      playerName=member("fname").text
      go to next
    end
    The Reveal Button Script
    on mouseUp me
      global playerName
      member("revealname").text=playerName
    end
    Thats it really....if its your first time using global variables inside director it can be a bit confusing if you are used to other programming languages.
    Good luck

Maybe you are looking for

  • Oracle forms 6i (Pentium 4, Win98) "Can not install"

    I have a "customized" Oracle interface that was created in Oracle forms 6. I have successfully used this form on Windows 95 Clients but now I must switch to a Windows 98 O/S on a Pentium 4 machine. I actually had to download a special Oracle Installe

  • Missing emails in Mail

    After I remove Yahoo account from Mail in OS X 10.7.2, all the yahoo emails no longer display inside Mail. How to find them back/ They do not exist in the Yahoo Server anymore as Mail 'sucked' them out when I added Yahoo to Mail initially.

  • Record Type Constructors in Packages

    I am having trouble getting past this error. Here is an example of my code: create or replace PACKAGE MyPackage AS   TYPE MyPerson IS RECORD ( "NAME"  VARCHAR2(255 CHAR) );   FUNCTION GetPerson RETURN MyPerson; END MyPackage; create or replace PACKAG

  • Missing hostname in DHCP Client Table???

    I give up. I've searched the internet for an answer to why my mac's hostname does not show up in my WRT54G's DHCP Client Table and come up empty. I see host names for my windows and linux boxes, but not my macbook pro. Anyone have a clue? Thanks, Ste

  • How to get addresses into iphoto

    My iphoto is ready to email my picture but I am unable to bring up all my email addresses. Can someone advise me on how I can achieve that pls?